Вы находитесь на странице: 1из 7

El Hassan EL AMRI Frame Relay

Campus des Rseaux Informatiques et Tlcommunications

Frame Relay
I. Introduction

F
rame Relay est un protocole de rseau tendu (WAN) qui intervient dans les couches physique
et liaison de donnes du modle de rfrence OSI. Bien que de nouveaux services tels que le
haut dbit et le mtro Ethernet ont rduit les besoins Frame Relay dans de nombreux endroits,
ce type de connexion reste une option viable dans de nombreux endroits partout dans le monde. Frame
Relay est une solution conomique de communication entre plusieurs sites distants, qui utilise un seul
circuit d'accs entre chaque site et le fournisseur.

II. Prsentation de Frame Relay


Les lignes loues offrent une capacit ddie permanente. Elles sont trs largement utilises pour la
cration de WAN. Elles reprsentent le choix traditionnel en matire de connexion, mais prsentent un
certain nombre d'inconvnients. Un de ces inconvnients et que les clients payent pour des lignes
loues de capacit fixe. Cependant, le trafic WAN est souvent variable et une partie de cette capacit
n'est pas utilise. Par ailleurs, chaque point d'extrmit requiert une interface physique spare sur le
routeur, ce qui augmente les cots d'quipements. Toute modification de la ligne loue ncessite
gnralement une intervention sur site du personnel de l'oprateur.

Frame Relay est un protocole de rseau tendu (WAN) qui intervient dans les couches physique et
liaison de donnes du modle de rfrence OSI. l'inverse des lignes loues, Frame Relay ne
ncessite qu'un seul circuit d'accs au fournisseur Frame Relay pour communiquer avec les autres sites
connects au mme fournisseur. La capacit entre deux sites peut varier.

II.1 Avantages de la technologie WAN Frame Relay


Avec l'arrive de services haut dbit tels que le DSL, le modem cble, le WAN Ethernet (service
Ethernet point point sur fibre optique), le VPN et le MPLS, Frame Relay a perdu de son intrt
comme solution d'accs au WAN. Cependant, la solution Frame Relay est toujours utilise pour la
connexion WAN dans certains endroits du monde.

Plus la distance couverte par une ligne spcialise est importante, plus le service est
coteux.
Les rseaux commutation de paquets fournissent un multiplexage de nombreuses
donnes travers un seul lien de communication.
Si 2 sites distants veulent communiquer via Frame Relay, ils ont donc juste constituer un
circuit entre ces sites, travers le rseau Frame Relay.

III. Fonctionnement de la technologie Frame Relay


III. 1 Circuits virtuels (VC)
Au sein du nuage Frame Relay, la connexion entre deux sites se fait par l'intermdiaire de
circuits virtuels qui peuvent tre tablis en dur par le fournisseur, Les circuits virtuels offrent un
chemin pour la communication bidirectionnelle d'un priphrique un autre. Les circuits virtuels
sont identifis par les DLCI.

Les circuits virtuels peuvent s'tablir de deux manires :

El Hassan EL AMRI 1
El Hassan EL AMRI Frame Relay

Circuits virtuels commuts (SVC, Switched Virtual circuits) : tablis de faon dynamique
par l'envoi de messages de signal au rseau (CALL SETUP, DATA TRANSFER, IDLE, CALL
TERMINATION).

Circuits virtuels permanents (PVC, Permanent Virtual Circuits) : prconfigurs par


l'oprateur, une fois mis en place, ils ne fonctionnent qu'en mode DATA TRANSFER ou IDLE.
Notez que dans certaines publications, les circuits virtuels permanents sont appels circuits
virtuels privs.

Remarque : les circuits virtuels permanents sont plus souvent utiliss que les circuits
virtuels commuts.

III.2 DLCI
Un indicateur DLCI identifie un circuit virtuel sur un quipement situ une extrmit. Au-del
de la liaison, ce DLCI n'a aucune signification. Deux priphriques connects par un circuit
virtuel peuvent utiliser une valeur DLCI diffrente pour faire rfrence la mme connexion.

IV. Encapsulation Frame Relay


Tout d'abord, Frame Relay accepte le paquet d'un protocole de couche rseau, par exemple IPv4.
Il ajoute ensuite un champ d'adresse qui contient le DLCI et une somme de contrle. Des champs
d'indicateur sont ajouts pour indiquer le dbut et la fin de la trame. Ces champs marquent le dbut
et la fin de la trame et sont toujours les mmes. Ces indicateurs sont reprsents soit en
hexadcimal par 7E, soit en binaire par 01111110. Une fois le paquet encapsul, Frame Relay
passe la trame la couche physique qui assure le transport.

Le routeur d'quipement d'abonn encapsule chaque paquet de couche 3 dans un en-tte et un


code de fin Frame Relay avant de l'envoyer sur le circuit virtuel. L'en-tte et le code de fin sont
dfinis par la spcification Link Access Procedure for Frame Relay (LAPF) Bearer Services, UIT
Q.922-A. Comme illustr la Figure 2, l'en-tte Frame Relay header (champ d'adresse) contient
les lments suivants :

DLCI : le DLCI 10 bits est un des champs les plus importants de l'en-tte Frame Relay. Cette valeur
reprsente la connexion virtuelle entre l'quipement ETTD et le commutateur. Chaque connexion
virtuelle multiplexe sur le canal physique est reprsente par un DLCI unique. Les identificateurs
DLCI n'ont qu'une signification locale. En d'autres termes, ils ne sont uniques que sur le canal
physique sur lequel ils rsident. Les quipements situs l'autre extrmit d'une connexion peuvent
donc faire rfrence la mme connexion virtuelle par des identificateurs DLCI diffrents.

C/R : bit qui suit l'octet DLCI significatif dans le champ d'adresse. Le bit C/R n'est pas actuellement
dfini.

EA (Extended Address) : si la valeur du champ EA est 1, l'octet actuel est considr comme le
dernier octet DLCI. Toutes les mises en uvre actuelles du protocole Frame Relay utilisent
cependant un DLCI de 2 octets, ce qui permet une extension des adresses DLCI dans le futur. Le
huitime bit de chaque octet du champ d'adresse sert indiquer une adresse tendue.

Contrle d'encombrement : compos de trois bits de notification d'encombrement Frame Relay.


Ces trois bits sont appels FECN (Forward Explicit Congestion Notification), BECN (Backward
Explicit Congestion Notification) et DE (Discard Eligible).

El Hassan EL AMRI 2
El Hassan EL AMRI Frame Relay

V. Topologies Frame Relay


Frame-relay supporte multiple topologies :

1) Full-mesh (Topologie maillage global)


2) Partial-mesh (Topologie maillage partiel)
3) Hub and Spoke (Topologie en toile)

VI. Mappage des adresses Frame Relay

VI.1 ARP inverse

Un des outils principaux de Frame Relay est le protocole ARP inverse (Address Resolution
Protocol). Alors que le protocole ARP traduit les adresses IPv4 de couche 3 en adresses MAC de
couche 2, le protocole ARP inverse effectue l'opration inverse. Les adresses IPv4 de couche 3
correspondantes doivent tre disponibles avant l'utilisation des circuits virtuels.

Remarque : Frame Relay pour IPv6 utilise le protocole IND (Inverse Neighbor Discovery) pour
obtenir une adresse IPv6 de couche 3 de la part d'un DLCI de couche 2.

El Hassan EL AMRI 3
El Hassan EL AMRI Frame Relay

VI.2 Mappage dynamique

Le mappage dynamique des adresses s'appuie sur le protocole ARP inverse pour convertir
l'adresse de couche rseau IPv4 du tronon suivant en valeur DLCI locale. Le routeur Frame Relay
envoie des demandes d'ARP inverse sur son circuit virtuel permanent pour dtecter l'adresse de
protocole du priphrique distant connect au rseau Frame Relay. Le routeur utilise les rponses
obtenues pour complter une table de mappage d'adresse en DLCI sur le routeur Frame Relay ou
sur le serveur d'accs. Le routeur tablit et entretient cette table de mappage qui contient toutes les
demandes d'ARP inverse rsolues, y compris les entres de mappage statique et dynamique.

VI.3 Mappage statique Frame Relay

L'utilisateur peut choisir d'ignorer le mappage ARP inverse dynamique en indiquant un mappage
statique pour l'adresse de protocole du tronon suivant au DLCI local. Le mappage statique
fonctionne de faon similaire au protocole ARP inverse en associant une adresse de protocole du
tronon suivant un DLCI Frame Relay local. Vous ne pouvez pas utiliser le protocole ARP inverse
et une instruction de mappage pour le mme DLCI et le mme protocole.

Un exemple d'utilisation de mappage d'adresse statique est une situation dans laquelle le routeur
l'autre extrmit du rseau Frame Relay ne prend pas en charge le protocole ARP inverse
dynamique pour un protocole rseau particulier. Afin d'assurer la connectivit, un mappage statique
est n. La LMI est un mcanisme de maintien de connexion qui fournit des informations d'tat sur
les connexions Frame Relay entre le routeur (ETTD) et le commutateur Frame Relay (DCE). Environ
toutes les 10 secondes, le priphrique final interroge le rseau pour obtenir soit une simple
squence de rponses, soit des informations sur l'tat des canaux. cessaire pour finaliser la
conversion de l'adresse de couche rseau distante en DLCI local.

VI.4 Interface de gestion locale (LMI)

La LMI est un mcanisme de maintien de connexion qui fournit des informations d'tat sur les
connexions Frame Relay entre le routeur (ETTD) et le commutateur Frame Relay (DCE). Environ
toutes les 10 secondes, le priphrique final interroge le rseau pour obtenir soit une simple
squence de rponses, soit des informations sur l'tat des canaux.

Les fonctions principales de l'interface LMI sont les suivantes :

Dterminer la fonctionnalit des divers circuits virtuels permanents connus du routeur


Transmettre des paquets de messages de veille pour s'assurer que le circuit PVC reste
ouvert et ne se ferme pas pour cause d'inactivit
Indiquer au routeur les circuits PVC disponibles

Le routeur peut faire appel trois types d'interface LMI : ansi, cisco et q933a.

VII. Concepts avancs du protocole Frame Relay


Dbit d'accs : fait rfrence la vitesse du port. Du point de vue du client, le fournisseur de
services propose une connexion srie ou une liaison d'accs au rseau Frame Relay via une ligne
loue. Le dbit d'accs est le dbit auquel vos circuits d'accs se connectent au rseau Frame
Relay. Il peut tre de 56 kbit/s, 1,544 Mbit/s (T1) ou une fraction de T1 (multiple de 56 kbit/s ou 64
kbit/s). Le dbit d'accs est mesur sur le commutateur Frame Relay. Il n'est pas possible d'envoyer
des donnes un dbit suprieur au dbit d'accs.

El Hassan EL AMRI 4
El Hassan EL AMRI Frame Relay

Dbit de donnes garanti (CIR, Committed Information Rate) : les clients ngocient les dbits
de donnes garantis avec le fournisseur de services pour chaque circuit virtuel permanent. Le dbit
de donnes garanti est la quantit de donnes que le rseau reoit du circuit d'accs. Le fournisseur
de services garantit que le client peut envoyer des donnes au dbit de donnes garanti. Toutes
les trames reues au dbit de donnes garanti ou en dessous sont acceptes.

Les rafales : permettent aux priphriques qui ont par moment besoin de plus de bande passante
d'en emprunter gratuitement auprs d'autres priphriques qui ne l'utilisent pas. Un priphrique
peut transmettre en rafale jusqu'au dbit d'accs et tre certain que les donnes seront transmises.
La dure d'une transmission en rafale doit tre de trois ou quatre secondes au maximum.

Il existe plusieurs termes pour dcrire les dbits de rafales, dont Bc (Committed Burst Size) et Be
(Excess Burst Size).

Configuration Frame-Relay

El Hassan EL AMRI 5
Configuration Frame-Relay 1

Interface physique Inverse-arp activ


R1>enable
R1#configure terminal
R1(config)#interface Serial 0/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#ip address 192.168.0.1 255.255.255.0
R1(config-if)#no shutdown

Interface physique Inverse-arp dsactiv


R1>enable
R1#configure terminal
R1(config)#interface Serial 0/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no frame-relay inverse-arp
R1(config-if)#ip address 192.168.0.1 255.255.255.0
R1(config-if)#frame-relay map ip 192.168.0.2 200 broadcast
R1(config-if)#frame-relay map ip 192.168.0.3 300 broadcast
R1(config-if)#no shutdown

Subinterface multipoint Inverse-arp activ


R1>enable
R1#configure terminal
R1(config)#interface Serial 0/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface Serial 0/0.1 multipoint
R1(config-subif)#frame-relay interface-dlci 200
R1(config-subif)#frame-relay interface-dlci 300
R1(config-subif)#ip address 192.168.0.1 255.255.255.0

Subinterface multipoint Inverse-arp dsactiv


R1>enable
R1#configure terminal
R1(config)#interface Serial 0/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no frame-relay inverse-arp
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface Serial 0/0.1 multipoint
R1(config-subif)#no frame-relay inverse-arp
R1(config-subif)#ip address 192.168.0.1 255.255.255.0
R1(config-subif)#frame-relay map ip 192.168.0.2 200 broadcast
R1(config-subif)#frame-relay map ip 192.168.0.3 300 broadcast

http://www.ciscomadesimple.be
Configuration Frame-Relay 2

Subinterface point-to-point Inverse-arp activ


R1>enable
R1#configure terminal
R1(config)#interface Serial 0/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface Serial 0/0.200 point-to-point
R1(config-subif)#ip address 192.168.0.1 255.255.255.252
R1(config-subif)#exit
R1(config)#interface Serial 0/0.300 point-to-point
R1(config-subif)#ip address 192.168.0.5 255.255.255.252
R1(config-subif)#exit
Subinterface point-to-point Inverse-arp dsactiv
R1>enable
R1#configure terminal
R1(config)#interface Serial 0/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no frame-relay inverse-arp
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface Serial 0/0.200 point-to-point
R1(config-subif)#no frame-relay inverse-arp
R1(config-subif)#frame-relay interface-dlci 200
R1(config-subif)#ip address 192.168.0.1 255.255.255.252
R1(config-subif)#exit
R1(config)#interface Serial 0/0.300 point-to-point
R1(config-subif)#no frame-relay inverse-arp
R1(config-subif)#frame-relay interface-dlci 300
R1(config-subif)#ip address 192.168.0.5 255.255.255.252
R1(config-subif)#exit

http://www.ciscomadesimple.be

Оценить