Вы находитесь на странице: 1из 9

ALGORITMOS

1. Escribir en pantalla los 100 primeros nmeros pares.


Pseudocdigo
Inicio
Escribir "Los 100 primeros pares son"
num <- 0;
Mientras num < 200 Hacer
Escribir num;
num <- num +2;
FinMientras
Fin
2. Algoritmo calcular el volumen de un prisma recto. El volumen de un
prisma recto es el producto del rea de una de las bases por la
distancia entre ellas (altura)
Pseudocdigo
Inicio
Escribir "Ingresar el rea de la base";
Leer base;
Escribir "Ingresar la altura";
Leer altura;
volumen = base * altura;
Escribir "El volumen del prisma es: ", volumen;
Fin
3. Algoritmo que lea N nmeros e imprima el porcentaje de nmeros
pares e impares.
Pseudocdigo
Inicio
Escribir "Ingrese la cantidad de nmeros:";
Leer cant;
par = 0;
Para i = 1 Hasta cant Con Paso 1 Hacer
Escribir "Ingrese el nmero ", i, " :";
Leer num;
Si num%2 = 0 Entonces
par = par + 1;
FinSi
FinPara
porcentaje = par/cant*100.0;
Escribir "El porcentaje de : ";
Escribir " - nmeros pares: ", porcentaje;
Escribir " - nmeros impares: ", 100 - porcentaje;
Fin
4. Permetro de un tringulo, el valor de los lados del tringulo se debe
ingresar por teclado.
Pseudocdigo
Inicio
Escribir "Ingresar los lados: ";
Escribir "Lado 1: ";
Leer L1;
Escribir "Lado 2: ";
Leer L2;
Escribir "Lado 3: ";
Leer L3;
Permetro = L1+L2+L3;
Escribir "Permetro = ", permetro;
Fin
5. Algoritmo que permita la carga de 10 valores por teclado y muestre la
suma de los valores ingresados y su promedio.
Pseudocdigo
Inicio
Suma = 0;
// se pide que se ingrese los nmeros
Para i =1 Hasta cant Con Paso 10 Hacer
Escribir "Ingrese el nmero ",i;
Leer nmero;
suma = suma + numero;
FinPara
Escribir "La suma es: ",suma;
Escribir "El promedio es: ", suma/10;
Fin
6. Suma de los nmeros pares en un rango dado, los nmeros inferior y
superior del rango deben ser ingresados por teclado.
Pseudocdigo
Inicio
Escribir "Ingrese numero inferior: ";
Leer inferior;
Escribir "Ingrese numero superior: ";
Leer superior;
Suma = 0;
Mientras inferior < superior Hacer
//averiguamos si el nmero es par
Si inferior%2=0 Entonces
Suma = suma + inferior;
FinSi
Inferior = inferior + 1;
FinMientras
Escribir "La suma de nmeros pares es: ", suma;
Fin
7. Algoritmo que permita determinar si un nmero es mltiplo de otro.
Pseudocdigo
Inicio
Escribir 'Ingrese un numero';
Leer n1;
Escribir 'Ingrese otro nmero';
Leer n2;
Si n1>n2 Entonces
Si n1 MOD n2=0 Entonces
Escribir 'El numero ',n1,' es mltiplo de ',n2;
Sino
Escribir 'El numero ',n1,' No es mltiplo de ',n2;
FinSi
Sino
Si n2 MOD n1=0 Entonces
Escribir 'El numero ',n2,' es mltiplo de ',n1;
Sino
Escribir 'El numero ',n2,' No es mltiplo de ',n1;
FinSi
FinSi
Fin

8. Convertir una cantidad ingresada en kilogramos a libras.


Pseudocdigo
Inicio
Escribir "Ingresar (Kg): ";
Leer kilos;
libras = 2.20462262*kilos;
Escribir "= ",libras," lb" ;
Fin
9. Elevar un nmero entero ingresado por teclado, a una potencia dada.
Pseudocdigo
Inicio
Escribir "Ingrese un numero: ";
Leer num;
Escribir "Ingrese la potencia: ";
Leer pot;
rpta = num;
Mientras pot>1 Hacer
rpta = rpta * num;
pot = pot - 1;
FinMientras
Escribir "El resultado es: ", rpta ;
Fin
10. Numero ingresado es divisible por tres.
Pseudocdigo
Inicio
Escribir "Ingrese un numero: ";
Leer num;
Si (num % 3) = 0 Entonces
Escribir "El numero SI es divisible por tres";
Sino
Escribir "El nmero NO es divisible por tres";
FinSi
Fin
FLUJOGRAMA

1. Escribir en pantalla los 100 primeros nmeros pares.

2. Algoritmo calcular el
volumen de un prisma recto.
El volumen de un prisma recto
es el producto
del rea de una de
las bases por la
distancia entre ellas
(altura)

3. Algoritmo que lea N


nmeros e imprima el porcentaje de nmeros pares e impares.
4. Permetro de un tringulo, el valor de los lados del tringulo se
debe ingresar por teclado.
5. Algoritmo que permita la carga de 10 valores por teclado y
muestre la suma de los valores ingresados y su promedio.

6. Suma de
los nmer os pares en un
rango dado,
los nmer os inferior y
superior del rango
deben ser ingresados por teclado.
7. Algoritmo que permita determinar si un nmero es mltiplo de
otro.

8.
C

onvertir una cantidad ingresada en kilogramos a libras.


9. Elevar un nmero entero ingresado por teclado, a una potencia
dada.

10. Numero ingresado es


divisible por tres.