Вы находитесь на странице: 1из 4
CENTRO UNIVERSITÁRIO 7 DE SETEMBRO Cursos: Engenharia de Produção, Elétrica, Mecânica e Civil. Disciplina: Sistemas

CENTRO UNIVERSITÁRIO 7 DE SETEMBRO

Cursos: Engenharia de Produção, Elétrica, Mecânica e Civil.

Disciplina: Sistemas de Computação Aplicados à Engenharia

Professor: Fernando Antônio de Cerqueira

Data:

Aluno:

Matrícula:

Prova Simulada.

INSTRUÇÕES

1. Leia com atenção o que está sendo solicitado em cada uma das questões, procurando não deixar questão sem resposta.

2. Sugere-se começar pelas questões que considerar mais fáceis. As respostas podem ficar fora da sequência. O importante é colocar o número da questão correspondente à resposta fornecida.

3. As soluções das questões devem ser escritas com caneta de tinta azul ou preta.

4. Esta prova é individual. São vedados o uso de celulares e qualquer comunicação e troca de material

entre os presentes, consultas a material bibliográfico, cadernos ou anotações de qualquer espécie.

5. Não é permitido o uso de calculadora.

6. O tempo de prova será de uma hora e quarenta minutos.

7. Não é permitido ao aluno se ausentar da sala de aula durante a aplicação da prova.

QUESTÕES

1. Construir

os

comprimentos em cm das três dimensões (S1, S2 e S3) de uma caixa retangular, calcular a diagonal da caixa é determinar qual a cor da menor esfera citadas, que vai poder conter a caixa: Esfera Verde com diâmetro = 10cm, Amarela com diâmetro = 20cm, Vermelha com diâmetro = 30cm e Azul com diâmetro = 50 cm. Observação: Pode não caber nas esfera. A diagonal da caixa é dada por: (Valor 4.0)

um programa

em

linguagem C++

para

ler

D

S 1 2  S 2 2  S 3 2  

S

1

2

S

2

2

S

3

2

 

2. Construir um algoritmo em portugol ou um programa em linguagem C++ para ler os comprimentos dos três lados de um triângulo (S1, S2 e S3) e determinar qual o tipo de triângulo que temos, com base nos seguintes casos. Sejam A o maior dos lados entre S1, S2 e S3 e B e C os outros dois lados. Então: (Valor 3.0)

Se A >= B + C Se A 2 = B 2 + C 2 Se A 2 > B 2 + C 2 Se A 2 < B 2 + C 2

Então nenhum triângulo é formado Então um triângulo retângulo é formado Então um triângulo obtusângulo é formado Então um triângulo acutângulo é formado

3. Construir um fluxograma que represente a lógica da leitura de

é

simultaneamente múltiplo de 2 e múltiplo de 5, ou não. (Valor

um

número

natural

e

logo depois

informe

se

este

3.0)

Tópicos para consulta - Fluxogramas:

 

Tabela de Símbolos Básicos

  Utilizado para indicar o início ou fim do
 

Utilizado para indicar o início ou fim do

 

fluxograma

 
    Utilizado para representar
 

Utilizado para representar

a

entrada de dados

     

Utilizado para cálculos e atribuição de valores

 
    Utilizado para representar
 

Utilizado para representar

a

saída de informações

 
  Conecta os símbolos

Conecta os símbolos

 

indicando o fluxo dos

dados

 
  Utilizado para indicar um desvio condicional

Utilizado para indicar um desvio condicional

Exemplo:

v f
v
f

Tópicos para consulta - ALGORITMOS:

Linguagem PORTUGOL e C++

Estrutura de controle sequencial - Comando bloco:

Estrutura de controle de seleção Comando de seleção encadeada:

Tipos primitivos de dados:

 

início

 

Inteiro

int

comando1;

se (condição1) então se (condição2) então

Real

float

comando2;

Caractere

char

 

comando3;

 

comando1;

Lógico

bool

fim;

   

senão

   

comando2;

Operadores Aritméticos:

 

{

fimse; senão se (condição3) então

**

potência pow(x,y)

 

comando1;

*

multiplicação

*

comando2;

/

divisão real

/

comando3;

 

comando3;

div

divisão inteira

/

}

 

senão

mod

resto da divisão %

   

comando4;

+

adição

+

Estrutura de controle de seleção

 

fimse;

-

subtração

-

Comando de seleção simples:

 

fimse;

 
 

se (condição) então

 

Operadores Relacionais:

 

comando1;

>

maior que

>

comando2;

if (condição1) { if (condição2) {

<

menor que

<

fimse;

 

=

igual a

==

 

comando1;

>=

maior ou igual a

>=

if (condição) {

   

}else{

<=

menor ou igual a

<=

comando1;

 

comando2;

<>

diferente

!=

comando2;

 

}

Operadores Lógicos:

 

}

}else{ if (condição3) {

não

negação lógica

!

Estrutura de controle de seleção

 

comando3;

e

conjunção lógica

&&

Comando de seleção composta:

 

}else{

ou

disjunção lógica

||

se (condição) então comando1; comando2; senão comando4; comando5; fimse;

if (condição) { comando1; comando2; }else{ comando4; comando5;

   

comando4;

xou

disjunção exclusiva ^

 

}

 

}

Comando de atribuição:

 

variável expressão; variável = expressão;

Estrutura geral de um algoritmo em C++

Comando de entrada de dados:

leia(variáveis);

 

#include <stdio.h> #include <stdlib.h> #include <math.h> main(){ //declaração de variáveis int i,j,m=4,n=6; float x,y; char c1,p[10],s[255],t[40]; lógico: k,op; // comandos

scanf(“%d”,&x);

 

}

Comando de saída de dados:

escreva(expressões);

 

printf(“resposta=%f\n”,k);

 

Estrutura geral de um algoritmo em pseudocódigo

Funções Matemáticas em

 

algoritmo nome; início //declaração de variáveis inteiro: i,j,m,n; real: x,y; caractere: c1,p,s,t; lógico: k,op; // comandos

 

portugol:

sen()

seno

comando1;

cos()

cosseno

comando2; comando3;

arcsen()

arco-seno

 

comando4;

arccos()

arco-cosseno

 

.

.

.

arctan()

arco-tangente

system(“pause”);

trunc()

truncar

}

frac()

fracionário

 

comando1;

abs()

absoluto

comando2; comando3;

ard()

arredondamento

 

comando4;

sqr()

quadrado

.

.

.

sqrt()

raiz quadrada

fim.

 

ln()

logaritmo natural

 

exp()

exponencial

 

Prioridades:

 

Estrutura de controle de repetição Comando de repetição com teste no início:

enquanto (condição) faça

Estrutura de controle de seleção Comando de seleção múltipla escolha:

(() ) internos funções matemáticas **

 

*

/

 

div

mod

 

comando1;

escolha(variável seletora) caso v1: comando1; caso v2 V3:

 

+

-

 

comando2;

>

<

 

>=

<=

=

<>

fimEnquanto;

 

não

 

while (condição) {

comando2;

 

e

ou

 

caso v4,v5: comando3; caso v6:inicio

xou

   

comando1;

 

comando2;

 

comando5;

Estrutura de Dados Variáveis Compostas Homogêneas

}

comando6;

Estrutura de controle de repetição Comando de repetição com teste no final:

Fim; casoContrário: comando7;

algoritmo nome;

 

fimescolha;

 

início

   
 

//declaração de tipos

Tipo tp1=vetor[0

5]

 

repita

 

switch (variável seletora){ case v1: comando1; case v4,v5: comando3; case v6:{

de

 

comando1;

real; tp2=matriz[0 3,0 2] de inteiro; //declaração de variáveis //simples

comando2;

até (condição);

 

do{

 

comando5;

 

comando1;

comando2;

 

comando6;

}

inteiro:i,j,m,n; real: x,y; caractere: c1,p,s,t; lógico: k,op; //declaraçãode variáveis //compostas tp1: v,w;

} while (condição);

}

default: comando7;

 

Estrutura de controle de repetição Comando de repetição com variável de controle:

//O uso do comando:

//break; pode evitar

a

para i de 0 até 9 passo 1 faça

comando1;

//execução de cases //seguidos.

 

tp2: a,b; .

.

.

#include <stdio.h> #include <stdlib.h> main(){ //declaração de variáveis //simples int i, j, m=4, n=6; float x,y; char c1, s[255], t[40]; lógico: k,op; //declaração de variáveis //compostas float v[6], w[n]; int a[4][3], b[m][3]; .

.

.

comando2;

fimPara;

 

Estrutura de Dados Variáveis Compostas

for (int i=0; i<=9; i++) {

Heterogêneas

 
 

comando1;

 

comando2;

algoritmo nome;

 

}

início

 

//declaração de tipos

 

Módulos em c++ (funções e procedimentos)

Tipo tp1=registro

 

inteiro:matricula;

 

caractere:nome;

float media(int a, int b){ float m; m = (a+b)/2.0; return m;

}

void mostra(char t[], float r){ printf(“%s=%f\n”,t,r);

real:salario;

 

fimRegistro;

 

tp2=vetor[0

49]de

tp1;

//declaração de variáveis

tp1: aux;

tp2: funcionário;

Algumas Funções <math.h>:

 

.

.

.

sin(x)

 

seno cosseno truncar absoluto de float absoluto de int arredonda p cima arredonda p baixo potência raiz quadrada logaritmo base 10 exponencial

}

 

cos(x)

trunc(x)

 

Void dobro(float *n){ *

*n = *n

2;

#include <stdio.h> #include <stdlib.h> struct tp1{ int matricula;

 

fabs(x)

}

abs(x)

ceil(x)

 

int main(){ int x=54, y=37; float k; k = media(x,y); dobro(&k); mostra(“total”,k); return 0;

floor(x)

   

char nome[30]; float salario;

pow(b,e)

sqrt(x)

};

main(){ struct tp1 aux; struct tp1 funcionario[50];

log10(x)

exp(x)

 
 

}

 

.

.

.