Вы находитесь на странице: 1из 63

ESTRUCTURAS REPITITIVAS

1. Hallar el factorial de un nmero N utilizando la estructura para,


mientras y repetir

Inicio Fin
Leer n Inicio Inicio
i 1 Leer n Leer n
fact 1 i 1 fact 1
mientras (i<=n) fact 1 Para (i 1) hasta n
hacer Repetir hacer
fact fact*i fact fact*i fact fact*i
i i+1 i i+1
fin_mientras Hasta que (i>n) fin_Para
Escribir fact fin_Repetir Escribir fact
Fin Escribir fact Fin

2. Imprimir los 30 primeras potencias de 4, es decir 4 elevado a 1, 4


elevador a 2 con las tres estructuras.

Inicio Fin
Leer n Inicio Inicio
i 1 Leer n Leer n
Mientras (i<=30) i 1 Para (i 1) hasta 30
hacer Repetir hacer
pot 4^i pot 4^i pot 4^i
Escribir pot Escribir pot
i i+1 i i+1 Escribir pot
Fin _ Mientras Hasta que (i>30) Fin _Para
Fin fin_Repetir Fin

3. Calcular la suma de los n primeros enteros con las tres estructuras.

Inicio Fin _ Mientras Repetir


Leer n Escribir S S S+1
i 1 Fin i i+1
S 0 Hasta que (i>n)
Mientras (i<=n) Inicio Fin _ Repetir
hacer Leer n Escribir S
S S+1 i 1 Fin
i i+1 S 0 Inicio
Leer n S S+1 Fin
S 0
Para (i 1) hasta n Fin _Para
hacer Escribir S

4. Disear un algoritmo para imprimir la suma de los nmeros impares


menores o iguales que n. Utilice las tres estructuras.

Inicio
Leer n Inicio Inicio
Sim 0 Leer n Leer n
i 1 Sim 0 Sim 0
Mientras (i<=n) i 1 Para (i 1) hasta n
hacer Repetir hacer
Si resto(i/2) 0 Si resto (i/2)0 Si resto (i/2)0
entonces entonces entonces
Sim Sim Sim
Sim+1 Sim+1 Sim+1
Fin _Si Fin_ Si Fin_ Si
i i+1 i i+1 Fin _Para
Fin _ Mientras Hasta que (i>n) Escribir Sim
Escribir Sim Fin _ Repetir Fin
Fin Escribir Sim
Fin

5. Calcular el nmero mximo de una serie de 100 nmeros. utilice as


tres estructuras.

Inicio Fin
Leer n Inicio Inicio
max n Leer n Leer n
i 1 max n max n
Mientras (i<=99) i 1 Para (i 1) hasta 99
hacer Repetir hacer
i i+1 i i+1
leer num leer num leer num
Si (num>max) Si (num>max)
entonces entonces Si (num>max)
max num max num entonces
Fin _Si Fin _Si max num
Fin _ Mientras Hasta que (i>99) Fin _Si
Escribir max Fin _ Repeir Fin _ Para
Fin Escribir max Escribir max
Fin

6. Realizar un algoritmo que escriba los N primeros nmeros de la serie


de Fibonacci 1,2,3,5,8,13,21, Utilice las tres estructuras.

7. I b o
n o 1
i 1 +
c , f
i f i
o i b
8. L b o
e o 2
e 2 15.
r 13. Esc
n Mie r
9. f n i
i t b
b r i
o a r
1 s f
i
1 ( b
10. i o
fibo < 3
2 = 16.
n fib
2 ) o
11. h 1
i a
3 c f
12. e i
Esc r b
r 14. o
i fibo 2
b 3 17.
i fibo
r f 2
f i
i b f
i 27. b
b i i
o 3 r
3 28. f
18. Esc i
i r b
i i o
+ b 3
1 i 32.
19. r fib
Fin f o
_ i 1
M b
i o f
e 1 i
n , b
t f o
r i 2
a b 33.
s o fibo
20. 2 2
Fin 29.
21. Rep f
e i
22. t b
i o
23. r 3
Inic 30. 34.
i fibo i
o 3 i
24. +
Lee f 1
r i 35.
n b Has
25. o t
fibo 1 a
1 +
f q
1 i u
26. b e
fibo o
2 2 (
31. i
2 Esc >
r n
i )
36. 1 i
Fin , b
_ f o
R i 2
e b 48.
p o Esc
e 2 r
t 46. i
i Par b
r a i
37. r
Fin ( f
38. i i
3 b
39. Inicio ) o
40. h 3
41. Leer n a 49.
42. s fib
43. t o
fibo a 1
1
n f
1 i
44. h b
fibo a o
2 c 2
e 50.
2 r fib
45. 47. o
Esc fibo 2
r 3
i f
b f i
i i b
r b o
f o 3
i 1 51. Fin _
b + Para
o f 52. Fin
53.

54. Determinar la media de una lista indefinida de nmeros positivos


ledos por teclado y estos son terminados con un nmero negativo o
cero. Utilice las tres estructuras.
55. 62.
Inic Si s
i ( /
o n m
56. > 70.
su 0 Esc
m ) r
a e i
n b
1 t i
57. o r
n M
j c e
2 e d
58. s i
63. j a
i j+1 71.
1 64. s Fin
59. s+n 72.
65.
m m 73.
m Inic
0 i
+
60. o
1
Mie 74.
66. i
n su
i+1
t m
67.
r a
Fin
a _
s 1
S
i 75.
(
68.
i j
Fin_
< 2
M
= 76.
i
j
e
) i
n
h 1
t
a 77.
r
c
a
e m
s
r
69.
61. 0
Me
Lee 78.
d
r Rep
i
n e
a
t 93.
i ( su
r i m
79. > a
Lee j
r ) 1
n 87. 94.
80. Fin_
Si R j
( e 2
n p
> e 95.
0 t
) i m
e r
88. 0
n
Me 96.
t
d Par
o
i a
n
c a
(
e
s i
s
/ 1
81. j
m )
j+1
89. h
82. s
Esc a
s+n
r s
83.
i t
m
b a
m
+ i
j
1 r
h
84. i M
a
i+1 e
c
85. d
e
Fin i
r
_ a
97.
S 90.
Lee
i Fin
r
86. 91.
n
Has 98.
t 92.
Si
a Inic
(
i
n
q o
>
u
0
e
)
e 102. s
n Fin /
t _ m
o S 105.
n i Esc
c 103. r
e Fin_ i
s P b
99. j a i
j+1 r r
100. s a M
s+n 104. e
101. Me d
m d i
m i a
+ a 106.
1 Fin
107.

108. Calcular los factoriales de n ledo por teclado. Utilice las tres
estructuras.

109. i i
Inic < r
i = f
o n a
110. ) c
Lee h t
r a 116.
n c i
111. e i
i r +
1 114. 1
112. fact 117.
fact f fin
1 a _
113. c M
Mie t i
n * e
t i n
r 115. t
a Esc r
s r a
i s
( b
118. + )
Fin 1 h
119. 128. a
Has s
120. t t
Inic a a
i
o q n
121. u
Lee e h
r a
n ( c
122. i e
i > r
1 n 135.
123. ) fact
fact 129. f
1 Fin a
124. _ c
Rep R t
e e *
t p i
i e 136.
r t Es
125. i c
fact r r
f 130. i
a Fin b
c 131. i
t Inic r
* i f
i o a
126. 132. c
Esc Lee t
r r 137.
i n
b 133. 138.
i fact Fin
r 1 _
f 134. P
a Par a
c a r
t a
127. ( 139.
i i Fin
i 1
140.

141. Calcular el factorial de los n nmeros ledos por teclado. Utilice las
tres estructuras.

142. 148. i
Inic fa e
i c n
o t t
143. 1 r
Lee 149. a
r s
n 150. 154.
144. Mien
t
r
155.
i a Esc
1 s r
145. ( i
Mie j b
<
n i
=
t n r
r u f
a m a
s ) c
e
n t
( t 156.
i o i
< n i
= c +
n e
s 1
) 157.
151.
h Fin
fact
a _
f
c M
a
e i
c
r e
t
146. n
*
Lee t
j
r r
152.
n a
j
u s
j
m 158.
+
147. Fin
1
j 159.
153.
1
Fin_
M
160. 169. 174.
Inic j Has
i j t
o + a
161. 1
Lee 170. q
r has u
n t e
162. a
(
i q i
1 u >
163. e n
Rep )
e ( 175.
t j Fin
i > _
r n R
164. u e
Lee m p
r ) e
n 171. t
u Fin_ i
m R r
165. e 176.
j p Fin
1 e 177.
166. t
fa i 178.
c r Inic
t 172. i
1 Esc o
167. r 179.
Rep i Lee
e b r
t i n
i r 180.
r f
168. a 181.
fact c Par
f t a
a 173.
c i (
t i i
* + 1
j 1 )
h t 190.
a 1 Esc
s 184. r
t i
a 185. Para (j 1) hasta b
num hacer i
n 186. r
fact f
h f a
a a c
c c t
e t 191.
r *
182. j 192.
Lee 187. Fin
r _
n 188. P
u Fin_ a
m P r
183. a a
fa r 193.
c a Fin
189.

194.

195. Se quiere hallar el producto de varios nmeros positivos


introducidos por teclado, de manera que el proceso termina cuando se
introduce un nmero negativo. Utilice las tres estructuras.

196. 198. 200.

197. 199. 201.

202. 204. s
Inic Pro (
i d n
o >
1 =
203.
205. 0
Lee )
r Mie
n h
n a
t
r c
a
e 213. 0
r Inic )
206. i 220.
Pro o Fin
d 214. _
Lee R
p r e
r n p
o e
d 215. t
* Pro i
n d r
207. 221.
Lee 1 Esc
r 216. r
n Rep i
208. e b
Fin t i
_ i r
M r P
i 217. r
e Pro o
n d d
t 222.
r p Fin
a r 223.
s o
209. d
Esc * 224.
r n Inic
i 218. i
b Lee o
i r 225.
r n Lee
P 219. r
r Has n
o t
d a 226.
210. Pro
Fin q d
211. u
e 1
227.
212. ( Par
n a
<
n * 231.
> n Esc
= 229. r
0 Lee i
228. r b
Pro n i
d 230. r
Fin P
p _ r
r P o
o a d
d r 232.
a Fin
233.

234. Escriba un algoritmo que encuentre el primer divisor entero de un


nmero, que previamente se ha introducido por teclado. Utilice las
tres estructuras.

235. Inici 246. Inici


o o
236. Leer 247. Leer
n n
237. i 248. i
2 2
238. Mie 249. Rep
ntras etir
(resto 250. i
(n/i) 0) i+1
hacer 251. Has
239. i ta que
i+1 (resto
240. Fin (n/i) = 0)
_Mientra hacer
s 252. Fin
241. Escr _Mientra
ibir i s
242. Fin 253. Escr
243. ibir i
244. 254. Fin
245.
255.

256. Escriba un algoritmo que calcule el mximo de los nmeros


positivos introducidos por teclado. Sabiendo que se introducen
nmeros desde teclado hasta teclear uno negativo. El negativo no
cuenta.
257. Inicio
258. Leer n
259. Max 0
260. Mientras (n>=0) hacer
261. Si (n > max) entonces
262. Max n
263. Fin _ si
264. Leer n
265. Fin _ mientras
266. Escribir max
267. Fin
268.
269.
270. Escriba un algoritmo que determine cules son los mltiplos de 5
comprendidos entre 1 y N.

271. Inicio
272. Leer N
273. i 1
274. Mientras (i<=N) hacer
275. Si resto(i/5)=0 entonces
276. Escribir i
277. Fin _Si
278. i i+1
279. Fin _Mientras
280. Fin

281. Escriba un algoritmo que encuentre al alumno de primer grado con


mejor nota media. Se sabe que este ao entraron 150 alumnos y que
en primero todos tienen 5 asignaturas. Dar el nombre y la nota media.

282. Inicio
283. i 1
284. max 0
285. Mientras (i<=150) hacer
286. Leer nombre
287. j 1
288. s 0
289. Mientras (j<=5) hacer
290. Leer nota
291. s s+nota
292. j j+1
293. Fin _Mientras
294. Media s/5
295. Si (media>max) entonces
296. Max media
297. Alumdes nombre
298. Fin _Si
299. i i+1
300. Fin _Mientras
301. Escribir max
302. Escrbir Alumdes
303. Fin
304.
305. Escriba un algoritmo que calcule la suma de los divisores de cada
nmero introducido por teclado. Se termina cuando el nmero es
negativo o 0.

306.
307. Inicio
308. Leer n
309. Mientras (n>0) hacer
310. s 0
311. Para (i 1) hasta n hacer
312. Si (resto(n/i)=0 ) entonces
313. s s+1
314. Fin _Si
315. Fin_Para
316. Escribir s
317. Leer n
318. Fin _Mientras
319. Fin
320.
321.

322.

323.

324.

325.

326.

327.

328.

16. Dado un capital c, a un inters i, durante m aos,


escriba un algoritmo que calcule en cuanto se habr
convertido ese capital en m ao, sabiendo que es
acumulativo.

329. V.E: C,I,M


330. V.S: CF
331.
332. INICIO
333.
334. Leer C,I,M
335. CIC
336. j1
337. Mientras (j<=M) hacer:
338.
339. CFCI+CI*I
340. Escribir j, CI, CF
341. CICF
342. jj+1
343.
344. Fin_mientras
345. FIN
346.
17. Dada la siguiente formula:
n

((a b) i
3) n
x i 1
n 1

(2 a * (i 1))
i 2
347.
348.
349.
350.
351.
352.
353. Realice un algoritmo que calcule el valor de x pidiendo al
usuario los valores de n, a, b.

354.
355. V.E: a, b, n
356. V.S: x
357.
358. INICIO
359.
360. Leer a, b, n
361.
362. s0
363. i1
364. j2
365. p1
366. va-b
367.
368. Mientras (i<=n)
369. sv^i-3
370. ii+1
371.
372. Fin_mientras
373.
374. Mientras (j<n)
375.
376. p(2+a*(j-1))*p
377. jj+1
378.
379. Fin_mientras
380.
381. x=(s+n)/p
382. escribir x
383. FIN
384.
18. La exponencial se puede aproximar mediante la
serie
x x 2 x3 xn
e =1+x+ + +...+
2! 3! n!
385.
386. , Para N > 0
387.
388.
Para un N dado

389.
390. V.E: x, N
391. V.S: e
392.
393. INICIO
394.
395. Leer x,N
396. i0
397. f1
398. e0
399.
400. Mientras (i<=N) hacer
401. j1;
402. ex^i/f + e
403. f1;
404.
405. Mientras (j<=i) hacer
406. jj+1
407. ff*j
408. Fin_mientras
409. ii+1
410. Fin_mientras
411.
412. Escribir e
413. FIN
414.
xn
Para que N sea tal que n! < e (por ejemplo e = 10 -4
)

415. V.E: x, E
416. V.S: e
417.
418. INICIO
419.
420. Leer x,E
421.
422. i0;
423. f1;
424. e0;
425.
426. Repetir
427. j1
428. g x^i/f+e
429. eg+e
430. f1
431. Mientras (j<=i)
432. jj+1
433. ff*j
434. Fin_mientras
435.
436. ii+1
437. Hasta que (g>=E)
438.
439. Escribir e, g
440. FIN
441.
Escribir un algoritmos que calcule la exponencial de a
segn dicha frmula, utilizando n=10 y luego n=20.

442. V.E: x,
443. V.S: e
444.
445. INICIO
446.
447. Leer x
448. i0
449. f1
450. e0
451.
452. Mientras (i<=10) hacer
453. j1;
454. ex^i/f+e
455. f1;
456.
457. Mientras (j<=i) hacer
458. jj+1
459. ff*j
460. Fin_mientras
461. ii+1
462. Fin_mientras
463.
464. Escribir e
465. FIN
466.
467.
468. INICIO
469.
470. Leer x
471. i0
472. f1
473. e0
474.
475. Mientras (i<=20) hacer
476. j1;
477. ex^i/f+e
478. f1;
479.
480. Mientras (j<=i) hacer
481. jj+1
482. ff*j
483. Fin_mientras
484. ii+1
485. Fin_mientras
486.
487. Escribir e
488. FIN
489.
490.
19.
20. Disear un algoritmo que determine los nmeros
primos entre dos nmeros dados.
491.
492. V.E: n1, n2
493. V.S: Lista de num.
494.
495. INICIO
496. Leer n1, n2
497. jn1+1
498.
499. Mientras (j<n2)
500. r0
501. p0
502. nj
503. jj+1
504. i2
505.
506. Mientras (i<n)
507. rresto (n/i);
508. ii+1;
509.
510. Si (r=0)
511. pp+1
512. Si (p=0)
513. Escribir n
514. Fin_si
515. Fin_si
516. Fin_mientras
517. Fin_mientras
518. FIN
519.
21. Los empleados de una fbrica trabajan en dos
turnos, diurno y nocturno. Se desea calcular el jornal
diario de acuerdo con los siguientes puntos:
520.
Las tarifas de las horas es de 50 nuevos soles
La tarifa de las horas nocturnas es de 80 nuevos
soles
Caso de ser domingo la tarifa se incrementa en
un 100% tanto en el turno diurno y nocturno

521. V.E: ht, turno


522. V.S: s
523.
524. INICIO
525. Leer turno
526. Segn_sea turno hacer
527.
528. Caso diurno
529.
530. Para i1 hasta 7 hacer
531. Segn_sea i hacer:
532. Caso 1:
533. Leer ht
534. sht*50
535. Escribir Lunes, ht, s
536. Caso 2:
537. Leer ht
538. sht*50
539. Escribir Martes, ht, s
540. Caso 3:
541. Leer ht
542. sht*50
543. Escribir Mircoles, ht, s
544. Caso 4:
545. Leer ht
546. sht*50
547. Escribir Jueves, ht, s
548. Caso 5:
549. Leer ht
550. sht*50
551. Escribir Viernes, ht, s
552. Caso 6:
553. Leer ht
554. sht*50
555. Escribir Sbado, ht, s
556. Caso 7:
557. Leer ht
558. sht*100
559. Escribir Domingo, ht, s
560. Fin_segn
561. Fin_para
562.
563. Caso nocturno
564.
565. Para i1 hasta 7 hacer
566. Segn_sea i hacer:
567. Caso 1:
568. Leer ht
569. sht*80
570. Escribir Lunes, ht, s
571. Caso 2:
572. Leer ht
573. sht*80
574. Escribir Martes, ht, s
575. Caso 3:
576. Leer ht
577. sht*80
578. Escribir Mircoles, ht, s
579. Caso 4:
580. Leer ht
581. sht*80
582. Escribir Jueves, ht, s
583. Caso 5:
584. Leer ht
585. sht*80
586. Escribir Viernes, ht, s
587. Caso 6:
588. Leer ht
589. sht*80
590. Escribir Sbado, ht, s
591. Caso 7:
592. Leer ht
593. sht*160
594. Escribir Domingo, ht, s
595. Fin_segn
596. Fin_para
597. FIN
598.
599.
600.
22. Disear el algoritmo que dado una lista nmeros
ledos por teclado, indique si es par o es impar e
imprima el total de nmeros ledos, adems el total de
los pares e impares.
601.
602.
603. V.E: a,n
604. V.S: mensaje, p, im
605.
606. INICIO
607.
608. Leer n
609.
610. i1
611. Repetir
612. Leer a
613. Rresto(a/2)
614.
615. Si R=0, entonces
616. pp+1
617. Escribir Par
618. Sino
619. imim+1
620. Escribir Impar
621. Fin_si
622. Hasta que i>n
623.
624. Escribir El Total de nmeros es,n
625. Escribir El total de pares es,p
626. Escribir El total de impares es,im
627.
628. FIN
629.
23. Dado un nmero N, calcular la suma 5 +10 +15 +
20+ . . . +5* n
630.
631. V.E: N
632. V.S: s
633.
634. INICIO
635.
636. Leer N
637. s0;
638. Para i1 hasta N hacer
639. s5*i+s
640. Fin_para
641. Escribir s
642. FIN
24. Disear el algoritmo que encuentre (muestre) los
nmeros pares que hay entre 100 y 1000.
643.
644. V.E: N
645. V.S: Numeros pares
646.
647. INICIO
648.
649. Para i100 hasta 1000 hacer
650. Rresto(i/2)
651. Si R=0, entonces
652. Escribir i
653. Fin_si
654. Fin_para
655. FIN
656.
25. Disear el algoritmo que calcule la suma de los
pares que hay entre dos nmeros dados.
657.
658. V.E: a, b
659. V.S: s
660.
661. INICIO
662.
663. Leer a, b
664. s0;
665. ia+1
666. Mientras i<b hacer
667. Rresto(i/2)
668. Si R=0, entonces
669. ss+i
670. Fin_si
671. ii+1
672. Fin_para
673. FIN
674.
26. Calcular los pagos mensuales de una hipoteca y el
total a pagar. El programa debe solicitar el capital, el
inters anual y el nmero de aos y debe escribir la
cuota a pagar mensualmente. Para calcular la cuota se
utiliza la siguiente frmula: Sea C el capital del
prstamo, R la tasa de inters mensual y N el nmero de
pagos. La cuota mensual viene dada por:
675.
676.
677.
678.
679.
680. V.E: C, IA, NA
681. V.S: CU, PT
682.
683. INICIO
684. Leer C, IA, NA
685.
27. Cifrado de datos: dado un nmero de cuatro dgitos
se reemplazar cada dgito por (dgito +7) mdulo 10. A
continuacin se intercambiar el primer dgito por el
tercero y el segundo por el cuarto, y ese ser el nmero
cifrado. Nota: obtener el cociente mediante diferencias
sucesivas.
686.
687. V.E: n
688. V.S: m1, c1,d1,u1
689.
690. INICIO
691.
692. Leer n
693.
694. on
695. m0
696.
697. Mientras o>=1000 hacer
698. zo-1000
699. oz
700. mm+1
701. Fin_mientras
702.
703. pn-m*1000
704. c0
705.
706. Mientras p>=100 hacer
707. yp-100
708. py
709. cc+1
710. Fin_mientras
711.
712. qn-m*1000-c*100
713. d0
714.
715. Mientras q>=10 hacer
716. wq-10
717. qw
718. dd+1
719. Fin_mientras
720.
721. un-m*1000-c*100-d*10
722.
723. m1 resto((m+7)/10)
724. c1 resto((c+7)/10)
725. d1 resto((d+7)/10)
726. u1 resto((u+7)/10)
727.
728. Escribir m1,c1,d1,u1
729. FIN
730.
731.
732.
733.
28. Desarrolle el algoritmo de la biseccin para el
clculo de la siguiente ecuacin no lineal.
f ( x) sen( x ) cos(1 x 2 ) 1
734.
735.

736.
737.
738.
739.
740.
741.
742.
743.
744.
745.
746.
747. Se debe ingresar los valores de a, b, iteracin
mxima y un error mnimo
748. Para calcular el error relativo porcentual y
comparar con el error mnimo, se calcula con la
siguiente formula.
xi 1 xi
erp x100
xi 1
749.
750.
751.
752.
753.
754. V.E: a, b, f, e
755. V.S: x
756.
757. INICIO
758. Leer a, b, f, e
759.
760. fasen(a)+cos(1-a^2)-1-f
761. fbsen(b)+cos(1-b^2)-1-f
762.
763. Si fa*fb<0, entonces
764.
765. Repetir
766.
767. c1(b+a)/2
768. fc1sen(c1)+cos(1-c1^2)-1-f
769. Si fb*fc1<=0, entonces
770. ac1
771. Si no
772. bc1
773. Fin_si
774. Hasta que abs(fc1<e/100)
775.
776. Repetir
777.
778. c2(b+a)/2
779. fc2sen(c2)+cos(1-c2^2)-1-f
780. Si fb*fc2>=0, entonces
781. bc2
782. Si no
783. ac2
784. Fin_si
785. Hasta que abs(fc2)<e/100
786.
787. ff1 sen(c1)+cos(1-c1^2)-1
788. ff2 sen(c2)+cos(1-c2^2)-1
789.
790. Escribir La raz aproximada por exceso es,c1
791. Escribir La raz aproximada por defecto es,c2
792. Escribir ("El valor aproximado de la funcin
respectivamente es",ff1,ff2
793.
794. Si no
795. Escribir ERROR
796. Fin_si
797. FIN
798.
29. Del algoritmo del ejercicio 20 remplazar el paso 1
por la siguiente formula
799.
f (b)(a b)
c b
f (a) f (b)
800.
801.
802.
803.
804. V.E: a, b, f, e
805. V.S: x
806.
807. INICIO
808. Leer a, b, f, e
809.
810. fasen(a)+cos(1-a^2)-1-f
811. fbsen(b)+cos(1-b^2)-1-f
812.
813. Si fa*fb<0, entonces
814.
815. Repetir
816.
817. c1b-fb*(a-b)/(fa-fb)
818.
819. fc1sen(c1)+cos(1-c1^2)-1-f
820. Si fb*fc1<=0, entonces
821. ac1
822. Si no
823. bc1
824. Fin_si
825.
826. Hasta que abs(fc1<e/100)
827.
828. Repetir
829.
830. c2 b-fb*(a-b)/(fa-fb)
831.
832. fc2sen(c2)+cos(1-c2^2)-1-f
833. Si fb*fc2>=0, entonces
834. bc2
835. Si no
836. ac2
837. Fin_si
838.
839. Hasta que abs(fc2)<e/100
840.
841. ff1 sen(c1)+cos(1-c1^2)-1
842. ff2 sen(c2)+cos(1-c2^2)-1
843.
844. Escribir La raz aproximada por exceso es,c1
845. Escribir La raz aproximada por defecto es,c2
846. Escribir ("El valor aproximado de la funcin
respectivamente es",ff1,ff2
847.
848. Si no
849. Escribir ERROR
850. Fin_si
851. FIN
852.
853.
854.
855.
30. Desarrolle el algoritmo del trapecio que consiste en
la siguiente formula.
856.
n 1
f ( xa ) 2 f ( xi ) f ( xb )
I (b a) i 1
2n
857.
858.
859. Donde los valores de a y b es el intervalo de la
integral definida y n es el nmero de segmentos.
Utilizar la siguiente funcin, para verificar los
resultados.
860.
861.
F(X) = 0.2 + 25 X - 200 X2 + 675 X3 - 900 X4 + 400 X5
862.

863. V.E: a, b, n
864. V.S: I
865.
866. INICIO
867. Leer a, b, n
868. s0
869.
fa0.2 + 25*a 200*a2 + 675*a3 900*a4 + 400*a5
870.
fb0.2 + 25*b 200*b2 + 675*b3 900*b4 + 400*b5
871.

872. Para i=1 hasta i<n hacer


873. xi=a+i*(b-a)/n
874.
fxi 0.2 + 25*xi 200*xi 2 + 675*xi 3 900*xi 4
+ 400*xi 5
875. sfxi+s
876. Fin_para
877.
878. I (b-a)*(fa+2*s+fb)/(2*n)
879. Escribir I
880.
881. FIN
882. 31. Elabore el algoritmo de integracin
numrica de Simpson 1/3 que consiste de la siguiente
formula
n 1 n 2
f ( xa ) 4 f ( xi ) 2 f ( x j ) f ( xb )
i 1,3,5 j 2,4,6
I (b a )
3n
883.
884.
885.
886.
887.
888. Donde los valores de a y b es el intervalo de la integral definida y n es
el nmero de segmentos pares.
889. Sea f(x) = x^2+2x+1
890. INICIO
891. Leer a, b, n,
892. f(a) a^2+2a+1
893. f(b) b^2+2b+1
894. Si (resto (n/2)=0) entonces:
895. h (b-a)/n
896. Sim 0
897. Spa 0
898. i1
899. Mientras (i<=n) hacer
900. x a+h*i
901. f(x) x^2+2x+1
902. Si (resto (i/2)=0) entonces:
903. Spa Spa+f(x)
904. Sino
905. Sim Sim+f(x)
906. Fin_si
907. i i+1
908. Fin_mientras
909. I h*(f(a)+4*Sim+2*Spa+f(b))/3
910. Escribir I
911. Sino
912. Escribir fuera de rango
913. Fin_si
914. FIN
915.
916. 32. Elabore el algoritmo de integracin
numrica de Simpson 3/8 que consiste de la siguiente
formula
917.
n 1
f ( xa ) 3 f ( xi ) f ( xb )
I (b a ) i 1
8n
918.
919. Donde los valores de a y b es el intervalo de la integral definida y n es
el nmero de segmentos impares.
920. Sea f(x) = x^2+2x+1
921. INICIO
922. Leer a, b, n
923. f(a) a^2+2a+1
924. f(b) b^2+2b+1
925. Si (resto (n/2) <>0) entonces:
926. h (b-a)/n
927. S0
928. i1
929. Mientras (i<=n) hacer:
930. x a+h*i
931. f(x) x^2+2x+1
932. S S+f(x)
933. i i+1
934. Fin_mientras
935. I h*(f(a)+3*S+f(b))/8
936. Escribir I
937. Sino
938. Escribir fuera de rango
939. Fin_si
940. FIN
941.
942. 33. Desarrollar un algoritmo para Aproximar la
siguiente funcin y = seno(x)
943.
944.
945.
946. INICIO
947. Leer x, n
948. i1
949. fact 1
950. y0
951. Mientras (i<=n) hacer:
952. pot (-1)^i*x^(2*i+1)
953. fact (2*i+1)*(2*i)*fact
954. y y+pot/fact
955. i i+1
956. Fin_mientras
957. y x+y
958. Escribir y
959. FIN
960.
961. 34. Desarrollar un algoritmo para Aproximar la
siguiente funcin y = coseno(x)
962.
963.
964.
965.
966. INICIO
967. Leer x, n
968. i1
969. fact 1
970. y0
971. Mientras (i<=n) hacer:
972. pot (-1)^i*x^(2*i)
973. fact (2*i)*(2*i-1)*fact
974. y y+pot/fact
975. i i+1
976. Fin_mientras
977. y 1+y
978. Escribir y
979. FIN
980.
981. 35. Desarrollar un algoritmo para Aproximar la
siguiente funcin y = e^x
982.
983.
984.
985. INICIO
986. Leer x, n
987. i1
988. fact 1
989. y0
990. Mientras (i<=n) hacer:
991. pot x^i
992. fact i*fact
993. y y+pot/fact
994. i i+1
995. Fin_mientras
996. y 1+y
997. Escribir y
998. FIN
999.
1000. 35. Desarrollar un algoritmo para Aproximar la
siguiente funcin y = ln(1+x)
1001.
1002.
1003.
1004.
1005. INICIO
1006. Leer x, n
1007. i1
1008. num 0
1009. y0
1010. Si (x>-1) y (x<=1) entonces:
1011. Mientras (i<=n) hacer:
1012. pot (-1)^(i-1)*x^(i)
1013. num num + 1
1014. y y+pot/num
1015. i i+1
1016. Fin_mientras
1017. Escribir y
1018. Sino
1019. Escribir fuera de rango
1020. Fin_si
1021. FIN
1022.
1023.
1024.
1025. 36. Dado n>0 hallar la suma
n
1
s
k 1 k
1026.
1027. INICIO
1028. Leer n
1029. Si (n>0) entonces:
1030. i1
1031. S0
1032. Mientras (i<=n) hacer
1033. S S + 1/i
1034. i i+1
1035. Fin_mientras
1036. Escribir S
1037. Sino
1038. Escribir fuera de rango
1039. Fin_si
1040. FIN
n
1
s
k 1 ak
1041. 37. Se desea calcular la suma siendo
los valores ak los elementos de la sucesin dada por
ak= ak-1+ ak-2, para k > 2, con a1=1 y a2=1. El limite n
ha de leerse del teclado y se supone mayor que dos.
1042. INICIO
1043. Leer n
1044. Si (n>2) entonces:
1045. a1 1
1046. a2 1
1047. S0
1048. i3
1049. Mientras (i<=n) hacer:
1050. a3 a1+a2
1051. S S+1/a3
1052. a1 a2
1053. a2 a3
1054. i i+1
1055. Fin_mientras
1056. Escribir S
1057. Fin_si
1058. FIN
1059.
n
1
s m
k 1 k
1060. 38. Se desea calcular la suma , siendo
m y n dos nmeros enteros positivos que se suponen
dados.
1061. INICIO
1062. Leer m, n
1063. Si (m>0) y (n>0) entonces:
1064. i1
1065. S0
1066. Mientras (i<=n) hacer
1067. S = S+1/(i^m)
1068. i i+1
1069. Fin_mientras
1070. Escribir S
1071. Fin_si
1072. FIN
1073.
1074. 39. Escriba los n primeros trminos de la
1
an (1 ) n
n
sucesin dada por , siendo n un numero
entero positivo dado.
1075. INICIO
1076. Leer n
1077. Si (n>0) entonces:
1078. i1
1079. Mientras (i<=n) hacer:
1080. num (1+1/i)^i
1081. Escribir num
1082. i i+1
1083. Fin_mientras
1084. Fin_si
1085. FIN
1086.
1087. 40. Escribir un programa que encuentre el
logaritmo en cualquier base de un numero positivo x.
la base y el nmero, lo ingresara el usuario y el
programa debe continuar hasta que se ingrese un
valor 0

log a ( x)
log10 ( x)
log a (b)
1088.

1089. INICIO
1090. i1
1091. Repetir
1092. Leer x, b
1093. Si (x>0) y (b>0) y (b<>1) Entonces
1094. S ln(x)/ln(b)
1095. Escribir S
1096. i i+1
1097. Fin Si
1098. Hasta que (x=0) o (b=0)
1099. FIN
1100.
1101. 41. Dado un numero entero x mayor que uno se
ha de escribir un uno si es primo y un cero en caso
contrario. Para ello ha de comprobar si x es divisible
por algn entero en el intervalo (1, x).
1102. INICIO
1103. Leer x
1104. Si (x>1) entonces:
1105. i 1
1106. s 0
1107. Mientras (i <= x) hacer
1108. Si (resto(x/i)=0) entonces
1109. s s + i
1110. Fin si
1111. i i+1
1112. Fin mientras
1113. p s
1114. q x+1
1115. Si (p=q) entonces
1116. Escribir 1
1117. Sino
1118. Escribir 0
1119. Fin_si
1120. Fin si
1121. FIN
1122.
1123. 42. Dado un numero entero mayor que uno se
ha de escribir la lista de sus divisores comprendidos en
el intervalo (1, x).
1124. INICIO
1125. Leer x
1126. Si (x>1) entonces
1127. i 1
1128. Mientras (i <= x) hacer
1129. Si (resto(x/i)=0) entonces
1130. Escribir i
1131. Fin si
1132. i i+1
1133. Fin mientras
1134. Fin si
1135. FIN
1136.
1137. 43. Dado dos nmeros enteros positivos p y q
escriba un algoritmo que permita hallar el mximo
comn divisor de los mismos
1138. INICIO
1139. Leer a, b
1140. Para (i 1) hasta a hacer
1141. R1 (resto(a/i))
1142. Para j 1 hasta b hacer
1143. R2 (resto (b/j))
1144. Si (i=j) y (r1=0) y (r2=0) entonces
1145. MCD i
1146. Fin si
1147. Fin para
1148. Fin para
1149. Escribir MCD
1150. FIN
1151.
1152. 44. Calcule e imprima los nmeros primos entre
1 y 100
1153. n1
1154. S0
1155. Para (i 2) hasta 100 hacer
1156. Mientras (n <= i) hacer
1157. Si (resto (i/n)=0) entonces
1158. S S+ n
1159. Fin si
1160. n n+1
1161. Fin mientras
1162. PS
1163. Q i+1
1164. Si (P=Q) entonces
1165. Escribir i
1166. Fin si
1167. n 1
1168. S0
1169. Fin Para
1170. FIN
1171.
46. Mostrar los N primeros trminos de la siguiente serie,
donde N debe estar entre 5 y 30
1172. 5, 7, 10, 14, 19
1173. Variables de entrada: N
1174. Variables de salida: Escribir
1175.
1176. Inicio
1177. Leer N
1178. Si (N>=5) y (N<=30) entonces
1179. i 1
1180. t 5
1181. Mientras (i<=N) hacer
1182. t t+1
1183. Escribir t
1184. i i+1
1185. Fin_mientras
1186. Sino
1187.
Escribir error
1188. Fin_si
1189. Fin
1190.
47. Mostrar los N primeros trminos de la siguiente serie,
indicando adems la suma de los mismos.
1191. 7, 9, 12, 16, 21
1192.
1193. Variables de entrada: N
1194. Variables de salida: Escribir
1195.
1196. Inicio
1197. Leer N
1198. s 7
1199. i 1
1200. t 7
1201. repetir
1202. t t+1
1203. s s+t
1204. Escribir t,s
1205. i i+1
1206. Hasta que (i>N)
1207. Fin
1208.
48. Determinar la cantidad de trminos que son mltiplos de
3 en los 200 primeros trminos de la siguiente serie
1209. 6, 8, 10, 12, 14
1210.
1211. Variables de entrada: N
1212. Variables de salida: Escribir
1213.
1214. Inicio
1215. Leer N
1216. Si (N<=200) entonces
1217. i 1
1218. m 1
1219. t 6
1220. Mientras (i<=N) hacer
1221. t t+2
1222. Escribir t
1223. i i+1
1224. si (t mod 3 = 0) entonces
1225. m m+1
1226. Escribir m
1227. Sino
1228. Escribir no mltiplo
1229. Fin_si
1230. Fin_mientras
1231. Sino
1232. Escribir error
1233. Fin_si
1234. Fin
1235.
1236.
1237.
49. Contar y sumar los nmeros enteros positivos ledos por
teclado. Se termina cuando se ingresa un nmero negativo.
1238.
1239.
1240. Variables de entrada: N, num
1241. Variables de salida: Escribir
1242.
1243.
1244.
1245.
1246. Inicio
1247. Leer N
1248. i 0
1249. t 0
1250. Si (N>=0) entonces
1251. Mientras (N>=0) hacer
1252. s s+n
1253. t t+i
1254. leer num
1255. n num
1256. t t+1
1257. Fin_mientras
1258. Escribir s,t
1259. Sino
1260. Escribir
error
1261. Fin_si
1262. Fin
1263.
1264.
50. Sume los nmeros del 1 al 200 menos los mltiplos de 5.
1265.
1266.
1267. Variables de salida: Escribir
1268.
1269. Inicio
1270. s 0
1271. Para i 1 hasta 200 hacer
1272. t i mod 5
1273. Si ( t<>0 ) entonces
1274. s s+1
1275. Fin_si
1276. Fin_para
1277. Escribir s
1278. Fin
1279.
1280.
51. Calcule la suma y el producto de los nmeros impares
comprendidos entre 11 y 111. Resolver con tres estructuras
distintas.
1281.
1282. Variables de salida: Escribir
1283. Inicio
1284. s 0 p 1
1285. Para (i 11 hasta 111) hacer
1286. t i mod 2
1287. Si ( t<>0 ) entonces
1288. s s+i
1289. p p*i
1290. Fin_si
1291. Fin_para
1292. Escribir s,p
1293. Fin
1294.
1295. Inicio
1296. s 0 i 11
1297. p 1
1298. Mientras (i<=111) hacer
1299. t i mod 2
1300. Si ( t<>0 ) entonces
1301. s s+i
1302. p p*i
1303. Fin_si
1304. i i+1
1305.
Fin_mientras
1306. Escribir s,p
1307. Fin
1308.
1309. Inicio
1310. s 0 p 1
1311. i 11 b 1
1312. Mientras (b=1)
1313. t i mod 2
1314. Si ( t<>0 ) entonces
1315. s s+i
1316. p p*i
1317. Fin_si
1318. i
i+1
1319. si
(i=112)
1320. b
2
1321.
fin_si
1322.
Fin_mientras
1323. Escribir s,p
1324. Fin
52. Calcule el MCD (Mximo Comn Divisor) de dos nmeros
A y B de acuerdo con el algoritmo de Euclides.
1325.
1326. Variables de entrada: P, Q, R
1327. Variables de salida: Escribir
1328.
1329. Inicio
1330. Leer P, Q, R
1331. R 0
1332. Si (P=Q) entonces
1333. Escribir P
1334. Sino
1335. Mientras (R=0) hacer
1336. Si ( P>Q ) entonces
1337. P (P-Q)
1338. Sino
1339. Q (Q-P)
1340. p p*i
1341. Fin_si
1342. si
(P=Q)
1343. R
1
1344.
Escribir P
1345.
fin_si
1346.
Fin_mientras
1347. Fin_si
1348. Fin
1349.
1350.
1351.
53. Imprima las tablas de multiplicar desde P hasta Q, siendo
P y Q dos valores ingresados por el teclado, tal que P<=0 cada
tabla debe tener el multiplicador desde 1 hasta 12.
1352.
1353.
1354. Variables de entrada: A, B
1355. Variables de salida: T
1356.
1357.
1358.
1359.
1360.
1361.
1362. Inicio
1363. Leer A,B
1364. Si (A<=0)
entonces
1365. Si (B>=A) entonces
1366. Para i A hasta B hacer
1367.
Para j 1 hasta 12 hacer
1368.
T i*j
1369.
Escribir T
1370.
Fin_para
1371.
Fin_para
1372. Sino
1373. Escribir
error
1374. Fin_si
1375. Sino
1376. Escribir
error
1377. Fin_si
1378. Fin
1379.
54. Imprima los nmeros de Fibonacci menores que 1500. Los
nmeros de Fibonacci se calcula como la suma de los 2
anteriores: 0, 1, 1, 2, 3, 5, 8, 13,
1380.
1381. Variables de entrada: P, Q
1382. Variables de salida: Escribir
1383. Inicio
1384. Para i 1
hasta 1500 hacer
1385. Si (i=1)
entonces
1386. F1 0
1387. Escribir F1
1388. sino
1389. Si (i=2) entonces
1390. F2 1
1391. Escribir F2
1392.
Sino
1393. F3
F1 + F2
1394. F1
f2
1395. F2
f3
1396.
Escribir f3
1397. Fin_si
1398. Fin_si
1399. Fin_para
1400. Fin
55. Imprima los 50 primeros nmeros mltiplos de 3
anteriores al 500 y la suma total de estos 50 primeros nmeros.
1401.
1402. Variables de salida: s
1403.
1404. Inicio
1405. s 0
1406. Para (i 450 hasta 500) hacer
1407. t i mod 3
1408. Si ( t<>0 ) entonces
1409. s s+i
1410. p p*i
1411. Fin_si
1412. Fin_para
1413. Escribir s
1414. Fin
1415.
1416.
56. Calcule e imprima el nmero de trminos necesarios para
que el valor de la siguiente. Sumatoria se aproxime lo ms
cercanamente a 1000 sin que lo exceda.
7
k 2 1

k 1 k
1417.
1418.
1419.
1420. Variables de entrada: p
1421. Variables de salida: s
1422. Inicio
1423. s 0 i 1
1424. p 1
1425. Mientras (p=1) hacer
1426. t (i^2+1)/i
1427. s s+1
1428. i i+1
1429. Si ( t>100 ) entonces
1430. p 0
1431. Fin_si
1432.
Fin_mientras
1433. Escribir s
1434. Fin
1435.
1436.
1437.
57. Calcule el nmero mximo de trminos de la serie de
Fibonacci cuya suma no exceda de 10000. Ingrese por teclado
dos nmeros como inicio de la serie.
1438.
1439.
1440. Variables de entrada: F1, F2
1441. Variables de salida: T
1442.
1443.
1444. Inicio
1445. Leer F1, F2
1446. B 1
1447. S F1+F2
1448. T 2
1449. Mientras (B=1)
hacer
1450. F3
F1+F2
1451. S
S + F3
1452. Si
(S<=10000)
1453. F1
f2
1454. F2
f3
1455. T
T+1
1456. Escribir
f3
1457. Sino
1458. B
0
1459. Fin_si
1460. Escribir
T
1461. Fin_mientras
1462. Fin
1463.
1464.
1465.
58. Calcule e imprima los nmeros primos entre 1 y 100
1466.
1467.
1468. Variables de salida: Escribir
1469.
1470.
1471.
1472.
1473.
1474.
1475.
1476.
1477. Inicio
1478. s 0
1479. Para (i 1 hasta 100) hacer
1480. Para (j 1 hasta 100) hacer
1481. t i mod 3
1482. Si ( t<>0 ) entonces
1483. s s+i
1484. Fin_si
1485. Fin_para
1486. Si
( s=2) entonces
1487.
Escribir i
1488. Fin_si
1489. S 0
1490. Fin_para
1491. Fin
1492.
1493.
59. Permita ingresar el nombre del bien, la cantidad a
depreciar y el nmero de aos de depreciacin, la salida debe
mostrar cada ao y su depreciacin. De acuerdo con el mtodo
de la suma de los dgitos empleado en el anlisis financiero
para calcular la depreciacin. Por ejemplo suponga que un
automvil de $20000 ser depreciado durante un periodo de 5
aos, la suma de los dgitos del ao: 1+2+3+4+5=15. De
acuerdo con el mtodo el primer ao el bien se deprecia 5/15,
el segundo 4/15 y as sucesivamente.
1494.
1495.
1496. Variables de entrada: N, C, A
1497. Variables de salida: j,t
1498.
1499. Inicio
1500. Leer N, C, A
1501. s 0 j 0
1502. Para (i 1 hasta A) hacer
1503. s s+i
1504. Fin_para
1505. Para (i
A hasta 1) hacer
1506. t
(i/s)*C
1507. j
j+1
1508. Escribir
j,t
1509. Fin_para
1510. Fin
1511.
1512.
y 2 x 18
2

60. La esquina de un rectngulo debe estar sobre


la curva elabore el algoritmo que determine las coordenadas de
la esquina del mayor rectngulo posible (imprima las
coordenadas (x, y) y el rea mxima).
1513.
1514.

1515.

1516. Variables de salida: x,y, M


1517.
1518.
1519. Inicio
1520. y -2*(-3) ^2+18
1521. A -3*y
1522. M A
1523. i -2,5
1524. Mientras (i <=3 ) hacer
1525. y (-2)*(i^2)+18
1526. A i*y
1527. Si ( A<0 ) entonces
1528. A A+i
1529. Fin_si
1530. Si
( A>=M) entonces
1531. M
A
1532. X1
i
1533. Y1
y
1534. Fin_si
1535. i i+0,5
1536. Fin_mientras
1537. Escribir M,
x,y
1538. Fin
1539.

1540.
1541.
1542.
1543. 61) Disee un algoritmo que
permita descubrir si dos enteros
positivos son primos entre s, es decir si
su mximo comn divisor es uno.
1544.
1545. VE = A,B
1546. VS = Mensaje
1547. PSEUDOCDIGO
1548. INICIO
1549. Leer: A,B
1550. Si: (A<B), entonces
1551. aux B
1552. BA
1553. Aaux
1554. Mientras (B0), hacer:
1555. Rresto (A/B)
1556. AB
1557. BR
1558. FIN_MIENTRAS
1559. Sino:
1560. Mientras (B0), hacer:
1561. Rresto (A/B)
1562. AB
1563. BR
1564. FIN_MIENTRAS
1565. FIN_SI
1566. Si: (A=1) , entonces
1567. Escribir:Si son PESI
1568. Sino:
1569. Escribir: No son PESI
1570. FIN_SI
1571. FIN
1572.
1573.
1574.
1575.
1576.
1577.
1578.
1579.
1580.
1581.
1582.
1583.
1584.
1585.
1586. 62) Permita ingresar las
coordenadas (x, y) de un punto y el
radio R, de un circulo con centro en el
origen. Luego de evaluar se debe decir
si el punto esta fuera, dentro o sobre el
circulo.
1587. VE = X, Y, R
1588. VS = Mensaje
1589. PSEUDOCDIGO
1590. INICIO
1591. Leer: X, Y, R
1592. Si: (X^ (2) +Y^ (2) =R^ (2)), entonces
1593. Escribir: El punto esta sobre sobre el
circulo
1594. Sino:
1595. Si: (X^ (2) +Y^ (2) R^ (2)),
entonces
1596. Escribir: El punto esta fuera del
circulo
1597. Sino:
1598. Escribir: El punto esta dentro
del circulo
1599. FIN_SI
1600. FIN_SI
1601. FIN
1602.

1603.

1604.

1605.

1606.

1607. 63) Dada una hoja de cartn de


ancho (A) y largo (L). si se recortan
cuadrados de las esquinas, la porcin
restante puede doblarse para formar
una caja. Determnese el tamao de los
recortes de los cuadrados para producir
una caja de volumen mximo (imprimase
el volumen mximo).
1608. VE = x, y, z
1609. VS = Mensaje
1610. PSEUDOCDIGO
1611. INICIO
1612. Leer: x, y, z
1613. Si: (x>100) y (y>100), entonces
1614. Escribir: error
1615. Sino:
1616. Si: ((x^2) + (y^2)= (z^2)), entonces
1617. Escribir: 1
1618. Sino:
1619. Escribir: 0
1620. FIN-SI
1621. FIN-SI
1622. FIN
1623.

1624.

1625.

1626.

1627.

1628.

1629.

1630.

1631.

1632.

1633.

1634.

1635.

1636.

1637.

1638.

1639.

1640. 64) Permita ingresar cuatro valores


reales, los primeros tres son longitud,
ancho y altura (en centmetros) de un
prisma rectangular. El cuarto valor real
es el peso ( en gramos) del prisma.
Escriba un programa para calcular e
imprimir la densidad de este objeto.
1641.

1642. VE = a, b, c, d, e
1643. VS = Mensaje
1644. PSEUDOCDIGO
1645. INICIO
1646. Leer: a, b, c, d, e
1647. Si: (a>b) y (a>c) y (a>d) y (a>e), entonces
1648. Escribir: El Mayor es a, a
1649. Sino:
1650. Si: (b>c) y (b>d) y (b>e), entonces
1651. Escribir: El Mayor es b,
1652. Sino:
1653. Si: (c>d) y (c>e), entonces
1654. Escribir: El Mayor es c, c
1655. Sino:
1656. Si: (d>e), entonces
1657. Escribir: El Mayor es d,
d
1658. Sino:
1659. Escribir: El Mayor es e,
e
1660. FIN-SI
1661. FIN-SI
1662. FIN-SI
1663. FIN-SI
1664. FIN
1665.
1666. 65) Desarrollar el algoritmo de
runge kutta 4to orden para dar una
solucin aproximada de una ecuacin
diferencial de 1er orden con los
siguientes pasos
1667. 1 Definiendo un problema de valor
inicial
como:

1668.
1669. 2 calculando los K

1670.
1671.
1672.
1673.
1674.
1675. 3 calculando el valor de la iteracin
i+1

1676.
1677.
1678.
1679. Ingrese como dato el error mnimo y
comprelo con error relativo porcentual.
1680. VE = p,q
1681. VS = Mensaje
1682. PSEUDOCDIGO
1683. INICIO
1684. Leer: p,q
1685. Si: p<q, entonces
1686. Escribir: error
1687. Sino:
1688. Si: (p mod q) =0, entonces
1689. Escribir: 1
1690. Sino:
1691. Escribir: 0
1692. FIN-SI
1693. FIN-SI
1694. FIN
1695.
1696.
1697.
1698. 66) Escribir un algoritmo que
permita ingresar un entero n y que
imprima si se trata o no de un nmero
capica

1699. VE = N,P,Q,i
1700. VS = Mensaje
1701. PSEUDOCDIGO
1702. INICIO
1703. Leer: N
1704. Mientras (i<N), hacer:
1705. i=i*10
1706. FIN_MIENTRAS
1707. I=i/10
1708. P= (n div i)
1709. Q= (n mod 10)
1710. Si: (P=Q), entonces
1711. Escribir: Si es Capicua
1712. Sino:
1713. Escribir: No es Capicua
1714. FIN-SI
1715. FIN
1716.

1717.

1718.

1719.

1720.

1721.

1722.

1723.

1724. 67) Escriba un algoritmo que lea un


nmero entero por teclado y escriba la
tabla de multiplicar de ese nmero
1725. VE = N
1726. VS = Mensaje
1727. PSEUDOCDIGO
1728. INICIO
1729. Leer: N
1730. i=0
1731. Mientras (i<=10), hacer:
1732. M=i*N
1733. Escribir: N, x , i , = , M
1734. i=i+1
1735. FIN_MIENTRAS
1736. FIN
1737.
1738. 68) Calcular la suma de las

siguientes series:
1739.
1740.
1741.
1742.
1743.
1744.
1745.
1746. Donde n es un nmero entero
introducido por teclado.
1747.

1748. VE = N
1749. VS = A, B
1750. PSEUDOCDIGO
1751. INICIO
1752. Leer: N
1753. i 1
1754. A0
1755. B 0
1756. Mientras ( i <= N) , hacer :
1757. Potencia 2^( i )
1758. A A+(1/ i )
1759. B B + ( i /Potencia)
1760. ii+1
1761. Fin_Mientras
1762. Escribir: A, B
1763. FIN
1764.
1765.
1766.
1767.
1768.
1769.
1770.
1771. 69) Realice un algoritmo que calcule
y visualice el ms grade, el ms pequeo
y la media de n nmeros (n>0). El valor
de n se solicitar al principio del
programa y los nmeros sern
introducidos por el usuario.
1772.
1773. VE = N, num
1774. VS = Max, Min, Me
1775. PSEUDOCDIGO
1776. INICIO
1777. Leer: N, num
1778. Max num
1779. Min num
1780. i 2
1781. S num
1782. Mientras ( i <=N), hacer:
1783. Leer: num
1784. Si: (Max<= num), entonces
1785. Max num
1786. Sino:
1787. Si: (num<= Min) , entonces
1788. Min num
1789. FIN_SI
1790. FIN_SI
1791. S S + num
1792. Fin_ Mientras
1793. Me S/2
1794. Escribir: Max, Min, Me
1795. FIN
1796.
1797.
1798.
1799.
1800.
1801.
1802.
1803.
1804.
1805.
1806.
1807.
1808.
1809.
1810.
1811.
1812.
1813.
1814.
1815.
1816. 70) Realice un programa que
determine si un nmero ledo del teclado
es primo o no
1817.
1818. VE = N
1819. VS = Mensaje
1820. PSEUDOCDIGO
1821. INICIO
1822. Leer: N
1823. i1
1824. P0
1825. Mientras ( i<= N), hacer:
1826. R resto (N/ i)
1827. Si: R=0, entonces
1828. PP+1
1829. Fin_Si
1830. ii +1
1831. Fin_ Mientras
1832. Si: P=2, entonces:
1833. Escribir: N, es primo
1834. Sino:
1835. Escribir: N, no es primo
1836. FIN_SI
1837. FIN
1838.

1839.

1840.

1841.

1842.

1843.

1844.

1845.

1846.

1847.

1848.

1849.

1850.

1851.

1852.

1853. 71) Un nmero perfecto es un


entero positivo, que es igual a la suma
de todos los enteros positivos (excluido
l mismo) que son divisores del nmero.
El primer nmero perfecto es 6, ya que
los divisores de 6 son 1, 2, 3 y 1 + 2 + 3
= 6. Escriba un programa que lea un
nmero entero positivo n y muestre por
pantalla si ese nmero es o no perfecto.
1854. VE = N
1855. VS = Mensaje
1856. PSEUDOCDIGO
1857. INICIO
1858. Leer: N
1859. Mientras ( i<=N), hacer
1860. R resto ( N/i)
1861. Si: (R=0), entonces
1862. P P+1
1863. FIN_SI
1864. ii+1
1865. Fin_ Mientras
1866. Si: (P=2), entonces
1867. Escribir: N,Es Perfecto
1868. Sino:
1869. Escribir: N, No es Perfecto
1870. FIN-SI
1871. FIN
1872.

1873.

1874.

1875.

1876.

1877.

1878.

1879.

1880.

1881.

1882.

1883.

1884.

1885.

1886.

1887. 72) Realizar un programa que


simule un juego de adivinar un nmero.
El programa pedir al usuario dos
nmeros que representan el rango de
valores entre los que se encuentra el
nmero a adivinar, as como el nmero
de intentos para adivinar el nmero. A
continuacin el programa generar un
nmero aleatorio entre esos dos
nmeros y el usuario deber adivinarlo
en el nmero mximo de intentos antes
indicado. Cada vez que el jugador
introduce un nmero el programa le dice
si es mayor o menor y le indica cuantos
intentos le quedan.
1888. (Pista: (x + rand( ) % y) genera un
numero aleatorio en el rango [x , y
1+x]).
1889.
1890. VE = A, B, NIn, num
1891. VS = Mensaje
1892. PSEUDOCDIGO
1893. INICIO
1894. Leer: A, B, NIn
1895. YB-A+1
1896. Incognita A + azar(Y)
1897. i NIn
1898. Mientras ( i>0),hacer:
1899. Leer: num
1900. ii - 1
1901. Si: (Incognita = num), entonces
1902. Escribir: Felicidades has adivinado el
numero incognita, era:, Incognita
1903. i - 1
1904. Sino:
1905. Si: (num>Incognita), entonces
1906. Escribir: El numero es Mayor, te
quedan , i,intentos
1907. Sino:
1908. Escribir: El numero es Menor, te
quedan , i,intentos
1909. FIN_SI
1910. FIN_SI
1911. FIN_MIENTRAS
1912. Si: (i=0) , entonces
1913. Escribir: Su numero de intentos se a
acabado el juego a Terminado
1914. FIN_SI
1915. FIN
1916.
1917.
1918.
1919.
1920.
1921.
1922.
1923.
1924.
1925.
1926.
1927.
1928. 73) Realice un programa que
pregunte aleatoriamente la tabla de
multiplicar. El programa debe indicar si
la respuesta ha sido correcta o no (en
caso que la respuesta sea incorrecta el
programa debe indicar cul es la
correcta). Una vez preguntado por una
multiplicacin el programa debe
preguntar si desea realizar otra. En
caso afirmativo preguntar
aleatoriamente otra
1929. VE = Respuesta, Consulta
1930. VS = Mensaje
1931. PSEUDOCDIGO
1932. INICIO
1933. i1
1934. Mientras (i>0), hacer:
1935. A azar (101)
1936. B azar (51)
1937. M A*B
1938. Escribir: Cuanto es, A,*,B
1939. Leer: Respuesta
1940. Si: (Respuesta=M), entonces
1941. Escribir: Es Correcto
1942. Sino:
1943. Escribir: Error, la Respuesta es: , M
1944. FIN_SI
1945. Escribir:Si desea seguir escriba 1, sino 0
1946. Leer: Consulta
1947. Si: (Consulta=0), entonces
1948. i0
1949. FIN_SI
1950. FIN_MIENTRAS
1951. FIN
1952.
1953.
1954.
1955.
1956.
1957.
1958.
1959.
1960.
1961.
1962.
1963.
1964.
1965.
1966.
1967.
1968.
1969.
1970.
1971.
1972.
1973. 74) Modificar el ejercicio anterior de
modo que el programa pregunta
aleatoriamente un total de n
multiplicaciones siendo n un nmero
dado por teclado. En cada
multiplicacin el programa debe indicar
si se ha acertado o no. Al final del
programa, ste deber mostrar un
resumen indicando el nmero de
respuestas correctas y errneas, as
como el porcentaje de aciertos y de
fallos

1974. VE = n
1975. VS = Mensaje
1976. PSEUDOCDIGO
1977. INICIO
1978. Leer: n
1979. A0
1980. F0
1981. i0
1982. Mientras (i<=n), hacer:
1983. B azar (101)
1984. C azar (51)
1985. M B*C
1986. Escribir: Cuanto es, B,*,C
1987. Leer: Respuesta
1988. Si: (Respuesta=M), entonces
1989. Escribir: Es Correcto
1990. A A+1
1991. Sino:
1992. Escribir: Error, la Respuesta es: ,
1993. FF+1
1994. FIN_SI
1995. i=i+1
1996. FIN_MIENTRAS
1997. TOTA+F
1998. PA (A/TOT)*100
1999. PF (A/TOT)*100
2000. Escribir: N de aciertos :, A ,N de
fallos :, F ,PA : , PA ,%, PF : , PF , %
2001. FIN
2002.
2003.
2004.
2005.
2006.
2007.
2008.
2009.
2010.
2011.
2012.
2013. Ejercicio 74

2014. Inicio
2015. Leer n
2016. C=o
2017. I=o
2018. Para i i hasta n hacer
2019.a= random (1, 1000)
2020.b= random (1, 1000)
2021.r=a*b
2022.escribir a*b=?
2023.leer num
2024. si (num=r)
2025. escribir correcto
2026. c=c+1
2027. sino
2028. escribir incorrecto
2029. i=i+1
2030. fin si
2031. escribir C,i
2032. PC= (C/n)*100
2033. Pi=(i/n)*100
2034. Fin para
2035. Fin
2036.
2037.
2038. Ejercicio 75

2039.

2040. Inicio
2041. Leer n,m
2042. S=o
2043. Si (m<n)
2044. Para i 1 hasta m hacer
2045. S = S +1
2046. fin para
2047. sino
2048. escribir error
2049. Fin si
2050. Fin
2051.

2052.

2053.

2054.

2055.

2056. Ejercicio 76

2057. Inicio
2058. leer n,m
2059. S=0
2060. Para i1 hasta m hacer
2061. S = S +n
2062. Fin para
2063. Fin
2064.
2065. Ejercicio 77
2066.
2067.
2068. Ejercicio 78
2069.
2070. Inicio
2071. Leer n
2072. S=0
2073. I=1
2074. C= 0
2075. Mientras C < n
2076. T = i mod 2
2077. Si (t<>0)
2078.S = S + i
2079.C = C + 1
2080.Fin si
2081. Fin mientras
2082. Escribir S
2083. Fin
2084.
2085.
2086.
2087.
2088.
2089.
2090.
2091.
2092.
2093.
2094.
2095.
2096.
2097.
2098.
2099.
2100. Ejercicio 79
2101.
2102. Inicio
2103. Leer n
2104. Tem=n
2105. Rev= 0
2106. Rem=0
2107. Mientras (tem <> 0)
2108. Rem = tem mod 10
2109. Rev = Rev*10 + Rem
2110. Tem= Entero ( tem / 10)
2111. Fin mientras
2112. Escribir Rev
2113. Fin
2114.

2115.

2116.