Вы находитесь на странице: 1из 8

TOPS Pre Work For AIX ML/TL Updation.

Before 3 days of window time :

We need to collect output of below command in a notepad before we do an


changed on the box.
#df g

df g |wc -l
information about space on file systems.

#lsdev -Cc adapter

#lsdev -Cc disk

The lsdev command displays information about devices in the Device Configuration
database
C Lists information about a device that is in the Customized Devices object
class. The default information displayed is name, status, location, and
description. -c Class Specifies a device class name. This flag can be used to restrict output
devices in a specified class

#ifconfig a

#ifconfig a |wc -l

We can use the ifconfig command to assign an address to a network interface and
to configure or display the current network interface configuration information.
the -a flag may be used instead of an interface name. This flag
instructs ifconfig to display information about all interfaces in the system.

#netstat ni

#netstat ni |wc -l

#netstat nr

#netstat nr |wc -l

#netstat na

#netstat na|wc -l

The Netstat cmd used to displays the contents of various


network-related data structures for active connections.

#lppchk v (should not report any error)

The lppchk command verifies that files for an installable software product
(fileset) match the Software Vital Product Data (SWVPD) database information
for file sizes, checksum values, or symbolic links. A fileset is a separately
installable option of a software package.

#bootlist -m normal o

The bootlist command allows the user to display and alter the list of possible
boot devices from which the system may be booted.

#oslevel s

The oslevel command reports the level of the operating system using a subset of
all filesets installed on your system.
Interpreting `oslevel -s` output:
5300-06-08-0831
5300 = AIX 5.3
06 = TL 06 (Technology Level)
08 = SP 08 (Service Pack)
0831 = Released in 31st week of 2008

Check whether the below command throws any dependency error.


If it shows check with IBM and solve it.
#oslevel rl <output of oslevel r>

#uptime

The uptime command prints the current time, the length of time the system has
been up, the number of users online, and the load average.

#instfix -i |grep -i ML (it should report as all filesets found)


#instfix -i |grep -i SP (it should report as all filesets found)

The instfix command allows you to install a fix or set of fixes without knowing
any information other than the Authorized Program Analysis Report (APAR)
number or other unique keywords that identify the fix.
The instfix command can also be used to determine if a fix is installed on your
system.

#emgr l

Starts the emergency fix (efix) manager, which installs, removes, lists, and
checks system efixes. To list efix; data: emgr -l [ -L Label
#errpt

The errpt command generates an error report from entries in an error log. It
includes flags for selecting errors that match specific criteria.
#lspv

The lspv command displays information about the physical volume if the specific
physical volume name is specified.

#lsvg

The lsvg command displays information about volume groups. If you use the
VolumeGroup parameter, only the information for that volume group is displayed.

#cat /etc/hosts

#bootinfo b

#ps eaf

#ps eaf |wc l

After collect the output

Export the script for mksysb backup from the NIM sever to the required server.
In the NIM server
# exportfs -i /export/mksysb

In the server where the script need to be pushed

#mkdir -p /export/mksysb

#mount v nfs nimservername:/export/mksysb /export/mksysb

eg:-

#mount -v nfs usclswu029_mgm:/export/mksysb /export/mksysb

TO check both the disks are bootable or not..


# bootlist -m normal o

Eg:-
Hdisk# blv=hd5
Hdisk# blv=hd5
If anyone of the disk not under the boot list..utilizing the below commands
#bosboot -ad /dev/hdisk# -----------------to create a boot image
#bootlist -m normal hdisk# hdisk#-----------to update a bootlist order
To run the system information script
# cd /usr/local/bin
./sysinfo.ksh
We need to check the status of LV STATE too..
Eg:-
[/]# lsvg -l rootvg
rootvg:
LV NAME TYPE LPs PPs PVs LV STATE MOUNT POINT
hd5 boot 1 2 2 closed/syncd N/A
hd6 paging 8 16 2 open/syncd N/A
hd7 sysdump 8 8 1 open/syncd N/A
hd8 jfs2log 1 2 2 open/syncd N/A
hd4 jfs2 2 4 2 open/syncd /
hd2 jfs2 24 48 2 open/syncd /usr
hd9var jfs2 3 6 2 open/syncd /var
hd3 jfs2 8 16 2 open/syncd /tmp
hd1 jfs2 3 6 2 open/syncd /home
hd10opt jfs2 7 14 2 open/syncd /opt
fslv00 jfs2 7 14 2 open/syncd /softdist
auditlv jfs2 16 16 1 open/syncd /audit
root @ sf03s03xxp02
[/]#

We will be comparing partition table of both bootable disk


If any partition missing between both diskswe wil be copying the same for other
disk
Example :- (hdisk0,hdisk1)
If hdisk1 has missing auditlv ,then before splitting we will have a copy on other disk
also.
So that both the disks will be similar..

Migratepv l auditlv hdisk1 hdisk0

Break the mirror copy of the rootvg


#unmirrorvg rootvg hdiskXX ( disk to be removed from the vg)
After splitting the mirrorvg

1. Check with command # lsvg -l rootvg

In this number of LPs should be equal to number of PPs. This will confirm the mirrior
is splitted properly..sample below

[/]# lsvg -l rootvg


rootvg:
LV NAME TYPE LPs PPs PVs LV STATE MOUNT POINT
hd5 boot 1 1 1 closed/syncd N/A
hd6 paging 8 8 1 open/syncd N/A
hd7 sysdump 8 8 1 open/syncd N/A
hd8 jfs2log 1 1 1 open/syncd N/A
hd4 jfs2 2 2 1 open/syncd /
hd2 jfs2 24 24 1 open/syncd /usr
hd9var jfs2 3 3 1 open/syncd /var
hd3 jfs2 8 8 1 open/syncd /tmp
hd1 jfs2 3 3 1 open/syncd /home
hd10opt jfs2 7 7 1 open/syncd /opt
fslv00 jfs2 7 7 1 open/syncd /softdist
auditlv jfs2 16 16 1 open/syncd /audit

# reducevg rootvg hdiskXX

# smitty alt_clone (or) alt_disk_install C hdiskxx


Check whether altdisk backup log has been saved.(lslpp l |grep i
alt_disk_install*)

# cd /var/adm/logs
# ls ltr

We need to create temporary /UPD 4 GB File System

if pp size=64 use below cmd



#mklv -t jfs2 -y patchlv rootvg 64 -------To create the Patchlv

if pp size=128 use below cmd

#mklv -t jfs2 -y patchlv rootvg 32

#crfs -v jfs2 -d /dev/patchlv -m /UPD---------To create /UPD File
Systems

#mount /UPD

#chfs -A yes /UPD ----------To set the Auto mount.

We need to copy TL12 with SP5 Filesets from TOPS NIM server using below
commands
root @ usclsitps063
[/]# cd /UPD/5300-12-05-1140

root @ usclsitps063# scp -rp 5300-12-05-


1140czfgbw@servername:/UPD

Note: usclsitps063----------Tops Nim server

During Window Time:

We need to collect output of below command in a notepad before we do


an REBOOT on the box
#df -g |wc -l
#ifconfig -a |wc -l
#netstat -nr |wc -l
#netstat -na |wc -l
#netstat -ni |wc -l
#df -g
#lsdev -Cc adapter
#lsdev -Cc disk
#ifconfig -a
#netstat -ni
#netstat -nr
#netstat -na
#bootlist -m normal -o
#oslevel -s
#uptime
#instfix -i |grep -i ML
#instfix -i |grep -i SP
#emgr -l
#errpt
#lspv
#lsvg
#cat /etc/hosts
#lppchk -v
#lssrc -g cluster
#lsvg rootvg
#lsvg -l rootvg
#lsvg |lsvg -il
#ps -eaf
#prtconf
#lspath
#lsvg -l `lsvg -o` |grep close
#lparstat -i
#uname -L
#lsrsrc "IBM.ManagementServer"
#lsrsrc IBM.MCP
#bootlist -m normal hdiskX hdiskX ( bootlist -m normal -o )

reboot system

#shutdown Fr

#lslpp -l | grep -i applied

Commit the applied filesets

#smitty commit

Once committed, move to the folder where you have TL files

#cd /UPD/5300-12-05-1140

Use smitty again to upgrade the TL

#smitty update_all

Type . (dot) inside the paranthesis ()


Dot represent the current directory

Give no to the commit option

Give yes to the accept license option

Press enter twice

Once the upgrade is complete check for the below commands.


#oslevel -s ------- to check whether the TL is upgraded with latest service package

#lppchk v

This command should not give any output.

In the console

Reboot the server once TL is upgraded


#shutdown Fr

In the session
Once the server is up check with ssh first and even compare the current output with
previous log which we took prior to reboot..

Post Work For AIX ML/TL Updation

AFTER TWO WORKING DAYS:

remove the altboot disk if everything is perfect.

#alt_disk_install -X altinst_rootvg hdiskXX -----------To remove the altdisk

#chdev -l hdiskXX -a pv=clear ------To remove the pvid

#extendvg -f rootvg hdiskXX

#lspv

#umount -f /UPD

#rmfs -r /UPD
#mirrorvg -S rootvg hdiskXX --------Mirorring the disk

#lsvg -l rootvg

#bootlist -m normal -o

#bosboot -ad /dev/hdiskXX

#bootlist -m normal hdiskXX hdiskXX

#bootlist -m normal -o

#bootinfo b --------to check the boot disk

Вам также может понравиться