Вы находитесь на странице: 1из 5

R1-------------------------------------------------------------------

conf t
!
ip vrf cliente1
rd 100:3
!
ip vrf cliente2
rd 200:4
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
exit
interface FastEthernet0/0
no shu
!
interface FastEthernet0/0.100
description R2_cliente1
encapsulation dot1Q 100
ip vrf forwarding cliente1
ip address 10.10.10.2 255.255.255.254
!
interface FastEthernet0/0.200
description R2_cliente2
encapsulation dot1Q 200
ip vrf forwarding cliente2
ip address 10.10.10.4 255.255.255.254
!
interface FastEthernet1/0
description R3
ip vrf forwarding cliente1
ip address 10.10.10.10 255.255.255.254
no shutdown
!
interface FastEthernet2/0
description R4
ip vrf forwarding cliente2
ip address 10.10.10.12 255.255.255.254
no shu
!
router bgp 123
no synchronization
bgp router-id 1.1.1.1
bgp log-neighbor-changes
no auto-summary
!
address-family ipv4 vrf cliente2
neighbor 10.10.10.5 remote-as 123
neighbor 10.10.10.5 activate
neighbor 10.10.10.5 next-hop-self
neighbor 10.10.10.13 remote-as 200
neighbor 10.10.10.13 activate
neighbor 10.10.10.13 as-override
no synchronization
exit-address-family
!
address-family ipv4 vrf cliente1
neighbor 10.10.10.3 remote-as 123
neighbor 10.10.10.3 activate
neighbor 10.10.10.3 next-hop-self
neighbor 10.10.10.11 remote-as 100
neighbor 10.10.10.11 activate
neighbor 10.10.10.11 as-override
no synchronization
exit-address-family
end
!
!
!
!

R2-------------------------------------------------------------------

conf t
ip vrf cliente1
rd 100:5
!
ip vrf cliente2
rd 200:6
!
interface Loopback0
ip address 1.1.1.2 255.255.255.255
!
interface FastEthernet0/0
no shut
exit
interface FastEthernet0/0.100
description R2_cliente1
encapsulation dot1Q 100
ip vrf forwarding cliente1
ip address 10.10.10.3 255.255.255.254
exit
interface FastEthernet0/0.200
description R2_cliente2
encapsulation dot1Q 200
ip vrf forwarding cliente2
ip address 10.10.10.5 255.255.255.254
exit
interface FastEthernet1/0
description R3
ip vrf forwarding cliente1
ip address 10.10.10.6 255.255.255.254
no shu
exit
interface FastEthernet2/0
description R4
ip vrf forwarding cliente2
ip address 10.10.10.8 255.255.255.254
no shu
exit

router bgp 123


no synchronization
bgp router-id 1.1.1.2
bgp log-neighbor-changes
no auto-summary
!
address-family ipv4 vrf cliente1
neighbor 10.10.10.2 remote-as 123
neighbor 10.10.10.2 activate
neighbor 10.10.10.2 next-hop-self
neighbor 10.10.10.7 remote-as 100
neighbor 10.10.10.7 activate
neighbor 10.10.10.7 as-override
no synchronization
exit-address-family

address-family ipv4 vrf cliente2


neighbor 10.10.10.4 remote-as 123
neighbor 10.10.10.4 activate
neighbor 10.10.10.4 next-hop-self
neighbor 10.10.10.9 remote-as 200
neighbor 10.10.10.9 activate
neighbor 10.10.10.9 as-override
no synchronization
end

R3-------------------------------------------------------------------

CONF T

interface Loopback0
ip address 172.16.0.1 255.255.255.0
EXIT

interface FastEthernet0/0
ip address 10.10.10.11 255.255.255.254
no shut
exit

router bgp 100


no synchronization
bgp router-id 172.16.0.1
bgp log-neighbor-changes
no auto-summary
neighbor 10.10.10.10 remote-as 123
no synchronization
netw 172.16.0.0 mask 255.255.255.0
end
R4-------------------------------------------------------------------

CONF T

interface Loopback0
ip address 192.168.0.1 255.255.255.0
EXIT

interface FastEthernet0/0
ip address 10.10.10.13 255.255.255.254
no shut
exit

router bgp 200


no synchronization
bgp router-id 192.168.0.1
bgp log-neighbor-changes
no auto-summary
neighbor 10.10.10.12 remote-as 123
no synchronization
netw 192.168.0.0 mask 255.255.255.0
end

R5-------------------------------------------------------------------

CONF T

interface Loopback0
ip address 172.16.1.1 255.255.255.0
EXIT

interface FastEthernet0/0
ip address 10.10.10.7 255.255.255.254
no shut
exit

router bgp 100


no synchronization
bgp router-id 172.16.1.1
bgp log-neighbor-changes
no auto-summary
neighbor 10.10.10.6 remote-as 123
no synchronization
netw 172.16.1.0 mask 255.255.255.0
end

R6-------------------------------------------------------------------

CONF T

interface Loopback0
ip address 192.168.1.1 255.255.255.0
EXIT

interface FastEthernet0/0
ip address 10.10.10.9 255.255.255.254
no shut
exit

router bgp 200


no synchronization
bgp router-id 192.168.1.1
bgp log-neighbor-changes
no auto-summary
neighbor 10.10.10.8 remote-as 123
no synchronization
netw 192.168.1.0 mask 255.255.255.0
end

Вам также может понравиться