Вы находитесь на странице: 1из 48

MUM Argentina 2015

Buenos Aires

CAPsMAN para redes


empresariales
Prozcenter - Quienes somos?
Empresa joven, con 12 aos de experiencia en Networking y TI.

Compuesta por profesionales de la industria tecnolgica

Consultores en redes de datos.

Entrenadores MikroTik.

Ms de 600 alumnos certificados.


Qu ofrecemos?
Soporte Capacitaciones
Soporte para ISP y empresas. Capacitaciones oficiales de Mikrotik.
Mantenimientos mensuales.
Consultora
Proyectos Consultora para pequeas,
Diseos de red. medianas y grandes redes.
StartUP de nuevos ISP. Servicio de consultora por
Proyectos llave en mano. incidentes.
Capacitacin - MikroTik

MTC Network Associate Wireless Engineer


Bsico Wireless Avanzado

MTC Traffic Control Engineer User Management Engineer


Firewall y QoS Avanzado Tneles avanzados y HS

MTC Routing Engineer Inter-networking Engineer


Routing Avanzado BGP y MPLS
Wi-Fi como base de la vida
El problema de la gestin descentralizada...
Problema dentro de empresas:
Necesidad de cubrir varias locaciones con Wi-Fi.
Algunas veces estas locaciones son remotas.
Generalmente se suelen utilizar varios equipos, y cada uno se gestiona de forma individual.

Solucin:
MikroTik CAPsMAN!

Principal ventaja:
Fcil de configurar.
Integrable.
Verstil y flexible.
Solucin econmica.
Introduccin y
Conceptos Bsicos
Introduccin
Significa Controlled Access Point system MANager.
Permite gestin centralizada de redes inalmbricas.
CAPsMAN Soporta:
Autenticacin MAC va RADIUS
Autenticacin va WPA/WPA2 y cifrado TKIP / AES
Lmites
32 interfaces por equipo.
32 interfaces virtuales por interfaz fsica.
No soporta para redes Nstreme / Nv2 (por ahora).
Elementos y Nomenclatura
CAPsMAN: Tambin llamado Manager es un equipo con o sin interfaces inalmbricas que tiene la
capacidad de administrar interfaces de otros dispositivos (llamados CAP). El Manager
opcionalmente puede hacer reenvo de trfico (es decir puede ser Manager y Router de Borde al
mismo tiempo).
CAP: son equipos con interfaces inalmbricas que proveen conexin a usuarios finales. Estas
interfaces no se configuran localmente sino a travs del Manager

El CAPsMAN tiene los perfiles o configuraciones de redes inalmbricas que sern luego configuradas de
forma automtica en cada CAP. Los CAP slo se encargan de proveer conectividad inalmbrica a los
equipos finales.
Arquitectura Bsica - Tpica
Red empresarial tpica: Access Points en el
mismo segmento que Router de Borde.

Router de Borde: adems de ejecutar sus


funciones (NAT, Firewall, QoS, etc) corre el
CAPsMAN.

Access Points: la configuracin inalmbrica


queda en blanco.
Arquitectura Bsica - Distribuida
Red empresarial distribuida: Access Points en
distintos segmentos.

Router de Borde: adems de ejecutar sus


funciones (NAT, Firewall, QoS, etc) corre el
CAPsMAN.

Access Points: la configuracin inalmbrica


queda en blanco aunque esta vez pueden
ejecutar funciones de Router de Borde (NAT,
Firewall, QoS, etc).
Comunicacin CAPsMAN / CAPs
Los CAPs se comunican con el CAPsMAN utilizando L2 o L3.
L2: los CAPs no precisan configuracin IP, slo requieren visibilidad L2
directa o con VLANs, tneles, etc.
L3: los CAPs requieren configuracin IP fija o va DHCP.
En ambos casos se utiliza comunicacin segura DTLS (UDP 5246).
Comunicacin CAPsMAN / CAPs
Para establecer la comunicacin, los CAP en principio tratan de contactar a los
Managers disponibles en la red utilizando estos mtodos:

1. Direccin IP configurada manualmente.


2. Direccin IP obtenida por DHCP.
3. Buscando en las interfaces configuradas (por broadcast).

Una vez establecida la comunicacin el CAPsMAN agrega el CAP como interfaz


y trata de configurarla con los parmetros que
Configuracin
Inicial (y rpida)
Requisitos
Paquete wireless-cm2.npk.
CAPsMAN funciona desde la versin 6.11, aunque la nueva versin
(CAPsMANv2) est operativa desde la 6.22rc7.
El CAPsMAN (Manager) no requiere interfaz inalmbrica.
Los CAPs deberan tener al menos una interfaz inalmbrica y licencia L4 para
proveer acceso a mltiples clientes.
Escenario
Router de Borde que va a oficiar de
CAPsMAN. Tiene una IP para la
WAN (Internet) y una para la LAN
(clientes).

Los AP se configuraran como CAPs


y en esta configuracin no requieren
IPs.
Configuracin de un CAP
Configuracin de un CAP
Configuracin de un CAP

En este ejemplo
utilizamos
comunicacin L2.
Configuracin de un CAP
Configuracin de un CAP

/interface wireless cap


set discovery-interfaces=ether1 enabled=yes \
interfaces=wlan1

/system identity set name=CAP


Configuracin del CAPsMAN
Configuracin del CAPsMAN
Configuracin del CAPsMAN
Configuracin del CAPsMAN
Configuracin del CAPsMAN
Ahora, volviendo al CAP...
Configuracin del CAPsMAN
/caps-man manager set enabled=yes

/interface wireless cap


set discovery-interfaces=ether1 enabled=yes \
interfaces=wlan1

/system identity
set name=Manager
Configuracin
de redes inalmbricas
Conceptos
El CAPsMAN puede entregar parmetros de configuracin para cada interfaz.
Esas configuraciones se encuentran en:

Configuration, Channels, Datapatsh y Security Cfg..


Conceptos - Solapa Configurations
Configuration: se encuentran los
perfiles principales para cada red
inalmbrica. Ac se configura SSID,
pas, canales y seguridad.

Estas configuraciones se pueden


cargar para todos los CAP del
controlador, para un grupo o para un
solo CAP.
Conceptos - Solapa Channels
Channels: configuraciones relativas
a los canales, como por ejemplo
banda, frecuencia y ancho de canal.
Conceptos - Solapa Datapaths
Datapaths: configuracin
relacionada con el bridge donde se
integrar la interfaz de los CAPs. De
esta forma se configura el reenvio de
trfico hacia el CAPsMAN.
Conceptos - Solapa Security Cfg.
Security Cfg.: configuraciones de
autenticacin y cifrado. Soporta
mtodo estticos (como llaves pre
compartidas), EAP y TLS.
Conceptos - Solapa Configurations (de nuevo)
Conceptos - Solapa Configurations (de nuevo)
Una vez creada la configuracin (al menos una), se la puede cargar en los diversos AP utilizando la
Solapa Provisioning.
Conceptos - Solapa Provisioning
Conceptos - Solapa Provisioning
Alterando el orden de las entradas en Provisioning se puede cargar
configuraciones:

1) A un CAP especfico
2) A un grupo de CAPs
3) A todos los CAP (Radio MAC 00:00:00:00:00:00)
Conceptos - Solapa Registration Table
Gestin de CAPs
por capa 3
Gestin va Capa 3
Para poder gestionar a los CAP va Capa 3 podemos utilizar
los siguiente mtodos:

IP fja en el CAP.
DHCP para los CAP con opcin de Manager.
Gestin va Capa 3
IP fja en el CAP
Gestin va Capa 3
DHCP para los CAP con opcin de Manager.
Hardware
Hardware Recomendado
CAPsMAN: cualquier RouterBOARD o hardware x86 con RouterOS!

CAPs: cAP2n, mAP2nD, RB951x, RB751x, cualquier RB con radio...


Ms funciones (para investigar en sus casas)
Soporte para APs Dual Band.
Comunicacin entre APs Controlador utilizando Certificados.
Upgrade automtico de firmwares.
Cambio de Identity de los CAP.
Control de acceso esttico, o por RADIUS.
Mas info en http://wiki.mikrotik.com/index.php?title=Manual:CAPsMAN
MUM Argentina 2015
Buenos Aires

Dudas?
MUM Argentina 2015
Buenos Aires

Muchas Gracias!