Вы находитесь на странице: 1из 9

1)DadasdosvariablesnumricasAyB,queelusuariodebeteclear,sepiderealizarun

algoritmoqueintercambielosvaloresdeambasvariablesymuestrecuantovalenalfinallas
dosvariables(recuerdalaasignacin).

Esconder

Papel:
1 VarA,B,C:numerica
2 Inicio
3 Escribir"IntroduceelvalordeA"
4 LeerA
5 Escribir"IntroduceelvalordeB"
6 LeerB
7 C<A
8 A<B
9 B<C
10 Escribir"Avale"A"yBvale"B
11 Fin

PSeInt:
1 Procesoejercicio_1
2 Escribir"IntroduceelvalordeA"
3 LeerA
4 Escribir"IntroduceelvalordeB"
5 LeerB
6 C<A
7 A<B
8 B<C
9 Escribir"Avale"A"yBvale"B
10 FinProceso

2)Algoritmoqueleadosnmeros,calculandoyescribiendoelvalordesusuma,resta,
productoydivisin.

Esconder

Papel:
1 Varnumero1,numero2,resultado:numerica
2 Inicio
3 Escribir"Introduceelprimernumero"
4 Leernumero1
5 Escribir"Introduceelsegundonumero"
6 Leernumero2
7 resultado<numero1+numero2
8 Escribirresultado
9 resultado<numero1numero2
10 Escribirresultado
11 resultado<numero1*numero2
12 Escribirresultado
13 resultado<numero1/numero2
14 Escribirresultado
15 Fin
PSeInt:
1 Procesoejercicio_2
2 Escribir"Introduceelprimernumero"
3 Leernumero1
4 Escribir"Introduceelsegundonumero"
5 Leernumero2
6 //inicializamoslavariableresultadoa0(recomendable)
7 resultado<0
8 //sumamoslosnumerosyescribimossuresultado
9 resultado<numero1+numero2
10 Escribirresultado
11 //restamoslosnumerosyescribimossuresultado
12 resultado<numero1numero2
13 Escribirresultado
14 //multiplicamoslosnumerosyescribimossuresultado
15 resultado<numero1*numero2
16 Escribirresultado
17 //dividimoslosnumerosyescribimossuresultado
18 resultado<numero1/numero2
19 Escribirresultado
20 FinProceso

3)Algoritmoqueleadosnmerosynosdigacualdeellosesmayorobiensisoniguales
(recuerdausarlaestructuracondicionalSI)

Esconder

Papel:
1 Varnumero1,numero2:numerica
2 Inicio
3 Escribir"Introduceelprimernumero"
4 Leernumero1
5 Escribir"Introduceelsegundonumero"
6 Leernumero2
7 Si(numero1>=numero2)Entonces
8 Si(numero1=numero2)Entonces
9 escribir"losnumeros"numero1""numero2"soniguales"
10 Sino
11 Escribirnumero1"eselmayordelosdos"
12 FinSi
13 Sino
14 Escribirnumero2"eselmayordelosdos"
15 FinSi
16 Fin

PSeInt:
1 Procesoejercicio_3
2 Escribir"Introduceelprimernumero"
3 Leernumero1
4 Escribir"Introduceelsegundonumero"
5 Leernumero2
6 //comparamoslosdosnumeros,
7 //sielprimeroesmayoroigualqueelsegundoentra
8 Si(numero1>=numero2)Entonces
9
Si(numero1>=numero2)Entonces
9 //Sielnumero1ynumero2sonigualesentrayescribequesoniguales
10 //Sinolosonescribequeelnumero1eselmayor
11 Si(numero1=numero2)Entonces
12 escribir"losnumeros"numero1""numero2"soniguales"
13 Sino
14 Escribirnumero1"eselmayordelosdos"
15 FinSi
16 //SielprimerSiesfalso,escribequeelnumero2esmayor
17 Sino
18 Escribirnumero2"eselmayordelosdos"
19 FinSi
20 FinProceso

4)Algoritmoqueleatresnmerosdistintosynosdigacualdeelloseselmayor(recuerdausar
laestructuracondicionalSiylosoperadoreslgicos).

Esconder

NOTA:Deestaformaqueestahecha,aunquedosdelosnmerosseaniguales,
siempredirelmayor.
Papel:
1 Varnumero1,numero2,numero3:numerica
2 Inicio
3 Escribir"Introduceelprimernumero"
4 Leernumero1
5 Escribir"Introduceelsegundonumero"
6 Leernumero2
7 Escribir"Introduceeltercernumero"
8 Leernumero3
9 Si(numero1>numero2ANDnumero1>numero3)Entonces
10 Escribir"elnumero"numero1"eselmayor"
11 Sino
12 Si(numero2>numero3)Entonces
13 Escribir"Elnumero"numero2"eselmayor"
14 Sino
15 Escribir"Elnumero"numero3"eselmayor"
16 FinSi
17 FinSi
18 Fin

PSeInt:
1 Procesoejercicio_4
2 Escribir"Introduceelprimernumero"
3 Leernumero1
4 Escribir"Introduceelsegundonumero"
5 Leernumero2
6 Escribir"Introduceeltercernumero"
7 Leernumero3
8 //comparamoselnumero1conelnumero2ynumero3
9 //Silasdoscondicionessonverdaderaselnumero1eselmayor
10 Si(numero1>numero2Ynumero1>numero3)Entonces
11 Escribir"elnumero"numero1"eselmayor"
12 //sielnumero1noeselmayor,
13 //comparamoselnumero2conelnumero3
13 //comparamoselnumero2conelnumero3
14 Sino
15 Si(numero2>numero3)Entonces
16 Escribir"Elnumero"numero2"eselmayor"
17 Sino
18 Escribir"Elnumero"numero3"eselmayor"
19 FinSi
20 FinSi
21 FinProceso

5)Disearunalgoritmoquepidaportecladotresnmerossielprimeroesnegativo,debe
imprimirelproductodelostresysinoloes,imprimirlasuma.

Esconder

Papel:
1 Varnumero1,numero2,numero3,resultado:numerica
2 Inicio
3 Escribir"Introduceelprimernumero"
4 Leernumero1
5 Escribir"Introduceelsegundonumero"
6 Leernumero2
7 Escribir"Introduceeltercernumero"
8 Leernumero3
9 Si(numero1<0)Entonces
10 resultado<numero1*numero2*numero3
11 Sino
12 resultado<numero1+numero2+numero3
13 FinSi
14 Escribirresultado
15 Fin

PSeInt:
1 Procesoejercicio_5
2 Escribir"Introduceelprimernumero"
3 Leernumero1
4 Escribir"Introduceelsegundonumero"
5 Leernumero2
6 Escribir"Introduceeltercernumero"
7 Leernumero3
8 //sielnumero1esmenorque0,
9 //multiplicaralosnumeroysinolossumara
10 Si(numero1<0)Entonces
11 resultado<numero1*numero2*numero3
12 Sino
13 resultado<numero1+numero2+numero3
14 FinSi
15 Escribirresultado
16 FinProceso

6)Realizarunalgoritmoqueleaunnmeroporteclado.Encasodequeesenmerosea0o
menorque0,sesaldrdelprogramaimprimiendoantesunmensajedeerror.Siesmayorque
0,sedebercalcularsucuadradoylaraizcuadradadelmismo,visualizandoelnumeroque
hatecleadoelusuarioysuresultado(DelnumeroX,supotenciaesXysuraizX).Para
calcularlaraizcuadradasepuedeusarlafuncininternaRAIZ(X)oconunapotenciade0,5.

Esconder

Papel:
1 Varnumero,potencia,raiz:numerica
2 Inicio
3 Escribir"Introduceunnumero"
4 Leernumero
5 Si(numero>0)Entonces
6 potencia<numero^2
7 raiz_cuadrada<numero^0,5
8 Escribir"Supotenciaes"potencia"
9 Escribir"Suraizes"raiz_cuadrada
10 Sino
11 Escribir"Error,introduceunnumeromayorque0"
12 FinSi
13 Fin

PSeInt:
1 Procesoejercicio_6
2 Escribir"Introduceunnumero"
3 Leernumero
4 //sielnumeroesmayorque0,calculalapotenciaylaraiz
5 //sinomuestraunmensajedeerrorysaledelprograma
6 Si(numero>0)Entonces
7 potencia<numero^2
8 raiz_cuadrada<RAIZ(numero)
9 Escribir"Supotenciaes"potencia
10 Escribir"Suraizes"raiz_cuadrada
11 Sino
12 Escribir"Error,introduceunnumeromayorque0"
13 FinSi
14 FinProceso

7)Uncolegiodeseasaberquporcentajedeniosyquporcentajedeniashayenelcurso
actual.Disearunalgoritmoparaestepropsito(recuerdaqueparacalcularelporcentaje
puedeshacerunareglade3).

Esconder

Papel:
1 Varnumero_nios,numero_nias,resultado:numerica
2 Inicio
3 Escribir"Introduceelnumerodenios"
4 Leernumero_nios
5 Escribir"Introduceelnumerodenias"
6 Leernumero_nias
7 porcentaje_nios<numero_nios*100/(numero_nios+numero_nias)
8 porcentaje_nias<100porcentaje_nios
9 Escribir"Hayun"porcentaje_nios"%denios
10 Escribir"Hayun"porcentaje_nias"%denias
11 Fin
PSeInt:
1 ProcesoEjercicio_7
2 Escribir"Introduceelnumerodenios"
3 Leernumero_nios
4 Escribir"Introduceelnumerodenias"
5 Leernumero_nias
6 //calculamoselporcentaje
7 porcentaje_nios<numero_nios*100/(numero_nios+numero_nias)
8 porcentaje_nias<100porcentaje_nios
9 Escribir"Hayun"porcentaje_nios"%denios
10 Escribir"Hayun"porcentaje_nias"%denias"
11 FinProceso

8)Unatiendaofreceundescuentodel15%sobreeltotaldelacompraduranteelmesde
octubre.Dadounmesyunimporte,calcularculeslacantidadquesedebecobraralcliente.

Esconder

Papel:
1 Varmes:cadena
2 importe,total:numerico
3 Inicio
4 Escribir"escribeelimportedelacompra"
5 Leerimporte
6 Escribir"Introduceelmes"
7 Leermes
8 Si(mes="octubre")Entonces
9 total<importe*0.85
10 Sino
11 total<importe
12 FinSi
13 Escribirtotal
14 Fin

PSeInt:
1 Procesoejercicio_8
2 Escribir"escribeelimportedelacompra"
3 Leerimporte
4 Escribir"Introduceelmes"
5 Leermes
6 //Sielmesesoctubre,seaplicaraeldescuento
7 Si(mes="octubre")Entonces
8 total<importe*0.85
9 Sino
10 total<importe
11 FinSi
12 Escribirtotal
13 FinProceso
9)Realizarunalgoritmoquedadounnmeroentero,visualiceenpantallasiesparoimpar.
Enelcasodeser0,debevisualizarelnmeronoesparniimpar(paraqueunnumerosea
par,sedebedividirentredosyquesurestosea0)

Esconder

Papel:
1 Varnumero:numerica
2 Inicio
3 Escribir"Introduceunnumero"
4 Leernumero
5 Si(numero=0)Entonces
6 Escribir"El"numero"noesparniimpar"
7 Sino
8 Si(numeroMOD2=0)Entonces
9 Escribir"El"numero"espar"
10 Sino
11 Escribir"El"numero"noespar"
12 FinSi
13 FinSi
14 Fin

PSeInt:
1 Procesoejercicio_9
2 Escribir"Introduceunnumero"
3 Leernumero
4 Si(numero=0)Entonces
5 Escribir"El"numero"noesparniimpar"
6 Sino
7 //comprobamossielnumeroespar
8 Si(numeroMOD2=0)Entonces
9 Escribir"El"numero"espar"
10 Sino
11 Escribir"El"numero"noespar"
12 FinSi
13 FinSi
14 FinProceso

10)Modificarelalgoritmoanterior,deformaquesisetecleauncero,sevuelvaapedirel
nmeroporteclado(ashastaquesetecleeunnmeromayorquecero)(recuerdala
estructuramientras).

Esconder

Papel:
1 Varnumero:numerica
2 Inicio
3 Escribir"Introduceunnumero"
4 Leernumero
5 Mientras(numero<=0)hacer
6 Escribir"escribeunnumeromayorque0"
7 Leernumero
8 FinMientras
9 Si(numeroMOD2=0)Entonces
9 Si(numeroMOD2=0)Entonces
10 Escribir"El"numero"espar"
11 Sino
12 Escribir"El"numero"noespar"
13 FinSi
14 Fin

PSeInt:
1 Procesoejercicio_10
2 Escribir"Introduceunnumero"
3 Leernumero
4 //Hastaquenoseintroduzcaunnumeromayorque0nosaldradelbucle
5 Mientras(numero<=0)hacer
6 Escribir"escribeunnumeromayorque0"
7 Leernumero
8 FinMientras
9 Si(numeroMOD2=0)Entonces
10 Escribir"El"numero"espar"
11 Sino
12 Escribir"El"numero"noespar"
13 FinSi
14 FinProceso

11)Algoritmoquenosdigasiunapersonapuedeaccederacursaruncicloformativodegrado
superiorono.Paraaccederaungradosuperior,sisetieneuntitulodebachiller,encasode
notenerlo,sepuedeaccedersihemossuperadounapruebadeacceso.

Esconder

Papel:
1 Varbachiller,prueba_acceso:cadena
2 Inicio
3 Escribir"Tieneseltitulodebachiller?"
4 Leerbachiller
5 si(bachiller="si")Entonces
6 Escribir"Puedesaccederalgradosuperior"
7 Sino
8 Escribir"Tieneslapruebadeaccesosuperada?"
9 Leerprueba_acceso
10 si(prueba_acceso="si")Entonces
11 Escribir"Puedesaccederalgradosuperior"
12 Sino
13 Escribir"Nopuedesaccederaungradosuperior"
14 FinSi
15 FinSi
16 Fin

PSeInt:
1 Procesoejercicio_11
2 Escribir"Tieneseltitulodebachiller?"
2 Escribir"Tieneseltitulodebachiller?"
3 Leerbachiller
4 si(bachiller="si")Entonces
5 Escribir"Puedesaccederalgradosuperior"
6 Sino
7 Escribir"Tieneslapruebadeaccesosuperada?"
8 Leerprueba_acceso
9 si(prueba_acceso="si")Entonces
10 Escribir"Puedesaccederalgradosuperior"
11 Sino
12 Escribir"Nopuedesaccederaungradosuperior"
13 FinSi
14 FinSi
15 FinProceso

12)Desarrollarunalgoritmoquenoscalculeelcuadradodelos9primerosnmerosnaturales
(recuerdalaestructuradesdehasta)

Esconder

Papel:
1 Varnum,res:numerica
2 Inicio
3 Desdenum<1Hasta9In1
4 res<num^2
5 Escribirnum""res
6 FinDesde
7 Fin
PSeInt:
1 Procesoejercicio_12
2 Paranum<1Hasta9ConPaso1
3 res<num^2
4 Escribirnum""res
5 FinPara
6 FinProceso
NOTA:esteejerciciotambinsepuedehacerconlaestructuraMientras,perolohemos
hechoconlaestructuraDesdeHastaporquesabemoselrango.