Вы находитесь на странице: 1из 29

CUE CUCM

Integration

Ryan Bennett

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential 1


Agenda
Overview Network/Configuration Setup
Configuration
Common Problems
Troubleshooting

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential 2


This guide will walk you through the integration
between CUCM CUE, which applies to 5.x/6.x/7.x

Overview

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential 3


CUCM CUE Integration x1001
Overview

x1000

Corporate
Network
CUCM 6.1.2 x1002
10.88.192.207

Hunt Pilot = x2000


CTI Route Point = x5500
Cisco 3845
CTI Port1 = 1100
CUE 3.2.1
CTI Port2 = 1101
10.88.230.71
CTI Port3 = 1102
CTI Port4 = 1103 VM Pilot = x5500
Sales Mailbox = x2000
CUCM x1000 Mailbox = x1000
CUCM x1001 Mailbox = x1001
CUCM x1002 Mailbox = x1002

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential ryabenne@cisco.com
4
High-Level Components and Protocols

SCCP/SIP

IP Phone

Cisco Unified
Communications Manager

JTAPI

Place CUE Module inside


Integrated Services
an ISR slot
Router NM-CUE Module
2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential 5
CUE GUI > Configure > Call Manager

IP of CUCM Server

CUCM Server Admin


Login/PW

JTAPI (Application User)


you created in CUCM server

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential ryabenne@cisco.com
6
CTI ports that you
created in CUCM server

Click here to pull the CTI


Port information from
The CUCM server to the
CUE. This helps the CUE
Find available ports to use.
Make sure they are clicked
In order to use them. Click
Apply

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential ryabenne@cisco.com
7
We are only concerned
About VM mailboxes
1000, 1001, 1002, 2000

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential ryabenne@cisco.com
8
Configure > Users
Click on a user, then
Go to groups tab
Then Subscribe as
member button,
Then do a search
For the DN of the
Hunt pilot/mailbox
Number (in this
Case its 2000)

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential ryabenne@cisco.com
9
Inside CUCM server:
CM Administration >
User Management >
Application User >
Add New > Type
The same information
In for User ID/PW as
You do in the CUE Call
Manager setup. This is
Your JTAPI User.

Controlled devices need


To be all devices controlled
By the JTAPI user. In this
Case I have my CTI Ports
As well as my CTI Route Point

In CUCM 5.x/6.x you will see Permissions Information down at the bottom of
That page. You must have Standard CTI Enabled in both the Groups and
Roles boxes.

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential ryabenne@cisco.com
10
Adding CTI Port:
CM Administration >
Devices > Phones >
Add New/Find > CTI Port
These ports are like
Phones, the will show
Registered

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential ryabenne@cisco.com
11
Inside the Device/Phone
Configuration page of
The CTI Port.

I did a pretty easy setup,


No specific Partition or
CSS.

I just made sure I clicked


The Logged Into Hunt
Group box as we will
Hunt later. Not sure if I
Really needed it, but it
Works

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential ryabenne@cisco.com
12
This is the DN of the
CTI Port. This
DN only relates to this
Port. It does not in any
Way need to be
Associated with anything
Else (other than inside
CUE config). So be sure
That it only has one
Association.

Supposedly you should


Set up the CTI Ports
To be unreachable to
All phones, but I didnt
Set it up this way.

Everything below what you see is left at the default settings. So Call Forward, MLPP,
And everything else are just blank.

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential ryabenne@cisco.com
13
Device > CTI Route Point

The device comes up


As Registered just like
The CTI Ports.

In this case I used this


To point to my Voicemail
DN in the CUE. I made
The CTI Route Point
DN the exact same as
The CUE Voicemail DN.

I would assume you do


The same for Auto-
Attendant and whatever
Else you can run on the
CUE.

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential ryabenne@cisco.com
14
This is the configuration For the
CTI Route Point. Look down at
The bottom and youll see 5500
For the DN.

The Device Name must be


The exact same as the CUE
Host name.

By clicking on 5500 you will get


This page. Again a very simple
Configuration. What you see on
This page is the only config I did.
I didnt configure anything more
Below.

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential ryabenne@cisco.com
15
You will for sure need to
Remember this page!!

From the Administration


Page: Look in the upper
Right corner drop down
Box. Click on the Box, and
Then go to Cisco Unified
Serviceability click Go.
You may have to log in.
Once you are in, go to
Tools > Control Center
Feature Services. You will
Find the Cisco CTIManager.
Be sure to reset that after
Almost any and every change
Done to anything. Im not for certain why you have to do this, but it works.
If your CTI ports/Route Points are unregistered, check this out for sure.

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential ryabenne@cisco.com
16
The AXL service for sure
Needs to be activated. I
Just activated all services
Just to make sure there
Was nothing else crazy I
Needed to add.

To get here: Go to the


Cisco Unified Serviceability
Page > Tools > Service
Activation

Then just enable all of them


To be on the safe side.

Scroll down a little bit to get


To the AXL service >>>>>

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential ryabenne@cisco.com
17
As everyone knows about
Phones in CUCM, Im skipping
That and going straight to
Making voicemail work in CUE.

I simply did call forward no


Answer and then just put the
DN of the VM pilot (x5500)
Then made sure I put a number
For the No Answer Ring
Duration (seconds) input.

After this is done you should


Be ready to roll on your normal
Phone.

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential ryabenne@cisco.com
18
Here is my Line Group
For my hunt.

Hunt Setup:

Someone Dials 2000


Then it rings on x1001
Then rolls to x1002
Then it rolls to the
Voicemail of 2000.

This is a general mailbox


Setup for x2000. This
Means that everyone
Associated with access
To 2000s mailbox will
Have access.

It will use 1101 at the CTI Port to CUE.

The MWI light will not light up for General Delivery Mailboxes, only
for individual mail. I found this out the hard way

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential ryabenne@cisco.com
19
Router Configuration: CUE Configuration:
=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2008.08.28 23:47:28 =~=~=~=~=~=~=~=~=~=~ =~=
sho run
Building configuration...
Current configuration : 8175 bytes
!
! Last configuration change at 20:41:55 UTC Wed Aug 27 2008
! NVRAM config last updated at 04:32:06 UTC Wed Aug 27 2008
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5-3845
!
boot-start-marker
boot system flash:c3845-adventerprisek9_ivs- mz.124-15.XZ .bin
boot-end-marker
!
card type t1 2 1
logging message-counter syslog
enable secret 5 $1$aS9K$5KbmR9fQF J.0j kB4ZanrX/

Part 1
enable password cisco
!
no aaa new-model
--More-- memory-size iomem 10
no network-clock-partici pate slot 2
!
dot11 syslog
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3 =~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2008.08.28 23:48:32 =~=~=~=~=~=~=~=~=~=~ =~=
ip cef [0m3845CUE E# # [0K
! [0;1m3845CUE# [0m[0K
! [0m3845CUE E# # [0K

Part 1
! [0;1m3845CUE# [0m[0K
! [0m3845CUE E# # [0K
no ip domain lookup [0;1m3845CUE# [0m[0K
no ipv6 cef [0;1m3845CUE E# # [0ms[0K[4hho run
! [0m[4l3845CUE E# # sho run[0K
multilink bundle-name authenticated Generating configuration:
! clock timezone America/Chicago
! hostname 3845CUE
! system language preferred "en_US"
signaling-class cas TEST software download server url "ftp://10.89.21.80/" credentials hidden "HG99ZSgwgwJX7H+T3/QBdknfGWTYHfmPSd8ZZNgd+Y9J3xl k2B35j0nfGWTYHfmPSd8ZZNgd+Y9J3xl k2B35j 0nfGWTYHfmPSd8Z ZNgd+Y9J3xl k2B35j 0nfGWTYHfmP"
profile incoming S< log trace local enable
isdn switch-type primary-ni groupname Administrators create
! groupname Broadcasters create
voice-card 0 groupname Sales create
--More-- no dspfarm groupname TechSales create
! groupname Finance create
voice-card 2 username admin create
dspfarm username wjennings create
dsp services dspfarm username jimmcgee create
! username crymcgee create
! username catmcgee create
! username tinmcgee create
voice service pots groupname Sales phonenumber "2000"
! groupname TechSales phonenumber "5513"
voice service voip groupname Finance phonenumber "5524"
allow-connections sip to sip username wjennings phonenumberE164 "5003"
h323 username wjennings phonenumber "5004"
h225 start-h245 on-connect username jimmcgee phonenumber "1000"
call start slow username crymcgee phonenumber "1001"
sip username catmcgee phonenumber "1002"

Part 2
min-se 90 username tinmcgee phonenumber "1003"
registrar server expires max 1200 min 300 groupname TechSales owner tinmcgee
! groupname Administrators member admin
! groupname Administrators member wjennings
! groupname Administrators member tinmcgee
! groupname Sales member jimmcgee
! groupname Sales member catmcgee
--More-- voice class h323 1 groupname TechSales member tinmcgee
h225 timeout setup 3 groupname Administrators privilege ManagePrompts
! groupname Administrators privilege broadcast
! groupname Administrators privilege local-broadcast
! groupname Administrators privilege ManagePublicList
! groupname Administrators privilege ViewPrivateList
! groupname Administrators privilege vm-imap
voice class custom-cptone conference groupname Administrators privilege ViewHistoricalReports
! groupname Administrators privilege ViewRealTimeReports
! groupname Administrators privilege superuser
! groupname Broadcasters privilege broadcast
! groupname Sales privilege superuser
voice class called number inbound 1 groupname Sales privilege ManagePrompts
index 1 4321 groupname Sales privilege local-broadcast
index 2 9876 groupname Sales privilege broadcast
index 3 8765 groupname Sales privilege vm-imap
! groupname Sales privilege ManagePublicList
! groupname Sales privilege ViewPrivateList
voice class called number outbound 1 groupname Sales privilege ViewHistoricalReports
index 1 4321 no mgcp package-capability fxr-package groupname Sales privilege ViewRealTimeReports
index 2 9876 no mgcp timer receive-rtcp groupname TechSales privilege ManagePrompts
index 3 8765 mgcp sdp simple groupname Finance privilege ManagePrompts
! mgcp rtp payload-type g726r16 static restriction msg-notification create
--More-- ! ! restriction msg-notification min-digits 1
! mgcp profile default restriction msg-notification max-digits 30
! ! restriction msg-notification dial-string preference 1 pattern * allowed
voice translation-rule 1 sccp local Loopback1 backup server url "ftp://64.101.175.0/CUEbkupdata/C UEbkupdata" credentials hidden "GixGRq8cUmFqrOHVxftjAknfGWTYHfmPSd8ZZNgd+Y9J 3xl k2B35j0nfGWTYH fmPSd8ZZNgd+Y9J 3xl k2B35j0nfGWTYHfmPSd8ZZNgd+Y9J3xl k2B35j0nfGWTYHfmP"
rule 1 /\(...\)/ /099188\1/ sccp ccm 10.88.230.70 identifier 1 version 4.1 calendar biz-schedule systemschedule
! sccp closed day 1 from 00:00 to 24:00
voice translation-rule 2 ! open day 2 from 00:00 to 24:00
rule 1 /^099188\(.*\)/ /\1/ sccp ccm group 1 open day 3 from 00:00 to 24:00
! associate ccm 1 priority 1 open day 4 from 00:00 to 24:00
voice translation-rule 3 associate profile 2 register confer2 open day 5 from 00:00 to 24:00
rule 1 /5001/ /1014/ associate profile 1 register transcode open day 6 from 00:00 to 24:00
! ! open day 7 from 00:00 to 24:00
voice translation-rule 5 dspfarm profile 1 transcode end schedule
rule 1 /\(.*\)/ /4\1/ codec g711ulaw ccn application aa_simple aa
! codec g711alaw description "aa_simple"
! --More-- codec g729ar8 enabled
voice translation-profile prepend4 codec g729abr8 maxsessions 16
translate called 1 maximum sessions 5 script "aasimple.aef"
! associate application SCCP parameter "BusinessClosedPrompt" "AABusinessClosed.wav"
voice translation-profile prependzero ! parameter "BusinessOpenPrompt" "AABusinessOpen.wav"
translate called 1 dspfarm profile 2 conference parameter "allowExternalTransfers" "false"
! codec g711ulaw parameter "MaxRetry" "3"
voice translation-profile redirect codec g711alaw parameter "BusinessSchedule" "systemschedule"
--More-- translate called 3 maximum sessions 12 parameter "HolidayPrompt" "AAHolidayPrompt.wav "
! associate application SCCP parameter "WelcomePrompt" "AAWelcome.wav"
voice hpi capture destination tftp:// shutdown parameter "PlayExtensionsPrompt" "AASPlayExtens ions.w av"
! ! parameter "ExtensionLength" "1"
! ! end application
application dial-peer voice 7000 voip ccn application autoattendant aa
service alternate default description ***VoIP Dial-Peer to R3745*** description "autoattendant"
! destination-pattern 700. enabled
global session target ipv4:10.88.230.66 maxsessions 16
service alternate default incoming called-number 700. script "aa.aef"
! ! parameter "busClosedPrompt" "AABusinessClosed.wav"
! dial-peer voice 5501 pots parameter "holidayPrompt" "AAHolidayPrompt.wav"
! description ***Dial Peer to R3845*** parameter "welcomePrompt" "friday.wav"
! service mgcpapp parameter "disconnectAfterMenu" "false"
! destination-pattern 55.. parameter "dialByFirstName" "false"
! --More-- incoming called-number 55.. parameter "allowExternalTransfers" "false"
username user1 password 0 cisco direct-inward-dial parameter "MaxRetry" "3"
username user2 password 0 cisco port 2/0:23 parameter "dialByExtnAnyti me" "false"
username jimmcgee password 0 cisco forward-digits all parameter "busOpenPrompt" "greeting.wav"
archive ! parameter "businessSchedule" "systemschedule"
log config dial-peer voice 5500 voip parameter "dialByExtnAnyti meInputLength" "4"
hidekeys mailbox-selection orig-called-num parameter "operExtn" "0"
! description ***VoIP Dial-Peer for CUE*** end application
--More-- ! destination-pattern 5500 ccn application ciscomwiapplication aa
! session protocol sipv2 description "ciscomwiapplication"
! session target ipv4:10.88.230.71 enabled
! incoming called-number 5500 maxsessions 16
controller T1 2/0 dtmf-relay sip-notify script "setmwi.aef"
framing esf codec g711ulaw parameter "CallControlGroupID" "0"
linecode b8zs no vad parameter "strMWI_OFF_DN" "8001"
pri-group timeslots 1-24 ! parameter "strMWI_ON_DN" "8000"
! dial-peer voice 5600 voip end application
controller T1 2/1 description ***VoIP Dial-Peer for CUE*** ccn application msgnotification aa
shutdown destination-pattern 560. description "msgnotification"
framing esf session protocol sipv2 enabled
linecode b8zs session target ipv4:10.88.230.71 maxsessions 16
ds0-group 1 timeslots 1-24 type e&m-fgd incoming called-number 5600 script "msgnotify.aef"

Copy and paste


! dtmf-relay sip-notify parameter "logoutUri" "http://localhost/voicemail/v xmlscripts/mbxLogout.jsp"
! --More-- codec g711ulaw parameter "DelayBeforeSendDTMF" "1"
! no vad end application
! ! ccn application promptmgmt aa
! dial-peer voice 999200 pots description "promptmgmt"
interface Loopback1 service mgcpapp enabled
ip address 2.2.2.2 255.255.255.0 port 2/0/0 maxsessions 1
! ! script "promptmgmt.aef"
interface GigabitEthernet0/0 dial-peer voice 999202 pots end application
--More-- ip address 10.88.230.70 255.255.255.0 service mgcpapp ccn application voicemail aa
duplex auto port 2/0/2 description "voicemail"
speed auto ! enabled
media-type rj45 dial-peer voice 999203 pots maxsessions 16
no keepalive service mgcpapp script "voicebrowser.aef"
h323-gateway voip bind srcaddr 10.88.230.70 port 2/0/3 parameter "logoutUri" "http://localhost/voicemail/v xmlscripts/mbxLogout.jsp"

Copy and paste


! ! parameter "uri" "http://localhost/voicemail/v xmlscripts/login.v xml"
interface GigabitEthernet0/1 ! end application
ip address dhcp sip-ua ccn engine

Part 1 in notepad,
ip nat inside retry invite 3 end engine
ip virtual-reassembly mwi-server ipv4:10.88.230.71 expires 3600 port 5060 transport udp ccn reporting historical
duplex auto ! database local
speed auto ! description "r5-3845-nm-cue-ec"
media-type rj45 ! end reporting
no keepalive gatekeeper ccn subsystem jtapi
! --More-- shutdown ctiport 1100 1101 1102 1103
interface Serial2/0:23 ! ccm-manager address 10.88.192.207
no ip address ! ccm-manager credentials hidden "c9yem6kD 1vJqrOHVxftj AknfGWTYHfmPSd8ZZNgd+Y9J3xl k2B35j 0nfGWTYHfmPSd8Z ZNgd+Y9J3xl k2B35j 0nfGWTYHfmPSd8Z ZNgd+Y9J3xl k2B35j0nfGWTYHfmP"
encapsulation hdlc telephony-service end subsystem
isdn switch-type primary-ni load 7960-7940 SCCP41 ccn subsystem sip
isdn map address .* plan unknown type unknown load 7941 SCCP41.8-3-3S gateway address "10.88.230.70"
isdn integrate calltype all load 7961 SCCP41.8-3-3S mwi sip sub-notify
no cdp enable max-ephones 100 end subsystem
--More-- ! max-dn 50 ccn trigger http urlname msgnotifytrg

Part 1 in notepad,
interface Service-Engine4/0 ip source-address 10.88.230.70 port 2000 application "msgnotification"
ip unnumbered GigabitEthernet0/0 url services http://10.88.230.71/voiceview/com mon/login.do enabled
service-module ip address 10.88.230.71 255.255.255.0 url authentication http://10.88.230.71/voiceview/authentication/authenticate.do maxsessions 2

Then do the same


service-module ip default-gateway 10.88.230.70 keepalive 10 end trigger
! voicemail 5500 ccn trigger http urlname mwiapp
ip default-gateway 10.88.230.1 max-conferences 12 gain -6 application "ciscomwiapplication"
ip forward-protocol nd web admin system name cisco password cisco enabled
ip route 0.0.0.0 0.0.0.0 10.88.230.1 transfer-system full-consult maxsessions 1
ip route 10.88.230.71 255.255.255.255 Service-Engine4/0 create cnf-files version-stamp 7960 Aug 27 2008 04:35:35 end trigger
ip http server ! ccn trigger jtapi phonenumber 5500
no ip http secure-server ! application "voicemail"
ip http path flash: ephone-dn 1 dual-line enabled
! number 5501 maxsessions 6
! --More-- description Tina McGee end trigger
ip nat inside source list 1 interface GigabitEthernet0/0 overload name Tina McGee ccn trigger jtapi phonenumber 5600

The font Is size 1


! call-forward busy 5500 application "autoattendant"
ip sla responder call-forward noan 5500 timeout 10 enabled
access-list 1 permit any mwi sip maxsessions 16
! ! end trigger
ixi transport http ! ccn trigger jtapi phonenumber 5602
response size 8 ephone-dn 4 dual-line application "promptmgmt"

For part 2. The font


no shutdown number 5504 enabled
--More-- request outstanding 2 description Jimmie McGee maxsessions 1
request timeout 30 name Jimmie McGee end trigger
! call-forward busy 5500 ccn trigger sip phonenumber 5500
ixi application cme call-forward noan 5500 timeout 10 application "voicemail"
shutdown mwi sip enabled
! ! maxsessions 6
! ! end trigger
! ephone-dn 5 dual-line ccn trigger sip phonenumber 5600
! number 5502 application "autoattendant"
! description Crystal McGee enabled
! name Crystal McGee maxsessions 16
tftp-server flash:cvm41sccp.8-3-2-27 call-forward busy 5500 end trigger
! call-forward noan 5500 timeout 10 ccn trigger sip phonenumber 5602
control-plane mwi sip application "promptmgmt"

Is size 1
! --More-- ! enabled
! ! maxsessions 1
! ephone-dn 6 dual-line end trigger
voice-port 2/0/0 number 5503 security password lockout policy temp-lock
timing hookflash-out 50 description Cathey McGee security pin lockout policy temp-lock
! name Cathey McGee service voiceview
voice-port 2/0/1 call-forward busy 5500 enable
cptone SA call-forward noan 5500 timeout 10 end voiceview
! mwi sip voicemail notification enable
--More-- voice-port 2/0/2 ! voicemail default language en_US
timing hookflash-out 50 ! voicemail default mailboxsize 1000
! ephone 1 voicemail broadcast recording time 300
voice-port 2/0/3 device-security-mode none voicemail default messagesize 240
echo-cancel coverage 32 mac-address 001E.F729.C5B7 voicemail notification restriction msg-notification
timing hookflash-out 50 username "tinmcgee" password null voicemail operator telephone 5001
! button 1:1 voicemail mailbox owner "Finance" size 2000
voice-port 2/0:23 ! description "Financial Voicemail Box"
! ! end mailbox
voice-port 2/1:1 ! voicemail mailbox owner "Sales" size 2500
timing dialout-delay 300 ephone 2 description "Sales mailbox"
! device-security-mode none end mailbox
ccm-manager redundant-host 10.88.230.123 ! voicemail mailbox owner "TechSales" size 2000
ccm-manager mgcp ! description "TechSales Voicemail Box"
ccm-manager music-on-hold --More-- ! end mailbox
ccm-manager config server 10.88.230.123 ephone 3 voicemail mailbox owner "catmcgee" size 1800
ccm-manager config device-security-mode none description "Cathey McGee's Mailbox"
! ! end mailbox
mgcp ! voicemail mailbox owner "crymcgee" size 1800
mgcp call-agent 10.88.230.124 2427 service-type mgcp version 0.1 ! description "Crystal's Mailbox"
mgcp dtmf-relay voip codec all mode out-of-band ephone 4 end mailbox
mgcp rtp unreachable timeout 1000 action notify device-security-mode none voicemail mailbox owner "jimmcgee" size 1800
mgcp modem passthrough voip mode nse mac-address 001B.D52C.51D1 description "Jimmie's Mailbox"
--More-- mgcp package-capability rtp-package username "jimmcgee" password null end mailbox
mgcp package-capability sst-package button 1:4 voicemail mailbox owner "tinmcgee" size 1800
mgcp package-capability pre-package ! description "Tina's Mailbox"
no mgcp package-capability res-package ! end mailbox
! voicemail mailbox owner "wjennings" size 2500
ephone 5 description "wjennings mailbox"
device-security-mode none zerooutnumber "5001"
mac-address 001B.D584.AD6B end mailbox
username "crymcgee" password null voicemail notification owner Finance enable
button 1:5 voicemail notification owner Sales enable
! voicemail notification owner TechSales enable
! voicemail notification owner catmcgee enable
! voicemail notification owner crymcgee enable
ephone 6 voicemail notification owner jimmcgee enable
--More-- device-security-mode none voicemail notification owner tinmcgee enable
mac-address 000A.41F9.74D9 voicemail notification owner wjennings enable
username "catmcgee" password null end
button 1:6 [0;1m3845CUE# [0m[0K
! [0m3845CUE E# # [0K
! [0;1m3845CUE# [0m[0K
ephone-hunt 55 sequential [0m3845CUE E# # [0K
pilot 5513 [0;1m3845CUE# [0m[0K
list 5501, 5503 [0m3845CUE E# # [0K
final 5500 [0;1m3845CUE# [0m[0K
timeout 3, 3
!
!
!
!
ephone-hunt 56 sequential
pilot 5524
list 5502, 5504
final 5500
timeout 10, 10
!
!
!
--More-- !
!
line con 0
exec-timeout 0 0
password cisco
login
line aux 0
line 258
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120
line vty 0 4
exec-timeout 0 0
password cisco
login
!
scheduler allocate 20000 1000
ntp master
ntp server 64.101.128.26
ntp server 10.88.230.70
ntp server 10.89.254.206
--More-- end
R5-3845#
R5-3845#
R5-3845#
R5-3845#
R5-3845#
R5-3845#

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential 20


Configuration Check

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential 21


Configuration Check
Call Flows:
1000, 1001, 1002 can all call each other and leave voicemail if desired. The MWI
Light will then light up accordingly.
1000, 1001, 1002 all have their own voicemail mailbox which can be accessed
By dialing 5500
Dialing 2000 from any phone will hit the Hunt Pilot which will then hunt for 1001,
Then roll to 1002, then roll to voicemail and you can leave a message in the
General Mailbox for 2000.
No CSS or partitions were ever created or used.

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential 22


Configuration Overview

CTI Route Point (Same DN on both sides) VM Pilot


CTI Route Point DN - x5500

CTI Port1 (has its own DN!, 1100) x5500


x1000
CTI Port2 (has its own DN!, 1101) X2000
x1001 CUCM CUE General Mailbox

CTI Port3 (has its own DN!, 1102) X1000 - 2


x1002 Individual Mailbox

Phone DNs

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential 23


Network Preferences

The codec going to CUE must


be G.711
The JTAPI User must have
control of your CTI Route Point
and CTI Ports
Your CTI Route Point will be
the same DN on both sides
(CUCM/CUE)

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential 24


Common Problems

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential 25


Common Problems
You may see the following problems.
Example 1: The customer upgraded CUCM versions but not CUE.
Resolution Check the compatibility matrix below to verify that their version
of CUE is supported by CUCM.

http://www.cisco.com/en/US/docs/voice_ip_comm/unity_exp/compatibil
ity/cuecomp.htm

--- Get inside the CUE module and issue a show software version
The Global version is the exact version of CUE they are running.

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential 26


Example 2: The CTI Route Points/Ports wont register.
Resolution - Check the compatibility matrix, Restart CTI Manager services, Go to
the CUE Web Admin page and verify that the CUE can login to the CUCM
server. Verify that your CTI Route Points/Ports are controlled by your JTAPI
user, and youve imported/selected them to be used in the CUE.

Example 3: Your CUE cant login to the CUCM account via JTAPI/Web Admin
Resolution - Make sure that you can ping the CUCM server from the CUE
module, make sure that your JTAPI username/pw is the exact same as on the
CUCM server.

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential 27


Troubleshooting

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential 28


Troubleshooting
Traces for certain issues:
CTI Route Point/Port registration: CTI Manager
Call Drop: Collect the CCM traces to troubleshoot and verify its
G711 going to the CUE module
Additional Info:
Make sure that the CUE version is compatible
Make sure that the CUE can login to the CUCM
Make sure that the JTAPI user has control of devices
Make sure that ports are registered
Services often need to be restarted for CTI Manager, so be sure to
do that whenever you make changes to CTI devices.

2007 Cisco Systems, Inc. All rights reserved. Cisco Confidential 29