Вы находитесь на странице: 1из 4

Test #4 Load balancing ( equal / Unequal)

R1 Config

config t
int s1/0
ip address 1.1.1.1 255.0.0.0
no shut
exit
!
int s1/1
ip address 4.4.4.2 255.0.0.0
no shut
exit
!
int f0/0
ip address 10.1.1.1 255.0.0.0
no shut
exit
!
!
!
!
router eigrp 100
network 1.0.0.0
network 10.0.0.0
network 4.0.0.0
no auto-summary
exit
!

=================
R2 Config

int s1/0
ip address 1.1.1.2 255.0.0.0
no shut
exit
!
int s1/1
ip address 2.2.2.1 255.0.0.0
no shut
exit
!
int f0/0
ip address 20.1.1.1 255.0.0.0
no shut
exit
!
router eigrp 100
no auto-summary
network 1.0.0.0
network 2.0.0.0
network 20.0.0.0
exit
!

==========================
R3 Config

int s1/0
ip address 2.2.2.2 255.0.0.0
no shut
exit
!
int s1/1
ip address 3.3.3.1 255.0.0.0
no shut
exit
!
int f0/0
ip address 30.1.1.1 255.0.0.0
no shut
exit
!

router eigrp 100


network 2.0.0.0
network 3.0.0.0
network 30.0.0.0
no auto-summary
exit
!
===========================================
R4 Config

int s1/0
ip address 3.3.3.2 255.0.0.0
no shut
exit
!
int s1/1
ip address 4.4.4.1 255.0.0.0
no shut
exit
!
int f0/0
ip address 40.1.1.1 255.0.0.0
no shut
exit
!
router eigrp 100
network 4.0.0.0
network 3.0.0.0
network 40.0.0.0
no auto-summary
exit
!

================================================================

Checking

R1# Show ip route eigrp


show ip eigrp topology

traceroute 30.1.1.1

show int s1/0

====================================

to change from Equal to unequal load balancing

WAY#1

Change the Bandwidth in R1 INT s1/0 from the default 1544kb/s to 1000 kbps (or
any valy less than 1544 )
as the other Interface S1/1 will stay 1544 kb/s so we will have two path with
diffrent bandwidth.

Note Bandwidth need to be change from both end of Serial other wise one will be
1000k
and the other will stay on 1544 , this is why we need change in R1 and R2 .
on R1
config t
int s1/0
bandwidth 1000
end
!
on R2
config t
int s1/0
bandwidth 1000
end
!

checking will be :-

# sh ip route EIGRP

# show ip route eigrp


You will see that there is only one path now to 30.0.0.0/8 though 4.4.4.1

# show ip route topology


you will see path to 30.0.0.0/8 has now two vlaue different in s1/0 and s1/0
FD will be the lowest value.

--------------------

way#2 (This is called MANUAL UNEQUAL LOAD BALANCING) this is used by using
VARIANCE

VARIANCE is a multiplier value ranges in between 1-28 and default 1

Calculation VARIANCE :-

EQUATION:-
---------
cost of SUCCESSOR X variance must be larger ( > ) cost of the other routers to
be used for load balancing

R1# router eigrp 100


# variance 2

checking :-
show ip protocolos
sh ip route eigrp
traceroute 30.1.1.1

Вам также может понравиться