Вы находитесь на странице: 1из 84

Lab 1. Converting IPv4 Addresses to Binary

Lab Objectives

Part 1: Convert IPv4 Addresses from Dotted Decimal to Binary

Part 2: Use Bitwise ANDing Operation to Determine Network Addresses

Part 3: Apply Network Address Calculations

Lab Solution

Part 1:

Convert IPv4 Addresses from Dotted Decimal to Binary

In Part 1, you will convert decimal numbers to their binary equivalent. After you have mastered this activity, you willconvert IPv4 addresses and subnet masks from dotted decimal to their binary form.

Step 1:

Convert decimal numbers to their binary equivalent.

Fill in the following table by converting the decimal number to an 8-bit binary number. The first number has been completed for your reference. Recall that the eight binary bit values in an octet are based on the powers of 2, and from left to right are 128, 64, 32, 16, 8, 4, 2, and 1.

Step 2:

Decimal

Binary

192

11000000

168

10

255

2

Convert the IPv4 addresses to their binary equivalent.

An IPv4 address can be converted using the same technique you used above. Fill in the table below with the binary equivalent of the addresses provided. To make your answers easier to read, separate the binary octets with a period.

Decimal

Binary

192.168.10.10

11000000.10101000.00001010.00001010

209.165.200.229

 

172.16.18.183

 

10.86.252.17

 

255.255.255.128

 

255.255.192.0

 

Part 2:

Use Bitwise ANDing Operation to Determine Network Addresses

In Part 2, you will use the bitwise ANDing operation to calculate the network address for the provided host addresses. You will first need to convert an IPv4 decimal address and subnet mask to their binary equivalent. Once you have the binary form of the network address, convert it to its decimal form.

Note: The ANDing process compares the binary value in each bit position of the 32-bit host IP with the corresponding position in the 32-bit subnet mask. If there two 0s or a 0 and a 1, the ANDing result is 0. If there are two 1s, the result is a 1, as shown in the example here.

1, the ANDing result is 0. If there are two 1s, the result is a 1,
1, the ANDing result is 0. If there are two 1s, the result is a 1,
1, the ANDing result is 0. If there are two 1s, the result is a 1,
1, the ANDing result is 0. If there are two 1s, the result is a 1,

Step 1:

Determine the number of bits to use to calculate thenetwork address.

Description

Decimal

Binary

IP Address

192.168.10.131

11000000.10101000.00001010.10000011

Subnet Mask

255.255.255.192

11111111.11111111.11111111.11000000

Network Address

192.168.10.128

11000000.10101000.00001010.10000000

How do you determine what bits to use to calculate the network address?

The bits that are set to 1 in the binary subnet mask are used to calculate the network address.

In the example above, how many bits are used to calculate the network address?

Step 2:

26 bits
26
bits

Use the ANDing operation to determine the network address.

a. Enter the missing information into the table below:

Description

Decimal

Binary

IP Address

172.16.145.29

10101100.00010000.10010001.00011101

Subnet Mask

255.255.0.0

11111111.11111111.00000000.00000000

Network Address

172.16.0.0
172.16.0.0

10101100.00010000.00000000.00000000

b. Enter the missing information into the table below:

Description

Decimal

Binary

IP Address

192.168.10.10

11000000.10101000.00001010.00001010

Subnet Mask

255.255.255.0

11111111.11111111.11111111.00000000

Network Address

   

c. Enter themissing information into the table below:

Description

Decimal

Binary

IP Address

192.168.68.210

11000000.10101000.01000100.11010010

Subnet Mask

255.255.255.128

11111111.11111111.11111111.10000000

Network Address

 

d. Enter the missing information into the table below:

Description

Decimal

Binary

IP Address

172.16.188.15

10101100.00010000.10111100.00001111

Subnet Mask

255.255.240.0

11111111.11111111.11110000.00000000

Network Address

 

e. Enter the missing information into the table below:

Network Address   e. Enter the missing information into the table below: www.nixtrain.com Page 2
Network Address   e. Enter the missing information into the table below: www.nixtrain.com Page 2
Network Address   e. Enter the missing information into the table below: www.nixtrain.com Page 2
Network Address   e. Enter the missing information into the table below: www.nixtrain.com Page 2

Description

Decimal

Binary

IP Address

10.172.2.8

00001010.10101100.00000010.00001000

Subnet Mask

255.224.0.0

11111111.11100000.00000000.00000000

Network Address

 

Part 3:

Apply Network Address Calculations

In Part 3, you must calculate the network address for the given IP addresses and subnet masks. After you have the network address, you should be able to determine the responses needed to complete the lab.

Step 1:

Determine whether IP addresses are on same network.

a. You are configuring two PCs for your network. PC-A is given an IP address of 192.168.1.18, and PC- B is given an IP address of 192.168.1.33. Both PCs receive a subnet mask of 255.255.255.240.

What is the network address for PC-A?

What is the network address for PC-B?

Will these PCs be able to communicate directly with each other?

What is the highest address that can be given to PC-B that allows it to be on the same network as PC-A?

192.168.1.16 192.168.1.32 No
192.168.1.16
192.168.1.32
No

192.168.1.30

b. You are configuring two PCs for your network. PC-A is given an IP address of 10.0.0.16, and PC-B is given an IP address of 10.1.14.68. Both PCs receive a subnet mask of 255.254.0.0.

What is the network address for PC-A?

What is the network address for PC-B?

Will these PCs be able to communicate directly with each other?

What is the lowest address that can be given to PC-B that allows it to be on the same network as PC- A?

Step 2:

Identify the defaultgateway address.

a. Your company has a policy to use the first IP address in a network as the defaultgateway address. A host on the local-area network (LAN) has an IP address of 172.16.140.24 and a subnet mask of

255.255.192.0.

What is the network address for this network?

172.16.128.0

What is the defaultgateway address for this host?

172.16.128.1

b. Your company has a policy to use the first IP address in a network as the defaultgateway address. You have been instructed to configure a new server with an IP address of 192.168.184.227 and a subnet mask of 255.255.255.248.

What is the network address for this network?

What is the defaultgateway for this server?

What is the network address for this network? What is the defaultgateway for this server? www.nixtrain.com
What is the network address for this network? What is the defaultgateway for this server? www.nixtrain.com
What is the network address for this network? What is the defaultgateway for this server? www.nixtrain.com
What is the network address for this network? What is the defaultgateway for this server? www.nixtrain.com

Lab 2. Calculating IPv4 Subnets

Lab Objectives

Part 1: Determine IPv4 Address Subnetting

Determine the network address.

Determine the broadcast address.

Determine the number of hosts.

Part 2: CalculateIPv4 Address Subnetting

Determine the number of subnets created.

Determine number of hosts per subnet.

Determine the subnet address.

Determine the host range for the subnet.

Determine the broadcast address for the subnet.

Lab Required Resources

1 PC (Windows 7, Vista, or XP with Internet access)

Optional: IPv4 address calculator

Lab Solution

Part 1:

Determine IPv4 Address Subnetting

In Part 1, you will determine the network and broadcast addresses, as well as thenumber of hosts, given an IPv4 address and subnet mask.

REVIEW: To determine the network address, perform binary ANDing on the IPv4 address using the subnet mask provided. The result will be the network address. Hint: If the subnet mask has decimal value 255 in an octet, the result will ALWAYS be the original value of that octet. If the subnet mask has decimal value 0 in an octet, the result will ALWAYS be 0 for that octet.

Example:

IP Address

192.168.10.10

Subnet Mask

255.255.255.0

==========

Result (Network)

192.168.10.0

Knowing this, you may only have to perform binary ANDing on an octet that does not have 255 or 0 in its subnet mask portion.

Example:

IP Address

172.30.239.145

Subnet Mask

255.255.192.0

Analyzing this example, you can see that you only have to perform binary ANDing on the third octet. The first two octets will result in 172.30due to the subnet mask. The fourth octet will result in 0 due to the subnet mask.

IP Address

172.30.239.145

Subnet Mask

255.255.192.0

==========

Result (Network)

172.30.?.0

Perform binary ANDing on the third octet.

 

Decimal

Binary

239

11101111

192

11000000

 

=======

Result

192

11000000

Analyzing this example again produces the following result:

IP Address

172.30.239.145

Subnet Mask

255.255.192.0

==========

Result (Network)

172.30.192.0

Continuing with this example, determining the number of hosts per network can be calculated by analyzing the subnet mask. The subnet mask will be represented in dotted decimal format, such as 255.255.192.0, or in network prefix format, such as /18. An IPv4 address always has 32 bits. Subtracting the number of bits used for the network portion (as represented by the subnet mask) gives you the number of bits used for hosts.

Using our example above, the subnet mask 255.255.192.0 is equivalent to /18 in prefix notation. Subtracting 18 network bits from 32 bits results in 14 bits left for the host portion. From there, it is a simple calculation:

2 (number of host bits) -2 = Number of hosts

2 14 = 16,384 – 2 = 16,382 hosts

Determine the network and broadcast addresses and number of host bits and hosts for the given IPv4 addresses and prefixes in the following table.

   

Total

IPv4

Total Number of Host Bits

Number of

Address/Prefix

Network Address

Broadcast Address

Hosts

192.168.100.25/28

192.168.100.16

192.168.100.31

4
4
14
14

172.30.10.130/30

   

10.1.113.75/19

   

198.133.219.250/24

   

128.107.14.191/22

   

172.16.104.99/27

   

Part 2:

Calculate IPv4 Address Subnetting

When given an IPv4 address, the original subnet mask and the new subnet mask, you will be able to determine:

Network address of this subnet

Broadcast address of this subnet

Range of host addresses of this subnet

Number of subnets created

Number of hosts per subnet

The following example shows a sample problem along with the solution for solving this problem:

Given:

Host IP Address:

172.16.77.120

Original Subnet Mask

255.255.0.0

New Subnet Mask:

255.255.240.0

Find:

Number of Subnet Bits

4

Number of Subnets Created

16

Number of Host Bits per Subnet

12

Number of Hosts per Subnet

4,094

Network Addressof this Subnet

172.16.64.0

IPv4 Address of First Host on this Subnet

172.16.64.1

IPv4 Address of Last Host on this Subnet

172.16.79.254

IPv4 Broadcast Address on this Subnet

172.16.79.255

Let’s analyze how this table was completed.

The original subnet mask was 255.255.0.0 or /16. The new subnet mask is 255.255.240.0 or /20. The resulting difference is 4 bits. Because 4 bits were borrowed, we can determine that 16 subnets were created because 2 4 = 16.

The new mask of 255.255.240.0 or /20 leaves 12 bits for hosts. With 12 bits left for hosts, we use the following formula: 2 12 = 4,096 – 2 = 4,094 hosts per subnet.

Binary ANDing will help you determine the subnet for this problem, which results in the network

172.16.64.0.

Finally, you need to determine the first host, last host, and broadcast address for each subnet. One method to determine the host range is to use binary math for the host portion of the address. In our example, the last 12 bits of the address is the host portion. The first host would have all significant bits set to zero and the least significant bit set to 1. The last host would have all significant bits set to 1 and the least significant bit set to 0. In this example, the host portion of the address resides in the 3 rd and 4 th octets.

Description

1 st Octet

2 nd Octet

3 rd Octet

4 th Octet

Description

Network/Host

nnnnnnnn

nnnnnnnn

nnnnhhhh

hhhhhhhh

Subnet Mask

Binary

10101100

00010000

01000000

00000001

First Host

Decimal

172

16

64

1

First Host

Binary

10101100

00010000

01001111

11111110

Last Host

Decimal

172

16

79

254

Last Host

Binary

10101100

00010000

01001111

11111111

Broadcast

Decimal

172

16

79

255

Broadcast

Step 1:

Fill out the tables below with appropriate answers given the IPv4 address, original subnet mask, and new subnet mask.

a. Problem 1:

 

Given:

Host IP Address:

192.168.200.139

Original Subnet Mask

255.255.255.0

New Subnet Mask:

255.255.255.224

Find:

Number of Subnet Bits

3
3

Number of Subnets Created

8
8

Number of Host Bits per Subnet

5
5

Number of Hosts per Subnet

30
30

Network Addressof this Subnet

192.168.200.128

IPv4 Address of First Host on this Subnet

192.168.200.129

IPv4 Address of Last Host on this Subnet

192.168.200.158

IPv4 Broadcast Address on this Subnet

192.168.200.159

b. Problem 2:

 
 

Given:

Host IP Address:

10.101.99.228

Original Subnet Mask

255.0.0.0

New Subnet Mask:

255.255.128.0

Find:

Number of Subnet Bits

Number of Subnets Created

Number of Host Bits per Subnet

Number of Hosts per Subnet

Network Addressof this Subnet

IPv4 Address of First Host on this Subnet

IPv4 Address of Last Host on this Subnet

IPv4 Broadcast Address on this Subnet

c. Problem 3:

 

Given:

Host IP Address:

172.22.32.12

Original Subnet Mask

255.255.0.0

New Subnet Mask:

255.255.224.0

Find:

Number of Subnet Bits

 

Number of Subnets Created

 

Number of Host Bits per Subnet

 

Number of Hosts per Subnet

 

Network Addressof this Subnet

 

IPv4 Address of First Host on this Subnet

 

IPv4 Address of Last Host on this Subnet

 

IPv4 Broadcast Address on this Subnet

 

d. Problem 4:

 
 

Given:

Host IP Address:

192.168.1.245

Original Subnet Mask

255.255.255.0

New Subnet Mask:

255.255.255.252

Find:

Number of Subnet Bits

 

Number of Subnets Created

 

Number of Host Bits per Subnet

 

Number of Hosts per Subnet

 

Network Addressof this Subnet

 

IPv4 Address of First Host on this Subnet

 

IPv4 Address of Last Host on this Subnet

 

IPv4 Broadcast Address on this Subnet

 

e. Problem 5:

 

Given:

Host IP Address:

128.107.0.55

Original Subnet Mask

255.255.0.0

New Subnet Mask:

255.255.255.0

Find:

Number of Subnet Bits

 

Number of Subnets Created

 

Number of Host Bits per Subnet

 

Number of Hosts per Subnet

 

Network Addressof this Subnet

 

IPv4 Address of First Host on this Subnet

 

IPv4 Address of Last Host on this Subnet

 

IPv4 Broadcast Address on this Subnet

 

f.

Problem 6:

 
 

Given:

Host IP Address:

192.135.250.180

Original Subnet Mask

255.255.255.0

New Subnet Mask:

255.255.255.248

Find:

Number of Subnet Bits

 

Number of Subnets Created

 

Number of Host Bits per Subnet

 

Number of Hosts per Subnet

 

Network Addressof this Subnet

 

IPv4 Address of First Host on this Subnet

 

IPv4 Address of Last Host on this Subnet

 

IPv4 Broadcast Address on this Subnet

 

Lab 3. Ethernet Cabling

1. Topologi

-

2. Tujuan

Cr imping kabel UTP menggunakan menggunak connector RJ45

Idetentifikasi perangkat Crimping

Crimping kabel dengan standar yang benar.

3. Konfigurasi

Kupas pembungkus luar kabel UTP

Urutkan warna kabel sesuai yang ditentukan (Crossover / Straight-throught)

Pastikan tidak ada kabel yang saling tindih didalmnya

Potong ujung kabel dengan panjang yang sesuai dengan konektor RJ45

Masukkan kabel ke konektor RJ45

Tekan menggunakan tang Crimping

4. Verifikasi

Test menggunakan kabel tester

5. Exam Notes

Gunakan standar yang benar dalam Crimping kabel UTP Straight-through ataupun cross-over

Ethernet Cabling

Ethernet cabling merupakan bahasana yang penting, khususnya untuk anda yang akan mengambil cisco exam. Tiga tipe kabel ethernet yang ada saat ini :

Straight-through

Crossover

Rollover

Straight-through

Straigh through digunakan untuk mengkoneksikan :

Host switch/hub

Router switch/hub

empat pin kabel yang digunakan pada straigh through untuk mengkoneksikan ethernet device. Sangat mudah jika kita akan membuatnya. Gambar dibawah ini adalah empat kabel yang digunakan pada straigh through ethernet kabel.

Hanya pin 1,2,3, dan 6 yang digunakan, koneksikan 1-1,2-2,3-3, dan 6-6 jaringan akan up dengan singkat. Tetapi perlu diingat, hal diatas hanya dapat bekerja pada ethernet dan tidak dapat bekerja pada voice, token ring, ISDN, dll.

Gambar 1. Staight through ethernet kabel Crossover Crossover digunakan untuk mengkoneksikan :  Switch –

Gambar 1. Staight through ethernet kabel

Crossover

Crossover digunakan untuk mengkoneksikan :

Switch switch

Hub hub

Host host

Hub switch

Router host

Sama dengan straight-trough, yang digunakan hanya empat pin. Perbadaannya disini adalah pin 1-3,2-6,3-1, dan 6-2.

pin. Perbadaannya disini adalah pin 1-3,2-6,3-1, dan 6-2. Gambar 2. Crossover ethernet kabel Rollover Rollover kabel

Gambar 2. Crossover ethernet kabel

Rollover

Rollover kabel digunakan untuk untuk mengkoneksikan host ke router console serial communication (com) port. Jika kita memiliki router atau switch. Kita bisa gunakan rollover kabel untuk mengkonfigurasi device tersebut. Delapan pin digunakan pada konektor ini. Dapat kita lihat seperti gambar dibawah ini.

tersebut. Delapan pin digunakan pada konektor ini. Dapat kita lihat seperti gambar dibawah ini. www.nixtrain.com 2

Gambar 3. Rollover ethernet kabel

C rimping tool

Gambar 3. Rollover ethernet kabel C rimping tool www.nixtrain.com 3
Gambar 3. Rollover ethernet kabel C rimping tool www.nixtrain.com 3

Lab 4. Basic Router (Basic Command)

1. Topologi

Lab 4. Basic Router (Basic Command) 1. Topologi 2. Tujuan  Setting IP Address pada PC1,

2. Tujuan

Setting IP Address pada PC1, PC2, PC3, PC4, PC5

Setting hostname pada R0, R1, R2, R3, R4, R5

Setting password exec pada R0, R1, R2, R3, R4, R5

Setting password console pada R0, R1, R2, R3, R4, R5

Setting password virtual terminal (vty) pada R0, R1, R2, R3, R4, R5

Setting service password encryption pada R0, R1, R2, R3, R4, R5

Setting banner MOTD pada R0, R1, R2, R3, R4, R5

Setting description pada R0 interface f0/0, f1/0, f2/0, f3/0, f4/0, f5/0

Setting IP Adress pada setiap interface yang terhubung di R0, R1, R2, R3, R4, R5

3. Konfigurasi

Setting IP Address pada PC1

Setting hostname pada R1

Setting password exec pada R1

Setting password console pada R1

Setting password virtual terminal (vty) pada R1

Setting service password encryption pada R1

Setting banner MOTD pada R1

Setting description pada R1 interface f0/0, f1/0

Setting IP Adress pada setiap interface yang terhubung di R1

Aktifkan interface yang telah ter assign IP Address pada R1

Simpan konfigurasi pada R1

4. Verifikasi

Konfigurasi R1 menggunakan console

Konfigurasi R1 menggunakan vty (telnet)

Tampilkan IP Address yang telah ter assign pada interface di R1

Kembali ke USER EXEC mode untuk melihat banner pada R1

Tampilkan seluruh konfigurasi di R1

5. Exam Notes

Berikan login setelah setting password console dan vty

Aktifkan interface setelah assign IP Address

Saat memberikan description pastikan pada interface yang benar

Simpan konfigurasi ketika selesai mengkonfigurasi perangkat (router/switch)

Lakukan konfigurasi dengan langkah yang sama pada PC2, PC3, PC4, PC5 dan R0, R2, R3, R4, R5

Table IP Address pada topologi diatas

Device

Interface

IP Address

Gateway

Subnetmask

PC1

NIC

192.168.1.3

192.168.1.1

255.255.255.0

PC2

NIC

192.168.2.3

192.168.2.1

255.255.255.0

PC3

NIC

192.168.3.3

192.168.3.1

255.255.255.0

PC4

NIC

192.168.4.3

192.168.4.1

255.255.255.0

PC5

NIC

192.168.6.3

192.168.6.1

255.255.255.0

 

F0/0

15.15.15.5

NA

255.255.255.0

F1/0

25.25.25.5

NA

255.255.255.0

R0

F2/0

35.35.35.5

NA

255.255.255.0

F3/0

45.45.45.5

NA

255.255.255.0

 

F4/0

65.65.65.5

NA

255.255.255.0

F5/0

10.0.0.1

NA

255.255.255.0

R1

F0/0

192.168.1.1

NA

255.255.255.0

F1/0

15.15.15.1

NA

255.255.255.0

R2

F0/0

192.168.2.1

NA

255.255.255.0

F1/0

25.25.25.1

NA

255.255.255.0

R3

F0/0

192.168.3.1

NA

255.255.255.0

F1/0

35.35.35.1

NA

255.255.255.0

R4

F0/0

192.168.4.1

NA

255.255.255.0

F1/0

45.45.45.1

NA

255.255.255.0

R5

F0/0

192.168.6.1

NA

255.255.255.0

F1/0

65.65.65.1

NA

255.255.255.0

Server

NIC

10.0.0.5

10.0.0.1

255.255.255.0

Konfigurasi IP address di PC 1

Konfigurasi IP address di PC 1 Pada packet tracer, untuk konfigurasi PC, laptop, server yaitu dengan

Pada packet tracer, untuk konfigurasi PC, laptop, server yaitu dengan klik device yang akan kita setting. Kemudian klik tab Desktop selanjutnya pilih menu IP Configuration, maka akan keluar tampilan seperti diatas. Pilih static ketika IP Address sesuai dengan apa yang akan kita inputkan & DHCP ketika suatu device ingin me request dari DHCP server (mendapatkan IP Address) otomatis dari DHCP Server.

System configuration dialog

--- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]:

System configuration dialog ini berfungsi ketika kita pilih yes maka kita akan mendapatkan panduan untuk basic configuration pada suatu router atau switch. Jika memilih no maka kita akan masuk ke User EXEC mode.

Konfigurasi hostname pada R1

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R1

R1(config)#

www.nixtrain.com

3

Global configuration adalah mode dimana kita konfigurasi suatu device dan akan berdampak pada seluruh device tersebut. Contoh disini kita setting hostname, maka pada router atau switch yang kita konfigurasi hostnamenya akan berubah pada router tersebut,

Konfigurasi password EXEC pada R1

R1(config)#enable secret R1

Pada lab ini, password exec yang akan kita gunakan adalah RX dimana X disini adalah nomor masing-masing router. Misal R1, R2, dst. Untuk konfigurasi password exec, kita masuk pada global configuration mode. Dan password exec sendir, akan kita inputkan ketika akan memasuki privillaged exec mode

Konfigurasi password console pada R1

R1(config)#line console 0

R1(config-line)#password class

R1(config-line)#login

Pada cisco router terdapat empat mode. Dalam konfigurasi password console, kita harus masuk pada mode specific (line) atau pada router sering ditandakan dengan R1(config-line)# . sebelum masuk ke mode specific (line) atau mode specific yang lainnya. Kita harus masuk pada global configuration mode terlebih dahulu. Dalam lab kali ini, R0 sampai dengan R6 akan kita berikan password class . dalam cisco packet tracer atau rela device, ketika kita telah konfigurasi password console dan selanjutnya kita berikan login maka saat kita akan mengkonfigurasi router atau switch menggunakan console cable router atau switch akan meminta password yang telah dikonfigurasikan. Atau dalam packet tracer digambarkan seperti dibawah ini.

Atau dalam packet tracer digambarkan seperti dibawah ini. Konfigurasi password virtual terminal (vty) pada R1

Konfigurasi password virtual terminal (vty) pada R1

R1(config)#line vty 0 4

R1(config-line)#password cisco

R1(config-line)#login

Fungsi dari konfigurasi password virtual terminal (vty) ini sendiri adalah untuk konfigurasi secara remote atau jarak jauh maka router akan meminta password vty/virtual terminal.

Untuk konfigurasi secara remote kita harus terkoneksi ke device yang akan kita remote terlebih dahulu. Untuk testing konektifitas kita dapat menggunakan command ping <alamat tujuan/IP Address tujuan>. Maksud dari command line vty 0 4 sendiri adalah angka 0 s/d 4 sendiri memiliki quota 5 yaitu 0,1,2,3,4,5. Oleh sebab itu user yang aktif dalam sekali remote bisa dilakukan secara bersamaan adalah 5 user. Untuk mode yang digunakan sama ketika konfigurasi password console.

Konfigurasi service password encryption pada R1

R1(config)#service password-encryption

Command ini digunakan untuk mengenkripsi semua password yang belum kita enkrip. Seperti contoh diatas, password vty dan console tidak kita setting untuk enkripsi atau hidden password.

Konfigurasi banner MOTD pada R1

R1(config)#banner motd %Welcome to R1%

Banner motd sendiri berfungsi untuk memberikan message kepada user yang sedang melakukan konfigurasi pada router. Pada lab ini, setiap router akan diberikan banner Welcome to RX” X disini mewakili dari nama router masing-masing. Contoh “Welcome to R1”. Dalam penulisan command diatas, message yang akan disampaikan akan diapit dengan tanda

% %

of The Day.

atau biasa disebut dengan delimiter. MOTD sendiri merupakan singkatan dari Message

Konfigurasi description pada R1 di interface F0/0 dan F1/0

R1(config)#interface f0/0

R1(config-if)#description Line to Access Layer or User

R1(config-if)#interface f1/0

R1(config-if)#description Line to Core Layer or R0

Interface description disini berfungsi memberikan deskripsi dari suatu interface, dalam implementasinya sangat membantu ketika dalam satu router terdapat banyak interface. Maka dengan mudah kita identifikasi interace tersebut melalui interfae description ini. Untuk memberikan interface description kita harus masuk pada mode specific (interface) atau biasa ditunjukkan dengan R1(config-if)#

Konfigurasi IP Address pada R1 di interface F0/0 dan F1/0

R1(config)#interface f0/0

R1(config-if)#ip address 192.168.1.1 255.255.255.0

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

R1(config-if)#interface fastEthernet 1/0

R1(config-if)#ip address 15.15.15.1 255.255.255.0

R1(config-if)#no sh

R1(config-if)#

%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up

Untuk konfigurasi IP Address disuatu router, langkah awal yang harus kita perhatikan adalah port/interface yang sedang kita gunakan (di port berapakah kita mengkoneksikan router tersebut ?) karena sebelum setting IP Address kita harus masuk ke interface terlebih dahulu. Pada Lab diatas khusunya di R1, kita gunakan interface f0/0 yang mengarah ke User dan f1/0 yang mengarah ke R0 atau router tetangganya (core layer). Format perintah yang dituliskan dalam setting IP Address adalah ip address <ip host> <subnet mask>. Contoh pada studi kasus diatas adalah ip address 15.15.15.1 255.255.255.0 . jika yang kita assign ip address bukan interface virtual (loopback) maka kita perlu merestart inteface terlebih dulu dengan perintah no shutdown.

Simpan konfigurasi R1

R1#copy running-config startup-config

Destination filename [startup-config]?

Building configuration

[OK]

R1#

Perintah yang digunakan yaitu copy running-config startup-config atau bisa kita singkat dengan copy run start

Testing konfigurasi R1 dengan console

Testing konfigurasi R1 dengan console Dalam kotak merah diatas menunjukkan bahwa router R1 dapat kita access

Dalam kotak merah diatas menunjukkan bahwa router R1 dapat kita access dengan menggunakan console yaitu con0 dan pada packet tracer kita dapat masuk pada device PC/Laptop dan masuk pada tab Desktop selanjutnya pilih Terminal. Selanjutnya akan terlihat seperti tampilan diatas yang memerlukan password console untuk melakukan konfigurasi.

Testing konfigurasi R1 dengan vty (telnet)

memerlukan password console untuk melakukan konfigurasi. Testing konfigurasi R1 dengan vty (telnet) www.nixtrain.com 7

Gambar diatas menunjukkan dengan menggunakan telnet kita akan konfigurasi router (R1). Ditegaskan lagi syarat untuk melakukan remote configuration adalah kita harus terkoneksi dengan router atau switch tujuan kita dan selanjutnya kita setting password exec serta password vty lalu kita berikan login untuk password vty tersebut.

Menampilkan IP address setiap interface di R1

R1#show ip interface brief

Interface

IP-Address

OK? Method Status

Protocol

FastEthernet0/0

192.168.1.1

YES manual up

up

FastEthernet1/0

15.15.15.1

YES manual up

down

Serial2/0

unassigned

YES unset administratively down

down

Serial3/0

unassigned

YES unset administratively down

down

FastEthernet4/0

unassigned

YES unset administratively down

down

FastEthernet5/0

unassigned

YES unset administratively down

down

Perintah yang digunakan untuk menampilkan yaitu show ip interface brief. Ketika kita berada pada diatas privillaged exec mode kita dapat menambahkan perintah do sebeleum perintah show ip interface brief. Contoh (pada global configuration mode) : R1(config)# do show ip interface brief. Maka hasilnya akan sama seperti diatas.

Banner MOTD pada User EXEC Mode

do show ip interface brief. Maka hasilnya akan sama seperti diatas. Banner MOTD pada User EXEC

Banner motd yang telah kita setting akan keluar ketika router dihidupkan kembali atau ketika akan memasuki User EXEC Mode.

Konfigurasi di R1

Press RETURN to get started!

Welcome to R1

User Access Verification

Password:

R1>en

Password:

R1#show run

Building configuration

Current configuration : 854 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

service password-encryption

!

hostname R1

!

!

!

enable secret 5 $1$mERr$jzzeYSszI5tIEoAh2kGm0/

!

!

www.nixtrain.com

9

interface FastEthernet0/0

description Line to Access Layer or User

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet1/0

description Line to Core Layer or R0

ip address 15.15.15.1 255.255.255.0

duplex auto

speed auto

!

interface Serial2/0

no ip address

shutdown

!

interface Serial3/0

no ip address

shutdown

!

interface FastEthernet4/0

no ip address

shutdown

!

interface FastEthernet5/0

no ip address

shutdown

!

ip classless

!

! ! ! banner motd ^CWelcome to R1^C ! ! ! ! line con 0
!
!
!
banner motd ^CWelcome to R1^C
!
!
!
!
line con 0
password 7 0822404F1A0A
login
!
line aux 0
!
line vty 0 4
password 7 0822455D0A16
login
!
!
!
end
R1#

Konfigurasi pada R1 yang telah kita masukkan ditandai dengan cetak tebal (BOLD)

Lab 5. Static Routing & Default Route

1. Topologi

Lab 5. Static Routing & Default Route 1. Topologi 2. Tujuan  Setiing IP Address pada

2. Tujuan

Setiing IP Address pada PC1, PC2, PC3

Menambahkan interface serial pada router R1, R2, R3

Setting IP address pada setiap interface yang berada pada router R1, R2, R3

Me routingkan network yang berada di router R1, R2, R3 menggunakan next-hope ataupun exit-interface

3. Konfigurasi

Setting IP Address pada PC 1

Menambahkan interface serial pada R1

Setting IP address R1 di interface F0/0 dan S2/0

Setting IP address R2 di interface F0/0, S2/0, dan S3/0

Setting IP address R3 di interface F0/0 dan S3/0

4. Verifikasi

Test ping dari PC1 ke PC2

Test ping dari PC2 ke PC3

Test ping dari PC3 ke PC1

Menampilkan table routing pada R1

Menampilkan table routing pada R2

Menampilkan table routing pada R3

5. Exam Notes

Static routing penulisannya menggunakan IP Network bukan IP Host

Metode yang dapat digunakan adalah next-hope atau exit-interface

Lakukan konfigurasi yang sama untuk PC2, PC3 dan R2, serta R3

www.nixtrain.com

Table IP Address

Device

Interface

IP Address

Subnet Mask

Gateway

R1

F0/0

192.168.1.1

255.255.255.0

NA

S2/0

192.168.5.1

255.255.255.0

NA

 

F0/0

192.168.2.1

255.255.255.0

NA

R2

S2/0

192.168.4.1

255.255.255.0

NA

S3/0

192.168.5.2

255.255.255.0

NA

R3

F0/0

192.168.3.1

255.255.255.0

NA

S3/0

192.168.4.2

255.255.255.0

NA

PC1

NIC

192.168.1.10

255.255.255.0

192.168.1.1

PC2

NIC

192.168.2.10

255.255.255.0

192.168.2.1

PC3

NIC

192.168.3.10

255.255.255.0

192.168.3.1

Router

Router sering digunakan untuk menghubungkan beberapa network. Baik network yang sama maupun berbeda dari segi teknologinya. Router juga digunakan untuk membagi network besar menjadi beberapa buah subnetwork (network-network kecil).

Routing

Sebuah router memiliki kemampuan routing. Routing adalah sebuah proses untuk meneruskan paket-paket dari satu jaringan ke jaringan lainnya melalui sebuah antar- jaringan (internetwork). Artinya router dapat mengetahui kemana rute perjalanan informasi (yang disebut packet) akan dilewatkan. Apakah ditujukan untuk host lain yang satu network atau berbeda network. Jika paketpaket ditujukan untuk host pada network yang lain maka router akan meneruskannya ke network tersebut. Sebaliknya, jika paket-paket ditujukan untuk host yang satu network maka router akan menghalangi paket-paket keluar, sehingga paket-paket tersebut tidak “membanjiri” network yang lain.

Terdapat dua macam routing, yaitu:

Routing Static

Routing Dynamic

Routing Static

Routing static memerlukan campur tangan network administrator dalam penentuan rute. Routing static adalah bentuk routing yang terjadi ketika router menggunakan entri routing yang dikonfigurasi secara manual oleh network administrator. Routing static tidak seperti routing dinamis, rute static tetap dan tidak berubah jika jaringan berubah.

www.nixtrain.com

Kegunaan

Routing static memiliki kegunaan sebagai berikut :

Routing static dapat digunakan untuk menentukan jalur keluar dari router ketika tidak ada rute lain yang tersedia atau diperlukan. Ini disebut default route.

Routing static dapat digunakan untuk jaringan kecil yang membutuhkan hanya satu atau dua rute.

Routing static sering digunakan untuk membantu mengirim informasi routing dari satu routing protocol ke routing protocok yang lain (routing redistribusi). Kekurangan

Routing static memiliki kekurangan sebagai berikut :

Rute static dikonfigurasi secara manual sehingga tingkat kesalahan input oleh administrator tinggi

Rute static harus dikonfigurasi pada setiap router dalam jaringan, sehingga memakan waktu lama jika ada banyak router dan rekonfigurasi bisa lambat dan tidak efisien.

Jika salah satu jalur routing terputus maka router tidak bisa mencari alternative jalan baru untuk meneruskan paket yang dikirim

Command Routing Static

Penggunaan Next Hop

yang dikirim Command Routing Static  Penggunaan Next Hop Kelebihan menggunakan next hop dapat mencegah terjadinya

Kelebihan menggunakan next hop dapat mencegah terjadinya error dalam meneruskan paket ke router tujuan karena router telah mengetahui next hop, yaitu IP Address router tujuan. Kekurangan jika menggunakan next hop akan mengalami multiple lookup atau lookup yang berulang

Penggunaan Exit Local Interface

lookup yang berulang  Penggunaan Exit Local Interface Kelebihan menggunakan exit local interface adalah proses

Kelebihan menggunakan exit local interface adalah proses lookup hanya akan terjadi satu kali karena router akan langsung meneruskan paket ke network tujuan melalui interface yang sesuai pada routing table. Kekurangannya kemungkinan akan terjadi error ketika meneruskan paket.

Default Routing

Merupakan routing statis khusus yang digunakan ketika rute dari sumber/tujuan tidak dikenali atau tidak terdapat informasi yang cukup dalam table routing tujuan.

www.nixtrain.com

Konfigurasi IP Address PC1 Konfigurasi hostname dan password EXEC di R1 Router>enable Router#configure terminal

Konfigurasi IP Address PC1

Konfigurasi IP Address PC1 Konfigurasi hostname dan password EXEC di R1 Router>enable Router#configure terminal

Konfigurasi hostname dan password EXEC di R1

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R1

R1(config)#enable secret R1

Konfigurasi IP Address di R1 (Sesuai table IP Address di atas)

R1(config)#interface fastEthernet 0/0

R1(config-if)#ip address 192.168.1.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0,

changed state to up

R1(config-if)#exit

R1(config)#int se2/0

R1(config-if)#ip add 192.168.5.1 255.255.255.0

R1(config-if)#no sh

www.nixtrain.com

%LINK-5-CHANGED: Interface Serial2/0, changed state to down

R1(config-if)#clock rate 64000

R1(config-if)#exit

4

Konfigurasi IP Address di R2 (Sesuai table IP Address di atas)

R2(config)#interface fastEthernet 0/0

R2(config-if)#ip address 192.168.2.1 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0,

changed state to up

R2(config-if)#exit

R2(config)#interface serial 3/0

R2(config-if)#ip address 192.168.5.2 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)#

%LINK-5-CHANGED: Interface Serial3/0, changed state to up

R2(config-if)#exit

R2(config)#interface serial 2/0

R2(config-if)#ip address 192.168.4.1 255.255.255.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial2/0, changed state to down

R2(config-if)#clock rate 64000

R2(config-if)#exit

Konfigurasi IP Address di R3 (Sesuai table IP Address di atas)

R3(config)#interface fastEthernet 0/0

R3(config-if)#ip address 192.168.3.1 255.255.255.0

R3(config-if)#no shutdown

R3(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0,

www.nixtrain.com

changed state to up

R3(config-if)#exit

5

R3(config-if)#no shutdown

R3(config-if)#

%LINK-5-CHANGED: Interface Serial3/0, changed state to up

R3(config-if)#exit

Konfigurasi static routing di R1 (next-hope)

R1(config)#ip route 192.168.2.0 255.255.255.0 192.168.5.2

R1(config)#ip route 192.168.3.0 255.255.255.0 192.168.5.2

R1(config)#ip route 192.168.4.0 255.255.255.0 192.168.5.2

Konfigurasi static routing di R2 (next-hope)

R2(config)#ip route 192.168.1.0 255.255.255.0 192.168.5.1

R2(config)#ip route 192.168.3.0 255.255.255.0 192.168.4.2

R2(config)#exit

Konfigurasi static routing di R3

R3(config)#ip route 192.168.1.0 255.255.255.0 192.168.4.1

R3(config)#ip route 192.168.2.0 255.255.255.0 192.168.4.1

R3(config)#ip route 192.168.5.0 255.255.255.0 192.168.4.1

Menampilkan table routing di R1

R1#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile,

B

- BGP

D

- EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter

area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external

type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E -EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia -IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

www.nixtrain.com

P - periodic downloaded static route

Gateway of last resort is not set

6

C 192.168.1.0/24 is directly connected, FastEthernet0/0

S

192.168.4.0/24 [1/0] via 192.168.5.2

C

192.168.5.0/24 is directly connected, Serial2/0

Menampilkan table routing di R2

R2#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile,

B

- BGP

D

- EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter

area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external

type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E -EGP

i

- IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia -IS-IS inter area

*

- candidate default, U - per-user static route, o - ODR

P

- periodic downloaded static route

Gateway of last resort is not set

S

192.168.1.0/24 [1/0] via 192.168.5.1

C

192.168.2.0/24 is directly connected, FastEthernet0/0

S

192.168.3.0/24 [1/0] via 192.168.4.2

C

192.168.4.0/24 is directly connected, Serial2/0

C

192.168.5.0/24 is directly connected, Serial3/0

Menampilkan table routing di R3

R3#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile,

B

- BGP

D

- EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

www.nixtrain.com

7

E1 - OSPF external type 1, E2 - OSPF external type 2, E -EGP

S

192.168.1.0/24 [1/0] via 192.168.4.1

S

192.168.2.0/24 [1/0] via 192.168.4.1

C

192.168.3.0/24 is directly connected, FastEthernet0/0

C

192.168.4.0/24 is directly connected, Serial3/0

S

192.168.5.0/24 [1/0] via 192.168.4.1

Test konektivitas dari PC1 ke PC2, PC2 ke PC3, dan PC3 ke PC1

www.nixtrain.com

Lab 1. Basic Switch (Basic Command)

1. Topologi

Lab 1. Basic Switch (Basic Command) 1. Topologi 2. Tujuan  Basic switch configuration  Konfigurasi

2. Tujuan

Basic switch configuration

Konfigurasi switch via console

Konfigurasi switch via vty

Menyimpan running configuration

3. Konfigurasi

Setting hostname pada Switch0

Setting password encription pada Switch0

Setting pencegahan DNS lookup pada Switch0

Setting banner MOTD pada Switch0

Setting VLAN 99 pada Switch0

Setting semua port ke VLAN 99 pada Switch0

Setting password console pada Switch0

Setting password telnet (vty) pada Switch0

Simpan konfigurasi pada Switch0

4. Verifikasi

Verifikasi default switch configuration (enable)

Verifikasi default switch configuration (show startup config)

Verifikasi default switch configuration (show interface vlan 1)

Verifikasi default switch configuration (show version)

Test ping PC0 ke Switch0 (VLAN 99)

Test konfigurasi menggunakan telnet

Test konfigurasi menggunakan console

5. Exam Notes

Berikan login setelah memberikan password console dan vty

Interface VLAN pada switch dapat diberikan/assign IP Address

Interface fisik pada switch tidak dapat diberikan/assign IP Address

Table IP Address pada topologi diatas

Device

Interface

IP Address

Subnet Mask

Default Gateway

SW1

VLAN 99

192.168.1.2

255.255.255.0

-

PC0

NIC

192.168.1.10

255.255.255.0

-

Verifikasi Default Switch Configuration

Pada langkah ini, kita akan memeriksa default switch setting, seperti current switch configuration, IOS information, Interface properties, VLAN information, dan flash memory.

a. Diasumsikan suatu switch tidak memiliki file konfigurasi di NVRAM, kita sedang berada pada user EXEC mode dan akan masuk privileged EXEC mode

Switch>enable

Switch#

Unutk verifikasi configuration file yang sedang berjalan, kita dapat menginputkan command show running-config pada priveleged EXEC mode

b. Menampilkan startup configuration file pada NVRAM

Switch#show startup-config

startup-config is not present

Ketika kita memasukkan command diatas, maka tidak ada startup configuration dikarenakan belum ada file configuration yang kita simpan ke NVRAM

c. Menampilkan interface VLAN 1

Switch#show interfaces vlan 1

Vlan1 is administratively down, line protocol is down

Hardware is CPU Interface, address is 0001.435c.7485 (bia

0001.435c.7485)

MTU 1500 bytes, BW 100000 Kbit, DLY 1000000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 21:40:21, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5

minute input rate 0 bits/sec, 0 packets/sec

5

minute output rate 0 bits/sec, 0 packets/sec

1682 packets input, 530955 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

563859 packets output, 0 bytes, 0 underruns

0

output errors, 23 interface resets

0

output buffer failures, 0 output buffers swapped out

d. Menampilkan informasi cisco IOS version

Switch#show version

Cisco IOS Software, C2960 Software (C2960-LANBASE-M), Version 12.2(25)FX, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2005 by Cisco Systems, Inc.

Compiled Wed 12-Oct-05 22:05 by pt_team

ROM: C2960 Boot Loader (C2960-HBOOT-M) Version 12.2(25r)FX, RELEASE SOFTWARE (fc4)

System returned to ROM by power-on

Cisco WS-C2960-24TT (RC32300) processor (revision C0) with 21039K bytes of memory.

24 FastEthernet/IEEE 802.3 interface(s)

2 Gigabit Ethernet/IEEE 802.3 interface(s)

63488K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address

: 0001.435C.7485

Motherboard assembly number

: 73-9832-06

Power supply part number

: 341-0097-02

Motherboard serial number

: FOC103248MJ

Power supply serial number

: DCA102133JA

Model revision number

: B0

Motherboard revision number

: C0

Model number

: WS-C2960-24TT

System serial number

: FOC1033Z1EY

Top Assembly Part Number

: 800-26671-02

Top Assembly Revision Number

: B0

Version ID

: V02

CLEI Code Number

: COM3K00BRA

Hardware Board Revision Number : 0x01

Switch

Ports

Model

SW Version

SW Image

------

----- -----

----------

----------

*

1

26

WS-C2960-24TT

12.2

C2960-LANBASE-

M

Configuration register is 0xF

Setting hostname di switch0

Switch(config)#hostname Switch0

Switch0(config)#

Setting password encription

Switch0(config)#service password-encryption

Setting Pencegahan DNS lookup

Switch0(config)#no ip domain-lookup

Command no ip domain-lookup sendiri berfungsi untuk mendrop perintah yang salah ketika kita menginputkan command di switch ataupun router.

Setting Banner MOTD

Switch0(config)#banner motd #

Enter TEXT message. End with the character '#'.

Welcome to Switch0 #

Setting VLAN 99

Switch0(config)#vlan 99

Switch0(config-vlan)#name management

Switch0(config-vlan)#exit

Switch0(config)#interface vlan 99

Switch0(config-if)#

%LINK-5-CHANGED: Interface Vlan99, changed state to up

Switch0(config-if)#ip add 192.168.1.2 255.255.255.0

Vlan 99 diatas kita gunakan sebagai vlan management atau digunakan untuk remote access (telnet)

Setting semua port sebagai anggota dari VLAN 99

Switch0(config)#interface range f0/1 - 24

Switch0(config-if-range)#switchport access vlan 99

Switch0(config-if-range)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan99, changed state to up

Setting password console

Switch0(config)#line console 0

Switch0(config-line)#password ciscocon

Switch0(config-line)#login

Switch0(config-line)#exit

Switch0(config)#

Setting password virtual terminal (vty)

Switch0(config)#line vty 0 15

Switch0(config-line)#password ciscovty

Switch0(config-line)#login

Setting IP Address di PC 0

Setting IP Address di PC 0 Test konektifitas PC 0 – Switch0 (VLAN 99) www.nixtrain.com 6

Test konektifitas PC 0 Switch0 (VLAN 99)

Setting IP Address di PC 0 Test konektifitas PC 0 – Switch0 (VLAN 99) www.nixtrain.com 6

Test konfigurasi Switch0 dengan console

Test konfigurasi Switch0 dengan console Switch dapat kita access dengan menggunakan console yaitu con0 dan pada

Switch dapat kita access dengan menggunakan console yaitu con0 dan pada packet tracer kita dapat masuk pada device PC/Laptop dan masuk pada tab Desktop selanjutnya pilih Terminal. Selanjutnya akan terlihat seperti tampilan diatas yang memerlukan password console untuk melakukan konfigurasi.

Test konfigurasi Switch0 dengan virtual terminal (vty)

password console untuk melakukan konfigurasi. Test konfigurasi Switch0 dengan virtual terminal (vty) www.nixtrain.com 7

Konfigurasi di Switch0

Switch0#show running-config

Building configuration

Current configuration : 1885 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

service password-encryption

!

hostname Switch0

!

!

!

no ip domain-lookup

!

spanning-tree mode pvst

!

interface FastEthernet0/1

switchport access vlan 99

!

interface FastEthernet0/2

switchport access vlan 99

!

interface FastEthernet0/3

switchport access vlan 99

!

interface FastEthernet0/4

switchport access vlan 99

!

interface FastEthernet0/5

switchport access vlan 99

!

interface FastEthernet0/6

switchport access vlan 99

!

interface FastEthernet0/7

switchport access vlan 99

!

interface FastEthernet0/8

switchport access vlan 99

!

interface FastEthernet0/9

switchport access vlan 99

!

interface FastEthernet0/10

switchport access vlan 99

!

interface FastEthernet0/11

switchport access vlan 99

!

interface FastEthernet0/12

switchport access vlan 99

!

interface FastEthernet0/13

switchport access vlan 99

!

interface FastEthernet0/14

www.nixtrain.com

9

switchport access vlan 99

!

interface FastEthernet0/15

switchport access vlan 99

!

interface FastEthernet0/16

switchport access vlan 99

!

interface FastEthernet0/17

switchport access vlan 99

!

interface FastEthernet0/18

switchport access vlan 99

!

interface FastEthernet0/19

switchport access vlan 99

!

interface FastEthernet0/20

switchport access vlan 99

!

interface FastEthernet0/21

switchport access vlan 99

!

interface FastEthernet0/22

switchport access vlan 99

!

interface FastEthernet0/23

switchport access vlan 99

!

interface FastEthernet0/24

www.nixtrain.com

10

switchport access vlan 99

!

interface GigabitEthernet1/1

!

interface GigabitEthernet1/2

!

interface Vlan1

no ip address

!

interface Vlan99

ip address 192.168.1.2 255.255.255.0

!

banner motd ^C

Welcome to Switch0 ^C

!

line con 0

password 7 0822455D0A1606181C

login

!

line vty 0 4

password 7 0822455D0A1613030B

login

line vty 5 15

password 7 0822455D0A1613030B

login

!

!

end

Save konfigurasi ke NVRAM

Switch0#copy running-config startup-config

Destination filename [startup-config]?

Building configuration

[OK]

Switch0#

Lab 2. Backup & Restore Menggunakan TFTP

1. Topologi

Lab 2. Backup & Restore Menggunakan TFTP 1. Topologi 2. Tujuan  Backup IOS ke TFTP

2. Tujuan

Backup IOS ke TFTP server

Delete IOS pada Switch

Restore IOS dari TFTP server ke switch

3. Konfigurasi

Setting IP Address pada Server0

Setting vlan 99 (name : Management)

Assign interface f0/1 pada Switch0 ke vlan 99

Setting IP Address pada vlan 99

Backup IOS pada Switch0 ke TFTP server (Server0)

Delete IOS yang ada pada Switch0

Restore IOS dari TFTP server (server0) ke Switch0

Simpan konfigurasi pada Switch0

Reload Switch0

4. Verifikasi

Test ping dari switch0 ke server0

Test ping dari server0 ke switch0

Verifikasi IP Address pada interface vlan 99

View backup IOS di TFTP server

View IOS version di switch0

5. Exam Notes

Pastikan TFTP server dengan switch yang akan kita backup saling terkoneksi

Sebelum melakukan backup, lakukan view IOS pada switch.

Table IP Address pada topologi diatas

Device

Interface

IP Address

Subnet Mask

Default Gateway

Switch0

VLAN 99

10.10.10.1

255.255.255.0

-

Server0

NIC

10.10.10.2

255.255.255.0

-

Setting IP Address Server0

Setting IP Address Server0 Setting IP Address pada server, langkah yang dilakukan sama seperti ketika kita

Setting IP Address pada server, langkah yang dilakukan sama seperti ketika kita melakukan setting IP Address PC atau Laptop pada packet Tracer.

Membuat VLAN 99 (VLAN Management)

Switch(config)#vlan 99

Switch(config-vlan)#name management

Unutk membuat suatu vlan, dapat dilakukan langkah seperti diatas. Masuk pada Global Configuration Mode. VLAN 99 disini berfungsi sebagai VLAN Management atau dengan kata lain jika kita ingin konfigurasi switch melalui server0 (via vty) dengan catatan password vty telah tersetting.

Assign Inteface f0/1 pada Switch0 ke VLAN 99

Switch(config)#interface f0/1

Switch(config-if)#switchport access vlan 99

Setting IP Address pada VLAN 99

Switch(config-vlan)#interface vlan 99

Switch(config-if)#

%LINK-5-CHANGED: Interface Vlan99, changed state to up

Switch(config-if)#ip add 10.10.10.1 255.255.255.0

Test ping dari Switch0 ke Server0

Switch#ping 10.10.10.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms

Test connectivity dari Server0 ke Switch0 (Interface VLAN99)

Test connectivity dari Server0 ke Switch0 (Interface VLAN99) Melihat IP Address pada Switch0 (Interface VLAN 99)

Melihat IP Address pada Switch0 (Interface VLAN 99)

Switch#show ip interface vlan 99

Vlan99 is up, line protocol is up

Internet address is 10.10.10.1/24

Broadcast address is 255.255.255.255

Address determined by setup command

MTU is 1500 bytes

Helper address is not set

Directed broadcast forwarding is disabled

Melihat Versi IOS di Switch0

Switch#dir flash:

Directory of flash:/

1 -rw-

22.EA4.bin

2 -rw-

3058048

616

<no date> c2950-i6q4l2-mz.121-

<no date> vlan.dat

64016384 bytes total (60957720 bytes free)

Sebelum melakukan backup, langkah awal kita mengetahui nama file yang akan kita kita lakukan backup. Dalam kasus ini kita akan melakukan backup file IOS “c2950-i6q4l2-mz.121-

22.EA4.bin”

BackUP IOS Switch0 ke tftp Server

Switch#copy flash: tftp:

Source filename []? c2950-i6q4l2-mz.121-22.EA4.bin

Address or name of remote host []? 10.10.10.2

Destination filename [c2950-i6q4l2-mz.121-22.EA4.bin]? c2950-i6q4l2-

mz.121-22.EA4.backup.bin

Writing c2950-i6q4l2-mz.121-

22.EA4.bin

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!

[OK - 3058048 bytes]

3058048 bytes copied in 0.041 secs (74586000 bytes/sec)

Dengan perintah copy flash: tftp: selanjutnya akan keluar dialog Source filename []? Dan yang akan kita isikan dengan nama file yang akan kita backup, dan dialog selanjutnya adalah Address or name of remote host []? Yang diisikan dengan IP address tujuan tempat kita menyimpat backup file yaitu IP Address tftp server. Dan dialog yang terakhir yaitu Destination filename [c2950-i6q4l2-mz.121-22.EA4.bin]? yang berguna untuk memberikan nama file yang diupload kedalam tftp server.

Melihat file backup pada Server0 di tftp

Melihat file backup pada Server0 di tftp Unutk melihat file yang sudah kita backup, kita dapat

Unutk melihat file yang sudah kita backup, kita dapat masuk pada Server0 selanjutnya masuk pada TAB Config lalu pilih Menu TFTP. Didalam TFTP tersebut terdapat nama file yang telah kita backup sesuai dengan nama destination diatas.

Delete IOS yang berada pada Switch0

Switch#delete flash:

Delete filename []? c2950-i6q4l2-mz.121-22.EA4.bin

Delete flash:/c2950-i6q4l2-mz.121-22.EA4.bin? [confirm]

Switch#write

Building configuration

[OK]

Switch#

Verifikasi IOS di Switch0 (Setelah melakukan Delete)

Switch#show flash:

Directory of flash:/

2

-rw-

616

<no date> vlan.dat

64016384 bytes total (64015768 bytes free)

File image IOS yang awalnya terdapat pada switch0, setelah kita delete dan kita simpan konfigurasi file tersebut telah terhapus.

Restore IOS dari TFTP server di Server0 ke Switch0

Switch#copy tftp: flash:

Address or name of remote host []? 10.10.10.2

Source filename []? c2950-i6q4l2-mz.121-22.EA4.backup.bin

Destination filename [c2950-i6q4l2-mz.121-22.EA4.backup.bin]?

Accessing tftp://10.10.10.2/c2950-i6q4l2-mz.121-22.EA4.backup.bin

Loading c2950-i6q4l2-mz.121-22.EA4.backup.bin from 10.10.10.2:

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

[OK - 3058048 bytes]

3058048 bytes copied in 0.045 secs (67956622 bytes/sec)

Simpan konfigurasi & reload Switch0

Switch#copy running-config startup-config

Destination filename [startup-config]?

Building configuration

[OK]

Switch#reload

Proceed with reload? [confirm]

Restore berhasil

Loading "flash:/c2950-i6q4l2-mz.121-22.EA4.backup.bin"

######################################################################### # [OK]

Lab 3. Reset Factory default Cisco Switch

1. Topologi

Lab 3. Reset Factory default Cisco Switch 1. Topologi 2. Tujuan  Reset Switch configuration 

2. Tujuan

Reset Switch configuration

Delete file vlan.dat pada flash switch

3. Konfigurasi

Reset switch0 configuration

Reload switch0

Delete vlan.dat pada flash memory switch

4. Verifikasi

Verifikasi switch configuration (show running-config)

Verifikasi switch configuration setelah reset configuration

Verifikasi VLAN di switch0

View vlan.dat di flash memory di switch0

5. Exam Notes

Vlan.dat tempat configurasi vlan berada, contoh : vlan yang telah dibuat.

Table IP Address pada topologi diatas

Device

Interface

IP Address

Subnet Mask

Default Gateway

SW1

VLAN 99

192.168.1.2

255.255.255.0

192.168.1.1

PC0

NIC

192.168.1.10

255.255.255.0

192.168.1.1

Konfigurasi di Switch0

Switch0#show running-config

Building configuration

Current configuration : 1885 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

service password-encryption

!

hostname Switch0

!

!

!

no ip domain-lookup

!

spanning-tree mode pvst

!

interface FastEthernet0/1

switchport access vlan 99

!

interface FastEthernet0/2

switchport access vlan 99

!

interface FastEthernet0/3

switchport access vlan 99

!

interface FastEthernet0/4

switchport access vlan 99

!

interface FastEthernet0/5

switchport access vlan 99

!

interface FastEthernet0/6

switchport access vlan 99

!

interface FastEthernet0/7

switchport access vlan 99

!

interface FastEthernet0/8

switchport access vlan 99

!

interface FastEthernet0/9

switchport access vlan 99

!

interface FastEthernet0/10

switchport access vlan 99

!

interface FastEthernet0/11

switchport access vlan 99

!

interface FastEthernet0/12

switchport access vlan 99

!

interface FastEthernet0/13

switchport access vlan 99

!

interface FastEthernet0/14

www.nixtrain.com

3

switchport access vlan 99

!

interface FastEthernet0/15

switchport access vlan 99

!

interface FastEthernet0/16

switchport access vlan 99

!

interface FastEthernet0/17

switchport access vlan 99

!

interface FastEthernet0/18

switchport access vlan 99

!

interface FastEthernet0/19

switchport access vlan 99

!

interface FastEthernet0/20

switchport access vlan 99

!

interface FastEthernet0/21

switchport access vlan 99

!

interface FastEthernet0/22

switchport access vlan 99

!