Вы находитесь на странице: 1из 2

Para solucionar este problema solo se debe ejecutar el siguiente comando:

sudo dpkg configure -a

Este comando le indica al sistema de paquetes que termine la instalacin pendiente. Si te sigue
mostrando ese problema puedes eliminar algunos archivos para que no se mantenga ninguna
configuracin o archivo que pudiera estar incorrecto. Para esto ve a la siguiente carpeta y elimina los
archivos .portrm y .list, lo puedes hacer con los siguientes comandos:
1.- Eliminar los archivos:
sudo rm /var/lib/dpkg/info/*.postrm
sudo rm /var/lib/dpkg/info/*.list

2.- Elimina el cache de paquetes y actualiza el sistema


sudo apt-get clean all
sudo apt-get update
sudo apt-get upgrade

Con esto tendremos nuestro sistema de de paquetes limpio y preparado para continuar trabajando sin
problemas y poder instalar o actualizar el sistema sin problemas

Error: repositorio no est actualizado y se utilizarn los ficheros


de ndice antiguo
Si ocurre que te muestra un mensaje como este: Se produjo un error durante la verificacin de las
firmas. El repositorio no est actualizado y se utilizarn los ficheros de ndice antiguos. ha ocurrido
algn problema con las listas de paquetes y no se pueden acceder, en este caso es mejor borrarlas y
descargar todo de nuevo, para esto ejecuta estos comandos:
sudo rm /var/lib/apt/lists/*
sudo rm /var/lib/apt/lists/partial/*
sudo apt-get update

Listo ya deberas poder instalar cualquier paquete o actualizar los paquetes del sistema que lo requieran
mediante el comando
sudo apt-get upgrade

Error: algo sali mal, ejecuta sudo apt-get -f install


Otro Error comn con el administrador de paquetes es que te indica que hay un problema con el gestor
de actualizaciones o con el centro de software y el mensaje de error te indica que ejecutes un comando
como este:
sudo apt-get -f install

Te recomiendo que lo hagas ya que se resuelve el problema de una actualizacin o instalacin


incompleta, una vez realizado esto puedes ejecutar de nuevo el comando siguiente:
sudo apt-get update
sudo apt-get upgrade

Error: Leyendo la lista de paquetes!


Este error es comn cuando se ha interrumpido la descarga de la lista de paquetes y no se han
procesado todos los archivos de la lista, para arreglarlo solo tienes que ejecuar estos comandos
sudo rm /var/lib/apt/lists/* -vf
sudo apt-get update

Con esto se eliminarn todos los listados que existan y se descargarn los mas actuales y podrs
continuar instalando los paquetes que necesites o actualizando tu sistema.