You are on page 1of 6

ISSN:2229-6093

Jaswinder Kumar et al, Int.J.Computer Technology & Applications,Vol 6 (1),1-6

Performance Analysis of RIPv2 protocol in


Wired Network Using Cisco Packet Tracer
Jaswinder Kumar1,Samiksha2,Amandeep Kaur3,Harsukhpreet singh 4
CT Institute of Technology & Research, Maqsudan, Jalandhar
jkheer229@gmail.com1

Abstract- In this research performance of RIPv2 II.TYPES OF ROUTING –There are mainly two
Protocol is optimized using enhanced routing methods for create a routing table-
parameter like routing Update, convergence time,
A. Static B Dynamic routing
invalid timer, hold timer, Flushout timer .By review
of RIP protocol the researcher use these value as A. STATIC ROUTING- In computer networking, the
30sec update Timer, 180 sec invalid timer and 180 word static means manually. So in process
sec hold timer and 240 sec flushout timer, which administrator configure each router interface
result in low QoS and slow routing. This research manually. So routing table is created, update and
paper mainly focuses on to optimize above maintained by administrator manually, in this process
mentioned Routing Parameter to enhance QoS router will not share our routing information with
parameter and make RIP Protocol routing fast. each other thus it reduced CPU/RAM overhead so as
the result bandwidth is saved.
Keywords: CISCO, RIP, RIPv1, RIPv2, EIGRP and
OSPF B. DYNAMIC ROUTING- In this routing, router learn
all the routing update and other information with help
I.INTRODUCTION of using routing protocol like RIPv1, RIPv2, EIGRP
Internetworking stands for the interconnection of two and OSPF etc. We will configure dynamic routing on
or more computers for sharing of data and other each router with the help of RIPv2 protocol.
information by devices such as routers and switches. ROUTING INFORMATION PROTOCOL (RIP)
A network is said to be established if two or more
computers are sharing data or resources such as Routing Information Protocol (RIP) is a standards-
scanner, printer etc between them and internet based, distance-vector, interior gateway protocol used
protocol are principles and rules by which the data is by routers to trade routing information. RIP uses hop
to be send through routers. In internetworking, routing count to find out the best path between two locations.
plays very significant role in moving packets from Hop count is the number of routers the packet must
LAN to WAN and vice versa. It also provides a best go through till it reaches the destination network. The
path for IP Packet to reach at the destination it occurs maximum allowable number of hops a packet can go
at network layer 3 of the OSI model. Router works at across in an IP network implementing RIP is 15 hops.
network layer of the OSI model and used to route IP Routing information protocol is a distance vector
packets to destination networks. This is possible as protocol that works like a buzz. Routers using RIP
router used routing technique like static, default and publicize information about each subnet to their
dynamic routing. Static and default routing is neighbors. Their neighbor in turn passes the
configure by administrator manually. In dynamic information to the nearby neighbors of their own and
routing, router used various routing protocol such as so on until all the routers are alert of information. Rip
RIPv1, RIPv2, EIGRP and OSPF etc. Basically router was first developed in 1969. It exists in three versions
performed routing to create a routing table and learn RIPv1, RIPv2, RIPng.RIP works well in small
the neighbor route information networks, but it's ineffective on large networks with

IJCTA | Jan-Feb 2015 1


Available online@www.ijcta.com
ISSN:2229-6093

Jaswinder Kumar et al, Int.J.Computer Technology & Applications,Vol 6 (1),1-6


slow WAN links or on networks with a large number FEATURES OF RIP:
of routers installed. 1) MULTICASTING: RIPv2 supports multicasting
beside the broadcast updates by RIPv1 to distribute
In a RIP network, each router broadcasts its entire
the routing information.
RIP table to its neighboring routers every 30 seconds.
When a router receives a neighbor's RIP table, it uses 2) TRIGGERED UPDATES: When a route fails. It
the information provided to update its own routing does not wait for the next periodic update. It
table and then sends the updated table to its immediately sends trigger update for the listed failed
neighbors. route. The updates are sending to share its routing
information with the neighbor, whenever a change
Table1 shows the dissimilarity and table2 shows
occurs.
similarities between RIPv1 and RIPv2. By default
RIPv1 has been used on routers because RIPv1 has 3) CLASSLESS PROTOCOLS: It supports Variable
limitation that it supports classfull IP. So it is not length subnet masking (VLSM) that enables to afford
being used in classless IP. more than 1 subnet mask value. These protocols are
known to class A, B and C network only. RIPv1 is a
S. No. RIPv1 RIPv2
Classfull addressing protocol.
1. Classful protocol Classes
4) AUTHENTICATION: It allows you to select the
protocol
routers that contribute in RIPv2. The process of
2. It does not send subnet It send subnet validation is done by administrator.
mask with route update mask with
RIP three types of messages which are:
update
1) HELLO MESSAGE: These messages are send to
3. It use broadcast IP It used
alert neighbor routers about the existence of the
255.255.255.255 to send multicast IP
respective router. It helps in creating neighbourships.
update 224.0.0.9 to
send update 2) UPDATE MESSAGE: These messages are send
by a router to update other and helps in trading
4. It does not support CIDR It support CIDR
information regarding the routing table.
and VLSM and VLSM
3) ACKNOWLEDGEMENT MESSAGE: This
TABLEI. DIFFERENCE BETWEEN RIPv1 AND RIPv2
message is used for acknowledgement to swap
S.No. Parameter RIPv1 RIPv2 information between two routers.
1. Distance vector Yes Yes RIP uses 4 timers to regulate its performance and
protocol keep track of the a range of routes linked.
2. Hop count Up to 15 Up to 15 1) ROUTER UPDATE TIMER: The default router
updates its routing table information after 30 second.
3. Split horizon Present Present
2) ROUTE INVALID TIMER: The default router
4. Poison reverse Yes Yes
unacceptable timer value is 180 second .This periods
TABLEII SIMILARITIES BETWEEN RIPv1 and RIPv2 specify that after this period router acknowledges a
RIP uses only hop count to decide the best path to a route as invalid. This happen only when router does
remote network; it sends the entire routing table out not exchange any neighbor routing update
to all active interfaces every 30 seconds. It has to information from route for that period.
send whole packet and entire routing information up 3) HOLD DOWN TIMER: The default value of hold
to 15 hops. After 15 hops packet will be dropped as it down timer is also 180 seconds.
does not provide any information after 15 hops.
4) ROUTE FLUSH TIMER: The default router flush
timer value is 240 seconds. After 180 second of
invalid timer when router states a route as invalid,

IJCTA | Jan-Feb 2015 2


Available online@www.ijcta.com
ISSN:2229-6093

Jaswinder Kumar et al, Int.J.Computer Technology & Applications,Vol 6 (1),1-6


router wait till next 60 seconds. After 60 second it III. SIMULATION AND SETUP
flushes out to the route from the routing table.
RELATED WORK
Fatima A.H. et al.(2011) has evaluated Performance
Comparison of Two Dynamic Routing Protocols: RIP
and OSPF using Network Simulator (NS2) to obtain
the performance results of the two classes using
different metrics such as throughput, packet delay
and packet loss. Results of the simulation show that
OSPF has a better performance than RIP in terms of
average throughput and packet delay in different
network sizes. Fig2.1 Simulation of dynamic routing in Cisco packet tracer
Gundalwar P.R. et al.(2013) have discuss issues from
Fig.1-A shows the simulation of dynamic routing
the basic working concept of a RIP to experimental
using RIPv2 protocol in Cisco packet tracer. We have
setup used in IP networks using OPNET IT Guru
developed a simulation networking model consist of
Academic Edition Simulator, stability features,
Cisco router, switches and make a physical
message formats etc.He concluded that RIP works
connection by connecting cable to serial and fast
unusual with different sense regarding failure or no
Ethernet by using simulation tool Cisco packet tracer
failure in the network. We compare RIP with other
Version 5.3.
Interior Gateway Protocol (IGP) for comparison in
future work. Configuring CISCO Router- After implementation of
Adhikari J. (2013) has analyzed the performance of physical model we are required to configuring of
Protocols RIP & EIGRP using GNS3 Software. He network with static routing means we are configure all
compared that both the protocols & concluded that the router interface manually. Router will be configure in
EIGRP protocol is better than RIP protocol. two ways-
Shah A. et al. (2013) evaluated the comparison of RIP 1.GUI(Graphical User Interface)- With GUI we
and OSPF protocols on the basis of convergence, simply configure router by clicking the router then
traffic and CPU utilization by changing special click configuration and then selected which type of
parameters within network using OPNET as configuration you want to configure as shown in
simulating tool. They have concluded that OSPF fig.2.2
network convergence is faster as compare to RIP
convergence
Vetriselvan V. et al. (2014) surveyed the Performance
evaluation of various routing protocols. With certain
criteria’s like Jitter, Convergence Time, end to end
delay, etc.They have conclude that EIGRP has better
than OSPF.
Sonam .et al.(2014) have analyzed that fastest Ftp
download response time IS-IS should be preferred for
800 and 1000 packets whereas slowest response is
Fig.2.2 GUI to add network routes to static routing
obtained by RIP protocol.
Kumar J. et al. (2013) have analyzed performance 2. CLI (command line interface) mode – In this
analysis between static and dynamic routing using mode, we can configure static routing with the of
CISCO packet tracer. They have concluded that various command
dynamic routing is better than static routing for a IV. SIMULATION CODE
large network.
Code used in Cisco packet tracer is given below:-

IJCTA | Jan-Feb 2015 3


Available online@www.ijcta.com
ISSN:2229-6093

Jaswinder Kumar et al, Int.J.Computer Technology & Applications,Vol 6 (1),1-6


interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
TABLE III CHECK DIRECTLY CONNECTED ROUTER
INTERFACE
speed auto
We have implemented routing technique dynamic
shutdown
routing.
!
interface Serial0/0/0
ip address 10.0.0.2 255.0.0.0
!
interface Serial0/0/1
ip address 11.0.0.1 255.0.0.0
!
interface Serial0/1/0 TABLE IV CONFIGURE AND DECRIPTION OF RIPV2
ROUTING PROTOCOL IN CLI MODE
ip address 15.0.0.1 255.0.0.0
Table IV shows that how to configure dynamic route
! using CLI mode and gives the description of various
commands used in static routing
interface Serial0/1/1
ip address 19.0.0.1 255.0.0.0
4. SIMULATION
!
interface Vlan1
no ip address
shutdown
!
So these commands are implemented in all router
interfaces. In this way we can implement all
internetwork so that all router interface ping with each
other but they cannot transmit the packet.
TABLE V CHECK ROUTER INTERFACE STATUS

TABLE V shows up status of router interface show that


router are configure properly and they work properly.

IJCTA | Jan-Feb 2015 4


Available online@www.ijcta.com
ISSN:2229-6093

Jaswinder Kumar et al, Int.J.Computer Technology & Applications,Vol 6 (1),1-6


flushed out timer is 240 sec. so it take more time for
all routing update than other routing protocol like
EIGRP and OSPF etc.

TABLE VI CONFIGURE RIPV2 COMMAND

TABLE VI shows that how to configure dynamic route


(RIPv2) using CLI mode and gives the description of
various commands used in dynamic routing

TABLE XIV Show the Simulation Results of RIP


Protocol

TABLE XIV shows that simulation Results of RIP


Protocol having update timer is 15 sec means router
1 send routing update to neighbours router every 15
sec, invalid timer is 60 sec ,hold timer is also 60 sec
and flushed out timer is 80 sec etc.

300
TABLE XII CHECK RIP ROUTE ON ROUTER 1
250
TABLE XII shows that RIPv2 protocol (dynamic 200
routing) enable in Router5. “R” indicates that RIP
route has been implementing in Router1 150 Existing
100 Results
The results of simulation are shown below :
50
0
Update Hold Invalid Flushout
Timer Timer Timer Timer

TABLE XV Show the both existing and Simulation of


Results RIP Protocol

This table compares the parameter of RIP Protocol


with existing and new simulation result and
concluded that new result provide less time for
exchanging routing information between the
neighbouring router in the LAN network
TABLE XIII Show the Existing Results of RIP Protocol

TABLE XIII Shows that existing results of RIP protocol 6. CONCLUSIONS


having update timer 30 sec means router 1 send
routing update to neighbours router every 30 sec, After the simulation, the parameter of RIP protocol
has 15 sec update timer so router send routing update
Invalid timer is 180 sec, hold timer is 180 sec and

IJCTA | Jan-Feb 2015 5


Available online@www.ijcta.com
ISSN:2229-6093

Jaswinder Kumar et al, Int.J.Computer Technology & Applications,Vol 6 (1),1-6


every 15 sec between neighbours router which is fast 2014 - IEEE Conference on Computer Communications,ISSN:
4799-3360,Volume 1,Issue 1,(2014) ,pp.1-14.
as compare to existing result, invalid timer is 60 sec [11] V.Vetriselvan, Pravin R.Patil, M.Mahendran, “Survey on the RIP,
than 180 sec for existing result, hold timer also 60 se c OSPF, EIGRP Routing Protocols” (IJCSIT) International Journal
than 180 sec and also flushed out timer is 80 sec than of Computer Science and Information Technologies, Vol. 5 (2) ,
2014, pp.1058-1065.
existing result so convergence time of routing [12] Jaswinder Kumar,Samiksha,Anurag Sharma, Rahul Malhotra
information is reduced. So the performance of RIPv2 “Performance Analysis of Static and Dynamic Routing in
protocol is enhanced by three times improved then Computer Network Using Cisco Packet Tracer” International
Multi Track Conference on Sciences, Engineering & Technical
existing results. So it becomes a faster routing Innovations(IMTC-14),Volume 1,May-2014,pp.35-41.
protocol in LAN network. But it is not used in WAN [13] Navita Komal ,Rajan Vohra and Ravinder Singh Sawhney,
network because after 16 hops have infinite route “Behavioal Analysis of Dynamic Routing Protocols under
Incrementing Workstations” Int. J. on Recent Trends in
problem is occurs which cannot be eliminated. Engineering and Technology, Vol. 11, No. 1, July 2014.
[14] Sonam, Rajan Vohra, “Dynamic Routing Protocols Analysis based
on Dissimilar Number of Packets” The Standard International
Journals (The SIJ), Vol. 2, No. 4, June 2014.
REFERENCES

[1] Fatima A. Hamza, Amr M. Mohamed, “Performance Comparison


of Two Dynamic Routing Protocols: RIP and OSPF” , Journal of
Emerging Trends in Computing and Information Sciences,volume
2:October 2011.
[2] Ashish Saklani ,Dr.S.C.Dimri “ Impact of computer network
routing based on imprecise routing tables and static v/s dynamic
routing” The International Journal Of Engineering And Science
(IJES) Volume2, Issue 7 , 2013 ISSN(e): 2319 – 1813 ISSN(p):
2319 – 1805.
[3] P. R. Gundalwar1, Dr. V. N. Chavan, “Routing Behavior of IP
Routers running RIP in different scenarios”, International Journal
Computer Technology & Applications, Volume 4 (2), 302-311:
Mar-Apr 2013.
[4] Jeevan Prasad Adhikari, “Performance Analysis of Protocols RIP
& EIGRP using GNS 3 Software”, International Journal of
Innovative Technology and Exploring Engineering (IJITEE),
Volume-2, April 2013.
[5] Neha Grang “Compare OSPF Routing Protocol with other Interior
Gateway Routing”, International Journal of Engineering,
Business and Enterprise Applications (IJEBEA) pp. 166-170
march- may 2013.
[5] Kuwar Pratap Singh, P. K. Gupta, “Performance Evaluation of
Enhanced Interior Gateway Routing Protocol in IPv6 Network”,
International Journal of Computer Applications (0975 – 8887)
Volume 70– No.5, May 2013
[6] Jagdeep Singh, Dr. Rajiv Mahajan, “Simulation Based Comparative
Study of RIP, OSPF and EIGRP” International Journal of
Advanced Research in Computer Science and Software
Engineering, Volume 3, Issue 8, August 2013.
[7] Shah.A1, Waqas J.Rana, “Performance Analysis of RIP and OSPF
in Network Using OPNET” IJCSI International Journal of
Computer Science Issues, Vol. 10, Issue 6, No 2, November 2013
[8] Syed Yasir Jalali, Sufyan Wani and Majid Derwesh, “Qualitative
Analysis and Performance Evaluation of RIP, IGRP, OSPF and
EGRP Using OPNET” Advance in Electronic and Electric
Engineering.ISSN 2231-1297, Volume 4, Number 4 (2014), pp.
389-396.
[9] Shalley Bakshi, Ms. Suman, “Opnet Based simulation for route
redistribution in EIGRP, BGP and OSPF network protocols”
IOSR Journal of Electronics and Communication Engineering
(IOSR-JECE) ,ISSN: 2278-8735.Volume 9, Issue 1, (Jan. 2014),
pp.47-52.
[10] Stefano Vissicchio, Laurent Vanbever, “Safe Routing
Reconfigurations with Route Redistribution” IEEE INFOCOM

IJCTA | Jan-Feb 2015 6


Available online@www.ijcta.com