You are on page 1of 27

UNIVERSIDAD TÉCNICA DE COTOPAXI

FACULTAD EN CIENCIAS HUMANAS Y DE LA EDUCACIÓN


CARRERA DE INGENIERÍA DISEÑO GRÁFICO
EVALUACIÓN

Nombre: Felix Cajamarca

Ciclo: 6º Diseño Grafico

Algoritmo sin_titulo

/// 1. Desarrollar un programa que me permita ingresar dos números, el programa debe realizar
suma

/// de los números ingresados, si la suma excede de 20, se debe restar 10 de la suma de los dos
números,

/// luego de este proceso el programa dejará saber si este último resultado es positivo o negativo.

Escribir "Ingrese los números "

Leer a,b

c=a+b

Si c>20 Entonces

d=c-10

Fin Si

Si d>0 Y d<=20 Entonces

Escribir d," Es positivo"

Fin Si

Si d<0 Entonces

Escribir d," Es negativo"

Fin Si

FinAlgoritmo

Algoritmo Diasdelasemana

///2. Desarrollar un programa que me permita ingresar un número del 1 al 7

/// los cuales representarán los días de la semana correspondientemente

/// desde el lunes hasta el domingo, si se ingresa un valor distinto se emitirá un mensaje

/// que no es día de la semana

Escribir "Ingrese el número"

Leer N

Si N=1 Entonces
Escribir "Lunes"

Fin Si

Si N=2 Entonces

Escribir "Martes"

Fin Si

Si N=3 Entonces

Escribir "miércoles"

Fin Si

Si N=4 Entonces

Escribir "Jueves"

Fin Si

Si N=5 Entonces

Escribir "viernes"

Fin Si

Si N=6 Entonces

Escribir "sábado"

Fin Si

Si N=7 Entonces

Escribir "Domingo"

Fin Si

Si N>7 Entonces

Escribir "No corresponde"

Fin Si

Si N<0 Entonces

Escribir "No corresponde"

Fin Si

FinAlgoritmo

Algoritmo sin_titulo
/// 3. Ingresar 10 números por teclado y saber cuál es el mayor y el menor

Escribir "Ingrese los números"

Leer a, b, c, d, e, f, g, h, i, j

Si a<b Y a<c Entonces

Si a<d Y a<e Entonces

Si a<f Y a<g Entonces

Si a<h Y a<i Entonces

Si a<j Entonces

Escribir a, " Es el menor de los numeros ingresados"

Fin Si

Fin Si

Fin si

Fin Si

Fin Si

Si b<a Y b<c Entonces

Si b<d Y b<e Entonces

Si b<f Y b<g Entonces

Si b<h Y b<i Entonces

Si b<j Entonces

Escribir b, " Es el menor de los numeros ingresados"

Fin Si

Fin Si

Fin si

Fin Si

Fin Si

Si c<b Y c<a Entonces

Si c<d Y c<e Entonces

Si c<f Y c<g Entonces

Si c<h Y c<i Entonces

Si c<j Entonces
Escribir c, " Es el menor de los numeros ingresados"

Fin Si

Fin Si

Fin si

Fin Si

Fin Si

Si d<b Y d<c Entonces

Si d<a Y d<e Entonces

Si d<f Y d<g Entonces

Si d<h Y d<i Entonces

Si d<j Entonces

Escribir d, " Es el menor de los numeros ingresados"

Fin Si

Fin Si

Fin si

Fin Si

Fin Si

Si e<b Y e<c Entonces

Si e<d Y e<a Entonces

Si e<f Y e<g Entonces

Si e<h Y e<i Entonces

Si e<j Entonces

Escribir e, " Es el menor de los números ingresados"

Fin Si

Fin Si

Fin si

Fin Si

Fin Si

Si f<b Y f<c Entonces

Si f<d Y f<e Entonces

Si f<a Y f<g Entonces


Si f<h Y f<i Entonces

Si f<j Entonces

Escribir f, " Es el menor de los números ingresados"

Fin Si

Fin Si

Fin si

Fin Si

Fin Si

Si g<b Y g<c Entonces

Si g<d Y g<e Entonces

Si g<f Y g<a Entonces

Si g<h Y g<i Entonces

Si g<j Entonces

Escribir g, " Es el menor de los números ingresados"

Fin Si

Fin Si

Fin si

Fin Si

Fin Si

Si h<b Y h<c Entonces

Si h<d Y h<e Entonces

Si h<f Y h<g Entonces

Si h<a Y h<i Entonces

Si h<j Entonces

Escribir h, " Es el menor de los números ingresados"

Fin Si

Fin Si

Fin si

Fin Si

Fin Si

Si i<b Y i<c Entonces


Si i<d Y i<e Entonces

Si i<f Y i<g Entonces

Si i<h Y i<a Entonces

Si i<j Entonces

Escribir i, " Es el menor de los números ingresados"

Fin Si

Fin Si

Fin si

Fin Si

Fin Si

Si j<b Y j<c Entonces

Si j<d Y j<e Entonces

Si j<f Y j<g Entonces

Si j<h Y j<i Entonces

Si j<a Entonces

Escribir j, " Es el menor de los números ingresados"

Fin Si

Fin Si

Fin si

Fin Si

Fin Si

Si a>b Y a>c Entonces

Si a>d Y a>e Entonces

Si a>f Y a>g Entonces

Si a>h Y a>i Entonces

Si a>j Entonces

Escribir a, " Es el mayor de los números ingresados"

Fin Si

Fin Si

Fin si
Fin Si

Fin Si

Si b>a Y b>c Entonces

Si b>d Y b>e Entonces

Si b>f Y b>g Entonces

Si b>h Y b>i Entonces

Si b>j Entonces

Escribir b, " Es el mayor de los números ingresados"

Fin Si

Fin Si

Fin si

Fin Si

Fin Si

Si c>b Y c>a Entonces

Si c>d Y c>e Entonces

Si c>f Y c>g Entonces

Si c>h Y c>i Entonces

Si c>j Entonces

Escribir c, " Es el mayor de los números ingresados"

Fin Si

Fin Si

Fin si

Fin Si

Fin Si

Si d>b Y d>c Entonces

Si d>a Y d>e Entonces

Si d>f Y d>g Entonces

Si d>h Y d>i Entonces

Si d>j Entonces

Escribir d, " Es el mayor de los números ingresados"

Fin Si
Fin Si

Fin si

Fin Si

Fin Si

Si e>b Y e>c Entonces

Si e>d Y e>a Entonces

Si e>f Y e>g Entonces

Si e>h Y e>i Entonces

Si e>j Entonces

Escribir e, " Es el mayor de los números ingresados"

Fin Si

Fin Si

Fin si

Fin Si

Fin Si

Si f>b Y f>c Entonces

Si f>d Y f>e Entonces

Si f>a Y f>g Entonces

Si f>h Y f>i Entonces

Si f>j Entonces

Escribir f, " Es el mayor de los números ingresados"

Fin Si

Fin Si

Fin si

Fin Si

Fin Si

Si g>b Y g>c Entonces

Si g>d Y g>e Entonces

Si g>f Y g>a Entonces

Si g>h Y g>i Entonces

Si g>j Entonces
Escribir g, " Es el mayor de los números ingresados"

Fin Si

Fin Si

Fin si

Fin Si

Fin Si

Si h>b Y h>c Entonces

Si h>d Y h>e Entonces

Si h>f Y h>g Entonces

Si h>a Y h>i Entonces

Si h>j Entonces

Escribir h, " Es el mayor de los números ingresados"

Fin Si

Fin Si

Fin si

Fin Si

Fin Si

Si i>b Y i>c Entonces

Si i>d Y i>e Entonces

Si i>f Y i>g Entonces

Si i>h Y i>a Entonces

Si i>j Entonces

Escribir i, " Es el mayor de los números ingresados"

Fin Si

Fin Si

Fin si

Fin Si

Fin Si

Si j>b Y j>c Entonces

Si j>d Y j>e Entonces

Si j>f Y j>g Entonces


Si j>h Y j>i Entonces

Si j>a Entonces

Escribir j, " Es el mayor de los números ingresados"

Fin Si

Fin Si

Fin si

Fin Si

Fin Si

FinAlgoritmo

Algoritmo sin_titulo

///4. Un programa que permita ingresar por teclado un nombre en una variable,

/// y despliegue el mensaje "HOLA MUNDO, SOY", "Nombre"

Escribir "Ingrese el nombre"

Leer Nom

Escribir "HOLA MUNDO SOY YO ", Nom

FinAlgoritmo

Algoritmo sin_titulo

///5. Un programa que permita ingresar por teclado, el nombre, la dirección del domicilio,

/// el teléfono, la edad en años y el estado civil. Y despliegue un mensaje mostrando de forma

/// explícita su información personal.

Escribir "Ingrese los datos"

Escribir "en el siguiente orden:"

Escribir "Nombre, Dirección, Teléfono, Edad en años y Estado Civil"

Leer n, d, t, e, ec

Escribir "NOMBRE: ",n

Escribir "DIRECCION DEL DOMICILIO: ",d

Escribir "TELÉFONO: ",t

Escribir "EDAD: ",e

Escribir "ESTADO CIVIL: “, ec

FinAlgoritmo

Algoritmo sin_titulo
///6. Un programa que permita ingresar un valor por teclado y permita obtener el resultado de
elevar

///a un exponente cualquiera.

Escribir "Ingrese la base y el exponente"

Leer b, e

a=b^e

Escribir "El resultado es “,a

FinAlgoritmo

Algoritmo TABLA_MULTIPLICAR

///7. Un programa que permita imprimir cinco primeras operaciones de la tabla de multiplicar,

/// de un número ingresado por teclado.

Escribir "----------------------TABLA DE MULTIPLICAR------------------------------"

Escribir "INGREGRE EL NUMERO PARA REALIZAR LA TABLA DE MULTIPLICAR"

LEER NUM

Escribir NUM " * 1 =", NUM*1

Escribir NUM " * 2 =", NUM*2

Escribir NUM " * 3 =", NUM*3

Escribir NUM " * 4 =", NUM*4

Escribir NUM " * 5 =", NUM*5

FinAlgoritmo

Algoritmo sin_titulo

///8. Un programa que permita ingresar el valor de una compra, calcular el 12% de IVA de la
cantidad ingresada.

/// Y el valor total a cancelar.

Escribir "Ingrese el valor de la compra"

Leer vc

iva=vc*0.12

tot=vc+iva

Escribir "El valor del 12% IVA es: ",iva

Escribir "El valor total a pagar es: ",tot

FinAlgoritmo
Algoritmo sin_titulo

///9. Un programa que permita ingresar un número y devuelva el mismo número con el signo
cambiado.

Escribir "Ingrese el número"

Leer a

r=a*(-1)

Escribir "El numero negativo ", r

FinAlgoritmo

Algoritmo sin_titulo

/// 10. Programa que permita ingresar dos numero distintos N1 y N2 por teclado,

///y permita saber cuál de los dos números es mayor y cuál es el menor.

Escribir "Ingrese los numeros"

Leer n1, n2

Si n1<n2 Entonces

Escribir "El primer número es menor y el segundo es mayor"

SiNo

Escribir "El primer número es mayor y el segundo es menor"

Fin Si

FinAlgoritmo

Algoritmo sin_titulo

///11. Un programa que permita saber si un número es positivo o negativo.

Escribir "Ingrese el número"

Leer a

Si a>0 Entonces

Escribir a, " Es positivo"

SiNo

Escribir a, " Es negativo"

Fin Si
FinAlgoritmo

///12. Programa que permita saber si un número es par o impar.

Escribir "Ingresar el número"

Leer N

R= n mod 2

Si N<>0 Entonces

Si R=0

Escribir "El número es par"

SiNo

Escribir "El número es impar"

Fin Si

SiNo

Escribir "El número es cero"

Fin Si

FinAlgoritmo

Algoritmo sin_titulo

/// 13. Un programa que permita ingresar una edad por teclado y despliegue el
mensaje por pantalla de,

/// si es menor de edad, si es que tiene menos de 18 años, ADULTO si la edad es menor
a 60 años,

/// y si es que es igual o mayor a 60 el mensaje ES ADULTO MAYOR

Escribir "Ingrese la edad"

Leer e

Si e<18 Entonces

Escribir "Es menor de edad"

Fin Si

Si e>=18 Y e<60 Entonces

Escribir "Es ADULTO"

Fin Si

Si e>=60 Entonces

Escribir "Es ADULTO MAYOR"

Fin Si
FinAlgoritmo

Algoritmo sin_titulo

/// 14. Un programa que permita ingresar un número y saber si es divisible para 5

Escribir "Ingresar el número"

Leer N

R= N mod 5

Si N<>0 Entonces

Si R=0

Escribir "El número es divisible para 5"

SiNo

Escribir "El número no es divisible para 5"

Fin Si

SiNo

Escribir "El número es cero"

Fin Si

FinAlgoritmo

Algoritmo sin_titulo

/// 15. Programa que permita ingresar dos números Dividendo y Divisor,

/// y que permita saber si la división es exacta o no es exacta.

Escribir "Ingresar el dividendo"

Leer d1

Escribir "Ingresar el divisor"

Leer d2

d=d1/d2

R= d2 mod 2

Si d<>0 Entonces

Si R=0

Escribir "la división es exacta"

Fin Si

Si R<>0

Escribir "la división no es exacta"


Fin Si

Fin Si

FinAlgoritmo

Algoritmo sin_titulo

///16. Un programa que permita saber si un número es positivo, negativo o cero.

Escribir "Ingrese el número"

Leer a

Si a<>0 Entonces

Si a>0 Entonces

Escribir a, " Es positivo"

SiNo

Escribir a, " Es negativo"

Fin Si

SiNo

Escribir a, " Es cero"

Fin Si

FinAlgoritmo

Algoritmo sin_titulo

///17. Tres termómetros dan la lectura de la temperatura del agua de tres piscinas
en forma simultánea,

///desarrollar un programa que me permita conocer si la temperatura en cada una de


las piscinas

///es la ideal para ingresar a nadar. (Considere ideal la temperatura de 22 grados C.)

Escribir "Ingrese la temperatura de la 1era piscina"

Leer a

Escribir "Ingrese la temperatura de la 2da piscina"

Leer b

Escribir "Ingrese la temperatura de la 3era piscina"

Leer c

Si a=22 Entonces

Escribir "Puede ingresar a la 1era piscina"

Fin Si
Si b=22 Entonces

Escribir "Puede ingresar a la 2da piscina"

Fin Si

Si c=22 Entonces

Escribir "Puede ingresar a la 3era piscina"

Fin Si

FinAlgoritmo

Algoritmo sin_titulo

/// 18. En un supermercado se está ofreciendo un descuento de un 5% por compras


que superan un valor de 20USD

/// del 10% si los valores de las compras superan los 30 USD

/// y el 15% si las compras superan los 60 USD

/// se necesita conocer cuál es el descuento al cual el comprador tiene derecho;

/// y si no tiene descuento también debe emitir el mensaje, desplegar el mensaje de


cuento debe pagar

Escribir "Ingrese el valor de la factura"

Leer Vc

Si Vc>20 Y Vc<=30 Entonces

D=Vc*0.05

Tp=Vc-D

Escribir "Ha superado el valor de compra"

Escribir "Su descuento es ",D

Escribir "El valor a pagar es ", Tp

Fin Si

Si Vc>30 Y Vc<=60 Entonces

D=Vc*0.1

Tp=Vc-D

Escribir "Ha superado el valor de compra"

Escribir "Su descuento es ",D

Escribir "El valor a pagar es ", Tp

Fin Si

Si Vc>60 Entonces
D=Vc*0.15

Tp=Vc-D

Escribir "Ha superado el valor de compra"

Escribir "Su descuento es ",D

Escribir "El valor a pagar es ", Tp

Fin Si

Si Vc<20 Entonces

D=0

Tp=Vc-D

Escribir "Usted no tiene descuento"

Escribir "Su descuento es ",D

Escribir "El valor a pagar es ", Tp

Fin Si

FinAlgoritmo

Algoritmo serie

///19. Un jornalero tiene un préstamo de 3000 USD en un tiempo determinado,

/// y que cancela mensualmente 100 USD por letra, los aportes los hace en cifras
pequeñas

/// hasta completar la letra mensual, en el banco se necesita saber en qué estado se
encuentra el crédito

/// antes de cerrar cada mensualidad, si los aportes en el mes llegan a un total de 30
USD la letra está en mora,

/// si los aportes en el mes llegan a un total de80 USD la letra está pendiente,

/// si los aportes en el mes alcanzan o superan los 100 USD la letra está cancelada.

/// Desarrollar un programa que me permita manejar estos datos.

Escribir "Ingrese los aportes"

Para I<-1 Hasta 30 Con Paso 1 Hacer

leer n

s=n+s

Fin Para

let=s
Si let<=30 Entonces

Escribir let, "La letra esta en mora"

Fin Si

Si let=80 Entonces

Escribir let, "La letra está pendiente"

Fin Si

Si let>=100 Entonces

Escribir let, "La letra esta cancelada"

Fin Si

FinAlgoritmo

Algoritmo sin_titulo

/// 20. Desarrollar un programa que me permita ingresar por teclado tres notas de
los parciales de un alumno,

/// el programa pide sacar por pantalla su promedio, si este promedio es de siete o más

/// desplegar el mensaje que está aprobado, si el promedio es del 5.5 al 6.9,

/// se desplegará un mensaje que tiene un examen adicional de recuperación,

/// y si el promedio es inferior a 5.5 se desplegará el mensaje que ha reprobado.

Escribir "Ingrese las notas del alumno"

Leer a,b,c

prom=(a+b+c)/3

Si prom>7 Entonces

Escribir prom, " Esta aprobado"

Fin Si

Si prom>=5.5 Y prom<=6.9 Entonces

Escribir prom, " Tiene examen adicional"

Fin Si

Si prom<5.5 Entonces

Escribir prom, " Esta reprobado"

Fin Si

FinAlgoritmo

Algoritmo sin_titulo
///21. Un programa que permita saber si un número es mayor, menor o igual a 10.

Escribir "Ingrese el número"

Leer n

Si n=10 Entonces

Escribir "El numero ingresado es igual a 10"

Fin Si

Si n<10 Entonces

Escribir "El numero ingresado es menor a 10"

Fin Si

Si n>10 Entonces

Escribir "El numero ingresado es mayor a 10"

Fin Si

FinAlgoritmo

Algoritmo sin_titulo

///22. Un programa que permita saber cuál es mayor de tres números ingresados
por teclado.

Escribir "Ingrese los números"

Leer a, b, c

Si a>b Y a>c Entonces

Escribir a, " Es el mayor de los numeros ingresados"

Fin Si

Si b>a Y b>c Entonces

Escribir b, " Es el mayor de los numeros ingresados"

Fin Si

Si c>a Y c>b Entonces

Escribir c, " Es el mayor de los numeros ingresados"

Fin Si

FinAlgoritmo

Algoritmo sin_titulo

///23. Un programa que permita ingresar un valor por teclado,

/// si ingresa el número 1 entonces el programa despliega un mensaje "MOTOR


ENCENDIDO",
/// si ingresa el 0 el programa despliega el mensaje "MOTOR APAGADO",

/// si ingresa cualquier otro valor, despliega otro mensaje "NO SE A REALIZADO
NINGUNA ACCIÓN".

Escribir "Ingrese el valor"

Leer a

Si a=1 Entonces

Escribir "MOTOR ENCENDIDO"

FinSi

Si a=0 Entonces

Escribir "MOTOR APAGADO"

FinSi

Si a<>1 y a<>0 Entonces

Escribir "NO SE HA REALIZADO NINGUNA ACCION"

FinSi

FinAlgoritmo

Algoritmo Diasdelasemana

///24. Desarrollar un programa que me permita ingresar un número del 1 al 7

/// los cuales representarán los días de la semana correspondientemente

/// desde el lunes hasta el domingo, si se ingresa un valor distinto se emitirá un mensaje

/// que no es día de la semana

Escribir "Ingrese el número"

Leer N

Si N=1 Entonces

Escribir "lunes"

Fin Si

Si N=2 Entonces

Escribir "martes"

Fin Si

Si N=3 Entonces

Escribir "miércoles"

Fin Si
Si N=4 Entonces

Escribir "jueves"

Fin Si

Si N=5 Entonces

Escribir "viernes"

Fin Si

Si N=6 Entonces

Escribir "sábado"

Fin Si

Si N=7 Entonces

Escribir "Domingo"

Fin Si

Si N>7 Entonces

Escribir "No corresponde"

Fin Si

Si N<0 Entonces

Escribir "No corresponde"

Fin Si

FinAlgoritmo

Algoritmo sin_titulo

/// 25. En una ferretería el propietario requiere saber cuánto debe cobrar

/// por la compra de un artículo de ferretería, si debe incluir el precio del IVA que es el
12%,

/// pero a la vez proporciona un descuento del 5% para las compras que sobrepasen los
30 USD.

Escribir "Ingrese el valor de la factura"

Leer Vc

Si Vc>35 Entonces

D=Vc*0.05

nv=vc-D

Tp=(nv*0.12)+nv

Escribir "Ha superado el valor de compra"


Escribir "Su descuento es ",D

Escribir "El valor incluido el IVA a pagar es ", Tp

Fin Si

Si Vc<=30 Entonces

Tp=(Vc*1.12)

Escribir "Usted no tiene descuento"

Escribir "El valor incluido el IVA a pagar es ", Tp

Fin Si

FinAlgoritmo

Algoritmo sin_titulo

/// 26. En una ferretería el propietario requiere saber cuánto debe cobrar

/// por la compra de un artículo de ferretería, si debe incluir el precio del IVA que es el
12%,

/// pero a la vez proporciona un descuento del 5% para las compras que sobrepasen los
30 USD.

Escribir "Ingrese el valor de la factura"

Leer Vc

Si Vc>35 Entonces

D=Vc*0.05

nv=vc-D

Tp=(nv*0.12)+nv

Escribir "Ha superado el valor de compra"

Escribir "Su descuento es ",D

Escribir "El valor incluido el IVA a pagar es ", Tp

Fin Si

Si Vc<=30 Entonces

Tp=(Vc*1.12)

Escribir "Usted no tiene descuento"

Escribir "El valor incluido el IVA a pagar es ", Tp

Fin Si

FinAlgoritmo

Algoritmo sin_titulo
///27. Un termómetro da la lectura de una piscina, realizar un programa que
permita

/// saber cuántos grados le falta al valor leído de la temperatura, para que la piscina

/// esté en buenas condiciones y que el cliente pueda ingresar a nadar en forma cómoda
con su familia.

/// (Considérese buenas condiciones al valor de 22 grados C.)

Escribir "Ingrese la temperatura de la piscina"

Leer a

Si a=22 Entonces

Escribir "Puede ingresar a la piscina"

Fin Si

Si a>22 Entonces

Escribir "La temperatura excede de los 22 grados permitidos"

Fin Si

Si a<22 Entonces

Escribir "La temperatura no alcanza el límite permitido"

Fin Si

FinAlgoritmo

Algoritmo sin_titulo

///28. Un empleado de una empresa de marketing y publicidad gana un sueldo


básico,

/// en ciertas ocasiones deberá trabajar los fines de semana.

/// El pago de horas en fin de semana es a 5 USD hasta las 10 horas.

/// Si supera este límite de horas, entonces todas las horas extras se pagarán a 6
dólares.

/// Calcular el valor de horas extras y el sueldo.

Escribir "Ingrese el número de horas"

Leer h

Si h<=10 Y h>0

ph=h*5

s=375+ph

FinSi

Si h>10
ph=h*6

s=375+ph

FinSi

Escribir "El valor del sueldo a pagar es ",s

FinAlgoritmo

Algoritmo sin_titulo

///29. Un programa que permita ingresar un número y despliegue

/// como mensaje el día del mes al que corresponde, empezando desde el 1 que
despliega ENERO,

/// hasta el 12 que despliega DICIEMBRE, si es que el número no corresponde con los
días de la semana,

/// el programa desplegará el mensaje, "NO ES MES"

Escribir "Ingrese el número"

Leer N

Si N=1 Entonces

Escribir "ENERO"

Fin Si

Si N=2 Entonces

Escribir "FEBRERO"

Fin Si

Si N=3 Entonces

Escribir "MARZO"

Fin Si

Si N=4 Entonces

Escribir "ABRIL"

Fin Si

Si N=5 Entonces

Escribir "MAYO"

Fin Si

Si N=6 Entonces

Escribir "JUNIO"

Fin Si
Si N=7 Entonces

Escribir "JULIO"

Fin Si

Si N=8 Entonces

Escribir "AGOSTO"

Fin Si

Si N=9 Entonces

Escribir "SEPTIEMBRE"

Fin Si

Si N=10 Entonces

Escribir "OCTUBRE"

Fin Si

Si N=11 Entonces

Escribir "NOVIEMBRE"

Fin Si

Si N=12 Entonces

Escribir "DICIEMBRE"

Fin Si

Si N>12 Entonces

Escribir "No es mes"

Fin Si

Si N<=0 Entonces

Escribir "No es mes"

Fin Si

FinAlgoritmo

Algoritmo sin_titulo

///30. Un programa que permita ingresar un número por teclado,

/// despliegue el mes al que corresponde y diga cuantos días tiene ese mes del año.

Escribir "Ingrese el número"

Leer N

Si N=1 Entonces
Escribir "ENERO"

Escribir "Este mes tiene 31 días"

Fin Si

Si N=2 Entonces

Escribir "FEBRERO"

Escribir "Este mes tiene 28 días"

Fin Si

Si N=3 Entonces

Escribir "MARZO"

Escribir "Este mes tiene 31 días"

Fin Si

Si N=4 Entonces

Escribir "ABRIL"

Escribir "Este mes tiene 30 días"

Fin Si

Si N=5 Entonces

Escribir "MAYO"

Escribir "Este mes tiene 31 días"

Fin Si

Si N=6 Entonces

Escribir "JUNIO"

Escribir "Este mes tiene 30 días"

Fin Si

Si N=7 Entonces

Escribir "JULIO"

Escribir "Este mes tiene 31 días"

Fin Si

Si N=8 Entonces

Escribir "AGOSTO"

Escribir "Este mes tiene 31 días"

Fin Si
Si N=9 Entonces

Escribir "SEPTIEMBRE"

Escribir "Este mes tiene 30 días"

Fin Si

Si N=10 Entonces

Escribir "OCTUBRE"

Escribir "Este mes tiene 31 días"

Fin Si

Si N=11 Entonces

Escribir "NOVIEMBRE"

Escribir "Este mes tiene 30 días"

Fin Si

Si N=12 Entonces

Escribir "DICIEMBRE"

Escribir "Este mes tiene 31 días"

Fin Si

Si N>12 Entonces

Escribir "No corresponde"

Fin Si

Si N<=0 Entonces

Escribir "No corresponde"

Fin Si

FinAlgoritmo