Вы находитесь на странице: 1из 3

BALANCEAR MICROTIK

1. Asignando IP's a las interfaces de red

/ip address
add address=192168.0.2/24 interface=ether1
add address=192168.1.2/24 interface=ether2
add address=192168.2.2/24 interface=ether3

add address=192.168.5.1/24 interface=ether5

2. Configurando enmascarado de las interfaces de red WAN

/ip firewall nat


add chain=srcnat out-interface=ether1 action=masquerade
add chain=srcnat out-interface=ether2 action=masquerade
add chain=srcnat out-interface=ether3 action=masquerade

3. Configurando las rutas, parte 1

/ip route
add gateway=192.168.0.1 check-gateway=ping distance=1
add gateway=192.168.1.1 check-gateway=ping distance=2
add gateway=192.168.2.1 check-gateway=ping distance=3
4. Configurando mangle, empieza la magia o los problemas para el que no
pone atención
4.1 Primera parte, todo lo que entre por un WAN, debe salir por el mismo
WAN.
/ip firewall mangle

add chain=prerouting in-interface=ether1 connection-state=new new-connection-


mark=ether1_conn action=mark-connection passthrough=yes

add chain=prerouting in-interface=ether2 connection-state=new new-connection-


mark=ether2_conn action=mark-connection passthrough=yes

add chain=prerouting in-interface=ether3 connection-state=new new-connection-


mark=ether3_conn action=mark-connection passthrough=yes

add chain=output connection-mark=ether1_conn new-routing-mark=to_ether1


action=mark-routing passthrough=yes

add chain=output connection-mark=ether2_conn new-routing-mark=to_ether2


action=mark-routing passthrough=yes

add chain=output connection-mark=ether3_conn new-routing-mark=to_ether3


action=mark-routing passthrough=yes

4.2 Segunda parte, dividiendo las conexiones de los clientes y formando


grupos.
/ip firewall mangle

#Parte A
add chain=prerouting in-interface=ether5 connection-state=new dst-address-
type=!local per-connection-classifier=both-addresses:4/0 action=mark-connection new-
connection-mark=ether1_conn passthrough=yes

add chain=prerouting in-interface=ether5 connection-state=new dst-address-type=!local


per-connection-classifier=both-addresses:4/1 action=mark-connection new-connection-
mark=ether1_conn passthrough=yes

add chain=prerouting in-interface=ether5 connection-state=new dst-address-type=!local


per-connection-classifier=both-addresses:4/2 action=mark-connection new-connection-
mark=ether2_conn passthrough=yes

add chain=prerouting in-interface=ether5 connection-state=new dst-address-type=!local


per-connection-classifier=both-addresses:4/3 action=mark-connection new-connection-
mark=ether3_conn passthrough=yes

#Parte B
add chain=prerouting in-interface=ether5 connection-mark=ether1_conn action=mark-
routing new-routing-mark=to_ether1 passthrough=yes

add chain=prerouting in-interface=ether5 connection-mark=ether2_conn action=mark-


routing new-routing-mark=to_ether2 passthrough=yes
add chain=prerouting in-interface=ether5 connection-mark=ether3_conn action=mark-
routing new-routing-mark=to_ether3 passthrough=yes

4.3 [Opcional] Tercera parte, accediendo a nuestros routers desde la red


balanceada
/ip firewall mangle
add chain=prerouting dst-address=192.168.0.0/24 action=accept in-interface=ether5
add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=ether5
add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=ether5

5. Configurando las rutas, parte 2


/ip route
add gateway=192.168.0.1 routing-mark=to_ether1 check-gateway=ping
add gateway=192.168.1.1 routing-mark=to_ether2 check-gateway=ping
add gateway=192.168.2.1 routing-mark=to_ether3 check-gateway=ping

Вам также может понравиться