Вы находитесь на странице: 1из 33

ALGORITMOS

ETAPA 2

PRESENTADO POR:

GELVER YESID RIVERA RAMOS CODIGO:

GRUPO: 301303_296

TUTORA

DELVIS DEL SOCORRO MEJIA ALVAREZ

UNIVERSIDAD NACIONAL ABIERTA Y A DISTANCIA – UNAD


ESCUELA DE CIENCIAS BASICAS TECNOLOGIAS E INGENIERIAS
INGENIERIA EN ELECTRONICA
2017
//Nombre del Autor: Gelver Yesid Rivera Ramos
//Fecha:22-09-2017
//Doy fe que este ejercicio es de mi autoría, en caso de encontrar plagio la nota de todo mi
//trabajo debe ser de CERO además de las respectivas sanciones a que haya lugar.
1. Desarrolle un Algoritmo que de las instrucciones para preparar un plato típico de su
región que sea suficiente para 4 invitados (debe anexar una foto del plato en el foro) –lo
desarrollan todos –

//Nombre del autor: Gelver Yesid Rivera Ramos


//Fecha: 22-09-2019
//Doy fe que este ejercicio es de mi autoría en caso de encontrar plagio la nota de
todo mi trabajo debe ser CERO además de las respectivas sanciones a las que
haya lugar.

Proceso ejercicio1
Escribir ("ingrese el número de personas que quieren bandeja paisa");

a<-100
ca<-80
ch<-1
hu<-2
pa<-1
cz<-1
ar<-2
fr<-100
Leer n
Escribir ("para la preparación de la bandeja paisa se necesitan los
siguientes ingredientes");
Escribir ("arroz en gramos"),n*a
Escribir ("carne en gramos"),n*ca
Escribir ("chicharrón en unidades"),n*ch
Escribir ("huevo en unidades"),n*hu
Escribir ("patacón en unidades"),n*pa
Escribir ("Chorizo en unidades"),n*cz
Escribir ("arepa en unidades"),n*ar
Escribir ("frijol en gramos"),n*fr

FinProceso
//Nombre del Autor: Gelver Yesid Rivera Ramos
//Fecha:03-09-2017
//Doy fe que este ejercicio es de mi autoría, en caso de encontrar plagio la nota de todo mi
//trabajo debe ser de CERO además de las respectivas sanciones a que haya lugar.
2. Desarrolle un Diagrama o Algoritmo que permita leer dos valores y escribir la suma,
resta, multiplicación y división de estos números.

proceso ejercicio2

Escribir ("digite el primer valor");

Leer v1

Escribir ("digite el segundo valor");

Leer v2

Escribir ("digite la funcion que deseé segun el menu")

Escribir ("1 para suma");

Escribir ("2 para resta");

Escribir ("3 para divicion")

Escribir ("4 para multiplicacion")

Leer vo

Segun vo Hacer

opcion 1:

Escribir ("la suma de los dos valores es"),v1+v2

opcion 2:

Escribir ("la resta de los dos valores es"),v1-v2

opcion 3:

Escribir ("la divicion de los dos valores es"),v1/v2

opcion 4:

Escribir ("la multiplicacion de los dos valores es"),v1*v2

De Otro Modo:

Escribir ("opcion no valida");


Fin Segun

FinProceso
//Nombre del Autor: Gelver Yesid Rivera Ramos
//Fecha:22-09-2017
//Doy fe que este ejercicio es de mi autoría, en caso de encontrar plagio la nota de todo mi
//trabajo debe ser de CERO además de las respectivas sanciones a que haya lugar.
3. Desarrolle un Algoritmo que permita leer un valor entero, calcular su cuadrado y
mostrar su resultado.

Análisis.

Datos de entrada:

Proceso:

Elevar a N al cuadrado

Datos de salida:

𝑁2

Código que se usó en PSeInt para el ejercicio 3

//Nombre del autor: Gelver Yesid Rivera Ramos


//Fecha: 22-09-2019
//Doy fe que este ejercicio es de mi autoría en caso de encontrar plagio la nota de
todo mi trabajo debe ser CERO además de las respectivas sanciones a las que
haya lugar.
Proceso Ejercicio_3

Escribir "Ingresa número"

Leer N

cuadrado <- N * N

Escribir "El cuadrado es: ",cuadrado

FinProceso
//Nombre del Autor: Gelver Yesid Rivera Ramos
//Fecha:03-09-2017
//Doy fe que este ejercicio es de mi autoría, en caso de encontrar plagio la nota de todo mi
//trabajo debe ser de CERO además de las respectivas sanciones a que haya lugar.
4. Desarrollar un diagrama o algoritmo que permita ingresar el radio de un circulo para
determinar el área del mismo (consultar la formula), y mostrar su resultado.

Proceso ejercicio4

Escribir ("ingrese el radio del circulo");

Leer r

p<-(3.14)*(r*r)

Escribir ("el area del circulo es"),p

FinProceso
//Nombre del Autor: Gelver Yesid Rivera Ramos
//Fecha:22-09-2017
//Doy fe que este ejercicio es de mi autoría, en caso de encontrar plagio la nota de todo mi
//trabajo debe ser de CERO además de las respectivas sanciones a que haya lugar.
5. Desarrollar un Algoritmo que permita determinar la hipotenusa de un triángulo
rectángulo conocido los valores de las longitudes de los catetos.

Análisis:

Datos de entrada:

Cateto a

Cateto b

Proceso:

Hallar la Hipotenusa

Datos de salida:

Hipotenusa

Código que se usó en PSeInt Para el ejercicio 5

//Nombre del autor: Gelver Yesid Rivera Ramos


//Fecha: 22-09-2019
//Doy fe que este ejercicio es de mi autoría en caso de encontrar plagio la nota de
todo mi trabajo debe ser CERO además de las respectivas sanciones a las que
haya lugar.
Proceso Ejercicio_5

Escribir 'Ingrese cateto a'

Leer a

Escribir 'Ingrese cateto b'

Leer b

Hipotenusa<-rc [(a^2)+(b^2)]

Escribir 'la hipotenusa del triangulo es:',Hipotenusa;

FinProceso
//Nombre del Autor: Gelver Yesid Rivera Ramos
//Fecha:22-09-2017
//Doy fe que este ejercicio es de mi autoría, en caso de encontrar plagio la nota de todo mi
//trabajo debe ser de CERO además de las respectivas sanciones a que haya lugar.
6. Desarrollar un diagrama o algoritmo que leer la temperatura en grados
centígrados y muestre su resultado en Fahrenheit y kelvin.

Análisis:

Datos de entrada:

Grados Celsius ‘C’

Proceso:

Convertir grados Celsius en:

Fahrenheit

Kelvin.

Datos de salida:

Fahrenheit

Kelvin.

Código que se usó en PSeInt Para el ejercicio 6

//Nombre del autor: Gelver Yesid Rivera Ramos


//Fecha: 22-09-2019
//Doy fe que este ejercicio es de mi autoría en caso de encontrar plagio la nota de
todo mi trabajo debe ser CERO además de las respectivas sanciones a las que
haya lugar.
Proceso Ejercicio_6

Escribir 'ingrese el valor en grados C'

Leer C

Farenheit<- [(9.0/5.0)*C+32]

Kelvin<- (C+273.15)

Escribir 'En grados Farenheit es:',Farenheit;

Escribir 'En grados Kelvin es :',Kelvin;

FinProceso
//Nombre del Autor: Gelver Yesid Rivera Ramos
//Fecha:03-09-2017
//Doy fe que este ejercicio es de mi autoría, en caso de encontrar plagio la nota de todo mi
//trabajo debe ser de CERO además de las respectivas sanciones a que haya lugar.
12. Desarrollar un diagrama o algoritmo que permita determinar si un valor cualquiera es
positivo o negativo.

Proceso ejercicio12

Escribir ("ingrese un numero");

Leer n

Si n=0 Entonces

Escribir ("el numero es 0");

Sino

Si n>0 Entonces

Escribir ("el numero es positivo");

Sino

Escribir ("el numero es negativo");

Fin Si

Fin Si

FinProceso
//Nombre del Autor: Gelver Yesid Rivera Ramos
//Fecha:22-09-2017
//Doy fe que este ejercicio es de mi autoría, en caso de encontrar plagio la nota de todo mi
//trabajo debe ser de CERO además de las respectivas sanciones a que haya lugar.
13. Desarrollar un diagrama o algoritmo que permia determinar sin un valor
cualquiera es par o impar.

Análisis:

Datos de entrada:

Un numero ‘N’

Proceso:

Determinar si la salida es par o impar:

Datos de salida:

El número es par o impar.

Código que se usó en PSeInt Para el ejercicio 13

//Nombre del autor: Gelver Yesid Rivera Ramos


//Fecha: 22-09-2019
//Doy fe que este ejercicio es de mi autoría en caso de encontrar plagio la nota de
todo mi trabajo debe ser CERO además de las respectivas sanciones a las que
haya lugar.

Escribir ("ingrese numero N");

Leer N

Si N mod 2=0 Entonces

Escribir ("el número es par");

Sino

Escribir ("el número es impar");

Fin Si

FinProceso
//Nombre del Autor: Gelver Yesid Rivera Ramos
//Fecha:22-09-2017
//Doy fe que este ejercicio es de mi autoría, en caso de encontrar plagio la nota de todo mi
//trabajo debe ser de CERO además de las respectivas sanciones a que haya lugar.
17. Diseñar un diagrama o algoritmo que permita leer dos valores V1 y V2 y determine
cuál es el mayor y cuál es el menor o si son iguales

Análisis:

Datos de entrada:

Valor uno ‘V1’

Valor dos ‘V2’

Proceso:

Determinar cuál es el mayor, cuál es el menor o si son iguales:

Datos de salida:

Cuál es mayor, cuál menor o iguales..

Código que se usó en PSeInt Para el ejercicio 17

//Nombre del autor: Gelver Yesid Rivera Ramos


//Fecha: 22-09-2019
//Doy fe que este ejercicio es de mi autoría en caso de encontrar plagio la nota de
todo mi trabajo debe ser CERO además de las respectivas sanciones a las que
haya lugar.

Proceso Ejercicio_17

Escribir " Este programa lee dos números determina cual es el mayor, menor o
iguales."

Escribir ("Ingrese valor uno:");

Leer v1

Escribir ("Ingrese valor dos:");

Leer v2

Si v1>v2 Entonces
Escribir ("el valor uno es mayor que el valor dos");

Sino

Si v1<v2 Entonces

Escribir ("el valor uno es menor que el valor dos");

Sino

Escribir ("Los dos valores son iguales");

Fin Si

Fin si

FinProceso
//Nombre del Autor: Gelver Yesid Rivera Ramos
//Fecha:22-09-2017
//Doy fe que este ejercicio es de mi autoría, en caso de encontrar plagio la nota de todo mi
//trabajo debe ser de CERO además de las respectivas sanciones a que haya lugar.
18. Diseñe un diagrama o algoritmo que permita leer dos números N1 y N2 e indicar si
uno de los dos divide exactamente al otro.

Análisis:

Datos de entrada:

Un numero ‘n1’

Un numero ‘n2’

Proceso:

Determinar si la salida al dividir los números es exacta o no.

Datos de salida:

La división es exacta.

Código que se usó en PSeInt Para el ejercicio 18

//Nombre del autor: Gelver Yesid Rivera Ramos


//Fecha: 22-09-2019
//Doy fe que este ejercicio es de mi autoría en caso de encontrar plagio la nota de
todo mi trabajo debe ser CERO además de las respectivas sanciones a las que
haya lugar.
Proceso ejercicio_18

Escribir 'Ingrese dividendo n1';

Leer n1;

Escribir 'Ingrese divisor n2';

Leer n2;

división<-n1/n2;

Si división es entero Entonces

Escribir 'La división es exacta’, división;

Sino

Escribir 'El resultado no es exacto:’, división;


Fin Si

FinProceso
//Nombre del Autor: Gelver Yesid Rivera Ramos
//Fecha:22-09-2017
//Doy fe que este ejercicio es de mi autoría, en caso de encontrar plagio la nota de todo mi
//trabajo debe ser de CERO además de las respectivas sanciones a que haya lugar.
20. Desarrollar un Diagrama o Algoritmo que permita el ingreso de 3 números Num1,
Num2, Num3 e indicar si la suma de los 3 números es par o impar.

Análisis:

Datos de entrada:
Tres valores‘Nm1,Nm2,Nm3’
Un numero ‘n2’

Proceso:
Determinar si la suma de los tres valores es par o impar.
Datos de salida:

La salida es par o impar.

Código que se usó en PSeInt Para el ejercicio 20

//Nombre del autor: Gelver Yesid Rivera Ramos


//Fecha: 22-09-2019
//Doy fe que este ejercicio es de mi autoría en caso de encontrar plagio la nota de
todo mi trabajo debe ser CERO además de las respectivas sanciones a las que
haya lugar.
Proceso Ejercicio_20

Escribir ("Este programa hace una suma de tres valores y determina si es par o
impar")

Escribir ("ingrese tres valores");

Leer v1,v2,v3

suma<-v1+v2+v3

Si suma mod 2=0 Entonces

Escribir ("la suma de los numeros es par");

Sino

Escribir ("la suma de los numeros es impar");

Fin Si
Escribir (" El resultado de la suma es: ") , suma

FinProceso
//Nombre del Autor: Gelver Yesid Rivera Ramos
//Fecha:27-09-2017
//Doy fe que este ejercicio es de mi autoría, en caso de encontrar plagio la nota de todo mi
//trabajo debe ser de CERO además de las respectivas sanciones a que haya lugar.
23. Desarrolle un Diagrama o Algoritmo que permita determinar la nota mínima que usted
debe sacar en el examen final del curso Algoritmos de acuerdo a las condiciones actuales
75% y 25%(final), esta nota debe estar representada tanto en puntos y en nota (0..5.0). –
Lo desarrollan todos –

Análisis:

Datos de entrada:

Nota del 75% ‘n’

Proceso:

Determinar la nota del 25% para determinar la nota para aprobar.

Datos de salida:

‘n1’ Nota del 25% para aprobar el curso

‘n2’ Puntaje del 25% para aprobar el curso

Código que se usó en PSeInt Para el ejercicio 23

//Nombre del autor: Gelver Yesid Rivera Ramos


//Fecha: 27-09-2019
//Doy fe que este ejercicio es de mi autoría en caso de encontrar plagio la nota de
todo mi trabajo debe ser CERO además de las respectivas sanciones a las que
haya lugar.

Proceso Ejercicio_23
Escribir ("Digite nota del 75%");
Leer n
Si n<=5 Entonces
n1<-(3-(n*0.75))/0.25
n2<-(125/5)*n1
Si n1<=5 Entonces
Escribir ("Nota sobre el 25% mínima para aprobar el
curso es"),n1
Escribir ("Puntos sobre 125 que debe sacar son"),n2
Sino
Escribir ("No tiene oportunidad de aprobar el curso");
Fin Si

Sino
Escribir ("dato invalido");
Fin Si
FinProceso
//Nombre del Autor: Gelver Yesid Rivera Ramos
//Fecha:27-09-2017
//Doy fe que este ejercicio es de mi autoría, en caso de encontrar plagio la nota de todo mi
//trabajo debe ser de CERO además de las respectivas sanciones a que haya lugar.
25. Desarrollar un Algoritmo que permita determinar la fecha un día después a un fecha
ingresada (tenga en cuenta meses de 30, 31, 28 días, cambio de año, ejemplo 31-12-
2004 el día siguiente será 1-1-2005). Lo desarrollan todos –

Análisis:

Datos de entrada:

Nota del fecha

Proceso:

Actualizar la fecha un día después de la fecha ingresada.

Datos de salida:

Fecha un dia adelanre de la fecha ingresada.

Código que se usó en PSeInt Para el ejercicio 25

//Nombre del autor: Gelver Yesid Rivera Ramos


//Fecha: 27-09-2019
//Doy fe que este ejercicio es de mi autoría en caso de encontrar plagio la nota de
todo mi trabajo debe ser CERO además de las respectivas sanciones a las que
haya lugar.
Proceso ejercicio25

Escribir "ingrese la fecha en el orden dia/mes/año";

Leer d,m,a

Si m=12 o d=31 Entonces

Escribir "la nueva fecha es:",01,"/",01,"/",a+1;

Sino

d<-d+1

Si m=2 Entonces

Si (a mod 4=0) o (a mod 100!=0) Entonces

Si d>29 Entonces
m<-m+1

d<-1

Escribir "la nueva fecha es:",d,"-",m,"-",a,;

Sino

Escribir "la nueva fecha es:",d,"-",m,"-",a,;

Fin Si

Sino

Si d>28 Entonces

m<-m+1

d<-1

Escribir "la nueva fecha es:",d,"-",m,"-",a,;

Sino

Escribir "la nueva fecha es:",d,"-",m,"-",a,;

Fin Si

Fin Si

Sino

Si m=1 o m=3 o m=5 o m=7 o m=8 o m=10 o m=12 Entonces

Si d>31 Entonces

m<-m+1

d<-1

Escribir "la nueva fecha es:",d,"-",m,"-",a,;

Sino

Escribir "la nueva fecha es:",d,"-",m,"-",a,;

Fin Si

Sino

Si d>30 Entonces

m<-m+1

d<-1

Escribir "la nueva fecha es:",d,"-",m,"-",a,;


Sino

Escribir "la nueva fecha es:",d,"-",m,"-",a,;

Fin Si

Fin Si

Fin Si

Fin Si

FinProceso
//Nombre del Autor: Gelver Yesid Rivera Ramos
//Fecha:27-09-2017
//Doy fe que este ejercicio es de mi autoría, en caso de encontrar plagio la nota de todo mi
//trabajo debe ser de CERO además de las respectivas sanciones a que haya lugar.
27. Es necesario realizar un algoritmo que funcione como una calculadora con las 4
funciones básicas (opcional puede incluir otra función). El algoritmo termia y entrega el
resultado al presionar la tecla “=” lo desarrollan todos –

Análisis:

Datos de entrada:

0pcion ‘1’

0pcion ‘2’

0pcion ‘3’

0pcion ‘4’

Proceso:

Determinar la opción a realizar:

0pcion ‘1’ suma

0pcion ‘2’ resta

0pcion ‘3’ multiplica

0pcion ‘4’ divide

Datos de salida:

Al oprimir la tecla igual escribe el resultado de la opción tomada del menu.

Código que se usó en PSeInt Para el ejercicio 27

//Nombre del autor: Gelver Yesid Rivera Ramos


//Fecha: 27-09-2019
//Doy fe que este ejercicio es de mi autoría en caso de encontrar plagio la nota de
todo mi trabajo debe ser CERO además de las respectivas sanciones a las que
haya lugar.
Proceso calculadora_operaciones_basicas

Escribir 'Este programa le permite realizar operaciones basicas matematicas.'

Escribir ('1. SUMA')

Escribir ('2. RESTA')

Escribir ('3. MULTIPLICA')

Escribir ('4. DIVIDE')

Escribir (' Seleccione Opcion')

Leer opcion

Si opcion=1 Entonces

Escribir ('Digite el primer sumando')

Leer sumando1

Escribir ('Digite el segundo sumando')

Leer sumando2

n1<-sumando1+sumando2

Escribir ('Oprima la tecla = para obtenere el resultado de la suma")

Leer igual

Escribir " La sumatoria es ", n1

FinSi

Si opcion=2 Entonces

Escribir ('Digite el Minudendo')

Leer minuendo1

Escribir ('Digite el sustraendo ')

Leer sustraendo2

s2<-minuendo1-sustraendo2

Escribir ('Oprima la tecla = para obtenere la diferencia de la resata ")

Leer igual

Escribir " La diferencia es: " , s2

FinSi

Si opcion=3 Entonces
Escribir ('Digite el Multiplicando')

Leer multiplicando1

Escribir ('Digite el Multiplicador')

Leer multiplicador2

m3<-multiplicando1*multiplicador2

Escribir ('Oprima la tecla = para obtenere el producto de la multiplicación")

Leer igual

Escribir " El producto es : " , m3

FinSi

Si opcion=4 Entonces

Escribir ('Digite el primer numero')

Leer dividendo1

Escribir ('Digite el segundo numero')

Leer divisor2

d4<-dividendo1/divisor2

Escribir ('Oprima la tecla = para obtenere el resultado de la division")

Leer igual

Escribir " El resultao es: " , d4

FinSi

Si opcion<1 O opcion>4 Entonces

Escribir ('opcion no valida')

FinSi

FinProceso
Suma
Resta

Multiplica

Divide