Вы находитесь на странице: 1из 5

Guía de Practica No.

05
Curso: Principios de Algoritmos

Contenido
I. OBJETIVOS.................................................................................................................... 2
II. ESPECIFICACIÓN DEL EJERCICIO ....................................................................... 2
2.1. Enunciado del Problema .......................................................................................... 2
III. DESARROLLO DE LA SOLUCIÓN ......................................................................... 2
3.1. Descripción de la solución (explicación) ................................................................. 2
3.2. Desarrollo de la solución en pseudocódigo ............................................................. 3
3.3. Pantalla de PSeInt con el Pseudocódigo .................................................................. 3
3.4. Resultado del ejercicio ............................................................................................. 4
IV. EJERCICIOS PROPUESTOS ..................................................................................... 5
I. OBJETIVOS
 Implementar ciclos repetitivos con la estructura mientras.
 Aplicar el uso de contadores y acumuladores dentro de la estructura repetitiva
mientras.

II. ESPECIFICACIÓN DEL EJERCICIO

2.1. Enunciado del Problema


Hacer un pseudocódigo para hallar la suma de la siguiente serie de N términos.
1 1 1 1
1    ... 
2 3 4 N

III. DESARROLLO DE LA SOLUCIÓN

3.1. Descripción de la solución (explicación)

Datos de Entrada Proceso Salida


 Ingresar el valor  Leer N  Hallar la suma de
de N la serie
 Generar la serie 1,1/2,1/3, …1/N

 Si el índice (o denominador) es par,


realizar la operación de resta con la
fracción.

 Sino, realizar la operación de suma


con la fracción.

 Mostrar el resultado de la suma


3.2. Desarrollo de la solución en pseudocódigo
Proceso ejemploRepetitivo01Guia05
Escribir "Ingrese la cantidad de términos N";
Leer N;

suma <- 0
i <- 1

Si N>0 Entonces
Mientras i<=N Hacer
Si i MOD 2 = 0 Entonces
suma <- suma – 1/i
Sino
suma <- suma + 1/i
FinSi
i <- i+1
FinMientras
Escribir "La suma de la serie es:",suma
Sino
Escribir "Error al ingresar la cantidad de términos N"
FinSi
FinProceso

3.3. Pantalla de PSeInt con el Pseudocódigo


3.4. Resultado del ejercicio

 Pantalla de PSeInt sin error de ingreso en los datos

 Pantalla de PSeInt con error de ingreso en los datos


IV. EJERCICIOS PROPUESTOS

4.1. Hacer un pseudocódigo que determine el n-ésimo número perfecto.


Un número es perfecto si la suma de sus divisores (excepto el mismo número)
es igual al número.
Por ejemplo 6 es un número perfecto. Sus divisores son 1, 2 y 3; y su suma es
6.

4.2. Hacer un pseudocódigo que solicite ingresar un conjunto de números


(positivos, negativos o ceros). Luego, calcular y mostrar:
 La suma de todos los números negativos
 El producto de todos los números positivos
 El porcentaje de ceros (con relación al total de números ingresados)