You are on page 1of 4

INFO6047 NAT AND PAT

Hub
Hub

Sniffer

Build the Network and Verify Connectivity


Set up the routers with the assigned IP addresses as per the lab drawing
On the ISP router set the enable and telnet passwords to cisco

Create a default route from the Gateway router to the ISP router
Gateway(config)# ip route 0.0.0.0 0.0.0.0 209.165.201.17
Create a static route from the ISP router to the Gateway router
ISP(config)# ip route 209.165.200.224 255.255.255.248 209.165.201.18

Configure PC hosts
Cable the network as shown in the topology

Verify network connectivity


From the PC hosts, ping the G0/1 interface on the Gateway router

STATIC NAT
A static map is configured to tell the router to translate between the private inside server address
192.168.1.20 and the public address 209.165.200.225
Gateway(config)# ip nat inside source static 192.168.1.20 209.165.200.225

Specify the interfaces


Gateway(config)# interface g0/1
Gateway(config-if)# ip nat inside
Gateway(config-if)# interface g0/0
Gateway(config-if)# ip nat outside

Test the configuration


Display the static NAT table by issuing the show ip nat translation command
What is the translation of the inside local host address?
From PC-A, ping the Looback0 interface (192.31.7.1) on the ISP router
From PC-A, telnet to the Looback0 interface (192.31.7.1) on the ISP router

On the Gateway router, display the NAT table


Gateway# show ip nat translation

From PC-A, telnet to the ISP Loopback0 interface and display the NAT table
Gateway# show ip nat translation

Ping from the ISP to PC-A at the static NAT public address

On the Gateway router, display the NAT table to verify the translation
Gateway# show ip nat translation
Gateway# show ip nat statistics

Verify with the professor

DYNAMIC NAT
Dynamic NAT uses a pool of public addresses and assigns them on a first-come first-served
basis.

Clear NATs
Gateway# clear ip nat translation *
Gateway# clear ip nat statistics

Remove Static NAT


Gateway(config)# no ip nat inside source static 192.168.1.20 209.165.200.225

Define an access control list (ACL) that matches the LAN private IP address range
ACL 1 is used to allow 192.168.1.0/24 network to be translated
Gateway(config)# access-list 1 permit 192.168.1.0 0.0.0.255

Verify that the NAT interface configurations are still valid


Gateway# show ip nat statistics

Define the pool of usable public IP addresses


Gateway(config)# ip nat pool public_access 209.165.200.225 209.165.200.230 netmask
255.255.255.248

Define the NAT from the inside source list to the outside pool
Gateway(config)# ip nat inside source list 1 pool public_access

Verify the NAT configuration


In Wireshark capture a packet on both the inside (one of the PCs) and outside (Sniffer) networks
From each PC host, ping the 192.31.7.1 address on the ISP router
From each PC, telnet to the Looback0 interface on the ISP router
Compare the results of the same packet
From the packets captured on the PC what are the source and destination addresses?
From the packets captured on the Sniffer what are the source and destination addresses?

Display NAT table and statistics on the Gateway router


Gateway# show ip nat translation

How many Inside Local IP addresses are listed in the output above? __________
How many Inside Global IP addresses are listed? __________

Verify with the professor

PAT
PAT will be configured by using an interface instead of a pool of addresses to define the outside
address

Clear NATs and statistics on the Gateway router


Gateway# clear ip nat translation *
Gateway# clear ip nat statistics

Verify the configuration for NAT


Verify that the outside and inside interfaces are still configured for NATs
Verify that the ACL is still configured for NATs

Remove the NAT translation from inside source list to outside pool
Gateway(config)# no ip nat inside source list 1 pool public_access
Remove the pool of useable public IP addresses
Gateway(config)# no ip nat pool public_access 209.165.200.225 209.165.200.230 netmask
255.255.255.248

Associate the source list with the outside interface


Gateway(config)# ip nat inside source list 1 interface G 0/0 overload

Test the PAT configuration


In Wireshark capture a packet on both the inside (one of the PCs) and outside (Sniffer) networks
From each PC, ping the 192.31.7.1 address on the ISP router
From each PC, telnet to the 192.31.7.1 address on the ISP router

Compare the results of the pings and the telnets


From the packet captured on the PC what are the source and destination addresses?
From the packet captured on the Sniffer what are the source and destination addresses?

Display NAT statistics on the Gateway router


Gateway# show ip nat statistics

Display NAT translations on Gateway


Gateway# show ip nat translation

How many Inside local IP addresses are listed in the output above? __________
How many Inside global IP addresses are listed? __________
How many port numbers are used paired with the Inside global addresses _________

Verify with the professor

On the ISP router connect a VMWare image of an IIS web server to G0/0 interface
Assign the IP address 192.55.4.1 to the G0/0 interface
Assign the IP address 192.55.4.9 to the VMware image. Place the network adapter to bridged
mode.

In Wireshark capture a packet on both the inside (one of the PCs) and outside (Sniffer) networks
From each PC, http to the Web Server
Compare the results of the packets
From the packet captured on the PC what are the source and destination addresses?
What are the source and destination port numbers?
From the packet captured on the Sniffer what are the source and destination addresses?
What are the source and destination port numbers?

Display NAT statistics on the Gateway router


Gateway# show ip nat statistics

Display NAT translations on Gateway


Gateway# show ip nat translation

How many inside local IP addresses are listed in the output above? __________
How many inside global IP addresses are listed? __________
How many port numbers are used paired with the Inside global addresses _________

Verify with the professor