Вы находитесь на странице: 1из 4

Part 1 Subnetting

Part 2 Create VLANs


Creating VLANs (including native VLAN as VLAN 99)
Switch>en
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#vlan 10
Switch(config-vlan)#name vlan10
Switch(config-vlan)#vlan 20
Switch(config-vlan)#name vlan20
Switch(config-vlan)#vlan 30
Switch(config-vlan)#name vlan30
Switch(config-vlan)#vlan 40
Switch(config-vlan)#name vlan40
Switch(config-vlan)#vlan 50
Switch(config-vlan)#name vlan50
Switch(config-vlan)#vlan 60
Switch(config-vlan)#name vlan60
Switch(config-vlan)#vlan 99
Switch(config-vlan)#name vlan99
Switch(config-vlan)#
Configuring trunk and access ports
Switch#CONF T
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#INT F2/1
Switch(config-if)#SWItchport MOde TRUnk
Switch(config-if)#INT F3/1
Switch(config-if)#SWItchport MOde ACCESS
Switch(config-if)#SWItchport ACCess VLAN 10
Switch(config-if)#INT F0/1
Switch(config-if)#SWItchport MOde ACCess
Switch(config-if)#SWItchport ACCess VLan 10
Switch(config-if)#INT F1/1
Switch(config-if)#SWItchport MOde ACCess
Switch(config-if)#SWItchport ACCess VLAN 20
Part 3 Configure Router-on-a-Stick Inter-VLAN Routing
Router 1
Router>EN
Router#CONF T
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#INT F0/0
Router(config-if)#NO SHUtdown
Router(config-if)#EXIT
Router(config)#INT F0/0.10
Router(config-subif)#ENcapsulation DOt1Q 10
Router(config-subif)#IP ADD 172.30.254.1 255.255.255.0 ?
Router(config-subif)#INT F0/0.20
Router(config-subif)#ENcapsulation DOt1Q 20
Router(config-subif)#IP ADD 172.30.255.1 255.255.255.128
Router(config-subif)#int F1/0
Router(config-if)#NO SHUtdown
Router(config)#INT F1/0.30
Router(config-subif)#ENcapsulation DOt1Q 30
Router(config-subif)#IP ADDress 172.30.255.129 255.255.255.192
Router(config)#INT F1/0.40
Router(config-subif)#ENcapsulation DOt1Q 40
Router(config-subif)#IP ADDress 172.30.255.193 255.255.255.224
Router(config-subif)#
Router 2
Router>EN
Router#CONF T
Router(config)#INT F0/0
Router(config-if)#NO SHUtdown
Router(config)#INT F0/0.50
Router(config-subif)#ENcapsulation DOt1Q 50
Router(config-subif)#IP ADDress 172.30.255.225 255.255.255.240
Router(config-subif)#INT F0/0.60
Router(config-subif)#ENcapsulation DOt1Q 60
Router(config-subif)#IP ADD 172.30.255.241 255.255.255.248
Router(config-subif)#

Part 4 Set up DHCP for all VLANs


Router>en
Router#conf t
Router(config)#ip dhcp pool vlan10
Router(dhcp-config)#network 172.30.254.0 255.255.255.0
Router(dhcp-config)#DEFAUlt-router 172.30.254.1
Router(dhcp-config)#EXI
Router(config)#IP DHcp POOl vlan20
Router(dhcp-config)#network 172.30.255.1 255.255.255.128
Router(dhcp-config)#DEFAUlt-router 172.30.255.1
Router(dhcp-config)#EXI
Router(config)#IP DHcp POol vlan30
Router(dhcp-config)#network 172.30.255.128 255.255.255.192
Router(dhcp-config)#DEfault-router 172.30.255.129
Router(dhcp-config)#EXI
Router(config)#IP DHcp Pool vlan40
Router(dhcp-config)#network 172.30.255.192 255.255.255.224
Router(dhcp-config)#DEfault-router 172.30.255.193
Router(dhcp-config)#EXIT
Router(config)#IP DHcp EXcluded-address 172.30.254.2 172.30.254.30

Part 5 OSPF
Assign static IP addresses to Router 1 and Router 2 within WAN 70
Router 1
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int f4/0
Router(config-if)#IP ADD 172.30.255.249 255.255.255.252
Router(config-if)#NO SHUtdown
Router 2
Router>EN
Router#CONF T
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#INT F4/0
Router(config-if)#NO SHUtdown
Router(config-if)#IP ADD 172.30.255.250 255.255.255.252

Configure single area OSPF between R1 and R2.


Router 1
Router(config)#router ospf 1
Router(config-router)#network 172.30.254.0 255.255.255.0 AREa 0
Router(config-router)#network 172.30.255.0 255.255.255.128 AREa 0
Router(config-router)#network 172.30.255.128 255.255.255.192 AREa 0
Router(config-router)#network 172.30.255.192 255.255.255.224 AREa 0
Router(config-router)#network 172.30.255.248 255.255.255.252 AREa 0
Router(config-router)#PASS
Router(config-router)#PASSive-interface S2/0
Router(config-router)#PASsive-interface S3/0
Router(config-router)#PASSive-interface F5/0

Router 2
Router(config)#ROUter OSpf 1
Router(config-router)#NETWork 172.30.255.224 255.255.255.240 AREa 0
Router(config-router)#NETWork 172.30.255.240 255.255.255.248 AREa 0
Router(config-router)#NETWork 172.30.255.248 255.255.255.252 AREa 0
Router(config-router)#PASSive-interface F1/0
Router(config-router)#PASSive-interface S2/0
Router(config-router)#PASSive-interface S3/0
Router(config-router)#PASSive-interface F5/0

Part 6 Rapid PVST+


Switch(config)#spanning-tree mode rapid-pvst
Switch(config)#spanning-tree vlan 50 root primary
Switch(config)#spanning-tree vlan 60 root primary

Part 7 Secure devices


Router(config)#line console 0
Router(config-line)#PASSword class
Router(config-line)#login
Router(config-line)#exi

Router(config)#enable secret cisco

Router(config)#line vty 0 14
Router(config-line)#PASSword doNotUseTelnet
Router(config-line)#login

Router(config-line)#service password-encryption
access-list 10
Router(config)#access-list 10 PERmit HOst 172.30.254.3
Router(config)#INT F0/0.20
Router(config-subif)#IP ACCess-group 10 OUT

access-list 10

Router(config)#ACCess-list 20 PERmit 172.30.255.224 0.0.0.15


Router(config)#ACCess-list 20 PERmit 172.30.255.240 0.0.0.7
Router(config)#INT F1/0.30
Router(config-subif)#IP ACCess-group 20 OUT

Оценить