Вы находитесь на странице: 1из 5

PRINCIPALES CONTROLES DE FORMULARIO (continuación):

6. CASILLA .- Permiten al usuario seleccionar un valor, o desmarcarlo,


con tan solo hacer clic sobre la casilla. Al activar el resultado será
VERDADERO y al desactivarlos el resultado será FALSO.
Ej.: Crear 2 controles de formulario del tipo casilla que permitan activar
las opciones de LAVADO SENCILLO o DESMANCHADO en un servicio de
lavandería, en donde el lavado sencillo cuesta S/. 10 y el desmanchado
S/. 15.

7. CONTROL DE NUMERO .- Permite aumentar o disminuir el dato


numérico de una celda con incrementos y topes definidos.
Ej.: Crear un control de formulario del tipo control de numero que
permita ingresar la nota de un alumno.

8. BOTON .- Permite ejecutar macros de una forma mas directa ya que


al terminar de dibujarlo se muestra la ventana de ASIGNAR MACRO.
Ej.:
CREACION DE MACROS EN VISUAL BASIC
Procedimiento:
1. Ingresar al editor de Visual Basic, siguiendo una de las siguientes
formas:
a. Ficha DESARROLLADOR, grupo CODIGO, VISUALBASIC.
b. Presionar las teclas ALT + F11.
2. Si en caso no se visualiza el panel izquierdo se ingresa al menú VER,
EXPLORADOR DE PROYECTOS.
3. Crear la carpeta MODULOS con su respectivo MODULO1, ingresando al
menú INSERTAR, MODULO.
4. En la ventana mostrada se procede a digitar las instrucciones en Visual
Basic que crearan a la macro…
INSTRUCCIONES EN VISUAL Basic.- Una instrucción es una unidad
sintácticamente completa que expresa algún tipo de acción, declaración o
definición. Entre las instrucciones mas importantes tenemos:
1. SUB.- Permite declarar un procedimiento (macro) al cual se le asignara
un nombre seguido de paréntesis. Todas las instrucciones que
aparecen entre las instrucciones SUB y ENDSUB se ejecutaran.
2. REM o ‘.- Permite insertar comentarios dentro del procedimiento los
cuales no se ejecutaran y su fuente es de color verde.
3. SHEETS(hoja).- hace referencia a la hoja de calculo indicada la cual
debe estar escrita entre doble comilla.
4. SELECT.- Activa o selecciona las hojas y los objetos de las hojas.
5. RANGE(rango).- Hace referencia a una celda o rango de celdas, estas
deben estar escritas entre doble comilla.
6. ACTIVECELL.- Hace referencia a la primera celda de un rango
previamente seleccionado, también se utiliza para el ingreso de datos.
7. OFFSET(fila,columna).- Desplaza el puntero o una selección la cantidad
de filas y columnas especificadas. Si la fila es + se desplaza hacia abajo
y si es – hacia arriba. Si la columna es + se desplaza hacia la dercha y si
es – hacia la izquierda.
8. CLEARCONTENTS.- Borra el contenido de una celda o rango de celdas.
9. MSGBOX.- Crea una interfaz entre el usuario y el programa y sirve para
mostrar, recibir o devolver información del usuario.
10. GOTO etiqueta.- Realiza saltos durante el procedimiento hacia la
etiqueta.
11. IF = SI
12. VLOOKUP = BUSCARV
13. CHOOSE = ELEGIR
14. ISBLANK = ESBLANCO
Ej.:

Al terminar de digitar el contenido de la macro, se procede a cerrar el Visual


Basic, para luego guardar el libro junto con la macro con la opción…

y GUARDAR.
TAREA 3: Completar las 2 hojas del archivo TAREA N°3 para entregar el
próximo domingo 25. =SI(E31=1,35,25)