Вы находитесь на странице: 1из 11

10/24/2016 BGP Inject Maps ~ << Networks Baseline ­ Cisco Engineers Live >>

Privacy Policy

BGP Inject Maps


UNDEFINED
UNDEFINEDNo comments    
UNDEFINED
categories: BGP

Share This:    Facebook  Twitter  Google+  Stumble  Digg

Author:
Das Blinken Lichten

Boiled down inject maps look for a particular prefix, from a particular source, and if detected,
advertise other prefixes.  This is mostly used along with BGP aggregation to ‘un-aggregate’ certain
prefixes. Inject maps sort of let you break the traditional rules of BGP by allowing you to originate
routes into BGP without the use of a network or redistribute statement.  However, there are a couple
of rules to consider when using inject maps. Namely, you have to ensure that the prefix you are
injecting is one that is within an existing aggregate.  So you can’t just make up prefixes that you wish
to inject. 
Let’s pick the lab up from where we left it in the last post about unsuppress maps…

http://www.networksbaseline.in/2014/06/bgp­inject­maps.html 1/11
10/24/2016 BGP Inject Maps ~ << Networks Baseline ­ Cisco Engineers Live >>

Now, if you recall, at this point we have a nice summarization going on.  All of the routers have full
reachability to each other and each tier is aggregating it’s prefixes up to the next tier.  Let’s prove that
we have good connectivity by doing a ping between 175.15.1.1 (ISP B) and 175.15.17.1 (ISP C)…

Looks good.  Now, lets assume that ISP A starts having some link issues and the connection between
the two ISP A routers breaks…

http://www.networksbaseline.in/2014/06/bgp­inject­maps.html 2/11
10/24/2016 BGP Inject Maps ~ << Networks Baseline ­ Cisco Engineers Live >>

No worries right?  We still have the path through the upstream ISP to get between ISP B and ISP C. 
Let’s verify we still have connectivity…

No dice.  What’s going on?  Let’s check the path starting from the ISP B router…

Here you can see that ISP B has a summary route from ISP A for the entire /18 network with a next
hop of 10.0.0.13.  Sounds good, lets take a look at that ISP A router…

Here’s our problem.  While ISP A does have the /18 route, it’s only because its generating the route
itself.  A look at the routing table points that destination to null0.  So at this point, things look like this…

http://www.networksbaseline.in/2014/06/bgp­inject­maps.html 3/11
10/24/2016 BGP Inject Maps ~ << Networks Baseline ­ Cisco Engineers Live >>

The ISP A routers are more than happy to tell all of their BGP peers about the /18 aggregate the
have.  This includes the routers who are sending the aggregated prefixes (ISP B and C).  ISP B and C
are telling their upstream peers in ISP A about their aggregate for their respective /20s.  The ISP A
routers are only advertising the aggregate to the upstream ISP.  Even if the upstream ISP advertised
the route back down to the other ISP A router, it wouldn’t look as appealing as the aggregate that the
router itself was generating to null0.  That besides the point though since the receiving ISP A router
will ditch the advertisement once it sees it’s own AS in the AS-path. 
So how do we fix this?  One way, is to use inject maps.  As mentioned above, the inject map allows a
BGP router to advertise a smaller prefix of a larger aggregate so long as the aggregate is being
learned from a specific BGP peer.  It’s sort of hard to get your mind around without an example so
let’s just jump into the configuration.  All of the configuration will be done on the upstream ISP router…
The first thing we have to do is build a route-map that specifies which prefixes we wish to inject…

The first step is to configure two prefix lists that match the ISP B and C aggregate (the /20) that we
wish to inject.  Next, we match them up with a route-map.  NOTE!!!!  Do not use the ‘match’
command in the route-map to specify the prefix-list.  You MUST use the ‘set’ command.

Next we configure the match piece of the inject map.  These prefix lists are used to match the BGP

http://www.networksbaseline.in/2014/06/bgp­inject­maps.html 4/11
10/24/2016 BGP Inject Maps ~ << Networks Baseline ­ Cisco Engineers Live >>

peer from which the aggregate is received as well as the aggregate we are looking for.  These are
then matched up in two route-maps.  Route-map ‘learnedb’ matches on the aggregate address
(175.15.0.0/18) being advertised as well as the route-source of that advertisement which should be
the ISP A router a1 (10.0.0.22).  I do the same for the other side calling that route-map ‘learnedc’. 

The final step is to tell the BGP process to use the inject maps.  This is done under the BGP process by
specifying the inject-map command matching the inject route-map you created and matching it to an
exist-map of the second route-map you created. 
If it all worked out as expected, you should be able to verify that the upstreamISP router is injecting
the routes with the ‘show ip bgp injected-paths’ command…

The ISP A routers should now also have a valid /20 path to each of their respective downstream
ISPs…

And with any luck, connectivity is restored!

At the concept level, inject-maps are rather easy to grasp, but their configuration can be hard to recall
and get right on the first go around.  Here’s the entire configuration that I used on the upstreamISP
router to make it work.  Sometimes it’s easier to see it all in one big block…
hostname upstreamISP interface FastEthernet0/0
ip address 10.0.0.21 255.255.255.252
duplex auto
speed auto
no shut
!
interface FastEthernet0/1
ip address 10.0.0.25 255.255.255.252
http://www.networksbaseline.in/2014/06/bgp­inject­maps.html 5/11
10/24/2016 BGP Inject Maps ~ << Networks Baseline ­ Cisco Engineers Live >>

duplex auto
speed auto
no shut router bgp 400
no synchronization
bgp log-neighbor-changes
neighbor 10.0.0.22 remote-as 200
neighbor 10.0.0.26 remote-as 200
no auto-summary ip prefix-list ispb_aggregate permit 175.15.0.0/20
ip prefix-list ispc_aggregate permit 175.15.16.0/20 ip prefix-list from_ispa1 permit 10.0.0.22/32
ip prefix-list from_ispa2 permit 10.0.0.26/32 ip prefix-list learned permit 175.15.0.0/18 route-map
inject_ispb permit 10
set ip address prefix-list ispb_aggregate route-map inject_ispc permit 10
set ip address prefix-list ispc_aggregate route-map learnedb permit 10
match ip address prefix-list learned
match ip route-source prefix-list from_ispa1 route-map learnedc permit 10
match ip address prefix-list learned
match ip route-source prefix-list from_ispa2 router bgp 400
bgp inject-map inject_ispc exist-map learnedc
bgp inject-map inject_ispb exist-map learned

Original Post:
http://www.dasblinkenlichten.com/category/cisco/page/2/

+1   Recommend this on Google

Related Posts:

BGP confederations
By using BGP confederations a full iBGP mesh between routers is to break the routers
into sub-autonomous systems.  This is referred to as confedera… Read More

BGP Communities
BGP communities can be summarized as a set of tags that can be used to further
classify BGP prefixes.  That might not be a ‘RFC’ definition, but in m… Read More

BGP LABS by GNS3Vault


A good collection of BGP Labs by GNS3Vault. BGP Filtering Extended Access-List BGP
AS Path Access List BGP Conditional Advertisement BGP Multipa… Read More

BGP RR( BGP Route Reflectors)


One of the main points to remember about iBGP relationships is that iBGP assumes that
all of the routers within a single AS are fully meshed.  That i… Read More

BGP Disable-Connected-Check

http://www.networksbaseline.in/2014/06/bgp­inject­maps.html 6/11
10/24/2016 BGP Inject Maps ~ << Networks Baseline ­ Cisco Engineers Live >>

The neighbor disable-connected-check command is used to disable the connection


verification process for eBGP peering sessions that are reachable … Read More

Newer Post Home Older Post

0 comments:

Post a Comment

Enter your comment...

Comment as:  Unknown (Google) Sign out

Publish   Preview   Notify me

Links to this post


Create a Link

Subscribe to: Post Comments (Atom)


Popular Posts

OSI Model
The Open Systems Interconnection model ( OSI )is a conceptual model that characterizes
and standardizes the inner functions of a communica...

http://www.networksbaseline.in/2014/06/bgp­inject­maps.html 7/11
10/24/2016 BGP Inject Maps ~ << Networks Baseline ­ Cisco Engineers Live >>

Secure Socket Layer ( SSL) Connection Setup


SSL (Secure Sockets Layer) is a standard security technology for establishing an
encrypted link between a server and a client—typically a w...

Traceroute
Traceroute, by default, sends a sequence of User Datagram Protocol (UDP) packets
addressed to a destination host; ICMP Echo Request or TCP ...

F5 Load Balancers: LTM vs GTM


F5® BIG-IP® Global Traffic Manager™ (GTM) distributes DNS and user application
requests based on business policies, data center and cloud s...

Comparison of Routers Cisco, Juniper and Huawei


Comparison of Routers Cisco, Juniper and Huawei # Cisco , Juniper and Huawei Router
comparison # CCI E Candidates only # MPLS requireme...

OSPF : "34 Things to remember"


Open Shortest Path First (OSPF) is a routing protocol for Internet Protocol (IP) networks. It uses a link
state routing algorithm and fal...

Cisco ASR 1002-X Basics


Cisco ASR 1002-X   # Cisco Routers #CCIE Candidates  # ASR Routers Specifications #
Capacity and Utilization # RP and ESP Processors ...

Interview questions for Networking Engineer's( CCNA/CCNP and CCIE candidates )


Please find some of the questions who are preparing for the interviews ( CCNA/CCNP) These are the
questions for the Network Engineer bas...

CISCO-JUNIPER COMMANDS REF


Cisco Command Juniper Command Co-Ordinating Definition show ip interface brief show interface
terse displays the status of interface...

LACP and PAgP


Hi so we have the Following descriptions of all these what is LACP and PAgP. What is Ether Channel?
Ether Channel links shaped while  or...


Search Search

TOTAL PAGEVIEWS
http://www.networksbaseline.in/2014/06/bgp­inject­maps.html 8/11
10/24/2016 BGP Inject Maps ~ << Networks Baseline ­ Cisco Engineers Live >>

1,561,346

BLOG ARCHIVE

Blog Archive

LIKE US !!

Networks­Baseline
82,630 likes

Liked Sign Up

You like this

CATEGORIES
access Lists (3) ADSL (3) Alcatel-Lucent (2) ARP (4) ASA (8) ATM (2) Basic Commands (3) Basics (13)
BGP (31) Brocade (1) Cables (1) CatOS (1) CCIE (3) CCIE Datacenter (22) CCNA (7)
CCNP (1) Checkpoint (3) Cisco (4) Cisco ASR (7) Cisco Icons (1) Cisco MDS Switch Cisco Routers (12)
(1)
Cisco Switches (7) Cisco Wireless (2) Cloud Computing (2) Data Center (17) DHCP (4) DWDM (1)
EIGRP (7) Etherchannel (3) F5 (2) Fiber Optics (1) Firewall (2) Fortinet (1) GLBP (5) GNS3 (2) Huawei (4)
interview Questions (1) IOS (1) IOS Upgradation (3) IoT (1) IP Addressing (2) IPV6 (2) Juniper (13) LABS (2)

MPLS (21) MPLS Traffic Engg. (3) MTU (5) Multicast (3) Nexus (20) OSI
Load Balancing (5)
Model (1) OSPF (22) OTV (2) Palo-Alto (2) Password Recovery (1) Physical (1) PPP (2) Riverbed (3) RSTP
(2) SDN & NFV (2) SSL (1) Stack (1) subnetting (3) Switching (9) TACACS (1) TCP (2) TCP and UDP ports (2)
Technology (1) Terminal Server (1) Topologies (5) Traceroute (2) VLAN (4) VPN (3) VRRP (4) WAN
optimization (4)

FEEDJIT

http://www.networksbaseline.in/2014/06/bgp­inject­maps.html 9/11
10/24/2016 BGP Inject Maps ~ << Networks Baseline ­ Cisco Engineers Live >>

Live Traffic Feed
A visitor from New Delhi,
Delhi arrived 12 secs ago
A visitor from Islamabad
arrived 8 mins ago
A visitor from Stockton,
California viewed "Point­to­
Point Protocol (PPP), the
Link Control Protocol (LCP)
and CHAP (Challenge­
A visitor from Lansing,
Handshake Authentication
Michigan viewed "The
Protocol) ~" 11 mins ago
Concept of PHP (Penultimate
Hop Popping) ­ MPLS ~" 12
A visitor from United States
mins ago
viewed "F5 Load Balancers:
LTM vs GTM ~" 16 mins ago
A visitor from La Paz viewed
"BGP: Path Selection Criteria
­ Path Vector Protocol ~" 17
A visitor from Ramsis, Al
mins ago
Buhayrah viewed ": BGP" 17
mins ago
A visitor from Pune,
Maharashtra viewed "F5 Load
Balancers: LTM vs GTM ~"
21 mins ago
A visitor from Karachi, Sindh
viewed "OSPF Area and LSAs
Propagation. ~" 30 mins ago
A visitor from Doha, Ad
Dawhah viewed "25 Things to
remember about EIGRP:
Short and Simple ~" 34 mins
Real­time view · Get Feedjit

ALEXA

Copyright@ 2006-2015 Networks-Baseline. Powered by Blogger.

http://www.networksbaseline.in/2014/06/bgp­inject­maps.html 10/11
10/24/2016 BGP Inject Maps ~ << Networks Baseline ­ Cisco Engineers Live >>

Copyright © 2016 << Networks Baseline - Cisco Engineers Live >> | Powered by Blogger
Design by BluChic | Blogger Theme by Lasantha - PremiumBloggerTemplates.com | BTheme.net | Distributed
By Gooyaabi Templates

http://www.networksbaseline.in/2014/06/bgp­inject­maps.html 11/11

Вам также может понравиться