Вы находитесь на странице: 1из 70

COPYRIGHT INFORMATION

This publication, CCNA LAB WORKBOOK, was developed by Mohamed Ouamer. All rights
reserved. No part of this publication may be reproduced or distributed in any form or by any
means without the prior written permission of Mohamed Ouamer.

Cisco®, Cisco Systems®, CCDA®, CCNA®, CCDP®, CCNP®, CCIE®, CCSI®, the Cisco
Systems logo and the CCIE logo are trademarks or registered trademarks of Cisco Systems,
Inc. in the United States and certain other countries. All other trademarks are trademarks of
their respective owners.

If you have questions or concerns about our Copyright information, please email us at
contact@networkexperttraining.com.

DISCLAIMER

The following publication, CCNA LAB WORKBOOK, is developed to assist candidates in the
preparation for Cisco Systems’ CCNA exam.
While every effort has been made to ensure that all material is as complete and accurate as
possible, the enclosed material is presented on an “as is” basis. Neither the authors nor
networkexperttraining.com assume any liability or responsibility to any person or entity with
respect to loss or damages incurred from the information contained in this workbook.

If you have questions or concerns about our disclaimer, please email us at


contact@networkexperttraining.com.

ERRATA

Although we have taken every care to ensure the accuracy of our contents, mistakes do
happen. If you find a mistake in this workbook—maybe a mistake in text or configuration—we
would be grateful if you would report this to us. By doing this you can save other readers from
frustration, and help to improve subsequent versions of this workbook. If you find any errata,
report them by contacting us at support@networkexperttraning.com. Once your errata have
been verified, your submission will be accepted and the errata added to the list of existing
errata. . The existing errata can be requested by by contacting us at
support@networkexperttraning.com.
TABLE OF CONTENTS:

RIPV1…………………………………...……………………………………………………………… 4
RIPV2…………………………………………………………..………………………………………. 10
RIPV2 OVER FRAME RELAY…………………………………………………………………………... 19
RIP UPDATE VERSIONS……………………………………………………………………………….. 33
RIP UNICAST UPDATES……………………………………...………………………………………... 41
RIPV2 AUTHENTICATION………………………………………………………………………………. 49
DEFAULT ROUTING ……………………………………………………………..……………………… 58
RIP ADVANCED SCENARIO…………………………………………………………………………..... 65
CCNA LAB WORKBOOK  RIP 

LAB 1: RIPV1

I. Network diagram:

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 1/1 
CCNA LAB WORKBOOK  RIP 

II. Initial Configuration


R1:
hostname R1
!
!
interface Loopback0
ip address 1.2.3.1 255.255.255.0
!
interface Loopback1
ip address 10.1.4.1 255.255.252.0
!
interface FastEthernet0/0
ip address 10.1.12.1 255.255.255.0
duplex auto
speed auto
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end
R2:
hostname R2
!
!
interface Loopback0
ip address 2.3.4.2 255.255.255.0
!
interface Loopback1
ip address 10.1.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.12.2 255.255.255.0
!
!
line con 0
exec-timeout 0 0
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 2/2 
CCNA LAB WORKBOOK  RIP 

logging synchronous
!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end

III. Tasks:
1. Enable RIPv1 on the routers and advertise all the subnets.

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 3/3 
CCNA LAB WORKBOOK  RIP 

IV. Solutions:
Task 1:

R1:
R1#configure terminal
R1(config)#router rip
R1(config-router)# version 1
R1(config-router)# network 1.0.0.0
R1(config-router)# network 10.0.0.0
R1(config-router)#end
R1#
R2:
R2#configure terminal
R2(config)#router rip
R2(config-router)# version 1
R2(config-router)# network 2.0.0.0
R2(config-router)# network 10.0.0.0
R2(config-router)#end
R2#

Verification:

R1:
R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets


C 1.2.3.0 is directly connected, Loopback0
R 2.0.0.0/8 [120/1] via 10.1.12.2, 00:00:25, FastEthernet0/0
10.0.0.0/24 is subnetted, 3 subnets
R 10.1.2.0 [120/1] via 10.1.12.2, 00:00:25, FastEthernet0/0
C 10.1.4.0 is directly connected, Loopback1
C 10.1.12.0 is directly connected, FastEthernet0/0
R1#

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 4/4 
CCNA LAB WORKBOOK  RIP 

R2:
R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

R 1.0.0.0/8 [120/1] via 10.1.12.1, 00:00:17, FastEthernet0/0


2.0.0.0/24 is subnetted, 1 subnets
C 2.3.4.0 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 2 subnets
C 10.1.2.0 is directly connected, Loopback1
C 10.1.12.0 is directly connected, FastEthernet0/0
R2#

The subnet 10.1.4.0/22 is not advertised to R2 out the interface F0/0 because of the
following reasons:
It has the major network as the interface F0/0.
His subnet mask do not match the interface F0/0’s subnet mask or the /32 subnet mask.

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 5/5 
CCNA LAB WORKBOOK  RIP 

V. Links:
For more information about the commands used in this lab, use the following links:
1. network
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_n1g.html#w
p1040868
2. router rip
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_o1g.html#w
p1038229
3. show ip route
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039689
4. show ip protocols
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039132
5. show ip rip database
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039551
6. version
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1042845

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 6/6 
CCNA LAB WORKBOOK  RIP 

LAB 2: RIPV2 - BASIC CONFIGURATION

I. Network diagram:

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 1/1 
CCNA LAB WORKBOOK  RIP 

II. Initial Configuration :


R1:
hostname R1
!
interface Loopback0
ip address 192.168.12.129 255.255.255.128
!
interface Loopback1
ip address 192.168.3.1 255.255.255.240
!
interface Loopback2
ip address 1.1.0.1 255.255.0.0
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.240
no shutdown
!
!
line console 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
end

R2:
hostname R2
!
!
interface Loopback0
ip address 192.168.2.2 255.255.255.192
!
interface Loopback1
ip address 192.168.12.65 255.255.255.240
!
interface Loopback2
ip address 2.2.2.2 255.255.255.255
!
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 2/2 
CCNA LAB WORKBOOK  RIP 

interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.240
no shutdown
!
!
line console 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
end

III. Tasks:
1. Enable RIPv2 on R1 and R2, and advertise all R1’s and R2’s interfaces in
the RIP domain.
2. Configure R1 to send the subnet information associated with the networks
1.1.0.0/16 and 192.168.3.0/28 to R2.
3. Configure R2 to advertise the subnet 192.168.2.0/26 with its real subnet
mask.

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 3/3 
CCNA LAB WORKBOOK  RIP 

IV. Solutions :
Task 1:
R1:
R1#configure terminal
R1(config)# router rip
R1(config-router)#version 2
R1(config-router)#network 1.0.0.0
R1(config-router)#network 192.168.12.0
R1(config-router)#network 192.168.3.0

R2:
R2#configure terminal
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 2.0.0.0
R2(config-router)#network 192.168.2.0
R2(config-router)#network 192.168.12.0

To advertise an interface in the RIP domain, you should use the network command.

The network command has the following syntax:


network {ip-address}
The ip-address parameter is the major network associated with the interface to be
advertised. The table below shows the major network associated with each interface on R1
and R2.

Router R1 Router R2
Major
Subnet Subnet Major Network
Network
192.168.12.0/28 – F0/0 192.168.12.0 192.168.12.2/28 – F0/0 192.168.12.0
192.168.12.128/25 – Lo0 192.168.12.0 192.168.2.2/26 – Lo0 192.168.2.0
192.168.3.0/28 – Lo1 192.168.3.0 192.168.12.65/28 – Lo1 192.168.12.0
1.1.0.1/16 – Lo2 1.0.0.0 2.2.2.2/32 – Lo2 2.0.0.0

Verification:
To verify your configuration you can use the following statements:
• Show ip route rip
• Debug ip rip
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 4/4 
CCNA LAB WORKBOOK  RIP 

The show ip route rip statement shows the routes of the route table received via the RIP
protocol. In General, not all the RIP routes received from RIP routers are installed in the route
table.

R1:
R1#show ip route rip
192.168.12.0/24 is variably subnetted, 3 subnets, 2 masks
R 192.168.12.64/28 [120/1] via 192.168.12.2, 00:00:16, FastEthernet0/0
R 2.0.0.0/8 [120/1] via 192.168.12.2, 00:00:16, FastEthernet0/0
R 192.168.2.0/24 [120/1] via 192.168.12.2, 00:00:16, FastEthernet0/0

Because the auto-summary is configured by default on R1 and R2, they will try to advertise
their networks in a classful manner.

Router R2 has three subnets to announce to R1, which are:

1. 192.168.2.0/26
2. 192.168.12.64/28
3. 2.2.2.2/32

The subnet 192.168.12.0/28 is not announced to R1 because it is associated with the interface
connecting R2 to R1 and split horizon is enabled on this interface.

When the auto-summary command is used, the router does the following check before
announcing a subnet out a RIP-enabled interface:

1. If the subnet has the same major network as the current interface, the subnet will be
advertised with its real subnet mask.

2. If the subnet does not have the same major network as the current interface, the router
will advertise the major network of that subnet with a classful subnet mask (/8 for class
A major network, /16 for class B major network, and /24 for class C major network).

Because of this, router R2 will advertise to R1 the route 192.168.2.0/24 instead of


192.168.2.0/26, 2.0.0.0/8 instead of 2.2.2.2/32, and 192.168.12.64/28 (it has the same major
network as the interface F0/0).
R2:

R2#show ip route rip


192.168.12.0/24 is variably subnetted, 3 subnets, 2 masks
R 192.168.12.128/25 [120/1] via 192.168.12.1, 00:00:22, FastEthernet0/0
R 1.0.0.0/8 [120/1] via 192.168.12.1, 00:00:22, FastEthernet0/0
R 192.168.3.0/24 [120/1] via 192.168.12.1, 00:00:22, FastEthernet0/0

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 5/5 
CCNA LAB WORKBOOK  RIP 

Router R1 has three subnets to announce to R2, which are:

1. 192.168.3.0/28
2. 192.168.12.128/25
3. 1.1.0.0/16

The subnet 192.168.12.0/28 is not announced to R2 because it is associated with the interface
connecting R1 to R2 and split horizon is enabled on this interface.

From the output of the show ip route rip command; you see that R1 is advertising to R2 the
route 192.168.3.0/28 instead of 192.168.3.0/26, 1.0.0.0/8 instead of 1.1.0.0/16, and
192.168.12.128/25 (it has the same major network as the interface F0/0).

The debug ip rip command helps you see the current behavior of the RIP process. The output
shows the following information:

• The version, and the source of the RIP updates received/sent out each RIP-enabled
interface.
• The destination IP address of the RIP updates out each RIP-enabled interface.
• The routes advertised out each RIP-enabled interface along with their subnet masks,
tags, the next-hop router and metrics.
• Error messages.

A next-hop address of 0.0.0.0 means that the router sourcing the update is the next-hop for
that route.

R2:
*Mar 1 00:02:20.695: RIP: received v2 update from 192.168.12.1 on FastEthernet0/0
*Mar 1 00:02:20.695: 1.0.0.0/8 via 0.0.0.0 in 1 hops
*Mar 1 00:02:20.699: 192.168.3.0/24 via 0.0.0.0 in 1 hops
*Mar 1 00:02:20.699: 192.168.12.128/25 via 0.0.0.0 in 1 hops
*Mar 1 00:02:29.507: RIP: sending v2 update to 224.0.0.9 via Loopback1 (192.168.12.65)
*Mar 1 00:02:29.507: RIP: build update entries
*Mar 1 00:02:29.511: 1.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Mar 1 00:02:29.511: 2.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:02:29.515: 192.168.2.0/24 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:02:29.519: 192.168.3.0/24 via 0.0.0.0, metric 2, tag 0
*Mar 1 00:02:29.519: 192.168.12.0/28 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:02:29.523: 192.168.12.128/25 via 0.0.0.0, metric 2, tag 0
*Mar 1 00:02:29.535: RIP: ignored v2 packet from 192.168.12.65 (sourced from one of our
addresses)
*Mar 1 00:02:31.851: RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (192.168.12.2)
*Mar 1 00:02:31.851: RIP: build update entries
*Mar 1 00:02:31.855: 2.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:02:31.859: 192.168.2.0/24 via 0.0.0.0, metric 1, tag 0
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 6/6 
CCNA LAB WORKBOOK  RIP 

*Mar 1 00:02:31.859: 192.168.12.64/28 via 0.0.0.0, metric 1, tag 0


*Mar 1 00:02:32.167: RIP: sending v2 update to 224.0.0.9 via Loopback0 (192.168.2.2)
*Mar 1 00:02:32.167: RIP: build update entries
*Mar 1 00:02:32.171: 1.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Mar 1 00:02:32.171: 2.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:02:32.175: 192.168.3.0/24 via 0.0.0.0, metric 2, tag 0
*Mar 1 00:02:32.179: 192.168.12.0/24 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:02:32.183: RIP: ignored v2 packet from 192.168.2.2 (sourced from one of our
addresses)
*Mar 1 00:02:33.051: RIP: sending v2 update to 224.0.0.9 via Loopback2 (2.2.2.2)
*Mar 1 00:02:33.051: RIP: build update entries
*Mar 1 00:02:33.055: 1.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Mar 1 00:02:33.055: 192.168.2.0/24 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:02:33.059: 192.168.3.0/24 via 0.0.0.0, metric 2, tag 0
*Mar 1 00:02:33.063: 192.168.12.0/24 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:02:33.067: RIP: ignored v2 packet from 2.2.2.2 (sourced from one of our addresses)

Task 2:
To accomplish this task, you should add the no auto-summary to RIP configuration on R1.
R1#configure terminal
R1(config)# router rip
R1(config-router)#no auto-summary

Verification:
R2#show ip route rip
192.168.12.0/24 is variably subnetted, 3 subnets, 2 masks
R 192.168.12.128/25 [120/1] via 192.168.12.1, 00:00:22, FastEthernet0/0
R 1.1.0.0/16 [120/1] via 192.168.12.1, 00:00:22, FastEthernet0/0
R 192.168.3.0/28 [120/1] via 192.168.12.1, 00:00:22, FastEthernet0/0

Task 3:
To accomplish this task, you should add the no auto-summary to RIP configuration on R2.
R2#configure terminal
R2(config)# router rip
R2(config-router)#no auto-summary

Verification:
R1#show ip route rip
192.168.12.0/24 is variably subnetted, 3 subnets, 2 masks
R 192.168.12.64/28 [120/1] via 192.168.12.2, 00:00:16, FastEthernet0/0
R 2.2.2.2/32 [120/1] via 192.168.12.2, 00:00:16, FastEthernet0/0

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 7/7 
CCNA LAB WORKBOOK  RIP 

R 192.168.2.0/26 [120/1] via 192.168.12.2, 00:00:16, FastEthernet0/0

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 8/8 
CCNA LAB WORKBOOK  RIP 

V. Links:
For more information about the commands used in this lab, use the following links:
1. auto-summary
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_a1g.html#w
p1039007
2. network
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_n1g.html#w
p1040868
3. router rip
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_o1g.html#w
p1038229
4. show ip route
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039689
5. version
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1042845

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 9/9 
CCNA LAB WORKBOOK  RIP 

LAB 3: RIPV2 OVER FRAME RELAY

I. Network diagram:

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 1/1 
CCNA LAB WORKBOOK  RIP 

II. Initial Configuration:


R1:
hostname R1
!
interface Loopback0
ip address 212.16.1.1 255.255.255.0
!
interface Serial0/0
encapsulation frame-relay
no frame-relay inverse-arp
!
interface Serial0/0.123 multipoint
ip address 212.16.123.1 255.255.255.0
frame-relay map ip 212.16.123.2 102 broadcast
frame-relay map ip 212.16.123.3 103 broadcast
!
!
line console 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
end

R2:
hostname R2
!
interface Loopback0
ip address 212.16.2.2 255.255.255.128
!
interface Serial0/0
encapsulation frame-relay
no frame-relay inverse-arp
ip address 212.16.123.2 255.255.255.0
frame-relay map ip 212.16.123.1 201 broadcast
frame-relay map ip 212.16.123.3 201 broadcast
!
!
line console 0
exec-timeout 0 0
logging synchronous
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 2/2 
CCNA LAB WORKBOOK  RIP 

!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
end

R3:
hostname R3
!
interface Loopback0
ip address 212.16.3.3 255.255.255.192
!
interface Serial0/0
encapsulation frame-relay
no frame-relay inverse-arp
ip address 212.16.123.3 255.255.255.0
frame-relay map ip 212.16.123.1 301 broadcast
frame-relay map ip 212.16.123.2 301 broadcast
!
!
line console 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
end

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 3/3 
CCNA LAB WORKBOOK  RIP 

III. Tasks:
1. Configure RIPv2 on R1, R2, and R3 according to the network diagram.
Disable auto-summarization.
2. Why R2 and R3 are advertising the subnet 212.16.1.0/24 back to R1?
Configure R2 and R3 to stop this behavior.
3. Configure R1 such that R2 and R3 can ping each other’s loopback interface.

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 4/4 
CCNA LAB WORKBOOK  RIP 

IV. Solutions :

Task 1:
To enable RIPv2 on the router, you should use the router, and version commands.
R1:
R1#configure terminal
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 212.16.123.0
R1(config-router)#network 212.16.1.0
R1(config-router)#no auto-summary
R2:
R2#configure terminal
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 212.16.123.0
R2(config-router)#network 212.16.2.0
R2(config-router)#no auto-summary
R3:
R3#configure terminal
R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#network 212.16.123.0
R3(config-router)#network 212.16.3.0
R3(config-router)#no auto-summary

Verification:
To verify your configuration you can use the following statements:
• Show running-config | b router rip
• Show ip route rip
• Debug ip rip

R1:
R1#show running-config | b router rip
router rip
version 2
network 212.16.1.0
network 212.16.123.0
no auto-summary

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 5/5 
CCNA LAB WORKBOOK  RIP 

R1#show ip route rip


212.16.3.0/26 is subnetted, 1 subnets
R 212.16.3.0 [120/1] via 212.16.123.3, 00:00:14, Serial0/0.123
212.16.2.0/25 is subnetted, 1 subnets
R 212.16.2.0 [120/1] via 212.16.123.2, 00:00:17, Serial0/0.123

R1#debug ip rip
RIP protocol debugging is on
R1#
*Mar 1 00:13:56.207: RIP: sending v2 update to 224.0.0.9 via Serial0/0.123 (212.16.123.1)
*Mar 1 00:13:56.207: RIP: build update entries
*Mar 1 00:13:56.207: 212.16.1.0/24 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:14:14.435: RIP: received v2 update from 212.16.123.3 on Serial0/0.123
*Mar 1 00:14:14.435: 212.16.3.0/26 via 0.0.0.0 in 1 hops
*Mar 1 00:14:14.439: 212.16.123.0/24 via 0.0.0.0 in 1 hops
*Mar 1 00:14:17.739: RIP: received v2 update from 212.16.123.2 on Serial0/0.123
*Mar 1 00:14:17.743: 212.16.2.0/25 via 0.0.0.0 in 1 hops
*Mar 1 00:14:17.747: 212.16.123.0/24 via 0.0.0.0 in 1 hops

R2:

R2#show running-config | b router rip


router rip
version 2
network 212.16.2.0
network 212.16.123.0
no auto-summary
!

R2#show ip route rip


R 212.16.1.0/24 [120/1] via 212.16.123.1, 00:00:12, Serial0/0

R2#debug ip rip
RIP protocol debugging is on
R2#
*Mar 1 00:05:33.795: RIP: sending v2 update to 224.0.0.9 via Serial0/0 (212.16.123.2)
*Mar 1 00:05:33.795: RIP: build update entries
*Mar 1 00:05:33.799: 212.16.1.0/24 via 212.16.123.1, metric 2, tag 0
*Mar 1 00:05:33.799: 212.16.2.0/25 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:05:33.803: 212.16.123.0/24 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:05:41.979: RIP: received v2 update from 212.16.123.1 on Serial0/0
*Mar 1 00:05:41.979: 212.16.1.0/24 via 0.0.0.0 in 1 hops

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 6/6 
CCNA LAB WORKBOOK  RIP 

R3:
R3#show running-config | b router rip
router rip
version 2
network 212.16.3.0
network 212.16.123.0
no auto-summary

R3#show ip route rip


R 212.16.1.0/24 [120/1] via 212.16.123.1, 00:00:07, Serial0/0

R3#debug ip rip
RIP protocol debugging is on
R3#
*Mar 1 00:05:22.487: RIP: received v2 update from 212.16.123.1 on Serial0/0
*Mar 1 00:05:22.487: 212.16.1.0/24 via 0.0.0.0 in 1 hops
*Mar 1 00:05:38.119: RIP: sending v2 update to 224.0.0.9 via Serial0/0 (212.16.123.3)
*Mar 1 00:05:38.119: RIP: build update entries
*Mar 1 00:05:38.123: 212.16.1.0/24 via 212.16.123.1, metric 2, tag 0
*Mar 1 00:05:38.127: 212.16.3.0/26 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:05:38.127: 212.16.123.0/24 via 0.0.0.0, metric 1, tag 0

Task 2:
From the output of the debug ip rip command on R2 and R3, we see that they are both re-
advertising the subnet 212.16.1.0/24 back to R1. This caused by the fact that split horizon is
disabled on the main frame interfaces on R2 and R3 as shown in the outputs of the show ip
interface command.

R2:
R2#debug ip rip
RIP protocol debugging is on
R2#
*Mar 1 00:19:25.203: RIP: received v2 update from 212.16.123.1 on Serial0/0
*Mar 1 00:19:25.203: 212.16.1.0/24 via 0.0.0.0 in 1 hops
R2#
*Mar 1 00:19:37.179: RIP: sending v2 update to 224.0.0.9 via Serial0/0 (212.16.123.2)
*Mar 1 00:19:37.183: RIP: build update entries
*Mar 1 00:19:37.183: 212.16.1.0/24 via 212.16.123.1, metric 2, tag 0
*Mar 1 00:19:37.187: 212.16.2.0/25 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:19:37.187: 212.16.123.0/24 via 0.0.0.0, metric 1, tag 0
R2#

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 7/7 
CCNA LAB WORKBOOK  RIP 

R2#show ip interface serial 0/0


Serial0/0 is up, line protocol is up
Internet address is 212.16.123.2/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Multicast reserved groups joined: 224.0.0.9
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is disabled
<omitted output>

R3:
R3#debug ip rip
RIP protocol debugging is on
R3#
*Mar 1 00:09:22.903: RIP: received v2 update from 212.16.123.1 on Serial0/0
*Mar 1 00:09:22.903: 212.16.1.0/24 via 0.0.0.0 in 1 hops
R3#
*Mar 1 00:09:41.379: RIP: sending v2 update to 224.0.0.9 via Loopback0 (212.16.3.3)
*Mar 1 00:09:41.383: RIP: build update entries
*Mar 1 00:09:41.383: 212.16.1.0/24 via 0.0.0.0, metric 2, tag 0
*Mar 1 00:09:41.387: 212.16.123.0/24 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:09:41.395: RIP: ignored v2 packet from 212.16.3.3 (sourced from one of our
addresses)
R3#
*Mar 1 00:09:43.767: RIP: sending v2 update to 224.0.0.9 via Serial0/0 (212.16.123.3)
*Mar 1 00:09:43.771: RIP: build update entries
*Mar 1 00:09:43.771: 212.16.1.0/24 via 212.16.123.1, metric 2, tag 0
*Mar 1 00:09:43.775: 212.16.3.0/26 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:09:43.779: 212.16.123.0/24 via 0.0.0.0, metric 1, tag 0
R3#

R3#show ip interface serial 0/0


Serial0/0 is up, line protocol is up
Internet address is 212.16.123.3/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 8/8 
CCNA LAB WORKBOOK  RIP 

Multicast reserved groups joined: 224.0.0.9


Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is disabled
<omitted output>

To circumvent this issue we’ve to enable split horizon on these interfaces.


R2:
R2#conf t
R2(config)#interface serial 0//0
R2(config-if)#ip split-horizon
R2(config-if)#^Z
R2#
R3:
R3#conf t
R3(config)#interface serial 0//0
R3(config-if)#ip split-horizon
R3(config-if)#^Z
R3#

Verification:
R2:
R2#debug ip rip
RIP protocol debugging is on
R2#
*Mar 1 00:19:25.203: RIP: received v2 update from 212.16.123.1 on Serial0/0
*Mar 1 00:19:25.203: 212.16.1.0/24 via 0.0.0.0 in 1 hops
R2#
*Mar 1 00:19:37.179: RIP: sending v2 update to 224.0.0.9 via Serial0/0 (212.16.123.2)
*Mar 1 00:19:37.183: RIP: build update entries
*Mar 1 00:19:37.187: 212.16.2.0/25 via 0.0.0.0, metric 1, tag 0
R2#

R2#show ip interface serial 0/0


Serial0/0 is up, line protocol is up
Internet address is 212.16.123.2/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 9/9 
CCNA LAB WORKBOOK  RIP 

Multicast reserved groups joined: 224.0.0.9


Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
<omitted output>

R3:
R3#debug ip rip
RIP protocol debugging is on
R3#
*Mar 1 00:09:22.903: RIP: received v2 update from 212.16.123.1 on Serial0/0
*Mar 1 00:09:22.903: 212.16.1.0/24 via 0.0.0.0 in 1 hops
R3#
*Mar 1 00:09:41.379: RIP: sending v2 update to 224.0.0.9 via Loopback0 (212.16.3.3)
*Mar 1 00:09:41.383: RIP: build update entries
*Mar 1 00:09:41.383: 212.16.1.0/24 via 0.0.0.0, metric 2, tag 0
*Mar 1 00:09:41.387: 212.16.123.0/24 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:09:41.395: RIP: ignored v2 packet from 212.16.3.3 (sourced from one of our
addresses)
R3#
*Mar 1 00:09:43.767: RIP: sending v2 update to 224.0.0.9 via Serial0/0 (212.16.123.3)
*Mar 1 00:09:43.771: RIP: build update entries
*Mar 1 00:09:43.775: 212.16.3.0/26 via 0.0.0.0, metric 1, tag 0
R3#

R3#show ip interface serial 0/0


Serial0/0 is up, line protocol is up
Internet address is 212.16.123.3/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Multicast reserved groups joined: 224.0.0.9
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
<omitted output>

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 10/10 
CCNA LAB WORKBOOK  RIP 

Task 3:
R1:
R1#configure terminal
R1(config)#interface serial 0/0.123
R1(config-subif)#no ip split-horizon
R1(config-subif)#^Z
R1#

Verification:
R1:
R1#show ip interface serial 0/0.123
Serial0/0.123 is up, line protocol is up
Internet address is 212.16.123.1/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Multicast reserved groups joined: 224.0.0.9
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is disabled
<omitted output>

R1#debug ip rip
RIP protocol debugging is on
R1#
*Mar 1 00:21:17.471: RIP: sending v2 update to 224.0.0.9 via Serial0/0.123
(212.16.123.1)
*Mar 1 00:21:17.475: RIP: build update entries
*Mar 1 00:21:17.475: 212.16.1.0/24 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:21:17.479: 212.16.2.0/25 via 212.16.123.2, metric 2, tag 0
*Mar 1 00:21:17.479: 212.16.3.0/26 via 212.16.123.3, metric 2, tag 0
*Mar 1 00:21:17.483: 212.16.123.0/24 via 0.0.0.0, metric 1, tag 0
R1#

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 11/11 
CCNA LAB WORKBOOK  RIP 

R2:
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C 212.16.123.0/24 is directly connected, Serial0/0


R 212.16.1.0/24 [120/1] via 212.16.123.1, 00:00:14, Serial0/0
212.16.3.0/26 is subnetted, 1 subnets
R 212.16.3.0 [120/2] via 212.16.123.3, 00:00:14, Serial0/0
212.16.2.0/25 is subnetted, 1 subnets
C 212.16.2.0 is directly connected, Loopback0

R2#ping 212.16.3.3

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 212.16.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 164/236/288 ms
R2#
R3:
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set

C 212.16.123.0/24 is directly connected, Serial0/0


R 212.16.1.0/24 [120/1] via 212.16.123.1, 00:00:00, Serial0/0
212.16.3.0/26 is subnetted, 1 subnets
C 212.16.3.0 is directly connected, Loopback0
212.16.2.0/25 is subnetted, 1 subnets
R 212.16.2.0 [120/2] via 212.16.123.2, 00:00:00, Serial0/0

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 12/12 
CCNA LAB WORKBOOK  RIP 

R3#ping 212.16.2.2

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 212.16.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/216/436 ms
R3#

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 13/13 
CCNA LAB WORKBOOK  RIP 

V. Links:
For more information about the commands used in this lab, use the following links:
1. auto-summary
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_a1g.html#w
p1039007
2. ip split-horizon (RIP)
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_i1g.html#wp
1040887
3. router rip
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_o1g.html#w
p1038229
4. network
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_n1g.html#w
p1040868
5. show ip route
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039689

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 14/14 
CCNA LAB WORKBOOK  RIP 

LAB 4: RIP UPDATE VERSIONS

I. Network diagram:

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 1/1 
CCNA LAB WORKBOOK  RIP 

II. Initial Configuration


R1:
hostname R1
!
interface Loopback0
ip address 2.2.3.1 255.255.255.0
!
interface Loopback1
ip address 10.1.4.1 255.255.252.0
!
interface FastEthernet0/0
ip address 10.1.12.1 255.255.255.0
duplex auto
speed auto
!
line con 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end
R2:
hostname R2
!
!
interface Loopback1
ip address 10.1.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.12.2 255.255.255.0
!
interface FastEthernet0/1
ip address 10.1.23.2 255.255.255.0
!
line con 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 2/2 
CCNA LAB WORKBOOK  RIP 

exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end

R3:
hostname R3
!
!
interface Loopback0
ip address 3.3.4.3 255.255.255.0
!
interface FastEthernet0/1
ip address 10.1.23.3 255.255.255.0
!
line con 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end

III. Tasks:
1. Configure RIP on the network as follows:
Enable RIPv2 between R2 and R1.
Enable RIPv1 between R2 and R3.
Advertise all the subnets. Updates should be sent out of necessary interfaces.
Do not accept RIPv2 updates between R2 and R3.
Do not accept RIPv1 updates between R2 and R1.
Disable auto-summarization.

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 3/3 
CCNA LAB WORKBOOK  RIP 

2. Solutions:
Task 1:

R1:
R1#configure terminal
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#passive-interface Loopback 0
R1(config-router)#passive-interface Loopback 1
R1(config-router)#network 2.0.0.0
R1(config-router)#network 10.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#^Z
R1#
R2:
R2#conf t
R2(config)#interface FastEthernet0/0
R2(config-if)#ip rip send version 2
R2(config-if)#ip rip receive version 2
R2(config-if)#
R2(config-if)#interface FastEthernet0/1
R2(config-if)#ip rip receive version 1
R2(config-if)#
R2(config-if)#router rip
R2(config-router)#passive-interface default
R2(config-router)#no passive-interface FastEthernet0/0
R2(config-router)#no passive-interface FastEthernet0/1
R2(config-router)#network 10.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#end
R2#

R3:
R3#conf t
R3(config)#router rip
R3(config-router)#version 1
R3(config-router)#passive-interface default
R3(config-router)#no passive-interface FastEthernet0/1
R3(config-router)#network 3.0.0.0
R3(config-router)#network 10.0.0.0
R3(config-router)#^Z
R3#

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 4/4 
CCNA LAB WORKBOOK  RIP 

By default, when you enable RIP process without using the version command, the router
send RIPv1 updates and accept both RIPv1 and RIPv2 updates. You can see this using the
show ip protocols command.
When you using the version command, the router allows only the specified version, unless
the ip rip send/receive commands are applied to one or more interfaces.
The no auto-summary command is not used on R3 because it has no effect when RIPv1 is
enabled.

Verification:

R1:
R1#show ip route rip
R 3.0.0.0/8 [120/2] via 10.1.12.2, 00:00:15, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
R 10.1.2.0/24 [120/1] via 10.1.12.2, 00:00:15, FastEthernet0/0
R 10.1.23.0/24 [120/1] via 10.1.12.2, 00:00:15, FastEthernet0/0
R1#

R1#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 23 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 2 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
2.0.0.0
10.0.0.0
Passive Interface(s):
Loopback0
Loopback1
Routing Information Sources:
Gateway Distance Last Update
10.1.12.2 120 00:00:17
Distance: (default is 120)

R1#

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 5/5 
CCNA LAB WORKBOOK  RIP 

R2:
R2#show ip route rip
2.0.0.0/24 is subnetted, 1 subnets
R 2.2.3.0 [120/1] via 10.1.12.1, 00:00:15, FastEthernet0/0
R 3.0.0.0/8 [120/1] via 10.1.23.3, 00:00:03, FastEthernet0/1
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
R 10.1.4.0/22 [120/1] via 10.1.12.1, 00:00:15, FastEthernet0/0
R2#

R2#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 20 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 1, receive any version
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 2 2
FastEthernet0/1 1 1
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
Passive Interface(s):
Loopback1
VoIP-Null0
Routing Information Sources:
Gateway Distance Last Update
10.1.12.1 120 00:00:09
10.1.23.3 120 00:00:25
Distance: (default is 120)

R2#

R3:
R3#show ip route rip
R 2.0.0.0/8 [120/1] via 10.1.23.2, 00:00:06, FastEthernet0/1
10.0.0.0/24 is subnetted, 3 subnets
R 10.1.12.0 [120/1] via 10.1.23.2, 00:00:06, FastEthernet0/1
R 10.1.2.0 [120/1] via 10.1.23.2, 00:00:06, FastEthernet0/1
R3#

R3#show ip protocols

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 6/6 
CCNA LAB WORKBOOK  RIP 

Routing Protocol is "rip"


Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 16 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 1, receive version 1
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/1 1 1
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
3.0.0.0
10.0.0.0
Passive Interface(s):
FastEthernet0/0
Loopback0
VoIP-Null0
Routing Information Sources:
Gateway Distance Last Update
10.1.23.2 120 00:00:11
Distance: (default is 120)

R3#

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 7/7 
CCNA LAB WORKBOOK  RIP 

3. Links:
For more information about the commands used in this lab, use the following links:
1. auto-summary
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_a1g.html#w
p1039007
2. ip rip receive version
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_i1g.html#wp
1040343
3. ip rip send version
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_i1g.html#wp
1040443
4. network
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_n1g.html#w
p1040868
5. passive-interface
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_o1g.html#w
p1036805
6. router rip
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_o1g.html#w
p1038229
7. show ip route
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039689
8. show ip protocols
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039132
9. show ip rip database
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039551
10. version
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1042845

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 8/8 
CCNA LAB WORKBOOK  RIP 

LAB 5: RIP UNICAST UPDATES

I. Network diagram:

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 1/1 
CCNA LAB WORKBOOK  RIP 

II. Initial Configuration


R1:
hostname R1
!
!
interface Loopback0
ip address 1.2.3.1 255.255.255.0
!
interface Loopback1
ip address 10.1.4.1 255.255.252.0
!
interface FastEthernet0/0
ip address 10.1.12.1 255.255.255.0
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end
R2:
hostname R2
!
!
interface Loopback0
ip address 2.3.4.2 255.255.255.0
!
interface Loopback1
ip address 10.1.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.12.2 255.255.255.0
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 2/2 
CCNA LAB WORKBOOK  RIP 

line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end

III. Tasks:
1. Enable RIPv2 on the network, and advertise all the subnets. RIP updates between R1
and R2 should be sent as unicast packets. Additionally, disable multicast RIP updates
on the network.
2. Set the maximum paths to the value of 2 on the routers.

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 3/3 
CCNA LAB WORKBOOK  RIP 

IV. Solutions:
Task 1:

R1:
R1#conf t
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 1.0.0.0
R1(config-router)#network 10.0.0.0
R1(config-router)#passive-interface default
R1(config-router)#no auto-summary
R1(config-router)#neighbor 10.1.12.2
R1(config-router)#^Z
R1#
R2:
R2#conf t
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 2.0.0.0
R2(config-router)#network 10.0.0.0
R2(config-router)#passive-interface default
R2(config-router)#no auto-summary
R2(config-router)#neighbor 10.1.12.1
R2(config-router)#^Z
R2#

Verification:

R1:
R1#show ip route rip
2.0.0.0/24 is subnetted, 1 subnets
R 2.3.4.0 [120/1] via 10.1.12.2, 00:00:14, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
R 10.1.2.0/24 [120/1] via 10.1.12.2, 00:00:14, FastEthernet0/0
R1#

R1#debug ip rip
RIP protocol debugging is on
R1#
*Mar 1 00:08:51.259: RIP: sending v2 update to 10.1.12.2 via FastEthernet0/0
(10.1.12.1)
*Mar 1 00:08:51.263: RIP: build update entries
*Mar 1 00:08:51.263: 1.2.3.0/24 via 0.0.0.0, metric 1, tag 0
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 4/4 
CCNA LAB WORKBOOK  RIP 

*Mar 1 00:08:51.267: 10.1.4.0/22 via 0.0.0.0, metric 1, tag 0


*Mar 1 00:09:06.839: RIP: received v2 update from 10.1.12.2 on FastEthernet0/0
*Mar 1 00:09:06.843: 2.3.4.0/24 via 0.0.0.0 in 1 hops
*Mar 1 00:09:06.847: 10.1.2.0/24 via 0.0.0.0 in 1 hops
R1#

R1#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 22 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Neighbor(s):
10.1.12.2
<omitted output>
R2:
R2#show ip route rip
1.0.0.0/24 is subnetted, 1 subnets
R 1.2.3.0 [120/1] via 10.1.12.1, 00:00:00, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
R 10.1.4.0/22 [120/1] via 10.1.12.1, 00:00:00, FastEthernet0/0
R2#

R2#debug ip rip
RIP protocol debugging is on
R2#
*Mar 1 00:08:12.739: RIP: sending v2 update to 10.1.12.1 via FastEthernet0/0
(10.1.12.2)
*Mar 1 00:08:12.743: RIP: build update entries
*Mar 1 00:08:12.743: 2.3.4.0/24 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:08:12.747: 10.1.2.0/24 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:08:23.687: RIP: received v2 update from 10.1.12.1 on FastEthernet0/0
*Mar 1 00:08:23.691: 1.2.3.0/24 via 0.0.0.0 in 1 hops
*Mar 1 00:08:23.695: 10.1.4.0/22 via 0.0.0.0 in 1 hops

R2#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 20 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Neighbor(s):
10.1.12.1
<omitted output>
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 5/5 
CCNA LAB WORKBOOK  RIP 

Task 2:

R1:
R1#conf t
R1(config)#router rip
R1(config-router)#maximum-paths 2
R1(config-router)#^Z
R1#
R2:
R2#conf t
R2(config)#router rip
R2(config-router)#maximum-paths 2
R2(config-router)#^Z
R2#

Verification:

R1:
R1#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 20 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Neighbor(s):
10.1.12.2
Default version control: send version 2, receive version 2
Automatic network summarization is not in effect
Maximum path: 2
<omitted output>
R2:
R2#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 20 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Neighbor(s):
10.1.12.1
Default version control: send version 2, receive version 2

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 6/6 
CCNA LAB WORKBOOK  RIP 

Automatic network summarization is not in effect


Maximum path: 2
<omitted output>

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 7/7 
CCNA LAB WORKBOOK  RIP 

V. Links:
For more information about the commands used in this lab, use the following links:
1. network
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_n1g.html#w
p1040868
2. router rip
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_o1g.html#w
p1038229
3. show ip route
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039689
4. show ip protocols
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039132
5. show ip rip database
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039551
6. version
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1042845

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 8/8 
CCNA LAB WORKBOOK  RIP 

LAB 6: RIPV2 AUTHENTICATION

I. Network diagram:

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 1/1 
CCNA LAB WORKBOOK  RIP 

II. Initial Configuration


R1:
hostname R1
!
interface Loopback0
ip address 2.2.3.1 255.255.255.0
!
interface Loopback1
ip address 10.1.4.1 255.255.252.0
!
interface FastEthernet0/0
ip address 10.1.12.1 255.255.255.0
duplex auto
speed auto
!
line con 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end
R2:
hostname R2
!
!
interface Loopback1
ip address 10.1.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.12.2 255.255.255.0
!
interface FastEthernet0/1
ip address 10.1.23.2 255.255.255.0
!
line con 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 2/2 
CCNA LAB WORKBOOK  RIP 

exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end

R3:
hostname R3
!
!
interface Loopback0
ip address 3.3.4.3 255.255.255.0
!
interface FastEthernet0/1
ip address 10.1.23.3 255.255.255.0
!
line con 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end

III. Tasks:
1. Enable RIPv2 on the network, and advertise all the subnets. Updates should be sent out of
necessary interfaces.
2. Configure RIPv2 authentication as follows:
Updates between R1 and R2 should be authenticated using the plain text password
PTCISCO.
Updates between R2 and R3 should be authenticated using the password
MD5CISCO and the key 3. The password should be sent in unencrypted format.

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 3/3 
CCNA LAB WORKBOOK  RIP 

3. Solutions:
Task 1:

R1:
R1#configure terminal
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 2.0.0.0
R1(config-router)#network 10.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#end
R1#

R2:
R2#conf t
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 10.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#end
R2#
R3:
R3#conf t
R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#network 3.0.0.0
R3(config-router)#network 10.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#end
R3#

Verification:

R1:
R1#show ip route rip
3.0.0.0/24 is subnetted, 1 subnets
R 3.3.4.0 [120/2] via 10.1.12.2, 00:00:02, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
R 10.1.2.0/24 [120/1] via 10.1.12.2, 00:00:02, FastEthernet0/0
R 10.1.23.0/24 [120/1] via 10.1.12.2, 00:00:02, FastEthernet0/0

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 4/4 
CCNA LAB WORKBOOK  RIP 

R2:
R2#show ip route rip
2.0.0.0/24 is subnetted, 1 subnets
R 2.2.3.0 [120/1] via 10.1.12.1, 00:00:23, FastEthernet0/0
3.0.0.0/24 is subnetted, 1 subnets
R 3.3.4.0 [120/1] via 10.1.23.3, 00:00:02, FastEthernet0/1
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
R 10.1.4.0/22 [120/1] via 10.1.12.1, 00:00:23, FastEthernet0/0
R2#

R3:
R3#show ip route rip
2.0.0.0/24 is subnetted, 1 subnets
R 2.2.3.0 [120/2] via 10.1.23.2, 00:00:17, FastEthernet0/1
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
R 10.1.12.0/24 [120/1] via 10.1.23.2, 00:00:17, FastEthernet0/1
R 10.1.2.0/24 [120/1] via 10.1.23.2, 00:00:17, FastEthernet0/1
R 10.1.4.0/22 [120/2] via 10.1.23.2, 00:00:17, FastEthernet0/1
R3#

Task 2:

R1:
R1#conf t
R1(config)#key chain RIP
R1(config-keychain)#key 1
R1(config-keychain-key)#key-string PTCISCO
R1(config-keychain-key)#
R1(config-keychain-key)#interface FastEthernet0/0
R1(config-if)#ip rip authentication key-chain RIP
R1(config-if)#end
R1#
R2:
R2#conf t
R2(config)#key chain RIP
R2(config-keychain)#key 8
R2(config-keychain-key)#key-string PTCISCO
R2(config-keychain-key)#
R2(config-keychain-key)#key chain RIP_MD5
R2(config-keychain)#key 3
R2(config-keychain-key)#key-string MD5CISCO
R2(config-keychain-key)#

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 5/5 
CCNA LAB WORKBOOK  RIP 

R2(config-keychain-key)#interface FastEthernet0/0
R2(config-if)#ip rip authentication key-chain RIP
R2(config-if)#
R2(config-if)#interface FastEthernet0/1
R2(config-if)#ip rip authentication mode md5
R2(config-if)#ip rip authentication key-chain RIP_MD5
R2(config-if)#end
R2#
R3:
R3#conf t
R3(config)#key chain RIP
R3(config-keychain)#key 3
R3(config-keychain-key)#key-string MD5CISCO
R3(config-keychain-key)#
R3(config-keychain-key)#interface FastEthernet0/1
R3(config-if)#ip rip authentication mode md5
R3(config-if)#ip rip authentication key-chain RIP
R3(config-if)#end
R3#

Verification:

R1:
R1#show key chain
Key-chain RIP:
key 1 -- text "PTCISCO"
accept lifetime (always valid) - (always valid) [valid now]
send lifetime (always valid) - (always valid) [valid now]
R1#

R1#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 27 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 2 2 RIP
Loopback0 2 2
Loopback1 2 2

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 6/6 
CCNA LAB WORKBOOK  RIP 

Automatic network summarization is not in effect


Maximum path: 4
Routing for Networks:
2.0.0.0
10.0.0.0
Routing Information Sources:
Gateway Distance Last Update
10.1.12.2 120 00:00:20
Distance: (default is 120)

R1#
R2:
R2#show key chain
Key-chain RIP:
key 8 -- text "PTCISCO"
accept lifetime (always valid) - (always valid) [valid now]
send lifetime (always valid) - (always valid) [valid now]
Key-chain RIP_MD5:
key 3 -- text "MD5CISCO"
accept lifetime (always valid) - (always valid) [valid now]
send lifetime (always valid) - (always valid) [valid now]
R2#

R2#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 18 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 2 2 RIP
FastEthernet0/1 2 2 RIP_MD5
Loopback1 2 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
Routing Information Sources:
Gateway Distance Last Update
10.1.12.1 120 00:00:24
10.1.23.3 120 00:00:20
Distance: (default is 120)

R2#
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 7/7 
CCNA LAB WORKBOOK  RIP 

R3:
R3#show key chain
Key-chain RIP:
key 3 -- text "MD5CISCO"
accept lifetime (always valid) - (always valid) [valid now]
send lifetime (always valid) - (always valid) [valid now]
R3#

R3#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 26 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/1 2 2 RIP
Loopback0 2 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
3.0.0.0
10.0.0.0
Routing Information Sources:
Gateway Distance Last Update
10.1.23.2 120 00:00:21
Distance: (default is 120)

R3#

In MD5 authentication, the keys configured under the key chain must be the same. But in
plain text authentication, this is not an issue.

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 8/8 
CCNA LAB WORKBOOK  RIP 

4. Links:
For more information about the commands used in this lab, use the following links:
1. auto-summary
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_a1g.html#w
p1039007
2. ip rip authentication key-chain
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_i1g.html#wp
1040178
3. ip rip authentication mode
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_i1g.html#wp
1040250
4. key chain
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_k1g.html#w
p1036467
5. network
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_n1g.html#w
p1040868
6. router rip
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_o1g.html#w
p1038229
7. show ip route
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039689
8. show ip protocols
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039132
9. version
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1042845
10. show key chain
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1040870

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 9/9 
CCNA LAB WORKBOOK  RIP 

LAB 7: DEFAULT ROUTING

I. Network diagram:

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 1/1 
CCNA LAB WORKBOOK  RIP 

II. Initial Configuration


R1:
hostname R1
!
!
interface Loopback0
ip address 1.2.3.1 255.255.255.0
!
interface Loopback1
ip address 10.1.4.1 255.255.252.0
!
interface FastEthernet0/0
ip address 10.1.12.1 255.255.255.0
duplex auto
speed auto
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end
R2:
hostname R2
!
!
!
interface Loopback0
ip address 10.1.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.12.2 255.255.255.0
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 2/2 
CCNA LAB WORKBOOK  RIP 

line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end

III. Tasks:
1. Enable RIPv2 on the network, and advertise all the subnets in the IP address space
10.0.0.0/8. Updates should be sent out of necessary interfaces.
2. Configure R1 to send a default route to R2.

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 3/3 
CCNA LAB WORKBOOK  RIP 

IV. Solutions:
Task 1:

R1:
R1#configure terminal
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#passive-interface default
R1(config-router)#no passive-interface FastEthernet0/0
R1(config-router)#network 10.0.0.0
R1(config-router)#^Z
R1#
R2:
R2#configure terminal
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#passive-interface default
R2(config-router)#no passive-interface FastEthernet0/0
R2(config-router)#network 10.0.0.0
R2(config-router)#^Z
R2#

Verification:

R1:
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets


C 1.2.3.0 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C 10.1.12.0/24 is directly connected, FastEthernet0/0
R 10.1.2.0/24 [120/1] via 10.1.12.2, 00:00:27, FastEthernet0/0
C 10.1.4.0/22 is directly connected, Loopback1
R1#
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 4/4 
CCNA LAB WORKBOOK  RIP 

R2:
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks


C 10.1.12.0/24 is directly connected, FastEthernet0/0
C 10.1.2.0/24 is directly connected, Loopback0
R 10.1.4.0/22 [120/1] via 10.1.12.1, 00:00:00, FastEthernet0/0
R2#

Task 2:

R1:
R1#configure terminal
R1(config)#router rip
R1(config-router)#default-information originate
R1(config-router)#^Z
R1#

Verification:

R2:

R2#show ip route
<omitted output>

Gateway of last resort is 10.1.12.1 to network 0.0.0.0

10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks


C 10.1.12.0/24 is directly connected, FastEthernet0/0
C 10.1.2.0/24 is directly connected, Loopback0
R 10.1.4.0/22 [120/1] via 10.1.12.1, 00:00:14, FastEthernet0/0
R* 0.0.0.0/0 [120/1] via 10.1.12.1, 00:00:06, FastEthernet0/0
R2#

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 5/5 
CCNA LAB WORKBOOK  RIP 

R2#show ip route 1.2.3.1


% Network not in table
R2

R2#ping 1.2.3.1

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 1.2.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/120/192 ms
R2#

You can advertise a default route within a RIP domain, using one of the following methods:
Use the default-information command.
Use the default-network command.
Redistribute the static route “ip route 0.0.0.0 0.0.0.0 null0” into the RIP domain.

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 6/6 
CCNA LAB WORKBOOK  RIP 

V. Links:
For more information about the commands used in this lab, use the following links:
1. auto-summary
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_a1g.html#w
p1039007
2. default-information originate
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_c1g.html#w
p1038175
3. network
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_n1g.html#w
p1040868
4. passive-interface
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_o1g.html#w
p1036805
5. router rip
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_o1g.html#w
p1038229
6. show ip route
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039689
7. show ip protocols
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039132
8. show ip rip database
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039551
9. version
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1042845

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 7/7 
CCNA LAB WORKBOOK  RIP 

LAB 8: RIP ADVANCED SCENARIO

I. Network diagram:

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 1/1 
CCNA LAB WORKBOOK  RIP 

II. Initial Configuration


R1:
hostname R1
!
!
interface Loopback0
ip address 1.2.3.1 255.255.255.0
!
interface Loopback1
ip address 10.1.4.1 255.255.252.0
!
interface FastEthernet0/0
ip address 10.1.12.1 255.255.255.0
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end
R2:
hostname R2
!
!
interface Loopback0
ip address 2.3.4.2 255.255.255.0
!
interface Loopback1
ip address 10.1.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.12.2 255.255.255.0
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 2/2 
CCNA LAB WORKBOOK  RIP 

line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end

III. Tasks:
1. Configure RIP on the network according to the outputs of the show command below:
R1:
R1#show ip route rip
R 2.0.0.0/8 [120/1] via 10.1.12.2, 00:00:08, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
R 10.1.2.0/24 [120/1] via 10.1.12.2, 00:00:08, FastEthernet0/0
R1#

R1#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 10 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 2 2
Loopback0 2 2
Loopback1 2 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
1.0.0.0
10.0.0.0
Routing Information Sources:
Gateway Distance Last Update
10.1.12.2 120 00:00:12
Distance: (default is 120)

R1#

R2:

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 3/3 
CCNA LAB WORKBOOK  RIP 

R2#show ip route rip


1.0.0.0/24 is subnetted, 1 subnets
R 1.2.3.0 [120/1] via 10.1.12.1, 00:00:06, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
R 10.1.4.0/22 [120/1] via 10.1.12.1, 00:00:06, FastEthernet0/0
R2#

R2#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 23 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 1, receive any version
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 2 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
2.0.0.0
10.0.0.0
Passive Interface(s):
Loopback0
Loopback1
Routing Information Sources:
Gateway Distance Last Update
10.1.12.1 120 00:00:13
Distance: (default is 120)

R2#

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 4/4 
CCNA LAB WORKBOOK  RIP 

IV. Solutions:
Task 1:

R1:
R1#conf t
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.0.0.0
R1(config-router)#network 1.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#^Z
R1#
R2:
R2#conf t
R2(config)#router rip
R2(config-router)#network 10.0.0.0
R2(config-router)#network 2.0.0.0
R2(config-router)#passive-interface lo0
R2(config-router)#passive-interface lo1
R2(config-router)#
R2(config-router)#
R2(config-router)#int f0/0
R2(config-if)#ip rip send version 2
R2(config-if)#ip rip receive version 2
R2(config-if)#
R2(config-if)#^Z
R2#

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 5/5 
CCNA LAB WORKBOOK  RIP 

V. Links:
For more information about the commands used in this lab, use the following links:
1. network
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_n1g.html#w
p1040868
2. router rip
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_o1g.html#w
p1038229
3. show ip route
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039689
4. show ip protocols
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039132
5. show ip rip database
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039551
6. version
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1042845

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 6/6