Вы находитесь на странице: 1из 7

TAREA Semana 6

SENTENCIAS DE SELECCIÓN EN PHP.

Juan Paulo Figueroa Maldonado

PROGRAMACIÓN DE COMPUTADORES I

INSTITUTO IACC

08 de Octubre, 2018
Instrucciones.
RECURSOS NECESARIOS:
1. Contenidos de la semana 6
2. Recursos adicionales: se recomienda utilizar como referencia para la construcción del script
solicitado, el contenido del libro de apoyo del curso “Manual de PHP”, Capítulo 16, publicado
en la plataforma del curso.
Para desarrollar la siguiente tarea descargue desde la plataforma del curso la plantilla
establecida por IACC para la entrega de tareas de la semana, y realice las siguientes actividades:

Desarrollo.
1. Elabore un algoritmo en pseudocódigo que permita calcular la edad de una persona, utilizando
PHP como lenguaje formal. Puede apoyar su construcción presentando el diagrama de flujo
respectivo si lo considera necesario. Se deben usar cada una de las siguientes estructuras de
control de selección (un algoritmo por cada estructura):
a) IF…ELSE
Proceso Edad_actual
//Se definen las variables del programa
Definir fec_actual como entero;
Definir mes_actual como entero;
Definir dia_actual como entero;

Definir fec_nacimiento como entero;


Definir mes_nacimiento como entero;
Definir dia como entero;

Definir edad como entero;


Definir edad_meses Como Entero;

// primero se pide el año y mes actual


Escribir 'Ingrese año actual: ';
Leer fec_actual;
Escribir 'Ingrese mes actual: ';
Leer mes_actual;
Escribir 'Ingrese dia actual: ';
Leer dia_actual;

// ahora se pide año y mes de nacimiento


Escribir 'Ingrese año de nacimiento: ';
Leer fec_nacimiento;
Escribir 'Ingrese mes de nacimiento: ';
Leer mes_nacimiento;
Escribir 'Ingrese dia de nacimiento: ';
Leer dia;

//Se calcula la edad y los meses


edad<-fec_actual-fec_nacimiento;

edad_meses<-mes_actual-mes_nacimiento;
//acá se revisa si el mes es menor al mes en curso, por lo tanto aun no cumple el año.
Si edad_meses<0 Entonces
edad<-edad-1;
edad_meses<-edad_meses+12;

FinSi

//se muestra la edad y los meses de una persona, se valida el dia también
si edad_meses=0 entonces //IF
Escribir 'La edad de la persona es: ';
Si (dia_actual < dia) Entonces
edad <- edad - 1;
Escribir edad, ' años y 11 meses.';
Sino //ELSE
Escribir edad, ' años.';
FinSi

Sino
Escribir 'La edad de la persona es ', edad, ' años y ', edad_meses, ' meses.';
FinSi
FinProceso

RESULTADO

b) IF…ELSEIF…ELSE
Proceso Edad_actual
//Se define las variables del programa
Definir fec_actual como entero;
Definir mes_actual como entero;
Definir dia_actual como entero;
Definir fec_nacimiento como entero;
Definir mes_nacimiento como entero;
Definir dia como entero;

Definir edad como entero;


Definir edad_meses Como Entero;

// primero se pide el año y mes actual


Escribir 'Ingrese año actual: ';
Leer fec_actual;
Escribir 'Ingrese mes actual: ';
Leer mes_actual;
Escribir 'Ingrese dia actual: ';
Leer dia_actual;

// ahora se pide año y mes de nacimiento


Escribir 'Ingrese año de nacimiento: ';
Leer fec_nacimiento;
Escribir 'Ingrese mes de nacimiento: ';
Leer mes_nacimiento;
Escribir 'Ingrese dia de nacimiento: ';
Leer dia;

//Se calcula la edad y los meses


edad<-fec_actual-fec_nacimiento;
edad_meses<-mes_actual-mes_nacimiento;

//acá se revisa si el mes es menor al mes en curso, por lo tanto aun no cumple el año.
Si edad_meses<0 Entonces //IF
edad<-edad-1;
edad_meses<-edad_meses+12;
Escribir 'La edad de la persona es ', edad, ' años y ', edad_meses, ' meses.';
//se muestra la edad y los meses de una persona, se valida el dia también
Sino
Si edad_meses=0 entonces
Escribir 'La edad de la persona es: ';
Si (dia_actual < dia) Entonces
edad <- edad - 1; //ELSEIF
Escribir edad, ' años y 11 meses.';
Sino
Escribir edad, ' años.';
FinSi

Sino //ELSE
Escribir 'La edad de la persona es ', edad, ' años y ', edad_meses, ' meses.';
FinSi
FinSi
FinProceso
RESULTADO

2. Seleccione, según prefiera, una de las estructuras de control antes utilizadas e implemente un
script en PHP que realice el cálculo solicitado. El script debe ser completamente funcional y
efectivo. Para probar que su programa está correcto, puede utilizar el ambiente de
programación dispuesto para estos efectos en la página del curso a través del link PHP Online.
Nota: No olvide comentar al interior de cada programa en pseudocódigo, las operaciones realizadas en
cada sentencia para documentar su funcionamiento (//comentario…).
<?php
//se utiliza la función date para calcular la fecha actual, y se descompone por día, mes y año
$dia=date("j");
$mes=date("n");
$era=date("Y");

// se imprime por pantalla la fecha actual


echo "El dia actual es : ".$dia;
echo "<br>";

echo "El mes actual es : ".$mes;


echo "<br>";

echo "El año actual es : ".$era;


echo "<br>";
echo "<br>";

//obtengo datos en forma aleatoria, para la fecha de nacimiento

$dia_nacimiento=rand(1, 28);
$mes_nacimiento=rand(1, 12);
$era_nacimiento=rand(1970, 2018);

//$dia_nacimiento=12;
//$mes_nacimiento=10;
//$era_nacimiento=1998;

// se imprime por pantalla la fecha de nacimiento


echo "El dia de nacimiento es : ".$dia_nacimiento;
echo "<br>";

echo "El mes de nacimiento es : ".$mes_nacimiento;


echo "<br>";

echo "El año de nacimiento es: ".$era_nacimiento;


echo "<br>";
echo "<br>";

//Se calcula la edad y los meses


$edad= $era-$era_nacimiento;
$edad_meses= $mes-$mes_nacimiento;

//acá se revisa si el mes es menor al mes en curso, por lo tanto aun no cumple el año.
if ($edad_meses<0)

{
$edad= $edad-1;
$edad_meses= $edad_meses+12;
}

// se valida si es el mismo mes


if ($edad_meses==0)

{
echo "La edad de la persona es: ";
//se valida el dia también
if ($dia < $dia_nacimiento)

{
$edad = $edad - 1;
echo "". $edad. " y 11 meses";
}

else
echo "".$era;
}

else
echo "La edad de la persona es ".$edad. " años y ". $edad_meses." meses ";
RESULTADO

Bibliografía
 Tecnologías de Internet, IACC, 2018, Semana 6.