Вы находитесь на странице: 1из 2

Ejercicios resueltos en PseInt- Algoritmos

1.Se debe Construir un programa que permita determinar el �rea de un Cubo.

// Algoritmo para calcular el �rea de un cubo


// El algoritmo se denomina 'Area_cubo'
Algoritmo Area_cubo
//Definir de tipo de datos que vamos a trabajar
Definir Arista, Area como Real
//Se toma la �nica variable a solicitar
Escribir 'CALCULADORA DE AREA DE UN CUBO'
Escribir 'Por favor digite la arista del cubo en Metros'
Leer Arista
//Se valida si el n�mero ingresado es apto para ser procesado
Mientras Arista < 0 hacer
Escribir 'Por favor digite un n�mero valido'
Leer Arista
Finmientras
// Se procesa el valor ingresado y se asigna a la variable Area
Area <- 6*Arista^2
// Se presentan los resultados del proceso
Escribir ':::::::::AREA TOTAL DEL CUBO:::::::::'
Escribir 'El cubo con arista de ', Arista, ' Metros'
Escribir 'Presenta un �rea total de ', Area, ' Metros cuadrados'
FinAlgoritmo

2. Le han pedido que Construya un algoritmo que permita convertir un valor


expresado en horas en d�as, lo mismo que en minutos.

// Algoritmo para calcular el horas a d�as o minutos


// El algoritmo se denomina 'Covertidor_horas'
Algoritmo Convertidor_horas
//Definir de tipo de datos que vamos a trabajar
Definir Horas, HoraDia, HoraMin como Real
Definir Eleccion como Entero
//Se toma la �nica variable a solicitar
Escribir '::::::::::CONVERTIDOR DE HORAS:::::::::::'
Escribir 'Por favor digite la cantidad de horas a convertir'
Leer Horas
//Se valida si el n�mero ingresado es apto para ser procesado
Mientras Horas<0 hacer
Escribir 'Por favor digite un n�mero valido'
Leer Horas
Finmientras
Escribir 'Por favor digite el numero de la opci�n que requiera'
Escribir '1 ) Horas a minutos'
Escribir '2 ) Horas a d�as'
Leer Eleccion
//Se valida si el n�mero ingresado es apto para ser procesado
Mientras Eleccion<1 o Eleccion>2 hacer
Escribir 'Por favor digite un n�mero valido'
Leer Eleccion
Finmientras
//Se procesa la eleccion tomada
//Se ejecuta la formula que corresponda
//Se presentan los resultados
Si Eleccion=1 Entonces
HoraMin <- Horas*60
Escribir ':::::::::RESULTADOS:::::::::'
Escribir 'Usted ingres�: ', Horas, ' horas'
Escribir 'Representa ', HoraMin, ' minutos'
SiNo
HoraDia <- Horas/24
Escribir ':::::::::RESULTADOS:::::::::'
Escribir 'Usted ingres�: ', Horas, ' horas'
Escribir 'Representa ', HoraDia, ' d�as'
FinSi
FinAlgoritmo