Вы находитесь на странице: 1из 17

Diagrama de Flujo para crear una matriz y llenarla de números ingresados por parte del

usuario (entrada por teclado).


Codigo Fuente DFD

DIAGRAMA DE FLUJO: Es un diagrama que muestra detalladamente las secuencia de pasos


o actividades para dar solución a un problema ejecutar un procedimiento.
Los diagrama de flujo se emplean para: el diseño de programas, para representar algoritmos,
etc.

Publicado por George Tacuri en 18:53


Etiquetas: diagrama de f lujo

1 comentarios:

Adri Gevara dijo...

Hola ....me podrías ayudar... necesito el código fuente en java que realice la multiplicación
de matrices a, b y que almacene el resultado en la matriz c.
26 de noviembre de 2014, 23:23

Publicar un comentario en la entrada


Entrada más recienteEntrada antiguaPágina principal

Buscar en este blog


Buscar
 ¿Qué son los diagramas de flujo?

 FreeDFD Dibujar y Simular Diagramas de Flujo

Labels

1. Public Class Form1


2. Private Sub Button1_Click(ByVal sender As System.Object,
3. ByVal e As System.EventArgs) Handles Button1.Click
4. Dim a, b, suma As Double
5. a = TextBox1.Text
6. b = TextBox2.Text
7. suma = a + b
8. TextBox3.Text = Trim(suma)
9. End Sub
10. End Class

Suma de matrices

¿Suma de matrices con visual basic?


Me pueden ayudar con este problemazo para mi.
Realizar un algoritmo de dos matrices A y B, sumarla y almacenar dicho resultado en otra matriz C,
además hallar el mayor y menor elemento de la matriz C.
Desde ya Gracias. Espero que alguien pueda ayudarme.

Actualizar: Ambas matrices de (M,M)

Seguir

3 respuestas

Notificar un abuso

Respuestas
Calificación
Mejor respuesta: Hace rato no le hacia al visualbasic pero gracias a tu problema practique
mucho .

jovencito solo añadi una cosa que los valores de las dos matrices los genere el metodo next de la
clase Math ok , esta implementado asi next(0,100) numeros entre 0 y 99 , si quiere tu lo puedes
cambiar sin nungun problema para generear tu limites numricos ok

Module Module1

Sub Main()

Dim m1(,) As Integer = CrearMatrizConNumerosAleatoreos(2, 2)


Dim m2(,) As Integer = CrearMatrizConNumerosAleatoreos(2, 2)
Dim m12(,) As Integer = SumarDosMatrices(m1, m2)

MayorMenorSumarDosMatrices(m12)

End Sub

Function CrearMatrizConNumerosAleatoreos(ByVal fila As Integer, ByVal columna As Integer) As


Integer(,)
Dim matriz(fila - 1, columna - 1) As Integer

Dim numero_aleatoreo As New Random()

For i = 0 To matriz.GetUpperBound(0)

For j = 0 To matriz.GetUpperBound(1)

matriz(i, j) = numero_aleatoreo.Next(0, 100)

Next

Next

Return matriz

End Function
Function SumarDosMatrices(ByVal M1 As Integer(,), ByVal M2 As Integer(,)) As Integer(,)

Dim matrizsuma(M1.GetUpperBound(0), M1.GetUpperBound(1)) As Integer

For i = 0 To matrizsuma.GetUpperBound(0)

For j = 0 To matrizsuma.GetUpperBound(1)

matrizsuma(i, j) = M1(i, j) + M2(i, j)

Next

Next

Return matrizsuma

End Function

Sub MayorMenorSumarDosMatrices(ByVal matrizsuma As Integer(,))


Dim mayor, menor As Integer
mayor = matrizsuma(0, 0)
menor = matrizsuma(0, 0)

For i = 0 To matrizsuma.GetUpperBound(0)
For j = 0 To matrizsuma.GetUpperBound(1)

If matrizsuma(i, j) > mayor Then


mayor = matrizsuma(i, j)
End If
If matrizsuma(i, j) < menor Then
menor = matrizsuma(i, j)
End If
Next
Next

Console.WriteLine("El mayor es: " & mayor.ToString() & "y el menor es : " & menor.ToString())
Console.ReadLine()

End Sub

End Module

Fuente(s):Dim m1(,) As Integer = CrearMatrizConNumerosAleatoreos(M, M)


Dim m2(,) As Integer = CrearMatrizConNumerosAleatoreos(M, M)

Juan Camilo · hace 5 años


0

Votar a favor

Votar en contra

Comentario

Notificar un abuso

Jaja tanto codigo.. '


weno.. aki mi aporte
Const N = 10
Dim A1(N)
Dim A2(N)
Dim AR(N)
Mayor = 0
menor = 9999999
For i = 0 To N
x = InputBox("LLenar MAtriz 1")
A1(i) = x
y = InputBox("LLenar MAtriz 2")
A2(i) = y
r=x+y
AR(i) = AR(i) + r
If AR(i) < menor Then menor = AR(i)
If AR(i) > Mayor Then Mayor = AR(i)
Next

MsgBox "La suma de Vectores esta almacenada en AR: " & "El Numero Mayor de Ar es: " & Mayor
& "El menor de Ar es: " & menor

Espero q sea de ayuda


Saludos!

Fuente(s):Mi pc

Josue Navarrete · hace 5 años

Mejor respuesta: ¡Buenas!

Declaras 3 matrices del mismo tipo de dato (int, float o double) "Mresultado" que contendrá a la
matriz suma inicializada a 0 en todas sus celdas, M1 y M2 que serán las dos matrices a sumar, y
todas con el mismo número de filas (N_FILAS) y columnas (N_COLUMNAS).
Vas recorriendo la matriz por ejemplo por filas, y vas sumando los elementos según sus indices i y j
por ejemplo:

Mresultado[2][3] = M1[2][3] + M2[2][3];

Te dejo el el código en lenguaje C que haría la suma.

for(i=0; i <N_FILAS ; i++)


for(j=0 ; j < N_COLUMNAS ; j++)
Mresultado[i][j] = M[i][j] + M2[i][j];

Espero que te ayude.

Un saludo

¿PSEUDOCODIGO PARA MATRICES?


Ayuda con estos ejercicios, no importa que solucionen solo 1, necesito su ayuda...GRACIAS
1))Diseñe un pseudocódigo (pseint ó C++) que sume cada fila de una matriz 3*3 y determine cual
de los números obtenidos de la suma de cada fila es el mayor y que imprima en pantalla cual fila
tiene la mayor... mostrar más

Seguir

1 respuesta

Notificar un abuso

Respuestas

Mejor respuesta: Hola.


1-

Proceso SumaFilasMatriz
Definir f,c Como Entero
Dimension m[3,3],sf[3]
para f<-1 Hasta 3 Hacer
para c<-1 hasta 3 Hacer
m[f,c]<-AZAR(100)+1//numero entre 1 y 100
FinPara
FinPara
para f<-1 Hasta 3 Hacer
para c<-1 hasta 3 Hacer
sf[f]<-sf[f]+m[f,c]
FinPara
FinPara
si(sf[1]>sf[2] y sf[1]>sf[3]) Entonces
f<-1
Sino
si(sf[2]>sf[3]) Entonces
f<-2
Sino
f<-3
FinSi
FinSi
Imprimir "La fila ",f," tiene la mayor suma"
FinProceso

2-
Proceso MatrizAVector
Definir f,c,i Como Entero
Dimension m[6,8],v[48]
para f<-1 Hasta 6 Hacer
para c<-1 hasta 8 Hacer
m[f,c]<-AZAR(100)+1//numero entre 1 y 100
FinPara
FinPara
i<-1
para f<-1 Hasta 6 Hacer
para c<-1 hasta 8 Hacer
v[i]<-m[f,c]
i<-i+1
FinPara
FinPara
para c<-1 hasta 48 Hacer
Imprimir Sin Saltar v[c]," "
FinPara
FinProceso

3-

Saludos.

Como hago un algoritmo de una suma de matrices?


construir un algoritmo que llene la matriz M y la matriz N de enteros positivos entre 1 y 20 y obtener
M+N

Seguir

3 respuestas

Notificar un abuso

Respuestas
Calificación
Mejor respuesta: Hola, aqui esta el algortimo en seudocódigo, la matriz R es la resultante de M
+N

Inicio
--M:matriz de números enteros de tamaño n x n
--N: matriz de números enteros de tamaño n x n
--R: matriz de números enteros de tamaño n x n
-- i: variable de numeros enteros
-- j: variable de numeros enteros
--d: variable de numeros enteros

--Desde i=0 hasta i=n


----Desde j=0 hasta j=n
-------Hacer
-------------Ingresar d
-------Mientras(d<1 or d>20)
-------M(i, j)=d
-------Hacer
-------------Ingresar d
-------Mientras(d<1 or d>20)
-------N(i, j)=d
----Fin Desde
--Fin Desde

--Desde i=0 hasta i=n


----Desde j=0 hasta j=n
-------R(i, j)=M( i, j)+N(i, j)
----Fin Desde
--Fin Desde

FIN

EJERCICIOS RESUELTOS (5): MATRICES

Proceso MatrizEnteros
Escribir “Ingrese numero de filas”
Leer n
Escribir “Ingrese numero de columnas”
Leer m
Dimension a[n,m]
Dimension v[n]
Dimension datos[n]
//recorrer de filas
Para i <- 1 hasta n Hacer
//recorrer de columnas
Para j <- 1 hasta m Hacer
Escribir “a[“,i,”,”,j,”]: “;
Leer a[i,j]
FinPara
FinPara

//Datos de las filas


Para i<-1 Hasta n Hacer
//datos de las columnas
para j<-1 hasta m Hacer
Escribir a[i,j]
FinPara
Fin Para

//Mostrar datos de matriz por fila


Escribir “los datos de cada fila son:…”
Para i<-1 hasta n Hacer
Escribir “fila:…”,i,”es…”,v[i]
FinPara

//mostrar datos de matriz por columna


Escribir “los datos de cada columna son:…”
Para j<-1 hasta m Hacer
Escribir “la columna:…”,j,”es…”,v[j]
FinPara

//suma de las filas


Para i<-1 hasta n Hacer
suma<-0
Para j<-1 hasta m hacer
suma<-sumaf+a[i,j]
FinPara
v[i]=sumaf
FinPara
//muestra la suma de cada fila
Escribir “la suma de cada fila es:”
Para i<-1 hasta n Hacer
Escribir “fila:…”,i, “es…”,v[i]
FinPara

FinProceso

Proceso ProblemaUNO
Escribir “Ingrese dimension de la matriz:…”
Leer n;
Dimension a[n,n]
Para i<-1 hasta n Hacer
Para j<-1 hasta n Hacer
Escribir “a[“,i,”,”,j,”]:”;
Leer a[i,j]
FinPara
FinPara
//Calcular la suma de los datos que se encuentran
//en la Triangular superior
Escribir “Triangular Superior”
suma<-0
Para i<-1 hasta n-1 Hacer
Para j<-i+1 hasta n Hacer
suma<-suma+a[i,j]
FinPara
FinPara
Escribir “La suma de la triangular superior es:…”,suma

//Calcular la suma de los datos que se encuentran


//en la triangular inferior
Escribir “Triangular inferior”
suma2<-0
Para i<-2 hasta n Hacer
Para j<-1 hasta i-1 Hacer
suma2<-suma2+a[i,j]
FinPara
FinPara
Escribir “La suma de la triangular inferior es:…”,suma2

//Determina la Triangular que obtuvo la menor suma


min<-0
Para i <- 1 Hasta n Hacer
Para j<-1 hasta n hacer
Si a[i,j]<min Entonces
min<-suma
Sino
min<-suma2
FinSi
FinPara
posMIN<-min
FinPara
Escribir “La triangular que tiene la suma menor es:..”,posMIN

//Suma diagonal principal


sumaDP<-0
Para i<-1 hasta n Hacer
sumaDP<-sumaDP+a[i,i]
FinPara
Escribir “la suma de la diagonal principal es:…”, sumaDP
//Suma diagonal secundaria
sumaDS<-0
j<-n
Para i<-1 hasta n Hacer
sumaDS<-sumaDS+a[i,j]
j<-j-1
FinPara
Escribir “la suma de la diagonal secundaria es:…”, sumaDS
//Calcular el cuociente entre la sumaDP y sumaDS
Escribir “el cuociente entre la sumaDP y sumaDS:…”, sumaDP/sumaDS
FinProceso
En un laboratorio de muestras médicas, se almacenan los datos de los exámenes clínicos
realizados 2012 utilizando una matriz A de Nx5. Los datos almacenados son rut, dd, mm,
aaaa y valor de la muestra. Se pide:

a) Crear una matriz de tamaño Nx5 con la información de exámenes.

b) Mostrar el total de dinero obtenido por exámenes del año 2012.

c) Contar cuántas atenciones se realizaron en el mes de diciembre 2012.

d) Mostrar el rut del paciente que canceló el menor valor de la muestra.

e) Sumar los vectores de la muestra entre el 15 y 20 de cada mes.

Proceso muestras

Escribir “ingrese cantidad de pacientes”

leer n

dimension a[N,5]

para i<-1 hasta n Hacer

Escribir “ingrese rut”

leer a[i,1]

Escribir “ingrese dia”

leer a[i,2]

Escribir “ingrese mes”

leer a[i,3]

Escribir “ingrese año”

leer a[i,4]
Escribir “ingrese valor de la muestra”

leer a[i,5]

FinPara

//Mostrar el total de dinero obtenido 2012

sumavalor<-0

para i<-1 hasta n Hacer

si a[i,4] = 2012 Entonces

sumavalor<- sumavalor+a[i,5]

FinSi

FinPara

Escribir “el total por muestras es:…”,sumavalor

//mostrar cantidad de atenciones 2012

cont2012<-0

Para i<-1 hasta n Hacer

si a[i,3]=12 y a[i,4]=2012 entonces

cont2012<-cont2012+1

FinSi

FinPara

Escribir “La cantidad de atenciones en diciembre:…”,cont2012

//Mostrar el rut que cancelo menor valor

min<-a[1,5]
rutmin<-a[1,1]

Para i<-1 hasta n Hacer

si a[i,5]<min Entonces

min<-a[i,5]

rutmin<-a[i,1]

FinSi

FinPara

Escribir “el rut que cancelo menor valor es:…”,rutmin

//Mostrar los valores de la muestra entre el 15 y 20 de cada mes

suma2<-0

para i<-1 hasta n Hacer

si a[i,2]>= 15 y a[i,2]<=20 Entonces

suma2<-suma2+a[i,5]

FinSi

FinPara

Escribir “suma valores de la muestra entre el 15 y 20 de cada mes…:”,suma2

FinProceso

DESARROLLO:

leer(matriz [x] [y])


mayor=0; menor=1000;
for(x=0; x
for (y=0; x
{
if (matriz [x] [y]> mayor)
mayor= matriz [x] [y];
if (matriz [x] [y]< menor)
menor= matriz [x] [y];
}
}
escribir(mayor, menor)

Publicado por TRABAJO DE INV