Вы находитесь на странице: 1из 12

AVA UNIVIRTUS http://univirtus-277877701.sa-east-1.elb.amazonaws.com/ava/web/#/a...

Para o algoritmo abaixo, explique a necessidade de se utilizar as variáveis k e j:

algoritmo "vetores"

var

i,j,k,n : inteiro

v: vetor [1..50] de real

vp: vetor [1..50] de real

vn: vetor [1..50] de real

aux: real

inicio

//seção de comandos

escreval("Digite o número de elementos do vetor:")

leia(n)

para i de 1 ate n faca

escreval("Digite um numero qualquer:")

leia(v[i])

fimpara

1 de 12 19/10/2016 10:27
AVA UNIVIRTUS http://univirtus-277877701.sa-east-1.elb.amazonaws.com/ava/web/#/a...

limpatela

k<-0

j<-0

para i de 1 ate n faca

se (v[i]>0) entao

k<-k+1

vp[k]<-v[i]

senao

j<-j+1

vn[j]<-v[i]

fimse

fimpara

escreval("Positivos:")

para i de 1 ate k faca

escreval(vp[i])

fimpara

escreval("Negativos:")

2 de 12 19/10/2016 10:27
AVA UNIVIRTUS http://univirtus-277877701.sa-east-1.elb.amazonaws.com/ava/web/#/a...

para i de 1 ate j faca

escreval(vn[i])

fimpara

Fimalgoritmo

A As variáveis k e j são utilizadas para que os vetores "vp" e "vn" tenham suas posições preenchidas,
respectivamente, com os valores positivos e negativos do vetor "v", definindo a quantidade de
elementos de cada um destes vetores.

Você acertou!

B As variáveis k e j são utilizadas para acumular a soma dos valores positivos e negativos do vetor "v".

C As variáveis k e j são utilizadas para separar os valores dos números positivos e negativos do vetor
"v".

D As variáveis k e j são utilizadas como contéudos dos vetores "vp" - valores positivos e "vn" - valores
negativos.

E As variáveis k e j são utilizadas como contéudos dos vetores "vp" - valores positivos e "vn" - valores
ímpares.

Para o algoritmo abaixo, qual deveria ser o resultado exibido para uma matriz 3X3?

algoritmo "matriz"

var

matriz:vetor[1..10,1..10] de inteiro

i,j,m,n:inteiro

inicio

3 de 12 19/10/2016 10:27
AVA UNIVIRTUS http://univirtus-277877701.sa-east-1.elb.amazonaws.com/ava/web/#/a...

escreval("***** Entrada de Dados *****")

escreval("")

escreva("Digite o numero de linhas e o numero de colunas para matriz:")

leia(m,n)

para i de 1 ate m faca

para j de 1 ate n faca

escreva("Digite um valor para linha:",i," coluna:",j,":")

matriz[i,j]<-i+1

fimpara

fimpara

limpatela

escreval("***** Resultados da matriz *****")

para i de 1 ate m faca

para j de 1 ate n faca

escreva(matriz[i,j])

fimpara

escreval("")

fimpara

fimalgoritmo

4 de 12 19/10/2016 10:27
AVA UNIVIRTUS http://univirtus-277877701.sa-east-1.elb.amazonaws.com/ava/web/#/a...

A 111
222
333

B 222
333
444

Você acertou!

C 222
222
333

D 111
333
555

E 123
345
567

Para o algoritmo abaixo, identifique qual a parte de código preencheria a lacuna em aberto. O algoritmo faz a distribuição
dos números em outros dois vetores, um vetor só com o zero e os números positivos e outro só com números negativos:

algoritmo "vetores"

var

i,j,k,n : inteiro

v: vetor [1..50] de real

vp: vetor [1..50] de real

vn: vetor [1..50] de real

aux: real

5 de 12 19/10/2016 10:27
AVA UNIVIRTUS http://univirtus-277877701.sa-east-1.elb.amazonaws.com/ava/web/#/a...

inicio

//seção de comandos

escreval("Digite o número de elementos do vetor:")

leia(n)

para i de 1 ate n faca

escreval("Digite um numero qualquer:")

leia(v[i])

fimpara

limpatela

+-------------------------------------------------------------------------------------------------------------------------------+

+-------------------------------------------------------------------------------------------------------------------------------+

escreval("Positivos:")

para i de 1 ate k faca

escreval(vp[i])

fimpara

escreval("Negativos:")

para i de 1 ate j faca

escreval(vn[i])

fimpara

6 de 12 19/10/2016 10:27
AVA UNIVIRTUS http://univirtus-277877701.sa-east-1.elb.amazonaws.com/ava/web/#/a...

fimalgoritmo

A para i de 1 ate n faca


se (v[i]>1) entao
k<-k+1
vp[k]<-v[i]
senao
j<-j+1
vn[j]<-v[i]
fimse
fimpara

B k<-0
j<-0
para i de 1 ate n faca
se (v[i]>=0) entao
k<-k+1
vp[k]<-v[i]
senao
j<-j+1
vn[j]<-v[i]
fimse

fimpara

Você acertou!

C para i de 1 ate n faca


se (v[i]>0) entao
k<-k+1
vp[i]<-v[i]
senao
j<-j+1
vn[i]<-v[i]
fimse
fimpara

7 de 12 19/10/2016 10:27
AVA UNIVIRTUS http://univirtus-277877701.sa-east-1.elb.amazonaws.com/ava/web/#/a...

D k<-0
j<-0
para i de 1 ate n faca
se (v[i]>0) entao
vp[k]<-v[i]
senao
vn[j]<-v[i]
fimse

fimpara

E x<-0
j<-0
para i de 1 ate n faca
se (v[i]>0) entao
vp[k]<-v[x]
senao
vn[j]<-v[i]
fimse

fimpara

Para o algoritmo abaixo, qual a melhor declaração de variáveis?

algoritmo "vetores"

inicio

//seção de comandos

escreval("Digite o número de elementos do vetor:")

leia(n)

para i de 1 ate n faca

escreval("Digite um numero qualquer:")

leia(v[i])

8 de 12 19/10/2016 10:27
AVA UNIVIRTUS http://univirtus-277877701.sa-east-1.elb.amazonaws.com/ava/web/#/a...

fimpara

escreval("Digite um valor qualquer para inserir no vetor:")

leia(valor)

escreval("Digite a posição do vetor")

leia(posicao)

para i de n ate 2 passo -1 faca

se (i>=posicao) entao

v[i+1]<-v[i]

fimse

se (posicao=i) entao

v[i]<-valor

fimse

fimpara

para i de 1 ate n+1 faca

escreval(v[i])

fimpara

fimalgoritmo

9 de 12 19/10/2016 10:27
AVA UNIVIRTUS http://univirtus-277877701.sa-east-1.elb.amazonaws.com/ava/web/#/a...

A var
i,n,posicao : inteiro
valor:real
v: vetor [1..50] de real

Você acertou!

B var
i,posicao : inteiro
valor:real
v: vetor [1..50] de real

C var
i,n,posicao : inteiro
v: vetor [1..50] de real

D var
i,n: inteiro
valor:real
v: vetor [1..50] de real

E var
y,x: inteiro
valor:real
v1: vetor [1..50] de real

Para o algoritmo abaixo, qual deveria ser a saída para uma matriz 5X5?

algoritmo "matriz"

var

matriz:vetor[1..10,1..10] de inteiro

i,j,m,n:inteiro

10 de 12 19/10/2016 10:27
AVA UNIVIRTUS http://univirtus-277877701.sa-east-1.elb.amazonaws.com/ava/web/#/a...

inicio

escreval("***** Entrada de Dados *****")

escreval("")

escreva("Digite o numero de linhas e o numero de colunas para matriz:")

leia(m,n)

para i de 1 ate m faca

para j de 1 ate n faca

escreva("Digite um valor para linha:",i," coluna:",j,":")

matriz[i,j]<-j+i

fimpara

fimpara

limpatela

escreval("***** Resultados da matriz *****")

para i de 1 ate m faca

para j de 1 ate n faca

escreva(matriz[i,j])

fimpara

escreval("")

fimpara

11 de 12 19/10/2016 10:27
AVA UNIVIRTUS http://univirtus-277877701.sa-east-1.elb.amazonaws.com/ava/web/#/a...

fimalgoritmo

A 23456
45678
56789
6 7 8 9 10
7 8 9 10 11

B 23456
34567
45678
56789
6 7 8 9 10

Você acertou!

C 13456
25678
36789
4 7 8 9 10
5 8 9 10 11

D 12345
24567
35678
46789
5 7 8 9 10

E 12345
24567
35678
46789
15 17 18 19 20

12 de 12 19/10/2016 10:27