Вы находитесь на странице: 1из 5

Lab ID: 9.9K1116A096.WAN2.

PPP and CHAP


Objective
Configure Point-to-Point Protocol (PPP) and Challenge Handshake Authentication Protocol (CHAP)
authentication on a serial interface.

Lab Topology
The topology diagram below represents the portion of the network you will be configuring in this lab.

Router1
S0/0

S0/0

Router3

Command Summary
Command Description
configure terminal enters global configuration mode from privileged EXEC mode
enable enters privileged EXEC mode
encapsulation ppp enables PPP encapsulation
end ends and exits configuration mode
exit exits one level in the menu structure
interface type number changes from global configuration mode to interface
configuration mode
ping ip-address sends an Internet Control Message Protocol (ICMP) echo
request to the specified address
ppp authentication chap enables CHAP authentication
show interfaces [type number] displays statistics for all interfaces configured on the router
show running-config displays the active configuration file
username router-name password creates a user entry for remote router authentication
password

1 Boson NetSim Lab Manual


The IP addresses and subnet masks used in this lab are shown in the table below:

IP Addresses
Device Interface IP Address Subnet Mask
Router1 Serial 0/0 175.10.1.1 255.255.255.0
Router3 Serial 0/0 175.10.1.2 255.255.255.0

Lab Tasks
Use cisco when prompted for a password.
1. What is the encapsulation type on Router1’s Serial 0/0 interface? __________________________

2. On Router1 and Router3, configure PPP encapsulation for interface Serial 0/0. Note that the link will
not come up unless both ends are configured with the same encapsulation type.

3. On Router1 and Router3, verify that PPP is configured for the link. The output should show the PPP
LCP phase as Open from Router1.

4. From Router1, ping Router3 (175.10.1.2) to verify that the link is operational.

5. Configure PPP CHAP authentication for the Serial 0/0 link on Router1 and Router3. Use the
password of cisco.

6. On Router1 and Router3, verify that both the interface and the line protocol are up.

7. From Router1, ping Router3 (175.10.1.2). The ping should be successful.

Once you have completed this lab, be sure to check your work by using the grading function.
You can do so by clicking the Grade Lab icon ( ) in the toolbar or by pressing Ctrl+G.

2 Boson NetSim Lab Manual


Lab Solutions
Use cisco when prompted for a password.
1. On Router1, issue the following command to display the encapsulation type. The encapsulation type
is High-level Data Link Control (HDLC), which is the default for serial links. Sample output is below:

Router1#show interfaces serial 0/0


Serial0/0 is up, line protocol is up
Hardware is HD64570
Description: Serial Link to Router3
Internet address is 175.10.1.1/24
MTU 1500 bytes, BW 64 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, loopback not set
Keepalive set (10 sec)
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of “show interface” counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queuing strategy: weighted-fair
<output omitted>

2. On Router1 and Router3, issue the following commands to configure PPP encapsulation for
interface Serial 0/0. Note that the link will not come up unless both ends are configured with the
same encapsulation type.

Router1(config)#interface serial 0/0


Router1(config-if)#encapsulation ppp

Router3(config)#interface serial 0/0


Router3(config-if)#encapsulation ppp

3. On Router1 and Router3, issue the following command to verify that PPP is configured for the link.
The output should show the PPP LCP phase as Open from Router1. Sample output from Router1 is
shown:

Router1#show interfaces serial 0/0


Serial0/0 is up, line protocol is up
Hardware is HD64570
Description: Serial Link to Router3
Internet address is 175.10.1.1/24
MTU 1500 bytes, BW 64 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
Keepalive set (10 sec)
LCP Open
Open: IPCP, CDPCP
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of “show interface” counters never
Queuing strategy: weighted-fair
<output omitted>

3 Boson NetSim Lab Manual


4. A ping from Router1 to Router3 (175.10.1.2) should succeed, verifying that the link is operational.

Router1#ping 175.10.1.2

5. On Router1 and Router3, issue the following commands to configure PPP CHAP authentication for
the Serial 0/0 link:

Router1(config)#username Router3 password cisco


Router1(config)#interface serial 0/0
Router1(config-if)#ppp authentication chap

Router3(config)#username Router1 password cisco


Router3(config)#interface serial 0/0
Router3(config-if)#ppp authentication chap

6. On Router1 and Router3, issue the following command to verify that both the interface and the line
protocol are up. Sample output from Router1 is shown:

Router1#show interfaces serial 0/0


Serial0/0 is up, line protocol is up
Hardware is HD64570
Description: Serial Link to Router3
Internet address is 175.10.1.1/24
MTU 1500 bytes, BW 64 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
Keepalive set (10 sec)
LCP Open
Open: IPCP, CDPCP
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of “show interface” counters never
Queuing strategy: weighted-fair
<output omitted>

7. A ping from Router1 to Router3 (175.10.1.2) should be successful.

Router1#ping 175.10.1.2

4 Boson NetSim Lab Manual


Sample Configuration Script
Router1 Router1 (continued)
Router1#show running-config interface FastEthernet0/0
Building configuration... ip address 160.10.1.1 255.255.255.0
Current configuration : 1238 bytes no ip directed-broadcast
! !
Version 15.b interface FastEthernet0/1
service timestamps debug uptime no ip address
service timestamps log uptime no ip directed-broadcast
no service password-encryption shutdown
! !
hostname Router1 router eigrp 100
enable secret 5 $1$lYSY$Ai2eZ8KpUCL9ptJCN1c41w network 160.10.0.0
enable password boson network 175.10.0.0
! auto-summary
username Router3 password cisco !
! ip classless
ip subnet-zero no ip http server
! !
ip cef cdp holdtime 20
no ip domain-lookup cdp timer 50
ip host Router2 160.10.1.2 !
! banner motd ^C
interface Loopback0 Unauthorized Access Prohibited^C
ip address 160.10.2.1 255.255.255.0 line con 0
no ip directed broadcast login
! password cisco
interface Serial0/0 line aux 0
description Serial Link to Router3 line vty 0 4
ip address 175.10.1.1 255.255.255.0 login
no ip directed-broadcast !
clock rate 64000 no scheduler allocate
bandwidth 64 end
encapsulation ppp
ppp authentication chap
!
interface Serial0/1
no ip address
no ip directed-broadcast
shutdown
!

Copyright © 1996–2017 Boson Software, LLC. All rights reserved. NetSim software and documentation are protected by copyright law.

5 Boson NetSim Lab Manual

Вам также может понравиться