Вы находитесь на странице: 1из 9

Institute of Technology of Cambodia

Department of Electrical and Energy


5th year Engineering, 34nd Batch

IP addressing and Sub-netting

Adviser : CHIN Chandaraly

Group : GEE-ET
Student : SANN SEYHA e20140592

2018 - 2019
Contents
I. Objective ................................................................................................................................................ 1
II. Benefit ................................................................................................................................................... 1
1.Addresing IP........................................................................................................................................... 1
2.Sub-netting ............................................................................................................................................. 1
2.1 Setting up logical divisions ............................................................................................................. 1
1.2 Improved network security ............................................................................................................ 2
1.3 Improved network performance .................................................................................................... 2
1.4 More or fewer IP addresses per subnet ......................................................................................... 2
III. Configuration and give an example in Packet Tracer ..................................................................... 2
HQ configuration: ................................................................................................................................. 4
Branch1 configuration: ........................................................................................................................ 6
Branche2 configuration: ....................................................................................................................... 7
IP addressing and Sub-netting

I. Objective
An IP address is an address used in order to uniquely identify a device on an IP network.
The address is made up of 32 binary bits, which can be divisible into a network portion and host
portion with the help of a subnet mask. The 32 binary bits are broken into four octets (1 octet = 8
bits). Each octet is converted to decimal and separated by a period (dot). For this reason, an IP
address is said to be expressed in dotted decimal format (for example, 172.16.81.100). The value
in each octet ranges from 0 to 255 decimal, or 00000000 - 11111111 binary.
Address: The unique number ID assigned to one host or interface in a network.

Subnet: A portion of a network that shares a particular subnet address.


Subnet mask: A 32-bit combination used to describe which portion of an address refers to the
subnet and which part refers to the host. Interface: A network connection.
Subnetting allows you to create multiple logical networks that exist within a single Class
A, B, or C network. If you do not subnet, you are only able to use one network from your Class A,
B, or C network, which is unrealistic.
Each data link on a network must have a unique network ID, with every node on that link being a
member of the same network. If you break a major network (Class A, B, or C) into smaller
subnetworks, it allows you to create a network of interconnecting subnetworks. Each data link on
this network would then have a unique network/subnetwork ID. Any device, or gateway, that
connects n networks/subnetworks has n distinct IP addresses, one for each network / subnetwork
that it interconnects.

II. Benefit

1.Addresing IP
Addressing ip helps we can assign ip for determine our devices.

2.Sub-netting
2.1 Setting up logical divisions
Subnetting helps you maintain clean separations within a network. For example, you can
define boundaries between different departments in your organization, with one subnet for sales,
another for marketing, and a third for engineering.
Alternatively, you could divide your network by floors in a building, or even create
separate subnets for different device types such as VoIP phones, servers, and workstations.

1|P age
Additionally, your logically separated networks would behave almost as if they were physically
separate without the need to re-cable much networking gear to make a change.

1.2 Improved network security


With logical divisions between subnets, you have greater control over who has access to
what. For example, in our departmental example, you could easily restrict those in engineering
from accessing file server containing sensitive sales information, and prevent sales from accessing
a share that houses classified engineering blueprints.
When you divide your network into subnets, you can also better contain security incidents.
Because there are clear separations between subnets, you can set rules to limit traffic between each
distinct subnet, and you can reduce exposure to security incidents. For example, you can better
contain a virus outbreak to one department, limit the information a hacker is able to obtain, or
restrict which devices are open to attack once a portion of a network is compromised.

1.3 Improved network performance


Networks, like highways, can slow to a crawl when there’s too much traffic saturating the
lanes. Some packets might not even make it to their destination if there’s too much network
congestion (or even collisions), which can be particularly problematic when there’s a high volume
of broadcast traffic being sent to every device. Subnetting reduces the amount of broadcast traffic
by containing network broadcasts at the subnet level instead of sending all broadcasts to the entire
network.

1.4 More or fewer IP addresses per subnet


Besides the logical separation use case, subnetting can be used for other purposes as well.
Once you reach a certain number of devices on your network, and have exhausted the number of
IP addresses you can assign on a subnet, re-subnetting is a useful way to add more IP addresses
(sometimes called supernetting). For example, if you need to extend a Class C IP range to
accommodate more than 254 devices, you can double the number available IP addresses by
changing your subnet mask.
Similarly, if you'll never have many devices on a particular subnet and are limited by the
number of available IP addresses you can use, you can easily halve the size of your subnet by
altering the subnet mask as well, reserving the remaining half of your IP addresses for use in a
separate subnet.

III. Configuration and give an example in Packet Tracer

2|P age
Scenario
In this lab, you have been given the network address 192.168.9.0/24 to subnet and provide the IP
addressing for the network shown in the Topology Diagram. The network has the following
addressing
requirements:
• The BRANCH1 LAN_GIM will require 10 host IP addresses.
• The BRANCH1 LAN_GIC will require 10 host IP addresses.
• The BRANCH2 LAN_GCA will require 10 host IP addresses.
• The BRANCH2 LAN_GCI will require 10 host IP addresses.
• The HQ LAN_GEE will require 20 host IP addresses.
• The link from HQ to BRANCH1 will require an IP address for each end of the link.
• The link from HQ to BRANCH2 will require an IP address for each end of the link.

3|P age
HQ configuration:
interface FastEthernet0/0
ip address 192.168.9.1 255.255.255.224
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.9.37 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.9.33 255.255.255.252

4|P age
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
passive-interface FastEthernet0/0
network 192.168.9.0
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login

5|P age
!
end

Branch1 configuration:

interface FastEthernet0/0
ip address 192.168.9.65 255.255.255.240
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.9.50 255.255.255.240
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.9.38 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
passive-interface FastEthernet0/0
passive-interface FastEthernet0/1
network 192.168.9.0
!
ip classless
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!

6|P age
line vty 0 4
login
!
end

Branche2 configuration:
interface FastEthernet0/0
ip address 192.168.9.102 255.255.255.240
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.9.85 255.255.255.240
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.9.34 255.255.255.252
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
passive-interface FastEthernet0/0
passive-interface FastEthernet0/1
network 192.168.9.0
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

7|P age

Вам также может понравиться