Вы находитесь на странице: 1из 6

Tarea Semana 2

Roberto Pulgar Roco

Programación de Computadores I

Instituto IACC

24-06-2019
Desarrollo

- Supongamos que el día lunes usted se levanta en la mañana y realiza todas sus

actividades normalmente hasta antes de salir hacia su trabajo. En el momento de

hacerlo, se encuentra con que su automóvil se niega a arrancar y obviamente existe en

el motor un desperfecto técnico que usted ignora como solucionar. Entonces, procede

a llamar una grúa para remolcarlo al taller, pero en el intertanto, recibe una llamada

desde la oficina solicitándole que concurra allí rápidamente para asistir a una reunión

importante. Usted deberá decidir entonces si esperar la llegada de la grúa y entregar

su auto para llevarlo al taller o sencillamente cancelar la llamada, abordar un microbús

o taxi y dirigirse a la oficina rápidamente para luego preocuparse de reparar su

automóvil.

Utilizando la plantilla establecida por IACC para la entrega de tareas de la semana, descargable

desde la plataforma del curso junto con estas instrucciones, se pide:

1.- Implementar un diagrama de flujo que describa la secuencia de eventos relatados

anteriormente, desde el momento en que se levanta hasta que llega a la oficina, tomando

en cuenta las decisiones tomadas, que obviamente dependen de su propia voluntad, y

aplicando la simbología básica abordada hasta la semana 2 del curso.


Con este diagrama de flujo podemos determinar la decisión que necesitamos para poder afrontar

la situación que se nos presentan, cada día tenemos que tomar estas cosas como por ejemplo ir al

trabajo, dormir, comer, cuidar de la familia etc. Es por eso que también se anteponen los

imprevistos por eso las secuencia se transforman en booleanos que esto quiere decir si es falso o

verdaderos o falso si es si o no.


2.- Traducir el diagrama de flujo, determinado en el punto anterior, a un algoritmo en

pseudocódigo de la manera más fiel posible, aplicando las 2 primeras fases de la

programación.

Algoritmo Inicio_Dia

Definir EnciendoAutomovil Como Caracter


Escribir 'Inicio de dia Laboral'

Escribir 'Levantarse'

Escribir 'Enceder auto'

Escribir 'Arranca el auto'

Leer EnciendoAutomovil

Si EnciendoAutomovil='Si' Entonces

Escribir 'llego sin incovenientes a la oficina'

SiNo

Si EnciendoAutomovil='No' Entonces

Escribir 'Llamar una grua'

Escribir 'Recibo Llamada desde la oficina'

Escribir 'Esperar la grua'

Leer Esperar_Grua

Si EsperoGrua='Si' Entonces

Escribir 'Entrego Auto para llevar al taller'

SiNo

Escribir 'Cancelar Llamada'

Escribir 'me traslado en locomoción al trabajo'

FinSi

FinSi

FinSi

FinAlgoritmo
Bibliografía

Iacc 2019, programación de computadores semana 2