Вы находитесь на странице: 1из 4

Después de consultar los temas de diagrama de flujo, algoritmo, programación y el lenguaje

de programación PSint, realice el siguiente proyecto final (Valor 15 Puntos)


Realiza un diagrama de flujo que luego convierta en algoritmo y por último programarlo que
consiste en lo siguiente: Que ingresado el código de un cliente, el nombre del cliente, el
monto de un préstamo (capital del préstamo), la tasa de interés anual, y la forma de pago
(Diario, semanal, quincenal o mensual) calcule e imprima lo siguiente:
1. Código del cliente
2. Nombre del cliente
3. Monto del préstamo
4. La tasa de interés
5. La forma de pago
6. Numero de cuotas a pagar
7. Monto a pagar por cuotas
8. Monto al que asciende el préstamo
9. Ganancia interés
Nota: Probar el programa con estos calores
Código del cliente :1
Nombre de cliente : Mario Ortiz
Monto del préstamo : 9000
Tasa de interés mensual: 5
Numero de cuotas : 12
Monto Cuotas : 1200
Monto al que asciende el préstamo: 14500
Ganancia por interés: 5400

Nota: mc = monto cuota , mp= Monto del préstamo, ti= tasa de interés, nc = número de cuotas,
map= monto al que asciende el préstamo, ig= intereses ganados

if (fp==1)

mc=(((mp *( ti/100))*nc)+mp)/nc;

map=((((mp*ti)/100)*nc)+mp);

ig=(((mp*ti)/100)*nc);

else
if (fp==2)

mc =((((mp *( ti / 2)/100))*nc)+mp)/nc;

map=((((mp*ti/2)/100)*nc)+mp);

ig=(((mp*ti/2)/100)*nc);

if (fp==3)

// Operaciones

mc =((((mp *( ti / 4.34524)/100))*nc)+mp)/nc;

map=((((mp*ti/4.34524)/100)*nc)+mp);

ig=(((mp*ti/4.34524)/100)*nc);

if (fp==4)

mc =((((mp *( ti / 30.42)/100))*nc)+mp)/nc;

map=((((mp*ti/30.42)/100)*nc)+mp);

ig=(((mp*ti/30.42)/100)*nc);

MI ALGORITMO

Algoritmo CALCULO_PRESTAMO

Definir N,CC Como Caracter;


Definir MP,TI,NC,IG,FP Como Entero;

Definir MC,TIG,MAP Como Real

//PRESENTACION DEL PROGRAMA//

Escribir "...INTRODUCCION DE DATOS PRESTAMO/CLIENTE.."

Escribir " ";

Escribir "//ingrese los siguientes de datos al sisitema// ";

//ingresos de datos al sistema//

Escribir "nombre del cliente: "

Leer N;

Escribir "codigo del cliente:"

Leer CC;

Escribir "monto del prestamo solicitado:"

Leer MP;

Escribir "DIGITE LA TAZA MENSUAL DE INTERES DEL PRESTAMO:"

Leer TI;

Escribir "DIGITE EN VALOR NUMERICO LA FORMA DE PAGO (1, 7 15 O


30);";

Leer FP;

Si FP=1 Entonces Escribir"OPCION DE PAGO: DIARA"

FinSi

Si FP=7 ENTONCES Escribir "OPCION DE PAGO: SEMANAL";

FinSi

si FP=15 ENTONCES Escribir "OPCION DE PAGO: QUINCENAL";


FinSi

SI FP=30 Entonces Escribir "OPCION DE PAGO: MENSUAL"

FinSi

Escribir " ";

Escribir "cantidad de cuotas"

Leer NC;

//formula de procesos

TIG<-(FP/30)*(TI*NC)*MP/100;

MC<-(MP+TIG)/NC;

MAP<-TIG+MP;

Escribir "EL MONTO A PAGAR DE LAS CUOTAS ES:RD:",MC;

Escribir "TAZA DE INTEREZ GENERADA DEL PRESTAMO:RD",TIG;

Escribir "EL MONTO QUE ASCIENDE EL PRESTAMO ES: RD",MAP;