Вы находитесь на странице: 1из 62

Borhen Eddine ZORGUI

1. Passage d’un mode a l’autre

Mode d’exécution
utilisateur

Router>enable

Mode d’exécution privilégie

Router #configure terminal

Mode de configuration global

Config-if Config-router Config-line Config-xxxx

1
Borhen Eddine ZORGUI

2. Commande de configuration

Configuration du nom et de mot de passe

Router>? Le point d’interrogation


permet d’afficher les
commandes disponibles
dans ce mode.
Router>enable

Passage en mode privilégié :


la commande enable

Router#conf t
Passage en mode de configuration
globale : la commande configure
terminal
configure terminal peut être écrit conf t le
routeur l’interprète automatiquement.
Il suffit d’écrire les deux ou trois premières
Lettres d’une commande (appuyant sur la
touche TAB pour que le routeur l’interprète

Les commandes disponibles en mode de configuration globale :


Router (config)#?

Choix d’un mot de passe pour la protection de la session du mode privilégié


Router (config)#enable password pwd

Ou pour activer un mot de passe chiffré :

Router (config)#enable secret pwd

L’attribution d’un nom au routeur : la commande hostname


Router (config)#hostname arfado_1

2
Borhen Eddine ZORGUI

Passage en mode de configuration d’interface


Router (config)#interface s0/0
Router (config-if)#ip address 204.204.7.33 255.255.255.240
Router (config-if)#no shutdown //Activation de l’interface//

Router (config-if)# shutdown //désactivation de l’interface//

La détermination de la vitesse d’horloge : la commande clock rate (pour


l’interface série) .
clock rate doit être
Router (config-if)#clock rate 56000 configuré pour le DCE
Router (config-if)#no shutdown

La détermination de la Bande passante: la commande bandwidth (pour


l’interface série).
Router (config-if)#bandwidth 56
Router (config-if)#no shutdown

Changement d’interface
Router (config)#int f0/0
Router (config-if)#ip ad 204.204.7.49 255.255.255.240
Router (config-if)#no s

Router (config-if)#int f0/1


Router (config-if)#ip ad 204.204.7.17 255.255.255.240
Router (config-if)#no s

Sortie du mode de configuration d’interface

Router (config-if)#exit

Configuration des sessions telnet


Router (config)#line vty 0 4
Router (config-line)#login
Router (config-line)#password Tma3touk
Router (config-line)#service password-encryption

Configuration du port console


Router (config)#line con 0
Router (config-line)#login
Router (config-line)#password Tma3touk //Activer le mot de passe//
Router (config-line)#ser password-encryption

Router (config-line)#no password //Désactiver le mot de passe//

3
Borhen Eddine ZORGUI

Configuration du port auxiliaire


Router (config)#line aux 0
Router (config-line)#login
Router (config-line)#password Tma3touk
Router (config-line)#exit

Nom de machine

Syntaxe :
ip host <nom machine> <@ip>

Exemple :

Router#conf term
Router (config)#ip host ali 88.77.66.55

Ajouter des comptes d’utilisateur


switch# conf t
switch (config)# username jay privilege 15 password pwd
switch (config)# username bob privilege 1 password pwd
switch (config)# line console 0 exec-timeout <min>< second> :
switch (config-line)# login local temps d’attente avant de saisir le
switch (config-line)# exit mot de passe dans l’invite de
switch (config)# line vty 0 4 commende pour l’entrer au switch
switch (config-line)# login local ou router.
switch (config-line)# exit
switch (config)# line aux 0 15 min

switch (config-line)# login local


switch #
-----------------------------------------
switch (config)# line vty 0 4 0 second
switch (config-line)# login local
switch (config-line)# exec-timeout 15 0
switch (config-line)# exit

4
Borhen Eddine ZORGUI

Exemple de configuration d’un router

S 0/0

Router>?
Router>enable
Router#configure terminal
Router(config)#
Router(config)#hostname router1
router1(config)#enable password pwd
router1(config)#enable secret pwd
router1(config)#line vty 0 4
router1(config-line)#password 0000
router1(config-line)#login
router1(config-line)#line console 0
router1(config-line)#password 0000
router1(config-line)#login
router1(config)#service pasword-encyption
router1(config)#interface f 0/1
router1(config-if)#ip address 192.168.1.1 255.255.255.0
router1(config-if)#no shutdown
router1(config-if)#interface s 0/0
router1(config-if)#ip address 10.0.0.1 255.0.0.0
router1(config-if)#clock rate 56000
router(config-if)#bandwidth 56
router1(config-if)#no shutdown

5
Borhen Eddine ZORGUI

2.1. Quelque commende utilisée


 Enregistrement synchrone

Le logiciel Cisco ISO envoie fréquemment des messages non sollicités, par exemple pour
signaler une modification de l’état d’une interface configurée. Ces messages peuvent parfois
s’afficher pendant la saisie d’une commande. Le message n’affecte pas la commande, mais
peut être déroutant pour l’utilisateur qui tape la commande. Pour séparer les messages non
sollicités des saisies de l’utilisateur, vous pouvez utiliser la commande logging synchronous
en mode de configuration globale.

 Désactivation de la recherche DNS

Par défaut, lorsqu’un nom d’hôte est entré en mode actif, le routeur suppose que l’utilisateur
tente d’établir une connexion Telnet avec un périphérique. Le routeur tente de résoudre les
noms inconnus entrés en mode actif en les envoyant au serveur DNS. Ce processus est
appliqué à tous les mots entrés qui ne son pas reconnus par le routeur, y compris les
commandes tapées incorrectement. Si ne souhaitez pas appliquer ce processus, la commande
no ip domain-lookup désactive cette fonctionnalité par défaut.

Et pour activer la fonctionnement de DNS taper la commande : ip domaine-lookup

 Running-config

6
Borhen Eddine ZORGUI

Les protocoles de routage extérieurs permettent aux systèmes autonomes de communiquer


entre eux.

Les protocoles de routage intérieurs sont utilisés au sein d'un système autonome

7
Borhen Eddine ZORGUI

3. Routage Statique

Interface
d’entrer :
10.10.10.2

ip route [destination_network] [mask] [next-hop_address or exitinterface]


[administrative_distance] [permanent]
next-hop_address : L'adresse du prochain routeur qui va recevoir le paquet et de le transmettre
au réseau distant.
En va configurée statiquement le routeur nommée router0 pour accédé a l’autre réseau, par
exemple vert le réseau 192.168.11.0 à travers l’interface 10.10.10.2 de routeur router1
Router>en
Router#conf t
Router(config)#ip route 192.168.11.0 255.255.255.0 10.10.10.2

Réseau destinateur @IP d’Interface d’entrer de prote série de


premier routeur

Router(config)#no shutdown

Routage statique par défeaut

Router0(config)#no ip route 192.168.11.0 255.255.255.0 10.10.10.2


Router0(config)#ip route 0.0.0.0 0.0.0.0 10.10.10.2
Ou
Router0 (config)#ip route 0.0.0.0 0.0.0.0 s0/0
Utilise l’adresse ip de l’interface s 0/0 par défaut

ip default-network

Router0 (config)#ip default-network 192.168.11.0


Dans la router0 ne trouve pas un default Gateway, alors dans le cas arrive un paquet
n’appartient pas au réseau 192.168.11.0/24 le router0 faire DROP à cette paquet.

8
Borhen Eddine ZORGUI

Alors pour acheminée cette paquet en va ajouter cette commande ip default-network


192.168.11.0 pour le router comprendre qui le réseau 192.168.11.0 c’est le seul choix pour
acheminer cette paquet dans le cas qui le paquet n’appartient au réseau 192.168.11.0

(*) qui présente devant (s)


indique que la commande ip
default-network est activer.

Si la commande ip default-
network n’est pas activer donc
l’* n’existe pas.
Activation du routage

Router(config)#iprouting

Vérifier la table de routage

Router#show ip route

Commande ip classless (sans classe)

Notez que c'est un mode de commande de configuration globale. La partie intéressante de l'ip
commande sans classes est que le routage par défaut fonctionne parfois sans elle, mais parfois
ne fonctionne pas. Pour être du bon côté, vous devriez toujours mettre la commande ip
classless lorsque vous utilisez le routage par défaut.
Router (config)#ip classless

9
Borhen Eddine ZORGUI

Exemple de configuration static :

Router0
bor>en
bor#conf t Dans chaque routeur en va Définie les route
statique vert tout les réseaux et à quelle
bor(config)#ip route 20.0.0.0 255.0.0.0 10.0.0.2
interface de sortie se passe
bor(config)#ip route 30.0.0.0 255.0.0.0 10.0.0.2
bor(config)#ip route 40.0.0.0 255.0.0.0 10.0.0.2
bor(config)#ip route 100.0.0.0 255.0.0.0 10.0.0.2
bor(config)#ip route 172.16.0.0 255.255.0.0 10.0.0.2
Router1
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ip route 192.168.1.0 255.255.255.0 10.0.0.1
Router(config)#ip route 100.0.0.0 255.0.0.0 20.0.0.2
Router(config)#ip route 30.0.0.0 255.0.0.0 20.0.0.2
Router(config)#ip route 40.0.0.0 255.0.0.0 20.0.0.2
Router(config)#ip route 172.16.0.0 255.255.0.0 20.0.0.2
Router4
bb#conf t
Enter configuration commands, one per line. End with CNTL/Z.
bb(config)#ip route 10.0.0.0 255.0.0.0 20.0.0.1

10
Borhen Eddine ZORGUI

bb(config)#ip route 192.168.1.0 255.255.255.0 20.0.0.1


bb(config)#ip route 40.0.0.0 255.0.0.0 30.0.0.2
bb(config)#ip route 172.16.0.0 255.255.0.0 30.0.0.2
Router2
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ip route 100.0.0.0 255.0.0.0 30.0.0.1
Router(config)#ip route 10.0.0.0 255.0.0.0 30.0.0.1
Router(config)#ip route 192.168.1.0 255.255.255.0 30.0.0.1
Router(config)#ip route 172.16.0.0 255.255.0.0 40.0.0.2
Router3
Router>en
Router#conf t
Router(config)#ip route 30.0.0.0 255.0.0.0 40.0.0.1
Router(config)#ip route 20.0.0.0 255.0.0.0 40.0.0.1
Router(config)#ip route 10.0.0.0 255.0.0.0 40.0.0.1
Router(config)#ip route 100.0.0.0 255.0.0.0 40.0.0.1
Router(config)#ip route 192.168.1.0 255.255.255.0 40.0.0.1

11
Borhen Eddine ZORGUI

4. Routage dynamique
4.1. Routage RIP

RIP est un protocole à vecteur de distance courant. Prise en charge par la plupart des
routeurs. Il s’agit d’un choix approprié pour les petits réseaux dotés de plusieurs routeurs. Il
trouve de version (version 1 et version 2). Le protocole RIP a été initialement défini dans la
RFC 1058. Ses principales caractéristiques sont les suivantes :

 il s'agit d'un protocole de routage à vecteur de distance,


 il utilise le nombre de sauts comme métrique de sélection de chemin,
 le nombre de sauts maximum autorisé est égal à 15,
 les mises à jour du routage sont diffusées par défaut toutes les 30 secondes.

Router(config)#router rip
Router(config-router)#version 1 | 2
Router(config-router)#network 1er @ réseau
Router(config-router)#network 2 éme @ réseau
Router(config-router)#network N° éme @ réseau
Le routage ce fait entre les deux interfaces 1er réseau et le 2 éme réseau

12
Borhen Eddine ZORGUI

4.2. Configuring IGRP Routing

Le protocole IGRP est un protocole de routage à vecteur de distance mis au point par Cisco. Il
envoie les mises à jour de routage toutes les 90 secondes et donne aux réseaux des
informations sur un système autonome particulier. De par sa conception, le protocole IGRP
est doté, entre autres, des caractéristiques suivantes :

 Sa polyvalence lui permet de traiter automatiquement des topologies complexes et


indéfinies.
 Il offre une grande souplesse pour les segments présentant des caractéristiques différentes
en termes de délai et de bande passante.
 Son évolutivité lui permet de fonctionner sur des réseaux de très grande taille.

Le protocole de routage IGRP utilise une combinaison de variables pour déterminer une
métrique composée. Ces variables sont les suivantes :

 bande passante,
 délai,
 charge,
 fiabilité.

Router(config)#router igrp numéraux_système_autonome


Router(config-router)#network 1er @ réseau
Router(config-router)#network 2 éme @ réseau
Router(config-router)#network N° éme @ réseau

 La vitesse est le facteur principal


 Une métrique composée sélectionne le chemin

13
Borhen Eddine ZORGUI

4.3. Configuring EIGRP Routing

EIGRP (Enhanced Interior Gateway Routing Protocol) est un protocole de routage


propriétaire CISCO à vecteur dedistance. Sa distance administrative est 90

Les 4 mécanismes clés


Selon Cisco
 découverte/rétablissement des voisins
 RTP (Reliable Transport Protocol) : les paquets d'échanges de tables entre voisins
(update, query et reply) sont acquittés (en unicast)
 basé sur l'algorithme DUAL (Diffusing Update ALgorithm) qui lui assure une topologie
sans boucle
 PDMs (Protocol-Dependent Modules) = support de multiples protocoles tels IP,
Appletalk, IP

Particularités d'EIGRP

 réduit la consommation de la bande passante par l'envoie d'update partiels


 VLSM (Variable-Length Subnet Masking) support : le protocole diffuse les réseaux avec
leur masque (classless routing protocol) mais pas par défaut (nécessite no auto-summary)
 utilise des paquets Hello pour découvrir ses voisins et connaitre leur état
 pour être voisins, 2 routeurs doivent avoir les mêmes constantes K (K-value) et le même
numéro d'AS
 métrique “sophistiquée” (composite metric) : par défaut basée sur la bande passante et le
délais de l'interface (256 x la métrique IGRP), mais on peut également prendre en compte
la fiabilité, la charge ou la MTU du lien
 utilise une adresse multicast pour dialoguer (224.0.0.10) mais peut aussi utilier de l'unicast
en spécifiant les voisins à la main
Par défaut EIGRP est capable de faire du partage de charge entre plusieurs (par défaut 4 ;
maximum 6) successeurs de même métrique ; en jouant sur la variance il peut même le faire
sur des routes à métriques différentes. Par défaut la variance vaut 1 (le max possible est 128) ;
si on la passe à 2 cela signifie que le routeur fera du partage de charge sur tous les feasible
successors ayant une métrique ⇐ à la métrique du successeur x2.
Le timeout en EIGRP est de 3 min : si un voisin ne répond pas à une demande avant la
fin de ce timeout, il est supprimé de la table des voisins.

Les 5 types de paquets

 Hello : paquet multicast de découverte des voisins, émis par défaut toutes les 5s sur les
liens rapides et toutes les 60s sur les liens multipoints lents (e.g. NBMA). Le hold
time est égal à 3 fois le hello interval.

14
Borhen Eddine ZORGUI

 Update : envoyés en multicast ou unicast, non périodiques


 Query : normalement multicast mais peuvent être en unicast
 Reply : unicast
 ACK : paquet unicast pour acquitter les update, query et reply

Calcul de la métrique
La métrique c'est un coût = plus elle est faible, meilleure elle est. En EIGRP on utilise la
même métrique qu'en IGRP x 256 (32 bits contre 24 bits pour IGRP). Elle est calculée grâce a
une savante formule qui peut prendre en compte les paramètres de l'interface suivants :
 la bande passante
 le délai
 la fiabilité
 la charge
 la MTU

A router Running EIGRP maintains 3 tables:

 la table de voisins ou table d'adjacence : contient la liste des routeurs voisins qui ont
établis une adjacence ainsi que l'interface pour les atteindre
 la table de topology : contient tous les routes apprises par les voisins, avec leur
FD/AD/voisin associé
 la table de routage : contient les meilleures routes vers chaque réseau connu (= successor
route)

Les routeurs n'échangent que leur meilleur route et pas la totalité contrairement à un protocole
à état de lien comme OSPF par exemple.

15
Borhen Eddine ZORGUI

Configuration :

Configurez le routage EIGRP sur le routeur Paris

Activez le processus de routage EIGRP sur Paris, puis configurez les réseaux qu’il annoncera.
Utilisez le numéro de système autonome EIGRP 101.
Paris(config)#router eigrp 101
Paris(config-router)#network 192.168.3.0
Paris(config-router)#network 192.168.2.0
Paris(config-router)#network 192.168.0.0
Paris(config-router)#end
Affichez la table de routage du routeur Paris.
Paris#show ip route
La table de routage contient-elle des entrées ? Non
Pourquoi ? Le processus de routage EIGRP n'est pas configuré sur Warsaw.
Configurez le routage EIGRP sur le routeur Warsaw

Activez le processus de routage EIGRP sur Warsaw, puis configurez les réseaux qu’il
annoncera. Utilisez le numéro de système autonome EIGRP 101.
Warsaw(config)#router eigrp 101
Warsaw(config-router)#network 192.168.2.0
Warsaw(config-router)#network 192.168.1.0
Warsaw(config-router)#end

16
Borhen Eddine ZORGUI

Affichez la table de routage du routeur Warsaw.


Warsaw#show ip route

À l’aide de la commande show ip interface brief, vérifiez l’état de chaque interface

Dans le cas général

Router(config)#router eigrp numéraux_système_autonome


Router(config-router)#network 1er @ réseau
Router(config-router)#network 2 éme @ réseau
Router(config-router)#network N° éme @ réseau

Maximum Paths and Hop Count

Par défaut, EIGRP (et IGRP) peut fournir l'équilibrage de charge inégale des coûts pouvant
aller jusqu'à quatre liens. Cependant, vous pouvez avoir EIGRP fait équilibrer la charge entre
jusqu'à six liaisons à l'aide de la commande suivante:

Vous avez entendu EIGRP ( Enhanced Interior Gateway Routing Protocol ) est un bon choix
car la vitesse de basculement est faible et il est capable d'équilibrer la charge entre les
chemins inégaux.

Router (config)#router eigrp 10


Router (config-router)#maximum-paths ?
<1-6> Number of paths

Par défaut, l'équilibrage de charge est actif uniquement entre des trajets égaux. Après cela, il
est possible d'utiliser l'équilibrage de charge entre les chemins inégaux

R1(config)# router eigrp 1


R1(config-router)# variance ?
<1-128> Metric variance multiplier

17
Borhen Eddine ZORGUI

Nous devons reset le process sur le router.


R1# clear ip eigrp neighbors

Pour faire du partage de charge sur des chemins de métriques différentes, on précise la
variance, un coefficient qui détermine quels chemins seront utilisés. Une variance de 2 active
le partage de charge entre les chemins dont la métrique est inférieur ou égale à 2 fois celle du
successeur. Par défaut la variance vaut 1, ce qui n'active le partage de charge que sur les
chemins de même métrique que le successeur (donc les meilleurs chemins)

En outre, EIGRP (et encore IGRP) dispose d'un nombre maximal de sauts de 100, mais il
peut être mis en place à 255. Il ya des chances que vous ne voulez pas jamais changer cela,
mais si vous l'avez fait, voici comment vous le feriez:

Pod1R1(config)#router eigrp 10
Pod1R1(config-router)#metric maximum-hops ?
<1-255> Hop count

Comme vous pouvez le voir à partir de la sortie du routeur ci-dessus, EIGRP peut être réglé à
un maximum de 255 sauts, et même si elle n'utilise pas le nombre de sauts dans le calcul
métrique de chemin, il utilise toujours le nombre maximal de sauts de limiter la portée de la
AS.

Visiting the Friendly EIGRP Neighborhood

 HELLO : forms relationship

 Par défaut, hello les paquets sont envoyés toutes les 60 secondes sur T1 ou plus lents
interfaces multipoints et toutes les 5 secondes sur d'autres interfaces série et LAN
(NBMA). Cette valeur peut être réglée avec la commande de configuration d'interface:

Router (config-if)#ip hello-interval eigrp <AS> <seconds>

 Hold-time :

 Il s'agit de la quantité de temps qu'un routeur prendra en considération un voisin vivant


sans recevoir de paquets hello. Le temps de maintien est généralement trois fois
l'intervalle HELLO. Contrairement à OSPF changer la minuterie HELLO n'ajuste pas
automatiquement la hold-time.
 Parfois paquets hello sont perdus dans les réseaux encombrés et des relations de voisinage
commencent à battre; dans ce cas, vous voudrez peut-être augmenter le temps de maintien.
 L'augmentation de la convergence attente à rebours des retards, il s'agit d'un effet
indésirable. Si le défaut hello/hold n'est pas adapté à votre réseau essayer de trouver la
valeur qui convient le mieux à votre réseau.

Router(config-if)#ip hold-time eigrp <AS> <seconds>

18
Borhen Eddine ZORGUI

 timers active-time

Quand un routeur EIGRP perd un itinéraire vers une destination (peut-être parce que d'une
interface vers le bas l'événement), il va chercher dans sa base de données de topologie EIGRP
pour voir si elle a un coût égal ou itinéraire de successeur possible pour le réseau de
destination. Si c'est le cas, immédiatement commencer à utiliser le nouveau chemin et mettre
à jour sa base de données de topologie EIGRP et table de routage IP, EIGRP Mises à jour et
envoyer à ses voisins décrivant les valeurs K de la meilleure voie nouvelle.
Si aucun chemin coût égal ou successeur possible existe, marquer la route comme "Active" et
envoyer des messages de requête EIGRP à ses voisins (à l'exception de l'interface sur laquelle
l'itinéraire a été perdue). Le message de requête EIGRP contient le réseau IP de destination en
question avec un "Destination Unreachable" message (infini métrique). Les voisins EIGRP
réception de la requête doit retourner immédiatement unicast un message d'accusé de
reconnaître simplement la requête a été reçue, mais encore en raison d'une réponse.
Après l'envoi de l'accusé de réception, le voisin va chercher dans sa base de données de
topologie EIGRP pour le réseau de destination en question.
Si la destination est trouvée grâce à un successeur ou successeur possible autre que le voisin
d'envoyer la requête, envoyer immédiatement une réponse avec les métriques de composants
itinéraire (valeurs K) retour à la voisine Interrogation. Le voisin Interrogation doit
immédiatement renvoyer un ACK pour accuser réception de la réponse a été reçue.
Si la destination se trouve dans le prochain envoi de la requête, ce voisin marquera également
le parcours comme "Active" et envoyer des requêtes à l'ensemble de ses voisins. Une fois que
tous les voisins ont répondu, puis renvoyer une réponse à l'interrogation initiale voisin.
Si aucune information n'est trouvée sur la destination en question, ou pas d'autres voisins peut
être interrogé, immédiatement renvoyer une réponse avec un "Destination Unreachable"
message (une métrique infinie)

EIGRP coincé en activité - SIA:


Lorsqu’un routeur envoie une requête à un voisin qu'il règle un temporisateur actif 3
minutes. Si le voisin ne répond pas dans le minuteur 3 minutes Active (peut-être parce que le
voisin est en attente de réponses de requêtes lui-même avant de pouvoir répondre) - la relation
de voisinage est remise à zéro
Router (config-router)#timers active-time ?

Show the neighbors


R1# show ip eigrp neighbors
IP-EIGRP Neighbors for process 77
H Address Interface Hold Uptime Q Seq SRTT RTO
(secs) (h:m:s) Count Num (ms) (ms)
1 160.89.81.28 Ethernet1 13 0:00:41 0 11 4 20
2 160.89.80.28 Ethernet0 14 0:02:01 0 10 12 24

19
Borhen Eddine ZORGUI

Show the Topology


R1# show ip eigrp topology

Advertising Default Information into EIGRP

 Mauvaise méthode

Router (config)#ip default-network 172.30.0.0


Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR
T - traffic engineered route
Gateway of last resort is not set

* 172.30.0.0/24 is subnetted, 2 subnets


C* 172.30.0.0 is directly connected, Loopback0
C 172.30.1.0 is directly connected, Loopback1

 Meilleur méthode

R1 (config)#ip route 0.0.0.0 0.0.0.0


R1#show ip route
...
Gateway of last resort is 0.0.0.0 to network 0.0.0.0

172.30.0.0/24 is subnetted, 2 subnets


C 172.30.0.0 is directly connected, Loopback0
C 172.30.1.0 is directly connected, Loopback1
S* 0.0.0.0/0 is directly connected, Loopback0

Traffic exchanged in EIGRP


R1# show ip eigrp traffic
IP-EIGRP Traffic Statistics for process 1
Hellos sent/received: 758/711
Updates sent/received: 16/23
Queries sent/received: 0/2
Replies sent/received: 2/0
Acks sent/received: 18/12
Input queue high water mark 0, 0 drops

20
Borhen Eddine ZORGUI

Authentication

Regarder l'heure:

Router#show clock
*01:02:05.658 UTC Mon Mar 1 1993

 Configurer l'authentification

Il est possible de configurer plusieurs clés pour des dates différentes. Ainsi le changement de
mot de passe se fera automatiquement.
Le nom de mot de passe
R1(config)# key chain EIGRPAuth
R1(config-keychain)# key 1
R1(config-keychain-key)#?
Key-chain key configuration commands:
accept-lifetime Set accept lifetime of key
default Set a command to its defaults
exit Exit from key-chain key configuration mode
key-string Set key string
no Negate a command or set its defaults
send-lifetime Set send lifetime of key
R1(config-keychain-key)# key-string myPasswd
R1(config-keychain-key)# accept-lifetime 11:30:00 Feb 5 2008 11:30:00 March 5 2008
R1(config-keychain-key)# send-lifetime 11:30:00 Feb 5 2008 11:30:00 March 5 2008

 On peut spécifier une seconde clé:

R1(config-keychain)# key 2
R1(config-keychain-key)# key-string myPasswd
R1(config-keychain-key)# accept-lifetime 11:30:00 March 4 2008 11:30:00 April 4 2008
R1(config-keychain-key)# send-lifetime 11:30:00 March 4 2008 11:30:00 April 4 2008

Ensuite copier-coller ces lignes de commande sur tous vos routeurs.

 Activer l'authentification

R1# conf t
R1(config)# int s0/0.2
R1(config-subif)# ip authentication mode eigrp as-number md5
R1(config-subif)# ip authentication key-chain eigrp as-number key-chain

The key-chain was EIGRPAuth in my previous example.

21
Borhen Eddine ZORGUI

Agrégation de routes
Dans certains cas, pour limiter la taille des tables de routage, il peut être intéressant d'agréger
les routes : l'endroit stratégique est sur les routeurs de bordure de système autonome (ASBR).
Cela se fait par défaut selon le schéma du CIDR, mais comme nous l'avons vu plus haut il
vaut mieux désactiver cette fonction. En revanche on peut affiner manuellement cette
agrégation, par interface :

Core#config t
Core(config)#router eigrp 10
Core(config-router)#network 192.168.10.0
Core(config-router)#network 10.0.0.0
Core(config-router)#no auto-summary
Core(config-router)#interface ethernet 0
Core(config-if)#ip summary-address eigrp 10 192.168.10.64 255.255.255.224
CIDR ????? : L’adressage CIDR (sans classe) utilisée pour résumé la taille d’adressage au
niveau de routeur pour diminuée la taille de table de routage
Subnet 1 : 192.168.0.0/24 soit 11000000. 10101000. 00000000.00000000/24
Subnet 2 : 192.168.1.0/24 soit 11000000. 10101000. 00000001.00000000/24
Subnet 3 : 192.168.2.0/24 soit 11000000. 10101000. 00000010.00000000/24
Subnet 4 : 192.168.3.0/24 soit 11000000. 10101000. 00000011.00000000/24

Y a-t-il quelque chose de commun à ces quatre sous-réseaux ? Rien ? Vous en êtes sûrs ?
Nous allons vous faciliter la tâche.
Subnet 1 : 11000000.10101000.00000000.00000000
Subnet 2 : 11000000.10101000.00000001.00000000
192.168.0.0 /22
Subnet 3 : 11000000.10101000.00000010.00000000
Subnet 4 : 11000000.10101000.00000011.00000000

22
Borhen Eddine ZORGUI

Stub router
Un routeur d'impasse ou stub router est un routeur “feuille” : c'est un routeur ne connait que
ses réseaux connected et apprend tout le reste par EIGRP. Ainsi il ne sert à rien de l'interroger
pour tout réseau qui ne lui appartient pas. On le déclare comme stub router afin que les autres
routeurs ne le sollicitent pas quand ils perdent une route, ce qui optimise les flux de routage.
Un routeur stub peut respectivement, juste [recevoir des routes | annoncer ses
routes connected | annoncer ses routes statiques | annoncer ses routes agrégée]

(config-router)#eigrp stub [receive-only | connected | static | summary]

passive-interface

Vous pouvez utiliser la commande passive-interface afin de contrôler la publicité des


informations de routage. La commande permet la suppression des mises à jour de routage sur
certaines interfaces tout en permettant les mises à jour doivent être échangées normalement
sur d'autres interfaces. la commande passive-interface dans EIGRP supprime l'échange de
paquets hello entre deux routeurs, ce qui entraîne la perte de leur relation de voisinage. Cela
empêche non seulement les mises à jour de routage d'être annoncé, mais il supprime
également entrants mises à jour de routage

R1#debug eigrp packet hello


EIGRP Packets debugging is on
(HELLO)
R1#
Nov 20 08:07:33.131: EIGRP: Sending HELLO on Serial0
Nov 20 08:07:33.135: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ
un/rely 0/0
Nov 20 08:07:35.327: EIGRP: Received HELLO on Serial0 nbr
192.168.1.1
Nov 20 08:07:35.331: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ
un/rely 0/0 peerQ un/rely 0/0

R1#show ip eigrp neighbors


IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO
Q Seq Type
(sec) (ms)
Cnt Num
0 192.168.1.1 Se0 13 00:24:47 1 3000
0 1

23
Borhen Eddine ZORGUI

R1(config)#router eigrp 1
R1(config-router)#passive-interface serial 0

R1# debug eigrp packet hello


EIGRP Packets debugging is on
(HELLO
R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
Cette commande utilisée généralement sur l’interface ethernet pour désactivée l’échange
de paquet HELLO (ospf ou eigrp) pour diminué la taille de table de routage.

Appliquée la liste ACL sur interface


Lorsque la commande passive-interface est utilisée dans EIGRP, le routeur ne peut pas former
des contiguïtés de voisinage de l'interface, ou d'envoyer ou de recevoir des mises à jour de
routage. Mais, si vous voulez que les mises à jour de routage sortant seul être supprimées,
mais les mises à jour entrants continuent d'être reçues (et les routeurs continuent à être des
voisins), puis utilisez la commande distribuer-liste.
R1(config)#access-list 20 deny any

R1(config)#router eigrp 1
R1(config-router)#no passive-interface serial 0
R1(config-router)#distribute-list 20 out serial 0

Distance administrative
La distance administrative détermine la priorité d'une route annoncée par un protocole par
rapport aux autres protocoles. C'est un coefficient de confiance attribué à une source (interne,
externe à l'AS). On peut la voir dans un show ip route de la forme [90/45003] : 90 désigne la
distance administrative et 45003 la métrique. Par défaut les routes EIGRP internes ont une
distance administrative de 90 et les routes EIGRP externes de 170.
On peut le modifier par la commande :
(config-router)#distance eigrp <distance_interne> <distance_externe>

24
Borhen Eddine ZORGUI

Bande passente en %

Notez que le paramètre bandwidth (exprimée en Kbps) ne joue pas sur la bande passante
réelle du lien, il influe uniquement le calcul de la métrique (car par défaut en EIGRP un lien
série est considéré comme ayant une bande passante de T1, soit 1,5Mbps). Par
défaut EIGRP ne dépasse pas 50% de la bande passante pour tourner, mais cela peut se
configurer par interface (ici pour l'AS 1 on passe à 30% max)

R1 (config-if)#ip bandwidth-percent eigrp 1 30

Debug

#debug eigrp neighbors


#debug eigrp packets

Eavesdropping on EIGRP Neighbors

Désactiver tous les messages de debug:

Router#undebug all
All possible debugging has been turned off
Debuger quand une route vient de tomber :
Router#debug eigrp packets query reply
EIGRP Packets debugging is on
(QUERY, REPLY)

25
Borhen Eddine ZORGUI

4.4. Routage OSPF (Routage à état des liens)

Principe

 Chaque nœud
 évalue le coût pour joindre ses voisins selon une certaine métrique (plusieurs
métriques peuvent être utilisées simultanément)
 construit un paquet contenant les infos relatives à chacun de ses liens (voisins)
 le diffuse à tout le monde (par inondation)
 calcule la route de moindre coût pour atteindre chaque entité du réseau
 ensuite, les routeurs s'échangent uniquement les changements détectés dans la topologie
 chaque nœud a une vision globale de la cartographie du réseau

OSPF -Aires

 Le routage est hiérarchisé pour


 limiter la diffusion (inondation)
 réduire le temps de calcul des routes ( Dijkstra)
 Un AS est divisé en aires (area) ou zones
 une aire ne connaît que l'état des liaisons internes à l'aire
 deux niveaux de routage : intra-area et inter-area
 chaque aire est identifiée par un numéro sur 32 bits
 Ne pas confondre AS et aires
 AS : un ou plusieurs réseaux sous une même autorité ; deux AS peuvent utiliser un
protocole interne différent
 Aire : toutes les aires OSPF utilisent le protocole OSPF

OSPF –Hiérarchie des aires

 Un AS contient une aire "épine dorsale" ou fédératrice (la zone 0.0.0.0) qui assure
l'acheminement entre les autres aires

 Toutes les autres aires sont reliées à la zone backbonepar au moins un routeur

 Chaque routeur qui est relié à deux zones ou plus fait partie de l'épine dorsale

26
Borhen Eddine ZORGUI

 Trois catégories de routeurs

 routeurs internes à une zone (50 max par zone)


 routeurs fédérateurs ou inter-zones qui connectent au moins deux zones
 routeurs inter-AS (routeurs de bordure) qui échangent les informations de
routage entre les AS (BGP)

BGP

 Dans chaque zone, découverte de la topologie de la zone et calcul des plus courts chemins

 Les routeurs fédérateurs reçoivent les informations locales à leurs zones pour calculer la
meilleure route pour atteindre chaque routeur de l'AS

 Cette information est ensuite communiquée à tous les routeurs inter-zones qui la
répercutent au sein de leurs zones

 Si les réseaux et sous-réseaux d'une zone ont des adresses IP contiguës, le routeur
inter-zones ne signale qu'une seule route par agrégation

27
Borhen Eddine ZORGUI

Les types des réseaux ospf

Les routeurs OSPF déterminent avec quel routeur ils doivent devenir adjacents en fonction du
type de réseau auquel ils sont connectés.

ATM

Les interfaces OSPF reconnaissent automatiquement trois types de réseaux :

 les réseaux à accès multiple avec diffusion, comme Ethernet.


 le réseau point à point.
 les réseaux à accès multiple sans diffusion (Nonbroadcast multi-access - NBMA).
 point à multipoint, peut être configuré manuellement sur une interface par un
administrateur

28
Borhen Eddine ZORGUI

Système autonome (AS)

Un système autonome est constitué de routeurs pilotés par un ou plusieurs opérateurs, qui
présentent une vue cohérente du routage vers l'extérieur. Le NIC (Network Information
Center) attribue aux entreprises un numéro de système autonome unique. Ce numéro est un
nombre à 16 bits. Un protocole de routage, tel que le protocole IGRP de Cisco, exige que
vous indiquiez ce numéro unique dans votre configuration.

29
Borhen Eddine ZORGUI

Configuration de routage ospf

Objectif
• Configurer un système d’adressage IP pour la zone OSPF 0.
• Configurer et vérifier le routage OSPF (Open Shortest Path First).

Étape 1 – Configurez les routeurs


Sur les routeurs, passez en mode de configuration globale et configurez le nom d’hôte comme
indiqué dans le tableau. Configurez ensuite la console, le terminal virtuel et les mots de passe
enable. Ensuite, configurez les interfaces conformément au tableau. Pour terminer, configurez
les noms d’hôte IP. Ne configurez le protocole de routage que lorsque vous y êtes invité. Si
vous rencontrez des difficultés à configurer les paramètres de base du routeur, reportez-vous
au TP précédent intitulé «Révision de la configuration de base des routeurs avec le protocole
RIP».
Routeur 1
Router>enable
Router#configure terminal
Router(config)#hostname BERLIN
BERLIN(config)#enable secret class
BERLIN(config)#line console 0
BERLIN(config-line)#password cisco
BERLIN(config-line)#login
BERLIN(config-line)#line vty 0 4
BERLIN(config-line)#password cisco
BERLIN(config-line)#login

30
Borhen Eddine ZORGUI

BERLIN(config-line)#exit
BERLIN(config)#interface serial 0
BERLIN(config-if)#ip address 192.168.15.1 255.255.255.252
BERLIN(config-if)#clock rate 64000
BERLIN(config-if)#no shutdown
BERLIN(config-if)#exit
BERLIN(config)#interface ethernet 0
BERLIN(config-if)#ip address 192.168.1.129 255.255.255.192
BERLIN(config-if)#no shutdown
BERLIN(config-if)#exit
BERLIN(config)#ip host ROME 192.168.0.1 192.168.15.2
Routeur 2
Router>enable
Router#configure terminal
Router(config)#hostname ROME
ROME(config)#enable secret class
ROME(config)#line console 0
ROME(config-line)#password cisco
ROME(config-line)#login
ROME(config-line)#line vty 0 4
ROME(config-line)#password cisco
ROME(config-line)#login
ROME(config-line)#exit
ROME(config)#interface serial 0
ROME(config-if)#ip address 192.168.15.2 255.255.255.252
ROME(config-if)#no shutdown
ROME(config-if)#exit
ROME(config)#interface ethernet 0
ROME(config-if)#ip address 192.168.0.1 255.255.255.0
ROME(config-if)#no shutdown
ROME(config-if)#exit
ROME(config)#ip host BERLIN 192.168.1.129 192.168.15.1

Étape 2 – Enregistrez les informations de configuration en mode privilégié


Berlin#copy running-config startup-config

 À l’invite du mode privilégié, tapez:


Berlin#show running-config
 À l’aide de la commande show ip interface brief, vérifiez l’état de chaque interface.

Étape 3 – Configurez le routage OSPF sur le routeur Berlin


 Configurez un processus de routage OSPF sur le routeur Berlin. Utilisez le processus
OSPF numéro 1 et assurez-vous que tous les réseaux se trouvent dans la zone 0.
Berlin(config)#router ospf 1
Berlin(config-router)#network 192.168.1.128 0.0.0.63 area 0
Berlin(config-router)#network 192.168.15.0 0.0.0.3 area 0
Berlin(config-router)#end

31
Borhen Eddine ZORGUI

 Examinez les fichiers de configuration courante des routeurs.


 Est-ce que la version IOS a ajouté automatiquement des lignes sous router OSPF 1 ? Oui
 Si oui, qu’a-t-il ajouté ? log-adjacency-changes
 Si des modifications ont été apportées à la configuration courante, tapez les commandes
suivantes :
Berlin(config)#router ospf 1
Berlin(config-router)#log-adjacency-changes
Berlin(config-router)#end
 Affichez la table de routage du routeur Berlin.
Berlin#show ip route
 La table de routage contient-elle des entrées ? Non
 Pourquoi ? OSPF n'est pas configuré sur Rome.

Étape 4 – Configurez le routage OSPF sur le routeur Rome


 Configurez un processus de routage OSPF sur chaque routeur Rome. Utilisez le processus
OSPF numéro 1 et assurez-vous que tous les réseaux se trouvent dans la zone 0.

Rome(config)#router ospf 1
Rome(config-router)#network 192.168.0.0 0.0.0.255 area 0
Rome(config-router)#network 192.168.15.0 0.0.0.3 area 0
Rome(config-router)#end

 Examinez les fichiers de configuration courante de Rome.


 Est-ce que la version IOS a ajouté automatiquement des lignes sous router OSPF 1 ? Oui
 Si oui, qu’a-t-il ajouté ? log-adjacency-changes
 Si des modifications ont été apportées à la configuration courante, tapez les commandes
suivantes :
Rome(config)#router ospf 2
Rome(config-router)#log-adjacency-changes
Rome(config-router)#end

 Affichez la table de routage du routeur Rome :


Rome#show ip route
 La table de routage contient-elle des entrées OSPF ? Oui
 Quelle est la valeur métrique de la route OSPF ? Elle varie ; celle par défaut lorsque la
bande passante d'interface série est paramétrée sur 128 Kbits/s donne comme valeur 782.
 Quelle est l’adresse VIA de la route OSPF ? 192.168.15.1
 Les routes vers tous les réseaux figurent-elles dans la table de routage ? Oui
 Que signifie la lettre O de la première colonne de la table de routage ? La route a été
acquise par OSPF.

32
Borhen Eddine ZORGUI

Id de routeur OSPF
L’ID de routeur OSPF permet d’identifier chaque routeur de façon unique dans le domaine de
routage OSPF. Un ID de routeur est tout simplement une adresse IP. Les routeurs Cisco
définissent leur ID de routeur en utilisant trois critères, selon la priorité ci-dessous :
1. Utilisation de l’adresse IP configurée avec la commande router-id du protocole OSPF.
2. Si router-id n’est pas configuré, le routeur choisit l’adresse IP la plus élevée parmi ses
interfaces loopback (quelle participe à OSPF ou non).
3. Si aucune interface loopback n’est configurée, le routeur choisit l’adresse IP la plus
élevée parmi ses interfaces physiques actives (quelle participe à OSPF ou non).
a) Adresse IP active la plus élevée
Si un routeur OSPF n’est pas configuré à l’aide d’une commande router-id OSPF et
qu’aucune interface loopback n’est configurée, l’ID de routeur OSPF correspondra à l’adresse
IP d’interface active la plus élevée.
L’interface n’a pas à être configurée pour OSPF, ce qui signifie qu’elle n’a pas à être incluse
à l’une des commandes network. Cependant l’interface doit être activée (elle doit être à l’état
up). En utilisant les critères décrits ci dessus, pouvez-vous déterminer les ID des routeurs R1,
R2 et R3 :

Comme nous n’avons pas configuré d’ID de routeur ou d’interface loopback sur nos trois
routeurs, l’ID de chacun des routeurs est déterminé par le critère numéro 3 de la liste :
l’adresse IP active la plus élevée des interfaces physiques du routeur. Comme indiqué dans le
schéma, l’ID de routeur de chacun des routeurs est :
 R1 : 192.168.10.5, supérieur à 172.16.1.17 ou 192.168.10.1
 R2 : 192.168.10.9, supérieur à 10.10.10.1 ou 192.168.10.2
 R3 : 192.168.10.10, supérieur à 172.16.1.33 ou 192.168.10.6
Pour vérifier l’ID de routeur en cours, vous pouvez utiliser la commande show ip protocols.
Certaines versions d’IOS n’affichent pas l’ID de routeur comme indiqué sur le schéma. Dans
ce cas, utilisez la commande show ip ospf ou la commande show ip ospf interface pour
vérifier l’ID de routeur.

33
Borhen Eddine ZORGUI

b) Configurez les interfaces en mode bouclé (loopback)


Si la commande router-id OSPF n’est pas utilisée et que vous avez configuré des
interfaces loopback, OSPF choisit l’adresse IP d’interface loopback la plus élevée.
Une adresse de loopback est une interface virtuelle et est automatiquement à l’état up
lorsqu’elle est configurée. Vous connaissez déjà les commandes pour configurer une interface
de bouclage :
Router (config)#interface loopback number
Router (config-if)#ip address adresse IP masque de sous-réseau

 Dans cette topologie, les trois routeurs ont été configurés avec des adresses de bouclage
afin de représenter les ID de routeur OSPF.
 L’avantage d’une interface loopback est que, contrairement aux interfaces physiques, elle
ne peut pas tomber en panne. Pour être à l’état up, l’interface loopback ne dépend pas de
câbles réels ou d’un périphérique contigu.
 Son utilisation pour déterminer l’ID de routeur offre au processus OSPF de la stabilité.
 La commande OSPF router-id, présentée ci-dessous, étant une nouveauté dans IOS, il est
plus courant d’utiliser des adresses de loopback pour la configuration des ID de routeur
OSPF.

34
Borhen Eddine ZORGUI

 Dans le router R1

R1(config)#interface loopback 0
R1(config-if)#ip address 10.1.1.1 255.255.255.255
R1(config-router)#end
 Dans le router R2
R2(config)#interface loopback 0
R2(config-if)#ip address 10.2.2.2 255.255.255.255
R2(config-router)#end
 Dans le router R3
R2(config)#interface loopback 0
R2(config-if)#ip address 10.3.3.3 255.255.255.255
R2(config-router)#end

c) Commande router-id OSPF


La commande router-id du protocole OSPF a été ajoutée à IOS dans la version 12.0(T) ; elle
remplace les adresses de bouclage et les adresses IP d’interface physique pour la
détermination des ID de routeur. La syntaxe de commande est la suivante :
Router(config)#router ospf process-id
Router(config-router)#router-id ip-address
Router#clear ip ospf process

Modification de l’ID de routeur :


 L’ID de routeur est sélectionné lors de la configuration du protocole OSPF avec la
première commande OSPF network.
 Si la commande OSPF router-id ou l’adresse de bouclage est configurée après la
commande OSPF network, l’ID de routeur est dérivé de l’interface dotée de l’adresse IP
active la plus élevée.
 L’ID de routeur peut être modifié en définissant une autre adresse IP au moyen de la
commande router-id OSPF ; il suffit ensuite de redémarrer le routeur ou d’utiliser la
commande suivante :
Router#clear ip ospf process
d) ID de routeur double :
 Lorsque deux routeurs portent le même ID dans un domaine OSPF, le routage risque de ne
pas fonctionner correctement. Si l’ID de routeur est le même sur deux routeurs _ de
voisinage, la reconnaissance du voisin peut ne pas fonctionner.
 Lorsque des doublons sont détectés au niveau des ID de routeur OSPF, IOS affiche un
message de type :
 %OSPF-4-DUP_RTRID1: Detected router with duplicate router ID
 Pour corriger ce problème, configurez tous les routeurs de manière à ce qu’ils aient un ID
OSPF unique.
 Certaines versions d’IOS ne prenant pas en charge la commande router-id, nous
utiliserons l’adresse loopback pour la définition des ID de routeur. En général, l’adresse IP

35
Borhen Eddine ZORGUI

d’une interface loopback remplace un ID de routeur OSPF simplement en redémarrant le


routeur._
 Dans le schéma, les routeurs ont été redémarrés. La commande show ip protocols permet
de vérifier que chaque routeur utilise bien l’adresse loopback comme ID de routeur.

The show ip ospf neighbor Command


Le show ip ospf neighbor commande est super utile, car elle résume l'information pertinente
au sujet des voisins OSPF et l'état de contiguïté. Si un DR ou BDR existe, cette information
sera également affichée. Voici un exemple:

Utilisation de la commande show ip ospf neighbors pour vérifier que les IDs de routeur ont
été modifiés

The show ip protocols Command


La commande show ip protocols est également utile si vous utilisez OSPF, EIGRP, IGRP,
RIP, BGP, IS-IS, ou tout autre protocole de routage qui peut être configuré sur votre routeur.
Il donne un excellent aperçu du fonctionnement réel de tous les protocoles en cours
d'exécution. Vérifier la sortie du routeur Lab_A:

36
Borhen Eddine ZORGUI

Vérifier la configuration OSPF

 show ip ospf
 show ip ospf database
 show ip ospf interface
 show ip ospf neighbor
 show ip protocols
 show ip route

Configurez London pour qu’il soit toujours le routeur désigné


Utilisation de la commande d’interface ip ospf priority pour paramétrer la priorité ospf de R1
sur 255. Il s’agit de la priorité la plus élevée possible
Berlin(config)#interface Fastethernet 0/0
Berlin(config-if)#ip ospf priority <0-255>
Berlin(config-if)#end

37
Borhen Eddine ZORGUI

Configuration du coût ospf


1) Bande passante de référence
Par défaut, la bande passante de référence est de 10 à la puissance 8, soit 100 000 000
bits/s ou 100 Mbits/s.
Résultat : des interfaces ayant une bande passante de 100 Mb/s et plus ont un même coût
OSPF de 1.
La bande passante de référence peut être modifiée pour s’adapter aux réseaux ayant des
liaisons d’une rapidité supérieure à 100 000 000 bits/s (100 Mbits/s) à l’aide de la
commande OSPF auto-cost reference-bandwidth.
Lorsque l’exécution de cette commande est nécessaire, il est conseillé de l’utiliser sur
tous les routeurs, afin que la métrique de routage OSPF reste cohérente.
𝐚𝐮𝐭𝐨 − 𝐜𝐨𝐬𝐭 𝐫𝐞𝐟𝐞𝐫𝐞𝐧𝐜𝐞 − 𝐛𝐚𝐧𝐝𝐰𝐢𝐝𝐭𝐡
𝐶𝑜𝑠𝑡: =
𝐛𝐚𝐧𝐝𝐰𝐢𝐝𝐭𝐡
 Utilisation de la commande bandwidth pour modifier la bande passante des interfaces
série de R1 et R2 sur la valeur réelle, soit 64Kbits/s

R1(config)#interface serial0/0/0
R1(config-if)#bandwidth 64
R1(config-if)#exit
R1(config)#interface serial0/0/1
R1(config-if)#bandwidth 64

 Utilisation de la commande show ip ospf interface sur R1 pour vérifier le coût des liaisons
série

R1#show ip ospf interface


Serial0/0/0 is up, line protocol is up
Internet address is 192.168.10.1/30, Area 0
Process ID 1, Router ID 10.1.1.1, Network Type POINT-TO-POINT, Cost: 1562
Transmit Delay is 1 sec, State POINT-TO-POINT,

 Utilisation de la commande ip ospf cost sur R1 pour vérifier le coût des liaisons série

Nous utilisons la commande ip ospf cost qui permet de configurer directement le coût. Nous
utilisons la commande ip ospf cost pour définir la bande passante des interfaces séries du
routeur R3 sur 1562.

R3(config)#interface serial0/0/0
R3(config-if)#ip ospf cost 1562
R3(config-if)#exit
R3(config)#interface serial0/0/1
R3(config-if)#ip ospf cost 1562

38
Borhen Eddine ZORGUI

 Utilisation de la commande show ip ospf interface sur R1 pour vérifier le coût des liaisons
série

R3#show ip ospf interface


Serial0/0/1 is up, line protocol is up
Internet address is 192.168.10.10/30, Area 0
Process ID 1, Router ID 10.3.3.3, Network Type POINT-TO-POINT, Cost: 1562

2) Configuration de fonctions ospf supplémentaires


 Utilisation de la commande auto-cost reference-bandwidth pour définir la valeur de
la bande passante de référence

Nous augmentons la bande passante de référence à 10 000 pour simuler des vitesses de 10
GigE. Ensuite nous configurons cette commande sur tous les routeurs dans le domaine de
routage OSPF.
R1(config)#router ospf 1
R1(config-router)#auto-cost reference-bandwidth 10000

Assurez-vous que la bande passante de référence est la même sur tous les routeurs.

𝐚𝐮𝐭𝐨−𝐜𝐨𝐬𝐭 𝐫𝐞𝐟𝐞𝐫𝐞𝐧𝐜𝐞−𝐛𝐚𝐧𝐝𝐰𝐢𝐝𝐭𝐡
𝐶𝑜𝑠𝑡: =
𝐛𝐚𝐧𝐝𝐰𝐢𝐝𝐭𝐡

39
Borhen Eddine ZORGUI

Redistribution d’une route ospf par défaut


 Configuration d’une adresse de bouclage sur R1 pour simuler une liaison avec un
FAI

Toutefois, dans la terminologie OSPF, le routeur situé entre un domaine de routage OSPF et
un réseau non-OSPF est appelé routeur ASBR (Autonomous System Boundary Router,
routeur de périphérie de système autonome).
Dans cette topologie, Lo1 représente une liaison vers un réseau non-OSPF. Nous ne
configurerons pas le réseau 172.30.1.1/30 dans le cadre du processus de routage OSPF.
Remarque : la route statique par défaut utilise la loopback en tant qu’interface de sortie parce
que le routeur ISP de la topologie n’existe pas physiquement. En utilisant une interface de
loopback, nous pouvons simuler une connexion vers un autre routeur.
R1(config)#interface loopback1
R1(config-if)#ip address 172.30.1.1 255.255.255.252

 Configuration d’une route statique par défaut sur R1

Nous utilisons l’adresse de bouclage configurée pour simuler une liaison avec un FAI comme
interface de sortie.
R1(config)#ip route 0.0.0.0 0.0.0.0 loopback1
R1(config)#

 Utilisation de la commande default-information originate pour inclure la route statique


dans les mises à jour ospf envoyés depuis R1

R1(config)#router ospf 1
R1(config-router)#default-information originate
40
Borhen Eddine ZORGUI

R1(config-router)#

 Consultation de la table de routage de R2 pou vérifier que la route statique par défaut est
redistribuée via ospf

R2#show ip route

Configuration des interfaces HELLO et d’arrêt ospf


Tâche 1- Utilisation de la commande show ip ospf neighbors sur R1 pour afficher le
compteur d’arrêt
Le compteur d’arrêt déclenche un compte à rebours à partir de l’intervalle par défaut de 40
secondes.

R1#show ip ospf neighbor


Neighbor ID Pri State Dead Time Address
Interface
10.2.2.2 0 FULL/- 00:00:34 192.168.10.2
Serial0/0/0
10.3.3.3 0 FULL/- 00:00:34 192.168.10.6
Serial0/0/1

Tâche 2 - Configuration des interfaces HELLO et d’arrêt ospf


Les intervalles Hello et d’arrêt OSPF peuvent être modifiés manuellement à l’aide des
commandes d’interface ip ospf hello-interval et ip ospf dead-interval.
Nous modifions l’intervalle Hello sur 5 secondes et l’intervalle d’arrêt sur 20 secondes sur
l’interface Serial0/0/0 du routeur R1.

R1(config)#interface serial0/0/0
R1(config-if)#ip ospf hello-interval 5
R1(config-if)#ip ospf dead-interval 20

Utilisation de la commande show ip ospf interface serial0/0/0 pour vérifier que les
interfaces des compteurs Hello et d’arrêt ont été modifiées

41
Borhen Eddine ZORGUI

Configuration du protocole OSPF sur un réseau à accès multiple

Diffusion des LSA :


 Dans le chapitre 10, « Protocoles de routage à état de liens », nous avons vu que les
routeurs à état de liens diffusent leurs paquets à état de liens lorsqu’OSPF est initialisé ou
qu’une modification de topologie intervient.
 Dans le cadre d’un réseau à accès multiple, cette diffusion peut devenir excessive. Dans
l’animation, R2 envoie une LSA. Cet événement déclenche chez tous les routeurs l’envoi
d’une LSA. L’animation ne montre pas les reçus renvoyés pour chaque LSA reçue. Si
chaque routeur d’un réseau à accès multiple devait envoyer une LSA, puis accuser
réception de toutes les LSA qu’il a reçues pour tous les routeurs de ce réseau à accès
multiple, le trafic réseau deviendrait chaotique.
 Pour illustrer ce propos, imaginez que vous vous trouvez dans une pièce avec un grand
nombre de personnes. Que se passerait-il si chacun devait se présenter lui-même à tous les
autres ? Non seulement chacune des personnes devrait dire son nom à tout le monde, mais,
à chaque fois qu’elle apprendrait un nom, chaque personne devrait en informer les autres,
individuellement. Comme vous pouvez le voir, cela entraînerait un chaos total !

Il existe une solution : le routeur désigné (DR)


 La solution pour gérer le nombre de contiguïtés et la diffusion des LSA sur un réseau à
accès multiple est le routeur désigné (DR). Pour poursuivre avec notre exemple, cette
solution revient à choisir une personne dans la pièce pour circuler et apprendre le nom de
chacune des personnes, et de les annoncer par la suite immédiatement à toutes les
personnes présentes dans la salle.
 Dans les réseaux à accès multiple, OSPF sélectionne un routeur désigné (Designated
Router - DR) comme point de collecte et de distribution des LSA envoyées et reçues. Un

42
Borhen Eddine ZORGUI

routeur désigné de sauvegarde (Backup Designated Router - BDR) est également choisi en
cas de défaillance du routeur désigné.
 Tous les autres routeurs deviennent des DROthers (ce qui signifie qu’ils ne sont ni DR, ni
BDR).

 Les routeurs d’un réseau à accès multiple choisissent un DR et un BDR.


 Les DROthers constituent des contiguïtés avec le DR et le BDR du réseau.
 Cela signifie qu’au lieu de diffuser les LSA à l’ensemble des routeurs du réseau, les
DROthers envoient leurs LSA uniquement au DR et au BDR en utilisant l’adresse
multidiffusion de 224.0.0.6 (ALLDRouters - tous les routeurs DR).
 Dans l’animation, R1 envoie des LSA au DR. Le BDR est lui aussi à l’écoute. Le DR est
chargé de transmettre les LSA depuis R1 vers les autres routeurs. Il utilise l’adresse
multidiffusion 224.0.0.5 (AllSPFRouters -tous les routeurs OSPF). Au final, un seul
routeur assure la diffusion de l’ensemble des LSA dans le réseau à accès multiple.

Modification de topologie :

43
Borhen Eddine ZORGUI

 Les sélections de DR/BDR n’ont pas lieu dans les réseaux point à point.
 Donc, dans une topologie standard à trois routeurs, R1, R2 et R3, il n’y a pas à choisir de
DR ou de BDR, car les liaisons existant entre ces routeurs ne sont pas des réseaux à accès
multiple.

 Pour le reste du sujet concernant le DR et le BDR, nous utiliserons la topologie à accès


multiple figurant dans le schéma.
 Les noms des routeurs sont différents, simplement pour souligner le fait que cette
topologie n’est pas la même que celle que nous avons utilisée jusqu’ici.
 Nous reviendrons à la topologie du chapitre après avoir traité le sujet du processus de
sélection du routeur désigné et du routeur désigné de secours.
 Dans cette nouvelle topologie, nous avons trois routeurs qui partagent un réseau à accès
multiple Ethernet, 192.168.1.0/24. Chacun des routeurs est configuré avec une adresse IP
sur l’interface Fast Ethernet et une adresse de loopback pour l’ID de routeur.

Sélection du DR/BDR :
 Comment le routeur désigné et le routeur désigné de sauvegarde sont-ils sélectionnés ?
Les critères suivants sont appliqués :
1. DR : Il s’agit du routeur dont la priorité d’interface OSPF est la plus élevée.
2. BDR : Il s’agit du routeur dont la priorité d’interface OSPF est la seconde valeur
la plus élevée.
3. Si les priorités d’interface OSPF sont identiques, l’ID de routeur le plus élevé
prévaut.
 Dans cet exemple, la priorité d’interface OSPF par défaut est 1. Résultat : selon les
critères de sélection énoncés plus haut, c’est l’ID de routeur OSPF qui est utilisé pour
sélectionner le DR et le BDR.

44
Borhen Eddine ZORGUI

 Comme vous le voyez, RouterC devient DR et RouterB, qui a le second ID de routeur le


plus élevé devient le BDR.


 RouterA, n’étant sélectionné ni comme DR, ni comme BDR, devient DROther.
 Un DROther ne constitue des contiguïtés FULL (complètes) qu’avec le DR et le BDR,
mais continue de fournir des contiguïtés de voisinage avec tous les DROthers qui
rejoignent le réseau.
 Cela signifie que tous les routeurs DROther du réseau à accès multiple continueront de
recevoir des paquets Hello de tous les autres routeurs DROther.
 Ainsi, ils connaissent les autres routeurs du réseau. Lorsque deux routeurs DROther
constituent une contiguïté de voisinage, l’état du voisin est 2WAY. Les différents états de
voisinage sont traités dans le cours CCNP.
 La sortie de commande du schéma affiche la contiguïté de voisinage de chaque routeur du
réseau à accès multiple. Notez que, pour RouterA, il affiche que le DR est RouterC, qui
porte l’ID de routeur 192.168.31.33 et que le BDR est RouterB, avec l’ID de routeur
192.168.31.22.

45
Borhen Eddine ZORGUI

 RouterA affiche ses deux voisins comme étant le DR et le BDR, lui-même est un
DROther.
 Vous pouvez le vérifier en utilisant la commande show ip ospf interface fastethernet 0/0
sur le routeur RouterA, comme indiqué dans le schéma.
 Cette commande affichera les états DR, BDR ou DROTHER de ce routeur, ainsi que l’ID
de routeur du DR et du BDR sur ce réseau à accès multiple.

Synchronisation de la sélection DR/BDR :


 Le processus de sélection du DR et du BDR a lieu aussitôt que le premier routeur ayant
une interface configurée OSPF est activé sur un réseau à accès multiple. Cet événement
peut se produire lorsque les routeurs sont mis sous tension ou lorsqu’une commande
network OSPF est configurée pour cette interface.
 Le processus de sélection ne prend que quelques secondes. Si l’amorçage de tous les
routeurs du réseau à accès multiple n’est pas terminé, il se peut qu’un routeur dont l’ID
n’est pas le plus élevé devienne le DR. Cela peut signifier que son amorçage a pris moins
de temps.
 Une fois le DR sélectionné, il le reste jusqu’à ce que l’une des situations suivantes se
produise :
 le DR tombe en panne ;
 le processus OSPF sur le DR échoue ;
 l’interface à accès multiple du DR ne fonctionne plus.

46
Borhen Eddine ZORGUI

Panne DR :

 Si le DR ne fonctionne pas correctement, le routeur désigné de secours prend le relais et


un nouveau routeur désigné de secours est choisi.
 Dans le schéma, RouterC s’arrête et le précédent BDR, RouterB, devient DR. Le seul
autre routeur disponible pour devenir BDR est RouterA.

Nouveau routeur :

 RouterD rejoint le réseau.


 Si un nouveau routeur entre dans le réseau une fois que le DR et le BDR ont été
sélectionnés, il ne devient pas DR ou BDR, même si sa priorité d’interface OSPF ou son
ID de routeur est plus élevé que ceux du DR ou du BDR courants.
 Il peut être sélectionné comme BDR si le DR ou le BDR en cours s’arrêtent. En cas de
défaillance du DR actuel, le BDR devient DR, et le nouveau routeur est sélectionné
comme nouveau BDR. Une fois que le nouveau routeur est devenu BDR, en cas de
défaillance du DR, il devient DR à son tour. Avant que le nouveau routeur puisse être
sélectionné comme DR et BDR, il faut que les DR et BDR courants soient tous les deux
hors service.

47
Borhen Eddine ZORGUI

Retour ancien DR :

Un ancien DR ne récupère pas le statut de DR s’il revient sur le réseau. Dans le schéma,
RouterC a terminé un réamorçage, et devient DROther même si son ID de routeur,
192.168.31.33, est plus élevé que celui du DR et du BDR en cours.

Panne BDR :

 Si le BDR s’arrête, _ une sélection s’opère parmi les DRothers pour voir lequel va devenir
le nouveau BDR.
 Dans le schéma, le routeur BDR a une défaillance.
 Une sélection s’opère entre RouterC et RouterD.
 RouterD, ayant un ID de routeur plus élevé, est sélectionné.

48
Borhen Eddine ZORGUI

Panne nouveau DR :

 Dans le schéma, RouterB s’arrête.


 RouterD étant le BDR en cours, il devient DR.
 RouterC devient BDR.
 Comment pouvez-vous alors être sûr que ce sont les routeurs que vous avez choisis qui
deviendront respectivement DR et BDR ?
 Si vous ne voulez pas procéder à une nouvelle configuration, procédez comme suit :
 démarrez le DR en premier, puis le routeur désigné de secours, et démarrez ensuite
tous les autres routeurs ;
 ou arrêtez l’interface de tous les routeurs, exécutez une commande no shutdown sur le
DR, puis sur le BDR, puis sur tous les autres routeurs.
 Toutefois, comme vous l’avez peut-être déjà deviné, il est possible de changer la priorité
d’interface OSPF afin de mieux contrôler le choix du routeur désigné/routeur désigné de
secours.

Priorité d’interface OSPF


 Le DR devenant le point central pour la collecte et la distribution des LSA, il est important
qu’il dispose d’une puissance et d’une capacité mémoire suffisantes pour assumer cette
responsabilité. Au lieu d’utiliser uniquement l’ID du routeur pour décider quels routeurs
deviendront routeur désigné (DR) et routeur désigné de secours, il est préférable de
contrôler le choix de ces routeurs à l’aide de la commande d’interface ip ospf priority.
 Router(config-if)#ip ospf priority {0 - 255}
 Lors de notre discussion précédente, la priorité OSPF était identique, et ce, parce que la
valeur de priorité par défaut était de 1 pour toutes les interfaces de routeur.
 C’était donc l’ID de routeur qui déterminait le DR et le BDR. Mais si vous remplacez la
valeur par défaut, 1, par une valeur plus élevée, le routeur dont la priorité est la plus
élevée devient le DR, et celui qui a la seconde priorité devient le BDR.
 Lorsqu’elle est attribuée à un routeur, la valeur 0 empêche sa sélection en tant que DR ou
BDR.

49
Borhen Eddine ZORGUI

 Les priorités étant des valeurs d’interface spécifique, elles procurent un meilleur contrôle
sur les réseaux à accès multiple OSPF. Elles permettent également de faire en sorte qu’un
routeur soit DR dans un réseau et DROther dans un autre.
 Pour simplifier notre propos, nous avons retiré RouterD de la topologie. La priorité
d’interface OSPF peut être affichée à l’aide de la commande show ip ospf interface. Dans
le schéma, nous pouvons vérifier que la priorité du RouterA est définie sur 1, la valeur par
défaut.

 La figure indique les priorités d’interface OSPF du RouterA et du RouterB, modifiées de


manière à ce que le RouterA doté de la priorité la plus élevée devienne routeur désigné
(DR) et le RouterB devienne routeur désigné de secours.
 La priorité d’interface OSPF de RouterC reste à la valeur par défaut 1.
 Une fois que nous aurons exécuté des commandes shutdown et no shutdown sur les
interfaces FastEthernet 0/0 des trois routeurs, nous verrons le résultat du changement des
priorités d’interface OSPF. La commande show ip ospf neighbor du RouterC affiche à

50
Borhen Eddine ZORGUI

présent que le RouterA (ID de routeur 192.168.31.11) est DR, avec une priorité
d’interface OSPF maximum de 200, et que le RouterB (ID de routeur 192.168.31.22) est
toujours routeur désigné de sauvegarde, avec la priorité d’interface OSPF suivante de 100.
Remarquez que la commande show ip ospf neighbor du RouterA n’indique aucun DR, car
c’est le RouterA lui-même qui est DR de ce réseau.

 Une fois que nous aurons exécuté des commandes shutdown et no shutdown sur les
interfaces FastEthernet 0/0 des trois routeurs, nous verrons le résultat du changement des
priorités d’interface OSPF.
 La commande show ip ospf neighbor du RouterC affiche à présent que le RouterA (ID de
routeur 192.168.31.11) est DR, avec une priorité d’interface OSPF maximum de 200, et
que le RouterB (ID de routeur 192.168.31.22) est toujours routeur désigné de sauvegarde,
avec la priorité d’interface OSPF suivante de 100.
 Remarquez que la commande show ip ospf neighbor du RouterA n’indique aucun DR, car
c’est le RouterA lui-même qui est DR de ce réseau.
 Le cours online contient une simulation Packet Tracer pour étudier les rôles de routeur
désigné et de routeur désigné de sauvegarde actuels et leur modification, puis forcer un
changement de priorité pour les nouveaux rôles. A faire absolument.

51
Borhen Eddine ZORGUI

1) Diagramme de topologie

Table d’adressage

Nous configurons les interfaces Ethernet et de bouclage sur les routeurs R1, R2 et R3 avec les
adresses IP du tableau sous le diagramme de topologie. La commande show ip interface brief
permet de vérifier que l’adressage IP est correct. Lorsque nous avons terminé, nous
enregistrons la configuration en cours dans la mémoire vive non volatile du routeur.

R1#show ip interface brief


Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.1.1 YES manual up up
FastEthernet0/1 unassigned YES manual administratively down down Serial0/1/0 unassigned
YES manual administratively down down Serial0/1/1 unassigned YES manual
administratively down down Loopback1 192.168.31.11 YES manual up up
Vlan1 unassigned YES manual administratively down down
R1#

52
Borhen Eddine ZORGUI

R3(config)#router ospf 1
R3(config-router)#network 192.168.1.0 0.0.0.255 area 0
R3(config-router)#end

 Utilisation de la commande router ospf en mode de configuration globale pour


activer le protocole ospf sur R2
R2(config)#router ospf 1
R2(config-router)#network 192.168.1.0 0.0.0.255 area 0
R2(config-router)#end
Utilisation de la commande show ip ospf interface pour vérifier que le protocole ospf a été
correctement configuré et que R2 est le routeur désigné de sauvegarde
R2#show ip ospf interface

 Utilisation de la commande router ospf en mode de configuration globale pour


activer le protocole ospf sur R1
R1(config)#router ospf 1
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
R1(config-router)#end

R1#show ip ospf interface

 Utilisation de la commande show ip ospf neighbors pour afficher des informations


sur les autres routeurs dans la zone ospf
R3 est le routeur désigné (DR) et que R2 est le routeur désigné de sauvegarde (BDR).
R1#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
192.168.31.22 1 FULL/BDR 00:00:35 192.168.1.2
FastEthernet0/0
192.168.31.33 1 FULL/DR 00:00:30 192.168.1.3
FastEthernet0/0

53
Borhen Eddine ZORGUI

2) Utilisation de la priorité ospf pour déterminer le routeur désigné (DR) et le


routeur désigné de sauvegarde (BDR)
Etape 1 : Utilisation de la commande d’interface ip ospf priority pour paramétrer
la priorité ospf de R1 sur 255. Il s’agit de la priorité la plus élevée possible
R1(config)#interface fastEthernet0/0
R1(config-if)#ip ospf priority 255
R1(config-if)#end

Etape 2 : Utilisation de la commande d’interface ip ospf priority pour paramétrer


la priorité ospf de R1 sur 100
R3(config)#interface fastEthernet0/0
R3(config-if)#ip ospf priority 100
R3(config-if)#end

Etape 3 : Utilisation de la commande d’interface ip ospf priority pour paramétrer


la priorité ospf de R2 sur 0
Le routeur dont la priorité est de 0 ne peut pas participer à la sélection OSPF pour devenir
routeur désigné ou routeur désigné de sauvegarde.

R2(config)#interface fastEthernet0/0
R2(config-if)#ip ospf priority 0
R2(config-if)#end

Etape 4 : Arrêt et réactivation des interfaces FastEthernet0/0 pour forcer une


sélection ospf
Les interfaces FastEthernet0/0 de chaque routeur peuvent être arrêtées et ensuite réactivées
pour forcer une sélection OSPF. Arrêtez l’interface FastEthernet0/0 sur chacun des trois
routeurs.
Notons que lorsque les interfaces sont arrêtées, les contiguïtés OSPF sont perdues. Sur R1:

R1(config)#interface fastethernet0/0
R1(config-if)#shutdown
R1(config-if)#no shutdown

R2(config)#interface fastethernet0/0
R2(config-if)#shutdown
R2(config-if)#no shutdown

R3(config)#interface fastethernet0/0
R3(config-if)#shutdown
R3(config-if)#no shutdown

54
Borhen Eddine ZORGUI

Area-range

La commande Area-range est utilisée pour fournir un résumé au niveau du routeur de bordure
de zone (ABR). Si votre routeur a plus d'une zone OSPF, n'hésitez pas à utiliser la commande
large zone de résumer sur les limites de la zone. La clé pour comprendre comment cela
fonctionne est la direction. Vous résumer les routes d'une région à tous les autres domaines
configurés sur cet ABR.

Exemple 1

In Figure, Router B will summarize the four Area 1 routes into Area 0. This example
simulates four networks on Router B using loopback interfaces. These four networks will then
be summarized into the backbone using the area range com m and.

An ABR Can Summarize OSPF Router from a Non-zero Area into the Backbone on Area 0

55
Borhen Eddine ZORGUI

Router A
Interface loopback0
Ip address 1.1.1.1 255.255.255.255
!
Interface serial 0/1
Ip address 10.1.1.1 255.255.255.252
Clock rate 64000
!
Router ospf 1
Network 10.1.1.0 0.0.0.3 area 0
Router B
Interface loopbak0
Ip address 2.2.2.2 255.255.255.255
!
Interface loopback1
Ip address 156.26.32.1 255.255.255.240
!
Interface loopback2
Ip address 156.26.32.17 255.255.255.240
!
Interface loopback3
Ip address 156.26.32.33 255.255.255.240
!
Interface loopback4
Ip address 156.26.32.49 255.255.255.240
!
Interface serial 0
Ip address 10.1.1.2 255.255.255.252
!
Router ospf 1
Network 10.1.1.0 0.0.0.3 area 0
Network 156.26.32.0 0.0.0.63 area 1

Un masque de sous-réseau 26 bits est besoin d pour résumer le bouclage quatre adresses
annoncé par b routeur. Modifier la configuration sur routeur B afin de résumer les quatre
adresses de bouclage

Router B
Area 1 range 156.26.32.0 255.255.255.192
Network 10.1.1.0 0.0.0.3 area 0
Network 156.26.32.0 0.0.0.63 area 1

56
Borhen Eddine ZORGUI

Exemple 1.1

Router B
Area 0 range 156.26.32.0 255.255.255.192
Network 10.1.1.0 0.0.0.3 area 1
Network 156.26.32.0 0.0.0.63 area 0

Exemple 2

57
Borhen Eddine ZORGUI

Pour résumer la zone 1 dans la zone 0 épine dorsale, utilisez la commande suivante sous l'ID
de processus OSPF. Voici la configuration complète OSPF pour le Core (backbone) du
routeur:

Core#config t
Core(config)#router ospf 1
Core(config-router)#network 192.168.10.64 0.0.0.3 area 1
Core(config-router)#network 192.168.10.68 0.0.0.3 area 1
Core(config-router)#network 10.10.10.0 0.0.0.255 area 0
Core(config-router)#area 1 range 192.168.10.64 255.255.255.224

58
Borhen Eddine ZORGUI

Configuration de l'authentification OSPF

Objectif
 Configurer un système d’adressage IP pour une zone OSPF (Open Shortest Path First).
 Configurer et vérifier le routage OSPF.
 Instaurer l’authentification OSPF dans la zone.

Étape 1 – Configurez les routeurs


Sur les routeurs, passez en mode de configuration globale et configurez le nom d’hôte ainsi
que la console, le terminal virtuel et les mots de passe enable. Ensuite, configurez les
interfaces et les noms d’hôte IP en fonction du tableau. Ne configurez le protocole de routage
que lorsque vous y êtes invité. Si vous rencontrez des difficultés à configurer les paramètres
de base du routeur, reportez-vous au TP précédent intitulé «Révision de la configuration de
base des routeurs avec le protocole RIP».

Routeur 1
Router#configure terminal
Router(config)#hostname Dublin
Dublin(config)#enable secret class
Dublin(config)#line console 0
Dublin(config-line)#password cisco
Dublin(config-line)#login
Dublin(config-line)#line vty 0 4
Dublin(config-line)#password cisco
Dublin(config-line)#login
Dublin(config-line)#exit
Dublin(config)#interface loopback 0

59
Borhen Eddine ZORGUI

Dublin(config-if)#ip address 192.168.31.11 255.255.255.255


Dublin(config-if)#interface serial 0
Dublin(config-if)#ip address 192.168.1.1 255.255.255.252
Dublin(config-if)#clockrate 64000
Dublin(config-if)#no shutdown
Dublin(config-if)#interface ethernet 0
Dublin(config-if)#ip address 192.168.1.129 255.255.255.192
Dublin(config-if)#no shutdown
Dublin(config-if)#exit
Dublin(config)#ip host Washington 192.168.0.1 192.168.1.2
Dublin(config)#exit

Routeur 2
Router>enable
Router#configure terminal
Router(config)#hostname Washington
Washington(config)#enable secret class
Washington(config)#line console 0
Washington(config-line)#password cisco
Washington(config-line)#login
Washington(config-line)#line vty 0 4
Washington(config-line)#password cisco
Washington(config-line)#login
Washington(config-line)#exit
Washington(config)#interface loopback 0
Washington(config-if)#ip address 192.168.31.22 255.255.255.255
Washington(config-if)#interface serial 0
Washington(config-if)#ip address 192.168.1.2 255.255.255.252
Washington(config-if)#no shutdown
Washington(config-if)#interface ethernet 0
Washington(config-if)#ip address 192.168.0.1 255.255.255.0
Washington(config-if)#no shutdown
Washington(config-if)#exit
Washington(config)#ip host Dublin 192.168.1.129 192.168.1.1
Washington(config)#exit

Étape 2 – Enregistrez les informations de configuration en mode privilégié

Dublin#copy running-config startup-config


Destination filename [startup-config]? [Entrée]
Washington#copy running-config startup-config
Destination filename [startup-config]? [Entrée]

Étape 3 – Configurez les hôtes avec l'adresse IP, le masque de sous-réseau et la


passerelle par défaut appropriés

Host connected to router Dublin


IP Address: 92.168.1.130
Subnet mask: 255.255.255.192
Default gateway: 192.168.1.129

60
Borhen Eddine ZORGUI

Host connected to router Washington


IP Address: 192.168.0.2
Subnet mask: 255.255.255.0
Default gateway: 192.168.0.1

Étape 5 – Configurez le routage OSPF sur les deux routeurs

a) Configurez le routage OSPF sur chaque routeur. Utilisez le processus OSPF numéro 1 et
assurez-vous que tous les réseaux se trouvent dans la zone 0. Reportez-vous au TP intitulé
« Configuration des interfaces en mode bouclé » pour revoir la configuration du routage
OSPF si nécessaire.
Dublin(config)#router ospf 1
Dublin(config-router)#network 192.168.1.128 0.0.0.127 area 0
Dublin(config-router)#network 192.168.1.0 0.0.0.3 area 0
Dublin(config-router)#end
Washington(config)#router ospf 1
Washington(config-router)#network 192.168.0.0 0.0.0.255 area 0
Washington(config-router)#network 192.168.1.0 0.0.0.3 area 0
Washington(config-router)#end

Étape 6 – Testez la connectivité du réseau


a) Envoyez une requête ping à l’hôte Dublin à partir de l’hôte Washington. A-t-elle abouti ?
Oui
b) Si elle a échoué, un dépannage est nécessaire.

Étape 7 – Configurez l’authentification OSPF


a) L’authentification OSPF est en cours d’établissement sur les routeurs du réseau. D’abord,
introduisez uniquement l’authentification sur le routeur Dublin.
b) En mode de configuration d’interface sur Serial 0, entrez la commande ip ospf
messagedigest-key 1 md5 7 unsecret.
Dublin(config)#interface Serial 0
Dublin(config-if)#ip ospf message-digest-key 1 md5 ?
<0-7> Encryption type (0 for not yet encrypted, 7 for proprietary)
Dublin(config-if)#ip ospf message-digest-key 1 md5 7 ?
LINE The OSPF password (key)
Dublin(config-if)#ip ospf message-digest-key 1 md5 7 unsecret

c) Quel mot de passe OSPF est utilisé pour l’authentification md5 ? asecret
d) Quel type de cryptage est actuellement utilisé ? Type 7

Étape 8 – Activez l’authentification OSPF dans cette zone, la zone 0


Dublin(config-if)#router ospf 1
Dublin(config-router)#area 0 authentication message-digest
a) Attendez quelques secondes. Le routeur génère-t-il un quelconque résultat ? Oui
b) Entrez la commande show ip ospf neighbor.

61
Borhen Eddine ZORGUI

c) Y a-t-il des voisins OSPF ? Non


d) Examinez la table de routage en entrant show ip route.
e) Y a-t-il des routes OSPF dans la table de routage du routeur Dublin ? Non
f) L’hôte Dublin peut-il envoyer une requête ping à l’hôte Washington ? Non
g) Tapez ces commandes de configuration (une par ligne). Terminez avec CNTL/Z.
Washington#configure terminal
Washington(config)#interface serial 0
Washington(config-if)#ip ospf message-digest-key 1 md5 7 unsecret
Washington(config-if)#router ospf 1
Washington(config-router)#area 0 authentication message-digest

h) Vérifiez qu’il y a un voisin OSPF en entrant la commande show ip ospf neighbor.


Neighbor ID Pri State Dead Time Address Interface
192.168.1.129 1 FULL/ - 00:00:38 192.168.1.1 Serial0
i) Affichez la table de routage en tapant show ip route.
Exemple de configuration :

62