Вы находитесь на странице: 1из 17

Practice Lab #2 - MPLS L3VPN +

MPLS AToM + MPLS TE + Internet


Access

1
Network Diagram

2
Lab Objectives

 MPLS L3VPN using different PE-CE routing protocols


 MPLS AToM
 MPLS Traffic Engineering (TE)
 Internet Access for MPLS L3VPN customers

Configuration Files

R1
hostname R1

ip cef
ipv6 unicast-routing

interface Loopback0
ip address 192.168.1.1 255.255.255.255
ipv6 address 2001:DB8::1/128

interface FastEthernet1/0
ip address 192.1.12.1 255.255.255.0
speed 100
duplex full
ipv6 address 2001:DB8:12::1/64
no shut

router eigrp 1
network 192.1.12.1 0.0.0.0
network 192.168.1.1 0.0.0.0

R2
hostname R2

vrf definition MSSK


rd 100:1
route-target export 100:1

3
route-target import 100:1

address-family ipv4
exit-address-family

address-family ipv6
exit-address-family

ip cef

mpls traffic-eng tunnels

interface Loopback0
ip address 2.2.2.2 255.255.255.255

interface Tunnel0
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 5.5.5.5
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 1 explicit name TO_R5
tunnel mpls traffic-eng path-option 2 dynamic

interface FastEthernet1/0
vrf forwarding MSSK
ip address 192.1.12.2 255.255.255.0
speed 100
duplex full
ipv6 address 2001:DB8:12::2/64
no shut

interface FastEthernet1/1
ip address 192.1.23.2 255.255.255.0
ip router isis 1
speed 100
duplex full

4
mpls traffic-eng tunnels
ip rsvp bandwidth
no shut

interface FastEthernet2/0
ip address 192.1.25.2 255.255.255.0
ip router isis 1
speed 100
duplex full
mpls traffic-eng tunnels
ip rsvp bandwidth
no shut

router eigrp 1

address-family ipv4 vrf MSSK autonomous-system 1


redistribute bgp 100 metric 10000 1000 255 1 1500
network 192.1.12.2 0.0.0.0
exit-address-family

router isis 1
net 49.0001.0000.0000.0002.00
is-type level-2-only
metric-style wide
passive-interface Loopback0
mpls ldp autoconfig
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2

router bgp 100


bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0

address-family ipv4

5
exit-address-family

address-family vpnv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community extended
exit-address-family

address-family ipv4 vrf MSSK


redistribute eigrp 1
exit-address-family

ip explicit-path name TO_R5 enable


next-address 3.3.3.3
next-address 4.4.4.4
next-address 5.5.5.5

R3
hostname R3

ip cef

mpls traffic-eng tunnels

pseudowire-class MSSK
encapsulation mpls
interworking ip

interface Loopback0
ip address 3.3.3.3 255.255.255.255

interface FastEthernet1/0
no ip address
speed 100
duplex full
no keepalive
xconnect 4.4.4.4 89 encapsulation mpls pw-class MSSK

6
no shut

interface FastEthernet1/1
ip address 192.1.23.3 255.255.255.0
ip router isis 1
speed 100
duplex full
mpls traffic-eng tunnels
ip rsvp bandwidth
no shut

interface FastEthernet2/0
ip address 192.1.34.3 255.255.255.0
ip router isis 1
speed 100
duplex full
mpls traffic-eng tunnels
ip rsvp bandwidth
no shut

interface FastEthernet2/1
ip address 192.1.35.3 255.255.255.0
ip router isis 1
speed 100
duplex full
mpls traffic-eng tunnels
ip rsvp bandwidth
no shut

router isis 1
net 49.0001.0000.0000.0003.00
is-type level-2-only
metric-style wide
passive-interface Loopback0
mpls ldp autoconfig
mpls traffic-eng router-id Loopback0

7
mpls traffic-eng level-2

router bgp 100


bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0

address-family ipv4
exit-address-family

address-family vpnv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community extended
exit-address-family

R4
hostname R4

vrf definition MSSK


rd 100:1
route-target export 100:1
route-target import 100:1

address-family ipv4
exit-address-family

address-family ipv6
exit-address-family

ip cef

mpls traffic-eng tunnels

pseudowire-class MSSK
encapsulation mpls

8
interworking ip

interface Loopback0
ip address 4.4.4.4 255.255.255.255

interface FastEthernet1/0
ip address 192.1.34.4 255.255.255.0
ip nat inside
ip router isis 1
speed 100
duplex full
mpls traffic-eng tunnels
ip rsvp bandwidth
no shut

interface FastEthernet1/1
ip address 192.1.45.4 255.255.255.0
ip nat inside
ip router isis 1
speed 100
duplex full
mpls traffic-eng tunnels
ip rsvp bandwidth
no shut

interface FastEthernet2/0
ip address 192.1.40.4 255.255.255.0
ip nat outside
speed 100
duplex full
no shut

interface Serial3/0
no ip address
encapsulation ppp
serial restart-delay 0

9
clock rate 128000
xconnect 3.3.3.3 89 encapsulation mpls pw-class MSSK
no shut

router isis 1
net 49.0001.0000.0000.0004.00
is-type level-2-only
metric-style wide
passive-interface Loopback0
mpls ldp autoconfig
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2

router bgp 100


bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback0
neighbor 5.5.5.5 remote-as 100
neighbor 5.5.5.5 update-source Loopback0
neighbor 192.1.40.10 remote-as 200

address-family ipv4
network 30.40.50.0 mask 255.255.255.0
neighbor 192.1.40.10 activate
exit-address-family

address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community extended
neighbor 2.2.2.2 route-reflector-client
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community extended
neighbor 3.3.3.3 route-reflector-client

10
neighbor 5.5.5.5 activate
neighbor 5.5.5.5 send-community extended
neighbor 5.5.5.5 route-reflector-client
exit-address-family

address-family ipv4 vrf MSSK


network 0.0.0.0
exit-address-family

ip nat pool POOL 30.40.50.0 30.40.50.255 prefix-length 24


ip nat inside source list RFC pool POOL vrf MSSK

ip route 30.40.50.0 255.255.255.0 Null0


ip route vrf MSSK 0.0.0.0 0.0.0.0 192.1.40.10 global

ip access-list standard RFC


permit 10.0.0.0 0.255.255.255
permit 172.16.0.0 0.15.255.255
permit 192.168.0.0 0.0.0.255

R5
hostname R5

vrf definition MSSK


rd 100:1
route-target export 100:1
route-target import 100:1

address-family ipv4
exit-address-family

address-family ipv6
exit-address-family

ip cef

11
mpls traffic-eng tunnels

interface Loopback0
ip address 5.5.5.5 255.255.255.255

interface Tunnel0
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 2.2.2.2
tunnel mpls traffic-eng path-option 1 explicit name TO_R2
tunnel mpls traffic-eng path-option 2 dynamic

interface FastEthernet1/0
vrf forwarding MSSK
ip address 192.1.56.5 255.255.255.0
speed 100
duplex full
no shut

interface FastEthernet1/1
ip address 192.1.25.5 255.255.255.0
ip router isis 1
speed 100
duplex full
mpls traffic-eng tunnels
ip rsvp bandwidth

interface FastEthernet2/0
ip address 192.1.45.5 255.255.255.0
ip router isis 1
speed 100
duplex full
mpls traffic-eng tunnels
ip rsvp bandwidth
no shut

12
interface FastEthernet2/1
ip address 192.1.35.5 255.255.255.0
ip router isis 1
speed 100
duplex full
mpls traffic-eng tunnels
ip rsvp bandwidth
no shut

router ospf 100 vrf MSSK


redistribute bgp 100 subnets
network 192.1.56.5 0.0.0.0 area 0

router isis 1
net 49.0001.0000.0000.0005.00
is-type level-2-only
metric-style wide
passive-interface Loopback0
mpls ldp autoconfig
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2

router bgp 100


bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0

address-family ipv4
exit-address-family

address-family vpnv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community extended
exit-address-family

13
address-family ipv4 vrf MSSK
redistribute ospf 100
exit-address-family

ip explicit-path name TO_R2 enable


next-address 4.4.4.4
next-address 3.3.3.3
next-address 2.2.2.2

R6
hostname R6

ip cef

interface Loopback0
ip address 172.16.6.6 255.255.255.255

interface FastEthernet1/0
ip address 192.1.56.6 255.255.255.0
speed 100
duplex full
no shut

interface FastEthernet1/1
ip address 192.1.67.6 255.255.255.0
speed 100
duplex full
no shut

router ospf 100


router-id 6.6.6.6
area 1 virtual-link 7.7.7.7
network 172.16.6.6 0.0.0.0 area 0
network 192.1.56.6 0.0.0.0 area 0
network 192.1.67.6 0.0.0.0 area 1

14
R7
hostname R7

ip cef

interface Loopback0
ip address 10.7.7.7 255.255.255.255

interface FastEthernet1/0
ip address 192.1.67.7 255.255.255.0
speed 100
duplex full
no shut

router ospf 100


router-id 7.7.7.7
area 1 virtual-link 6.6.6.6
network 10.7.7.7 0.0.0.0 area 2
network 192.1.67.7 0.0.0.0 area 1

R8
hostname R8

ip cef

interface Serial1/0
ip address 192.1.89.8 255.255.255.0
encapsulation ppp
clock rate 128000
no shut

R9
hostname R9

ip cef

15
interface FastEthernet1/0
ip address 192.1.89.9 255.255.255.0
speed 100
duplex full
no shut

GW
hostname Gw

ip cef

interface FastEthernet1/0
ip address 192.1.40.10 255.255.255.0
speed 100
duplex full
no shut

interface FastEthernet1/1
ip address 192.1.100.10 255.255.255.0
speed 100
duplex full
no shut

router bgp 200


bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 192.1.40.4 remote-as 100

address-family ipv4
network 192.1.100.0
neighbor 192.1.40.4 activate
exit-address-family

16
Verifications

R1#traceroute 10.7.7.7 source lo0


Type escape sequence to abort.
Tracing the route to 10.7.7.7
VRF info: (vrf in name/id, vrf out name/id)
1 192.1.12.2 4 msec 4 msec 4 msec
2 192.1.56.5 [MPLS: Label 27 Exp 0] 12 msec 8 msec 4 msec
3 192.1.56.6 16 msec 12 msec 12 msec
4 192.1.67.7 20 msec 16 msec *

R7#traceroute 192.168.1.1 source lo0


Type escape sequence to abort.
Tracing the route to 192.168.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.1.67.6 4 msec 4 msec 4 msec
2 192.1.56.5 8 msec 12 msec 8 msec
3 192.1.12.2 [MPLS: Label 23 Exp 0] 12 msec 12 msec 12 msec
4 192.1.12.1 16 msec 16 msec *

After implementing MPLS traffic Engineering

R1#traceroute 10.7.7.7 source lo0


Type escape sequence to abort.
Tracing the route to 10.7.7.7
VRF info: (vrf in name/id, vrf out name/id)
1 192.1.12.2 8 msec 0 msec 0 msec
2 192.1.23.3 [MPLS: Labels 22/27 Exp 0] 24 msec 20 msec 20 msec
3 192.1.34.4 [MPLS: Labels 23/27 Exp 0] 24 msec 20 msec 24 msec
4 192.1.56.5 [MPLS: Label 27 Exp 0] 20 msec 16 msec 16 msec
5 192.1.56.6 20 msec 20 msec 20 msec
6 192.1.67.7 24 msec 28 msec *

17

Вам также может понравиться