Вы находитесь на странице: 1из 5

DISEÑO DE ALGORITMOS CON PSEINT

A. Estructuras de control secuencial – asignación

1. La suma de dos números

Algoritmo suma_de_dos_numeros

Escribir "escriba su primer número"

leer r

Escribir "escriba su segundo número"

leer s

suma<-r+s

Escribir "la suma de los dos números es: ",suma

Fin Algoritmo

2. El promedio de tres notas

Algoritmo promedio_tres_notas

Escribir "ingrese la primera nota"

Leer nota1

Escribir "digite la segunda nota"

Leer nota2

Escribir "digite la tercera nota"

Leer nota3

promedio<-nota1+nota2+nota3

promediototal<-promedio/3

Escribir "el promedio de las tres notas es: ", promediototal

FinAlgoritmo

3. Calcular la hipotenusa de un triángulo rectángulo

Algoritmo hipotenusa_de_un_triangulo

Escribir "ingrese el cateto opuesto"

Leer catop

Escribir "ingrese el cateto adyasente"

Leer catad
hipotenusa<-(catad*catad)+(catop*catop)

hipotenusatotal<-rc(hipotenusa)

Escribir "la hipotenusa es: ", hipotenusatotal

FinAlgoritmo

4. Calcular la longitud y área de un circulo

Algoritmo lomgitud_area_de_circulo

Definir p,radio,resultado como real

p<-3.1416

Escribir "ingrese el radio"

Leer radio

resultado<-p*(radio*radio)

long<-2*p*radio

Escribir "el area del ciirculo es: ",resultado

Escribir "la longitud del circulo es: ",long

FinAlgoritmo

B. Estructuras de control condicional “Si … Entonces”

Ejemplo:

1. Determinar si el número es par o impar

Algoritmo determinar_numero_par

escribir "ingrese el numero"

leer r

Si r%2=0 Entonces

Escribir "si es numero par"

SiNo

Escribir "no es numero par"

Fin Si

FinAlgoritmo
2. Determinar los múltiplos de seis

Algoritmo multiplos_de_seis

Escribir "escriba su numero "

leer a

Si a%6=0 Entonces

Escribir "si es multiplo de seis"

SiNo

Escribir "no es multiplo de seis"

Fin Si

FinAlgoritmo

3. Determina si un número es divisible de 14

Algoritmo multiplos_de_seis

Escribir "escriba un numero para saber si es divisor de catorce"

leer a

Si 14%a=0 Entonces

Escribir "si es divisor de catorce"

SiNo

Escribir "no es divisor de catorce"

Fin Si

FinAlgoritmo

4. Hallar el aumento al sueldo de un empleado, si el sueldo es mayor a s/. 5000 su

aumento será del 15%, pero su sueldo es menor el aumento será 12%

Algoritmo multiplos_de_seis

Escribir "escriba el sueldo del empleado"

leer sueldo

Si sueldo>5000 Entonces aumento<-sueldo/15

escribir "su aumento sera: ",aumento

SiNo

aumento2<-sueldo/12
Escribir "su aumento sera: ",aumento2

Fin Si

FinAlgoritmo

C. Estructuras de control repetitivo

C.1 “Para … hasta”

1. Diseñar un algoritmo que permita visualizar el incremento de un numero

Algoritmo incremento_numero

Escribir "escriba su numero inicial"

Leer a

escribir "escriba su numero limite"

leer n

Para i<-a Hasta n Con Paso 3 Hacer

Escribir i;

Fin Para

FinAlgoritmo

2. Diseñar un algoritmo que recíprocos de 1 al 10

Algoritmo reciprocos_del_1__al_10

Escribir "se mostrarn los reciprocos del 1 asta el 10"

Para reci<-1 Hasta 10 Con Paso 1 Hacer

reciproco<-1/reci

Escribir "su reciproco es: ",reciproco

Fin Para

FinAlgoritmo

3. Diseñar un algoritmo que sume 7 números

4. Diseñar un algoritmo que imprima la tabla de 8

5. Diseñar un algoritmo que multiplique 9 dígitos ingresados

6. Diseñar un algoritmo que sume y multiplique 8 dígitos ingresados

7. Diseñar un algoritmo que imprima el triángulo de pascal

8. Algoritmo que imprima el promedio de una lista de 15 datos


C.2 Función “Para … Hasta” y “Si … entonces”

1. Diseñar un algoritmo que indique si es primo o no es primo un numero

2. Diseñar un algoritmo que indique positivos y negativos de un conjunto de 8

datos ingresados.

3. Diseñar un algoritmo que imprima el primer mayor y segundo mayor de 10

datos ingresados

4. Algoritmo que indique si es primo o no es primo

C.3 Función “Mientras … Hacer”

1. Algoritmo que imprima los números enteros del 1 al 100

2. Algoritmo que realiza la suma de los dgitos de un número

3. Algoritmo que imprime impares del 1 al 51

4. Algoritmo que determine la factorial de un número

C.4 Función “Mientras … Hacer” y función “Si… entonces”

1. Hacer algoritmo que imprima el mayor y el menor de una serie de 10 dígitos que

vamos introduciendo por teclado.

2. Diseñar el algoritmo que imprima la suma de números pares e impares de un

conjunto de 10 primeros números naturales

3. Diseñar el algoritmo que adivine un número del 1 al 20 en 4 intentos

4. Calcular mediante un algoritmo repetitivo y condicional la suma de los números

pares e impares de un conjunto de n primeros numeros naturale