Вы находитесь на странице: 1из 72

Projet Tutoré

IPv6 :
Étude de la chaîne d'acheminement complète

Licence Professionnelle Réseaux Informatiques, Mobilité et Sécurité


Amine CHOUGUER - Sofian LAKHDAR - Théo VILLEMINOT
Tuteur : Mme. Frédérique JACQUET

Promotion 2019 / 2020


IPv6 : Étude de la chaîne d'acheminement complète

Remerciements
Tout d’abord, nous tenons à remercier notre tuteur, Frédérique JACQUET pour
nous avoir accompagnée tout au long de notre projet avec ses conseils mais aussi d’avoir
proposée ce sujet intéressant sur lequel nous avons travaillé.

Nous remercions également Mme Nadine GIRAUD pour les conseils donnés afin
de rédiger notre rapport ainsi que pour la préparation de notre soutenance.

Ainsi que l’ensemble de l’équipe pédagogique de l’Institut Universitaire de


Technologie de Clermont-Ferrand de la section Réseaux et Télécommunications qui nous
a permis d’acquérir les compétences nécessaires pour la réalisation de ce projet et pour
le prêt des matériels nécessaires pour les tests et la mise en place de l’infrastructure.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
2 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Sommaire

Remerciements ......................................................................................................................................... 2
Sommaire.................................................................................................................................................... 3
Table des figures ...................................................................................................................................... 5
Introduction................................................................................................................................................ 6
Présentation du sujet .............................................................................................................................. 7
Définition des termes ............................................................................................................................. 7
Objectifs .................................................................................................................................................. 8
Organisation ................................................................................................................................................ 9
1. La technologie IPv6 ....................................................................................................................... 10
Objectif du chapitre............................................................................................................................... 10
L’IPv4 et ses limites.............................................................................................................................. 10
Le successeur, l’IPv6 ........................................................................................................................... 14
L’adressage IPv6 .................................................................................................................................. 16
Les types d’adresses IPv6 .................................................................................................................. 19
Internet et IPv6 ...................................................................................................................................... 23
IPv6 et le routage BGP ........................................................................................................................ 27
Le routage OSPF .................................................................................................................................. 29
2. Déploiement de l’environnement de travail ............................................................................. 32
Objectif du chapitre............................................................................................................................... 32
Présentation de GNS3 ......................................................................................................................... 32
Présentation des routeurs physiques ................................................................................................ 33
3. Mise en place de l’infrastructure ................................................................................................ 37
Objectif du chapitre............................................................................................................................... 37
Infrastructure IPv6 avec BGP (routeurs physiques) ........................................................................ 37
Infrastructure IPv6 avec BGP & OSPF (GNS3) ............................................................................... 46
4. Bilan du projet ................................................................................................................................. 56
Infrastructure IPv6 avec BGP (routeurs physiques) ........................................................................ 56
Infrastructure IPv6 avec BGP & OSPF (GNS3) ............................................................................... 58
Analyses Wireshark des infrastructures ............................................................................................ 61

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
3 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Conclusion ............................................................................................................................................... 68
Difficultés.................................................................................................................................................. 68
Bilan Humain ........................................................................................................................................... 69
Résumé (en anglais) .............................................................................................................................. 69
Glossaire ................................................................................................................................................... 71
Bibliographie ........................................................................................................................................... 72

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
4 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Table des figures


Figure 1: Bête à corne ...................................................................................................................... 8
Figure 2: Diagramme de gantt .................................................................................................... 9
Figure 3: Notation décimale à point .............................................................................................. 11
Figure 4: En-tête IPv4 ..................................................................................................................... 12
Figure 5: Vision binaire................................................................................................................... 13
Figure 6: Transition En-tête IPv4 vers IPv6 .................................................................................... 15
Figure 7: Entête IPv6 ...................................................................................................................... 16
Figure 8: Adressage IPv6 ................................................................................................................ 18
Figure 9: Tableau de conversion hexadécimal-binaire .................................................................. 18
Figure 10: Représentation d’Internet (Mapping)........................................................................... 23
Figure 11: Représentation des différents niveaux d'opérateurs ................................................... 24
Figure 12: Logo de GNS3 ................................................................................................................ 32
Figure 13: Routeur Cisco 2901 ....................................................................................................... 33
Figure 14: Routeurs physique utilisés ............................................................................................ 36
Figure 15: Routeurs physiques utilisés........................................................................................... 36
Figure 16: Schéma infrastructure réseau ....................................................................................... 38
Figure 17: Schéma de l'infrastructure réseau final ........................................................................ 47

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
5 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Introduction

Au cours de notre formation Licence Professionnelle RIMS au sein de l’IUT de


Clermont-Ferrand, nous avons la possibilité de réaliser un projet tutoré. Ce projet sera
traité par un groupe de 3 personnes : Amine, Sofian, Théo et supervisé par Madame F.
Jacquet. Cette étude a une grande importance dans notre formation et elle a pour objectif
d’étudier et de développer nos connaissances.

Parmi les sujets proposés, nous avons choisi l’étude de la technologie IPv6 et son
fonctionnement sur Internet. Nous nous sommes intéressés à ce sujet car c’est une
technologie émergente. L’objectif de ce projet est d’étudier, tester et analyser la chaîne
d’acheminement complète entre deux entités (client et serveur).

Depuis les années 1980, la chaîne d’acheminement fonctionne avec la technologie


IPv4. Mais certains problèmes se posent avec celle-ci. Ainsi nous chercherons à savoir
pourquoi il est nécessaire d’évoluer vers l’IPv6.

Tout d’abord, nous présenterons les principes de bases et les différences des
technologies entre IPv4 et IPv6. Puis, nous présenterons les environnements de travail
des maquettes de la chaine d’acheminement complète en IPv6 ce qui nous permettra par
la suite de mettre en place ces maquettes. Enfin, nous terminerons par présenter les
résultats obtenus.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
6 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Présentation du sujet
Le sujet de ce projet tutoré consiste à étudier la technologie IPv6 en la mettant en
œuvre sur des éléments actifs du réseau. L’idée c’est qu’on va analyser comment deux
entités communiquent sur Internet de bout en bout en utilisant la technologie IPv6. Mais
avant d’entrer dans le vif du sujet, nous allons définir les termes du sujet.

Définition des termes

L’IPv6 :

L’IPv6 est le successeur d’IPv4. Une adresse IPv6 a une taille de 128 bits soit 4
octets. Elle est composée de 8 blocs de 2 octets séparés par des « : ». Celle-ci est
représentée en hexadécimal, et elle est calculée à partir de l’adresse MAC de la carte
réseau. Pour éviter que l’adresse MAC de la carte réseau soit diffusée sur internet, une
adresse IP temporaire et aléatoire peut être utilisée. Une adresse IPv6 peut concaténée.
Il est possible de supprimer les O non significatifs, tout comme nous pouvons remplacer
un ou plusieurs octets nuls consécutif une seule fois par adresse.

Acheminement :

L’acheminement est le processus de sélection d'un chemin pour le trafic dans un


réseau ou entre ou à travers plusieurs réseaux. L’acheminement est une caractéristique
clé d'Internet car il permet aux paquets de passer d'un ordinateur à un autre et finalement
d'atteindre la machine cible. L’acheminement est lié au routage.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
7 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Objectifs

L’objectif de ce projet est d’ajouter la technologie IPv6 à une infrastructure réseau


initialement configurée en IPv4. Ainsi, il s’agira de veiller à l’interopérabilité de ces deux
technologies et d’exploiter l’acheminement des paquets.

Les délégations d'espace d'adressage ont augmenté à un rythme alarmant, et il


était clair que la version 4 du Protocole Internet avait un nombre d’adresses trop faibles
par rapport au nombre d'entités pouvant se connecter à internet. C’est pour cela que l’on
déploie la technologie IPv6.

Cette évolution apparaît alors comme indispensable, pourtant nous constatons que
son implémentation est encore très faible, moins de 11% des sites internet étant
compatibles, et le déploiement par les fournisseurs d’accès internet est plus ou moins
rapide. La quasi-totalité des équipements est quant à elle totalement compatible avec
cette technologie.

Figure 1: Bête à corne

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
8 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Organisation

Figure 2: Diagramme de Gantt

Ce diagramme de Gantt donne un aperçu sur l’organisation que nous avons porté
à ce projet. Nous nous sommes réparti les tâches entre nous, chacun a apporté ses
idées au projet et a contribué dans chaque partie (théorie et pratique). En effet, nous
avons commencé dans un premier temps par l’étude théorique du sujet, ce qui nous a
permis de bien comprendre comment fonctionner la technologie IPv6 puis nous avons
fini par la partie pratique qui comprend la phase des tests et d’élaboration et la phase
obtention des résultats.

Nous avons participé à trois réunions avec notre tuteur, ce qui nous a permis de
nous guider et améliorer dans notre travail.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
9 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

1. La technologie IPv6

Objectif du chapitre

L’objectif de ce premier chapitre est de présenter la partie théorique de la


technologie IPv6, de comprendre comment elle fonctionne. Nous aborderons les
connaissances de base autour de cette version IP comme l’adressage, les fonctionnalités,
les différences avec son ancienne version, etc.

L’IPv4 et ses limites

Avant de commencer à traiter de la technologie IPv6, il est utile de connaitre son


prédécesseur l’IPv4. Et même bien avant, qu’est-ce qu’une IP (Internet Protocol) ?
Vous avez sans doute déjà entendu parler d’adresse IP pour vous connecter à
Internet afin de surfer sur le Web ou encore rejoindre un serveur de jeu-vidéo. En fait, une
adresse IP est un numéro d’identification qui est attribué de façon permanente ou
provisoire à chaque périphérique relié à un réseau informatique. C’est l’élément qui va
permettre d’acheminer les paquets de données sur Internet. Pour faire une analogie, si
on considère une ville comme un réseau informatique et qu’une maison est un ordinateur
alors l’adresse postale correspondrait à l’adresse IP.
On retrouve aujourd’hui deux principales versions de l’IP : la version 4 (IPv4) et la
version 6 (IPv6).
L’IPv4 a été déployé en 1981 par le groupe Internet Engineering Task Force (EITF).
Une adresse IPv4 est un identifiant de 32 bits représentés par 4 octets (soit 8 bits par
octet) codés en décimales séparée par des points.
Par exemple, 192.168.1.1 est une adresse IP de version 4. Sur cette adresse, on
retrouve deux parties : l’identifiant réseau et l’identifiant hôte dont la taille dépendra du
nombre de réseau et du nombre de machines souhaitées.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
10 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Figure 3: Notation décimale à point

Il faut savoir que sur Internet chaque hôte doit avoir accès à au moins une interface
du réseau qui peut être identifié de manière unique grâce à une adresse IP unique au
monde.
Par exemple, si vous disposez d’un accès à Internet dans votre domicile, pour
joindre les autres réseaux informatiques du monde entier vous possédez surement une
adresse IP unique fournit par votre fournisseur d’accès à Internet (FAI).

Note : Pour savoir à quoi bien elle ressemble, vous pouvez vérifier sur le site mon-ip.com/
qui vous fournira des informations détaillées sur votre adresse IP.

Un autre aspect théorique à aborder sur le protocole IP est le format du paquet ou


datagramme IP (également appelé paquet IP) qui contient les adresses IP source et
destination permettant de déterminer à qui envoyer et donc de déterminer la route à
utiliser pour joindre l’adresse de destination. Le paquet IP est constitué d’un en-tête et
d’une section de données.
On retrouve dans l’en-tête d’autres informations qui permettront à ce protocole
d’assurer d’autres rôles annexes comme la segmentation, les options éventuelles, etc. Ici,

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
11 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

nous n’allons pas présenter les différents champs que composent le datagramme IP de
la version 4 mais simplement montrer dans la prochaine partie les différences avec l’en-
tête IPv6.
Un entête IPv4 dispose d’une taille variable de minimum 20 octets et de maximum
60 octets. La taille d’un paquet entier peut aller jusque 65536 octets (les octets d’entête
et d’options). L’en-tête contient 14 champs. Dans l’en-tête IPv4, l’adresse source et
l’adresse de destination ont une longueur de 32 bits.

Figure 4: En-tête IPv4

Le schéma d'adressage IPv4, avec un champ d'adresse 32 bits, fournit un espace


d’adressage avec plus de 4 milliards d’adresses possibles (32 bits = 232 ≈ 4,3 milliards, ce
qui pourrait sembler plus que suffisant pour adresser tous les hôtes sur Internet.
Malheureusement, ça n’est pas le cas pour un certain nombre de raisons, par exemple :

➢ Même avec l'utilisation du CIDR (les masques réseaux de taille variable), les tables
de routage, principalement dans les routeurs de dorsale IP, sont devenues trop
grand pour être gérable.
➢ La priorité du trafic, ou classe de service, est vaguement définie, rarement utilisée
et pas du tout appliqué en IPv4, mais hautement souhaitable pour les applications
modernes en temps réel.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
12 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

➢ Le nombre d'applications et d'appareils de données mobiles augmente rapidement,


et IPv4 a des difficultés pour gérer les adresses de transfert et à réaliser la
localisation des visiteurs et l’authentification réseau. En effet, aujourd'hui, il y a 7,3
milliards de personnes dans le monde. La moitié d'entre eux possèdent un
ordinateur quelconque et 6 milliards ont accès à des téléphones portables. Si nous
ne distribuions qu'une seule adresse IPv4 à chaque personne, nous manquerions
de 3 milliards d'adresses IP. Cela rend la récupération de l'espace d'adressage
perdu pratiquement inutile.
➢ Il n'y a pas de prise en charge de sécurité directe dans IPv4. Diverses solutions de
sécurité ouvertes et propriétaires pouvant causer des problèmes d'interopérabilité.
Comme Internet fait partie de la vie de tous les jours, la sécurité et les améliorations
de l'infrastructure devraient être intégrées au protocole IP de base.
➢ L'autre problème avec IPv4 est la traduction d'adresses réseau (NAT). Le NAT
surchargé - une adresse IP avec plusieurs adresses IP privées derrière lui casse
un certain nombre d'applications, les équipements réseaux n’étant pas joignable
depuis internet.

Dans son plan CountDown IPv4, ARIN (American Registry for Internet Numbers)
chargé de l’attribution des adresses IPv4 en Amérique du Nord, a signalé le 2015 un
épuisement d’adresse IPv4. Cela signifie que les fournisseurs n’étaient plus en mesure
de fournir des adresses IPv4 publiques routables.

En dépit de ces problèmes, l'IETF a créé un groupe de travail IPng (IP nouvelle
génération) pour faire des recommandations à propos du protocole IP Next Generation.
Finalement, la spécification de la version 6 du protocole Internet (IPv6) a été décrite dans
la RFC 2460 - Protocole Internet, version 6 (IPv6) en tant que dernière version du
protocole IP. Ainsi, le protocole IPv6 est la solution standardisée pour palier à ce manque
d’adresses et résoudre les autres problèmes soulevés.

Figure 5: Vision binaire

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
13 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Le successeur, l’IPv6

L’IETF a commencé les travaux au milieu des années 1980 dans le but d’améliorer
le protocole IP (IPng). A cette période on ne parlait encore du protocole IPv6, il s’agissait
simplement des premières réflexions sur la saturation des adresses IP. Il faut attendre
vers la fin des années 1990 pour avoir les premières recommandations et les premiers
tests de l’IPv6. En 1998, les spécifications ont été finalisées dans la RFC 2640 et c’est en
2017 que le protocole a été standardisé dans la RFC 8200. A noté que les premières
migrations des segments IPv4 vers IPv6 ont commencé en 2003.

IPv6 offre les fonctionnalités importantes suivantes :

• Un espace d'adressage plus grand, qui serait suffisant pour au moins les 30
prochaines années
• Adressage globalement unique et hiérarchique, basé sur des préfixes plutôt que
sur l'adresse classes, pour garder les tables de routage plus petites (agrégation
des tables de routage) et le routage backbone efficace
• Un mécanisme pour l'auto-configuration des interfaces réseaux
• Prise en charge de l'encapsulation de lui-même et d'autres protocoles
• Une classe de service qui distingue les types de données
• Prise en charge améliorée du routage de multidiffusion (de préférence à la
diffusion)
• Authentification et cryptage intégrés
• Méthodes de transition pour migrer depuis IPv4
• Méthodes de compatibilité pour coexister et communiquer avec IPv4

L’utilisation du protocole IPv6 permet ainsi d’investir pour le futur. En effet, des
tendances comme celles décrites par l’internet des objets (« Internet of Things », IoT)
suggèrent que le nombre d’appareils connectés à Internet et qui doivent être clairement
identifiés, augmentera de manière significative dans les prochaines années.
Par rapport à une en-tête IPv4, IPv6 vise à minimiser la surcharge à son niveau et à
simplifier le processus de traitement des paquets sur les routeurs.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
14 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Figure 6: Transition En-tête IPv4 vers IPv6

À première vue, l’en-tête IPv6 a été simplifiée pour laisser principalement quelques
champs de taille fixe comme les adresses source et destination codées sur 128 bits, un
champ de durée de vie (Hop Limit) et celui qui annonce une charge supérieure (Next
Header)

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
15 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Figure 7: Entête IPv6

L’adressage IPv6

La première caractéristique d'IPv6 est l’utilisation d'adresses beaucoup plus


grandes. La taille d'une adresse dans IPv6 est de 128 bits, ce qui est quatre fois plus
grand qu'une adresse IPv4. Un espace d'adresses 32 bits permet de disposer de 4 294
967 296 adresses possibles. Un espace d'adresse 128 bits permet d’avoir 340 282 266
920 938 463 463 374 607 431 768 211 465 (ou 3,4 x 1038) adresses possibles.
Avec IPv6, il est encore plus difficile de concevoir que l'espace d'adresses IPv6
puisse un jour être épuisé. Pour illustrer le nouveau cadre d'adressage, un espace
d'adresses de 128 bits fournit 655 570 793 348 866 943 898 599 (6,5 x 1023) adresses
par millimètre carré de la surface terrestre.
Les adresses IPv4 sont représentées en format décimal à points. L'adresse 32 bits
est divisée par des frontières à 8 bits. Chaque groupe de 8 bits est converti en son
équivalent décimal et séparé par des points. Pour IPv6, l'adresse de 128 bits est divisée
en frontières de 16 bits, et chaque bloc de 16 bits est converti en un nombre hexadécimal

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
16 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

à 4 chiffres et séparé par des deux-points. La représentation résultante est qualifiée


d’hexadécimal deux-points.

L'exemple suivant est une adresse IPv6 en format binaire :


0010000111011010 1001000011010011 0000000001010000 0010111100111011
0000001010101010 0000000011111111 1111111000101000 1001110001011010

L'adresse 128 bits est divisée en frontières 16 bits :


0010000111011010 1001000011010011 0000000001010000 0010111100111011
0000001010101010 0000000011111111 1111111000101000 1001110001011010

Chaque bloc de 16 bits est converti en nombre hexadécimal et séparé par des
deux-points. Le résultat est le suivant :

21DA:00D3:0000:2F3B:02AA:00FF:FE28:9C5A

La représentation IPv6 peut encore être simplifiée en supprimant les zéros en


tête dans chaque bloc de 16 bits. Avec la suppression des zéros non significatifs, la
représentation d'adresse devient la suivante :
21DA:D3::2F3B:2AA:FF:FE28:9C5A

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
17 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Figure 8: Adressage IPv6

Les adresses IPv6 ont une longueur de 128 bits et sont écrites sous la forme d'une
chaîne de chiffres hexadécimaux. Tous les 4 bits peuvent être représentés par un seul
chiffre hexadécimal.

Figure 9: Tableau de conversion hexadécimal-binaire

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
18 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Les types d’adresses IPv6

Avec le protocole IPv6, il y a pas mal de nouveautés en matière d’adresses. En


effet, le broadcast disparaît complètement d’IPv6, il est remplacé par l’adressage
Multicast plus fin.
De plus, concernant les adresses IPv6, elles rétablissent la connectivité globale
(publique). Le NAT (Network Adresse Translation) qui permet de faire correspondre des
adresses IP à d’autres adresses IP n’est plus utile avec l’IPv6. Il est même déconseillé.
Cependant, les adresses privées IPv6 restent néanmoins utiles pour transporter
du trafic privé (sur des lignes privées, dans des tunnels VPN)
On retrouve plusieurs types d’adresse IPv6 :

Préfixe Désignation et Equivalence en IPv4


explication
::/128 Non spécifié 0.0.0.0
Cette adresse ne peut être
utilisée que comme
adresse source par un hôte
initialisant
avant d'avoir appris sa
propre adresse.
::1/128 Loopback 127.0.0.1
Cette adresse est utilisée
lorsqu'un hôte parle à lui-
même sur IPv6. Cela se
produit souvent lorsqu’un
programme envoie des
données à un autre.
::ffff/96 IPv4 Mappée Il n'y a pas d'équivalent.
Ces adresses sont utilisées Cependant, l'adresse IPv4
Exemple: pour intégrer des adresses mappée peut être
::ffff:192.0.2.47 IPv4 dans une adresse consultée
IPv6. On utilise pour cela dans le Whois du RIR
une transition à double pile base de données.
où les adresses IPv4
peuvent être mappé dans
une adresse IPv6. Voir
RFC
4038 pour plus de détails.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
19 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

fc00::/7 Adresses locales uniques Espace d'adressage privé


(ULA) ou RFC 1918:
Exemple: Ces adresses sont 10.0.0.0/8
fdf8:f53b:82e4::53 réservées aux utilisations à 172.16.0.0/12
l’intérieur d’un réseau local. 192.168.0.0/16
Elles ne sont pas routables
sur internet
Ces adresses doivent être
uniques seulement à
l’intérieur du même réseau
local. Des paquets avec
ces adresses dans les
champs source ou
destination ne sont pas
destinés à être routés sur
l'internet public, mais sont
destinés à l’acheminement
des paquets au sein d’un
réseau local.
Voir RFC 4193 pour plus
de détails.
fe80::/10 Adresses Link-Local 169.254.0.0/16
Ces adresses sont utilisées
Exemple: pour faire le lien entre deux
fe80::200:5aee:feaa:20a2 équipements à l’intérieur
d’un même réseau, comme
un LAN Ethernet. Elles
n'ont pas besoin d'être
uniques en dehors de cela
lien. Les adresses de lien
local peuvent apparaître
comme
source ou destination d'un
paquet IPv6. Les routeurs
ne doivent pas transmettre
de paquets IPv6 si la
source ou la destination
contient une adresse Link-
local. Ces adresses ne sont
donc pas routables.
2001:0000::/32 Teredo Pas d'équivalent
Il s'agit d'une adresse
mappée permettant
l’encapsulation d’IPv6 dans

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
20 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Exemple: un tunnel via un NAT IPv4.


2001:0000:4136:e378: L'adresse est formée en
8000:63bf:3fff:fdd2 utilisant le préfixe Teredo,
l’adresse IPv4 unique, le
drapeaux décrivant le type
de NAT, le port client
obscurci et le l'adresse IPv4
du client, qui est
probablement une adresse
privée. Il est possible
d'inverser le processus et
identifier l'adresse IPv4 du
serveur relais, qui peut
ensuite être recherchée
dans la Base de données
Whois du RIR.
2001:0002::/48 Analyse comparative 198.18.0.0/15
Ces adresses sont
Exemple: réservées à une utilisation
2001:0002:6c::430 dans le but de réaliser de la
documentation. Elles ne
doivent pas être utilisés
comme adresses source ou
destination.
2001:0010::/28 Orchid Pas d'équivalent
Ces adresses sont utilisées
Exemple: pour une durée déterminée.
2001:10:240:ab::a Elles ne doivent être
visibles que sur un seul lien
et les routeurs ne peuvent
pas router les paquets
utilisant ces adresses
comme source ou
destination.
2002::/16 6to4 Il n'y a pas d'équivalent
Une passerelle 6to4 ajoute mais
Exemple: son adresse IPv4 au préfixe 192.88.99.0/24 a été
2002:cb0a:3cdd:1::1 2002::/16, créant un préfixe réservé comme
unique de taille /48. le préfixe d'adresse
Comme l'adresse IPv4 du anycast du relais 6to4
routeur servant de par l'IETF.
passerelle est utilisée pour
composer le préfixe IPv6, il
est possible d'inverser le

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
21 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

processus et identifier
l'adresse IPv4, qui peut
ensuite être consultée dans
les base de données
WHOIS des RIR.

2001:db8::/32 Documentation 192.0.2.0/24


Ces adresses sont utilisées 198.51.100.0/24
Exemple: dans des exemples et de la 203.0.113.0/24
2001:db8:8:4::2 documentation. Elles ne
devraient jamais être
utilisées comme source ou
de destination d’un paquet.
2000::/3 Unicast Globale Aucun bloc unique
Outre les exceptions équivalent
documentées dans ce
tableau, les opérateurs de
réseaux utilisant ces
adresses peuvent être
trouvées en utilisant les
serveurs Whois des RIR.
ff00::/8 Multidiffusion 224.0.0.0/4
Ces adresses sont utilisées
Exemple: pour identifier les groupes
ff01:0:0:0:0:0:0:2 de multidiffusion. Elles ne
doivent être utilisées que
comme adresse de
destination, jamais comme
adresse source.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
22 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Internet et IPv6

Fonctionnement général d’internet :


Le client dispose d’une connexion fournie par son fournisseur d’accès à internet.
Le fournisseur de contenus est lui aussi relié à un fournisseur d’accès à internet. Un
fournisseur d’accès, pour atteindre tous les autres fournisseurs d’accès passe par un
opérateur de transit. Un opérateur peut également être relié directement à un autre
opérateur, c’est ce que l’on appelle un accord de peering. Les opérateurs utilisent le
protocole BGP pour le routage (voir la partie suivante sur le BGP).

Figure 10: Représentation d’Internet (Mapping)

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
23 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Les différents niveaux d’opérateurs :


Sur internet, il y a trois niveaux d’opérateurs (niveaux aussi appelés tiers).

L’opérateur de tier 1 voit l’intégralité des routes d’internet. Il possède donc des accords
de transit avec au minimum tous les autres opérateurs de tier 1.

L’opérateur de tier 2 possède des accords de peering avec certains opérateurs mais pas
avec tous. Il doit donc passer par un opérateur de transit pour atteindre les destinations
qu’il ne connait pas.

L’opérateur de tier 3 ne possède aucun accord de peering, il est donc entièrement


dépendant d’un opérateur de transit.

Figure 11: Représentation des différents niveaux d'opérateurs

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
24 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Le peering :
Le peering, que l’on peut traduire par appairage, consiste, pour deux opérateurs à
s’échanger du trafic internet.
Un accord de peering peut être gratuit ou payant. Il est en général gratuit quand le volume
de données échangées est relativement équivalent des deux côtés. Dans le cadre d’un
échange déséquilibré, c’est celui qui génère le plus de trafic qui doit payer. Un accord de
peering peut donc être avec ou sans conditions. On dit qu’un accord de peering est soit
ouvert, soit restrictif, soit sélectif.
Les opérateurs de tier 1 sont très exigeant concernant l’établissement d’un accord de
peering. En effet, un opérateur obtenant un accord de peering avec un opérateur de tier
1 peut accéder à l’ensemble des routes d’internet. Il devient alors à son tour un opérateur
de transit en mesure de concurrencer le premier.

Le transit :
Le transit est une prestation commerciale fournie par un opérateur à un autre afin
de lui permettre de joindre toutes les destinations avec lesquelles il ne dispose pas
d’accord de peering. Ce service est souvent fourni par un opérateur de tier 1. La
facturation se fait la plupart du temps selon la règle du 95e centile. Cette méthode
implique que le client est facturé en fonction du débit maximum utilisé dans le mois, débit
mesuré toutes les 5 minutes, en enlevant les 5% des mesures les plus élevées (cela
permet de ne pas facturer les pics de consommation). L’opérateur client s’engage
également à un minimum de consommation appelé commitment.

Le peering par rapport au transit :


Le peering permet de réduire les coûts et d’augmenter la qualité. Le peering permet
de gérer plus facilement la saturation des liens, réduit le nombre d’intermédiaire et de
chemin ce qui a pour effet de diminuer les latences.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
25 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Les deux types de peering :


Il y a deux types de peering, le privé et le public.
Dans le cas du peering privé, un opérateur doit avoir un lien physique direct avec l’autre
opérateur.
Le peering public consiste à relier plusieurs opérateurs au sein d’un point d’échange. Une
seule liaison physique avec le point d’échange permet alors d’obtenir un accord de
peering avec tous les opérateurs présents sur celui-ci.
Le peering privé est utilisé pour obtenir des débits importants entre deux opérateurs
importants s’échangeant un trafic important. Le peering public, lui, permet la mutualisation
des accords de peering. Ce dernier est surtout utilisé par des petits opérateurs qui, à eux
seuls, génèrent peu de trafic, mais qui une fois regroupés en génèrent beaucoup. Ils
peuvent alors plus facilement obtenir un accord de peering avec un gros opérateur.

Le DHCPv6 :
Le routeur du client, qui lui fournit sa connexion internet, et relié à celui du
fournisseur d’accès à internet. Contrairement à ce qui se faisait avec l’IPv4, le client
n’utilise plus le NAT et les adresses privées non routable. Chaque équipement du client
dispose d’une adresse IPv6 unicast routable sur internet. C’est le routeur du client qui
s’occupe de distribuer les adresses IPv6 aux équipements du client grâce au protocole
DHCPv6. Pour cela, le routeur a obtenu un préfixe IPv6 du fournisseur d’accès, préfixe
dans lequel seront adressés les équipements.

Internet Control Message Protocol V6 (ICMPv6) :


Le support d’ICMPv6 est obligatoire pour le fonctionnement d’IPv6. ICMPv6
regroupe plusieurs protocoles qui étaient séparés avec l’IPv4 , à savoir ICMPv4 Internet
Control Message Protocol version 4), ARP (Address Resolution Protocol) et IGMP
(Internet Group Membership Protocol).

Le Neighbor Discovery Protocol (NDP) :


Neighbor Discovery Protocol (NDP) est le protocole qui permet de détecter les
hôtes présents sur le même réseau et de récupérer leur adresse IP (ARP en IPv4) ainsi
que d’identifier les routeurs présents (IGMP en IPv4). Ce protocole repose sur l’utilisation
d’ICMPv6. Contrairement à ARP qui fonctionne en broadcast, NDP utilise du multicast,
l’adresse IPv6 ne disposant pas de broadcast.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
26 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

IPv6 et le routage BGP

Définition et historique de Border Gateway Protocol (BGP) :


BGP est un protocole d’échange de routes externe (EGP), très utilisé pour internet.
Il est le successeur du protocole Exterior Gateway Protocol (EGP) qui était utilisé par
ARPANET. Depuis 1994, c’est la version 4 de BGP qui est utilisée, les autres étant
obsolètes. Contrairement aux protocoles de routage internes, il ne fonde pas ses
décisions sur des métriques mais sur les chemins parcourus, les attributs des préfixes et
un ensemble de règles de sélection. BGP permet de spécifier les routes qui doivent être
choisis ainsi que les priorités.
Numéro d’Autonomous System (numéro d’AS) :
Un numéro d’AS est un numéro qui désigne un ensemble de réseaux informatiques
ayant une politique de routage interne cohérente. Ces numéros ont une taille de 16 bits.
Une taille de 32 bits est également utilisée aujourd’hui pour faire face à la pénurie de
numéro en 16 bits. Ces numéros sont distribués par les Registres Internet Régionaux
(RIR), en Europe c’est le RIPE-NCC (Réseaux IP Européens - Network Coordination
Centre). Les RIR agissent pour le compte de l’IANA (Internet Assigned Numbers
Authority) qui délègue cette tâche.
Plusieurs routeurs peuvent annoncer le même numéro d’AS. Pour différencier les
routeurs, chacun d’entre eux à un identifiant unique au sein de l’AS, appelé router-id.
Chaque AS annonce des réseaux dont il a la gestion.

Agrégation des réseaux en IPv6 :


BGP route des préfixes. Le but est d’agréger les réseaux afin de réduire au
maximum la taille des tables de routage. L’adresse IPv6 a été conçue pour faciliter cette
agrégation. En effet, contrairement à l’adresse IPv4 donc la taille utilisée pour l’adressage
des réseaux et l’adressage des machines n’est pas fixe, ce n’est plus le cas avec l’IPv6.
Avec cette dernière, les 64 premiers bits sont utilisés pour l’adressage des réseaux et les
64 autres pour l’adressage des machines. Les 64 bits utilisés pour l’adressage des
réseaux sont découpés en deux. La première partie est le préfixe de routage global, la
deuxième constitue l’identificateur de sous-réseau. La répartition entre les deux n’est pas
fixe. Le préfixe de routage global représente la topologie publique de l’adresse, la
topologie privée étant représentée par l’identificateur de sous réseau. Actuellement, le
préfixe de routage global utilisé est 2000::/3.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
27 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

BGP interne et BGP externe :


Il existe deux modes de fonctionnement dans BGP, iBGP et eBGP. iBGP est utilisé
entre deux routeurs du même AS. eBGP, lui, est utilisé entre deux routeurs de deux AS
différents.
Fonctionnalités offertes par le protocole BGP :

Le chemin du système autonome permet d’indiquer les AS qu’un paquet devra


traverser pour arriver à destination.
Les priorités locales définissent le coût d’une liaison interne afin d’assurer la cohérence
d’un AS.
Une communauté permet de signaler les stratégies administratives utilisées entre les
routeurs BGP, et permet notamment de pouvoir privilégier un point de peering ou un
opérateur de transit par rapport à un autre, c’est ce que l’on appelle les discriminateurs à
sortie multiples.

Gestion des sessions par BGP :

Quand deux routeurs BGP communiquent, ils montent une session TCP sur le port
179. Une fois que la session est établie, les routeurs s’échangent les routes pour
lesquelles elle propose du transit.
Les messages suivants sont utilisés pour la création et la gestion des sessions :
OPEN
Ce message permet, une fois la connexion TCP établie, d’ouvrir la session. Il permet
d’échanger des données telles que les numéros d'AS respectifs et les router ID de chacun,
et de négocier les capacités de chacun des pairs.
KEEPALIVE
Il permet de maintenir la session ouverte. Par défaut, le message KEEPALIVE est envoyé
toutes les 30 secondes, une absence de message UPDATE ni KEEPALIVE reçu dans les
90 secondes provoque la fermeture de la session.
UPDATE
Ce message permet d’annoncer des nouvelles routes ainsi que de supprimer des routes.
NOTIFICATION
Message mettant fin à une session BGP à la suite d’une erreur.
ROUTE-REFRESH

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
28 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Permet de rafraichir les routes négociées dans le message open ainsi que de demander
ou réannoncer des préfixes après la modification d’une politique de filtrage.

Le routage OSPF

Définition et historique d’Open Shortest Path First (OSPF) :


Open Shortest Path First (OSPF) est un protocole de routage interne à état de liens
(en opposition à vecteur de distance). Il été développé par l'Internet Engineering Task
Force (IETF) depuis 1987. La version 3 est la dernière du protocole, elle a été publiée en
2008 et permet la prise en charge de l’IPv6. Il a été conçu pour replacer le protocole
Routing Information Protocol (RIP) qui est un protocole à vecteur de distances. Les
infrastructures OSPF sont numérotés afin de pouvoir être séparées, à la manière de ce
qui se fait pour BGP.

Différence entre les protocoles à état de liens et vecteur de distance :


Avec un protocole de routage à état de liens, les routeurs possèdent une vision
complète du réseau. Chaque routeur dispose donc de toutes les routes afin de joindre
l’ensemble des autres routeurs du réseau. Ce protocole impose de recalculer l’intégralité
des routes si une interface change, mais si la topologie n’est pas modifiée.
Avec un protocole de routage à vecteur de distances, les routeurs ne connaissent
l'entièreté de la topologie du réseau. Ils connaissent uniquement le nombre de sauts à
effectuer pour atteindre leurs voisins. Les routes sont donc calculées chaque fois qu’un
paquet est envoyé, car le routeur qui envoie le paquet ne peut pas savoir si la topologie
a été modifiée.
Le routage a état de liens est plus adapté pour des grandes topologies mais qui
évoluent peu, car le protocole de calcul des routes demande beaucoup de ressources
processeur. Le routage à vecteur de distance est adapté aux réseaux qui évoluent
beaucoup, mais qui restent de taille modeste. Car s’il ne consomme pas beaucoup de
ressources pour le calcul des routes, plus la topologie est importante et plus le nombre
de routes à calculer à l’envoie de chaque paquet sera important.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
29 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Aire OSPF :
Une aire OSPF permet de réduire les zones de découvertes des routes. En effet,
OSPF applique, dès qu’une interface est modifiée l’algorithme de Dijkstra pour recalculer
les routes. Or, celui-ci recalcule l’ensemble des routes à chaque fois, ce qui est fortement
consommateurs de ressources processeur. Le fait de séparer l’infrastructure réseau en
aires permet de limiter l’application de l’algorithme uniquement à l’intérieur de celles-ci, et
limite donc le nombre de routes à calculer.
Toutes les interfaces d’un même réseau doivent se situer dans la même aire et
deux aires ne peuvent pas être coupées en deux par une autre aire.
Les aires sont numérotées. L’aire 0 correspond à ce que l’on appelle l’aire
backbone. Toutes les autres aires doivent être reliées à l’aire backbone, c’est pour cela
que l’on conseille de commencer l’infrastructure par celle-ci. L’aire 0 permet
l’interconnexion avec un autre protocole réseau. En général l’aire backbone fait la liaison
avec les routeurs BGP.

Les types de routeur :


Chaque routeur est identifié par un ID de la forme X.X.X.X qui doit nécessairement
être différent pour chaque routeur de la même infrastructure OSPF.
Il y a deux types de routeurs OSPF. Les routeurs internes dont toutes les interfaces
appartiennent à la même aire et les routeurs de bordure d’aire ou Area Border Router
(ABR) qui disposent d’interfaces dans plusieurs aires. Les routeurs backbone sont les
routeurs dont au moins une interface appartient à l’aire 0. Les routeurs ABR sont
forcément des routeurs backbone.

Transmission des paquets OSPF :


Le protocole OSPF utilise le protocole d’IP 89. Un paquet à une durée de vie (TTL)
d’une seconde et le champ ToS à 0 afin d’éviter une propagation au-delà du sous-réseau.
La taille maximale d’un paquet OSPF est de 65535 octets et peut-être fragmenté si
besoin, mais il est conseillé de tenir compte de la taille maximale d’un paquet que peut
transmettre le routeur (MTU) afin de régler la taille des paquets en conséquence. Les
paquets OSPF utilisent la technologie Link State Advertisements (LSA) et ils sont transmis
en multicast.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
30 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Avantages de l’OSPF :
C’est un protocole à états de lien ouvert et standardisé par l’IETF, ce qui permet
son interopérabilité contrairement à l’EIGRP qui est un protocole propriétaire de Cisco. Il
permet le routage VLSM, c’est-à-dire le routage sans classe et il est économe en bande
passante.

Inconvénients de l’OSPF :
Il ne permet pas la répartition de charge contrairement à l’EIGRP. Etant donné que
toutes les routes sont calculées pour chaque routeur, il faut que ceux-ci disposent d’une
quantité de mémoire suffisante. Si les aires sont trop grandes, le calcul des routes peut
mal se faire. Il est recommandé de ne pas dépasser 10 routeurs par aires. Le protocole
OSPF peut difficilement prendre en charge plus de 1000 routeurs. Les aires peuvent
rendre la configuration difficile. De plus, le concept d’aires backbone peut limiter les
possibilités en termes d’infrastructure.

Cette première partie nous a permis de présenter les aspects théoriques du


protocole IP (IPv4 et IPv6) qui nous seront utiles pour la suite surtout les dernières sous-
parties concernant le fonctionnement d’Internet et le protocole BGP car nous
travaillerons avec ces termes pour la mise en pratique de la chaine d’acheminement
complète.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
31 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

2. Déploiement de l’environnement de travail

Objectif du chapitre

Dans cette partie nous allons présenter notre environnement de travail où nous allons
mettre en place les différentes infrastructures représentant la chaine d’acheminement
complète en IPv6 sur Internet. C’est-à-dire décrire les matériels et logiciels utilisés.

Présentation de GNS3

Figure 12: Logo de GNS3


Qu'est-ce que GNS3 exactement ? Développé à l'origine comme un outil pour la
mise en réseau Cisco, GNS3 (abréviation de Graphical Network Simulator) est devenu
un simulateur de réseau multifournisseurs. GNS3 a été initialement développé par un
étudiant universitaire au-dessus de Dynamips pour émuler un logiciel Cisco, l'interface a
été développée pour concevoir et configurer des réseaux. Cependant, grâce aux
professionnels de la mise en réseau à la recherche d'un outil pour en savoir plus sur la
mise en réseau, tester leurs idées et pour se préparer aux rigoureux examens de
certification Cisco, le logiciel a été téléchargé plus de 11 millions de fois depuis 2008.
GNS3 est gratuit, open source, compatible avec toutes les machines Windows et
est fourni dans un ensemble comprenant des outils supplémentaires tels que Putty,
SuperPutty, Wireshark et WinPcap.
GNS3 combine les meilleures fonctionnalités des logiciels d'émulation existants
(tels que Dynamips et Qemu) dans une interface graphique et vous permet de créer un
nombre illimité de scénarios de laboratoire de routage et de commutation Cisco. De plus,
la plupart des gens et des entreprises ne peuvent pas se permettre d'investir dans tout

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
32 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

l'équipement nécessaire pour tester des dizaines de scénarios différents, GNS3 est une
option viable. Nous l’avons utilisé car nous allons mettre en place une infrastructure avec
12 routeurs que nous ne possédons pas physiquement. Comme Cisco Packet Tracer, il
suffit de faire glisser et déposer les différents composants réseau tels que des routeurs,
des pares-feux, des commutateurs, etc., dans votre zone de mise en réseau, puis essayez
différentes connexions en configurant les composants.
Dans notre cas, nous avons créé une machine virtuelle afin d’héberger le serveur
GNS3 et nous avons importé les iOS des différents routeurs

Présentation des routeurs physiques

Pour l’infrastructure utilisant des routeurs physiques, nous avons choisi des
routeurs de la marque Cisco 2901 Series.

Figure 13: Routeur Cisco 2901


Ces routeurs à services intégrés (ISR) fournissent des services de données, voix,
vidéo et applications hautement sécurisés pour les petites entreprises. Les fonctionnalités
clés incluent:

➢ 2 ports Ethernet 10/100/1000 intégrés


➢ 4 emplacements de carte d'interface WAN haute vitesse améliorés
➢ 2 emplacements de processeur de signal numérique (DSP) intégrés

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
33 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

➢ 1 module de service interne intégré pour les services d'application


➢ Distribution d'alimentation entièrement intégrée aux modules prenant en charge
la technologie 802.3af Power over Ethernet (PoE) et Cisco Enhanced PoE
Concernant la sécurité :
➢ Cryptage VPN accéléré par matériel intégré pour des communications VPN
collaboratives sécurisées
➢ Contrôle intégré des menaces à l'aide du pare-feu Cisco IOS, du pare-feu basé
sur zone Cisco IOS, de Cisco IOS IPS et du filtrage de contenu Cisco IOS
➢ Gestion des identités qui utilise l'authentification, l'autorisation et la comptabilité
(AAA) et l'infrastructure à clé publique
Concernant la voix :
➢ Module DSP vocal à haute densité, optimisé pour la voix et la vidéo
➢ Services de navigateur VoiceXML certifiés aux normes
➢ Capacités de Cisco Unified Border Element
➢ Prise en charge de la messagerie vocale Cisco Unity Express
➢ Prise en charge de Cisco Communications Manager Express et de la téléphonie
de site distant survivant

Mais l’argument principal pour le choix des routeurs est que ceux-ci sont compatibles
avec l’IPv6.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
34 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Informations techniques Cisco 2901

Description du produit Cisco 2901 - routeur - Montable sur rack


Type de périphérique Routeur
Type de boîtier Montable sur rack - modulaire - 1U
Nombre de ports WAN 2
Protocole de liaison de données Ethernet,Fast Ethernet,Gigabit Ethernet
Protocole réseau / transport IPSec,L2TPv3
OSPF,IS-IS,BGP,EIGRP,DVMRP,PIM-SM,routage
IP statique,IGMPv3,GRE,PIM-SSM,routage statique
Protocole de Routage IPv4,routage statique IPv6,routage à base de règles
(PBR),MPLS,Bidirectional Forwarding Detection
(BFD),IPv4-to-IPv6 Multicast
Protocole de gestion à distance SNMP,RMON,TR-069
Protection par firewall,Prise en charge VPN,prise en
charge de MPLS,prise en charge de Syslog,prise en
charge d'IPv6,Class-Based Weighted Fair Queuing
Caractéristiques
(CBWFQ),Weighted Random Early Detection
(WRED),Web Services Management Agent
(WSMA),NetFlow
IEEE 802.3,IEEE 802.1Q,IEEE 802.3af,IEEE
Normes de conformité 802.3ah,IEEE 802.1ah,IEEE 802.1ag,ANSI
T1.101,ITU-T G.823,ITU-T G.824
Alimentation CA 120/230 V (50/60 Hz)
Dimensions (LxPxH) 43.8 cm x 43.9 cm x 4.5 cm
Poids 6.1 kg
Garantie du fabricant 90 jours de garantie

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
35 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Voici en image les 6 routeurs physiques que nous allons configurer pour représenter la
chaine d’acheminement complète en IPv6 sur Internet :

Figure 14: Routeurs physique utilisés

Figure 15: Routeurs physiques utilisés

Pour les deux infrastructures nous avons aussi utilisé un PC (sous Windows) représentant
le client et un autre PC (sous Linux) représentant le serveur de contenu.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
36 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

3. Mise en place de l’infrastructure

Objectif du chapitre

Dans cette partie nous allons montrer comment nous avons mis en place nos
différentes infrastructure représentant la chaine d’acheminement complète en IPv6 sur
Internet. Nous avons réalisé deux infrastructures l’une avec des vrais routeurs physiques
avec seulement du BGP et une autre infrastructure virtuelle en utilisant le logiciel GNS3
qui comprend aussi le protocole OSPF.

Infrastructure IPv6 avec BGP (routeurs physiques)

Cette infrastructure utilisera 6 routeurs physiques Cisco 2901, chacun jouant son
propre rôle dans la chaine d’acheminement. Nous travaillerons ici seulement avec le
protocole de routage BGP. Dans notre infrastructure, les deux fournisseurs d’accès à
internet n’ont pas d’accord de peering entre eux et n’ont pas le même opérateur de transit.

Les acteurs de l’infrastructure :


➢ Le client
➢ Le fournisseur d’accès à internet du client
➢ L’opérateur de transit du fournisseur d’accès à internet du client
➢ L’opérateur de transit du fournisseur d’accès à internet du fournisseur de contenus
➢ Le fournisseur d’accès à internet du fournisseur de contenus
➢ Le fournisseur de contenus
Les équipements informatiques utilisés pour la création de l’infrastructure :
➢ PC du client
➢ Routeur du client
➢ Routeur du fournisseur d’accès à internet du client
➢ Routeur de l’opérateur de transit du fournisseur d’accès à internet du client
➢ Routeur de l’opérateur de transit du fournisseur d’accès à internet du fournisseur
de contenus.
➢ Routeur du fournisseur d’accès à internet du fournisseur de contenus
➢ Routeur du fournisseur de contenus

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
37 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Schéma de l’infrastructure :

Figure 16: Schéma infrastructure réseau


Routage et délégation de préfixe :
Entre les fournisseurs d’accès à internet et les opérateurs de transit, ainsi que les
opérateurs de transit en eux utilisent le protocole de routage BGP, c’est ce que l’on
appelle le routage externe. Le routage à l’intérieur d’un fournisseur d’accès à internet,
appelé routage interne, utilise des protocoles de routage interne. En utilisant des
équipements Cisco pour le routage d’IPv6, il faut obligatoirement activer IPv6 unicast-
routing.
Le routeur du fournisseur d’accès va déléguer un préfixe IPv6 au routeur de son
client afin que celui-ci puisse ensuite adresser les clients qui sont connectés dessus. La
délégation de préfixe utilise le protocole DHCPv6.

Mise en place de la délégation de préfixe :


Sur le routeur du fournisseur d’accès à internet :
Création du préfixe :
ipv6 local pool DELIGv6POOL <préfixe délégué>::/40 56

Attribution du pool au dhcp :


ipv6 dhcp pool DHCPv6POOL

Délégation du préfixe :

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
38 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

prefix-delegation pool DELIGv6POOL lifetime 1800 600

Sur le routeur du client :


Récupération du préfixe à déléguer :
ipv6 dhcp client pd PREFDEL rapid-commit

Création du réseau qui adressera les machines clientes :


ipv6 address PREFDEL ::<sous réseau du préfix>/64

Mise en place du BGP :


Création de l’Autonomous System :
router bgp <numéro d’AS>

Attribution de l’ID du routeur :


bgp router-id <ID du routeur>

Envoie des routes à transmettre à un autre AS :


neighbor <IP du routeur qui recevra les routes> remote-as <AS du routeur qui recevra les
routes>

Création de la configuration des routeurs


address-family ipv6

Route à transmettre :
network <Route que l’on souhaite transmettre>

Activer le transfert :
neighbor <IP du routeur qui recevra les routes> activate

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
39 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Détail de configuration des routeurs :


➢ Routeur_Client

ipv6 unicast-routing
ipv6 cef
!
interface GigabitEthernet1/0
no ip address
negotiation auto
ipv6 address autoconfig default
ipv6 enable
ipv6 dhcp client pd PREFDEL rapid-commit
!
interface GigabitEthernet2/0
no ip address
negotiation auto
ipv6 address PREFDEL ::1:0:0:0:1/64
ipv6 enable
ipv6 nd other-config-flag
ipv6 dhcp server DHCPv6

Table de routage :
ipv6 unicast-routing
ipv6 cef
!
interface GigabitEthernet1/0
no ip address
negotiation auto
ipv6 address autoconfig default
ipv6 enable
ipv6 dhcp client pd PREFDEL rapid-commit
!
interface GigabitEthernet2/0
no ip address
negotiation auto
ipv6 address PREFDEL ::1:0:0:0:1/64
ipv6 enable
ipv6 nd other-config-flag
ipv6 dhcp server DHCPv6

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
40 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

➢ FAI_Client

no ip domain lookup
ipv6 unicast-routing
ipv6 cef
ipv6 dhcp pool DHCPv6POOL
prefix-delegation pool DELIGv6POOL lifetime 1800
600
!
interface GigabitEthernet1/0
no ip address
negotiation auto
ipv6 address 2010::1/64
ipv6 enable
ipv6 dhcp server DHCPv6POOL
!
interface GigabitEthernet2/0
no ip address
negotiation auto
ipv6 address 2001::2/64
ipv6 enable
!
router bgp 1
bgp router-id 1.1.1.1
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 2001::1 remote-as 2
!
address-family ipv6
network 2011::/56
network 2011:ABCD::/56
neighbor 2001::1 activate
exit-address-family

Table de routage :

no ip domain lookup
ipv6 unicast-routing
ipv6 cef
ipv6 dhcp pool DHCPv6POOL
prefix-delegation pool DELIGv6POOL lifetime 1800
600
!
interface GigabitEthernet1/0
no ip address
negotiation auto
ipv6 address 2010::1/64
ipv6 enable
ipv6 dhcp server DHCPv6POOL
!
Sofian LAKHDAR
interface GigabitEthernet2/0
Amine CHOUGUER LP RIMS
no ip address
Théo VILLEMINOT
41 2019/2020
negotiation auto
ipv6 address 2001::2/64
ipv6 enable
IPv6 : Étude de la chaîne d'acheminement complète

➢ Transit_FAI_Client

no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
interface GigabitEthernet1/0
no ip address
negotiation auto
ipv6 address 2000::1/64
ipv6 enable
!
interface GigabitEthernet2/0
no ip address
negotiation auto
ipv6 address 2001::1/64
ipv6 enable
!
router bgp 2
bgp router-id 2.2.2.2
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 2000::2 remote-as 4
neighbor 2001::2 remote-as 1
!
address-family ipv4
exit-address-family
!
address-family ipv6
neighbor 2000::2 activate
neighbor 2001::2 activate
exit-address-family

no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
interface GigabitEthernet1/0
no ip address
negotiation auto
ipv6 address 2000::1/64
ipv6 enable
! LAKHDAR
Sofian
interface
Amine GigabitEthernet2/0
CHOUGUER LP RIMS
no ip address
Théo VILLEMINOT
42 2019/2020
negotiation auto
ipv6 address 2001::1/64
IPv6 : Étude de la chaîne d'acheminement complète

Table de routage :

➢ Transit_FAI_Serveur :

no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
interface GigabitEthernet1/0
no ip address
negotiation auto
ipv6 address 2000::2/64
ipv6 enable
!
interface GigabitEthernet2/0
no ip address
negotiation auto
ipv6 address 2002::1/64
ipv6 enable
!
router bgp 4
bgp router-id 4.4.4.4
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 2000::1 remote-as 2
neighbor 2002::2 remote-as 3
!
address-family ipv4
exit-address-family
!
address-family ipv6
neighbor 2000::1 activate
neighbor 2002::2 activate
exit-address-family

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
43 2019/2020
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
IPv6 : Étude de la chaîne d'acheminement complète

Table de routage :

➢ FAI_Serveur :
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
ipv6 dhcp pool DHCPv6POOL
prefix-delegation pool DELIGv6POOL lifetime 1800
600
!
interface GigabitEthernet1/0
no ip address
negotiation auto
ipv6 address 2020::1/64
ipv6 enable
ipv6 dhcp server DHCPv6POOL
!
interface GigabitEthernet2/0
no ip address
negotiation auto
ipv6 address 2002::2/64
ipv6 enable
!
router bgp 3
bgp router-id 3.3.3.3
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 2002::1 remote-as 4
!
address-family ipv4
exit-address-family
!
address-family ipv6
network 2021:ABCD::/56
neighbor 2002::1 activate
exit-address-family
Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
44 2019/2020
no ip domain lookup
ipv6 unicast-routing
IPv6 : Étude de la chaîne d'acheminement complète

Table de routage :

➢ Routeur_Serveur :

no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
interface GigabitEthernet1/0
no ip address
negotiation auto
ipv6 address autoconfig default
ipv6 enable
ipv6 dhcp client pd PREFDEL rapid-commit
!
interface GigabitEthernet2/0
no ip address
negotiation auto
ipv6 address PREFDEL ::1:0:0:0:1/64
ipv6 enable
ipv6 nd other-config-flag
ipv6 dhcp server DHCPv6

no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
interface GigabitEthernet1/0
no ipLAKHDAR
Sofian address
negotiation
Amine auto
CHOUGUER LP RIMS
ipv6VILLEMINOT
Théo address autoconfig default
45 2019/2020
ipv6 enable
ipv6 dhcp client pd PREFDEL rapid-commit
IPv6 : Étude de la chaîne d'acheminement complète

Table de routage :

Infrastructure IPv6 avec BGP & OSPF (GNS3)

Cette infrastructure a été réalisée sur GNS3 qui permet de simuler et d’émuler des
équipements réseaux. En effet, ici nous avons configuré 12 routeurs, nombre que nous
ne possédons pas physiquement. L’objectif ici est de construire la chaine d’acheminement
complète en IPv6 sur Internet mais comparé à l’autre infrastructure nous avons ajouté le
protocole de routage interne OSPF.
Entre les routeurs de bordures des fournisseurs d’accès à internet et les opérateurs
de transit, ainsi que les opérateurs de transit en eux utilisent le protocole de routage BGP.
Les réseaux internes des fournisseurs d’accès à internet utilisent le protocole interne
OSPF.
Les acteurs de l’infrastructure :
➢ Les clients
➢ Les fournisseurs d’accès à internet des clients
➢ L’opérateur de transit du fournisseur d’accès à internet des clients
➢ L’opérateur de transit du fournisseur d’accès à internet des fournisseurs de
contenus
➢ Les fournisseurs d’accès à internet des fournisseurs de contenus
➢ Les fournisseurs de contenus

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
46 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Les équipements informatiques utilisés pour la création de l’infrastructure :


➢ PC des clients
➢ Routeurs des clients
➢ Routeurs du fournisseur d’accès à internet des clients
➢ Routeur de l’opérateur de transit du fournisseur d’accès à internet des clients
➢ Routeur de l’opérateur de transit du fournisseur d’accès à internet des fournisseurs
de contenus.
➢ Routeurs du fournisseur d’accès à internet des fournisseurs de contenus
➢ Routeurs des fournisseurs de contenus

Schéma de l’infrastructure :

Figure 17: Schéma de l'infrastructure réseau final

Mise en place de l’OSPF :


ipv6 router ospf <numéro OSPF>
router-id <id du routeur sous la forme X.X.X.X>
default-information originate always (si le routeur est la route par défaut)
interface <interface sur laquelle on souhaite appliquer OSPF>
ipv6 ospf <numéro OSPF, identique à celui de dessus> area <numéro de l’aire OSPF l’interface>

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
47 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Détail de la configuration des routeurs :


➢ Border_FAI_Client

Table BGP :

Table de routage :

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
48 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

➢ Border_FAI_Serveur :

Table BGP :

Table de routage :

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
49 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

➢ FAI_Client_1 :

Table de routage :

➢ FAI_Client_2
Table de routage :

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
50 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

➢ FAI_Serveur_1 :
Table de routage :

➢ FAI_Serveur_2 :
Table de routage :

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
51 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

➢ Routeur_Client_1 :
Table de routage :

➢ Routeur_Client_2 :
Table de routage :

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
52 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

➢ Routeur_Serveur_1 :
Table de routage :

➢ Routeur_Serveur_2 :
Table de routage :

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
53 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

➢ Transit_FAI_Client :
Table BGP :

Table de routage :

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
54 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

➢ Transit_FAI_Serveur :
Table BGP :

Table de routage :

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
55 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

4. Bilan du projet

Infrastructure IPv6 avec BGP (routeurs physiques)

Adressage du client

Adressage du serveur de contenu

Table BGP FAI_Client

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
56 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Table BGP FAI_Serveur

Table BGP Transit_FAI_ Client

Table BGP Transit FAI Serveur

Accès au Serveur de contenu Web (Apache)

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
57 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Infrastructure IPv6 avec BGP & OSPF (GNS3)

➢ Client_1 :
Ping client 1 vers client 2 :

Ping client 1 vers serveur 1 :

Ping client 1 vers serveur 2 :

➢ Client_2 :

Ping client 2 vers client 1 :

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
58 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Ping client 2 vers serveur 1 :

Ping client 2 vers serveur 2 :

➢ Serveur_1 :
Ping serveur 1 vers client 1 :

Ping serveur 1 vers client 2 :

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
59 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Ping serveur 1 vers serveur 2 :

➢ Serveur_2 :

Ping serveur 2 vers client 2 :

Ping serveur 2 vers serveur 1 :

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
60 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Analyses Wireshark des infrastructures

➢ Analyse de la communication BGP :

On analyse chaque partie de l’infrastructure mise en place qui utilisent du BGP :

o Partie Transit FAI

On analyse la communication BGP entre le routeur Transit FAI client et le routeur


Transit FAI serveur :

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
61 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Le routeur Transit FAI client envoie un message de type ‘OPEN Message’ afin
d’initier la session avec l’autre extrémité qui est le routeur Transit FAI serveur.

Les deux routeurs échangent le message de type ‘KEEPALIVE’ d’une façon


périodique. Ce message est utilisé pour garantir que l’autre extrémité est toujours
disponible. Si un routeur ne reçoit pas de message de type ‘KEEPALIVE’ d'une extrémité
pendant une période de maintien de 180 secondes (Valeur par défaut), le routeur déclare
cette extrémité morte.

Enfin, les deux routeurs s’échanges les routes en utilisant des messages de type
‘UPDATE Message’.

o Partie Border Client / Serveur

La communication BGP reste la même pour le lien entre le routeur Transit FAI
client/serveur et le routeur Border FAI client/serveur.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
62 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

De la capture Wireshark, nous voyons que le routeur Border FAI client/serveur


envoie un message de type ‘OPEN Message’ pour lancer une session BGP avec le
routeur Transit FAI client/serveur.

Les deux routeurs échangent toujours des messages de type ‘KEEPALIVE


Message’ pour s’assurer que les deux extrémités sont toujours disponibles.

Enfin comme d'habitude nous terminons la communication BGP avec des


messages de type ‘UPDATE Message’ afin de s’échanger les routes.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
63 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

➢ Analyse de la communication OSPF

Prenons l’extrémité où se trouve le client. Nous avons six routeurs que nous avons
configurés pour utiliser le protocole de routage OSPF :

Nous analyserons la communication OSPF entre le routeur FAI Client 1 et Routeur Client
1.

A partir du capture Wireshark suivant, on constate qu’on passe par des étapes afin
de finalement permettre le routage des paquets.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
64 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Le routeur qui essaye d’acheminer ses paquets doit envoyer d’abord des paquets
de type ‘Hello Packet’ afin de permettre la découverte dynamique des voisins et maintenir
des relations avec les voisins.

Pour les protocoles de routage d'état de liaison tel que OSPF, il est essentiel que
la base de données d'état de liaison de tous les routeurs reste synchronisée. Une fois la
contiguïté formée, des paquets de type ‘DB Description’ seront échangés entre les deux
routeurs donnant une base de données résumée de la topologie.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
65 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Le voisin récepteur décidera quelles informations de liaison il lui manque et enverra


une demande d'état de liaison pour les informations complètes sur cette liaison
manquante.

Ce paquet implémente l'inondation LSA (Link State Advertisement). Chaque LSA


comprend la métrique, les informations de topologie et le routage pour décrire la partie
réseau OSPF.

L'OSPF a besoin d'un accusé de réception pour la réception de chaque LSA. Du


coup, en envoie des paquets de type ‘LS Acknowledge’.

➢ Analyse de la communication DHCPv6

On analyse la communication DHCPv6 entre le routeur Client et le routeur FAI


Client :

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
66 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Le routeur client envoi d’abord un message de type ‘Solicit XID’ pour localiser les
serveurs DHCPv6 qui se trouve dans le réseau, et dans ce cas-là c’est le routeur FAI
Client.

Le routeur FAI Client envoie un message de publicité pour indiquer qu'il est
disponible pour le service DHCP, en réponse au message de type ‘Solicit XID’ reçu du
routeur client et après ça le routeur envoie un message de réponse contenant les
adresses attribuées et les paramètres de configuration au routeur client.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
67 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Conclusion
En guise de conclusion, ce projet nous a permis de comprendre, dans sa globalité
la technologie IPv6 et son fonctionnement avec Internet.

En effet, dans la première partie théorique nous avons exposés nos différents
arguments en répondant à la problématique « Pourquoi choisir l’IPv6 ? ». Nous avons
aussi expliqué quelques notions du fonctionnement d’Internet et de quelques autres
protocoles de routage. Ce qui nous a permis par la suite de comprendre et d’introduire la
mise en place de la chaine d’acheminement complète sur Internet en IPv6. Par nos deux
infrastructures mise en place, nous avons réussi à représenter cette chaine
d’acheminement comme attendu. Du client au serveur de contenu tout en passant par
des routeurs jouant chacun un rôle spécifique dans cette chaine.

Ce projet a pu aussi nous apporter de nombreuses satisfactions, aussi bien à titre


personnel que collectif. En effet, nous avons d’avantage appris à travailler en équipe,
quand il s’agissait d’exposer ses idées aux autres, développer son esprit d’analyse, son
organisation, ses méthodes de travail, etc.

Il s’agit donc d’une expérience enrichissante, aussi bien pour les connaissances
obtenues que pour ce que nous avons pu apprendre avec le travail en groupe, ainsi
chacun a pu en retirer un bénéfice.

Difficultés
La difficulté que nous avons rencontrée dans ce projet était le fait que nous n'avions
pas suffisamment de routeurs pour configurer complètement notre infrastructure. Pour y
parvenir, nous avons donc dû utiliser un logiciel de simulation qui nous a permis de le
compléter.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
68 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Bilan Humain

Ce projet a été une expérience enrichissante qui nous a permis d'acquérir de


nouvelles compétences dans le domaine des réseaux informatiques, nous avons
également eu l'opportunité de travailler en équipe, ce qui nous a aidé à être plus organisés
et décisifs dans ce projet, et ce sont des compétences qui vont nous servir dans le monde
professionnel.

Nous avons également réussi à trouver de nouvelles idées qui ont rendu notre
projet plus intéressant et atteindront les objectifs fixés par notre tuteur tout en apprenant
les nouvelles technologies utilisées dans le domaine des réseaux informatiques.

Si je devais refaire le projet, je travaillerais sur d'autres technologies de routage


utilisées par les fournisseurs de services Internet et étudierais leurs aspects.

Résumé (en anglais)


This year we had the opportunity to do a tutored project in the study of IPv6 Routing.
This project is important for the process of obtaining our vocational degree. The goal of
the project is to study how IPv6 internet traffic gets transported from a client to a server
while focusing on the technologies used by operators.

The three members of the project are: Amine CHOUGUER, Théo VILLEMINOT,
Sofian LAKHDAR. Supervised by our Tutor Ms. Frederique JACQUET.

IPv6, short for Internet Protocol version 6, is a routing protocol that allows
communication and data transfers to take place between different entities. The internet
protocol uses addresses to identify and locate entities to initiate communication; it’s similar
to a phone number that identifies an individual. IPv6 technology is still in the process of
deployment since its predecessor IPv4 is still operational. Our goal is to study the

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
69 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

problems that the IPv6 protocol is trying to solve and how operators use routing
technologies to transit internet traffic. To do that, we’re going to build a network
infrastructure that uses IPv6 only and simulate how Internet Service Providers route
internet traffic.

To simulate how Internet Service Providers route internet traffic, we’re going to
have three levels in our network. The first level will have routers that are used by 1 st Tier
Transit Operators who are responsible for routing traffic inter-continentally. The second
Level will have routers operated by 2nd Tier Transit operators who are responsible for
routing internet traffic from 1st Tier routers to the Internet service providers. Finally, the
third level, which consists of routers operated by 3rd Tier Transit Operators, which are the
Internet service providers, are responsible for providing internet access to clients. And
we’re going to use routing protocols such as OSPFv3 and BGP to do these simulations.

We succeeded in building a fully functional network infrastructure operating on IPv6


only, which includes all the three levels, and we use the routing protocols such as BGP
and OSPFv3 that are used to route internet traffic. We also had two extremities: one was
the client, and the other was a web server. The communication between the two entities
was successful, and we studied the routing process in different levels of our networks that
allowed the communication between the two using tools such as GNS3 and Wireshark.

We encountered some difficulties throughout the project, one of them was the fact
that we didn’t have enough routers to deploy our infrastructure, so we had to use a
powerful simulation software which is GNS3 that allows you to download router images
and deploy them virtually as if you’re deploying them physically which made it way easier
to complete and meet the goals of our projects.

Overall this project was an enriching experience for us. It gave us a new
perspective on how transit operators and Internet Service Providers handle internet traffic.
We acquired new skills such as configuring routing protocols (BGP, OSPv3), the use of
IPv6 in network infrastructures, and we also learned how powerful is IPv6 and its capacity
to solve IPv4 problems.

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
70 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Glossaire

Ce glossaire regroupe tous les sigles utilisés dans ce rapport et les termes difficiles ou
mal connus.
IP : Internet Protocol
BGP : Border Gateway Protocol
NAT : Network Address Translation
IETF : Internet Engineering Task Force
VPN : Virtual Private Network
FAI : Fournisseur d’accès à internet
CIDR : Classless Inter-Domain Routing
ARIN : American Registry for Internet Numbers
IPng : Groupe de travail de l’IETF
RFC : Request for Comments
Backbone : Dorsale ou colonne vertébrale d’un réseau.
IoT : Internet of Things (Internet des objets)
Broadcast : Paquet envoyé à l’ensemble des équipements d’un réseau
Multicast : Paquet envoyé à une partie des équipements d’un réseau
Unicast : Paquet envoyé à un seul équipement d’un réseau
OSPF : Open Shortest Path First
EGP : Exterior Gateway Protocol
IGP : Interior Gateway Protocol
AS : Autonomous System
TCP : Transport Control Protocol

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
71 2019/2020
IPv6 : Étude de la chaîne d'acheminement complète

Bibliographie
https://fr.wikipedia.org/wiki/IPv6
https://fr.wikipedia.org/wiki/Transition_d%27IPv4_vers_IPv6
https://fr.wikipedia.org/wiki/Adresse_IPv6
https://fr.wikipedia.org/wiki/Border_Gateway_Protocol
https://fr.wikipedia.org/wiki/Open_Shortest_Path_First
Pour la mise en place de la délégation de préfixe :
https://packetpushers.net/ipv6-home-prefix-delegation/
Pour la mise en place du BGP :
https://www.cisco.com/c/en/us/support/docs/ip/ip-version-6-ipv6/112135-ipv6-bgp-
00.html
Pour la mise en place d’OSPF :
https://www.supinfo.com/articles/single/2459-configurer-router-ipv6

Sofian LAKHDAR
Amine CHOUGUER LP RIMS
Théo VILLEMINOT
72 2019/2020