Вы находитесь на странице: 1из 3

ДОМАШНЕЕ ЗАДАНИЕ №6

Создайте переменные – ДвухзначноеЧисло и Степень. Присвойте им определенные целочисленные значения.

Обеспечьте возведение ДвухзначногоЧисла в Степень. Далее, нужно сообщить получившийся результат.

Также нужно сообщить превышает ли полученное значение 10 000.

//ДвухзначноеЧисло = 50; //Если Результат Тогда

//Степень = 2; // Сообщить(Результат);

//Результат = 1; // Если (Результат) < 10000


Тогда
//Для Счетчик = 1 По Степень Цикл
//
// Результат =
Сообщить("Меньше");
Результат*ДвухзначноеЧисло;
// ИначеЕсли (Результат) >
//КонецЦикла;
10000 Тогда
//Если ДвухзначноеЧисло и
//
Степень Тогда
Сообщить("Больше");
// Сообщить(Результат);
// КонецЕсли;
// Если (Результат) < 10000
//КонецЕсли;
Тогда
//
//
Сообщить("Меньше");

// ИначеЕсли (Результат) > //ДвухзначноеЧисло = 54;


10000 Тогда
//Степень = 3;
//
Сообщить("Больше"); //Результат =
Pow(ДвухзначноеЧисло, Степень);
// КонецЕсли;
//Сообщить (Результат) ;
//КонецЕсли;
//Если Результат > 10000 Тогда
//
// Сообщить("Больше");

//Иначе
//ДвухзначноеЧисло = 50;
// Сообщить("Меньше");
//Степень = 2;
//КонецЕсли;
//Результат =
Pow(ДвухзначноеЧисло, Степень);

//
ДОМАШНЕЕ ЗАДАНИЕ №7

Сообщите на какой день недели выпадает 31 декабря в ближайшие 10 лет.

Название дня недели нужно выдать в текстовом виде, например – понедельник, вторник, …

Подсказка. Для определения дня недели используйте встроенную функцию ДеньНедели.


//

//НГ = КонецГода(ТекущаяДата());

//для Индекс = 1 по 10 Цикл

// Сообщить(Формат(НГ,"ДФ=гггг ММММ дддд'"));

// НГ=ДобавитьМесяц(НГ,12);

//КонецЦикла;

//

//КонецГода = КонецГода(ТекущаяДата());

//Для Индекс = 1 По 10 Цикл

// ДНедели = ДеньНедели(КонецГода);

//

// Если ДНедели = 1 Тогда

// Сообщить("Понедельник");

// ИначеЕсли ДНедели = 2 Тогда

// Сообщить("Вторник");

// ИначеЕсли ДНедели = 3 Тогда

// Сообщить("Среда");

// ИначеЕсли ДНедели = 4 Тогда

// Сообщить("Четверг");

// ИначеЕсли ДНедели = 5 Тогда

// Сообщить("Пятница");

// ИначеЕсли ДНедели = 6 Тогда

// Сообщить("Субота");

// Иначе

// Сообщить("Неделя");

// КонецЕсли;

// КонецГода = КонецГода(КонецДня(КонецГода)+1);

//КонецЦикла;
ДОМАШНЕЕ ЗАДАНИЕ №8

При записи документа «Реализация товаров» сохраните общую сумму документа в реквизит «Сумма
документа».

Также необходимо выполнить проверку, что в документе «Реализация товаров» выбран контрагент, у которого
указан флаг «Клиент».

Подсказка 1. Для проверки корректности заполнения реквизитов используйте событие


ОбработкаПроверкиЗаполнения.

Подсказка 2. Чтобы получить значение реквизита обращайтесь через «точку». Например,


Сообщить(Контрагент.ЭтоКлиент).

Оценить