Вы находитесь на странице: 1из 6

PRINCIPIOS DE ALGORITMOS

EJERCICIOS- SEMANA9

1. Realice un programa tal que, al ingresar un carácter, determine si éste es una vocal en
mayúscula o minúscula, o es una consonante.
Resolución:
1 Proceso VocalMMIC
2 Definir L Como Caracter
3 Escribir "Digite una letra "
4 Leer L
5 Segun L Hacer
6 "A","E","I","O","U":
7 Escribir "Es mayuscula y vocal"
8 "a","e","i","o","u":
9 Escribir "Es minuscula y vocal"
10 De Otro Modo:
11 Escribir "Es constante"
12 Fin Segun
13 FinProceso

2. Realizar un programa que permita ingresar un número correspondiente a los meses del año y
muestre el último día del mes.
Resolución:
1 Proceso DIASMES
2 Definir M,A,D Como Real
3 Definir MES Como Caracter
4 Escribir "Ingrese el año"
5 Leer A
6 Escribir "Ingrese el numero correspondiente al mes(1-12)"
7 Leer M
8 Segun M Hacer
9 1:
10 MES="ENERO"
PRINCIPIOS DE ALGORITMOS

11 D=30
12 2:
13 MES="FEBRERO"
14 Si (A mod 4==0)y(A mod 100<>0)o(A mod 400==0)Entonces
15 D=29
16 Sino
17 D=28
18 FinSi
19 3:
20 MES="MARZO"
21 D=31
22 4:
23 MES="ABRIL"
24 D=30
25 5:
26 MES="MAYO"
27 D=31
28 6:
29 MES="JUNIO"
30 D=30
31 7:
32 MES="JULIO"
33 D=31
34 8:
35 MES="AGOSTO"
36 D=31
37 9:
38 MES="SEPTIEMBRE"
39 D=30
40 10:
41 MES="OCTUBRE"
42 D=31
43 11:
44 MES="NOVIEMBRE"
45 D=30
46 12:
47 MES="DICIEMBRE"
48 D=31
49 De Otro Modo:
50 Escribir "Valor Invalido"
51 Fin Segun
52 Escribir " El mes es " ,MES, " tiene " ,D," para el año indicado"
53 FinProceso
PRINCIPIOS DE ALGORITMOS

3. Escriba un seudocódigo que calcule el importe a pagar por un vehículo al circular por una
autopista. El vehículo puede ser una bicicleta, una moto, un coche, o un camión. Para definir
el conjunto vehículos utilizaremos un tipo enumerado. El importe se calculará según los
siguientes datos:
 Un importe fijo de 100 soles para las bicicletas
 Las motos y los carros pagarán 30 soles por Km.
 Los camiones pagarán 30 soles por Km más 25 soles por Toneladas.
La presentación en pantalla de la solución, será de la forma siguiente:
1. bicicleta
2. moto
3. carro
4. camión
5. salir
Resolución:
1 Proceso Vehiculos
2 Definir OP,IT Como Real
3 Escribir "[1] BICICLETA"
4 Escribir "[2] MOTO"
5 Escribir "[3] CARRO"
6 Escribir "[4] CAMION"
7 Escribir "[5] SALIR"
8 Escribir "INGRESAR OPCION"
9 Leer OP
10 Segun OP Hacer
11 1:
12 IT<-100
13 2:
14 ESCRIBIR "INGRESE LOS KILOMETROS RECORRIDOS"
15 LEER KM
16 IT<-30*KM
17 3:
18 ESCRIBIR "INGRESE LOS KILOMETROS RECORRIDOS"
19 LEER KM
20 IT<-30*KM
21 4:
22 ESCRIBIR "INGRESE LOS KILOMETROS RECORRIDOS"
PRINCIPIOS DE ALGORITMOS

23 LEER KM
24 ESCRIBIR "INGRESE LAS TONELADAS CARGADAS EN SU CAMION"
25 LEER TN
26 IT<-(30*KM) + (25*TN)
27 5:
28 ESCRIBIR "SALISTE"
29 DE OTRO MODO:
30 ESCRIBIR "ERROR, OPCION NO DISPONIBLE"
31 FinSegun
32 ESCRIBIR "SU IMPORTE TOTAL A PAGAR ES DE: ", IT
33 FinProceso

4. Escriba un seudocódigo tal, que, dados como datos el modelo de un vehículo y su precio,
determine el valor final que debe pagar el comprador. El concesionario está haciendo
descuentos teniendo en cuenta el modelo, con base en la siguiente tabla:

Haga uso de una enumeración. Defínala como un nuevo tipo. Además, una por defecto
que imprima “El modelo no es válido”
Resolucion:
1 Proceso Carros
2 Escribir "Se calculara el descuento dependiendo el automóvil, y el precio del
mismo"
3 Escribir "Ingrese el precio del automóvil"
4 Leer p
5 Escribir "----------------------------------------------"
6 Escribir "A continuación se daran los modelos, escoga el suyo según el numero:"
7 Escribir "Modelo 1 = Cutlass"
PRINCIPIOS DE ALGORITMOS

8 Escribir "Modelo 2 = Cavalier"


9 Escribir "Modelo 3 = Chevy"
10 Escribir "Modelo 4 = Century"
11 Leer op
12 Escribir "----------------------------------------------"
13 Segun op Hacer
14 1:
15 Escribir "Escogió Cutlass, con descuento de 8%"
16 Escribir "El precio a pagar con descuento es = ",(p *0.92)
17 2:
18 Escribir "Escogió Cavalier, con descuento de 5%"
19 Escribir "El precio a pagar con descuento es = ",(p *0.95)
20 3:
21 Escribir "Escogió Chevy con descuento de 6%"
22 Escribir "El precio a pagar con descuento es = ",(p *0.94)
23 4:
24 Escribir "Escogió Century con descuento de 9%"
25 Escribir "El precio a pagar con descuento es = ",(p *0.91)
26 De Otro Modo:
27 Escribir "El modelo no es válido"
28 FinSegun
29 Escribir "¡Gracias por su compra!"
30 FinProceso

5. En una tienda de descuento se efectúa una promoción en la cual se hace un descuento


sobre el valor de la compra total según el color de la bolita que el cliente saque al pagar
encaja. Si la bolita es de color blanco no se le hará descuento alguno, si es verde se le hará
un 10% de descuento, si es amarilla un 25%, si es azul un 50% y si es roja un 100%.
Determinar la cantidad final que el cliente deberá pagar por su compra. Se sabe que sólo
hay bolitas de los colores mencionados.
Resolución:
1 Proceso Color
2 Definir c Como Real
3 D<- 0
4 Escribir "Escriba el monto total a pagar:"
5 Leer total
PRINCIPIOS DE ALGORITMOS

6 Escribir "Escriba el color de la bolita de oferta segun las siguientes opciones:"


7 Escribir "1: blanco"
8 Escribir "2: verde"
9 Escribir "3: amarillo"
10 Escribir "4: azul"
11 Escribir "5: rojo"
12 Leer c
13 Segun c Hacer
14 1:
15 Escribir "No hay descuento el mionto a pagar es:",total
16 2:
17 D<- total-(total*0.1)
18 Escribir "Hay un descuento del 10% el monto a pagar es de: ",D
19 3:
20 D<- total-(total*0.25);
21 Escribir "Hay un descuento del 25% el monto a pagar es de: ",D
22 4:
23 D<- total-(total*0.50)
24 Escribir "hay un descuento del 50% el monto a pagar es de: ",D
25 5:
26 Escribir "Hay un descuento del 100% por lo que no hay cobro"
27 De Otro Modo:
28 Escribir "Color incorrecto";
29 FinSegun
30 FinProceso