Вы находитесь на странице: 1из 30

Команды на ZTE

enable  вход в режим конфигурации


(cfg)#show port 1-24 brief состояние всех портов (физическое)
(cfg)#show port 1-24 состояние всех портов (админское)
(cfg)#show port <portlist>  отображение полной информации о порте
(cfg)#show port <portlist> brief  отображение краткой информации о портах
(cfg)#show port <portlist> stat посмотреть ошибки на порту
(cfg)#clear port <portlist> stat почистить ошибки на порту
(cfg)#show vct port <portlist>  тест кабеля
(cfg)#show vlan просмотр вланов на свитче
(cfg)#set vlan <vlanlist> enable создание влана
(cfg)#set vlan <vlan> add port <portlist>  tag проброс транком влана на порту
(cfg)#set vlan  add port <portlist> untag  забрасывание аксесом влана на порт
(cfg)#set port <portlist> pvid <vlanlist>  указать аксесс влан на порту
(cfg)#set port <portlist> {enable|disable}  включить/выключить порт
(cfg)#set port <portlist> duplex {full|half|auto}  выбор дуплекса на порту
(cfg)#set port <portlist> speed {10|100|1000|auto}  выбор скорости на порту
(cfg)#set port <portlist> mdix {crossover|normal|auto}  выбор на порту стандарта обжимки конектор
(cfg)#set port <portlist> description <текст>  дескрипшен на порту
(cfg)#clear port <portlist> description  удалить дескрипшен на порту
(cfg)#set port <portlist> auto dis/en включение/отключение автосогласования на п
(cfg)#show fdb detail  просмотр всех маков на свитче
(cfg)#show fdb port <port> detail  просмотр маков на порту
(cfg)#show fdb mac <HH.HH.HH.HH.HH.HH> поиск мак-адреса на коммутаторе
(cfg)#show acl binding all просмотр "привязок" на свитче
(cfg)#show acl binding port  просмотр ацеелей на портах
(cfg)#show acl config <name>  просмотр аксесс-листа
(cfg)#set port <portlist> acl <name> dis/en включение/отключение acl на порту
(cfg)#show terminal log  просмотр логов свитча
(cfg)#show running-config  просмотр конфигурации свитча
(cfg)#show date-time просмотр текущего времени на коммутаторе
(cfg)#show cpu просмотреть загрузку процессора на коммута
(cfg)#show memory просмотр используемой памяти
(cfg)#saveconfig  сохранение конфигурации свитча
(cfg)#conf router что-бы поклирить арпы заходим в режим
(cfg-router)#clear arp клирим арпы
(cfg)#set pvlan session 1 add prom gepor <ports> isol port включить пвлан (аналог протект порта) на ко
<ports> (2900)
(cfg)#set vlan pvlan session 1 promis-port <ports> isolate-
включить пвлан на коммутаторе (2900E)
port <ports>
   
 set  

2928Е/2920E
(cfg)#sh mac dynamic  просматриваем все маки на коммутаторе
(cfg)#sh mac dynamic port <portlist> смотрим мак на конкретно взятом порту
(cfg)#show mac mac-address <HH.HH.HH.HH.HH.HH> поиск мак-адреса на коммутаторе
(cfg)#sh arp-inspection смотрим режим арп-инспекшена на портах
(cfg)#show terminal log include  <string> просмотр конкретного параметра в логе
(cfg)#show temperature просмотр температуры коммутатора
просмотр потребляемой коммутатором электр
(cfg)#show power
ватах
(cfg)#sh auto-saveconfig время самосохранения коммутатором своего
   
 set qos traffic-limit fe-port <1-24>  
 set qos traffic-shaping fe-port <1-24>  

ACL для шлюзующих роутеров


(cfg)#config acl extend number 108
(cfg)#rule 1 deny icmp any any
(cfg)#rule 2 permit tcp any any создаем привязку
(cfg)#rule 3 permit udp any any
(cfg)#rule 4 permit arp any any
(cfg)#set port <port> acl 108 enable вешаем привязку на порт

Перевод порта на DHCP (сделай скрипту донышко)


включить DHCP глобально на коммутароре (е
(cfg)#set dhcp snooping-and-option82 enable
выключен)
(cfg)#set port [номер порта] acl [номер порта] dis выключить ACL на порту
(cfg)#set dhcp port [номер порта] client
(cfg)#set dhcp snooping add port [номер порта] 
(cfg)#set dhcp ip-source-guard add port [номер порта]
прописать на порту абонента
(cfg)#set dhcp option82 add port [номер порта]
(cfg)#set dhcp option82 sub-option port [номер порта] circuit-
ID on cis
(cfg)#show dhcp snooping binding проверяем привязки на коммутаторе
(cfg)#set dhcp snooping del port [номер порта]
ЕСЛИ АБОНЕНТУ НУЖНО ВЕРНУТЬ СТАТ
(cfg)#set dhcp ip-source-guard del port [номер порта]
ПРОПИСЫВАЕМ НА ПОРТУ АБОНЕНТА
(cfg)#set dhcp option82 del port [номер порта]
(cfg)#saveconfig или write не забываем сохраняться (в зависимости от п
ВНИМАНИЕ!!! ЕСЛИ АБОНЕНТУ ВЫДАЛО СЕРУЮ IP НО НЕ ПУСКАЕТ НА БИНДЕР, Н
СМОТРЕТЬ ACL, И ЕСЛИ ОНА ЕСТЬ НА ПОРТУ - УДАЛЯТЬ (ТАК КАК С СЕРОЙ IP ИЗ ЗА AC
НЕ ПУСТИТ)
Команды на Edge-Core
sh interfaces status ethernet <1/ports> просмотр данных на порту
show mac-address-table interface ethernet <1/ports> смотрим какие маки на порту
show interfaces switchport ethernet <1/ports> смотрим параметры порта
show ip source-guard смотрим включен ли сорс-гард на портах
show ip source-guard binding смотрим привязки
configure входим в режим конфигурирования
(config)#ip source-guard binding <mac> vlan <vlan> <ip>
создать привязку
interface ethernet <1/ports>
(config)#no ip source-guard binding <mac> vlan <vlan> удалить привязку
(config)#interface ethernet <1/ports> заходим на порт
(config-if)#ip source-guard sip-mac включаем сорс-гард на порту
(config-if)#no ip source-guard выключаем сорс-гард на порту
(config-if)#switchport allowed vlan add <vlan>  untagged меняем влан на порту
(config-if)#switchport native vlan <номер влана> добавляем нативный влан на порт
(config-if)#speed-duplex [1000full | 100full | 100half | 10full |
спид и дуплекс
10half] 
(config-if)#ip dhcp snooping trust  включаем dhcp snooping  траст на порту
(config-if)#shutdown  уложить порт
(config-if)#no shutdown  поднять порт
(config)#vlan database  входим в список вланов на свиче
(config)#vlan <vlan> media ethernet state active  создаем влан
(config)#vlan <vlan> name IPTV media ethernet state active  создаем мультикастовый влан
show mac-address-table address <mac>  vlan 4000  смотрим светится ли конкретный мак
show mac-address-table address  vlan 4000  смотрим добегает ли 4000 влан до свича
show mac-address-table multicast просмотр мультикастовых груп на свиче
show mvr members  просмотр всех груп на свиче
show mvr members 230.33.0.1  просмотр активности конкретной группы
show interfaces brief состояние портов(только новая прошивка)
sh cable-diagnostics tdr int eth 1/1 просмотр состояния теста кабеля
copy running-config startup-config сохраняем конфиг
exit  выход/переход на низший уровень

Перевод порта на DHCP


ip dhcp snooping
ip dhcp snooping vlan {абонентский влан} глобально на коммутаторе прописываем эт
ip dhcp snooping information policy replace (если DHCP выключено)
ip dhcp snooping information option
ip dhcp snooping trust прописываем на транковых портах
no ip source-guard binding <mac> vlan <vlan> удаляем привязку
no ip dhcp snooping trust
прописать на порту абонента
ip source-guard sip-mac
show ip dhcp snooping binding проверяем привязки на коммутаторе
ip source-guard binding <mac> vlan <vlan> <ip> interface
ЕСЛИ АБОНЕНТУ НУЖНО ВЕРНУТЬ С
ethernet <1/ports>
ПРОПИСЫВАЕМ НА ПОРТУ АБОНЕНТ
no ip dhcp snooping trust
ip source-guard sip-mac
copy running-config startup-config не забываем сохраняться
Команды на D-Link
show switch просмотр snmp, iproute, ipif, hostname, cpu mac
enable admin войти в привелигированный режим
show firmware information просмотр прошивок в боксах памяти коммута
show utilization cpu просмотр загрузки процессора коммутатора
настройки консольного порта (необходимо зна
show serial
подключения к свитчу)
config address_b ip_mac ipaddress {ip} mac_address
изменить привязку
{mac} mode acl ports {x}
config address_b ip_mac ports {x-y} state enable включить привязку на порту
config address_binding ip_mac ports {x-y} ip_inspection
включить привязку на порту (модель 3200)
enable
create address_b ip_mac ipaddress {ip} mac_address
создать привязку
{mac} mode acl ports {x}
create address_b ip_mac ipaddress {ip} mac_address
создать привязку (модель 3200)
{mac} ports  {x}
delete address_b ip_mac ipaddress {ip} mac_address {mac} удалить привязку
config address_b ip_mac ports {x-y} state disable выключить привязку на порту 
config address_b ip_mac ports {x-y} ip_inspection disable выключить привязку (модель 3200)
logout выйти
save сохранить
show address_binding blocked посмотреть МАК-адреса которые блокируютс
show address_binding ip_mac посмотреть все привязки на коммутатре
show log вывести системный лог
enable address_binding trap_log включить логирование (посмотреть почему бл
show session просмотр текущих сессий (юзеров) на коммут

Порты:
show ports состояние портов
show ports {x} просмотр состояния порта x
show ports {x-y} просмотр состояния портов в диапазоне от x д
show ports {x-y, z} просмотр состояния портов в диапазоне от x д
show ports {x} description просмотреть дескрипшены на порту
config ports {x} description [...] создать дескрипшен на порту
config ports {x} speed 100/10-half/full изменить скорость порта
config ports {x} state disable положить порт
config ports {x} state enable поднять порт
config vlan vlanid <vlan> add untagged <port> добавление порта в влан
conf vlan <vlan> delete port <port> удаление порта с влана
просмотр состояния порта x и вывод его descr
show ports {x} description
(подписи)
просмотр портов, отключенных коммутатором
show ports {x} err_disabled
за петли)
просмотр форвард листов на всех портах (хож
show traffic_segmentation
между портами)
show traffic_segmentation {x} просмотр форвард-листа для порта x
show bandwidth_control {x} просмотр настроек разрешенной скорости (не
порту x
config traffic_segmentation 14 forward_list 25-28 разрешаем общатся порту 14 только через пор
show error_ports {x,y-z} просмотр ошибок на порту x, и портах с y по z
clear counters ports {x} почистить ошибки на порту х
show loopdetect ports {x} просмотр состояния механизма loopdetect на п
просмотр длины, статуса, типа соединения, ра
cable_diag ports {x}
кроссы за портом x
cable_diag ports all прозвонить кабель на всех портах
просмотр загрузки портов x-y (удобно ловить
show utilization ports x-y
порт)
show packet ports 21 просмотрите пакеты передаваемые портом
show mirror просмотр зеркалирующих портов на коммутат
show port_security просмотр механизмов port-security на портах
просмотр детальной инфы о порте, в том числ
show ports {x} det
скорости ап/давн лоад

Таблицы MAC-адресов
show fdb просмотреть таблицу mac-адресов
просмотреть за каким портом мак. MAC можн
show fdb mac
разделения октетов
show fdb port x просмотреть mac-адреса за портом x

Таблицы ARP:
show arpentry просмотреть таблицу ARP-записей
show arpetnty ipaddress x.x.x.x просмотреть запись для ip x.x.x.x
show arpentry ipif System просмотреть записи arp для интерфейса System

VLAN:
просмотреть vlan xxx – порты-участники, тран
show vlan xxx
акцессные
show vlan port x просмотреть настройки vlan на порту x
show vlan посмотреть все вланы на коммутаторе

STP:
show stp просмотр состояния stp на коммутаторе
просмотр уровня приоритета stp на коммутато
show stp instance 0
коммутатора 
show stp ports x,y просмотр состояния STP на портах x и y

Модель DES 3200


show address_binding просмотреть статус привязок
show address_binding ip_mac all просмотреть все привязки на коммутаторе
show address_binding blocked all просмотреть все маки которые блокируются
show address_binding ports просмотреть статусы привязок на портах
config address_binding ip_mac ports (port) ip_inspection
включение ACL
enable
Перевод порта на DHCP
show switch сначала определяем версию коммутатора
Для коммутаторов DES-3526:
enable dhcp_local_relay
enable address_binding dhcp_snoop глобально на коммутаторе прописываем эти ко
disable dhcp_relay DHCP выключено)
config dhcp_local_relay vlan [клиентский vlan] state enable
delete address_binding ip_mac ipaddress {ip} mac_address
удаляем привязку (если есть)
{mac}
config address_binding ip_mac ports [номер порта] state
enable 
config address_binding ip_mac ports [номер порта]
прописать на порту абонента
forward_dhcppkt enable
config address_binding ip_mac ports [номер порта]
allow_zeroip enable
show address_binding dhcp_snoop binding_entry проверяем привязки на коммутаторе
сделать статическую привязку и прописать настройки
ЕСЛИ АБОНЕНТУ НУЖНО РАБОТАТЬ НА С
если привязки отключены – просто прописать настройки
save не забываем сохраняться
Для коммутаторов DES-3200 (Hardware Version C1):
enable dhcp_local_relay
enable address_binding dhcp_snoop
disable dhcp_relay
глобально на коммутаторе прописываем эти ко
config dhcp_local_relay option_82 circuit_id default
DHCP выключено)
config dhcp_local_relay option_82 remote_id default
config dhcp_local_relay vlan vlanid [клиентский vlan] state
enable
delete address_binding ip_mac ipaddress {ip} mac_address
удаляем привязку (если есть)
{mac}
config dhcp_local_relay option_82 ports [номер порта] policy
replace
config address_binding ip_mac ports [номер порта]
arp_inspection strict
config address_binding ip_mac ports [номер порта]
ip_inspection enable
прописать на порту абонента
config address_binding ip_mac ports [номер порта] protocol
ipv4
config address_binding ip_mac ports [номер порта]
forward_dhcppkt enable
config address_binding ip_mac ports [номер порта]
allow_zeroip enable
show address_binding dhcp_snoop binding_entry проверяем привязки на коммутаторе
delete address_binding blocked all  удалить мак из блоков
сделать статическую привязку и прописать настройки
ЕСЛИ АБОНЕНТУ НУЖНО РАБОТАТЬ НА С
если привязки отключены – просто прописать настройки
save не забываем сохраняться
Для коммутаторов DES-3200 (Hardware Version А1/B1):
enable dhcp_local_relay
enable address_binding dhcp_snoop
глобально на коммутаторе прописываем эти ко
disable dhcp_relay
DHCP выключено)
config dhcp_local_relay vlan vlanid [клиентский vlan] state
enable
delete address_binding ip_mac ipaddress {ip} mac_address
удаляем привязку (если есть)
{mac}
config address_binding ip_mac ports [номер порта] state
прописать на порту абонента
disable
show address_binding dhcp_snoop binding_entry проверяем привязки на коммутаторе
сделать статическую привязку и прописать настройки ЕСЛИ АБОНЕНТУ НУЖНО РАБОТАТЬ НА С
если привязки отключены – просто прописать настройки
save не забываем сохраняться

Если МАК блочиться


show address_binding blocked all посмотреть заблокированые мак-адреса
config ports {x} state disable ложим нужный нам порт
config address_binding ip_mac ports [номер порта]
ip_inspection dis
config address_binding ip_mac ports [номер порта] выключаем либо арп и ип инспекшн, 
arp_inspection dis либо привязку в зависимости от модели
config address_binding ip_mac ports [номер порта] state
disable
delete address_binding blocked all удаляем все заблоченные мак-адреса
потом делаем привязку в ручную в биллинге (не поднимая порт, то есть - положили порт, выкл. привязку,
сделали привязку в ручную)
просмотр на сколько выдалась лиза (лицензия
show address_binding dhcp_snoop binding_entry
она закончиться
config ports {x} state enable когда лиза истекла - поднимаем порт
show address_binding dhcp_snoop binding_entry проверяем все ли ок
config address_binding ip_mac ports [номер порта]
ip_inspection enable
если все гуд - включаем арп и ип инспекшн
config address_binding ip_mac ports [номер порта]
arp_inspection strict
save не забываем сохраняться
Команды на Linksys
На Alcatel команды такие же, но писать нужно полностью а не сокращенн
show interfaces description посмотреть дескрипшен
(config-if)# description (текст дескрипшена) прописать дескрипшен
show interfaces status посмотреть состояния портов (физическое)
show interfaces configuration посмотреть состояние портов (админское)
show ip source-guard status посмотреть все привязки
show mac address-table просмотреть мас таблицы
show mac address-table 00:00:00:00:00:00 посмотреть конкретный адрес
show bridge address-table посмотреть все мак-адреса на свитче
show bridge address-table address "mac"  посмотреть на каком порту светится мак
show bridge address-table ethernet e[port]  посмотреть мак-адрес на порту
show interfaces status ethernet e[port]  посмотреть состояние порта
show interfaces counters ethernet e[port]  просмотр ошибок на порту
clear counters ethernet e[port]  очистка ошибок на порту
show vlan  посмотреть вланы на коммутаторе
show running-config посмотреть текущую конфигурацию  свитч
test copper-ports tdr e[port]  прозвонить кабель
show copper-ports cable-length просмотреть длину кабеля на гигабитках.
configure вход в режим конфигурирования
(config)#ip source-guard binding [mac-addr] [vlan] [ip] ethernet
создать привязку
e[port] 
(config)#no ip source-guard binding [mac-addr] [vlan]  удалить привязку
(config)#no ip source-guard снять правило привязок с свитча
(config)#sh access-lists просмотреть все аксесс-листы на коммутато
config)#show interfaces access-lists посмотреть какие аксесс-листы есть на всех
config)#show interfaces access-lists Ethernet [port] просмотреть аксесс-лист на конкретном пор
(config)#interface ethernet e [port]  зайти на порт
(config)#interface range ethernet e1-24 зайти на группу портов
(config)#interface vlan [vlan]  зайти на влан
(config)#interface range vlan [список вланов]  зайти на группу вланов
(config-if)#switchport access vlan [vlan]  меняем аксессовый влан на порту
(config-if)#switchport trunk allowed vlan add [vlan]  добавляем транковый влан по порт
(config-if)#shutdown  положить порт
(config-if)#no shutdown  поднять порт
(config-if)#speed 10/100  скорость порта
(config-if)#duplex full/half  дуплекс
(config-if)# negotiation включить автосаглосование на порту
(config-if)# no negotiation выключить автосаглосование на порту
(config-if)#ip source-guard  включить привязку
(config-if)#no ip source-guard  выключить привязку
(config-if)#no ip arp inspection trust отключить АРП
вкл протект порт на порту(общение только
(config-if)# switchport protected port <ports>
указанный порт)
(config-if)#port storm-control broadcast {enable | disable} включить | отключить шторм контроль
(config-if)#port storm-control broadcast rate {70-1000000} выставить ограничение на бродкаст трафик
(config-if)#port storm-control include-multicast добавить контроль мультикаст трафика
copy running-config startup-config сохранить изменения
задать общение абон-х портов только через
switchport protected-port fastethernet
порты
write  сохранить
console(config-if)#  no switchport access multicast-tv vlan удалить порт с мультикаст влана

AcL для шлюзующих роутеров


configure  заходим в режим конфигурации 
(config)#ip access-list testicmp 
(config)#deny icmp any any  создаем ацеельку
(config)#permit any any any 
interface ethernet e<port>  заходим на порт
(config-if)#no service-acl input  удаляем acl которая была до этого
(config-if)#service-acl input testicmp  назначим на на данному порту acl testicmp

Перевод порта на DHCP


ip dhcp snooping
ip dhcp information option
no ip dhcp snooping database
ip dhcp snooping vlan [клиентский vlan] глобально (в config) на коммутаторе пропис
ip arp inspection команды (если DHCP выключено)
ip arp inspection validate
ip arp inspection vlan [клиентский vlan]
ip source-guard
(config)#no ip source-guard binding [mac-addr] [vlan]  удаляем все статические привязки этого або
ip source-guard
no ip arp inspection trust прописать на порту абонента
no ip dhcp snooping trust
show ip dhcp snooping binding проверяем привязки на коммутаторе
ЕСЛИ АБОНЕНТУ НУЖНО РАБОТАТЬ НА СТАТИКЕ - ПРОСТО СОЗДАЕМ ПРИВЯЗКУ
просмотреть и
Команды на Extreme history
на коммутатор
create vlan <vlan name> создать влан
config vlan <old_name> name
переименовать влан
<new_name>
config <vlan name> tag 1000 установить влану vlanid 1000
config <vlan name> add port 1- забросить влан на порты аксесом
3 tagged (тегированый)
забросить влан транком на порт
config <vlan name> add port 9
(нетегированый, untagged)
show vlan {<name>} {detail} просмотр информации о влане
delete vlan <name> удалить влан с коммутатора
[enable | disable] ports поднять | уложить порт на
<portlist> коммутаторе
включить автосаглосование на
config ports <portlist> auto
порту
config ports <portlist> auto off выключить автосаглосование на
{speed [10 | 100 | 1000]} порту, установить скорость
duplex [half | full] и(или) дуплекс
config ports <all | portlist>
включить/выключить  
auto-polarity <off | on>
сбросить автосогласование,
restart ports <portlist> 
ресетнув линк
show ports {<portlist>} просмотр коллизий на порту(ах)
collisions в реальном времени
show ports {<portlist>} info просмотреть информацию о
{detail} порте
просмотр статистики пакетов на
show ports {<portlist>} packet
порту в виде глистограммы
просмотр статистики по порту в
show ports {<portlist>} stats
реальном времени
просмотр колличества ошибок
show ports {<portlist>} rxerrors
полученных данных
просмотр колличества ошибок
show ports {<portlist>} txerrors
переданных данных
show ports {<portlist>}
просмотр загрузки порта
utilization
show sharing address-based просмотр
unconfig ports <portlist>
сброс
display-string <string>
config ports <portlist> display-
 
string <string>
просмотр времени работы
show switch
коммутатора
просмотреть маки нс
show mac
коммутаторе
show fdb {<mac_address> | просмотреть маки (или
vlan <name> | ports <portlist> | конкретный мак) во влане | на
permanent} порту | на портах
clear fdb [{<mac_address> | поклирить маки(или конкретный
vlan <name> | ports <portlist>}]мак) во влане | на порту
create access-list <name> создать ацеельку
delete access-list <name> удалить ацеельку
show access-list {name | ports просмотреть ацеельку | ацеельки
<portlist>} на порту(портах)
просмотреть версию прошивки
show version
коммутатора
включить igmp снупинг
enable igmp snooping
глобально
отключить igmp снупинг
disable igmp snooping
глобально
disable igmp {vlan <name>} отключить igmp снупинг во влане
clear igmp snooping {vlan очистьть настройки igmp
<name>} снупинга во влане
unconfig igmp сбросить все настройки igmp
show igmp snooping {vlan просмотреть данные igmp
<name>} {detail} снупинга во влане
sh igmp group просмотр групп
save сохранить конфигурацию
logout или quit выйти с коммутатора
Команды на Quidway
<Sw> disp ver просмотреть данные о прошивке коммутатора
<Sw> display current-configuration просмотреть конфигурацию коммутатора  
<Sw> display current-configuration configuration XXXX вывод настроек секции XXXX
<Sw>  display saved-configuration просмотр сохраненной конфигурации 
просмотреть логи по езернет портам (поднятия и
<Sw> disp log | include Ethernet
падения)
<Sw> disp log | include DOWN просмотреть падения в логах
<Sw> disp log | include Jan 18 просмотреть логи на коммутаторе за выбранную д
<Sw>  display time-range all узнать время на коммутаторе
<Sw> display interface brief просмотреть информацию о портах
<Sw> display brief interface просмотреть информацию о портах
<Sw> display brief interface | in UP  просмотреть информацию о портах в апе
просмотреть информацию о портах в дауне, включ
<Sw> display brief interface | in DOWN 
админ
<Sw> display interface Ethernet brief | in [номер порта] просмотреть данные о конкретном порте
<Sw> display interface Ethernet brief | in [номер порта] просмотреть данные о конкретном порте
<Sw> dis port vlan Ethernet 0/0/1  просмотр вланы на 100 мегабитногм порту  
<Sw> dis port vlan GigabitEthernet 0/0/1  просмотреть вланы на гигабитке
<Sw>  disp mac-address dynamic Ethernet 0/0/1  посмотреть маки на стомегабитном порту 
<Sw>  disp mac-address dynamic GigabitEthernet 0/0/1  посмотреть маки на гигабитке 
<Sw>  disp mac-address dynamic  просмотреть все маки 
<Sw>  disp mac-address f4ec-38d6-a55c  просмотреть конкретный мак на коммутаторе 
<Sw>  dis mac-address dynamic vlan [номер влана]  просмотреть маки в конкретном влане 
<Sw> display port-isolate group all просмотреть все изолированные порты 
<Sw> system-view перейти в режим конфигурирования
перейти в режим конфигурирования (сокращенная
<Sw> sys
команда)
[Sw] interface gigabitethernet 0/0/1 заходим на гигабитный порт
[Sw] int gi0/0/1 заходим на гигабитный порт (сокращенная команд
[Sw-GigabitEthernet0/0/1] port link-type trunk переводим порт в транк
[Sw-GigabitEthernet0/0/1] port trunk allow-pass vlan
забрасываем влан на порт
<vlan>
[Sw-GigabitEthernet0/0/1] quit выходим с режима конфигурирования порта
[Sw] interface Ethernet 0/0/1 заходим на стомегабитный порт
[Sw-Ethernet0/0/1 virtual-cable-test протестировать порт(тест кабла на порту)
[Sw-Ethernet0/0/1] shutdown положить порт
[Sw-Ethernet0/0/1] undo shutdown поднять порт
[Sw-Ethernet0/0/1] port link-type access  переводим порт в аскесс
[Sw-Ethernet0/0/1]  port default vlan (vlan) забрасываем аксесный влан на порт
если при вводе выводит ошибку, то ввести port hybrid untagged vlan 1
[Sw-Ethernet0/0/1] display this  вывод конфигурации текущей секции
int XXX заходим на порт
auto speed 100 установить скорость в 100
auto duplex full установить дублекс в фулл
<Sw> display users просмотреть кто с юзеров висит на коммутаторе
[Sw] undo [команда] для отмены введенной команды
<Sw>  display this просмотр настроек режима, в котором сейчас нахо
<Sw>  save сохранить конфиг
[Sw] return выход в режим пользователя из любого режима
<Sw> quit выйти с коммутатора

Основные команды для диагностики STP на коммутаторах тип


Huawei:
[Sw] disp stp brief  
[Sw] disp stp  
[Sw] disp stp interface  
[Sw] stp interface GigabitEthernet 0/0/1 to 0/0/24 disable отключение стп на абонских портах с 1 по 24
Команды на FoxGate
show version Просмотр информации о коммутаторе
show interface brief Просмотр состояния портов
show interface brief ethernet 0/0/1 Просмотр состояния конкретного порта
show interface brief ethernet 0/0/1 to ethernet 0/0/3 Просмотр состояния диапазона портов
show interface brief ethernet 0/0/1 ethernet 0/0/4 Просмотр состояния выбранных портов
Просмотр информации об sfp модулях на портах
show interface sfp
коммутатора
show interface sfp ethernet 0/0/1 Просмотр информации об sfp на конкретном порту
show interface Просмотр информации о всех портах коммутатора
sh statistics interface ethernet 0/0/1 Просмотр статистики (ошибок) на порту
show interface ethernet 0/0/1 Просмотр информации о порте
show interface ethernet 0/0/1 to ethernet 0/0/3 Просмотр информации о группе портов
show description interface Посмотреть дескрипшен
show description interface ethernet 0/0/1 Посмотреть дескрипшен на порту
show mac-address-table Просмотр маков на коммутаторе
sh mac-address-table vlan 1880 Просмотр маков во влане
sh mac-address-table interface ethernet 0/0/1 Просмотр маков на порту
sh mac-address-table interface ethernet 0/0/3 vlan 1180 Просмотр маков на порту по определенному влану
sh mac-address-table H:H:H:H:H:H Просмотр мака на коммутаторе
sh mac-address-table H:H:H:H:H:H vlan 1180 Просмотр мака в конкретном влане на коммутаторе
show multicast Просмотр параметров мультикаста
show multicast igmp-snooping interface Просмотреть все подписки на коммутаторе
show multicast igmp-snooping interface ethernet 0/0/1 Просмотреть подписки на конкретном порту
show multicast igmp-snooping ip-address 239.99.0.3 Просмотреть подписки по выбранной групе
show igmp-snooping Просмотр информации об игмп снупинге
show igmp-snooping profile Просмотр информации о профилях снупинга
sh vlan Просмотр полной информации о вланах
sh vlan brief Просмотр информации на какие порты закинут влан
sh vlan brief 1880 Просмотр информации на кокие порты закинут влан
show cpu-utilization Просмотр загрузки процессора
sh ip-source-guard Просмотр параметров привязок
sh ip-source-guard bind Просмотр сконфигурированных привязок
sh running-config Просмотр конфигурации коммутатора
enable Перейти в привелегированный режим
switchport mode access Делаем порт аксесным
switchport default vlan 1180 Забрасываем влан на порт
switchport mode trunk Делаем порт транковым
switchport trunk allowed vlan 1180,1880,4080 Забрасываем транком вланы
configure Переход в режим конфигурирования
interface ethernet 0/0/1 или int e0/0/1 Зайти на порт 1
shutdown Сложить порт
no  shutdown Поднять порт
copy running-config startup-config Сохранить конфиг
write running-config startup-config Сохранить конфиг
Перевод порта на DHCP
dhcp option82 глобально на коммутаторе прописываем эти команд
dhcp-snooping DHCP выключено)
ip-source-guard ip-mac-vlan
прописать на порту абонента
no dhcp-snooping trust
show dhcp-snoop client проверяем привязки на коммутаторе
если нужно работать на статике - прописываем на п
no ip-source-guard ip-mac-vlan 
абонента
Команды на ZyXEL(Зухель,Зиксель
enable (пароль 1234) Перейти в привелегированный
configure вход в режим конфигурации
show version Просмотр информации о прош
show system-information Просмотр информации о комм
show interfaces 1-24 посмотреть состояния портов (
show interfaces 1  Просмотр состояния конкретно
show interfaces config 1-28 посмотреть состояние портов (
show interfaces transceiver 1-24 Просмотр информации об sfp м
show interfaces transceiver 1 Просмотр информации об sfp н
show mac-address-table all Просмотр маков на коммутатор
show mac-address-table port 1 Просмотр маков на порту
show mac-address-table port 25 <MAC|VID|PORT> Просмотр маков с сортировкой
show mac address-table mac H:H:H:H:H:H Просмотр мака на коммутаторе
show multicast  
show multicast vlan Просмотреть все подписки на
show multicast igmp-snooping ip-address 239.99.0.3 Просмотреть подписки по выб
show igmp-snooping  Просмотр информации об игм
show igmp-snooping group all  Просмотр iptv подписок и друг
show vlan Просмотр полной информации
show vlan  1880 Просмотр информации на коки
show cpu-utilization Просмотр загрузки процессора
show dhcp snooping Информация о DHCP снупинге
show dhcp snooping binding Просмотреть привязки на комм
show ip source binding Просмотр привязок статикой н
show loopguard Просмотреть информацию о вк
show  multi-login Просмотр юзеров на коммутат
show logging Просмотреть логи на коммутат
show time Просмотреть данные о времен
show spanning-tree config Просмотреть данные о настрой
show memory Просмотреть сколько использу
write memory Сохранить конфиг
Команды на BDCOM-e(для EPO
enable (пароль bdcom) Перейти в приве

show version Просмотр инфор


show epon active-onu Посмотреть все а
show epon onu-information Просмотреть спи
show mac address-table interface epON 0/1:1 Просмотр маки н
show epon interface epON 0/1:1 onu mac address-table Посмотреть маки
sh mac address-table  10fe.edc0.a833 Просмотр где св
   
show epon optical-transceiver-diagnosis Посмотреть пара
show epon interface epON 0/1:1 onu ctc optical-transceiver-diagnosis Посмотреть пара
   
show epon interface epON 0/1:1 onu pon-port statistics Просмотр статис
show interface ePON 0/1:1  Просмотр статис
   
show epon interface ePON 0/1:1  onu ctc basic-info Просмотр инфор
Просмотр инфор
show epon interface ePON 0/1:1 onu port 1 state
порту)
show epon interface epON 0/1:1 onu port 1 statistics Просмотр статис
show epon interface ePON 0/1:1 onu port 1 ctc flow-control Просмотр состоя
show epon interface ePON 0/1:1 onu port 1 ctc auto-negotiation Просмотр включ
 Просмотр устан
show epon interface ePON 0/1:1 onu port 1 ctc ratelimit-ingress
онушки
clear l2 counters interface ePON 0/1:1 Очистить счетчи
   
show ip dhcp-relay snooping statistics  Просмотр глоба
show ip dhcp-relay snooping binding all Просмотреть все
   
show cpu Просмотреть дан
show spanning-tree Просмотреть дан
 
Команды на ISCOM (Raiseco
enable (пароль zxr10)  или raisecom Перейти в привелегированный ре
configure вход в режим конфигурации
show version Просмотр информации о прошив
show interface port description Просмотр информации о дескрип
show interfaces port посмотреть состояния портов (фи
show interfaces port 1  Просмотр состояния конкретного
show interfaces port 1 switchport посмотреть состояние портов (ад
show interfaces port 1 transceiver Просмотр информации об sfp на к
show mac-address-table l2-address Просмотр маков на коммутаторе
show mac-address-table l2-address port 2 Просмотр маков на порту
show mac-address-table l2-address vlan <VID> Просмотр маков по влану
show mac-address-table l2-address | include HH.HH.HH Просмотр мака на коммутаторе
show ip dhcp snooping binding Просмотреть привязки
show mac-address-table multicast  
show multicast vlan Просмотреть все подписки на ком
show multicast igmp-snooping ip-address 239.99.0.3 Просмотреть подписки по выбран
show igmp-snooping  Просмотр информации об игмп с
show igmp-snooping group all  Просмотр iptv подписок и других
show vlan Просмотр полной информации о
show vlan  1880 Просмотр информации на кокие п
show cpu-utilization Просмотр загрузки процессора
show dhcp snooping Информация о DHCP снупинге
show dhcp snooping binding Просмотреть привязки на коммут
show ip source binding Просмотр привязок статикой на к
show loopguard Просмотреть информацию о вклю
show  multi-login Просмотр юзеров на коммутаторе
show logging Просмотреть логи на коммутатор
show time Просмотреть данные о времени н
show spanning-tree config Просмотреть данные о настройка
show memory Просмотреть сколько используетс
write memory Сохранить конфиг
Cisco
show arp | include <ip> просмотр арпов по IP
show arp | include <mac> просмотр арпов по макам
sh mac- | in [mac-adr] на каком порту абон
sh ip igmp membership просмотр подписок
sh ip igmp membership | in 239.10 просмотр конкретной подписки
sh mac- dy add [mac] просмотр мака, на каком он порту
sh mac- dy int [int] просмотр маков на порту
sh ip ro просмотр роутов
sh proc cpu просмотр загрузки проца
sh int description | in [№ кольца] просмотр дескрипшена по аргументу

ZTE
sh processor просмотр загрузки процессора
sh ip ro просмотр роутов
sh interface description просмотр дескрипшенов и статусов портов на узле
sh interface brief просмотр полной информации о портах на узле
show arp dynamic | include <ip> просмотр арпов по IP
show arp dynamic | include <mac> просмотр арпов по макам
просмотр информации о супинге на узле(также видно
sh ip igmp snooping
какая группа с какого порта приходит)
sh ip igmp groups просмотр всех подписок на узле
sh ip igmp groups vlan [номер
просмотр всех подписок в конкретном влане
влана]
просмотр количества активных подписок на узлу, по
sh ip igmp groups summary
вланах
sh ip igmp groups 239.103.3.1 просмотр подписок по конкретной мультикастовой группе
просмотр статистики пакетов за время работы igmp
sh ip igmp snooping statistic
снупинга
sh ip igmp snooping statistic
просмотр статистики на конкретном интерфейсе узла
interface gei_1/4
sh ip igmp snooping vlan 4040 просмотр информации о снупинге в конкретном влане
sh ip igmp snooping statistic clear поклирить статистику количества пакетов снупинга

Huawai
display arp dynamic | include <ip> просмотр арпов по IP
display arp dynamic | include
просмотр арпов по макам
<mac>
display igmp group | include просмотр конкретной подписки
display ip routing-table <ip> просмотр роутов
ПАРОЛЬ НА УЗЕЛ
логин DUTY пароль SUPPORT1
АГРЕГАЦИИ HUAWEI

Juniper
show arp | match <ip> просмотр арпов по IP
show arp | match <mac> просмотр арпов по макам
show bridge mac-table | match
просмотр мака, на каком он порту
<mac>
show bridge mac-table interface xe-
просмотр маков на порту
4/1/1.0
show route <ip> просмотр роутов
ПАРОЛЬ НА УЗЕЛ логин DUTY пароль SUPPORT
show bridge domain v[номер
просмотреть куда заброшен влан
влана]
show bridge mac-table vlan-id
просмотреть маки в влоне
[номер влана, v2128]
show interfaces descriptions просмотр дескрипшена
show interfaces descriptions | match просмотр дескрипшена по аргументу
ZTE
show acl binding port
show acl config <name>
config acl extend number 105
rule 1 permit ip ХХХ.ХХХ.ХХХ.ХХХ 255.255.255.255 any

rule 2 permit ip any ХХХ.ХХХ.ХХХ.ХХХ255.255.255.255

rule 500 deny ip any any


exit
set port 5 acl 105 enable
Включаем привязки на свтче
set dhcp snooping-and-option82 enable

set dhcp snooping add port [порт абонента]


set dhcp ip-source-guard add port [порт абонента]
set dhcp option82 add port [порт абонента]
Создание и удаление(очистка) привязки
sh dhcp snooping binding
set dhcp snooping bind-entry mac [mac-адрес абонента] ip [ip абонента] vlan [влан абонента] port [порт
абонента]
clear dhcp snp-bind-entry mac [mac-адрес абонента]
Отключаем привязки
set dhcp snooping-and-option82 disable
set dhcp ip-source-guard delete port [порт абонента]
set dhcp snooping delete port [порт абонента]

set dhcp option82 delete port [порт абонента]

Edge-Core
showip so

show ip so bin
no ip so bin xx-xx-xx-xx-xx-xx vlan [влан]
ip so sip-mac
no ip so
D-Link
show add ip
cre add ip ip [ip address] mac [mac-address] mode acl port [port]
con add ip ip [ip address] mac [mac-address] mode acl port [port]
del add ip ip [ip address] mac [mac address]
delete address_binding ip_mac ipaddress айпи mac_address мак
con address_binding ip_mac ports [port] state enabled
con address_binding ip_mac ports [port] state disable

Linksys
show ip source-guard
ip source-guard
no ip source-guard
ip source-guard binding [mac-addr] [vlan] [ip] ethernet [port]
НАСТРОЙКА дхцп
 Коммутатор Linksys

Для работы абонента по DHCP (настройка порта абонента вручную), необходимо:

1.  На коммутаторе, глобально (config), прописать команды:

ip dhcp snooping
ip dhcp information option
no ip dhcp snooping database
ip dhcp snooping vlan [клиентский vlan]

ip arp inspection
ip arp inspection validate
ip arp inspection vlan [клиентский vlan]

ip source-guard

2.  Удалить привязку.

3.  На порту абонента прописать команды:

ip source-guard
no ip arp inspection trust
no ip dhcp snooping trust

4.  Провертить привязки на коммутаторе:

show ip dhcp snooping binding

Если абоненту нужно работать на ручных настройках, необходимо:

1.  Создать привязку.

2.  На порту абонента прописать команду:

no ip dhcp snooping trust

                                                               На узле агрегации Cisco (для старших смены).

В режиме просмотра доступно:

Вводим  команду sh running-config interface vlan (клиентский vlan, в примере 9) .

Получаем информацию:

1 –  наличие серых сеток, количество серых сеток должно ровняться количеству белых!!!Если серых
сеток меньше, возможно  

где то не будет работать DHCP.

2  – адрес DHCP сервера (адрес сервера можно посмотреть по  http://host.o3.ua/spravochnik/?


section=dhcp_con&id=426 ).

Коммутатор ZTE

 Для работы абонента по DHCP (настройка порта абонента в ручную), необходимо:

1.  На коммутаторе, глобально, прописать команду:

set dhcp snooping-and-option82 enable

2.  Удалить acl на порту.

3.  На порту абонента прописать команды:

set dhcp port [номер порта] client  


set dhcp snooping add port [номер порта] 
set dhcp ip-source-guard add port [номер порта]
set dhcp option82 add port [номер порта]
set dhcp option82 sub-option port [номер порта] circuit-ID on cisco

4.  Проверить привязки на коммутаторе:

show dhcp snooping binding

Если абоненту нужно работать на ручных настройках, необходимо:

set dhcp snooping del port [номер порта]

set dhcp ip-source-guard del port [номер порта]

set dhcp option82 del port [номер порта]

ВНИМАНИЕ!!! ЕСЛИ АБОНЕНТУ ВЫДАЛО СЕРУЮ IP НО НЕ ПУСКАЕТ НА БИНДЕР, НУЖНО


СМОТРЕТЬ ACL, И ЕСЛИ ОНА ЕСТЬ НА ПОРТУ - УДАЛЯТЬ (ТАК КАК С СЕРОЙ IP ИЗ ЗА ACL НЕ
ПУСКАЕТ НА САЙТ).
На узле агрегации  ZTE (для старших смены).

В режиме просмотра доступно:

Вводим  команду sh running-config interface vlan (клиентский vlan, в примере 18) .

Получаем информацию:

1 –  наличие серых сеток, количество серых сеток должно ровняться количеству белых!!!Если серых
сеток меньше, возможно где то не будет работать DHCP.
2 –  включен ли во влане DHCP.

3  – адрес DHCP агента.+_

4  – адрес DHCP сервера (адрес сервера можно посмотреть по  http://host.o3.ua/spravochnik/?


section=dhcp_con&id=426 ).

                                                                                         Коммутатор D-Link

Для начала определите версию коммутатора командой:

show  switch

Для коммутаторов DES-3526:

1.  На коммутаторе, глобально, прописать команды:

enable dhcp_local_relay
enable address_binding dhcp_snoop
disable dhcp_relay
config dhcp_local_relay vlan [клиентский vlan] state enable

2.  Удалить привязку.

3.  На порту абонента прописать команды:


config dhcp_local_relay option_82 ports [номер порта] policy replace

config address_binding ip_mac ports [номер порта] state enable  


config address_binding ip_mac ports [номер порта] forward_dhcppkt enable
config address_binding ip_mac ports [номер порта] allow_zeroip enable

4.  Проверить привязки на коммутаторе:

show address_binding dhcp_snoop binding_entry


Если абоненту нужно работать на ручных настройках, необходимо:

- сделать статическую привязку и прописать настройки

- если привязки отключены – просто прописать настройки

Для коммутаторов DES-3200 (Hardware Version C1):

1. На  коммутаторе, глобально, прописать команды:

enable dhcp_local_relay
enable address_binding dhcp_snoop
disable dhcp_relay
config dhcp_local_relay option_82 circuit_id default
config dhcp_local_relay option_82 remote_id default
config dhcp_local_relay vlan vlanid [клиентский vlan] state enable
2.  Удалить привязку.

3.  На порту абонента прописать команды:

config dhcp_local_relay option_82 ports [номер порта] policy replace


config address_binding ip_mac ports [номер порта] arp_inspection strict
config address_binding ip_mac ports [номер порта] ip_inspection enable
config address_binding ip_mac ports [номер порта] protocol ipv4
config address_binding ip_mac ports [номер порта] forward_dhcppkt enable
config address_binding ip_mac ports [номер порта] allow_zeroip enable

4.  Проверить привязки на коммутаторе:

show address_binding dhcp_snoop binding_entry

5.Если на свиче блокирует мак (переключался между компьютером и роутером или  

подключал другое устройство).

delete address_binding blocked all  

Если абоненту нужно работать по статике, необходимо:

- сделать статическую привязку и прописать настройки

- если привязки отключены – просто прописать настройки

Для коммутаторов DES-3200 (Hardware Version А1/B1):

1. На  коммутаторе, глобально, прописать команды:

enable dhcp_local_relay
enable address_binding dhcp_snoop
disable dhcp_relay
config dhcp_local_relay vlan vlanid [клиентский vlan] state enable

2.  Удалить привязку.

3.  На порту абонента прописать команду:

config address_binding ip_mac ports [номер порта] state disable

4.  Проверить привязки на коммутаторе:

show address_binding dhcp_snoop binding_entry

Если абоненту нужно работать по статике, необходимо:

- сделать статическую привязку и прописать настройки

- если привязки отключены – просто прописать настройки

Коммутатор Edge-Core
1.  На коммутаторе, глобально, прописать команды:

ip dhcp snooping
ip dhcp snooping vlan {абонентский влан}   !!!!
ip dhcp snooping information policy replace
ip dhcp snooping information option

2. На транкових портах прописать.

ip dhcp snooping trust     !!!!

3.  Удалить привязку.

4.  На порту абонента прописать команду:

no ip dhcp snooping trust

ip source-guard sip-mac        !!!!

5.  Проверить привязки на коммутаторе:

show ip dhcp snooping binding

Если абоненту нужно работать на ручных настройках, необходимо:

1.  Создать привязку.

2.  На порту абонента прописать команду:

no ip dhcp snooping trust

ip source-guard sip-mac

                                                                                       Коммутатор Foxgate
1.  На коммутаторе, глобально, прописать команды:

dhcp option82
dhcp-snooping

2.  На порту абонента прописать команды:

ip-source-guard ip-mac-vlan
no dhcp-snooping trust

3.  Проверить привязки на коммутаторе:

show dhcp-snoop client

Если абоненту нужно работать по статике, необходимо прописать команды:


no ip-source-guard ip-mac-vlan  

Коммутатор Iscom

ip dhcp snooping

ip dhcp snooping information option

interface range 25-28

ip dhcp snooping trust

На узле агрегации  Huawei (Quidway) (для старших смены).

В режиме просмотра доступно:

Вводим команду  sh running-config interface vlan (на узлах агрегации Huawei (Quidway) на данный


момент выбрать конкретный влан нет возможности, выводится список конфигурации всех
вланов в котором можно выбрать нужный Вам ) .

Получаем информацию:

1 –  наличие серых сеток, количество серых сеток должно ровняться количеству белых!!!Если серых
сеток меньше, возможно где то не будет работать DHCP.

2 –  включен ли во влане DHCP.

3  – адрес DHCP сервера (адрес сервера можно посмотреть по  http://host.o3.ua/spravochnik/?


section=dhcp_con&id=426 ).