You are on page 1of 33

c

LimkokwingInst of
Creative Technology,
Kuching
Attempt 1

— —  
 
—  
 

—
tudent Number: 0876164/1
— 
Faculty of cience and Technology
— 

—
Module Code / Occ / Year EJ215004S / LU1 / 2010/1
Module Title ROUTING PROTOCOL AND CONCEPTS
Module Element 010 - PORTFOLIO PREPARATION 3000 WORD
To be marked by UMAN ubmission date (by 5p.m.) 29/12/2010
 
       
 c
cc c c
 c c c c cc  cc c cc 
c c cc c c c cc   c c c
 c cc  c c cc  c c
  cc cc c cc


 c cc   cc c
c c  c c  c c
cc c
c
   cc c cc  ccc c c c cc  c c   c   c c ccc c   c c
c cc cc c c c
  c ccc cc c cc c ccc c cc
 c c c c

D   

   !"

—



#—$
 
  %


)&
!$ & " 

&'&((((((((((((((((((((((( &(((((((((((((((( 
c c
c

c c
 c  c
 c  IBECHIODO EMMANUEL SYLVANUS\
c  0876164/1
 c  06/01/2011
 c  ROUTING PROTOCOL AND CONCEPTS
 c  EJ215004S / LU1 / 2010/1 / 011 - ASSIGNMENT
4500 WORDS
  cc c  

 c   c cc c!"c


 c

#$ $c%$$#c&'c$$#&cc c ($c# $c c


)$&c*c+,c-$c$&
$c+c
#+
&+c+(c&'c$$#&.

c c
 c  c
 c  IBECHIODO EMMANUEL SYLVANUS
c  0876164/1
 c  06/01/2011
 c  ROUTING PROTOCOL AND CONCEPTS
 c  EJ215004S / LU1 / 2010/1 / 011 - ASSIGNMENT
3000 WORDS
  cc c  

 c   c cc c!"c


 c

#$ $c%$$#c&'c$$#&cc c ($c# $c c


)$&c*c+,c-$c$&
$c+c#+
&+c
+(c&'c$$#&.
c c
& -$c+(c+&$&cc
1.0 INTRODUCTION ............................................................................................................................. 5
2.0 NETWORK DESIGN BACKGROUND ............................................................................................ 5
3.0 NETWORK DESIGN ........................................................................................................................ 6
4.0 CABLING ......................................................................................................................................... 6
5.0 ADDRESSING SCHEME ................................................................................................................. 7
6.0 NETWORK ADDRESSING SCHEME ............................................................................................. 8
7.0 ASSIGNED ADDRESS TO EACH PC .............................................................................................. 9
8.0 ROUTER CONFIGURATION ........................................................................................................ 10
9.0 ROUTER CONFIGURATION FILE ............................................................................................... 11
9.1 ENABLING PASSWORD FOR ROUTERS ................................................................................ 11
9.2 CONFIGURATION OF EIGRP ON ROUTERS .......................................................................... 12
9.3 VIRTUE ROUTER EIGRP CONFIGURATION .......................................................................... 12
9.4 DUAL NEIGHBORS TABLE...................................................................................................... 13
9.5 LOOPBACK CONFIGURATION ............................................................................................... 13
10.0 CONFIGURATION OF STATIC ROUTE ..................................................................................... 13
11.0 TESTING ...................................................................................................................................... 14
12.0 TEST LOG .................................................................................................................................... 15
13.0 TEST LOG RESULT ..................................................................................................................... 16
14.0 TEST FOR EIGRP AND COVERGENCE ..................................................................................... 27
14.0 HQ ROUTER ROUTING TABLE ................................................................................................. 28
14.1 REMOTE 1 ROUTER ROUTING TABLE ................................................................................ 29
14.2 REMOTE 2 ROUTER ROUTING TABLE ................................................................................ 30
CONCLUSION ..................................................................................................................................... 31
c
QUESTION 1

!./c&+
&+c
The design of this network implements the virtue connection of ISP router with the head quarter with
multiple locations, two to be précised. Communication within the routers is via enhanced interior gateway
routing protocol (EIGRP).

0./c$&*+%c$)c- %)+
c
This report is a routing design for UK based travel agency (UKTA). This report use enhanced interior
gateway routing protocol (EIGRP) for design and implementation of interconnected multiple locations
from single internet service provider. This network logical topology consist of four network directly
connected to the head quarter router. A total of three routers are used in this network, this routers are
configured to implement EIGRP routing protocol within the network.

Figure 1: network topology

From the network design above both the physical and logical network topology can be obtained. Using
the above topology an address scheme was created to accommodate the entire host in the network. For
achieving this, the private internetwork protocol provided 192.168.156.0/22 needs to be sub-netted.
-./c$&*+%c$)c
The network design consists of three routers, HQ, REMOTE 1 and REMOTE 2. REMOTE 1 and
REMOTE 2 are connected to HQ via WAN. Other connected network is Fa0/0 and Fa0/1 on the HQ
router and same for REMOTE 1 and REMOTE 2.

Figure 2: network design

1./c -)c
While design this network assumption where made based on the number of host of each subnet. Each
subnet where allocated required amount of switch necessary for connection of host. HQ Fa0/0 was
allocated 5 switches, Fa0/1 three switches, REMOTE1 Fa0/0 two switches, Fa0/1 three switches,
REMOTE2 Fa0/1 three switches and Fa0/0 six switches In most case extra port where left this is meant
for use in case of physical growth of the network topology. WAN connection is used for connection
within the router, straight through cable is used for connecting router to switch and switch to pc, while
cross over is used for connection between switch to switch.
è./c $)c'$$c
The private network address of 192.168.156.0/22 has been given. EIGRP being a distance vector routing
protocol is used for routers packet transfer and communication. EIGRP being a classless routing protocol
support variable length subnet mask. Classless internetwork protocol was used to design the addressing
range for the devices in this network, helping in making maximum use of the ip and limiting ip wastage
as possible.

The addressing given was sub-netted to provide the eight available subnet address used for this network.
The first sub-netting starts from HQ Fa0/0 subnet. This reason why the subnet was start at the HQ Fa0/0
is because it had the highest number of host in the HQ, grouping them into the same sub-net will provide
sharing of resources.

Loopback interface address given 189.54.69.234/30 was assigned for it designated subnet. This is because
the ISP router is a virtual interface for management purpose. Unlike the proper loopback address that is
used for ping within system this is used within the network, it does not talk back at itself. The ISP router
is a virtue router because first it don not exist in the network topology but is used because most loopback
functionality is provided by ISP router.

Please see below table for address scheme.


./c$&*+%c $)c'$$c
$2$c &$( $c 
-$c +(c 
-$& $c 
-$&c %c -+  &c
$ -$c $c $(
&c) &$* ,c
'+&c $c
HQ Fa0/0 90/25 192.168.156.0 255.255.255.128 192.168.156.127 192.168.156.1 ± 192.168.156.1
192.168.157.126
Fa0/1 60/26 192.168.156.128 255.255.255.192 192.168.156.191 192.168.156.129 - 192.168.156.129
192.168.156.190
S0/0/1 2/30 192.168.158.96 255.255.255.252 192.168.158.99 192.168.158.97 - 192.168.158.97
192.168.158.98
S0/0/0 2/30 192.168.158.100 255.255.255.252 192.168.158.103 192.168.158.101 ± 192.168.158.101
192.168.158.102
REMOTE1 Fa0/0 30/27 192.168.158.64 255.255.255.224 192.168.158.95 192.168.158.65 - 192.168.158.65
192.168.158.94
Fa0/1 60 /26 192.168.156.192 255.255.255.192 192.168.156.225 192.168.156.193 - 192.168.156.193
192.168.156.224
S0/0/1 2/30 192.168.158.96 255.255.255.252 192.168.158.99 192.168.158.97 - 192.168.158.97
192.168.158.98
REMOTE Fa0/0 128/24 192.168.157.0 255.255.255.0 192.168.157.255 198.168.157.1 - 198.168.157.1
198.168.157.244
Fa0/1 60/26 192.168.158.0 255.255.255.192 192.168.158.63 192.168.158.1 - 192.168.158.1
192.168.158.62
S0/0/0 2/30 192.168.158.100 255.255.255.252 192.168.158.103 192.168.158.101 ± 192.168.158.101
192.168.158.102
./c )$c $c&+c$ 'c#c
DEVICE INTERFACE IP ADDRESS SUBNET MASK DEFAULT GATEWAY
HQ Fa0/0 192.168.156.1 255.255.255.128 0.0.0.127
Fa0/1 192.168.156.129 255.255.255.192 0.0.0.63
S0/0/1 192.168.158.97 255.255.255.252 0.0.0.3
S0/0/0 192.168.158.101 255.255.255.252 0.0.0.3
Lo0 189.54.69.254 255.255.255.252 0.0.0.3
REMOTE 1 Fa0/0 192.168.158.65 255.255.255.224 0.0.0.31
Fa0/1 192.168.156.193 255.255.255.192 0.0.0.63
S0/0/1 192.168.158.98 255.255.255.252 0.0.0.3
REMOTE 2 Fa0/0 192.168.157.1 255.255.255.0 0.0.0.255
Fa0/1 192.168.158.1 255.255.255.192 0.0.0.63
S0/0/0 192.168.158.102 255.255.255.252 0.0.0.3
PC1 Ethernet 192.168.156.126 255.255.255.128 192.168.156.1
PC2 Ethernet 192.168.156.190 255.255.255.192 192.168.156.129
PC3 Ethernet 192.168.158.94 255.255.255.224 192.168.158.65
PC4 Ethernet 192.168.156.254 255.255.255.192 192.168.156.193
PC5 Ethernet 192.168.158.62 255.255.255.192 192.168.158.1
PC6 Ethernet 192.168.157.128 255.255.255.0 192.168.157.1
cccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccc3
$&+c0cc

4./c+
&$c+()
 &+c
Using Cisco packet tracer environment, a network topology was create as shown below. This network
comprises of HQ router, REMOTE 1 and REMOTE 2 routers interconnected by WAN.

Figure 3: router connection

The router was all configured using EIGRP process 1. All connected networks were advertised except the
loopback interface, this was done to ensure communication throughout the network using EIGRP. Default
route was configured on the HQ router as a static route which was distributed through EIGRP to
REMOTE 1 and REMOTE 2. REMOTE1 is connected to the HQ router via S0/0/1 and S0/0/1 on
REMOTE1 on router. REMOTE 1 subnet is connecting via Fa0/1 and Fa0/0 to the REMOTE1 router.
REMOTE 2 subnets are connected via Fa0/0 and Fa0/1 on the REMOTE2 router. HQ router are connect
through Fa0/0 and Fa0/1 on the HQ router.

Due the router were not configured with password be EIGRP was configured. Secret password was set to
µemmanuel¶ for all three routers. This was done for security purpose. To prevent unauthorized up set of
router configuration. Configuration of EIGRP on the three router forms an autonomous systems.
 ./c+
&$c+()
 &+c($c

 .!c$ -)c# *+c(+c+


&$c
HQ ROUTER
HQ#config t
Enter configuration commands, one per line. End with CNTL/Z.
HQ(config)#hostname HQ
HQ(config)#enable secret emmanuel
HQ(config)#
HQ(config)#line console 0
HQ(config-line)#password emmanuel
HQ(config-line)#login
HQ(config-line)#line vty 0 4
HQ(config-line)#password emmanuel
HQ(config-line)#login
HQ(config-line)#exit
REMOTE 1
REMOTE 1#config t
Enter configuration commands, one per line. End with CNTL/Z.
REMOTE 1(config)#enable secret emmanuel
REMOTE 1(config)#
REMOTE 1(config)#line console 0
REMOTE 1(config-line)#password emmanuel
REMOTE 1(config-line)#login
REMOTE 1(config-line)#line vty 0 4
REMOTE 1(config-line)#password emmanuel
REMOTE 1(config-line)#login
REMOTE 1(config-line)#exit
REMOTE 1(config)#
REMOTE2
REMOTE2(config)#hostname REMOTE2
REMOTE2(config)#enable secret emmanuel
REMOTE2(config)#
REMOTE2(config)#line console 0
REMOTE2(config-line)#password emmanuel
REMOTE2(config-line)#login
REMOTE2(config-line)#line vty 0 4
REMOTE2(config-line)#password emmanuel
REMOTE2(config-line)#login
REMOTE2(config-line)#exit
REMOTE2(config)#
 .0c+()
 &+c+(c$)#c+c+
&$c
'3c+
&$cc
HQ(config)#route eigrp 1
HQ(config-router)#network 192.168.156.0 0.0.0.127
HQ(config-router)#network 192.168.156.128 0.0.0.63
HQ(config-router)#network 192.168.158.96 0.0.0.3
HQ(config-router)#network 192.168.158.100 0.0.0.3
HQ(config-router)#end
HQ#
%SYS-5-CONFIG_I: Configured from console by console
$+&$c!c+
&$cc
REMOTE 1#config t
Enter configuration commands, one per line. End with CNTL/Z.
REMOTE 1(config)#route eigrp 1
REMOTE 1(config-router)#no auto-summary
REMOTE 1(config-router)#network 192.168.158.64 0.0.0.31
REMOTE 1(config-router)#network 192.168.156.192 0.0.0.63
REMOTE 1(config-router)#network 192.168.158.96 0.0.0.3
REMOTE 1(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 192.168.158.97 (Serial0/0/1) is up: new adjacency
Router(config-router)#end
Router#
%SYS-5-CONFIG_I: Configured from console by console
$+&$c0+
&$
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#route eigrp 1
Router(config-router)#no auto-summary
Router(config-router)#network 192.168.157.0 0.0.0.255
Router(config-router)#network 192.168.158.0 0.0.0.63
Router(config-router)#network 192.168.158.100 0.0.0.3
Router(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 192.168.158.101 (Serial0/0/0) is up: new adjacency
Router(config-router)#end
Router#
%SYS-5-CONFIG_I: Configured from console by console

 .-c2&
$c+
&$c$)#c+()
 &+c

Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#route eigrp 1
Router(config-router)#no auto-summary
Router(config-router)#network 189.54.69.253 0.0.0.3
Router(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 189.54.69.254 (Serial0/0) is up: new adjacency
 .1c
c$)'-+c& -$c
DUAL NEIGHBORS TABLE FOR HQ
HQ#showipeigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface HoldUptime SRTT RTO Q Seq
(sec) (ms) CntNum
0 192.168.158.98 Se0/0/1 10 00:21:38 40 1000 0 9
1 192.168.158.102 Se0/0/0 14 00:10:14 40 1000 0 9
DUAL NEIGHBORS TABLE FOR REMOTE 1
REMOTE 1>en
REMOTE 1#show ipeigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) CntNum
0 192.168.158.97 Se0/0/1 14 00:38:27 40 1000 0 9
REMOTE 1#
DUAL NEIGHBORS TABLE FOR REMOTE 2
Router>en
Router#showipeigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
( sec) (ms) CntNum
0 192.168.158.101 Se0/0/0 13 00:41:16 40 1000 0 14
Router#
c

 .èc++#- %c+()
 &+c
c

HQ(config)# interface loopback0


%LINK-5-CHANGED: Interface Loopback0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
HQ(config-if)#ip address 189.54.69.254 255.255.255.252
% 189.54.69.252 overlaps with Serial0/1/0
HQ(config-if)#no shut
HQ(config-if)#end
HQ#
%SYS-5-CONFIG_I: Configured from console by console

QUESTION 3

!/./c+()
 &+c+(c& &c+
&$c
CONFIGURATION OF STATIC ROUTE
HQ>en
Password:
HQ#config t
Enter configuration commands, one per line. End with CNTL/Z.
HQ(config)#ip route 0.0.0.0 0.0.0.0 loopback0
HQ(config)#router eigrp 1
HQ(config-router)#redistribute static
HQ(config-router)#end
HQ#
%SYS-5-CONFIG_I: Configured from console by console

!!./c&$&)c
Test plan have been developed to check the network device ability to communicate with each other. Basic
ping is to be carried out, pinging each interface from each location. EIGRP specific test are carried out to
ensure EIGRP protocol used on the router is functioning correctly. This includes testing convergence and
cdp.

Test no Description Source Destination address Expected output


1 Ping HQ Lo0 PC3 189.54.69.254 Ping should be successful
2 Ping HQ Fa0/0 PC4 192.168.156.1 Ping should be successful
3 Ping HQ Fa0/1 REMOTE1 router 192.168.156.129 Ping should be successful
4 Ping ISP virtue router HQ router 189.54.69.253 Ping should be successful
5 Ping REMOTE1 router HQ router 192.168.158.98 Ping should be successful
6 Ping REMOTE1 Fa0/0 PC 5 ! !! c Ping should be successful
7 Ping REMOTE1 Fa0/1 PC2 ! !!c Ping should be successful
8 Ping REMOTE1 router REMOTE2 router 192.168.158.98 Ping should be successful
9 Ping REMOTE1 router PC1 192.168.158.98 Ping should be successful
10 Ping REMOTE2 router PC3 192.168.158.102 Ping should be successful
11 Ping REMOTE2 Fa0/0 PC2 192.168.157.128 Ping should be successful
12 Ping REMOTE2 Fa0/1 PC1 192.168.158.62 Ping should be successful
13 Ping REMOTE2 router HQ router 192.168.158.102 Ping should be successful
14 Ping REMOTE2 router REMOTE1 router 192.168.158.102 Ping should be successful
15 Ping REMOTE2 router ISP virtue router 192.168.158.102 Ping should be successful
16 Ping HQ router PC3 192.168.158.101 Ping should be successful
17 Ping HQ router PC2 192.168.156.129 Ping should be successful
18 PC4 ISP virtue router 192.168.156.254 Ping should be successful
19 PC3 PC6 192.168.158.94 Ping should be successful
20 PC6 PC1 192.168.157.128 Ping should be successful
21 PC1 PC5 192.168.156.126 Ping should be successful
22 PC5 PC3 192.168.158.62 Ping should be successful

!0./c&$&c+)c

Test no Description Expected result Actual result Successful/fail


1 Ping HQ Lo0 ping should be successful See figure 4 below successful
2 Ping HQ Fa0/0 ping should be successful See figure 5 belowc successful
3 Ping HQ Fa0/1 ping should be successful See figure 6 belowc successful
4 Ping ISP virtue router ping should be successful c See figure 7 belowc successful
5 Ping REMOTE1 router ping should be successful c See figure 8 belowc successful
6 Ping REMOTE1 Fa0/0 ping should be successful c See figure 9 belowc successful
7 Ping REMOTE1 Fa0/1 ping should be successful c See figure 10 belowc successful
8 Ping REMOTE1 router ping should be successful c See figure 11 belowc successful
9 Ping REMOTE1 router ping should be successful c See figure 12 belowc successful
10 Ping REMOTE2 router ping should be successful c See figure 13 belowc successful
11 Ping REMOTE2 Fa0/0 ping should be successful c See figure 14 belowc successful
12 Ping REMOTE2 Fa0/1 ping should be successful c See figure 15 belowc successful
13 Ping REMOTE2 router ping should be successful c See figure 16 belowc successful
14 Ping REMOTE2 router ping should be successful c See figure 17 belowc successful
15 Ping REMOTE2 router ping should be successful c See figure 18 belowc successful
16 Ping HQ router ping should be successful c See figure 19 belowc successful
17 Ping HQ router ping should be successful c See figure 20 belowc successful
18 Ping PC4 ping should be successful c See figure 21 belowc successful
19 Ping PC3 ping should be successful c See figure 22belowc successful
20 Ping PC6 ping should be successful c See figure 23 belowc successful
21 Ping PC1 ping should be successful c See figure 24 belowc successful
22 Ping PC5 ping should be successful c See figure 25 belowc successful
!-./c&$&c+)c$
&c
PING 1

Figure 4: ping HQ Lo0

PING 2

Figure 5: Ping HQ Fa0/0

Ping 3
Figure 6:Ping HQ Fa0/1

PING 4

Figure 7:Ping ISP virtue router


PING 5

Figure 8:Ping REMOTE1 router

PING 6

Figure 9:Ping REMOTE1 Fa0/0


PING 7

Figure 10:Ping REMOTE1 Fa0/1

PING 8

Figure 11:Ping REMOTE1 router


PING 9

Figure 12:Ping REMOTE1 router

PING 10

Figure 13:Ping REMOTE2 router


PING 11

Figure 14:Ping REMOTE2 Fa0/0

PING 12

Figure 15:Ping REMOTE2 Fa0/1


PING 13

Figure 16:Ping REMOTE2 router

PING 14

Figure 17:Ping REMOTE2 router


PING 15

Figure 18:Ping REMOTE2 router

PING 16

Figure 19:Ping HQ router


PING 17

Figure 20:Ping HQ router

PING 18

Figure 20:Ping PC4


PING 19

Figure 21:Ping PC3

PING 20

Figure 22: Ping PC6


PING 21

Figure 23:Ping PC1

PING 22

Figure 24:Ping PC5


!1./c&$&c(+c$)#c c+2$)$$c
Test no Description Expected result Actual result Successful/fail
1 Routing update should be sent around the network Using EIGRP packet should be sent See routing tables below successful
to connected and configured routers
2 Testing convergence All devices so be able converge See routing tables belowc successful
c

!1./c'3c+
&$c+
&)c& -$c

Figure 25:HQ routing table

c
c
c

!1.!c$+&$c!c+
&$c+
&)c& -$c

Figure 26:REMOTE1 routing table

 c
c
c

!1.0c$+&$c0c+
&$c+
&)c& -$c

Figure 27:REMOTE2 routing table

c
c
c

+
+c
UKTA network is design to conform to all network standards. The network topology support high level of
scalability, Qos and security within the network. Extra port on the router was left to support physical
scalability within each subnet for logical increase internwork protocol could be sub-netted to get required
IPs. Based on the UKTA scenario routers were successfully configured to use EIGRP protocol for
communication within the network forming an autonomous group. The HQ was configured with loopback
address meant for the network and a static route was also configured for a virtue communication with the
network.

!c
c
c

REFERENCE

@ Imagestream.com, nd; Leading the Router Revolution (Online)


Available at: http://www.imagestream.com/
[Accessed on December 18, 2010]

@ Serverfault.com, 2009; Dhen/why to start subnetting a network?(Online)


Available at:2 



 !2 2
  
    

[Accessed on December 18, 2010]

@ petri.co.il, 2010: urouble Configuring EIGRP with 2503(Online 1st May)


Available at: 2   
 

2
 2 2  c
[Accessed on December 12, 2010

@ cisco.iphelp.ru, nd:EIGRP Summarization(Online)


Available at:2  
 2 
  2 ! 2 c

[Accessed on December 8, 2010c

@ fengnet.com,nd: Case Study: uroubleshooting EIGRP Neighbor Relationships(Online)


Available at2    


 

   2 ! 2 c


[Accessed on December 8, 2010c
c

@ informit.com, nd: Configuring Advanced EIGRP and Redistribution(Online)


Available at:
2  
 
  
  
 

 
c
 c
c  cc!
c

c
c
c

c
c