Вы находитесь на странице: 1из 125

1

РЕФЕРАТ
Дипломная работа – 125 с., 64 рис., 10 источника, 4 главы.
Объект работы – салон красоты Fashion Studio.
Задача выпускной квалификационной работы: разработка
конфигурации на платформе 1С: Предприятия для записи клиентов, учёта
товара и формирования отчётов.
Для решения данной задачи были проведены следующие работы:
1) Проведено обследование деятельности салона красоты Fashion
Studio;
2) Изучен интернет-сервис Арника;
3) Изучены должностные инструкции работников салона красоты
Fashion Studio;
4) На основании собранных данных была составлена диаграмма
прецедентов;
5) На основании собранных данных были составлены диаграммы
классов;
6) Определен формат входных и выходных данных;
7) Разработаны макетные формы.
Результатом работы является разработка конфигурации для платформы
1С: Предприятие.

2
Оглавление
РЕФЕРАТ ................................................................................................................. 1
ВВЕДЕНИЕ .............................................................................................................. 4
1.Описание предметной области ........................................................................... 5
1.1. Описание предприятия ................................................................................ 5
1.2. Структура предприятия ............................................................................... 5
1.3. Цели и задачи предприятия......................................................................... 6
1.4. Аналоги разрабатываемой системы ............................................................ 7
2.Постановка цели и задачи ................................................................................... 8
2.1. Проблематика ................................................................................................ 8
2.2. Цель ................................................................................................................ 8
2.3. Задачи ............................................................................................................. 9
2.4. Требования к объекту автоматизации......................................................... 9
3.Информационное обеспечение ......................................................................... 11
3.1. Диаграмма Прецедентов............................................................................. 11
3.2. Диаграмма Классов ..................................................................................... 16
3.3. Диаграмма Последовательности ............................................................... 23
4.Проектирование программного обеспечения.................................................. 51
4.1. Средства разработки ................................................................................... 51
4.2. Описание приложения ................................................................................ 51
4.3.Выходные документы .................................................................................. 94
Заключение .......................................................................................................... 114
Список литературы ............................................................................................. 115
Приложение ......................................................................................................... 116

3
ВВЕДЕНИЕ
Арника является интернет-сервисом, предназначенным для
обеспечения работы салона красоты. Основные функции которые выполняет
интернет-сервис: запись и расчёт клиентов, расчёт мастеров и составление
отчётов.
Для работы сайта необходимо помесячная оплата. Так же для
полноценной работы необходимо постоянное стабильное интернет
соединение. Всю информацию которую вводят в систему может
просматривать владелец интернет-сервиса.
В связи свыше описанными ограничениями увеличивается время
обслуживания клиентов при отключении интернета. Так же по этой причине
теряется некоторая часть информации, которая в этот момент заносится
вручную.
Данные ограничения не позволяют в полной мере пользоваться этим
интернет-сервисом, поэтому появляется необходимость в разработке
собственной аналогичной системы.
Цель выпускной квалификационной работы:
Повышение надёжности и качества обслуживания, сокращение
временных затрат на формирование отчётов и учёт расходных материалов.

Задачи выпускной квалификационной работы:


1. Изучить бизнес процесс салона красоты;
2. Определить архитектурные решения разрабатываемой
конфигурации;
3. Разработать конфигурацию.

4
1.Описание предметной области
1.1. Описание предприятия
Салон красоты Fashion Studio — заведение, занимающееся
обслуживанием мужчин и женщин. Это предприятие, занимается
предоставлением услуг для населения по уходу за волосами (стрижка,
завивка, создание причёски, окраска, мелирование и другие виды работ с
красителями, стрижка огнём и др.) в оборудованном специально для этого
помещении. Так же там оказывают следующие виды услуг: маникюр,
педикюр, косметические услуги и услуги визажиста.
1.2. Структура предприятия
 зал для приёма клиентов;
 парикмахерский зал;
 рабочее место мастера ногтевого сервиса;
 кабинет педикюра;
 косметический кабинет;
 раздельные кабинеты косметологии лица и тела;
 два рабочих места ногтевого сервиса (одно для маникюра в
парикмахерском зале.
Должностные обязанности директора салона красоты:
 Принимать на работу сотрудников;
 Увольнять сотрудников;
 Просматривать и анализировать отчёты составленные
администратором.
Должностные обязанности администратора салона красоты:
 Заносить новых клиентов в базу;
 Заносить новых сотрудников в базу;
 Записывать клиентов;
 Рассчитывать клиентов;
 Составлять отчёты;

5
 Закупать товар и материалы;
 Заносить поступившие товары в базу;
 Удалять товары из базы;
 Заносить услуги в базу;
1.3. Цели и задачи предприятия
Основной задачей салона красоты Fashion Studio является
предоставление услуг потребителю на профессиональном уровне, используя
профессиональные качественные материалы, оборудование и
высококвалифицированный персонал.
Максимизировать прибыль предприятия и удовлетворить спрос
потребителей - вот цели, которые ставит перед собой салон красоты Fashion
Studio.
Деятельность салона Fashion Studio ориентирована на жителей города
Новый Уренгой со средним достатком, работает непосредственно с большим
количеством людей, объясняется это тем, что салон предоставляет
качественные и не дорогие для салона красоты косметические услуги.
Салон красоты Fashion Studio оказывает следующие виды услуг:
Территория стилистов:

 Стрижка;
 Укладка волос;
 Прическа;
 Окрашивание;
 Моделирование;
 И т.д.
Ногтевой сервис:
 Гигиенический маникюрм;
 Комплексный маникюр;
 Полировка ногтей;
 Покрытие лаком;
6
 Использование дизайна;
 И т.д.
Сфера Педикюра:
 Педикюр классический;
 Парафинотерапия;
 Покрытие лаком;
 И т.д.
1.4. Аналоги разрабатываемой системы
 Сrm-система «UNIVERSE-Красота»
 Max1
 Программа для салонов красоты "Универсальная Система Учета"
 Beauty Expert

7
2.Постановка цели и задачи
2.1. Проблематика
Во время прохождения практики в городе Новый Уренгой в салоне
красоты Fashion Studio передо мной была поставлена задача разработки
конфигурации на платформе 1С: Предприятия для записи клиентов, учёта
товара и формирования отчётов. Решение данной задачи так же
представлено в выпускной квалификационной работе.
На данный момент салон красоты пользовался программным
продуктом арника. Арника является интернет-сервисом, предназначен для
обеспечения работы салона красоты. Основные функции которые выполняет
интернет-сервис: запись и расчёт клиентов, расчёт мастеров и составление
отчётов.
Для работы сайта необходимо помесячная оплата. Так же для
полноценной работы необходимо постоянное стабильное интернет
соединение. Всю информацию которую вводят в систему может
просматривать владелец интернет-сервиса.
В связи свыше описанными ограничениями увеличивается время
обслуживания клиентов при отключении интернета. Так же по этой причине
теряется некоторая часть информации, которая в этот момент заносится
вручную.
Данные ограничения не позволяют в полной мере пользоваться этим
интернет-сервисом, поэтому появляется необходимость в разработке
собственной аналогичной системы.

Решением этой проблемы станет разработка конфигурации для


платформы 1С: Предприятие.

2.2. Цель

Повышение надёжности и качества обслуживания, сокращение


временных затрат на формирование отчётов и учёт расходных материалов.

8
2.3. Задачи
1. Изучить бизнес процесс салона красоты.
2. Определить архитектурные решения разрабатываемой
конфигурации.
3. Разработать конфигурацию.
2.4. Требования к объекту автоматизации
1.Требование к системе в целом
Система должна предоставлять возможность записи клиентов, учёта
материалов и формирования отчётов.
2.Требование к функциям выполняемым системой
 Обработка информации о должностях
 Обработка информации о клиентах
 Обработка информации о красителях
 Обработка информации о складе
 Обработка информации о сотрудниках
 Обработка информации о товарах
 Обработка информации об услугах
 Формирование документа «Создать визит»
 Формирование документа «Приход товара»
 Формирование документа «Расход товара»
 Формирование документа «Приход красителей»
 Формирование документа «Расход красителей»
 Формирование документа «Цены на красители»
 Формирование документа «Цены на товары»
 Формирование документа «Цены на услуги»
 Формирование отчёта «Отчёт по одному клиенту»
 Формирование отчёта «Отчёт по всем клиентам»
 Формирование отчёта «Отчёт по клиентам за определённый
период»
9
 Формирование отчёта «Отчёт по мастерам за определённый
период»
 Формирование отчёта «Отчёт по одному мастеру»
 Формирование отчёта «Остаток товара на складе»
 Формирование отчёта «Выручка по услугам»
 Формирование отчёта «Выручка по товарам»
 Формирование отчёта «Отчёт по красителям»
 Формирование отчёта «Остаток красителей на складе»

10
3.Информационное обеспечение
3.1. Диаграмма Прецедентов
Разрабатываемая система была описана с помощью языка
моделирования UML. На рисунке «Рисунок 1: Диаграмма прецедентов»
представлена диаграмма прецедентов процесса работы салона красоты, на
ней изображены актеры: главный эксперт отдела аспирантуры, проректор по
научной работе и аспирант. Модель прецедентов показывает совокупность
вариантов использования, актеров и отношения между ними. С помощью
этой диаграммы иллюстрируется статический вид системы с точки зрения
прецедентов.

Рисунок 1. Диаграмма прецедентов

11
Клиент пришёл в салон по записи.

Описание: Клиент приходит в салон красоты и сообщает


администратору, что он записан к мастеру.
Основной поток:
1.Клиент приходит в салон красоты и сообщает администратору, что он
по записи.
2.Администратор проверяет записан ли клиент на данное время.
3.Администратор сообщает мастеру о прибытии клиента.
4.Получить ответ от мастера, что он может принять клиента.
А1.Мастер занят.
5.Направить клиента к мастеру.
Альтернативные потоки:
А1.Мастер занят.
1.Администратор узнаёт у мастера, когда он сможет принять
клиента.
2.Сообщить клиенту время ожидания мастера.
3.Переход к 4 шагу основного потока.

Клиент пришёл в салон не по записи.

Описание: Клиент приходит в салон красоты и записывается к мастеру.


Основной поток:
1.Клиент пришёл в салон красоты.
2.Клиент интересуется необходимой ему услугой у администратора.
3.Администратор предоставляет информацию об этой услуге.
4.Клиент выбирает подходящее ему время
5.Администратор проверяет свободен ли мастер в это время
6. Клиент записывается сейчас.
А1.Клиент записывается на сегодняшний день, но на другое
время.
А2.Клиент записывается на другой день.
А3.Клиент отказывается от услуг.
5.Администратор направляет клиента к мастеру.
Альтернативные потоки:
А1. Клиент записывается на сегодняшний день, но на другое время.
1. Клиент приходит и сообщает мастеру, что он по записи.
2.Переход к шагу 5 основного потока.
А2. Клиент записывается на другой день.
12
1.Клиент приходит и сообщает мастеру, что он по записи.
2. Переход к шагу 5 основного потока.
А3. Клиент отказывается от услуг.
1.Клиент уходит.

Обслуживание клиента.

Описание: Мастер обслуживает записанного к нему клиента.


Основной поток:
1.Мастер получает информацию от администратора.
2.Мастер обслуживает клиента на основе полученной информации от
администратора и уточняет у клиента.
3.Мастер отчитывается администратору.

Оформление услуги клиента.

Описание: Администратор заполняет информационный лист.


Основной поток:
1.Администратор берёт лист и подходит к мастеру.
2.Администратор записывает имя клиента, дату обслуживания, имя
мастера, услуги и какой товар и в каком количестве было использовано.
3.Администратор заносит товар и услуги в систему и система
подсчитывает стоимость всей работы.

Оплата.

Описание: Система подсчитывает работу мастера и стоимость


материалов.
Основной поток:
1. Администратор заносит товар и услуги в систему и система
подсчитывает стоимость всей работы
2. Администратор нажимает на кнопку «Клиент пришёл»
3. Клиент оплачивает услуги.
4. Администратор нажимает на кнопку «клиент оплатил»

Закупка материала.

Описание: Администратор закупает весь нужный материал для


выполнения работы.
Основной поток:
1.Администратор составляет документ о нужных материалах по отчёту.
13
2.Администратор подписывает этот документ.
3.Поставщики привезли материалы в срок.
А1.Поставщики не привезли материалы в срок.
4.Администратор принимает материалы.
5.Администратор фиксирует в базе купленные материалы.
Альтернативные потоки:
А1. Поставщики не привезли материалы в срок.
1.Связать с поставщиками.
2.Изменить дату доставки материалов.
3.Переход к 3 шагу основного потока.

Отчёт по клиентам ( сколько клиентов обслужили за месяц).


Описание: Администратор составляет отчёт.
Основной поток:
1. Получить информацию.
2. Составить отчёт.

Отчёт по товарам ( сколько было израсходовано того или иного товара


за месяц).
Описание: Администратор составляет отчёт.
Основной поток:
1.Получить информацию.
2.Составить отчёт.

Отчёт по мастерам ( какой мастер сколько клиентов обслужил за


месяц).
Описание: Администратор составляет отчёт.
Основной поток:
1.Получить информацию.
2.Составить отчёт.

Отчёт «Выручка за месяц».


Описание: Администратор составляет отчёт.
Основной поток:
1.Получить информацию.
2.Составить отчёт.

Выдача зарплаты мастеру.

Описание: Администратор выдаёт зарплату мастерам.

14
Основной поток:
1.В конце рабочего дня администратор формирует документ где
подчитано сколько заработал за сегодня мастер, к нему так же прикрепляется
бумажка с услугами.
2. Мастер расписывается в документе.
3.Администратор рассчитывает мастера.

12.Продажа товара.
Описание: Администратор продаёт некоторый товар клиентам.
Основной поток:
1.Клиент приходит в салон
2.Клиент выбирает нужный товар
3.Администратор отдаёт этот товар клиенту
4.Клиент оплачивает

13.Клиент записался к мастеру по телефону.


Описание: Клиент позвонил в салон и записался
Основной поток:
1.Клиент звонит в салон называет нужное ему время и день
А1. Клиент говорит к какому мастеру хочет записаться,
в какое время и в какой день
2.Администратор смотрит в системе какой мастер в это время свободен
А2.Ни один мастер не свободен
3.Администратор записывает клиента в это время
Альтернативный поток:
А1.Клиент говорит к какому мастеру хочет записаться, в какое время и
в какой день
2.Администратор смотрит в системе свободен ли мастер в это время и в
этот день

15
3. Если мастер не свободен, администратор предлагает другой вариант
4.Клиент соглашается
5.Администратор записывает его
6.Клиент не соглашается
А2.Ни один мастер не свободен
2.Администратор предлагает другое время или другой день
3.Клиент соглашается
4.Переход к 3 шагу основного потока

3.2. Диаграмма Классов

В данной работе на рисунках «Рисунок 2: Диаграмма классов»,


«Рисунок 3: Диаграмма классов» и «Рисунок 4: Диаграмма классов»
представлена диаграмма классов выполненная с помощью нотации UML .
Диаграмма классов (англ. Static Structure diagram) — диаграмма,
демонстрирующая классы системы, их атрибуты, методы и взаимосвязи
между ними. Диаграмма классов служит для представления статической
структуры модели системы в терминологии классов объектно-
ориентированного программирования. Эта нотация выбрана с целью
наглядно представить структуру реляционной базы данных и отношения
между сущностями.

16
Рисунок 2. Диаграмма классов

17
Рисунок 3. Диаграмма классов

18
Рисунок 4. Диаграмма классов

19
Сотрудники
Описание Взаимосвязь
Должность
Документ «Создать визит»

Клиенты
Описание Взаимосвязь
Хранение и отображение информации о Документ «Создать визит»
клиентах

Должность
Описание Взаимосвязь
Хранение и отображение информации о Сотрудники
должностях

Услуги
Описание Взаимосвязь
Хранение и отображение информации об Документ «Создать визит»
услугах Красители

Товар
Описание Взаимосвязь
Хранение и отображение информации о товарах Документ «Создать визит»
Документ «Расход товара»
Документ «Приход товара»
Документ «Цены на товары»

Красители
Описание Взаимосвязь
Хранение и отображение информации о Документ «Создать визит»
красителях Документ «Приход красителей»
Документ «Расход красителей»
Документ «Цены на красители

Склад
Описание Взаимосвязь
Хранение и отображение информации о складах Документ «Приход красителей»
Документ «Расход красителей»
Документ «Приход товара»
Документ «Расход товара»

Документ «Расход товара»


Описание Взаимосвязь
Хранение и отображение информации о Товар
20
проданных товарах Регистр накопления «ПриходРасход»
Склад
Регистр накопления «Выручка по товарам»

Документ «Приход товара»


Описание Взаимосвязь
Хранение и отображение информации о Товар
поступивших товарах Регистр накопления «ПриходРасход»
Склад

Регистр накопления «ПриходРасход»


Описание Взаимосвязь
Документ «Приход товара»
Документ «Расход товара»

Документ «Цены на красители»


Описание Взаимосвязь
Хранение и отображение информации о ценах Товар
на красители Регистр сведений «Цены на красители»

Регистр сведений «Цены на красители»


Описание Взаимосвязь
Документ «Цены на красители»

Документ «Цены на товары»


Описание Взаимосвязь
Хранение и отображение информации о ценах Товар
на товары Регистр сведений «Цены на товары»

Регистр сведений «Цены на товары»


Описание Взаимосвязь
Документ «Цены на товары»

Документ «Цены на услуги»


Описание Взаимосвязь
Хранение и отображение информации о ценах Услуги
на услуги Регистр сведений «Цены на услуги»

Регистр сведений «Цены на услуги»


Описание Взаимосвязь

21
Документ «Цены на услуги»

Документ «Создать визит»


Описание Взаимосвязь
Хранение и отображение информации о Сотрудники
клиентах которые записались на обслуживание Регистр накопления «Выручка по услугам»
к мастерам Регистр сведений «Записать клиента»
Товар
Клиенты
Услуги
Регистр сведений «Красители»

Регистр сведений «Записать клиента»


Описание Взаимосвязь
Документ «Создать визит»

Регистр накопления «Выручка по товарам»


Описание Взаимосвязь
Документ «Расход товара»

Регистр накопления «Выручка по услугам»


Описание Взаимосвязь
Документ «Создать визит»

Регистр сведений «Красители»


Описание Взаимосвязь
Документ «Создать визит»

Документ «Расход красителей»


Описание Взаимосвязь
Хранение и отображение информации о Красители
проданных товарах Регистр накопления «ПриходРасходКрасители»
Склад

Документ «Приход красителей»


Описание Взаимосвязь
Хранение и отображение информации о Красители
проданных товарах Регистр накопления «ПриходРасходКрасители»
Склад

Регистр накопления «ПриходРасходКрасители»


Описание Взаимосвязь
Хранение и отображение информации о Документ «Приход красителей»

22
проданных товарах Документ «Расход красителей»

3.3. Диаграмма Последовательности

На ниже приведённых рисунках изображена диаграмма


последовательностей в нотации UML. Диаграмма последовательности —
диаграмма, на которой для некоторого набора объектов на единой
временной оси показаны жизненный цикл (создание-деятельность-
уничтожение) и взаимодействие (отправка запросов и получение ответов).

Рисунок 5. Диаграмма последовательности «справочник Должность»

23
Описание диаграммы последовательности «справочник Должность»
1.Сотрудник нажимает на кнопку «Создать»
2.Открывается экранная форма
3.Сотрудник заполняет поле «Наименование»
4.Отображается заполненная экранная форма
5.Сотрудник нажимает на кнопку «Записать» или «Записать и закрыть»
6.Отображается записанный документ

Рисунок 6. Диаграмма последовательности "справочник Клиенты"

Описание диаграммы последовательности «справочник Клиенты»


1.Сотрудник нажимает на кнопку «Создать»
24
2.Открывается экранная форма
3.Сотрудник заполняет поля: «ФИО», «Телефон», «Примечание», «Скидка в
процентах»
4.Отображается заполненная экранная форма
5.Сотрудник нажимает на кнопку «Записать» или «Записать и закрыть»
6.Отображается записанный документ

Рисунок 7. Диаграмма последовательности "справочник Красители"

Описание диаграммы последовательности «справочник Красители»


1.Сотрудник нажимает на кнопку «Создать»
25
2.Открывается экранная форма
3.Сотрудник заполняет поле «Наименование»
4.Отображается заполненная экранная форма
5.Сотрудник нажимает на кнопку «Записать» или «Записать и закрыть»
6.Отображается записанный документ

Рисунок 8. Диаграмма последовательности "справочник Склад"

Описание диаграммы последовательности «справочник Склад»


1.Сотрудник нажимает на кнопку «Создать»
2.Открывается экранная форма

26
3.Сотрудник заполняет поле «Наименование»
4.Отображается заполненная экранная форма
5.Сотрудник нажимает на кнопку «Записать» или «Записать и закрыть»
6.Отображается записанный документ

Рисунок 9. Диаграмма последовательности "справочник Сотрудники"

Описание диаграммы последовательности «справочник Сотрудники»


1.Сотрудник нажимает на кнопку «Создать»
2.Открывается экранная форма
3.Сотрудник заполняет поля: «ФИО», «Телефон», «Должность»

27
4.Отображается заполненная экранная форма
5.Сотрудник нажимает на кнопку «Записать» или «Записать и закрыть»
6.Отображается записанный документ

Рисунок 10. Диаграмма последовательности "справочник Товар"

Описание диаграммы последовательности «справочник Товар»


1.Сотрудник нажимает на кнопку «Создать»
2.Открывается экранная форма
3.Сотрудник заполняет поля: «Наименование товара», «Категория»

28
4.Отображается заполненная экранная форма
5.Сотрудник нажимает на кнопку «Записать» или «Записать и закрыть»
6.Отображается записанный документ

Рисунок 11. Диаграмма последовательности "справочник Услуги"

Описание диаграммы последовательности «справочник Услуги»


1.Сотрудник нажимает на кнопку «Создать»
2.Открывается экранная форма
3.Сотрудник заполняет поля: «Наименование», «Родитель»
4.Отображается заполненная экранная форма
5.Сотрудник нажимает на кнопку «Записать» или «Записать и закрыть»
6.Отображается записанный документ

29
Рисунок 12. Диаграмма последовательности "документ Создать визит"
Описание диаграммы последовательности «документ Создать визит»

30
1.Сотрудник нажимает на кнопку «Создать»
2.Открывается экранная форма
3.Сотрудник заполняет поля: «ФИОКлиента», «ФИОМастера»,
«ВремяНачала», «ВремяКонца»
4.Отображаются заполненные поля
5.Сотрудник нажимает на кнопку «Добавить»
6.Создаётся строка в табличной части
7.Сотрудник заполняет поле «Услуга»
8.Автоматически заполняется поле «Цена на услугу»
9.Сотрудник заполняет поле «Красители»
10.Автоматически заполняется поле «Цена на краситель»
11.Сотрудник заполняет оставшиеся поля: «Продавец», «Граммы», «Скидка в
процентах»
12.Подсчитывается сумма
13.Сотрудник нажимает на кнопку «Провести» или «Провести и закрыть»
14.Подсчитывается общая сумма документа и отображается проведённый
документ

31
Рисунок 13. Диаграмма последовательности "документ Приход товара"

Описание диаграммы последовательности «документ Приход товара»


1.Сотрудник нажимает на кнопку «Создать»
2.Открывается экранная форма
3.Сотрудник нажимает на кнопку «Добавить»
4.Создаётся строка в табличной части

32
5.Сотрудник заполняет поля: «Товар», «Количество», «Цена», «Склад»
6.Подсчитывается общая сумма
7.Сотрудник нажимает на кнопку «Провести» или «Провести и закрыть»
8.Подсчитывается общая сумма документа и отображается проведённый
документ

Рисунок 14. Диаграмма последовательности "документ Расход товара"


33
Описание диаграммы последовательности «документ Расход товара»
1.Сотрудник нажимает на кнопку «Создать»
2.Открывается экранная форма
3.Сотрудник нажимает на кнопку «Добавить»
4.Создаётся строка в табличной части
5.Сотрудник заполняет поле «Товар»
6.Подставляет цену
7.Сотрудник заполняет поля «Количество» и «Склад»
8.Подсчитывается общая сумма
9.Сотрудник нажимает на кнопку «Провести» или «Провести и закрыть»
10.Подсчитывается общая сумма документа и отображается проведённый
документ

34
Рисунок 15. Диаграмма последовательности "документ Цены на красители"

Описание диаграммы последовательности «документ Цены на красители»


1.Сотрудник нажимает на кнопку «Создать»
2.Открывается экранная форма
3.Сотрудник нажимает на кнопку «Добавить»
4.Создаётся строка в табличной части
5.Сотрудник заполняет поля: «Наименование», «Граммы», «Стоимость»
6.Отображает заполненную экранную форму
7.Сотрудник нажимает на кнопку «Провести» или «Провести и закрыть»

35
8.Подсчитывается общая сумма документа и отображается проведённый
документ

Рисунок 16. Диаграмма последовательности "документ Цены на товары"

Описание диаграммы последовательности «документ Цены на товары»


1.Сотрудник нажимает на кнопку «Создать»
2.Открывается экранная форма
3.Сотрудник нажимает на кнопку «Добавить»
4.Создаётся строка в табличной части

36
5.Сотрудник заполняет поля: «Наименование», «Себестоимость»,
«Стоимость»
6.Отображает заполненную экранную форму
7.Сотрудник нажимает на кнопку «Провести» или «Провести и закрыть»
8.Подсчитывается общая сумма документа и отображается проведённый
документ

Рисунок 17. Диаграмма последовательности "документ Цены на услуги"

37
Описание диаграммы последовательности «документ Цены на услуги»
1.Сотрудник нажимает на кнопку «Создать»
2.Открывается экранная форма
3.Сотрудник нажимает на кнопку «Добавить»
4.Создаётся строка в табличной части
5.Сотрудник заполняет поля: «Наименование», «Цена»
6.Отображает заполненную экранную форму
7.Сотрудник нажимает на кнопку «Провести» или «Провести и закрыть»
8.Подсчитывается общая сумма документа и отображается проведённый
документ

Рисунок 18. Диаграмма последовательности "документ Приход красителей "

38
Описание диаграммы последовательности «документ Приход красителей»
1.Сотрудник нажимает на кнопку «Создать»
2.Открывается экранная форма
3.Сотрудник нажимает на кнопку «Добавить»
4.Создаётся строка в табличной части
5.Сотрудник заполняет поля: «Наименование», «Количество», «Цвет»,
«Стоимость», «Склад»
6.Подсчитывается общая сумма
7.Сотрудник нажимает на кнопку «Провести» или «Провести и закрыть»
8.Подсчитывается общая сумма документа и отображается проведённый
документ

39
Рисунок 19. Диаграмма последовательность "документ Расход красителей"

Описание диаграммы последовательности «документ Расход красителей»


1.Сотрудник нажимает на кнопку «Создать»
2.Открывается экранная форма
3.Сотрудник нажимает на кнопку «Добавить»
4.Создаётся строка в табличной части
5.Сотрудник заполняет поля: «Наименование», «Количество», «Цвет»,
«Стоимость», «Склад»
6.Подсчитывается общая сумма
7.Сотрудник нажимает на кнопку «Провести» или «Провести и закрыть»
40
8.Подсчитывается общая сумма документа и отображается проведённый
документ

Рисунок 20. Диаграмма последовательности "отчёт Выручка по товарам"

Описание диаграммы последовательности «отчёт Выручка по товарам»


1.Сотрудник выбирает отчёт
2.Открывается форма не сформированного отчёта
3.Сотрудник заполняет поля: «Начало месяца» и «Конец месяца»
4.Отображает заполненные поля
5.Сотрудник нажимает на кнопку «Сформировать»
6.Отправляет запрос на получение данных

41
7.Получает данные
8.Формируется отчёт

Рисунок 21. Диаграмма последовательности "отчёт Выручка по услугам"

Описание диаграммы последовательности «отчёт Выручка по услугам»


1.Сотрудник выбирает отчёт
2.Открывается форма не сформированного отчёта
3.Сотрудник заполняет поля: «Начало месяца» и «Конец месяца»
4.Отображает заполненные поля
5.Сотрудник нажимает на кнопку «Сформировать»
6.Отправляет запрос на получение данных

42
7.Получает данные
8.Формируется отчёт

Рисунок 22. Диаграмма последовательности "Отчёт по одному клиенту"

Описание диаграммы последовательности «Отчёт по одному клиенту»


1.Сотрудник выбирает отчёт
2.Открывается форма не сформированного отчёта
3.Сотрудник заполняет поле: «ФИОКлиента»
4.Отображает заполненное поле
5.Сотрудник нажимает на кнопку «Сформировать»
6.Отправляет запрос на получение данных

43
7.Получает данные
8.Формируется отчёт

Рисунок 23. Диаграмма последовательности "Отчёт по всем клиентам"

Описание диаграммы последовательности «Отчёт по всем клиентам»


1.Сотрудник выбирает отчёт
2.Открывается форма не сформированного отчёта
3.Сотрудник нажимает на кнопку «Сформировать»
4.Отправляет запрос на получение данных
5.Получает данные
6.Формируется отчёт

44
Рисунок 24. Диаграмма последовательности "Отчёт по клиентам за
определённый период"

Описание диаграммы последовательности «Отчёт по клиентам за


определённый период»
1.Сотрудник выбирает отчёт
2.Открывается форма не сформированного отчёта
3.Сотрудник заполняет поля: «Начало периода» и «Конец периода»
4.Отображает заполненные поля
5.Сотрудник нажимает на кнопку «Сформировать»
6.Отправляет запрос на получение данных
7.Получает данные
8.Формируется отчёт

45
Рисунок 25. Диаграмма последовательности "Отчёт по красителям"

Описание диаграммы последовательности «Отчёт по красителям»


1.Сотрудник выбирает отчёт
2.Открывается форма не сформированного отчёта
3.Сотрудник нажимает на кнопку «Сформировать»
4.Отправляет запрос на получение данных
5.Получает данные
6.Формируется отчёт

46
Рисунок 26. Диаграмма последовательности "Отчёт по мастерам за
определённый период"

Описание диаграммы последовательности «Отчёт по мастерам за


определённый период»
1.Сотрудник выбирает отчёт
2.Открывается форма не сформированного отчёта
3.Сотрудник заполняет поля: «Начало периода» и «Конец периода»
4.Отображает заполненные поля
5.Сотрудник нажимает на кнопку «Сформировать»
6.Отправляет запрос на получение данных
7.Получает данные
8.Формируется отчёт
47
Рисунок 27. Диаграмма последовательности "Отчёт по одному мастеру"

Описание диаграммы последовательности «Отчёт по одному мастеру»


1.Сотрудник выбирает отчёт
2.Открывается форма не сформированного отчёта
3.Сотрудник заполняет поле: «ФИОМастера»
4.Отображает заполненное поле
5.Сотрудник нажимает на кнопку «Сформировать»
6.Формируется отчёт

48
Рисунок 28. Диаграмма последовательности "отчёт Остаток товара на складе"

Описание диаграммы последовательности «отчёт Остаток товара на


складе»
1.Сотрудник выбирает отчёт
2.Открывается форма не сформированного отчёта
3.Сотрудник заполняет поле «Дата»
4.Отображает заполненное поле
5.Сотрудник нажимает на кнопку «Сформировать»
6.Отправляет запрос на получение данных
7.Получает данные
8.Формируется отчёт
49
Рисунок 29. Диаграмма последовательности "отчёт Остаток красителей на
складе"

Описание диаграммы последовательности «отчёт Остаток красителей на


складе»
1.Сотрудник выбирает отчёт
2.Открывается форма не сформированного отчёта
3.Сотрудник заполняет поле «Дата»
4.Отображает заполненное поле
5.Сотрудник нажимает на кнопку «Сформировать»
6.Отправляет запрос на получение данных
7.Получает данные
8.Формируется отчёт
50
4.Проектирование программного обеспечения

4.1. Средства разработки

Конфигурация для салона красоты Fashion Studio была разработана на


платформе 1С:Предприятие, для записи клиентов, расчёта клиентов, учёта
товара и составления отчётов.
1С:Предприятие — программный продукт компании «1С»,
предназначенный для автоматизации деятельности на предприятии.
Так же для наиболее наглядного представления процесса в Software
Ideas Modeler были построены диаграммы UML, прецедентов, классов и
последовательности.
Software Ideas Modeler – это программа для моделирования диаграмм
UML (Unified Modeling Language). UML – это язык графического описания
для объектного моделирования в области разработки программного
обеспечения, использующий графические обозначения для создания
абстрактной модели системы, называемой UML-моделью.

4.2. Описание приложения

Приложение позволяет хранить и обрабатывать всю необходимую


информацию для обслуживания клиентов салона красоты.
Приложение состоит из таких разделов как документы, справочники и
отчёты.
Справочники
Справочники - позволяют хранить в информационной базе данные,
имеющие одинаковую структуру и списочный характер.
В разделе «Справочники» представлены семь справочников:
 Должность;
 Клиенты;
 Красители;

51
 Склад;
 Сотрудники;
 Товар;
 Услуги.
На рисунке «Рисунок 30. Справочник Должность» представлен
справочник «Должность». Что бы его заполнить необходимо нажать на
кнопку «Создать» и в открывшемся окне заполнить поле «Наименование» и
нажать на кнопку «Записать и закрыть».

52
Рисунок 30. Справочник Должность

53
На рисунке «Рисунок 31. Справочник Клиенты» представлен
справочник «Клиенты». Что бы его заполнить необходимо нажать на кнопку
«Создать» и в открывшемся окне заполнить поля «ФИО», «Телефон»,
«Примечание» ( при необходимости) ,«Скидка в процентах» ( если у клиента
есть скидка) и нажать на кнопку «Записать и закрыть».

54
Рисунок 31. Справочник Клиенты

55
На рисунке «Рисунок 32. Справочник Красители» представлен
справочник «Красители». Что бы его заполнить необходимо нажать на
кнопку «Создать» и в открывшемся окне заполнить поле «Наименование» и
нажать на кнопку «Записать и закрыть».

56
Рисунок 32. Справочник Красители

57
На рисунке «Рисунок 33. Справочник Склад» представлен справочник
«Склад». Что бы его заполнить необходимо нажать на кнопку «Создать» и в
открывшемся окне заполнить поле «Наименование» и нажать на кнопку
«Записать и закрыть».

58
Рисунок 33. Справочник Склад

59
На рисунке «Рисунок 34. Справочник Сотрудники» представлен
справочник «Сотрудники». Что бы его заполнить необходимо нажать на
кнопку «Создать» и в открывшемся окне заполнить поля «ФИО»,
«Телефон», «Должность» и нажать на кнопку «Записать и закрыть».

60
Рисунок 34. Справочник Сотрудники

61
На рисунке «Рисунок 35. Справочник Товар» представлен справочник
«Товар». Что бы его заполнить необходимо нажать на кнопку «Создать» или
«Создать группу». При нажатии на одну из этих кнопок необходимо
заполнить поля «Наименование товара» и «Категория»

62
Рисунок 35. Справочник Товар

63
Если уже есть нужная группа, но туда надо добавить товар, то надо
выбрать необходимую группу и нажать на кнопку «Создать» , в открывшемся
окне заполнить поле «Наименование» и нажать на кнопку «Записать и
закрыть». Рисунок 36. Справочник Товар

64
Рисунок 36. Справочник Товар

65
На рисунке «Рисунок 37. Справочник Услуги» представлен
справочник «Услуги». Что бы его заполнить необходимо нажать на кнопку
«Создать» или «Создать группу». При нажатии на одну из этих кнопок
необходимо заполнить поля «Наименование товара» и «Родитель».

66
Рисунок 37. Справочник Услуги

67
Если уже есть нужная группа, но туда надо добавить услугу, то надо
выбрать необходимую группу и нажать на кнопку «Создать» , в открывшемся
окне заполнить поле «Наименование» и нажать на кнопку «Записать и
закрыть». Рисунок 38. Справочник Услуги.

68
Рисунок 38. Справочник Услуги

69
Документы
Документы - позволяют хранить в прикладном решении информацию о
совершенных хозяйственных операциях или о событиях, произошедших в
"жизни" предприятия.
В разделе «Документы» представлены восемь документов:
 Создать визит;
 Приход товара;
 Расход товара;
 Приход красителей;
 Расход красителей;
 Цены на красители;
 Цены на товары;
 Цены на услуги.
На рисунках «Рисунок 39. Документ Создать визит» и «Рисунок 40.
Документ Создать визит» представлен документ «Создать визит». Что бы
записать клиента необходимо нажать на кнопку «Создать» и в открывшемся
окне заполнить следующие поля: «ФИОКлиента», «ФИОМастера», «Время
начала», «Время конца» и заполнить табличную часть, добавить услугу, цена
встаёт автоматически, добавить краситель если он использовался в услуге,
так же цена встанет автоматически, добавить продавца т.е у кого была взята
краска, граммы, цена за грамм встанет автоматически, затем скидку и сумма
посчитается автоматически . После надо нажать на кнопку «Провести» или
«Провести и закрыть». После проведения документа в поле «Общая сумма»
появится общая сумма документа.

70
Рисунок 39. Документ Создать визит

71
Рисунок 40. Документ Создать визит

72
На рисунках «Рисунок 41. Документ Приход товара» и «Рисунок 42.
Документ Приход товара» представлен «Приход товара». Что бы создать
запись в документе необходимо нажать на кнопку «Создать». В открывшемся
окне в табличной части документа надо заполнить следующие поля: «Товар»,
«Количество», «Цена», «Склад» поле «Общая сумма» посчитается
автоматически. Затем необходимо нажать на кнопку «Провести» или
«Провести и закрыть». После проведения документа в поле «Общая сумма
документа» появится сумма всего документа.

73
Рисунок 41. Документ Приход товара

74
Рисунок 42. Документ Приход товара

75
На рисунках «Рисунок 43. Документ Расход товара» и «Рисунок 44.
Документ Расход товара» представлен документ «Расход товара». Что бы
создать запись в документе необходимо нажать на кнопку «Создать». В
открывшемся окне в табличной части документа надо заполнить следующие
поля: «Товар», «Количество», «Цена», «Склад» поле «Общая сумма»
посчитается автоматически. Затем необходимо нажать на кнопку «Провести»
или «Провести и закрыть». После проведения документа в поле «Общая
сумма документа» появится сумма всего документа.

76
Рисунок 43. Документ Расход товара

77
Рисунок 44. Документ Расход товара

78
На рисунках «Рисунок 45. Документ Цены на красители» и «Рисунок
46. Документ Цены на красители» представлен документ «Цены на
красители». Что бы создать запись в документе необходимо нажать на
кнопку «Создать». В открывшемся окне в табличной части документа надо
заполнить следующие поля: «Наименование», «Граммы», «Стоимость» и
нажать на кнопку «Провести» или «Провести и закрыть».

79
Рисунок 45. Документ Цены на красители

80
Рисунок 46. Документ Цены на красители

81
На рисунках «Рисунок 47. Документ Цены на товары» и «Рисунок 48.
Документ Цены на товары» представлен документ «Цены на товары». Что
бы создать запись в документе необходимо нажать на кнопку «Создать». В
открывшемся окне в табличной части документа надо заполнить следующие
поля: «Наименование», «Себестоимость», «Стоимость» и нажать на кнопку
«Провести» или «Провести и закрыть».

82
Рисунок 47. Документ Цены на товары

83
Рисунок 48. Документ Цены на товары

84
На рисунках «Рисунок 49. Документ Цены на услуги» и «Рисунок 50.
Документ Цены на услуги» представлен документ «Цены на услуги». Что
бы создать запись в документе необходимо нажать на кнопку «Создать». В
открывшемся окне в табличной части документа надо заполнить следующие
поля: «Наименование», «Цена» и нажать на кнопку «Провести» или
«Провести и закрыть».

85
Рисунок 49. Документ Цены на услуги

86
Рисунок 50. Документ Цены на услуги

87
На рисунках «Рисунок 51. Документ Приход красителей» и «Рисунок
52. Документ Приход красителей» представлен документ «Приход
красителей». Что бы создать запись в документе необходимо нажать на
кнопку «Создать». В открывшемся окне в табличной части документа надо
заполнить следующие поля: «Наименование», «Количество», «Цвет»,
«Стоимость», «Склад» поле «Общая сумма» посчитается автоматически.
Затем необходимо нажать на кнопку «Провести» или «Провести и закрыть».
После проведения документа в поле «Общая сумма документа» появится
сумма всего документа.

88
Рисунок 51. Документ Приход красителей

89
Рисунок 52. Документ приход красителей

90
На рисунках «Рисунок 53. Документ Расход красителей» и «Рисунок
54. Документ Расход красителей» представлен документ «Расход
красителей». Что бы создать запись в документе необходимо нажать на
кнопку «Создать». В открывшемся окне в табличной части документа надо
заполнить следующие поля: «Наименование», «Количество», «Цвет»,
«Стоимость», «Склад» поле «Общая сумма» посчитается автоматически.
Затем необходимо нажать на кнопку «Провести» или «Провести и закрыть».
После проведения документа в поле «Общая сумма документа» появится
сумма всего документа.

91
Рисунок 53. Документ Расход красителей

92
Рисунок 54. Документ Расход красителей

93
4.3.Выходные документы

Отчёты
Отчёты - предназначены для обработки накопленной информации и
получения сводных данных в удобном для просмотра и анализа виде.
Раздел «Отчёты» находится в разделе «Документы». В разделе
«Отчёты» представлены десять отчётов:
 Отчёт по одному клиенту;
 Отчёт по всем клиентам;
 Отчёт по клиентам за определённый период;
 Отчёт по мастерам за определённый период;
 Отчёт по одному мастеру;
 Остаток товара на складе;
 Выручка по услугам;
 Выручка по товарам;
 Отчёт по красителям;
 Остаток красителей на складе.
На рисунке «Рисунок 55. Отчёт по одному клиенту» представлен отчёт
«Отчёт по одному клиенту». Что бы сформировать данный отчёт, в поле
«ФИОКлиента» необходимо выбрать нужного клиента и нажать на кнопку
«Сформировать».

94
Рисунок 55. Отчёт по одному клиенту

95
На рисунке «Рисунок 56. Отчёт по всем клиентам» представлен отчёт
«Отчёт по всем клиентам». Что бы сформировать данный отчёт необходимо
нажать на кнопку «Сформировать».

96
Рисунок 56. Отчёт по всем клиентам

97
На рисунке «Рисунок 57. Отчёт по клиентам за определённый период»
представлен отчёт «Отчёт по клиентам за определённый период». Что бы
сформировать данный отчёт необходимо выбрать «Начало периода» и
«Конец периода» и нажать на кнопку «Сформировать».

98
Рисунок 57. Отчёт по клиентам за определённый период

99
На рисунке «Рисунок 58. Отчёт по мастерам за определённый период»
представлен отчёт «Отчёт по мастерам за определённый период». Что бы
сформировать данный отчёт необходимо выбрать «Начало периода» и
«Конец периода» и нажать на кнопку «Сформировать».

100
Рисунок 58. Отчёт по мастерам за определённый период

101
На рисунке «Рисунок 59. Отчёт по одному мастеру» представлен
отчёт «Отчёт по одному мастеру». Что бы сформировать данный отчёт, в
поле «ФИОМастера» необходимо выбрать нужного мастера и нажать на
кнопку «Сформировать».

102
Рисунок 59. Отчёт по одному мастеру

103
На рисунке «Рисунок 60. Отчёт Выручка по услугам» представлен
отчёт «Прибыль». Что бы сформировать данный отчёт необходимо выбрать
«Начало месяца» и «Конец месяца» и нажать на кнопку «Сформировать».

104
Рисунок 60. Отчёт Выручка по услугам

105
На рисунке «Рисунок 61. Отчёт Выручка по товарам» представлен
отчёт «Прибыль по товарам». Что бы сформировать данный отчёт
необходимо выбрать «Начало месяца» и «Конец месяца» и нажать на кнопку
«Сформировать».

106
Рисунок 61. Отчёт Выручка по товарам

107
На рисунке «Рисунок 62. Отчёт Остаток товара на складе» представлен
отчёт «Остаток товара на складе». Что бы сформировать данный отчёт
необходимо заполнить поле «Дата» и нажать на кнопку «Сформировать».

108
Рисунок 62. Отчёт Остаток товара на складе

109
На рисунке «Рисунок 63. Отчёт по красителям» представлен отчёт
«Отчёт по красителям». Что бы сформировать данный отчёт необходимо
нажать на кнопку «Сформировать».

110
Рисунок 63. Отчёт по красителям

111
На рисунке «Рисунок 64. Отчёт Остаток красителей на складе»
представлен отчёт «Остаток красителей на складе». Что бы сформировать
данный отчёт необходимо заполнить поле «Дата» и нажать на кнопку
«Сформировать».

112
Рисунок 64. Отчёт Остаток красителей на складе

113
Заключение
В ходе разработки дипломного проекта были выполнены следующие
задачи: была изучена предметная область - деятельность салона красоты.

На основе изученной предметной области были построены диаграммы


прецедентов, классов и последовательности для более наглядного
представления процессов.

Были определены архитектурные решения разрабатываемой


конфигурации

Было создано семь справочников, восемь документов, десять отчётов,


пять регистров сведений и четыре регистра накопления.

Результатом данной работы была разработка конфигурации для


платформы 1С:Предприятие.

114
Список литературы

1. Ивашко А.Г., Барская Г.Б., Моор П.К., Ивахник Д.Е.,


Методические рекомендации по проведению производственной и
преддипломной практики для студентов специальности 351400 «Прикладная
информатика в экономике».
2. Ивашко А.Г., Григорьев М.В., Коломиец И.И. Проектирование
информационных систем. - Тюмень: Издательство ТюмГУ, 2007г
3. Хрусталева Е. Ю., "101 совет начинающим разработчикам в
системе "1С:Предприятие 8", 2014г
4. Ажеронок В.А., Разработка управляемого интерфейса. Серия
"1С:Профессиональная разработка", 2014г
5. 1C:Предприятие 8.3. Практическое пособие разработчика.
Примеры и типовые приемы: http://v8.1c.ru/metod/books/book.jsp?id=441

6. ГОСТ 7.32-2001.Отчет о научно-исследовательской работе.


Структура и правила оформления. - Взамен ГОСТ 7.32-91; Введ.01.07.01.
7. ГОСТ 7.1-84. Библиографическое описание документа. Общие
требования и правила составления. Вед 01.01.86.
8. ГОСТ 2.105-95. Общие требования к текстовой документации. -
Взамен ГОСТ 2.105-79, ГОСТ 2.906-71; Введ. 01.07.96.
9. ГОСТ Р 6.30-97 Требования к оформлению документов - Введ.
01.07.98.
10. ГОСТ 7.12-93. Библиографическая запись. Сокращение слов на
русском языке. Общие требования и правила. - Взамен ГОСТ 7.12—77; Введ.
13.12.94

115
Приложение
Программный код документа «Создать визит»

Расположение: Формы – ФормаДокумента - Модуль


&НаКлиенте

Процедура УслугиГраммыПриИзменении(Элемент)

СтрокаТабличнойЧасти = Элементы.Услуги.ТекущиеДанные;

СтрокаТабличнойЧасти.СуммаЗаКрасителиРуб = СтрокаТабличнойЧасти.Граммы
* СтрокаТабличнойЧасти.ЦенаНаКрасительРуб;

СтрокаТабличнойЧасти.СуммаРуб = СтрокаТабличнойЧасти.СуммаЗаКрасителиРуб +
СтрокаТабличнойЧасти.ЦенаНаУслугуРуб;

КонецПроцедуры

&НаКлиенте

Процедура УслугиЦенаНаУслугуПриИзменении(Элемент)

СтрокаТабличнойЧасти = Элементы.Услуги.ТекущиеДанные;

СтрокаТабличнойЧасти.СуммаРуб = СтрокаТабличнойЧасти.СуммаЗаКрасителиРуб +
СтрокаТабличнойЧасти.ЦенаНаУслугуРуб;

КонецПроцедуры

&НаКлиенте

Процедура УслугиЦенаНаКрасительПриИзменении(Элемент)

СтрокаТабличнойЧасти = Элементы.Услуги.ТекущиеДанные;

СтрокаТабличнойЧасти.СуммаЗаКрасителиРуб = СтрокаТабличнойЧасти.Граммы
* СтрокаТабличнойЧасти.ЦенаНаКрасительРуб;

СтрокаТабличнойЧасти.Сумма = СтрокаТабличнойЧасти.СуммаЗаКрасителиРуб +
СтрокаТабличнойЧасти.ЦенаНаУслугуРуб;

КонецПроцедуры

&НаКлиенте

Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)

116
ОбщийИтог = Объект.Услуги.Итог("СуммаРуб");

КонецПроцедуры

&НаКлиенте

Процедура УслугиСуммаПриИзменении(Элемент)

СтрокаТабличнойЧасти = Элементы.Услуги.ТекущиеДанные;

СтрокаТабличнойЧасти.СуммаРуб = СтрокаТабличнойЧасти.СуммаЗаКрасителиРуб +
СтрокаТабличнойЧасти.ЦенаНаУслугуРуб;

СтрокаТабличнойЧасти.СуммаРуб = СтрокаТабличнойЧасти.СуммаРуб - (
СтрокаТабличнойЧасти.СуммаРуб * СтрокаТабличнойЧасти.СкидкаВПроцентах / 100);

КонецПроцедуры

&НаКлиенте

Процедура УслугиСкидкаПриИзменении(Элемент)

СтрокаТабличнойЧасти = Элементы.Услуги.ТекущиеДанные;

СтрокаТабличнойЧасти.СуммаРуб = СтрокаТабличнойЧасти.СуммаРуб - (
СтрокаТабличнойЧасти.СуммаРуб * СтрокаТабличнойЧасти.СкидкаВПроцентах / 100);

КонецПроцедуры

&НаКлиенте

Процедура УслугиУслугаПриИзменении(Элемент)

ТекДан = Элементы.Услуги.ТекущиеДанные;ТекДан.ЦенаНаУслугуРуб =
УслугиУслугаПриИзмененииНаСервере(Объект.Дата,ТекДан.Услуга)

КонецПроцедуры

&НаСервере

Функция УслугиУслугаПриИзмененииНаСервере(Дата,Элемент)

Запрос = Новый Запрос;

Запрос.Текст =

117
"ВЫБРАТЬ

| ЦеныНаУслугиСрезПоследних.Наименование,

| ЦеныНаУслугиСрезПоследних.ЦенаРуб

|ИЗ

| РегистрСведений.ЦеныНаУслуги.СрезПоследних(&ДатаЦе,
Наименование = &Наименование) КАК ЦеныНаУслугиСрезПоследних";

Запрос.УстановитьПараметр("ДатаЦе", Дата);

Запрос.УстановитьПараметр("Наименование",Элемент);

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

Возврат ВыборкаДетальныеЗаписи.ЦенаРуб;

КонецЦикла;

КонецФункции

&НаКлиенте

Процедура УслугиКрасителиПриИзменении(Элемент)

//УслугиКрасителиПриИзмененииНаСервере();

ТекДан = Элементы.Услуги.ТекущиеДанные;

ТекДан.ЦенаНаКрасительРуб =
УслугиКрасителиПриИзмененииНаСервере(Объект.Дата,ТекДан.Красители);

КонецПроцедуры

&НаСервере

Функция УслугиКрасителиПриИзмененииНаСервере(Дата,Элемент)

Запрос = Новый Запрос;

Запрос.Текст =

"ВЫБРАТЬ

| ЦеныНаКрасителиСрезПоследних.Наименование,
118
| ЦеныНаКрасителиСрезПоследних.СтоимостьРуб

|ИЗ

| РегистрСведений.ЦеныНаКрасители.СрезПоследних(&ДатаЦе,
Наименование = &Наименование) КАК ЦеныНаКрасителиСрезПоследних";

Запрос.УстановитьПараметр("ДатаЦе", Дата);

Запрос.УстановитьПараметр("Наименование", Элемент);

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

Возврат ВыборкаДетальныеЗаписи.СтоимостьРуб;

КонецЦикла;

КонецФункции

&НаКлиенте

Процедура УслугиСуммаЗаКрасителиПриИзменении(Элемент)

СтрокаТабличнойЧасти = Элементы.Услуги.ТекущиеДанные;

СтрокаТабличнойЧасти.СуммаЗаКрасителиРуб = СтрокаТабличнойЧасти.Граммы *
СтрокаТабличнойЧасти.ЦенаНаКрасительРуб;

КонецПроцедуры

Расположение: Прочее –Модуль объекта


Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)

ОбщаяСуммаРуб = 0;

Для каждого СтрокаТаблицыТовары Из Услуги Цикл

ОбщаяСуммаРуб= ОбщаяСуммаРуб+СтрокаТаблицыТовары.СуммаРуб;

КонецЦикла;

КонецПроцедуры

119
Программный код документа «Приход товара»

Расположение: Формы – ФормаДокумента - Модуль


&НаКлиенте

Процедура ПриходКоличествоПриИзменении(Элемент)

СтрокаТабличнойЧасти = Элементы.Приход.ТекущиеДанные;

СтрокаТабличнойЧасти.ОбщаяСуммаРуб = СтрокаТабличнойЧасти.Количество *
СтрокаТабличнойЧасти.ЦенаРуб;

КонецПроцедуры

&НаКлиенте

Процедура ПриходЦенаПриИзменении(Элемент)

СтрокаТабличнойЧасти = Элементы.Приход.ТекущиеДанные;

СтрокаТабличнойЧасти.ОбщаяСуммаРуб = СтрокаТабличнойЧасти.Количество *
СтрокаТабличнойЧасти.ЦенаРуб;

КонецПроцедуры

&НаКлиенте

Процедура ПриходОбщаяСуммаПриИзменении(Элемент)

СтрокаТабличнойЧасти = Элементы.Приход.ТекущиеДанные;

СтрокаТабличнойЧасти.ЦенаРуб =
СтрокаТабличнойЧасти.ОбщаяСуммаРуб/СтрокаТабличнойЧасти.Количество;

КонецПроцедуры

&НаКлиенте

Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)

ОбщийИтог = Объект.Приход.Итог("ОбщаяСуммаРуб");

КонецПроцедуры

120
Расположение: Прочее –Модуль объекта
Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)

ОбщаяСуммаДокументаРуб = 0;

Для каждого СтрокаТаблицыТовары Из Приход Цикл

ОбщаяСуммаДокументаРуб=
ОбщаяСуммаДокументаРуб+СтрокаТаблицыТовары.ОбщаяСуммаРуб;

КонецЦикла;

КонецПроцедуры

Программный код документа «Расход товара»

Расположение: Формы – ФормаДокумента - Модуль


&НаКлиенте

Процедура РасходКоличествоПриИзменении(Элемент)

СтрокаТабличнойЧасти = Элементы.Расход.ТекущиеДанные;

СтрокаТабличнойЧасти.ОбщаяСуммаРуб = СтрокаТабличнойЧасти.Количество *
СтрокаТабличнойЧасти.ЦенаРуб;

КонецПроцедуры

&НаКлиенте

Процедура РасходЦенаПриИзменении(Элемент)

СтрокаТабличнойЧасти = Элементы.Расход.ТекущиеДанные;

СтрокаТабличнойЧасти.ОбщаяСуммаРуб = СтрокаТабличнойЧасти.Количество *
СтрокаТабличнойЧасти.ЦенаРуб;

КонецПроцедуры

&НаКлиенте

Процедура РасходОбщаяСуммаПриИзменении(Элемент)

СтрокаТабличнойЧасти = Элементы.Расход.ТекущиеДанные;
121
СтрокаТабличнойЧасти.ЦенаРуб =
СтрокаТабличнойЧасти.ОбщаяСуммаРуб/СтрокаТабличнойЧасти.Количество;

КонецПроцедуры

&НаКлиенте

Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)

ОбщийИтог = Объект.Расход.Итог("ОбщаяСуммаРуб");

КонецПроцедуры

&НаКлиенте

Процедура РасходТоварПриИзменении(Элемент)

ТекДан = Элементы.Расход.ТекущиеДанные;

ТекДан.ЦенаРуб =
РасходТоварПриИзмененииНаСервере1(Объект.Дата,ТекДан.Товар);

КонецПроцедуры

&НаСервере

Функция РасходТоварПриИзмененииНаСервере1(Дата,Элемент)

Запрос = Новый Запрос;

Запрос.Текст =

Запрос = Новый Запрос;

Запрос.Текст =

"ВЫБРАТЬ

| ЦеныНаТоварыСрезПоследних.Наименование,

| ЦеныНаТоварыСрезПоследних.СтоимостьРуб

|ИЗ

| РегистрСведений.ЦеныНаТовары.СрезПоследних(&ДатаЦе,
Наименование = &Наименование) КАК ЦеныНаТоварыСрезПоследних";

Запрос.УстановитьПараметр("ДатаЦе", Дата);

122
Запрос.УстановитьПараметр("Наименование", Элемент);

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

Возврат ВыборкаДетальныеЗаписи.СтоимостьРуб;

КонецЦикла;

КонецФункции

Расположение: Прочее –Модуль объекта


Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)

ОбщаяСуммаДокументаРуб = 0;

Для каждого СтрокаТаблицыТовары Из Расход Цикл

ОбщаяСуммаДокументаРуб=
ОбщаяСуммаДокументаРуб+СтрокаТаблицыТовары.ОбщаяСуммаРуб;

КонецЦикла;

КонецПроцедуры

Программный код документа «Приход красителей»

Расположение: Формы – ФормаДокумента - Модуль


&НаКлиенте

Процедура ПриходКоличествоПриИзменении(Элемент)

СтрокаТабличнойЧасти = Элементы.Приход.ТекущиеДанные;

СтрокаТабличнойЧасти.ОбщаяСуммаРуб = СтрокаТабличнойЧасти.Количество *
СтрокаТабличнойЧасти.СтоимостьРуб;

КонецПроцедуры

&НаКлиенте

Процедура ПриходСтоимостьПриИзменении(Элемент)

СтрокаТабличнойЧасти = Элементы.Приход.ТекущиеДанные;

123
СтрокаТабличнойЧасти.ОбщаяСуммаРуб = СтрокаТабличнойЧасти.Количество *
СтрокаТабличнойЧасти.СтоимостьРуб;

КонецПроцедуры

&НаКлиенте

Процедура ПриходОбщаяСуммаПриИзменении(Элемент)

СтрокаТабличнойЧасти = Элементы.Приход.ТекущиеДанные;

СтрокаТабличнойЧасти.СтоимостьРуб =
СтрокаТабличнойЧасти.ОбщаяСуммаРуб/СтрокаТабличнойЧасти.Количество;

КонецПроцедуры

&НаКлиенте

Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)

ОбщийИтог = Объект.Приход.Итог("ОбщаяСуммаРуб");

КонецПроцедуры

Расположение: Прочее –Модуль объекта


Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)

ОбщаяСуммаДокументаРуб = 0;

Для каждого СтрокаТаблицыТовары Из Приход Цикл

ОбщаяСуммаДокументаРуб=
ОбщаяСуммаДокументаРуб+СтрокаТаблицыТовары.ОбщаяСуммаРуб;

КонецЦикла;

КонецПроцедуры

Программный код документа «Расход красителей»


&НаКлиенте

Процедура РасходКоличествоПриИзменении(Элемент)

СтрокаТабличнойЧасти = Элементы.Расход.ТекущиеДанные;

СтрокаТабличнойЧасти.ОбщаяСуммаРуб = СтрокаТабличнойЧасти.Количество *
СтрокаТабличнойЧасти.СтоимостьРуб;

124
КонецПроцедуры

&НаКлиенте

Процедура РасходСтоимостьПриИзменении(Элемент)

СтрокаТабличнойЧасти = Элементы.Расход.ТекущиеДанные;

СтрокаТабличнойЧасти.ОбщаяСуммаРуб = СтрокаТабличнойЧасти.Количество *
СтрокаТабличнойЧасти.СтоимостьРуб;

КонецПроцедуры

&НаКлиенте

Процедура РасходОбщаяСуммаПриИзменении(Элемент)

СтрокаТабличнойЧасти = Элементы.Расход.ТекущиеДанные;

СтрокаТабличнойЧасти.СтоимостьРуб =
СтрокаТабличнойЧасти.ОбщаяСуммаРуб/СтрокаТабличнойЧасти.Количество;

КонецПроцедуры

&НаКлиенте

Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)

ОбщийИтог = Объект.Расход.Итог("ОбщаяСуммаРуб");

КонецПроцедуры

Расположение: Прочее –Модуль объекта


Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)

ОбщаяСуммаДокументаРуб = 0;

Для каждого СтрокаТаблицыТовары Из Расход Цикл

ОбщаяСуммаДокументаРуб=
ОбщаяСуммаДокументаРуб+СтрокаТаблицыТовары.ОбщаяСуммаРуб;

КонецЦикла;

КонецПроцедуры

125

Вам также может понравиться