Вы находитесь на странице: 1из 6

Lab Worksheet 6

Static and Dynamic (RIP) Routing

I. Objectives

Upon completion of this lab, you will be able to:


• Understand concept of routing both static and dynamic
• Configure dynamic routing specifically RIP and compare to static routing. More advanced routing
protocols like EIGRP and OSPF will not be covered yet on this activity.

II. Discussion of the Theory

Routing tables can contain directly connected, manually configured static routes and routes
learned dynamically using a routing protocol. Network professionals must understand when to use static
or dynamic routing. This section compares static routing and dynamic routing.

Static Routing Advantages and Disadvantages


Advantages Disadvantages
Easy to implement in a small network. Suitable for simple topologies or for special purposes
such as a default static route.
Very secure. No advertisements are sent, Configuration complexity increases dramatically as the
unlike with dynamic routing protocols. network grows. Managing the static configurations in
large networks can become time consuming.
It is very predictable, as the route to the If a link fails, a static route cannot reroute traffic.
destination is always the same. Therefore, manual intervention is required to re-route
traffic.
No routing algorithm or update mechanisms
are required. Therefore, extra resources (CPU
and memory) are not required.

Dynamic Routing Advantages and Disadvantages


Advantages Disadvantages
Suitable in all topologies where multiple Can be more complex to initially implement.
routers are required.
Generally independent of the network size. Less secure due to the broadcast and multicast routing
updates. Additional configuration settings such as
passive interfaces and routing protocol authentication
are required to increase security.
Automatically adapts topology to reroute traffic Route depends on the current topology.
if possible.
Requires additional resources such as CPU, memory,
and link bandwidth.

Notice how dynamic routing addresses the disadvantages of static routing.

1
III. Lab Exercise

Task 1: Configure Static Routing

Step 1: Setup the following initial configurations on R1, R2, and R3.

On R1:

configure terminal
!
hostname R1
!
interface Loopback0
ip address 10.61.10.1 255.255.255.0
!
interface Serial0/0
no ip address
encapsulation frame-relay
serial restart-delay 0
no frame-relay inverse-arp
!
interface Serial0/0.122 point-to-point
ip address 10.61.12.1 255.255.255.252
frame-relay interface-dlci 122
!
interface Serial0/0
no shut

On R2:
configure terminal
!
hostname R2
!
interface Loopback0
ip address 10.61.20.1 255.255.255.0
!
interface Serial0/0
no ip address
encapsulation frame-relay
serial restart-delay 0
no frame-relay inverse-arp

2
!
interface Serial0/0.221 point-to-point
ip address 10.61.12.2 255.255.255.252
frame-relay interface-dlci 221
!
interface Serial0/0.223 point-to-point
ip address 10.61.23.1 255.255.255.252
frame-relay interface-dlci 223
!
interface Serial0/0
no shut
!

On R3:
configure terminal
!
hostname R3
!
interface Loopback0
ip address 10.61.30.1 255.255.255.0
!
interface Serial0/0
no ip address
encapsulation frame-relay
serial restart-delay 0
no frame-relay inverse-arp
!
interface Serial0/0.322 point-to-point
ip address 10.61.23.2 255.255.255.252
frame-relay interface-dlci 322
!
interface Serial0/0
no shut

Step 2: Configure a static route


Create a Static Route on R1 that states to get to 10.61.20.0/24 go to the next hop of 10.61.12.2
then place the return route on R2 stating to get to 10.61.10.0/24 go to the next hop of 10.61.12.1

R1#configure terminal
R1(config)#ip route 10.61.20.0 255.255.255.0 10.61.12.2
R1(config)#end

R2#configure terminal
R2(config)#ip route 10.61.10.0 255.255.255.0 10.61.12.1
R2(config)#end

From R1, ping the loopback address of R2. What is the result?
____________________________________________________________________________

Check the routing table of R2 by issuing the command show ip route. What do you observe?

_____________________________________________________________________________
_____________________________________________________________________________
_____________________________________________________________________________
_____________________________________________________________________________

3
Step 3: Create a Static Route on R2 that states to get to 10.61.30.0/24 go to the next hop of 10.61.23.2
then place the return route on R3 stating to get to 10.61.20.0/24 go to the next hop of 10.61.23.1

R2#configure terminal
R2(config)#ip route 10.61.30.0 255.255.255.0 10.61.23.2
R2(config)#end

R3#configure terminal
R3(config)#ip route 10.61.20.0 255.255.255.0 10.61.23.1
R3(config)#end

From R2, ping the loopback address of R3. What is the result?
_____________________________________________________________________________

Check the routing table of R3 by issuing the command show ip route. What do you observe?
_____________________________________________________________________________
_____________________________________________________________________________
_____________________________________________________________________________

Step 4: Configure R1 to route 10.61.30.0/24 to the next hop of 10.61.12.2 (R2) then configure R3 to route
10.61.10.0/24 to 10.61.23.1

R1#configure terminal
R1(config)#ip route 10.61.30.0 255.255.255.0 10.61.12.2
R1(config)#end

R3#configure terminal
R3(config)#ip route 10.61.10.0 255.255.255.0 10.61.23.1
R3(config)#end

From R1, ping the loopback address of R3. What is the result?
_____________________________________________________________________________

Check the routing table of R3 by issuing the command show ip route. What do you observe?
_____________________________________________________________________________
_____________________________________________________________________________
___________________________________________________________________________

Step 5: Configure R1 to reach R2 and R3 loopback through a default static route.

Remove the current static route configurations on R1 and configure default route.

R1# show run | include ip route


ip route 10.61.20.0 255.255.255.0 10.61.12.2
ip route 10.61.30.0 255.255.255.0 10.61.12.2

R1# configure terminal


R1(config)#no ip route 10.61.20.0 255.255.255.0 10.61.12.2
R1(config)#no ip route 10.61.30.0 255.255.255.0 10.61.12.2
R1(config)# ip route 0.0.0.0 0.0.0.0 10.61.12.2
R1(config)#end

From R1, ping the loopback address of R2 and R3. What is the result?
_____________________________________________________________________________
_____________________________________________________________________________

4
Check the routing table of R1 by issuing the command show ip route. What do you observe?

_____________________________________________________________________________
_____________________________________________________________________________
_____________________________________________________________________________
_____________________________________________________________________________

Task 2: Configure dynamic routing protocols through the use of RIP.

Step 1: Remove all static routes currently configured on R1, R2 and R3. Save the configurations on the
three routers.
R1(config)# no ip route

R2(config)# no ip route

R3(config)# no ip route

Step 2: Verify at this point, R1 cannot ping loopback address of R3.


_____________________________________________________________________________
_____________________________________________________________________________
_____________________________________________________________________________

Step 3: Configure the all the routes with the following configurations.

R1#configure terminal
R1(config)#router rip
R1(config-router)#network 10.0.0.0
R1(config-router)#end

R2#configure terminal
R2(config)#router rip
R2(config-router)#network 10.0.0.0
R2(config-router)#end

R3#configure terminal
R3(config)#router rip
R3(config-router)#network 10.0.0.0
R3(config-router)#end

Step 4: View the routing table to verify that routes are being learned via RIP.
Describe the result by issuing the commands

R2#show ip protocols

R2#show ip route

5
R2#show ip rip database

Step 5: Verify connectivity.


From R1, ping the loopback of R2. What is the result?
___________________________________________________________

From R3, ping the loopback of R1. What is the result?


___________________________________________________________

Step 6: Enable RIP version 2 in the 3 routers.

R1#configure terminal
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#end

R2#configure terminal
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#end

R3#configure terminal
R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#end

Check the routing table of R2 in RIP version 2 and compare to the routing table of R2 previously
on RIP version 1. Describe the differences and similarities
_____________________________________________________________________________
_____________________________________________________________________________
_____________________________________________________________________________
_____________________________________________________________________________
IV. Conclusion

*End of Lab Worksheet 6*

Вам также может понравиться