Вы находитесь на странице: 1из 10

Лабораторная работа «Настройка маршрутизации между сетями VLAN с

использованием конфигурации router-on-a-stick»


Часть 1.
Шаг 1.     С помощью утилиты ping проверьте связь между PC1 и PC3.

Шаг 2..
Нажмите « Захват / пересылка», чтобы увидеть шаги, которые выполняет эхо- запрос
между ПК1 и ПК3 . Обратите внимание, что пинг никогда не покидает ПК1 . Какой процесс не
удался и почему?
b) Процесс ARP завершился неудачно, потому что запрос ARP так и не достиг ПК3. ПК1 и ПК3 не
находятся в одной сети, поэтому S1 не пересылает ARP-запрос ПК1 (широковещательный пакет)
в VLAN30. ПК1 никогда не получает MAC-адрес для ПК3. Без MAC-адреса ПК1 не может создать
эхо-запрос ICMP.

Часть 2.
Шаг 1: Создайте VLAN на S1.
Вернитесь в режим реального времени и создайте VLAN 10 и VLAN 30 на S1 .
S1>enable
S1#conf t
S1(config)#vlan 10
S1(config-vlan)#exit
S1(config)#vlan 30
S1(config-vlan)#exit
Шаг 2. Назначьте портам сети VLAN.
Настройте интерфейс F0 / 6 и F0 / 11 как порты доступа и назначьте VLAN.
S1(config)#int f0/11
S1(config-if)#switchport mode access
S1(config-if)#switchport access vlan 10
S1(config-if)#exit
S1(config)#int f0/6
S1(config-if)#switchport mode access
S1(config-if)#switchport access vlan 30
S1(config-if)#exit
S1(config-if)# int g0/1
S1(config-if)# switchport mode trunk
b. Для проверки конфигурации VLAN выполните команду show vlan brief.
S1# show vlan brief

Шаг 3. Проверьте связь между ПК1 и ПК3.


Отправьте эхо-запрос от узла PC1 на PC3. Эхо-запросы по-прежнему должны не проходить
между узлами. Почему проверка связи с помощью эхо-запросов завершается неудачно?
Каждая VLAN представляет собой отдельную сеть и требует маршрутизатора или коммутатора
уровня 3 для обеспечения связи между ними.
Часть 3. Настройка подынтерфейсов
Шаг 1.
Создайте подынтерфейс G0/0.10.
Установите для типа инкапсуляции значение 802.1Q и назначьте сеть VLAN 10
подынтерфейсу.
См. Таблицу адресации; назначьте интерфейсу правильный IP-адрес.
R1>en
R1#conf t
R1(config)#int g0/0.10
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip add 172.17.10.1 255.255.255.0
R1(config-subif)#exit

Повторите данную операцию для подынтерфейса G0/0.30.


R1(config)#int g0/0.30
R1(config-subif)#encapsulation dot1Q 30
R1(config-subif)#ip add 172.17.30.1 255.255.255.0
R1(config-subif)#exit

Шаг 2. Проверьте конфигурацию.

a. С помощью команды show ip interface brief проверьте конфигурацию


подынтерфейса. Оба подынтерфейса отключены. Подынтерфейсы — это
виртуальные интерфейсы, связанные с физическим интерфейсом. Поэтому, чтобы
включить подынтерфейсы, необходимо сначала включить физический интерфейс, с
которым они связаны.
b. Включите интерфейс G0/0. Убедитесь в том, что теперь подынтерфейсы
работают.
R1(config)#int g0/0
R1(config-if)#no sh

Часть 4.
Шаг 2: Включите транкинг.
a) На коммутаторе S1 выполните команду show vlan. Какой сети VLAN назначен интерфейс G0/1?
Vlan 1

b) Поскольку в настройках маршрутизатора множество подынтерфейсов назначены


разным сетям VLAN, коммутационный порт, подключаемый к маршрутизатору,
должен настраиваться как магистральный канал. Настройте интерфейс G0/1 как
магистральный канал.
R1(config)# int g0 / 1
R1(config-if)# switchport mode trunk
R1(config-if)#exit
c) Интерфейс больше не указан в VLAN 1.
Шаг 3.     Перейдите в режим Simulation (Моделирование), чтобы наблюдать за
прохождением ping-запросов.
Лабораторная работа «Устранение неполадок маршрутизации между
VLAN»
Настройка R1: Назначьте IP-адресацию R1 и S1 на основе таблицы адресации .
R1>en
R1#conf t
R1(config)#int g0/0
R1(config-if)#ip add 172.17.25.2 255.255.255.252
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#int g0/1.10
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip add 172.17.10.1 255.255.255.0
R1(config-subif)#exit
R1(config)#int g0/1.20
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip add 172.17.20.1 255.255.255.0
R1(config-subif)#exit
R1(config)#int g0/1.30
R1(config-subif)#encapsulation dot1Q 30
R1(config-subif)#ip add 172.17.30.1 255.255.255.0
R1(config-subif)#exit
R1(config)#int g0/1.88
R1(config-subif)#encapsulation dot1Q 88
R1(config-subif)#ip add 172.17.88.1 255.255.255.0
R1(config-subif)#exit
R1(config)#int g0/1.99
R1(config-subif)#encapsulation dot1Q 99
R1(config-subif)#ip add 172.17.99.1 255.255.255.0
R1(config-subif)#exit
R1(config)#int g0/1
R1(config-if)#no shut
Настройка S1: Создайте, назовите и назначьте сети VLAN на S1 на основе таблицы VLAN и
назначения портов . Порты должны быть в режиме доступа.
S1>en
S1#conf t
S1(config)#vl 10
S1(config-vlan)#na Faculty/Staff
S1(config-vlan)#vl 20
S1(config-vlan)#na Students
S1(config-vlan)#vl 30
S1(config-vlan)#na Guest(Default)
S1(config-vlan)#vl 88
S1(config-vlan)#na Native
S1(config-vlan)#vl 99
S1(config-vlan)#na Management
S1(config-vlan)#exit
S1(config)#int range f0/11-17
S1(config-if-range)#switchport mode access
S1(config-if-range)#switchport access vlan 10
S1(config-if-range)#int range f0/18-24
S1(config-if-range)#switchport mode access
S1(config-if-range)#switchport access vlan 20
S1(config-if-range)#int range f0/6-10
S1(config-if-range)#switchport mode access
S1(config-if-range)#switchport access vlan 30
S1(config-if-range)#exit

Настройте S1 на транк, разрешите только VLAN в таблице VLAN и Port Assignment Table .
Настройте шлюз по умолчанию на S1.
S1(config)#int g0/1
S1(config-if)#no shut
S1(config-if)#switchport mode trunk
S1(config-if)#switchport trunk native vlan 88
S1(config-if)#switchport trunk allowed vlan 10,20,30,88,99
S1(config-if)#exit

Настройте шлюз по умолчанию на S1.

S1(config)#int vlan 99
S1(config-if)#ip add 172.17.99.10 255.255.255.0
S1(config-if)#no shut
S1(config-if)#exit
S1(config)#ip default-gateway 172.17.99.1
S1(config)#int range f0/1-5, g0/2
S1(config-if-range)#shut

Оценить