Вы находитесь на странице: 1из 7

ПРАКТИЧЕСКОЕ ЗАНЯТИЕ №18

ТЕМА: Настройка NAT.

ЦЕЛЬ: научиться настраивать NAT.

ТИП ЗАНЯТИЯ: выполнение комплексных заданий.

1)Построил ЛВС.

2)Настройки интерфейсов маршрутизаторов.

L1 G1 G2
Ethernet 10.10.1.2 10.10.1.1
Serial 175.10.1.1 175.10.1.2
Задайте OSPF маршрутизацию на G1

G1(config)#router ospf 1
G1(config- router)#network 10.10.1.0 0.0.0.255 area 0
G1(config- router)#network 175.10.1.0 0.0.0.255 area 0

На L1
L1 (config)#router ospf 1
L1 (config- router)#network 10.10.1.0 0.0.0.255 area 0
Для G2
G2 (config)#router ospf 1
G2(config- router)#network 175.10.1.0 0.0.0.255 area 0

На G2 разрешим вход по телнет с паролем G2


G2 (config)#line vty 0 4
G2 (config-line)#login
G2 (config-line)#password G2

Проверьте работоспособность сети с помощью команды ping. Проверьте


Telnet-
соединение из L1 (10.10.1.2) к G2
L1# telnet 175.10.1.2
Password:G2
G2>show users
G1(config)#ip nat inside source static 10.10.1.2 175.10.1.2
Определим сеть fastEthernet0/0 интерфейса как внутреннюю
G1(config)#interface fa0/0
G1(config-if)# ip nat inside
Определим сеть serial2/0 интерфейса как внешнюю
G1(config-if)#interface s2/0
G1(config-if#ip nat outside

Для вывода таблицы переводов адресов введите команду на


маршрутизаторе
G1#show ip nat translations

Проверьте перевод, создав Telnet-соединение из L1 к G2. Войдя по


Telnet на G2 введите команду show users. Вы должны увидеть переведенный
IP-адрес 175.10.1.2.
L1#  telnet 175.10.1.2
Password:G2
G2> show users
Вместо 169.10.1.2 можно использовать и задействованный адрес
интерфейса Serial2/0 G1
175.10.1.1
G1(config)#no ip nat inside source static 10.10.1.2 175.10.1.2
G1(config)#ip nat inside source static 10.10.1.2 175.10.1.1

L1#  telnet 175.10.1.2


Password:G2
G2> show users

На маршрутизаторе G1 удалил предыдущую NAT-команду


статистического перевода
G1(config)#no ip nat inside source static 10.10.1.2 175.10.1.1
и настроил NAT для динамического перевода Ethernet-адреса
маршрутизатора L1. Используем область адресов в диапазоне: 175.10.1.50 -
169.10.1.100. Определим пул адресов pool1
G1(config)#ip nat pool pool1 175.10.1.50 175.10.1.100 netmask
255.255.255.0
Зададим NAT преобразование адресов из списка 1 в пул адресов pool1
G1(config)#ip nat inside source list 1 pool pool1
Настроим и проверим список доступа 1 для внутренних адресов,
которые будут преобразовываться
G1(config)#access-list 1 permit 10.10.1.0 0.0.0.255
^Z
G1#Show access-list
С помощью команды show running-config проверил, что маршрутизатор
G1 «подхватил» введённые команды.

Проверьте перевод, создав Telnet-соединение из L1 к маршрутизатору


G2. Войдя по Telnet на G2 введите команду show users. Вы должны увидеть
переведенный IP- адрес 175.10.1.50.
L1#  telnet 175.10.1.2
Password:G2
G2> show users
То есть NAT взял из пула адресов первый свободный адрес 175.10.1.50.
Для вывода таблицы переводов адресов ввел команду show ip nat
translations
на маршрутизаторе G1.

На маршрутизаторе G1 удалите предыдущие NAT-команды


динамического перевода и настройте перегрузку (перевод адресов портов)
Ethernet-адреса маршрутизатора L1 (10.10.1.2) на адрес интерфейса serial2/0
(175.10.1.1) на маршрутизаторе G1.
G1(config)#no ip nat pool pool1 175.10.1.50 175.10.1.100 netmask
255.255.255.0
G1(config)#no nat inside source list 1 pool pool1
G1(config)#ip nat inside source list 1 interface s2/0 overload

C помощью команды show running-config проверил, что маршрутизатор


G1 «подхватил» введённые команды.

Проверил перевод, создав Telnet-соединение из L1 к маршрутизатору


G2. Находясь на маршрутизаторе G2, ввел команду show users.
L1#  telnet 175.10.1.2
Password:G2
G2> show users
Выведите список NAT-переводов на маршрутизаторе G1.
G1#show ip nat translations

Вывод: научился настраивать NAT.