Вы находитесь на странице: 1из 13

01

Аггрегация каналов в
DualWAN на Mikrotik
Вступайте в группу в
telegram

http://t.me/miktrain
Аггрегация каналов в DualWAN на Mikrotik.
.

Вопросы вебинара
• Общие сведения и проблемы
• Постановка задачи
• ECMP - Equal Cost Multi-Path
• PCC – per connection classifier
• Nth – использование соединения по счету
• Использование опции random

Курсы по Mikrotik с гарантией результата 2


Аггрегация каналов в DualWAN на Mikrotik.

Общие сведения и проблемы

• Многие компании могут позволить себе резервный выход в интернет


• Проблема в том, что резервный канал чаще всего простаивает, не
принося никакой пользы 99% времени.
• Сегодня я расскажу как задействовать оба канала и распределить
нагрузку между ними

Курсы по Mikrotik с гарантией результата 3


Аггрегация каналов в DualWAN на Mikrotik.

Схема

Курсы по Mikrotik с гарантией результата 4


Аггрегация каналов в DualWAN на Mikrotik.
.

Постановка задачи
• У нас есть два канала со скоростью 10M и 5M
• У обоих каналов есть внешние и ip 1.1.1.2 и 2.2.2.2
• Задача – задействовать оба канала без потери
качества выхода в интернет

/ip route rule


add src-address=1.1.1.2/32 table=to-ISP1
add src-address=2.2.2.2/32 table=to-ISP2
add dst-address=192.168.0.0/16 table=main
add dst-address=172.16.0.0/12 table=main
add dst-address=10.0.0.0/8 table=main
add routing-mark=ISP1 table=to-ISP1
add routing-mark=ISP2 table=to-ISP2

Курсы по Mikrotik с гарантией результата 5


Аггрегация каналов в DualWAN на Mikrotik.
.

ECMP - Equal Cost Multi-Path – маршруты равной стоимости


• Позволяет установить несколько равнозначных
маршрутов для передачи данных
• Распределение происходит по алгоритму
Round-robin.
• Маршруты распределяются по соединениям
src-address(адрес источника) – dst-address (адрес
получателя)
• Каждые 10 минут таблица маршрутизации
обнуляется.
• Check gateway не работает
• /ip route add distance=1 gateway=1.1.1.1,1.1.1.1,2.2.2.1

Курсы по Mikrotik с гарантией результата 6


Аггрегация каналов в DualWAN на Mikrotik.
.

ECMP - Equal Cost Multi-Path – маршруты равной стоимости


• Для нормальной работы пробросов портов нужно чтобы роутер
отвечал с того интерфейса и ip с которого пришел трафик:
/ip firewall mangle
add action=mark-connection chain=prerouting comment=ISP1 in-interface=bridge1.11 new-connection-mark=in-ISP1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=in-ISP1 new-routing-mark=ISP1 passthrough=yes
add action=mark-routing chain=output connection-mark=in-ISP1 new-routing-mark=ISP1 passthrough=yes
add action=mark-routing chain=output new-routing-mark=ISP1 passthrough=yes src-address=1.1.1.2
add action=mark-connection chain=prerouting comment=ISP2 in-interface=bridge1.22 new-connection-mark=in-ISP2 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=in-ISP2 new-routing-mark=ISP2 passthrough=yes
add action=mark-routing chain=output connection-mark=in-ISP2 new-routing-mark=ISP2 passthrough=yes
add action=mark-routing chain=output new-routing-mark=ISP1 passthrough=yes src-address=2.2.2.2
• Отдельные таблицы маршрутизации:
/ip route
add distance=1 gateway=1.1.1.1 routing-mark=ISP1 /ip route rule
add distance=1 gateway=2.2.2.1 routing-mark=ISP2 add src-address=1.1.1.2/32 table=to-ISP1
add src-address=2.2.2.2/32 table=to-ISP2
add dst-address=192.168.0.0/16 table=main
• Src-nat add dst-address=172.16.0.0/12 table=main
/ip firewall nat add dst-address=10.0.0.0/8 table=main
add action=masquerade chain=srcnat out-interface=bridge1.11 add routing-mark=ISP1 table=to-ISP1
add action=masquerade chain=srcnat out-interface=bridge1.22 add routing-mark=ISP2 table=to-ISP2

Курсы по Mikrotik с гарантией результата 7


Аггрегация каналов в DualWAN на Mikrotik.

PCC - per connection classifier – классификатор по


соединениям
• Каждый IP-пакет имеет заголовок с полями src-addres(адрес источника)
– dst-addres(адрес назначения) и src-port(порт источника) – dst-port(порт
назначения)
• С помощью алгоритма хеширования данные из выбранных полей IP-
пакета преобразуется в уникальное 32-битное значение.
• Далее полученное 32-битное значение позволяет отсортировать
трафик по различным критериям и направить в определенную
таблицу маршрутизации

Курсы по Mikrotik с гарантией результата 8


Аггрегация каналов в DualWAN на Mikrotik.

PCC - per connection classifier – классификатор по


соединениям
/ip firewall mangle
add action=mark-connection chain=prerouting comment=PCC dst-address-type=!local
new-connection-mark=ISP1-conn passthrough=no
per-connection-classifier=both-addresses-and-ports:3/0
add action=mark-connection chain=prerouting dst-address-type=!local
new-connection-mark=ISP1-conn passthrough=no
per-connection-classifier=both-addresses-and-ports:3/1
add action=mark-connection chain=prerouting dst-address-type=!local
new-connection-mark=ISP2-conn passthrough=no
per-connection-classifier=both-addresses-and-ports:3/2

Курсы по Mikrotik с гарантией результата 9


Аггрегация каналов в DualWAN на Mikrotik.

NTH – каждое n-ое соединение

/ip firewall mangle


add action=mark-connection chain=prerouting comment=Nth connection-state=new
new-connection-mark=ISP1-conn nth=3,1 passthrough=yes
add action=mark-connection chain=prerouting connection-state=new
new-connection-mark=ISP1-conn nth=3,2 passthrough=yes
add action=mark-connection chain=prerouting connection-state=new
new-connection-mark=ISP2-conn nth=3,3 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=ISP1-conn
new-routing-mark=ISP1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=ISP2-conn
new-routing-mark=ISP2 passthrough=yes

Курсы по Mikrotik с гарантией результата 10


Аггрегация каналов в DualWAN на Mikrotik.

Random – случайные %

/ip firewall mangle


add action=mark-connection chain=prerouting comment=Random connection-state=new
disabled=yes new-connection-mark=ISP1-conn passthrough=yes random=77
add action=mark-connection chain=prerouting connection-state=new disabled=yes
new-connection-mark=ISP2-conn passthrough=yes random=33
add action=mark-routing chain=prerouting connection-mark=ISP1-conn disabled=yes
new-routing-mark=ISP1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=ISP2-conn disabled=yes
new-routing-mark=ISP2 passthrough=yes

Курсы по Mikrotik с гарантией результата 11


СПАСИБО ЗА ВНИМАНИЕ
Приходите на наши курсы по
Mikrotik и Asterisk
http://t.me/miktrain