Вы находитесь на странице: 1из 4

Работа в аудитории.

Научите меня (версия для инструктора:


дополнительная работа в аудитории)
Примечание для инструктора. Красным шрифтом или серым фоном выделен текст, который
отображается только в копии инструктора. Дополнительные упражнения помогут лучше понять материал и
(или) приобрести практический опыт.

Задачи
Настройка исходных параметров на сетевом устройстве с помощью ПО Cisco IOS.

Общие сведения/сценарий
(Учащиеся будут работать в парах. Для выполнения данного упражнения необходимо использовать
Packet Tracer.)
Представьте, что ваш новый коллега просит вас провести инструктаж по интерфейсу командной
строки Cisco IOS. Ранее ему не приходилось работать с устройствами Cisco.
Вы объясняете принципы действия основных команд и структуру интерфейса командной строки (CLI)
так, чтобы ваш коллега понял, что CLI — это простой и в то же время мощный командный язык,
который легко воспринимать и применять на практике.
Используйте Packet Tracer и одно из упражнений в этой главе в качестве простой модели сети.
Обратите особое внимание на следующие моменты.
o Хотя эти команды и носят технический характер, похожи ли они на какие-либо
утверждения, используемые в повседневном языке?
o Каким образом команды объединяются в подгруппы или режимы? Как администратору
узнать, какой режим он использует в данный момент?
o С помощью каких отдельных команд можно настроить основные параметры устройства
Cisco? Как объяснить значение этой команды неспециалисту? По возможности проведите
сравнения с реальной жизнью.
Предложите свой способ группировки различных команд в соответствии с их режимами, чтобы
уменьшить количество переключений между режимами.
Примечания для инструктора. Это дополнительное упражнение по моделированию может
оцениваться. Однако его цель — помочь учащимся, руководствуясь знаниями, полученными из
главы 2, понять, как напрямую использовать Cisco IOS для настройки промежуточных устройств. Ваша
задача — мотивировать учащихся на обсуждение выполняемой работы в парах.

Необходимые ресурсы
 Packet Tracer
 Любое простое упражнение по моделированию сети из главы 2.

Вопросы для повторения


1. Закончив изучение главы 2, приобрели ли вы четкое понимание функций и принципов работы Cisco
IOS? С какими трудностями вы столкнулись при объяснении своему коллеге основных команд и
структуры интерфейса командной строки (CLI)? Если бы вы были на месте нового коллеги, какие бы
сложности вы испытали в процессе освоения базовых команд и структуры CLI?
_______________________________________________________________________________________
_______________________________________________________________________________________

© Компания Cisco и/или ее дочерние компании, 2021 г. Все права защищены. В данном документе содержится общедоступная информация компании Cisco. Страница 1 из 4
Работа в аудитории. Научите меня

2. Ответьте на следующие вопросы и обсудите ответы со всей аудиторией.


a. Хотя эти команды и носят технический характер, похожи ли они на какие-либо утверждения,
используемые в повседневном языке?
____________________________________________________________________________________
____________________________________________________________________________________
b. Каким образом команды объединяются в подгруппы или режимы? Как администратору узнать,
какой режим он использует в данный момент?
____________________________________________________________________________________
____________________________________________________________________________________
c. С помощью каких отдельных команд можно настроить основные параметры устройства Cisco? Как
объяснить значение этой команды неспециалисту? По возможности проведите сравнения с
реальной жизнью.
____________________________________________________________________________________
____________________________________________________________________________________
d. С помощью коллеги попробуйте предложить способ группировки различных команд в соответствии
с их режимами, чтобы уменьшить необходимое количество переключений между режимами.
____________________________________________________________________________________
____________________________________________________________________________________

(Ответы будут различаться (ниже представлены варианты, основанные на материалах


главы 2).)
a. Хотя эти команды и носят технический характер, похожи ли они на какие-либо утверждения,
используемые в повседневном языке?
Разумеется! Ключевые слова, такие как enable (включить), password (пароль), banner (баннер),
address (адрес), shutdown (выключение), — это обычные слова, значение которых в интерфейсе
CLI соответствующим образом адаптировано, но все же тесно связано с их повседневным
употреблением.
e. Каким образом команды объединяются в подгруппы или режимы? Как администратору узнать,
какой режим он использует в данный момент?
Во-первых, доступ к CLI может осуществляться на уровне пользователя (пользовательский режим
EXEC), либо на уровне администратора (привилегированный режим EXEC). На уровне
администратора доступен режим конфигурации, который делится на режим глобальной
конфигурации, режим конфигурации линии, режим конфигурации интерфейса и при необходимости
другие режимы. Администратор определяет текущий режим по командной строке, где символ «>»
означает доступ на уровне пользователя, символ «#» — доступ на уровне администратора, а
дополнительные ключевые слова в скобках — основной режим конфигурации и возможные
вспомогательные режимы.
f. С помощью каких отдельных команд можно получить доступ к основным параметрам устройства
Cisco и их настройке? Как бы вы объяснили эти команды простыми словами? По возможности
проведите сравнения с реальной жизнью.
enable — получение возможности контролировать устройство
configure terminal — запуск редактора конфигурации с принятием изменений с терминала
hostname — присвоение имени устройству
service password-encryption — устройство шифрует все введенные пароли в конфигурации,
чтобы их нельзя было подсмотреть

© Компания Cisco и/или ее дочерние компании, 2021 г. Все права защищены. В данном документе содержится общедоступная информация компании Cisco. Страница 2 из 4
Работа в аудитории. Научите меня

line con 0 — переход в режим конфигурации линии (или «сокета») с маркировкой CONSOLE 0 на
устройстве для управления устройством
line vty 0 4 — переход в режим конфигурации 5 виртуальных «сокетов» для удаленного
управления устройством по сети
password — настройка пароля для доступа к устройству
login — защита доступа с помощью процедуры входа с требованием определения пароля при
помощи команды password
exit — выход из текущего режима и переход в режим более высокого уровня
enable secret — секретная фраза для защиты использования команды enable
banner — отображение сообщения для пользователя, который пытается получить доступ к
устройству
interface Vlan 1 — переход в режим конфигурации интерфейса с именем Vlan1
description — ввод текстового комментария к интерфейсу, чтобы администратор знал назначение
и расположение интерфейса
ip address — назначение числового IP-адреса интерфейсу
no shutdown — удаление команды shutdown и, как следствие, активация интерфейса
end — выход из редактора конфигурации
Переход между режимами конфигурации и внесение изменений в настройки устройства можно
сравнить с движением по лабиринту. Каждый режим конфигурации — как отсек лабиринта. Даже
если у вас есть карта лабиринта, вы можете перемещаться по нему беспорядочно и никогда не
найти выход. Аналогичным образом даже если вы знаете смысл отдельных команд и режимы, в
которых они применяются, способ перехода между этими режимами во время настройки
устройства зависит главным образом от вас.
g. С помощью коллеги попробуйте предложить способ группировки различных команд в соответствии
с их режимами, чтобы уменьшить необходимое количество переключений между режимами.
Вот одна из возможных эффективных последовательностей команд для настройки устройства.
enable
configure terminal
hostname AtlantaSw
service password-encryption
banner login ^

Access to this device permitted only to authorized personnel!

^
enable secret V3ry5ecr3tP4ssw0rd
line con 0
password 5ecr3tP4ssw0rd
login
exit
line vty 0 4
password 5ecr3tP4ssw0rd
login
exit
interface Vlan 1

© Компания Cisco и/или ее дочерние компании, 2021 г. Все права защищены. В данном документе содержится общедоступная информация компании Cisco. Страница 3 из 4
Работа в аудитории. Научите меня

ip address 192.0.2.11 255.255.255.0


no shutdown
end

An ineffective way of configuring would be, for example:


enable
configure terminal
line con 0
password 5ecr3tP4ssw0rd
exit
hostname AtlantaSw
service password-encryption
line vty 0 4
password 5ecr3tP4ssw0rd
exit
banner login ^

Access to this device permitted only to authorized personnel!

^
line con 0
login
exit
interface Vlan 1
ip address 192.0.2.11 255.255.255.0
exit
line vty 0 4
login
exit
enable secret V3ry5ecr3tP4ssw0rd
interface Vlan 1
no shutdown
end
(Примечание. Хотя обе конфигурации приводят к одному и тому же итоговому набору параметров,
вторая конфигурация немного больше (из-за повторяющегося входа в отдельные режимы) и ее очень
сложно реализовать, поскольку порядок команд является практически случайным и не соответствует
их логической последовательности и общности режимов.)
Укажите элементы модели, которые соответствуют сфере ИТ.
 Команды
 Режимы
 Эффективная ориентация в режиме конфигурации
 Практические навыки взаимоотношений с заказчиками

© Компания Cisco и/или ее дочерние компании, 2021 г. Все права защищены. В данном документе содержится общедоступная информация компании Cisco. Страница 4 из 4