Вы находитесь на странице: 1из 10

2013/Вологодский филиал ООО «MyBOX»/технический Департамент/

Руководства/Коммутаторы Eltex

Главы:
1. Базовая настройка коммутатора.
2. Настройка параметров системы безопасности.
3. Режимы работы в командной строке.
4. Настройка VLANs.
5. Настройка портов коммутатора.
6. Настройка колец по протоколу EAPS.
7. Общесистемные команды для сбора статистики и обслуживания коммутатора.

1. Базовая настройка коммутатора


На компьютере запустить программу эмуляции терминала (HyperTerminal, TeraTerm) и
произвести следующие настройки:
1. Выбрать соответствующий последовательный порт.
2. Установить скорость передачи данных – 115200 бод.
3. Задать формат данных: 8бит данных, 1 стоповый бит, без контроля четности.
4. Отключить аппаратное и программное управление потоком данных.
5. Задать режим эмуляции терминала VT100 (многие терминальные программы
используют данный режим эмуляции терминала в качестве режима по умолчанию).

После загрузки коммутатора базовая настройка включает в себя:

- Задание пароля для пользователя «admin» (с уровнем привилегий – 15).

Пример команд для задания пользователю «admin» пароля «eltex»:


console# configure
console(config)# username admin password eltex
console#

- Настройка статического IP-адреса, маски подсети и шлюза по умолчанию

Параметры интерфейса:
IP-адрес, назначаемый для интерфейса VLAN 2000 – 192.168.240.9
Маска подсети – 255.255.248.0
IP-адрес шлюза по умолчанию — 192.168.240.1
console# configure
console(config)# interface vlan 2000
2013/Вологодский филиал ООО «MyBOX»/технический Департамент/
Руководства/Коммутаторы Eltex

console (config-if) # ip address 192.168.240.9 /21


console (config-if) # exit
console (config) # ip default-gateway 192.168.240.1
console (config) # exit

2. Настройка параметров системы безопасности


Для обеспечения безопасности системы используется механизм ААА (аутентификация,
авторизация, учет). Для шифрования данных используется механизм SSH. Для обеспечения
первоначальной безопасности пароль в системе можно задать для сервисов:
– Консоль (подключение через серийный порт);
– Telnet;
– SSH.

Установка пароля для консоли:


console# configure
console(config)# aaa authentication login default line
console(config)# aaa authentication enable default line
console(config)# line console
console(config-line)# login authentication default
console(config-line)# enable authentication default
console(config-line)# password console
В ответ на приглашение ввести пароль во время регистрации в устройстве через сеанс
консоли введите пароль – console.

Установка пароля для Telnet:


console# configure
console(config)# aaa authentication login default line
console(config)# aaa authentication enable default line
console(config)# ip telnet server
console(config)# line telnet
console(config-line)# login authentication default
console(config-line)# enable authentication default
console(config-line)# password telnet
2013/Вологодский филиал ООО «MyBOX»/технический Департамент/
Руководства/Коммутаторы Eltex

В ответ на приглашение ввести пароль во время регистрации в устройстве через сеанс Telnet
введите пароль – telnet.

Установка пароля для SSH:


console# configure
console(config)# aaa authentication login default line
console(config)# aaa authentication enable default line
console(config)# ip ssh server
console(config)# line ssh
console(config-line)# login authentication default
console(config-line)# enable authentication default
console(config-line)# password ssh
В ответ на приглашение ввести пароль во время регистрации в устройстве через сеанс SSH
введите пароль – ssh.

3. Режимы работы в коммандной строке.


Привилегированный командный режим (privileged EXEC), этот режим доступен при входе
привилегированного пользователя. Вход в режим должен быть обязательно защищен
паролем.
console>enable
enter password:
console#

Режим глобального конфигурирования (global configuration), данный режим предназначен для


задания общих настроек коммутатора.
console# configure
console(config)#

Режим конфигурирования интерфейса (interface configuration), данный режим предназначен


для конфигурирования интерфейсов (порт, группа портов, интерфейс VLAN)
коммутатора.
console(config)# interface vlan 1
console (config-if)#
2013/Вологодский филиал ООО «MyBOX»/технический Департамент/
Руководства/Коммутаторы Eltex

4. Настройка VLANs.
Для того, чтобы настраивать VLAN мы должны сначала добавить их в базу данных, потом
зайти в интерфейс VLAN и прописать его наименование:
console#
console# configure
console(config)# vlan database
console(config-vlan)#vlan 2000
console(config-vlan)#exit
console(config)#interface vlan 2000
console(config-if)#name mng
console(config-if)#exit
console(config)#
Для добавления диапазона портов используется следующие команды в режиме
конфигурирования VLAN:
console# configure
console(config)#vlan database
console(config-vlan)#vlan 1-10.
Соответственно для конфигурирования диапозона интерфейсов VLAN используется
следующие команды:
console(config-vlan)#exit
console(config)#interface vlan range 1-10
console(config-if)#

Для удаления VLAN из базы требуется выполнить следующее:


console#configure
console(config)#vlan database
console(config)#no vlan 2000[1-10]
console(config)#exit
console#

Для того чтобы показать информацию по всем VLAN:


console#show vlan
2013/Вологодский филиал ООО «MyBOX»/технический Департамент/
Руководства/Коммутаторы Eltex

Для того чтобы показать информацию по индентификатору VLAN:


console#show vlan tag 3201

5. Настройка портов коммутатора.


Порт может работать в четырех режимах:
– access – интерфейс доступа – нетегированный интерфейс для одной VLAN;
– trunk – интерфейс, принимающий только тегированный трафик, за исключением
одного VLAN, который может быть добавлен с помощью команды switchport trunk
native vlan;
– general – интерфейс с полной поддержкой 802.1q, принимает как тегированный, так и
нетегированный трафик;
– customer – 802.1 Q-in-Q интерфейс.

Вид запроса командной строки в режиме конфигурирования интерфейса Ethernet, интерфейса


группы портов:
console#configure
console(config)#interface {tengigabitethernet te_port | gigabitethernet gi_port | range {...}}
console(config-if)#

При настройке коммутаторов в транспортной сети MyBOX в основном необходимо


использовать два режима access и trunk.
Рекомендация: желательно порты, через которые идет много VLAN, делать транковыми и
явно прописывать конкретные VLANs. На входящих/кольцевых портах желательно
прописать все VLAN, которые ходят через коммутатор.
Пример настройки порта в режима доступа:
console#
console#configure
console(config)#interface GigabitEthernet 1/0/14
console(config-if)#switchport mode access
console(config-if)#switchport access vlan 10
Для того чтобы вернуть значение по умолчанию использовать команду no switchport access
vlan.
2013/Вологодский филиал ООО «MyBOX»/технический Департамент/
Руководства/Коммутаторы Eltex

Пример настройки порта в режима транка:


console#
console#configure
console(config)#interface GigabitEthernet 1/0/15
console(config-if)#switchport mode trunk
console(config-if)#switchport trunk allowed vlan add 1,3,10-12[all]
Для того чтобы удалить VLAN для интерфейса использовать команду switchport trunk
allowed vlan remove 1,3,10-12[all].

6. Настройка колец по протоколу EAPS.


Протокол EAPS (Ethernet Automatic Protection Switching) предназначен для повышения
устойчивости и надежности сети передачи данных, имеющей кольцевую топологию, за счет
снижения времени восстановления сети в случае аварии. Время восстановления не
превышает 1 секунды, что существенно меньше времени перестройки сети при
использовании протоколов семейства spanning tree.

Один коммутатор настраиваем как мастер, а остальные как транзитные:

1)мастер:

no spanning-tree
eaps
eaps domain 0
control-vlan 100
ring 0
role master level 0
primary-port gigabitethernet1/0/11
secondary-port gigabitethernet1/0/12
exit
set ring 0 enable
exit
vlan database
vlan 100-101,4000
exit
2013/Вологодский филиал ООО «MyBOX»/технический Департамент/
Руководства/Коммутаторы Eltex

interface gigabitethernet1/0/11
switchport mode trunk
switchport trunk allowed vlan add 100-101,4000
exit
interface gigabitethernet1/0/12
switchport mode trunk
switchport trunk allowed vlan add 100-101,4000
exit

2) Транзит:

no spanning-tree
eaps
eaps domain 0
control-vlan 100
ring 0
role transit level 0
primary-port gigabitethernet1/0/7
secondary-port gigabitethernet1/0/8
exit
set ring 0 enable
exit
vlan database
vlan 100-101,4000
exit
interface gigabitethernet1/0/7
switchport mode trunk
switchport trunk allowed vlan add 100-101,4000
exit
interface gigabitethernet1/0/8
switchport mode trunk
switchport trunk allowed vlan add 100-101,4000
exit
2013/Вологодский филиал ООО «MyBOX»/технический Департамент/
Руководства/Коммутаторы Eltex

7. Общесистемные команды для сбора статистики и обслуживания коммутатора.


Для того чтобы сохранить настройки коммутатора необходимо записать
действующую(запущенную) конфигурацию в стартовую:
console#copy running-config startup-config
Overwrite file [startup-config] ?[Yes/press any key for no]....
После этого можно смело перезапускать оборудования по питанию или просто
перезапустить командой reload.

Для просмотра таблицы MAC-адресов:


- всей
console#show mac address-table

- конкретного порта на оборудовании


console#show mac address-table interface GigabitEthernet1/0/13
Aging time is 300 sec
Vlan Mac Address Port Type
-------- --------------------- ---------- ----------
3037 00:80:48:30:02:14 gi1/0/13 dynamic

- конкретного VLAN на порту на оборудовании


console#show mac address-table interface GigabitEthernet1/0/13 vlan 3037
Aging time is 300 sec
Vlan Mac Address Port Type
-------- --------------------- ---------- ----------
3037 00:80:48:30:02:14 gi1/0/13 dynamic

- конкретного VLAN на оборудовании


console#show mac address-table vlan 3037
Aging time is 300 sec
Vlan Mac Address Port Type
2013/Вологодский филиал ООО «MyBOX»/технический Департамент/
Руководства/Коммутаторы Eltex

-------- --------------------- ---------- ----------


3037 00:80:48:30:02:14 gi1/0/13 dynamic
3037 00:90:1a:43:16:72 gi1/0/1 dynamic

Для того чтобы просмотреть запущенную конфигурацию коммутатора необходимо


использовать следующую команду:
console#show running-config

Посмотреть версию начального загрузчика (Boot version) и системную информацию:


console#show version
SW version 2.5.3 ( date 12-Nov-2012 time 11:59:22 )
Boot version 0.0.0.3 ( date 23-Feb-2011 time 16:07:46 )
HW version 02.05
CPLD version 03
console#show version
SW version 2.5.3 ( date 12-Nov-2012 time 11:59:22 )
Boot version 0.0.0.3 ( date 23-Feb-2011 time 16:07:46 )
HW version 02.05
CPLD version 03
nov4#show system
System Description: MES-3124F 28-port Fiber 1G/10G Managed Switch
System Up Time (days,hour:min:sec): 29,03:27:08
System Contact:
System Name:
System Location:
System MAC Address: a8:f9:4b:82:a0:00
System Object ID: 1.3.6.1.4.1.35265.1.30

Main Power Supply Status: OK


Redundant Power Supply Status: OK
Fan 1 Status: OK
Fan 2 Status: OK
2013/Вологодский филиал ООО «MyBOX»/технический Департамент/
Руководства/Коммутаторы Eltex

Fan 3 Status: OK
Fan 4 Status: OK

Sensor Index Temperature (Celsius) Status


--------------------- -------------------------- -------------------
1 45 OK
2 46 OK
3 41 OK