Вы находитесь на странице: 1из 70

Начало работы с формулами

Выполнив всего несколько шагов, вы научитесь вводить формулы и функции в Excel — самом
популярном приложении для работы с электронными таблицами.

Приступить >

Чтобы вернуться в начало страницы, нажмите клавиши CTRL+HOME. Чтобы начать курс, нажмите клавиши CTRL+PAGE DOWN.
найти его в
ней. Из-за
этого
константы
сложно
изменять.
Гораздо
ПОПРОБУЙТЕ
удобнее
САМИ!
ввести
Введите вв
Основные сведения: математические
значения
Основные
Формулы
ячейки C3 исведения:
Вы можете
отдельные складывать,математические расчеты
вычитать, умножать в Excel числа в Excel, не используя встроенные функции. Для этого потребуются только основные операторы: +, -, *, /. Все
и делить
могут
C4 другие
ячейки, где их числа, выделите ячейку F3, введите =C3+C4, а затем нажмите клавишу ВВОД. Числа:
Чтобы сложить
расчеты в Excel
содержать
числа
можноилегко
ссылки на и
посмотрите, 1
изменять,
ячейки,
Чтобы
Чтобы вычесть
как
добавить
умножить числа,
числа,выделите
выделите ячейку F4,F5,
ячейку введите
введите=C3-C4, а затем
=C3*C4, нажмите
а затем нажмитеклавишу
клавишу ВВОД.
ВВОД. 2
диапазоны,
автоматическ
ссылки на них
Чтобы поделить
операторы
и изменятся и числа, выделите ячейку F6, введите =C3/C4, а затем нажмите клавишу ВВОД.
в формулу.Вы можете складывать, вычитать, умножать и делить числа в Excel, не
константы.
результаты
Вот используя встроенные функции. Для этого потребуются только основные
примеры
формулы.
Например,
формул:
выделите операторы:
ДОПОЛНИТЕЛЬНО +, -,возвести
Чтобы *, /. Всезначение
формулыв степень,
начинаются со знакасимвол
используйте равенства
крышки(=).(^), например: =A1^A2. Для ввода формулы нажмите SHIFT+6. В ячейке F7 введите =
желтую
Подробнее ПОПРОБУЙТЕ САМИ!
=A1+B1
ячейку с
числом 12 1
=10+20
Следующий шаг Чтобы сложить числа, выделите ячейку F3, введите =C3+C4, а затем Введите здесь другие числа и
=СУММ(A1:A1 посмотрите, как автоматически
Немного
ниже. Вы
Листы
0) Excel нажмите
о формулах,
состоят ячеек,клавишу
изячейках которые ВВОД.
и диапазонах
сгруппированы по строкам и столбцам. Строкам присвоены номера, а столбцам — буквы.
изменятся На листеформулы.
результаты больше миллиона строк и 16  0
увидите, что в
2 вЧтобы
ней
Как вы заметили,
используется вычесть
третьем примере числа, выделите ячейку
мы использовали функциюF4, СУММ.
введитеФункция
=C3-C4, —аэто
затем
встроенная команда, которая принимает значения, определенным образом обр
функция нажмите клавишу ВВОД.
Формулы с функциями начинаются со знака равенства, за которым следуют имя функции и ее аргументы (значения, которые функция использует для вычисления), закл
СУММ,
которая
ссылается на 3 Чтобы умножить числа, выделите ячейку F5, введите =C3*C4, а затем
Пояснения
диапазон формул нажмите клавишу ВВОД.
ячеек.
‘=10+20В — это формула, где 10 и 20 — константы, а + — оператор.
формуле нет4 —Чтобы
=СУММ(A1:A10) поделить
это формула, числа,СУММ
в которой выделите
— этоячейку F6, введите
имя функции, =C3/C4,
в скобках а затем
указаны ее аргументы, а A1:A10 — диапазон ячеек для функции.
самих чисел 4
=СУММ(A1:A10;C1:C10)
и 8. нажмите— этоклавишу
формула, ВВОД.
в которой СУММ — это имя функции, в скобках указаны ее аргументы, а A1:A10 и C1:C10— диапазоны ячеек, разделенные точк

Назад
Далее
Подробнее Следующий шаг

Дополнительные сведения в Интернете


Немного о формулах, ячейках и
Использование Microsoft Excel в качестве калькулятора
Оператор
диапазонах
Полные сведения о формулах в Excel

=A1+B1
Немного о формулах, ячейках и
диапазонах
Функции Excel (по категориям)
Функции Excel (по алфавиту) 
Листы
Бесплатные Excelвеб-курсы
учебные состоят изпоячеек,
Excel которые сгруппированы по строкам и столбцам.
=A1+B1
Строкам присвоены номера, а столбцам — буквы. На листе больше миллиона Ссылка на Ссылка на
строк и 16 000 столбцов, и вы можете вставлять формулы в любые ячейки на ячейку ячейку
их пересечении.
Формулы могут содержать ссылки на ячейки, диапазоны, операторы и
константы. Вот примеры формул: Функция

=A1+B1
=10+20 =СУММ(A1:A10)
=СУММ(A1:A10)
Как вы заметили, в третьем примере мы использовали функцию СУММ. Функция Диапазон состоит из начальной ячейки, двоеточия и
конечной ячейки. Если выбрать диапазон ячеек для
— это встроенная команда, которая принимает значения, определенным формулы, Excel автоматически добавит двоеточие.
образом обрабатывает их и возвращает результат. Например, функция СУММ
принимает в качестве значений ссылки на ячейки или диапазоны и суммирует  
их. В данном примере она вычисляет сумму значений в ячейках с A1 по A10. В
Excel более 400 функций, и все их можно найти на вкладке Формулы.
Функция
Формулы с функциями начинаются со знака равенства, за которым следуют имя
функции и ее аргументы (значения, которые функция использует для
вычисления), заключенные в круглые скобки.
=СУММ(A1:A10;C
Чтобы подтвердить формулу, нужно нажать клавишу ВВОД. После этого
формула будет вычислена, а результат отобразится в ячейке. Чтобы просмотреть
саму формулу, взгляните на строку формул под лентой или нажмите клавишу F2, Открывающая круглая скобка
чтобы перейти в режим правки, в котором формула выводится в ячейке.
Нажмите клавишу ВВОД еще раз, чтобы завершить работу над формулой и
вычислить результат.

Назад Далее
Назад Далее

Дополнительные сведения в Интернете

Использование Microsoft Excel в качестве калькулятора

Полные сведения о формулах в Excel

Функции Excel (по категориям)

Функции Excel (по алфавиту) 

Бесплатные учебные веб-курсы по Excel


Операция: Формулы: Ответы:
Сложение (+) 3
Вычитание (-) -1
Умножение (*) 2
Деление (/) 0.5
Возведение в степень (^) 1
мулы нажмите SHIFT+6. В ячейке F7 введите =C3^C4.
БУЙТЕ САМИ! ДОПОЛНИТЕЛЬНО
Чтобы возвести значение в
здесь другие числа и степень, используйте символ
ите, как автоматически крышки (^),вставлять
например: =C3^C4. в любые ячейки на их пересечении.
яуквы. На листеформулы.
результаты больше миллиона строк и 16  000 столбцов, и вы можете формулы
Для ввода формулы нажмите
SHIFT+6.
нимает значения, определенным образом обрабатывает их и возвращает результат. Например, функция СУММ принимает в качестве значений ссылки на ячейки или диапазоны и
ые функция использует для вычисления), заключенные в круглые скобки.

он ячеек для функции.


C1:C10— диапазоны ячеек, разделенные точкой с запятой.

ПОЛЕЗНЫЕ СВЕДЕНИЯ
Оператор Константы — это значения, которые вводятся в ячейки и формулы.
Хотя формула =10+20 может давать тот же результат, что и =A1+B1,

+B1 =10+20 использовать константы не рекомендуется. Это объясняется


следующим: чтобы увидеть значение константы, нужно выделить
ячейку и найти его в ней. Из-за этого константы сложно изменять.
Гораздо удобнее ввести значения в отдельные ячейки, где их можно
легко изменять, и добавить ссылки на них в формулу.
ПОЛЕЗНЫЕ СВЕДЕНИЯ
Константы — это значения, которые вводятся в ячейки и формулы.
Хотя формула =10+20 может давать тот же результат, что и =A1+B1,

+B1 =10+20 использовать константы не рекомендуется. Это объясняется


следующим: чтобы увидеть значение константы, нужно выделить
ячейку и найти его в ней. Из-за этого константы сложно изменять.
Гораздо удобнее ввести значения в отдельные ячейки, где их можно
Ссылка на легко изменять, и добавить ссылки на них в формулу.
Константа Константа
ячейку
Например, выделите желтую ячейку с числом 12 ниже. Вы увидите,
что в ней используется функция СУММ, которая ссылается на
диапазон ячеек. В формуле нет самих чисел 4 и 8.

Аргумент

М(A1:A10) Значения
4
он состоит из начальной ячейки, двоеточия и
ой ячейки. Если выбрать диапазон ячеек для 8
лы, Excel автоматически добавит двоеточие. 12

Аргументы разделяются точкой с запятой

Аргумент Аргумент

М(A1:A10;C1:C10)
Диапазон ячеек Другой диапазон ячеек
   
Открывающая круглая скобка Закрывающая круглая скобка. Excel обычно добавляет ее
автоматически при нажатии клавиши ВВОД.
на ячейки или диапазоны и суммирует их. В данном примере она вычисляет сумму значений в ячейках с A1 по A10. В Excel более 400 функций, и все их можно найти на вкладке «Ф
их можно найти на вкладке «Формулы».
числа
затем таким
Excel нажать
образом,
клавишу
автоматическ
делайте
ВВОД. Приэто
и введет
только
этом в
будут
формулу.
исключительн
просуммиров
Нажмите
ых случаях.
аны значения
клавишу
Это
вВВОД, число D3,
ячейках
чтобы
называется
D4, D5 и D6. В
подтвердить
константой,
результате и
ее. Автосумма
Общие сведения о функциях
вы
должнолегко
Общие сведения о функциях
поддерживае
можете
получиться
тзабыть
все часто
Функции позволяют выполнять математические операции, подставлять значения, рассчитывать значения даты Фрукт
о его Количество
170.
используемые
наличии в Яблоки 50
функции.
формуле.Функции позволяют выполнять математические операции, подставлять
Откройте
Вместо этого вкладку «Формулы» и просмотрите библиотеку функций. В ней функции упорядочены по категориям, например «Текстовые»,
Апельсины 20 «Дата и время» и т
Также можно
рекомендуетс значения, рассчитывать
использовать значения
сочетание клавиш.даты и времени
Выберите ячейкуиD15,
делать многое
нажмите другое.
ALT=, а затем — ВВОД. При этом автоматически
Бананы будет введена60формула с функцией СУМ
яЕсли нажать
включить
Подробнее Попробуем
ДОПОЛНИТЕЛЬНО сложить
= и начать значения
вводить с помощью
имя функции, функции средство
активируется СУММ несколькими
Intellisense, которое перечисляет все функции, названия которых
Лимоны 40 начинаются с вводим
ссылку наспособами.
Попробуйте
другую использовать функцию СЧЁТ с помощью одного из этих способов. Она подсчитывает количество ячеек Сумма
в диапазоне,
> содержащих170
числа.
Следующий
ячейку, шаг
например
Еще немного 1о функциях
В столбце «Количество» для фруктов (ячейка D7) введите =СУММ(D3:D6). Товар Количество
F51. Вы также можете ввести =СУММ( и выбрать диапазон с помощью мыши,
Рассмотрим
Функция СУММ
Значения, структуру нескольких
возвращает функций.
суммуклавишу
всех Функция
значений СУММ
в ячейках с D38 имеет
по D41следующий синтаксис:
и во всем столбце Хлеб
H. СУММ — это имя функции, D38:D41 — первый 50
аргумент диапазона (он по
а затем нажать ВВОД. При этом будут просуммированы значения
которые не Пончики 100
будут скрыты в ячейках D3, D4, D5 и D6. В результате должно получиться 170.
Функция
ПОПРОБУЙТЕ СЕГОДНЯ возвращает текущую дату. Ее результат автоматически обновляется при пересчете книги ExcelПеченье 40
в формуле, САМИ!
Выделите
гораздо эти 2 ячейки.
Теперь давайте
Затем в правомпопробуем использовать
нижнем углу Автосумма.
окна Excel найдите Выделите
надпись «Сумма: 170». Эта нижняя область
Торты
называется строкой состояния.
50 В ней можно быстро п
проще найти. желтую ячейку в таблице «Мясо» (G7), а затем щелкните Формулы > Пироги 20
Дополнительные Автосумма и выберите операцию Сумма. Excel автоматически введет
сведения в Интернете Сумма >
Все о функции СУММ формулу. Нажмите клавишу ВВОД, чтобы подтвердить ее. Автосумма
Использование функцииподдерживает все часто
«Автосумма» используемые
для суммирования функции.
чисел
Все о функции СЧЁТ
Бесплатные3 Также
учебные можнопо
веб-курсы использовать
Excel сочетание клавиш. Выберите ячейку D15,
В начало страницынажмите A LT = и ВВОД. При этом автоматически будет введена
Следующий шаг формула с функцией СУММ.

Подробнее Следующий шаг

Еще немного о функциях


Еще немного о функциях
Откройте вкладку Формулы и просмотрите библиотеку функций. В ней функции
упорядочены по категориям, например Текстовые, Дата и время и т. д. Если
нажать кнопку Вставить функцию, можно будет найти функцию по имени. После Фрукт Количество
этого запустится мастер функций, который поможет вам создать формулу. Яблоки 50
Апельсины 20
Если нажать = и начать вводить имя функции, активируется средство Intellisense, Бананы 60
которое перечисляет все функции, названия которых начинаются с вводимых букв. Лимоны 40
Когда вы найдете нужный вариант, нажмите клавишу TAB, и Excel автоматически Сумма > 170
завершит имя функции и введет открывающую круглую скобку. Кроме того, будут
показаны обязательные и необязательные аргументы.

Товар Количество
Автомобили 20
Рассмотрим структуру нескольких функций. Функция СУММ имеет следующий
Грузовики 10
синтаксис:
Велосипеды 10
Коньки 40
Имя функции. Первый Дополнительн
аргумент. Он ые аргументы, Итого:
почти всегда отделенные
является точкой с 180
обязательным. запятой (;).

ВАЖНО
Дважды щелкните эту ячейку. Вы заме
конце. Хотя в формулу можно вставля
=СУММ(D38:D41;H:H) образом, делайте это только в исключ
случаях. Это число называется конста
можете забыть о его наличии в форму
рекомендуется включить ссылку на др
Функция СУММ возвращает сумму всех значений в ячейках с D38 по D41 и во например F51. Значения, которые не б
всем столбце H. формуле, гораздо проще найти.

Теперь посмотрим на функцию, которая не требует никаких аргументов.


можете забыть о его наличии в форму
рекомендуется включить ссылку на др
Функция СУММ возвращает сумму всех значений в ячейках с D38 по D41 и во например F51. Значения, которые не б
всем столбце H. формуле, гораздо проще найти.

Теперь посмотрим на функцию, которая не требует никаких аргументов.

Функция СЕГОДНЯ возвращает текущую дату.


Ее результат автоматически обновляется при
пересчете книги Excel.

=СЕГОДНЯ()

Дополнительные сведения в Интернете


Все о функции СУММ

Использование функции «Автосумма» для суммирования чисел

Все о функции СЧЁТ

Бесплатные учебные веб-курсы по Excel

Бесплатные учебные веб-курсы по Excel


Чтобы вернуться в начало страницы, нажмите клавиши CTRL+HOME. Чтобы перейти к следующему шагу, нажмите клавиши CTRL+PAGE DOWN.
В начало страницы Следующий шаг
Мясо Количество
Говядина 50
Курятина 30
Свинина 10
Рыба 50
Сумма >

Товар Количество
Хлеб 50
Пончики 100
Печенье 40
Торты 50
Пироги 20
Счет >

ДОПОЛНИТЕЛЬНО
Попробуйте использовать функцию СЧЁТ с
помощью одного из этих способов. Функция
СЧЁТ подсчитывает количество ячеек в
диапазоне, содержащих числа.
ПОПРОБУЙТЕ САМИ!
Выделите эти ячейки. Затем в правом
нижнем углу окна Excel найдите
следующее:

Эта нижняя область называется строкой


состояния. В ней можно быстро
просмотреть итоговое значение и другие
сведения о выделенной ячейке или
диапазоне.

Дополнительное значение Новый итог


100 180

ЖНО
ды щелкните эту ячейку. Вы заметите число 100 в
е. Хотя в формулу можно вставлять числа таким
зом, делайте это только в исключительных
ях. Это число называется константой, и вы легко
ете забыть о его наличии в формуле. Вместо этого
мендуется включить ссылку на другую ячейку,
имер F51. Значения, которые не будут скрыты в
уле, гораздо проще найти.
ете забыть о его наличии в формуле. Вместо этого
мендуется включить ссылку на другую ячейку,
имер F51. Значения, которые не будут скрыты в
уле, гораздо проще найти.
ДОПОЛНИТЕЛ
ЬНО
Попробуйте
использовать
ПОПРОБУЙТЕ
здесь
САМИ!
функцию
Выберите
МЕДИАНА
любой
или МОДА.
диапазон
Функция СРЗНАЧ
Функция
чисел,
СРЗНАЧа затем
МЕДИАНА
взгляните на
выводит
Функция
строку СРЗНАЧ вычисляет среднее значение чисел в диапазоне ячеек.
значение, Фрукт Количество
Выберите
состояния,
которое Функция
ячейку СРЗНАЧ вычисляет
D7, а затем добавьтесреднее
функцию значение
СРЗНАЧчисел в диапазоне
с помощью ячеек.
Aвтосумма. Яблоки 50
Затем выберите
чтобы узнать
приходится на ячейку G7 и введите функцию СРЗНАЧ: =СРЗНАЧ(G3:G6). Апельсины 20
1 можно
их среднее
середину
В ячейке D15
значение.
набора Выберите ячейку D7, аAвтосумма
воспользоваться затем добавьте функцию
или же ввести СРЗНАЧ с помощью
другую функцию СРЗНАЧ от руки. Бананы 60
данных, а Aвтосумма Лимоны 40
МОДА —
Активировать предыдущий лист Среднее >
самое частое
2 Затем выберите ячейку G7 и введите функцию СРЗНАЧ:
Перейти
значение.к следующему листу
=СРЗНАЧ(G3:G6). Товар Количество
Дополнительные сведения в Интернете Хлеб 50
Подробные сведения о функции СРЗНАЧ в Интернете Пончики 100
3 В ячейке
Подробные сведения D15
о функции можноввоспользоваться
МЕДИАНА Интернете Aвтосумма или же ввести другую Печенье 40
Подробные сведенияфункцию СРЗНАЧ
о функции от руки.
МОДА в Интернете Торты 50
Сведения о бесплатных учебных веб-курсах по Excel Пироги 20
Назад Далее Среднее >
Назад Далее

Дополнительные сведения в Интернете


Все о функции СРЗНАЧ

Все о функции МЕДИАНА

Все о функции МОДА

Бесплатные учебные веб-курсы по Excel Дополнительные сведения о функции СУММ


С помощью нескольких описанных выше советов вы на
Ячейки с C37 по D41 содержат данные из двух столбцов
Формула в ячейке D42: =СУММ(D38:D41).
Если бы функция СУММ в ячейке D42 могла говорить, в
Вот еще один способ использования этой функции.
Ячейки с C47 по D48 содержат данные из двух столбцов

Дополнительные сведения в Интернете


Все о функции СУММ
Все о функции СУММЕСЛИ
Используйте Excel в качестве калькулятора
Бесплатные учебные веб-курсы по Excel
Чтобы вернуться в начало страницы, нажмите клавиши
Мясо Количество
Говядина 50 ПОПРОБУЙТЕ САМИ!
Выберите любой диапазон
Курятина 30 чисел, а затем взгляните на
Свинина 10 строку состояния, чтобы узнать
их среднее значение.
Рыба 50
Среднее >

Товар Количество
Хлеб 50
Пончики 100
Печенье 40
Торты 50
Пироги 20

ДОПОЛНИТЕЛЬНО
Попробуйте использовать здесь
функцию МЕДИАНА или МОДА.
МЕДИАНА выводит значение,
которое приходится на середину
набора данных, а
МОДА — самое частое значение.

ения о функции СУММ


х описанных выше советов вы научились использовать функцию СУММ. Рассмотрим ее немного подробнее.
держат данные из двух столбцов: «Фрукт» и «Количество».
=СУММ(D38:D41).
М в ячейке D42 могла говорить, вот что бы она сказала: Просуммируйте значения в ячейках D38, D39, D40 и D41.
спользования этой функции.
держат данные из двух столбцов: «Товар» и «Количество».

ения в Интернете

честве калькулятора
еб-курсы по Excel
ало страницы, нажмите клавиши CTRL+HOME. Чтобы перейти к следующему шагу, нажмите клавиши CTRL+PAGE DOWN.
ПОЛЕЗНЫЕ
СВЕДЕНИЯ
Функцию МИН
или МАКС
можно
использовать с
несколькими
Выберите
диапазонами
ячейку
В
или ячейкеD7,
D15
а

Функции МИН и МАКС


затем
можно добавьте
значениями,
Затем
функцию МИН
воспользоватьс
выберите
например
Функции МИН и МАКС
ся=МИН(A1:A10;B
мастером
помощью
ячейку G7 и
автосуммирова
Функция
мастера
1:B10) или
введите
МИН выводит минимальное число в диапазоне ячеек. Фрукт
ния или же
автосуммирова
Функция МИН выводит наименьшее число в диапазоне ячеек.
=МАКС(A1:A10; Яблоки
Функция
функцию
ввести МАКС позволяет узнать самое большое число в диапазоне ячеек.
ния.
B1).
МАКС:В
функцию Функция МАКС позволяет узнать наибольшее число в диапазоне ячеек.
МИН Апельсины
последней
=МАКС(D3:D6).
или МАКС
Дополнительн
формуле B1от Бананы
руки.
Интернете 1
является
ые сведения в
пороговым Выберите ячейку D7, а затем добавьте функцию МИН с помощью Лимоны
значением, то мастера автосуммирования. Минимум >
есть формула
Все о функции МИН
2МАКСЗатем выберите ячейку G7 и введите функцию МАКС: =МАКС(D3:D6).
никогда не
выводит
Все о функции Товар
результат Хлеб
Бесплатные
меньше B1. учебные веб-курсы по Excel
Пончики
3 В ячейке D15 можно воспользоваться мастером автосуммирования или
Печенье
же ввести функцию МИН или МАКС от руки.
Торты
Пироги
Минимум или максимум >
Назад Далее

Дополнительные сведения в Интернете


Функцию МИН или МАКС можно использовать с несколькими диапазонами или значениями, например =МИН(A1:A10;B1:B10) или =МАКС(A1:A10;10).

Дополнительные сведения в Интернете


Все о функции МИН Все о функции МИН
Все о функции МАКС
Все оExcel
Использование Microsoft функции МАКС
в качестве калькулятора
Бесплатные учебные веб-курсы по Excel
Бесплатные учебные веб-курсы по Excel
Количество Мясо Количество
50 Говядина 50
20 Курятина 30
60 Свинина 10
40 Рыба 50
Максимум >

Количество Товар Количество


50 Хлеб 50
100 Пончики 100
40 Печенье 40
50 Торты 50
20 Пироги 20
10

ПОЛЕЗНЫЕ СВЕДЕНИЯ
Функцию МИН или МАКС можно использовать с несколькими
диапазонами или значениями, например =МИН(A1:A10;B1:B10)
или =МАКС(A1:A10;B1). В последней формуле B1 является
пороговым значением, то есть формула никогда не выводит
результат меньше B1.
вать
потомуячейку
что вы
отображает
как число.
еще не
текущее
Чтобы
указали свой
время,
сделать это,
день
которое
откройте
рождения,
обновляется
вкладку
используйте
при каждом
«Главная»,
формулу
пересчете
нажмите
=ЕСЛИ(D7="";"
книги Excel.
кнопку
";D7-D6). Она
Если вам
Функции даты
«Формат»
означает
Функции даты и
нужно
выберите
следующее:
изменить
Excel
«Формат
если может вывести текущую дату с учетом региональных параметров компьютера. Кроме того, он может складывать и вычитать даты.
ячейка
формат
ячеек» (или
D7 пуста,
времени,
Попробуйте использовать функцию СЕГОДНЯ, которая выводит сегодняшнюю дату. Это динамическая функция, поэтому если вы откроете книгу завтра, дата изменится
ничего неExcel может вывести текущую дату с учетом региональных параметров
же нажмите
нажмите
Вычитание
клавиши
отображать, дат:
в введите Кроме
компьютера. в ячейку D7 свой
того, следующий
он может день рождения
складывать в формате
и вычитать даты. дд.мм.гг, и Excel подсчитает в ячейке D8, сколько дней до него осталось, с помощью фо
клавиши
CTRL+1), а дат: предположим, вы хотите узнать, когда следует оплатить счет или вернуть книгу в библиотеку. Для этого можно прибавить нужное количество дней к дат
противном
Сложение
CTRL+1,
затем
случае нана Функции даты
1
вкладке
ПОЛЕЗНЫЕ
вывести D7 СВЕДЕНИЯ
вкладке
«Число» Попробуйте использовать функцию СЕГОДНЯ, которая выводит
Excel
«Число»хранит
D6. даты всегодняшнюю
виде количества дней, прошедших с 1 января 1900 г. Значения времени переводятся в минуты Сегодняшняя
и хранятся как
дата:
дробные части дня. Например, значен
минус
щелкните дату. Это динамическая функция, поэтому если вы откроете
щелкните Ваш день рождения:
«Время»
«Числовой» и и книгу завтра, дата изменится. Введите =СЕГОДНЯ() в ячейку D6.
выберите
Функции
задайте 2времени Дней доидня рождения:
Excel
нужный может вывести текущее время с учетом региональных параметров компьютера. Кроме того, он может складывать вычитать значения времени. Например, вы мо
десятичных
формат.
знака. 2 Вычитание дат: введите в ячейку D7 свой следующий день рождения в Период оплаты:
формате дд.мм.гг, и Excel подсчитает в ячейке D8, сколько дней до него
осталось, с помощью формулы =D7-D6. Срок платежа:
Вот как расшифровывается эта формула: возьмем время окончания работы и вычтем из него время начала, затем отнимем от полученного значения разницу между ок
Назад
Далее 3 Сложение дат: предположим, вы хотите узнать, когда следует оплатить ПОЛЕЗНЫЕ СВЕДЕНИЯ
счет или вернуть книгу в библиотеку. Для этого можно прибавить нужное Excel хранит даты в виде количества дней,
Дополнительные сведения в Интернете
количество дней к дате. В ячейке D10 введите какое-либо число дней. В прошедших с 1 января 1900 г. Значения времени
Все о функции СЕГОДНЯ переводятся в минуты и хранятся как дробные ч
ячейке D11 указана формула =D6+D10, которая рассчитывает срок
Все о функции ТДАТА дня. Например, значение 12:30 01.01.2017 храни
начиная с текущей даты. как 42736,5208. Если значения времени или дат
Все о функции ДАТА
отображаются в виде таких чисел, вы можете
Бесплатные учебные веб-курсы по Excel нажать клавиши CTRL+1 и на вкладке Число выб
формат Дата или Время.

Функции времени
Excel может вывести текущее время с учетом региональных параметров
компьютера. Кроме того, он может складывать и вычитать значения времени.
Например, вы можете отслеживать, сколько часов в неделю проработал Функции времени
сотрудник, чтобы вычислять его зарплату и сверхурочные. Текущее время:
Excel может вывести текущее время с учетом региональных параметров
компьютера. Кроме того, он может складывать и вычитать значения времени.
Например, вы можете отслеживать, сколько часов в неделю проработал
сотрудник, чтобы вычислять его зарплату и сверхурочные.

1 В ячейке D28 введите =ТДАТА(). Эта формула отображает текущее


время, которое обновляется при каждом пересчете книги Excel. Если Отработано часов
вам нужно изменить формат времени, нажмите клавиши CTRL+1, на Время начала:
вкладке Число щелкните Время и выберите нужный формат. Окончание обеда:
Начало обеда:
2 Чтобы определить количество часов между значениями Время окончания:
времени, в ячейке D36 мы ввели формулу =((D35-D32)-(D34- Всего часов:
D33))*24, которая вычисляет время начала и окончания работы, а
затем вычитает время, затраченное на обед. Операция *24 в конце
формулы преобразует дробную часть дня, которая хранится в Excel, в
часы. Вам потребуется отформатировать ячейку как число. Чтобы
сделать это, откройте вкладку Главная, нажмите кнопку Формат и
выберите Формат ячеек (или же нажмите клавиши CTRL+1), а затем
на вкладке Число щелкните Числовой и задайте 2 десятичных знака.

3 Вот как расшифровывается эта формула: возьмем время окончания Статические значения даты и время
работы и вычтем из него время начала, затем отнимем от Дата:
полученного значения разницу между окончанием и началом обеда и Время:
умножим результат на 24, чтобы преобразовать дробные значения
времени в часы. Схематично это можно представить как
=((Окончание работы - Начало работы)-(Окончание обеда -
Начало обеда))*24.
Умножение на 24 для
преобразования ПОЛЕЗНЫЕ СВЕДЕНИЯ
Время окончания Окончание обеда дробного значения в С помощью сочетаний клавиш можно
часы вводить значения даты и времени, которые
не будут постоянно изменяться:

Дата: CTRL+SHIFT+4
=((D35-D32)-(D34-D33))*24 Время: CTRL+SHIFT+6

Время начала Начало обеда


Время начала Начало обеда

Внутренние скобки () указывают на то, что эти части формулы


нужно вычислить отдельно. Внешние скобки позволяют Excel
перемножить внутренний результат на 24.

Назад Далее

Дополнительные сведения в Интернете


Все о функции СЕГОДНЯ

Все о функции ТДАТА

Все о функции ДАТА

Бесплатные учебные веб-курсы по Excel


ы откроете книгу завтра, дата изменится. Введите =СЕГОДНЯ() в ячейку D6.
о дней до него осталось, с помощью формулы = D7-D6.

Функции даты

0 ВАЖНО
ать значения времени. Например, вы можете
Еслиотслеживать,
вы не хотите,сколько часоввыводил
чтобы Excel в неделю проработал сотрудник, чтобы вычислять его зарплату и сверхурочные.
отрицательное число, потому что вы еще не
указали свой день рождения, используйте формулу
=ЕСЛИ(D7="";"";D7-D6). Она означает следующее:
30/12/99 если ячейка D7 пуста, ничего не отображать, в
олученного значения разницу между окончанием и началом
противном обеда и умножим
случае вывести результат на 24, чтобы преобразовать дробные значения времени в часы. Схематично это можно пр
D7 минус D6.

ЗНЫЕ СВЕДЕНИЯ
нит даты в виде количества дней,
ших с 1 января 1900 г. Значения времени
ятся в минуты и хранятся как дробные части
ример, значение 12:30 01.01.2017 хранится
6,5208. Если значения времени или даты
аются в виде таких чисел, вы можете
лавиши CTRL+1 и на вкладке Число выбрать
Дата или Время.

нкции времени
работано часов
8:00
12:00
13:00
17:00
8

е значения даты и время


27/09/17
8:52

ВЕДЕНИЯ
аний клавиш можно
я даты и времени, которые
но изменяться:

а: CTRL+SHIFT+4
мя: CTRL+SHIFT+6
сы. Схематично это можно представить как =((Окончание работы - Начало работы)-(Окончание обеда - Начало обеда))*24.
чтобы создать
новую
текстовую
строку.
Введем
=D3&", "&C3.
Синтаксис
&" ,"&
позволяет
Объединение текста из разных ячеек
ПОПРОБУЙТЕ
объединить
Объединение
В Excel
САМИ! часто текста из разных
приходится ячеек текстовые строки, которые находятся в разных ячейках. Допустим, у вас есть списки имен и фамилий и вы хотите объединить их в
объединять
В ячейке
пробел с C36
Формулы,
В ячейкевE3 введите =D3&C3, чтобы объединить фамилии и имена.
введите Имя
текстом
В ячейке C37
особенно
=C28&"
ячейках. Надежда
введите
длинные, В
"&ТЕКСТ(D28;
=C29&" Excel часто приходится объединять текстовые строки, которые находятся в Виктор
Кроме того, соединим имя с фамилией в обратном порядке. В ячейке F3 введем =C3&" "&D3.
иногда
"ДД-ММ- разных ячейках. Допустим, у вас есть списки имен и фамилий и вы хотите
"&ТЕКСТ(D29; Виталий
сложно
ГГГГ"). ДД-
"ч:мм").
читать.
Подробнее
ММ-ГГГГ объединить
ч:мм
Вы— их в полные имена. К счастью, в Excel это можно сделать с помощью Валентина
— это русский
можете амперсанда (&), который вводится путем нажатия клавиш SHIFT+7.
это русский
Далее
формат Николай
разделить
формат их
даты,
времени,
Объединение
на части 23- текста и чисел Василий
на1диапазон
например
например
Взгляните
пробелами:
09-2017. В ячейке E3 введите
C28:D29. Значения=D3&C3, чтобы объединить
даты и времени фамилии
указаны в разных и имена.
ячейках. Их можно объединить с помощью
Кирилл символа &, но результат в ячейках C32:C33 не с
13:30.
Евгения
=C28 & " " &
2 Хм, «КолесниковаНадежда» смотрится не так уж красиво. Нужно
ТЕКСТ(D28;"Д
Д-ММ-ГГГГ")
СЛЕДУЕТ ЗНАТЬ добавить пробел. Используем кавычки, чтобы создать новую
Если вы не знаете, какой код формата использовать, нажмите клавиши CTRL+1 и выберите формат на вкладке «Число». Затем щелкните «(все форматы)». Вы можете ск
текстовую строку. Введем =D3&", "&C3. Синтаксис &", "& позволяет
Дополнительные сведения в Интернете
объединить пробел с текстом в ячейках.
Все о функции ТЕКСТ
Объединение текста и чисел
Бесплатные3 учебныеКроме того, соединим
веб-курсы по Excel имя с фамилией в обратном порядке. В ячейке
F3 введем =C3&" "&D3.

Подробнее Далее

Объединение текста и чисел


Использование текста и чисел
Попробуем объединить с помощью оператора & не только текстовые строки, но Сегодняшняя дата:
и числа. Текущее время:

Взгляните на диапазон C28:D29. Значения даты и времени указаны в разных


ячейках. Их можно объединить с помощью символа &, но результат в ячейках
C32:C33 не слишком радует. К сожалению, Excel не знает, как вы хотите
отформатировать числа, поэтому представляет их в базовом формате. В данном
Попробуем объединить с помощью оператора & не только текстовые строки, но
и числа.

Объединение текста и чисел


Взгляните на диапазон C28:D29. Значения даты и времени указаны в разных
Сегодняшняя дата: 44448
ячейках. Их можно объединить с помощью символа &, но результат в ячейках
Текущее время: 44448.4495089108
C32:C33 не слишком радует. К сожалению, Excel не знает, как вы хотите
отформатировать числа, поэтому представляет их в базовом формате. В данном
Форматирование текста и чисел
случае это порядковый номер даты. Нужно в явном виде указать, как следует
Сегодняшняя дата: ДД-ММ-ГГГГ
отформатировать число в формуле. Для этого можно использовать функцию
Текущее время: ч:мм
ТЕКСТ и код формата.

1 В ячейке C36 введите =C28&" "&ТЕКСТ(D28;"ДД-ММ-ГГГГ").


ДД-ММ-ГГГГ — это русский формат даты, например 23-09-2017.

2 В ячейке C37 введите =C29&" "&ТЕКСТ(D29;"ч:мм"). ч:мм — это


СЛЕДУЕТ ЗНАТЬ
русский формат времени, например 13:30. Если вы не знаете, какой код формата использовать,
нажмите клавиши CTRL+1 и выберите формат на
вкладке Число. Затем щелкните (все форматы). Вы
можете скопировать нужный код формата в формулу.
Назад Далее

Дополнительные сведения в Интернете


Все о функции ТЕКСТ

Объединение текста и чисел

Бесплатные учебные веб-курсы по Excel


Фамилия Имя Фамилия Фамилия Имя
Колесникова Колесникова, Надежда Надежда Колесникова
Дегтярев
Токарев
Александрова
Белых
Бутусов
Крюков
Маслова

все форматы)». Вы можете скопировать нужный код формата в формулу.

е текста и чисел
09/09/21
10:47
текста и чисел

ие текста и чисел
ПОПРОБУЙТЕ САМИ!
Формулы, особенно длинные, иногда
сложно читать. Вы можете разделить их на
части пробелами:

=C28 & " " & ТЕКСТ(D28;"ДД-ММ-ГГГГ")

од формата использовать,
и выберите формат на
кните (все форматы). Вы
ый код формата в формулу.
значением
СОВЕТ
указана
его. Это
0,0825.
Попробуем
ЭКСПЕРТА
формула
именованный
Формула
еще один
Благодаря
=ЕСЛИ(E35="Д
диапазон,
означает
пример.
а";СУММ(D28:
именованным
который
Скопируйте мы
следующее:
Взгляните
D29)*1,25;0).
диапазонам
В ячейке D9на
определили
ячейку
если
формулу D9
значение
в в с
Она
можно означает
введите
впомощью
D10.
ячейкеВ ней
ячейке
следующее:
определить E33
D12:
=ЕСЛИ(C9="Яб
команды
будет
равно «Да»,
=ЕСЛИ(C12<10
условия
если или >
ячейка
локо";ИСТИН
«Формулы»
выведен
следует
0;"Меньше
значения
E35 имеет
А;ЛОЖЬ).
«Задать
ответ имя».
ЛОЖЬ,
умножить
Операторы ЕСЛИ
100";"100
один раз, аили
значение
Правильный
Если
так вам
как
Операторы
значение
больше"). ЕСЛИ
вЧто
затем
«Да»,
ответ —следует
когда-либо
апельсины и
ячейке
Операторы F31
произойдет,
многократно
вычислить
ИСТИНА. на
ЕСЛИ позволяют выполнять логические сравнения условий. Обычно оператор ЕСЛИ означает следующее: если условие имеет значение ИСТИНА, следует вы
потребуется
яблоки
НДС, —
если в ячейку
сумму
использовать
изменить
разные ввещи.
противном
C12в ввести
столбце
их книге.
стоимость
случае
100 Операторы ЕСЛИ позволяют выполнять логические сравнения условий. Обычно
или число
«Количество»
Чтобы
доставки, вы
вернуть
больше
просмотреть
приведенной
В отличие 0.оператор
100 от других ЕСЛИ означаетИСТИНА
слов, значения следующее:
и ЛОЖЬесли
не условие имеет значение
нужно заключать ИСТИНА,
в кавычки. Кроме того, Excel автоматически пишет их с большой буквы. Для чисел также не нуж
можете
все
выше следует выполнить
=ЕСЛИ(C3="Яблоко";"Да";"Нет")
сделать это некое действие, в противном случае необходимо выполнить
Выберите идругое
именованные
таблицы
один раз,
Подробнее
«Нет» вместоа действие. Формулы могут возвращать текст, значения или даже другие
диапазоны
умножить в
ее
затем
«Да»
Далее
книге,
на 1,25, в вычисления.
в ячейке Операторы ЕСЛИ
использовать
E33 и
противном
выберите
Оператор
С ЕСЛИ с другой функцией Яблоко
помощью операторов ЕСЛИ также можно выполнять дополнительные вычисления при соблюдении определенного условия. В этом примере мы определим, нужно л
имя
посмотрите,
случае
«Формулы» в>
1
«Доставка» Апельсин
как изменится
необходимо
«Диспетчер
любой ячейке В ячейке D9 введите =ЕСЛИ(C9="Яблоко";ИСТИНА;ЛОЖЬ).
вычисление.
вернуть
имен».
книги. 0. Правильный ответ — ИСТИНА.
Щелкните 50
здесь, чтобы
ПОЛЕЗНЫЕ
узнать
При создании
2 формулы
Скопируйте ячейку D9 в D10. В ней будет выведен ответ ЛОЖЬ, так как
СВЕДЕНИЯ
Excel автоматически выводит цветные границы вокруг диапазонов, на которые она ссылается; при этом цвет границ соответствует цвету диапаз
больше. апельсины и яблоки — разные вещи.
ВАЖНО
Назад В отличие от других слов, значения ИСТИН
Далее 3 Попробуем еще один пример. Взгляните на формулу в ячейке D12: нужно заключать в кавычки. Кроме того, E
=ЕСЛИ(C12<100;"Меньше 100";"100 или больше"). Что произойдет, автоматически пишет их с большой буквы.
Дополнительные сведения в Интернете также не нужны кавычки. Обычный текст,
если в ячейку C12 ввести 100 или число больше 100?
Все о функции ЕСЛИ или Нет, необходимо заключать в кавычки
Все о функции ЕСЛИМН =ЕСЛИ(C3="Яблоко";"Да";"Нет")
Сложные операторы ЕСЛИ
Подробнее
Бесплатные учебные веб-курсы по Excel Далее

Оператор ЕСЛИ с другой функцией Товар


Вилка
Ложка
С помощью операторов ЕСЛИ также можно выполнять дополнительные
вычисления при соблюдении определенного условия. В этом примере мы
определим, нужно ли взимать НДС, и вычислим его, если условие соблюдается.
С помощью операторов ЕСЛИ также можно выполнять дополнительные
вычисления при соблюдении определенного условия. В этом примере мы
определим, нужно ли взимать НДС, и вычислим его, если условие соблюдается.

1 В ячейке F33 мы ввели =ЕСЛИ(E33="Да";F31*НДС;0), где «НДС» — это


именованный диапазон со значением 0,0825. Формула означает
следующее: если значение в ячейке E33 равно «Да», следует умножить
значение в ячейке F31 на НДС, в противном случае вернуть 0.

Выберите «Нет» вместо «Да» в ячейке E33 и посмотрите, как изменится


вычисление.

2 Затем мы добавим оператор ЕСЛИ, чтобы рассчитать стоимость


доставки, если она требуется. В ячейке F35 указана формула
=ЕСЛИ(E35="Да";СУММ(D28:D29)*1,25;0). Она означает следующее:
если ячейка E35 имеет значение «Да», следует вычислить сумму в
столбце «Количество» приведенной выше таблицы и умножить ее на
1,25, в противном случае необходимо вернуть 0.
СОВЕТ ЭКСПЕРТА
3 Теперь замените 1,25 в формуле в ячейке F35 словом Доставка. По Благодаря именованным диапазонам можно
мере ввода Excel найдет и предложит вам это значение. Нажмите определить условия или значения один раз, а затем
многократно использовать их в книге. Чтобы
клавишу TAB, чтобы ввести его. Это именованный диапазон, который просмотреть все именованные диапазоны в книге,
мы определили с помощью команды Формулы > Задать имя. Если выберите Формулы > Диспетчер имен. Щелкните
вам когда-либо потребуется изменить стоимость доставки, вы можете здесь, чтобы узнать больше.
сделать это один раз, а затем использовать имя «Доставка» в любой
ячейке книги.

Назад Далее

Дополнительные сведения в Интернете


Все о функции ЕСЛИ

Все о функции ЕСЛИМН

Сложные операторы ЕСЛИ

Бесплатные учебные веб-курсы по Excel


и условие имеет значение ИСТИНА, следует выполнить некое действие, в противном случае необходимо выполнить другое действие. Формулы могут возвращать текст, значения и

ет их с большой буквы. Для чисел также не нужны кавычки. Обычный текст, такой как «Да» или «Нет», необходимо заключать в кавычки:

Операторы ЕСЛИ

Меньше 100

и этом цвет границ соответствует цвету диапазона в формуле. Убедитесь в этом сами: выделите ячейку F33 и нажмите клавишу F2, чтобы изменить формулу.
ВАЖНО
В отличие от других слов, значения ИСТИНА и ЛОЖЬ не
нужно заключать в кавычки. Кроме того, Excel
автоматически пишет их с большой буквы. Для чисел
также не нужны кавычки. Обычный текст, такой как Да
или Нет, необходимо заключать в кавычки:
=ЕСЛИ(C3="Яблоко";"Да";"Нет")

Количество Стоимость Итого


2 9.76 ₽ 19.52 ₽
3 3.42 ₽ 10.26 ₽
Промежуточный итог 13.18 ₽ 29.78 ₽

НДС? Да 2.46 ₽ ПОЛЕЗНЫЕ СВЕДЕНИЯ


При создании формулы Excel автоматически
выводит цветные границы вокруг диапазонов, на
Доставка? Да 6.25 ₽ которые она ссылается; при этом цвет границ
соответствует цвету диапазона в формуле.
Итого 38.48 ₽ Убедитесь в этом сами: выделите ячейку F33 и
нажмите клавишу F2, чтобы изменить формулу.

ЕТ ЭКСПЕРТА
даря именованным диапазонам можно
елить условия или значения один раз, а затем
кратно использовать их в книге. Чтобы
отреть все именованные диапазоны в книге,
рите Формулы > Диспетчер имен. Щелкните
чтобы узнать больше.
ращать текст, значения или даже другие вычисления.
вВ ячейке G43 D22
=ЕСЛИ(C43="";
специальную
введите
"";ВПР(C43;C3
функцию
=ВПР(C22;C17:
7:D41;2;ЛОЖЬ
ЕСЛИОШИБКА
D20;2;ЛОЖЬ).
))
:Правильный
=ЕСЛИОШИБК
ответ для
Эта формула
А(ВПР(F43;F37
значения
Теперь
означает, что
:G41;2;ЛОЖЬ);
«Яблоки» —
попробуйте
если
""). в
Еслиячейке
50. Функция
самостоятель
C43 ничего
функция ВПР
ВПР
ВПР
но
нет нашла
ввести
(""),
ВПР
возвращает
ВПР — одна
значение
формулу
возвращается
действительн дляиз самых популярных (и наших любимых!) функций Excel. Она позволяет найти значение в столбце слева, а затем вернуть данные из другого столбца справ
«Яблоки»,
таблицы
пустое а
ый
затемрезультат,
вернула
=ВПР(A1;B:C;2;ЛОЖЬ)
«Мясо»
будетв а в
значение,
он
количество,
ячейку
противном ВПР
G22. — одна из самых популярных (и наших любимых!) функций Excel. Она
Что нужно
выведен;
указанное ввнайти?
Вы должны
случае
противном позволяет найти значение в столбце слева, а затем вернуть данные из другого
Из какого столбца справа
столбце
получить
возвращаются нужно получить значение?
случае
справа
Где нужно
формулу
результаты отстолбца
не справа. У функции ВПР следующий синтаксис:
найти значение?
отображается
него.
=ВПР(F22;F17:
функции
Может ("").
ничего лиВПР.
совпадение быть неточным?
G20;2;ЛОЖЬ).
Обратите Что нужно Из какого столбца
Кроме того,
внимание
вы можетена найти? справа нужно получить
вторую
ЭКСПЕРИМЕНТ
вывести значение?
круглую
Попробуйте выбрать другие элементы из раскрывающихся списков. Значения в ячейках результатов мгновенно обновятся.
определенно
скобку
числов(0, 1, 2
еПодробнее
конце
и т. д.) или
Далее
формулы.
текстовое Она
закрывает
ВПР
Рано иили
оператор
#Н/Д
значение, =ВПР(A1;B:C;2;ЛОЖЬ)
поздно вы столкнетесь с тем, что функция ВПР не сможет найти требуемое значение и вернет ошибку #Н/Д. Это может произойти потому, что искомое значен
например
ЕСЛИ.
"Неправильна
ВАЖНО
я формула".
Функция ЕСЛИОШИБКА является глобальным обработчиком ошибок, то есть подавляет любые ошибки в формуле. Это может привести к проблемам, если в формуле ес
Где нужно Может ли Фрукт Количество
найти совпадение
Не добавляйте обработчики ошибок в формулы, пока не будете абсолютно уверены в том, что они работают правильно.
Яблоки 50
значение? быть
Назад неточным? Апельсины 20
Далее Бананы 60
Дополнительные сведения в Интернете Лимоны 40

1 В ячейке D22 введите =ВПР(C22;C17:D20;2;ЛОЖЬ). Правильный ответ


Все о функции ВПР
Все о функциях ИНДЕКС и ПОИСКПОЗ Яблоки
для значения «Яблоки» — 50. Функция ВПР нашла значение «Яблоки», а
Все о функции ЕСЛИОШИБКА
затем вернула количество, указанное в столбце справа от него.
Использование сводных таблиц для анализа данных
Бесплатные 2 Теперь
учебные попробуйте
веб-курсы по Excel самостоятельно ввести формулу для таблицы ЭКСПЕРИМЕНТ
Попробуйте выбрать другие элементы из раскрывающи
«Мясо» в ячейку G22. Вы должны получить формулу списков. Значения в ячейках результатов мгновенно
=ВПР(F22;F17:G20;2;ЛОЖЬ). обновятся.

Подробнее Далее
Подробнее Далее

ВПР и #Н/Д Если бы функция СУММ в ячейке D42 могла говорить, вот что бы она сказала: просуммиру
Товар Количество
Хлеб 50
Рано или поздно вы столкнетесь с тем, что функция ВПР не сможет найти Пончики 100
требуемое значение и вернет ошибку #Н/Д. Это может произойти потому, что Печенье 40
искомое значение не существует или ячейка, указывающая на него, пуста. Торты 50
Пироги 20
1 Если вы знаете, что искомое значение существует, и хотите скрывать
сообщение об ошибке, если ячейка, ссылающаяся на него, пуста, можно #N/A
использовать оператор ЕСЛИ. При этом формула в ячейке D43 будет
выглядеть следующим образом:

=ЕСЛИ(C43="";"";ВПР(C43;C37:D41;2;ЛОЖЬ))

Эта формула означает, что если в ячейке C43 ничего нет (""),
возвращается пустое значение, а в противном случае возвращаются
результаты функции ВПР. Обратите внимание на вторую круглую скобку
в конце формулы. Она закрывает оператор ЕСЛИ.

2 Если вы не уверены в том, что искомое значение существует, но не


хотите, чтобы выводилась ошибка #Н/Д, вы можете использовать в
ячейке G43 специальную функцию ЕСЛИОШИБКА:
=ЕСЛИОШИБКА(ВПР(F43;F37:G41;2;ЛОЖЬ);""). Если функция ВПР
возвращает действительный результат, он будет выведен; в противном
случае не отображается ничего (""). Кроме того, вы можете вывести
определенное число (0, 1, 2 и т. д.) или текстовое значение, например
"Неправильная формула".
Назад Далее

Дополнительные сведения в Интернете


Все о функции ВПР

Все о функциях ИНДЕКС и ПОИСКПОЗ

Все о функции ЕСЛИОШИБКА

Использование сводных таблиц для анализа данных

Бесплатные учебные веб-курсы по Excel


данные из другого столбца справа. У функции ВПР следующий синтаксис:

ойти потому, что искомое значение не существует или ячейка, указывающая на него, пуста.

Мясо Количество
Говядина 50
Курятина 30
Свинина 10
Рыба 50

Свинина

ругие элементы из раскрывающихся


ейках результатов мгновенно
что бы она сказала: просуммируйте значения в ячейках D38, D39, D40 и D41.
Товар Количество
Хлеб 50
Пончики 100
Печенье 40
Торты 50
Пироги 20

Выпечка

ВАЖНО
Функция ЕСЛИОШИБКА является глобальным обработчиком
ошибок, то есть подавляет любые ошибки в формуле. Это
может привести к проблемам, если в формуле есть ошибка,
которую следовало бы исправить.

Не добавляйте обработчики ошибок в формулы, пока не


будете абсолютно уверены в том, что они работают
правильно.
значения по
столбцам
«Фрукт» и
«Сорт», а не
только по
столбцу
«Фрукт».
Выберите
ячейку
СОВЕТ H17 и
Условные функции: СУММЕСЛИ
введите
ЭКСПЕРТА
Условные
=СУММЕСЛИ функции: СУММЕСЛИ
В ячейках
Функция
Условные функции позволяют определять сумму, среднее, количество значений, минимум и максимум в диапазон Фрукт Количество
МН(H3:H14;F3
«Фрукт» и
СЧЁТЕСЛИМН
:F14;F17;G3:G
Функцияесть
«Сорт»
похожа наСУММЕСЛИ позволяет вычислить сумму в одном диапазоне с учетом условия, соответствие которому Яблоки 50
14;G17).
раскрывающеУсловные функции позволяют определять сумму, среднее, количество значений,
функцию
Функция 150 Апельсины 20
еся списки,
СЧЁТЕСЛИ, минимум
в
но и максимум в диапазоне с учетом указанного условия. Например,
В каком диапазоне нужно найти значение?
СУММЕСЛИМ Бананы 60
которых
позволяет
Н имеет можно определить, сколько в списке фруктов яблок или апельсинов сорта Florida.
Какое
можно значение (текстовое или числовое) нужно найти?
задавать Лимоны 40
следующий
выбрать
несколько
В каком диапазоне нужно просуммировать соответствующие значения?
синтаксис: Яблоки 50
различные
условий. Апельсины 20
фрукты.
Например, в
1 Функция СУММЕСЛИ
=СУММЕСЛИМН(H3:H14;F3:F14;F17;G3:G14;G17)
Попробуйте
этом примере
позволяет вычислить сумму в одном диапазоне с Бананы 60
сделать
можно это
искатьи учетом условия, соответствие которому определяется по другому
В каком диапазоне нужно просуммировать значения?
Второй Лимоны 40
обратите
значения
диапазон по
для диапазону. Например, так можно определить общее количество яблок.
Первый
внимание диапазон
на для поиска соответствующих значений Яблоки 50
столбцам
поиска Выберите ячейку D17 и введите =СУММЕСЛИ(C3:C14;C17;D3:D14).
Первое
то, как
«Фрукт» условие
и
соответствую Апельсины 20
формулы
«Сорт», а не Функция СУММЕСЛИ имеет следующий синтаксис:
щих значений Бананы 60
автоматическ
только по
Второе
и условие Лимоны 40
столбцу В каком диапазоне В каком диапазоне нужно
обновляются.
«Фрукт». нужно найти значение? просуммировать
Выберите
Подробнее соответствующие значения? Фрукт СУММЕСЛИ
ячейку H64 и
Следующий
введите шаг Яблоки
Условные функции: СУММЕСЛИ
=СЧЁТЕСЛИМ
Н(F50:F61;F64;
Функции СЧЁТЕСЛИ и СЧЁТЕСЛИМН позволяют подсчитать значения в диапазоне с учетом указанных условий. Они отличаются от функций ЕСЛИ и ЕСЛИМН тем, что у ни
G50:G61;G64).
Выберите =СУММЕСЛИ(C3:C14;C17;D3:D14)
Функция ячейку D64 и введите =СЧЁТЕСЛИ(C50:C61;C64). Функция СЧЁТЕСЛИ имеет следующий синтаксис:
=СЧЁТЕСЛИ(C50:C61;C64)
СЧЁТЕСЛИМН
имеет
В каком диапазоне нужно найти значение?
следующий
Какое значение (текстовое или числовое) нужно найти?
синтаксис: Какое значение (текстовое
или числовое) нужно найти?
=СЧЁТЕСЛИМН(F50:F61;F64;G50:G61;G64)
Первый диапазон для подсчета значений
2 Функция СУММЕСЛИМН похожа на функцию СУММЕСЛИ, но
Первое условие
позволяет задавать несколько условий. Например, в этом примере
Второй диапазон для подсчета значений
можно искать значения по столбцам «Фрукт» и «Сорт», а не только по
Второе условие
столбцу «Фрукт». Выберите ячейку H17 и введите
=СУММЕСЛИМН(H3:H14;F3:F14;F17;G3:G14;G17). Функция
СУММЕСЛИМН имеет следующий синтаксис:
Функция СУММЕСЛИМН похожа на функцию СУММЕСЛИ, но
СУММЕСЛИ =СУММЕСЛИ(C92:C103;C106;E92:E103)
СУММЕСЛИМН позволяет задавать несколько условий. Например, в этом примере
=СУММЕСЛИМН(E92:E103;C92:C103;C106;D92:D103;D106)
СРЗНАЧЕСЛИ можно искать значения по столбцам «Фрукт» и «Сорт», а не только по
=СРЗНАЧЕСЛИ(C92:C103;C106;E92:E103)
СРЗНАЧЕСЛИМН столбцу «Фрукт». Выберите ячейку H17 и введите
=СРЗНАЧЕСЛИМН(E92:E103;C92:C103;C106;D92:D92;D106)
Подробнее =СЧЁТЕСЛИ(C92:C103;C106)
СЧЁТЕСЛИ
СЧЁТЕСЛИМН =СУММЕСЛИМН(H3:H14;F3:F14;F17;G3:G14;G17).
=СЧЁТЕСЛИМН(C92:C103;C106;D92:D103;D106) Функция
Далее
МАКСЕСЛИМН СУММЕСЛИМН имеет следующий синтаксис:
=МАКСЕСЛИМН(E92:E103;C92:C103;C106;D92:D103;D106)
Другие условные =МИНЕСЛИМН(E92:E103;C92:C103;C106;D92:D103;D106)
МИНЕСЛИМН функции
В каком Первое Второе
Подробнее диапазоне нужно условие условие
просуммировать
Далее
значения?
Функция СУММЕСЛИ с аргументом значения
Вот пример использования функции СУММЕСЛИ с оператором «больше» (>) для поиска всех значений, превышающих указанное:
=СУММЕСЛИ(D118:D122;">50")

Сложить значения с учетом этого условия:


 
=СУММЕСЛИМН(H3:H14;F3:F14;F17;G3:G14;G17)
Просмотреть эти ячейки:
Если значение больше 50, добавить его в сумму.
 
ПРИМЕЧАНИЕ. Если вы часто применяете условные формулы, возможно, стоит воспользоваться сводной таблицей. Дополнительные сведения см. в статье о сводных та
Дополнительные сведения в Интернете Первый Второй диапазон
диапазон для для поиска
Все о функции СУММЕСЛИ поиска соответствующих
Все о функции СУММЕСЛИМН соответствующих значений
Все о функции СЧЁТЕСЛИ значений
Все о функции СЧЁТЕСЛИМН
Все о функции СРЗНАЧЕСЛИ
Все о функции СРЗНАЧЕСЛИМН Фрукт Количество
Все о функции МИНЕСЛИМН Подробнее Далее Яблоки 50
Все о функции МАКСЕСЛИМН Апельсины 20
Создание раскрывающегося списка Бананы 60
Бесплатные учебные веб-курсы по Excel Лимоны 40
В начало страницы Яблоки 50
Далее Условные функции: СУММЕСЛИ Апельсины
Бананы
20
60
Лимоны 40
Функции СЧЁТЕСЛИ и СЧЁТЕСЛИМН позволяют подсчитать значения в Яблоки 50
диапазоне с учетом указанных условий. Они отличаются от других функций ЕСЛИ Апельсины 20
и ЕСЛИМН тем, что у них есть только условия и диапазон, в котором они Бананы 60
проверяются. Они не суммируют значения в одном диапазоне после проверки Лимоны 40
значений в другом.
Фрукт СЧЁТЕСЛИ
1 Выберите ячейку D64 и введите =СЧЁТЕСЛИ(C50:C61;C64). Функция
Яблоки 3
СЧЁТЕСЛИ имеет следующий синтаксис:

В каком диапазоне
нужно найти значение?

=СЧЁТЕСЛИ(C50:C61;C64)

Какое значение (текстовое


или числовое) нужно найти?

2 Функция СЧЁТЕСЛИМН похожа на функцию СЧЁТЕСЛИ, но позволяет


задавать несколько условий. Например, в этом примере можно искать
значения по столбцам «Фрукт» и «Сорт», а не только по столбцу
«Фрукт». Выберите ячейку H64 и введите
=СЧЁТЕСЛИМН(F50:F61;F64;G50:G61;G64). Функция СЧЁТЕСЛИМН
имеет следующий синтаксис:

Первый диапазон для Второй диапазон для


подсчета значений подсчета значений

=СЧЁТЕСЛИМН(F50:F61;F64;G50:G61;G64)
Фрукт Сорт
Первое Второе Яблоки Fuji
условие условие
Апельсины Florida
Бананы Cavendish
Лимоны Rough
Яблоки Honeycrisp
Подробнее Далее Апельсины Navel
Бананы Lady Finger
Лимоны Eureka
Яблоки Honeycrisp

Другие условные функции


Апельсины Navel
Бананы Cavendish
Лимоны Eureka
Вы уже знакомы с функциями СУММЕСЛИ, СУММЕСЛИМН, СЧЁТЕСЛИ и
Фрукт Сорт
СЧЁТЕСЛИМН. Теперь попробуйте самостоятельно изучить другие функции,
Лимоны Eureka
например СРЗНАЧЕСЛИ, СРЗНАЧЕСЛИМН, МАКСЕСЛИМН или МИНЕСЛИМН.
Все они имеют одинаковый синтаксис, поэтому если у вас уже есть формула, вы
можете просто заменить в ней название функции. Ниже вы найдете все функции,
которые можно использовать в ячейке E106. Вы можете скопировать и вставить
их или попытаться ввести их самостоятельно, чтобы лучше запомнить.

СУММЕСЛИ =СУММЕСЛИ(C92:C103;C106;E92:E103)
СУММЕСЛИМН =СУММЕСЛИМН(E92:E103;C92:C103;C106;D92:D103;D106)
СРЗНАЧЕСЛИ =СРЗНАЧЕСЛИ(C92:C103;C106;E92:E103)
СРЗНАЧЕСЛИМН =СРЗНАЧЕСЛИМН(E92:E103;C92:C103;C106;D92:D92;D106)
СЧЁТЕСЛИ =СЧЁТЕСЛИ(C92:C103;C106)
Наименование Количество
СЧЁТЕСЛИМН =СЧЁТЕСЛИМН(C92:C103;C106;D92:D103;D106)
Хлеб 50
МАКСЕСЛИМН =МАКСЕСЛИМН(E92:E103;C92:C103;C106;D92:D103;D106)
Пончики 100
МИНЕСЛИМН =МИНЕСЛИМН(E92:E103;C92:C103;C106;D92:D103;D106)
Печенье 40
Торты 50
Пироги 20
100
Подробнее Далее

Функция СУММЕСЛИ с аргументом


значения
Функция СУММЕСЛИ с аргументом
значения
Вот пример использования функции СУММЕСЛИ с оператором «больше» (>) для
поиска всех значений, превышающих указанное:

Сложить Просмотреть Если значение


значения с эти ячейки: больше 50,
учетом этого добавить его
условия:   в сумму.
 

=СУММЕСЛИ(D118:D122;">50")

ПРИМЕЧАНИЕ. Если вы часто применяете условные формулы, возможно, стоит


воспользоваться сводной таблицей. Дополнительные сведения см. в статье о
сводных таблицах.

Дополнительные сведения в Интернете


Все о функции СУММЕСЛИ Все о функции СУММЕСЛИМН

Все о функции СЧЁТЕСЛИ Все о функции СЧЁТЕСЛИМН

Все о функции СРЗНАЧЕСЛИ Все о функции СРЗНАЧЕСЛИМН

Все о функции МИНЕСЛИМН Все о функции МАКСЕСЛИМН


Все о функции МИНЕСЛИМН Все о функции МАКСЕСЛИМН

Создание раскрывающегося Бесплатные учебные веб-курсы


списка по Excel

В начало страницы Следующий шаг


Фрукт Сорт Количество
Яблоки Fuji 50
Апельсины Florida 20
Бананы Cavendish 60
Лимоны Rough 40
Яблоки Honeycrisp 50
Апельсины Navel 20
Бананы Lady Finger 60
Лимоны Eureka 40
Яблоки Honeycrisp 50
Апельсины Navel 20
Бананы Cavendish 60
Лимоны Eureka 40

Фрукт Сорт СУММЕСЛИМН


Апельсины Florida

кций ЕСЛИ и ЕСЛИМН тем, что у них есть только условия и диапазон, в котором
СОВЕТони проверяются. Они не суммируют значения в одном диапазоне после проверки значений в друг
ЭКСПЕРТА
В ячейках «Фрукт» и «Сорт» есть
раскрывающееся списки, в которых
можно выбрать различные фрукты.
Попробуйте сделать это и обратите
внимание на то, как формулы
автоматически обновляются.
сведения см. в статье о сводных таблицах.

Фрукт Сорт Количество


Яблоки Fuji 50
Апельсины Florida 20
Бананы Cavendish 60
Лимоны Rough 40
Яблоки Honeycrisp 50
Апельсины Navel 20
Бананы Lady Finger 60
Лимоны Eureka 40
Яблоки Honeycrisp 50
Апельсины Navel 20
Бананы Cavendish 60
Лимоны Eureka 40
Фрукт Сорт СЧЁТЕСЛИМН
Апельсины Florida 1

Количество
50
20
60
40
50
20
60
40
50
20
60
40

Попробуйте сами
80
е проверки значений в другом.
ПОЛЕЗНЫЕ СВЕДЕНИЯ
Дважды щелкните эту ячейку. Вы увидите, что
формула изменилась. В частности, условие суммы
имеет вид «>=50», то есть больше или равно 50.
Можно использовать другие операторы, например
«<=50», то есть меньше или равно 50. Также есть
оператор «<> 50», что значит «не равно 50».
«Найти».
каждого
Когда функция
аргумента
ВПР будет
указываются в
выделена,
нижней части
нажмите
формы. Когда
кнопку «ОК»
вы закончите
внизу.
ПОЛЕЗНЫЕ
работу, Когда
вы выбираете
СВЕДЕНИЯ
нажмите
функцию
клавишу
При вводе в
«ОК»,
ПОПРОБУЙТЕ
Используйте мастер функций
списке,
и
каждого
Excel Excel
Если
САМИ! вывведет
Используйте
отображает
мастер функций
знаете
ее имя функции, но не помните, как ее вводить, воспользуйтесь мастером функций.
формулу.
аргумента
Вы должны его
синтаксис.
описание
получить
выводится
формулу в
нижней Если вы знаете имя функции, но не помните, как ее вводить, воспользуйтесь
части
=ВПР(C10;C5:D Фрукт Количество
формы
8;2;ЛОЖЬ).
ПОЛЕЗНЫЕ мастером функций.
(над Яблоки 50
результатомСВЕДЕНИЯ
Вы
формулы). ввести ссылки на ячейки и диапазоны или выбрать их с помощью мыши.
можете Апельсины 20
1 Выделите ячейку D10, выберите Формулы > Вставить функцию, введите Бананы 60
Назад ВПР в поле Поиск функции и нажмите кнопку Найти. Когда функция Лимоны 40
Далее ВПР будет выделена, нажмите кнопку ОК внизу. Когда вы выбираете
функциюввИнтернете
Дополнительные сведения списке, Excel отображает ее синтаксис. Яблоки 50
Полные сведения о формулах в Excel
2 (поЗатем
Функции Excel вы можете ввести аргументы функции в соответствующие
категориям)
Функции Excel (потекстовые
алфавиту) поля. При вводе каждого аргумента Excel обработает его и ПОПРОБУЙТЕ САМИ!
покажет
Бесплатные учебные результат.
веб-курсы по ExcelВнизу окна выводится окончательный результат. Вы должны получить формулу
=ВПР(C10;C5:D8;2;ЛОЖЬ).
Когда вы закончите работу, нажмите клавишу ОК, и Excel введет
формулу.

ПОЛЕЗНЫЕ СВЕДЕНИЯ
Вы можете ввести ссылки на ячейки и диапазоны
или выбрать их с помощью мыши.

ПОЛЕЗНЫЕ СВЕДЕНИЯ
При вводе каждого аргумента его описание выводится
нижней части формы (над результатом формулы).
ПОЛЕЗНЫЕ СВЕДЕНИЯ
При вводе каждого аргумента его описание выводится
нижней части формы (над результатом формулы).

Назад Далее

Дополнительные сведения в Интернете


Полные сведения о формулах в Excel

Функции Excel (по категориям)

Функции Excel (по алфавиту)

Бесплатные учебные веб-курсы по Excel


ЙТЕ САМИ!
олучить формулу
D8;2;ЛОЖЬ).

Я
ячейки и диапазоны
мыши.

его описание выводится в


ультатом формулы).
его описание выводится в
ультатом формулы).
ПОЛЕЗНЫЕ
СВЕДЕНИЯ
Нажав
Рано илиИсправление ошибок в формулах
кнопку
Исправление ошибок
поздно
«Параметры»,
в формулахформула с ошибкой, которую Excel обозначает сообщением #ОШИБКА! Ошибки могут быть полезны, так как они указывают на то, что ч
вам встретится
Проверка
можно ошибок: выберите «Формулы» > «Проверка ошибок». Откроется диалоговое окно, в котором указана общая причина ошибки. Ошибка #Н/Д в ячейке D9 вызв
задать
Если нажать кнопку «Справка по этой ошибке», откроется раздел справки, посвященный сообщению об ошибке. Фрукт
правила Количество
Если щелкнуть «Показать этапы вычисления», появится
Рано
отображения или поздно вам встретится формула с ошибкой, которую Excel обозначает Яблоки 50вы сможете понять, где о
При каждом нажатии кнопки «Вычислить» Excel будет обрабатывать одну часть формулы. Даже если Excel не укажет напрямую, в чем ошибка,
или сообщением
ЭКСПЕРИМЕНТ #ОШИБКА! Ошибки могут быть полезны, так как они указывают на Апельсины 20
игнорировани
В чем тут
я ошибок. то, что что-то
проблема? не работает,
Подсказка. Мы но иногда
пытаемся их сложно
вычислить исправить.
СУММУ всех К счастью,
чисел. существует Бананы 60
несколько решений, которые помогут вам определить причину ошибки и Лимоны 40
Назад исправить ее.
Далее Яблоко #N/A
Дополнительные1 сведения
Проверка ошибок: выберите Формулы > Проверка ошибок.
в Интернете
Откроется диалоговое окно, в котором указана общая причина
Поиск ошибок в формулах
ошибки. Ошибка #Н/Д в ячейке D9 вызвана отсутствием значения
Рекомендации, позволяющие избежать появления неработающих формул
«Яблоко». Вы можете исправить ошибку, указав существующее
Вычисление вложенной формулы по шагам
значение, скрыть ее, используя функцию ЕСЛИОШИБКА, или
Бесплатные учебные веб-курсы по Excel
проигнорировать ошибку, так как она исчезнет, когда вы введете
допустимое значение.

ПОЛЕЗНЫЕ СВЕДЕНИЯ
Нажав кнопку Параметры, можно задать правил
2 Если нажать кнопку Справка по этой ошибке, откроется раздел отображения или игнорирования ошибок.
справки, посвященный сообщению об ошибке. Если щелкнуть
Показать этапы вычисления, появится диалоговое окно вычисление Фрукт Количество
формулы.
Если нажать кнопку Справка по этой ошибке, откроется раздел
справки, посвященный сообщению об ошибке. Если щелкнуть
Показать этапы вычисления, появится диалоговое окно вычисление
формулы. Яблоки 50
Апельсины 20
Бананы 60
Лимоны 40

Итого #NAME?

ЭКСПЕРИМЕНТ
В чем тут проблема? Подсказка. Мы
пытаемся вычислить СУММУ всех чи

3 При каждом нажатии кнопки Вычислить Excel будет обрабатывать


одну часть формулы. Даже если Excel не укажет напрямую, в чем
ошибка, вы сможете понять, где она возникла. После этого прочтите
раздел справки, чтобы понять, что не так с формулой.

Назад Далее

Дополнительные сведения в Интернете


Поиск ошибок в формулах

Рекомендации, позволяющие избежать появления неработающих формул

Вычисление вложенной формулы по шагам


Бесплатные учебные веб-курсы по Excel
ни указывают на то, что что-то не работает, но иногда их сложно исправить. К счастью, существует несколько решений, которые помогут вам определить причину ошибки и исправ

ЕНИЯ
ры, можно задать правила
ирования ошибок.
ИМЕНТ
роблема? Подсказка. Мы
ычислить СУММУ всех чисел.
причину ошибки и исправить ее.
Есть еще вопросы об Excel?

Есть еще вопросы об Excel?


Нажмите клавиши ALT+X и введите свой запрос.
Это еще не все. Есть чему поучиться с Excel:
Сообщество: Задавайте вопросы и общайтесь с другими фанатами Excel.
Что нового?Подписчики Office 365 постоянно получают обновления и новые функции.

Нажмите кнопку Помощник и введите запрос.

Это еще не все. Есть чему поучиться с Excel:

Сообщество Что нового?


Задавайте вопросы и Подписчики Office 365
общайтесь с другими постоянно получают
фанатами Excel. обновления и новые функции.

Подробнее (только на английском) Подробнее


Фрукт Сорт Количество
Яблоки Fuji 50
Апельсины Florida 20
Бананы Cavendish 60
Лимоны Rough 40
Яблоки Honeycrisp 50
Апельсины Navel 20
Бананы Lady Finger 60
Лимоны Eureka 40
Яблоки Honeycrisp 50
Апельсины Navel 20
Бананы Cavendish 60
Лимоны Eureka 40