Вы находитесь на странице: 1из 19

01

Active Directory:
интеграция с Mikrotik
Active Directory: интеграция с Mikrotik

Вопросы вебинара
• Удаленный филиал и Active Directory
• DHCP DNS options
• Условная пересылка DNS с использованием
Layer7
• Использование Radius сервера NPS
• Для авторизации PPP клиентов
• Для авторизации Wifi клиентов

Курсы по Mikrotik с гарантией результата 2


Active Directory: интеграция с Mikrotik.

Удаленный филиал и Active Directory

Центральный офис Филиал

VPN

Курсы по Mikrotik с гарантией результата 3


Active Directory: интеграция с Mikrotik.

Удаленный филиал и Active Directory


• Для авторизации рабочих станций удаленного филиала необходимо,
чтобы клиенты могли работать с DNS сервером AD – получать ответы
на запросы о корневой зоне Active Directory
• Есть две возможности организовать подобную схему
взаимодействия:
• Использование записей DNS сервера AD в настройках DHCP
сервера
• Использование сервера условной пересылки DNS запросов

Курсы по Mikrotik с гарантией результата 4


Active Directory: интеграция с Mikrotik.

Использование записей DNS сервера AD в настройках DHCP


сервера

Курсы по Mikrotik с гарантией результата 5


Active Directory: интеграция с Mikrotik

Использование сервера условной пересылки DNS запросов


• Задача детектировать в заголовках пакетов DNS запросов имена доменов
AD
• Это возможно сделать с использованием layer7 protocol
• Далее ставим метку соединения (connection mark)
• И на основании этой метки соединения – пересылаем запросы на
удаленный DNS сервер

Курсы по Mikrotik с гарантией результата 6


Active Directory: интеграция с Mikrotik.

Использование сервера условной пересылки DNS запросов


• /ip firewall layer7-protocol add name=corp.local regexp=corp.local
• /ip firewall mangle add action=mark-connection chain=prerouting dst-
address=192.168.7.1 dst-port=53 layer7-protocol=corp.local new-connection-
mark=corp.local passthrough=yes protocol=udp
• /ip firewall mangle add action=mark-connection chain=prerouting dst-
address=192.168.7.1 dst-port=53 layer7-protocol=corp.local new-connection-
mark=corp.local passthrough=yes protocol=tcp
• /ip firewall nat add action=dst-nat chain=dstnat comment=ST connection-
mark=corp.local to-addresses=192.168.78.242

Курсы по Mikrotik с гарантией результата 7


Active Directory: интеграция с Mikrotik.

Использование Radius сервера NPS

• Т.к. различные сетевые устройства не поддерживают LDAP, NTLM, Kerberos


авторизацию – используют различные RADIUS серверы
• RADIUS — протокол для реализации аутентификации, авторизации и сбора
сведений об использованных ресурсах, разработанный для передачи
сведений между центральной платформой и оборудованием.
• Для использования учетных данных Active Dirtectory используется сервер
NAP – отдельная служба radius сервера, которая входит в поставку
Windows Server

Курсы по Mikrotik с гарантией результата 8


Active Directory: интеграция с Mikrotik.

Общие настройки NPS


• Регистрация NPS в Active Directory – для взаимодействия с группами и
пользователями AD
• Использование только необходимых на портов для доступа к NPS

Курсы по Mikrotik с гарантией результата 9


Active Directory: интеграция с Mikrotik

Добавление клиента NPS

Курсы по Mikrotik с гарантией результата 10


Active Directory: интеграция с Mikrotik

Добавление сетевой политики NPS для PPP клиентов

Курсы по Mikrotik с гарантией результата 11


Active Directory: интеграция с Mikrotik

Добавление сетевой политики NPS для PPP клиентов

Курсы по Mikrotik с гарантией результата 12


Active Directory: интеграция с Mikrotik

Настройка MikroTik для авторизации PPP клиентов на NPS

Курсы по Mikrotik с гарантией результата 13


Active Directory: интеграция с Mikrotik

Добавление сетевой политики NPS для WiFi клиентов

Курсы по Mikrotik с гарантией результата 14


Active Directory: интеграция с Mikrotik.

Добавление сетевой политики NPS для WiFi клиентов

Курсы по Mikrotik с гарантией результата 15


Active Directory: интеграция с Mikrotik

Добавление сетевой политики NPS для WiFi клиентов

Курсы по Mikrotik с гарантией результата 16


Active Directory: интеграция с Mikrotik

Настройка MikroTik для авторизации WIFi клиентов на NPS

Курсы по Mikrotik с гарантией результата 17


Active Directory: интеграция с Mikrotik

Поиск проблем

Курсы по Mikrotik с гарантией результата 18


СПАСИБО ЗА ВНИМАНИЕ
Приходите на наши курсы по
Mikrotik и Asterisk
MTCNA дневной
11 декабря по 14 декабря

Вам также может понравиться