Вы находитесь на странице: 1из 5

Devoir n1

Lalgorithme doit demander lutilisateur une srie de trois nombres strictement compris entre les bornes de 100 et 1000. Il doit ensuite retourner le plus grand et le plus petit de ces 3 nombres. Cet Algorithme boucle enfin sur la sais dune autre srie de trois nombres, et effectue le mme traitement. Il ne sarrte que lorsque ces trois nombres sont gaux. Saisir le 1er nombre 125 Saisir le 2nd nombre 135 Saisir le 3ime nombre 7 Refus car infrieur 100 Saisir le 3ime nombre 654 Le plus grand est 654 Le plus petit est 125 Saisir le 1er nombre 825 Saisir le 2nd nombre 656 Saisir le 3ime nombre540 Le plus grand est 825 Le plus petit est 540 Saisir le 1er nombre 752 Saisir le 2nd nombre 752 Saisir le 3ime nombre 752 Trois nombre identiques, cest la fin de lalgorithme.

Bloc dclaration des variables Nbr1, nbr2, nbr3, plusgd, pluspetit de type rel

Bloc saisi 125 Ecrire veuillez saisir une valeur pour nbr1 Lire x1 Nbr1 <- x1 TantQue nbr1<100 ou nbr1>1000 Si nbr1 < 100 Alors Ecrire valeur saisie incorrect, veuillez saisir une valeur plus grande SinonSi nbr1 > 1000 Alors Ecrire valeur saisie incorrect, veuillez saisir une valeur plus petite FinTantQue Ecrire veuillez saisir une valeur pour nbr2 Lire x2 Nbr2 <- x2 TantQue nbr2<100 ou nbr2>1000 Si nbr2 < 100 Alors Ecrire valeur saisie incorrect, veuillez saisir une valeur plus grande SinonSi nbr2 > 1000 Alors Ecrire valeur saisie incorrect, veuillez saisir une valeur plus petite FinTantQue

Dtermination de la condition: nbr compris entre les borne 100 et 1000

Saisi du nombre 2

Dtermination de la condition: nbr compris entre les borne 100 et 1000

Saisi du nombre 3

Dtermination de la condition: nbr compris entre les borne 100 et 1000

Ecrire veuillez saisir une valeur pour nbr3 Lire x3 Nbr3 <- x3 TantQue nbr3<100 ou nbr3>1000 Si nbr3 < 100 Alors Ecrire valeur saisie incorrect, veuillez saisir une valeur plus grande SinonSi nbr3 > 1000 Alors Ecrire valeur saisie incorrect, veuillez saisir une valeur plus petite FinTantQue

Bloc traitement TantQue nbr1<>nbr2 <>nbr3 plusgrd <- nbr1 Si nbr2 > nbr1 Alors plusgrd <- nbr2 FinSi Si nbr3 > nbr1 Alors Plusgrd <- nbr3 FinSi Pluspetit <- nbr1

Dtermination de la variable plusgrd

Dtermination de la

variable pluspetit

Si nbr2 < nbr1 Alors pluspetit <-Nbr2 FinSi Si nbr3 < nbr1 Alors Pluspetit <- nbr3 FinSi Ecrire ""le plus petit des 3 nombre saisi est",pluspetit, "le plus plus grand des 3 nombres saisi est', plusgrd Ecrire veuillez saisir une valeur pour nbr1 Lire x1 Nbr1 <- x1 TantQue nbr1<100 ou nbr1>1000 Si nbr1 < 100 Alors Ecrire valeur saisie incorrect, veuillez saisir une valeur plus grande SinonSi nbr1 > 1000 Alors Ecrire valeur saisie incorrect, veuillez saisir une valeur plus petite FinTantQue Ecrire veuillez saisir une valeur pour nbr2 Lire x2 Nbr2 <- x2 TantQue nbr2<100 ou nbr2>1000 Si nbr2 < 100 Alors Ecrire valeur saisie incorrect, veuillez saisir une valeur plus grande SinonSi nbr2 > 1000 Alors Ecrire valeur saisie incorrect, veuillez saisir une valeur plus petite FinTantQue Ecrire veuillez saisir une valeur pour nbr3 Lire x3

Saisi du nombre 1

Dtermination de la condition: nbr compris entre les borne 100 et 1000

Saisi du nombre 2

Dtermination de la condition: nbr compris entre les borne 100 et 1000

Saisi du nombre 3

Dtermination de la condition: nbr compris entre les borne 100 et 1000

Nbr3 <- x3 TantQue nbr3<100 ou nbr3>1000 Si nbr3 < 100 Alors Ecrire valeur saisie incorrect, veuillez saisir une valeur plus grande SinonSi nbr3 > 1000 Alors Ecrire valeur saisie incorrect, veuillez saisir une valeur plus petite FinTantQue FinTantQue