You are on page 1of 13

Cd.

Jurez, Chihuahua A 14 de Marzo de 2011

Centro de Bachillerato
Tecnolgico
industrial y
de servicios no. 114

Principios de
Programacin
Portafolio de Evidencias

Profesor: Roberto Mreles Corpus


Alumno: Omar Helem Garca Palomares
ndice
Practica 1

Definicin del
Problema..
Anlisis (E-P-S)
..........................................................................
Pseudocdigo....................................................
..................

Practica 2

Definicin del
Problema..
Anlisis (E-P-S)
..........................................................................
Pseudocdigo....................................................
..................

Practica 3

Definicin del
Problema..
Anlisis (E-P-S)
..........................................................................
Pseudocdigo....................................................
..................

Practica 4

Definicin del
Problema..
Anlisis (E-P-S)
..........................................................................
Pseudocdigo....................................................
..................

Practica 5

Definicin del
Problema..
Anlisis (E-P-S)
..........................................................................
Pseudocdigo....................................................
..................

Practica 6

Definicin del
Problema..
Anlisis (E-P-S)
..........................................................................
Pseudocdigo....................................................
..................

Practica 7

Definicin del
Problema..
Anlisis (E-P-S)
..........................................................................
2

Pseudocdigo....................................................
..................

Practica 8

Definicin del
Problema..
Anlisis (E-P-S)
..........................................................................
Pseudocdigo....................................................
..................

Practica 9

Definicin del
Problema..
Anlisis (E-P-S)
..........................................................................
Pseudocdigo....................................................
..................

Practica 10

Definicin del
Problema..
Anlisis (E-P-S)
..........................................................................
Pseudocdigo....................................................
..................

Definicin:

Practica 1

Se desea desarrollar una solucin para que conociendo los datos


necesarios para el calculo, del volumen de un cilindro, se pida al usuario que ingrese
dichos datos que se de cmo resultado el volumen del cilindro y adems el numero
de litros de liquido que cabran.

Anlisis de la solucin:
Como entrada se le piden los datos al usuario y en este caso serian los siguientes
datos:
o Valor de : 3.1416.
o Valor de la altura del cilindro.
o Valor del radio de la base del cilindro.
En proceso se harn las siguientes formulas:
o ( *r2)(h)
o Resultado*.01
Se mostraran los siguientes datos de Salida:
o Resultado en cm.
o Resultado en litros.
3

Diseo de la solucin:
Proceso Practica1
//Ingresar los datos
Escribir "Ingrese el radio de la base en CM";
Leer r;
Escribir "Ingrese la altura del cilindro en CM";
Leer h;
//Calcular el volumen del circulo
a<-3.1416*r*r;
v<-a*h;
l<-v/1000;
//Mostrar resultado
Escribir "El volumen en cm3 es ", v;
Escribir "El volumen en litros es ", l;
FinProceso

Practica 2
Definicin:

Elaborar un programa en pseudocdigo que tome como entrada una


cantidad monetaria (numrica), enseguida solicitar al usuario que indique si dicha
cantidad son pesos o dlares. Se deber calcular la conversin a la moneda
complementaria considerando el tipo de cambio constante a 12.25 pesos cada dlar.

Anlisis de la solucin:
Entrada:

o Cantidad monetaria.
o Indicador de pesos/dlares.

Proceso:

De ser pesos la cantidad monetaria se dividir entre 12.25, de ser dlares la cantidad
se multiplicara por 12.25; las operaciones para lo siguiente, dependiendo del caso,
sern:
o Cantidad/12.25
o Cantidad*12.25

Salida:

Escribir el resultado de la conversin para presentarlo al usuario.

Diseo de la solucin:
Proceso Practica2
//Ingresar datos
Escribir "Ingrese la Cantidad a convertir";
4

Leer C;
Escribir "Ingrese si son Pesos P o Dlares D";
Leer pd;
//Calcular
Si pd="P" Entonces
r<-C*12.25;
Sino
r<-C/12.25;
FinSi
//Mostrar resultado
Escribir "El resultado es:", r;
FinProceso

Definicin:

Practica 3

Elaborar un programa en pseudocdigo que pida al usuario que


ingrese dos valores numricos, se deben calcular las 4 operaciones aritmticas
bsicas con dichos valores, es decir suma, resta, multiplicacin y divisin. En el caso
de la divisin verificar que la variable que funge como divisor sea diferente de 0, en
tal caso mostrar un mensaje que informe al usuario que la operacin no se puede
realizar.

Anlisis de la solucin:
Entrada:
o Se tendrn que ingresar dos nmeros.
o Identificar cada uno en una variable.

Proceso:
o
o
o
o

En suma realizar la suma de ambos valores.


En resta realizar la resta de ambos valores.
En multiplicacin realizar el resultado de esta.
En divisin, si el valor es 0 entonces mostrar un mensaje de error. En caso de
ser diferente a 0 entonces realizar la divisin de ambos valores.

Salida:

Proceso Practica3
//Ingresar datos
Escribir "Ingrese un nmero";
Leer a;
Escribir "Ingrese un segundo nmero";
Leer b;
//Proceso
s<-a+b;
r<-a-b;
m<-a*b;
//Divisin
Si b=0 Entonces
5

Escribir "Error";
d<- -1;
Sino
d<-a/b;
FinSi
d<-a/b;
//Mostrar resultado
Escribir "Resultado es:";
Escribir "La suma es:", s;
Escribir "La resta es:", r;
Escribir "La multiplicacin es:", m;
Escribir "La divisin:", d;
FinProceso

Practica 4
Definicin:

Elaborar un programa en pseudocdigo que pida al usuario ingrese 3


calificaciones y sus respectivas ponderaciones, las cuales deben sumar 100%, se
deber calcular el promedio ponderado, el promedio normal, es decir, sin ponderacin
y adems se deber elegir el mayor de estos para asignarlo al promedio final . Se
debern mostrar los siguientes datos: nombre del alumno, nombre de la materia,
calificacin 1, 2, 3; promedio final y un mensaje de aprobado o reprobado Segn
sea el caso considerando 7 como mnimo aprobatorio.

Anlisis de la solucin:
Entrada:
Se debern ingresar los siguientes datos:
o Nombre del Alumno
o Nombre de la Materia
o 1era Calificacin
o 2da Calificacin
o 3ra Calificacin
o 1ra Ponderacin
o 2da Ponderacin
o 3ra Ponderacin

Proceso:
o
o
o
o

Calcular Promedio Ponderado


Calcular Promedio Normal
Definir el Promedio Final, de acuerdo al mayor de PP y PN.
Definir si el alumno ha aprobado; si el promedio final es mayor a 7 est
aprobado de lo contrario el alumno ha sido reprobado

Salida:
Proceso Practica4
//Ingresar datos
Escribir "Ingresa
Leer alumno;
Escribir "Ingresa
Leer materia;
Escribir "Ingresa
Leer c1;
Escribir "Ingresa

Nombre del Alumno";


Nombre de la Materia";
la primera calificacin";
la segunda calificacin";
6

Leer c2;
Escribir "Ingresa
Leer c3;
Escribir "Ingresa
Leer p1;
Escribir "Ingresa
Leer p2;
Escribir "Ingresa
Leer p3;

la tercera calificacin";
1era ponderacin";
2da ponderacin";
3era ponderacin";

//Proceso
pp1<-p1*0.1;
pp2<-p2*0.1;
pp3<-p3*0.1;
pp<-(c1*pp1+c2*pp2+c3*pp3)*0.1;
pn<-(c1+c2+c3)/3;
//Definir promedio final
Si pp<pn Entonces
pf<-pn;
Sino
pf<-pp;
FinSi
//Mostrar resultado
Escribir "Nombre del Alumno: ", alumno;
Escribir "Nombre de la Materia: ", materia;
Escribir "Primera Calificacin: ", c1;
Escribir "Segunda Calificacin: ", c2;
Escribir "Tercera Calificacin: ", c3;
Escribir "El promedio final es: ", pf;
//Aprobado o reprobado
Si pf<7 Entonces
Escribir "Reprobado";
Sino
Escribir "El alumno ha sido aprobado";
FinSi
FinProceso

Definicin:

Definicin:

Practica 5

Practica 6
8

Definicin:

Practica 7

Practica 8
Definicin:

10

Definicin:

Practica 9

11

Practica 10
Definicin:

12

Definicin:

Practica 11

13