Вы находитесь на странице: 1из 35

Command Line Interface

Configuration Access
Web/SNMP
(Fabric Manager)
Out-of-band
Ethernet Port

Fibre Channel
Fabric

IP
Network

Telnet/SSH

FC Port

Direct
Console Port

VT100

In-band
(IP over FC)

Getting Help in CLI


? is the key to everything

Shows valid ranges, keywords, etc.

MDS-3# show vsan ?


<1-4094>

VSAN id range

Membership

Show membership information

Usage

Show vsan usage in the system

<cr>

Carriage return

MDS-3(config-vsan-db)# vsan ?
<1-4094>

VSAN id range

Getting Help in CLI and Tab Usage


Tab character Use to complete a command
MDS-3(config-vsan-db)# vsan 1 ?
interface

Add Interface to vsan

interop

Turn on interoperability mode

loadbalancing

Configure loadbalancing scheme

name

Assign a name to vsan

suspend

Suspend vsan

<cr>

Carriage Return

MDS-3(config-vsan-db)# vsan 1 l(Press <TAB>)


!(becomes)
MDS-3(config-vsan-db)# vsan 1 load-balancing

Other Convenient Features


MDS-3#

show running-config

Display the current configuration information


MDS-3#

copy running-config startup-config

Save the current running configuration to stable


storage for use when the switch is rebooted

Other Convenient Features (Cont.)

MDS-3-config#

end

Exit any configuration mode; return to EXEC mode


MDS-3(config)#

exit

Go up one layer in the menu


Use the up arrow and down arrow keys to traverse the
command history.

Role-Based Access Control


Can set up different roles with different rules for each role.
Two pre-defined roles:
network-operator Cannot configure the MDS; has access only
to the show commands along with file system commands (dir,
copy, etc.) and basic network utilities (ping, etc.)
network-admin Has access to all the CLI commands and can
setup 64 permission levels based on user roles and groups

Role-Based: Configuration items


There are 3 configuration items:
1. Role Name
MDS-3# config terminal
MDS-3(config)# role name role2
MDS-3(config-role)#

2. Description
MDS-3(config-role)# description non-admin group

3. Rule
MDS-3(config-role)# rule 1 permit debug
MDS-3(config-role)# rule 2 permit clear
MDS-3(config-role)# rule 3 permit show feature interface

Creating Users
Users configuration attributes
username
password
password expiration
role assigned

MDS-3(config)# username user1 password cisco expire 2002-12-25 role no-configuration


MDS-3(config)# username user2 password cisco role interface-config

Fibre Channel Interfaces

Fiber Channel Interfaces Overview

Host
Private Loop
F port

ISL

E port

TL port

E port

TE port

FL port
Public Loop

Port Channel
EISL

TE port
Disk Array

SD port

Interface Modes in MDS Family Switches

FC Analyzer

FC Interfaces Trunk Modes


Trunk Mode configuration:
1

EISL (for TE) or ISL (for E)

Administrative
Trunk Mode (1)

Administrative
Trunk Mode (2)

Operational Port
Mode

Auto

Auto

E port

On

On or Auto

TE port

Off

Off

E port

FC Interfaces Name and Beacon


Interface WWN:
Each interface is assigned a unique WWN
Interface FCID:
In operational Up state, each interface is assigned an FCID
In F mode, it is the FCID assigned to the attached N-port
In FL mode, it is the Loop Fabric Address (LFA) of the port
Interface Beacon:
If enabled, the Port LED keeps blinking
Does not affect operation of the interface

Interface Management Infrastructure

Interface Management Services

Port Manager

FLOGI Manager

TL Port Manager

SPAN Manager

Port Channel Manager

VSAN Interface Manager

Basic Fibre Channel Interface Configuration

FLOGI Enhancement: FC-ID Inter-Op Mode

1.

FC-ID consists of domain-area-port. Today, most switch vendors


assign one complete area to an N port attached to an F port, thus
limiting the maximum number of ports in the switch to be 255.

2.

FLOGI Manager intelligently assigns single FC-ID to an N-port


attached to an F port in the switch:

It provides a command to disable this feature, if required.

MDS-3(config)# no fcinterop fcid-allocation (No,Flat,Auto)

FLOGI Manager CLI

To display the FLOGI Database:

MDS-3# show flogi database ?


fcid

Fcid: enter the fcid to be matched

interface Interface id: enter the interface id of the port


vsan

Vsan id:Enter the vsan number.

<cr>

Carriage Return

MDS-3# show flogi database vsan 1


--------------------------------------------------------------------------INTERFACE

VSAN

FCID

PORT NAME

NODE NAME

--------------------------------------------------------------------------fc2/7

0x7a0100

21:00:00:e0:8b:08:20:21

20:00:00:e0:8b:08:20:21

fc2/11

0x7a0000

21:00:00:e0:8b:07:ca:39

20:00:00:e0:8b:07:ca:39

fc2/14

0x7a0200

50:06:04:82:c3:a0:98:53

50:06:04:82:c3:a0:98:53

fc8/11

0x7a0201

50:06:04:82:c3:a0:98:43

50:06:04:82:c3:a0:98:43

fc8/31

0x7a0202

50:06:04:82:c3:a0:98:42

50:06:04:82:c3:a0:98:42

Advanced Interface Configurations


Important: The following configurations should be done with extreme
care. For most cases the default values should work fine

Configuration of BB-Credit and Max Receive Buffer Size:


These values may be modified for each interface.
Such configuration may be needed for specific network designs to optimize
bandwidth utilization or interoperate with existing fabric.

Configuration of FC Timers:
Values for E_D_TOV, R_A_TOV used in ELP and FLOGI may be modified on a
global basis (must be the same on all switches).
Any modification does not affect the active ports (in Up state) and the changes
take effect only for subsequent logins (ELP or FLOGI).

Make such configurations before connecting to existing fabric

Interface Default Settings


Parameter

Default

Interface Administrative State

Shutdown

Interface mode

Auto

Interface speed

Auto

Trunk Allowed VSANs

1-4093

Switchport Trunk mode

Enabled (On)

Beacon mode

Disabled (Off)

Fibre Channel received buffer-to-buffer credit

16 (Hardware Default)
12 on 32 port card

Fibre Channel receive buffer size

2112

Interface States
Each Interface has an associated
administrative and operational state.
Administrative State

Description

UP

No shut command to enable the interface

Down

Shut command to disable interface

Operational State

Description

UP

Interface is transmitting and receiving traffic as


desired: Administratively UP; Link Layer state is UP
and interface initialization must be completed

Down

Cannot transmit or receive data

Interface FC Switchport Configuration Summary

MDS-3# config t
MDS-3(config)# interface fc2/1
MDS-3(config-if)# switchport ?
beacon
Disable/enable the beacon for an interface
description
Enter description of maximum 80 characters
encap
Configure encapsulation for the port
fcrxbbcredit Configure receive BB_credit for the port
fcrxbufsize
Configure receive buffer size for the port
mode
Enter the port mode
speed
Enter the port speed
trunk
Configure trunking parameters on an interface

Interface Mode Configuring

MDS-3(config-if)# switchport mode ?


auto Autosense mode
E
E port mode
F
F port mode
FL
FL port mode
Fx
Fx port mode
SD
SD port mode
TL
TL port mode
MDS-3(config-if)# switchport mode e
MDS-3(config-if)# switchport mode sd

Interface Description Speed, BBcredits and


Rxbuffers
MDS-3(config-if)# switchport description sample-configuration
MDS-3(config-if)#
1000 1000 Mbps
2000 2000 Mbps
auto Autosense

switchport speed ?
speed
speed
speed

MDS-3(config-if)# switchport speed 1000


MDS-3(config-if)# switchport fcrxbbcredit ?
<1-255> Enter receive BB_credit
default Default receive BB_credit
MDS-3(config-if)# switchport fcrxbbcredit 16
MDS-3(config-if)# switchport fcrxbufsize ?
<256-2112> Enter receive buffer size
MDS-3(config-if)# switchport fcrxbufsize 2112

Interface Trunking Mode and Allowed VSAN


MDS-3(config-if)# switchport trunk ?
allowed Configure allowed list for interface(s)
mode
Configure trunking mode
MDS-3(config-if)# switchport trunk allowed ?
vsan
Configure allowed list for interface(s)
MDS-3(config-if)# switchport trunk allowed vsan 1
updated trunking membership
MDS-3(config-if)# switchport trunk mode ?
auto
Autosense trunking for an interface
off
Disable trunking for an interface
on
Enable trunking for an interface
MDS-3(config-if)# switchport trunk mode on

Encapsulation, Enabling Interfaces and Beacon

MDS-3(config-if)# switchport encap ?


eisl
EISL encapsulation
MDS-3(config-if)# switchport encap eisl
MDS-3(config-if)# shutdown
MDS-3(config-if)# no shutdown
MDS-3(config-if)# switchport beacon
MDS-3(config-if)# no switchport beacon
MDS-3(config-if)#

show interface Command

Counter Values (current):


MDS-4# show interface fc1/1
fc1/1 is trunking
40 frames input, 3284 bytes, 0 discards
Hardware is Fibre Channel
0 runts, 0 jabber, 0 too long, 0 too short
0 input errors, 0 CRC, 0 invalid transmission words
Port WWN is 20:01:00:05:30:00:50:1e
Peer port WWN is
0 address id, 0 delimiter
20:41:00:05:30:00:23:de
0 EOF abort, 0 fragmented, 0 unknown class
Admin port mode is E, trunk mode is on
40 frames output, 2544 bytes, 0 discards
Received 1 OLS, 1 LRR, 1 NOS, 0 loop inits
Port mode is TE
Speed is 1 Gbps
Transmitted 2 OLS, 1 LRR, 1 NOS, 0 loop inits
vsan is 1
Counter Values (5 minute averages):
0 frames input, 95 bytes, 0 discards
Beacon is turned off
FCID is 0x000000
0 runts, 0 jabber, 0 too long, 0 too short
Receive B2B Credit is 12
0 input errors, 0 CRC, 0 invalid transmission words
Trunk vsans (allowed active) (1)
0 address id, 0 delimiter
0 EOF abort, 0 fragmented, 0 unknown class
Trunk vsans (operational)
(1)
Trunk vsans (up)
(1)
0 frames output, 74 bytes, 0 discards
Trunk vsans (isolated)
()
Received 0 OLS, 0 LRR, 0 NOS, 0 loop inits
Transmitted 0 OLS, 0 LRR, 0 NOS, 0 loop inits
Trunk vsans (initializing)
()

Note: MDS-4# show interface command will show all the installed interfaces in
the above format.

show interface status Command


MDS-3# show interface status
fc2/1
fc2/2
fc2/3
fc2/4
fc2/5

is
is
is
is
is

trunking
down (Fcot
down (Fcot
down (Fcot
down (Link

Port mode is TE
not present)
not present)
not present)
failure or not-connected)

fc8/31 is up
Port mode is F
fc8/32 is down (Fcot not present)
sup-fc0 is up
mgmt0 is up

More show interface Commands


MDS-3# show interface transceiver
fc2/1 fcot is present
name is IBM
part number is IBM42P21SNY
revision is AA20
serial number is 53P1487000ZPW
vendor specific data (bytes 96-127)
0x49 0x42 0x4D 0x20 0x53 0x46 0x50
0x20 0x41 0x52 0x45 0x20 0x43 0x4C
0x53 0x53 0x20 0x31 0x20 0x4C 0x41
0x45 0x52 0x20 0x53 0x41 0x46 0x45
fc2/2 fcot not present

0x53
0x41
0x53
0x20

Some more show interface commands:


MDS-3# show interface ?
brief
Show brief info of interface
counters
Show counters of interface
status
Show operational state of interface

Example: Configuring an F-Port


The interface fc2/2 is enabled in VSAN 2, mode F,
speed 2GB/s :
1 MDS-3# config t
2 MDS-3(config)# vsan database
3 MDS-3(config-vsan-db)# vsan 2 interface fc2/2
4 MDS-3(config-vsan-db)# exit
5 MDS-3(config)# interface fc2/2
6 MDS-3(config-if)# switchport mode f
7 MDS-3(config-if)# switchport speed 2000
8 MDS-3(config-if)# no shutdown

Example: Configuring an E-Port


The interface fc2/2 is enabled in VSAN 1, mode E,
speed 2GB/s :
1 MDS-3# config t
2 MDS-3(config)# interface fc2/2
3 MDS-3(config-if)# switchport mode e
4 MDS-3(config-if)# switchport speed 2000
5 MDS-3(config-if)# switchport trunk mode off
6 MDS-3(config-if)# no shutdown

Example: Configuring a TE-Port


The interface fc2/2 is enabled in VSAN 2, mode
trunking-E, speed 2GB/s :
1 MDS-3# config t
2 MDS-3(config)# interface fc2/2
3 MDS-3(config-if)# switchport mode e
4 MDS-3(config-if)# switchport speed 2000
5 MDS-3(config-if)# switchport trunk mode on
6 MDS-3(config-if)# switchport trunk allowed vsan 1
8 updated trunking membership
7 MDS-3(config-if)# no shutdown

FCping and FCtrace

Fibre Channel Ping


Similar to ping in IP networks

Used to verify connectivity

Used to check congestion/latency

MDS-3# fcping fcid 0x6f0002 vsan 1


28 bytes from

0x6f0002

time = 288 usec

28 bytes from

0x6f0002

time = 4803 usec

28 bytes from

0x6f0002

time = 5087 usec

28 bytes from

0x6f0002

time = 4971 usec

28 bytes from

0x6f0002

time = 5124 usec

5 frames sent, 5 frames received, 0 timeouts


Round-trip min/avg/max = 288/4054/5124 usec

Fibre Channel Trace


Trace
Slightly different from Traceroute in IP networks
Checks connectivity using RDL
Can be used in fault isolation
Checks both outbound and return paths
switch# fctrace fcid 0x260000
Route present for : 0x260000
20:00:00:05:30:00:017:5e ; (0xfffcc1) Port No: 48
20:00:00:05:30:00:33:de ; (0xfffc83) Port No: 104
20:00:00:05:30:00:35:1e ; (0xfffc26) Port No: 107
20:00:00:05:30:00:35:1e ; (0xfffc26) Port No: 104
20:00:00:05:30:00:33:de ; (0xfffc83) Port No: 112

Latency:
Latency:
Latency:
Latency:

9158 usec
2153 usec
0 usec
2153 usec

Questions?

Вам также может понравиться